Zili Chen created HUDI-834:
------------------------------

             Summary: Concrete signature of 
HoodieRecordPayload#combineAndGetUpdateValue & 
HoodieRecordPayload#getInsertValue
                 Key: HUDI-834
                 URL: https://issues.apache.org/jira/browse/HUDI-834
             Project: Apache Hudi (incubating)
          Issue Type: Improvement
            Reporter: Zili Chen


So far, the return type of {{HoodieRecordPayload#combineAndGetUpdateValue}} & 
{{HoodieRecordPayload#getInsertValue}} is effectively 
{{Option<GenericRecord>}}. Instead of doing unchecked cast at

org/apache/hudi/hadoop/realtime/RealtimeCompactedRecordReader.java:88

I propose we use {{Option<GenericRecord>}} as the return type of these two 
method, which replaces current {{Option<IndexedRecord>}}.

FYI, I encounter this ticket when trying to get rid of self type parameter in  
{{HoodieRecordPayload}} and found that it is a bit awkward if we don't take a 
self type while doing this casting. Fortunately it is the fact that we can 
directly concrete it.

cc [~vinoth] [~leesf]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to