[jira] [Commented] (NETBEANS-519) Bump Eclipse JGit dependency to latest version

2020-05-21 Thread Agly (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17113677#comment-17113677
 ] 

Agly commented on NETBEANS-519:
---

Thanks for working on this!!! It will be good to start using NetBeans again!!

> Bump Eclipse JGit dependency to latest version
> --
>
> Key: NETBEANS-519
> URL: https://issues.apache.org/jira/browse/NETBEANS-519
> Project: NetBeans
>  Issue Type: Improvement
>  Components: versioncontrol - Git
>Affects Versions: 8.2
>Reporter: Christian Bourque
>Assignee: Matthias Bläsing
>Priority: Major
>  Labels: pull-request-available
> Fix For: 11.3
>
>  Time Spent: 9h 50m
>  Remaining Estimate: 0h
>
> The current JGit dependency bundled with NetBeans 8.2 is 3 years old and 
> missing all the newest Git features! This would also be a good time to remove 
> the old JGit Java 7 NetBeans module...
> This would upgrade the current dependency from version 3.6.2 to 4.11.0.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-519) Bump Eclipse JGit dependency to latest version

2019-04-22 Thread Agly (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16823139#comment-16823139
 ] 

Agly commented on NETBEANS-519:
---

JGit is not at version 5.3.0.  It is becoming more difficult to use NetBeans 
due to issues with the older JGit implementation. I tried building from source 
and updating my local version to use JGit 5.3.0.  Everything builds, but the 
OSGI framework can't find some of the new dependencies that 5.3.0 has like 
org.bouncycastle. I added those jars to the "ide/modules" directory, but still 
it can't find them for some reason. I am not familiar with OSGI, so... I have 
no choice but to abandon NetBeans for my current development until JGit is 
updated (or if NETBEANS-2122 ever gets implemented).

> Bump Eclipse JGit dependency to latest version
> --
>
> Key: NETBEANS-519
> URL: https://issues.apache.org/jira/browse/NETBEANS-519
> Project: NetBeans
>  Issue Type: Improvement
>  Components: versioncontrol - Git
>Affects Versions: 8.2
>Reporter: Christian Bourque
>Assignee: Christian Bourque
>Priority: Major
>  Labels: pull-request-available
>  Time Spent: 6h 50m
>  Remaining Estimate: 0h
>
> The current JGit dependency bundled with NetBeans 8.2 is 3 years old and 
> missing all the newest Git features! This would also be a good time to remove 
> the old JGit Java 7 NetBeans module...
> This would upgrade the current dependency from version 3.6.2 to 4.11.0.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Comment Edited] (NETBEANS-519) Bump Eclipse JGit dependency to latest version

2019-04-22 Thread Agly (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16823139#comment-16823139
 ] 

Agly edited comment on NETBEANS-519 at 4/22/19 2:32 PM:


JGit is now at version 5.3.0.  It is becoming more difficult to use NetBeans 
due to issues with the older JGit implementation. I tried building from source 
and updating my local version to use JGit 5.3.0.  Everything builds, but the 
OSGI framework can't find some of the new dependencies that 5.3.0 has like 
org.bouncycastle. I added those jars to the "ide/modules" directory, but still 
it can't find them for some reason. I am not familiar with OSGI, so... I have 
no choice but to abandon NetBeans for my current development until JGit is 
updated (or if NETBEANS-2122 ever gets implemented).


was (Author: agly):
JGit is not at version 5.3.0.  It is becoming more difficult to use NetBeans 
due to issues with the older JGit implementation. I tried building from source 
and updating my local version to use JGit 5.3.0.  Everything builds, but the 
OSGI framework can't find some of the new dependencies that 5.3.0 has like 
org.bouncycastle. I added those jars to the "ide/modules" directory, but still 
it can't find them for some reason. I am not familiar with OSGI, so... I have 
no choice but to abandon NetBeans for my current development until JGit is 
updated (or if NETBEANS-2122 ever gets implemented).

> Bump Eclipse JGit dependency to latest version
> --
>
> Key: NETBEANS-519
> URL: https://issues.apache.org/jira/browse/NETBEANS-519
> Project: NetBeans
>  Issue Type: Improvement
>  Components: versioncontrol - Git
>Affects Versions: 8.2
>Reporter: Christian Bourque
>Assignee: Christian Bourque
>Priority: Major
>  Labels: pull-request-available
>  Time Spent: 6h 50m
>  Remaining Estimate: 0h
>
> The current JGit dependency bundled with NetBeans 8.2 is 3 years old and 
> missing all the newest Git features! This would also be a good time to remove 
> the old JGit Java 7 NetBeans module...
> This would upgrade the current dependency from version 3.6.2 to 4.11.0.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists