[jira] [Updated] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-13 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2397:
-
Description: 
Please check the attached sample.

 

The sample is working with VS Code and IntelliJ Idea.

Also working when doing with "old school" netbeans (ant) projects.

 

Please fix urgently!

 

Some linker problem?

 



Problem is
 * mavenproject1 uses I_Sample
 * mavenproject2 provides I_Sample with SampleImpl
 * mavenproject3 requires mavenproject1 and mavenproject2

 

When you debug or run mavenproject3
 * it will call mavenproject1.Sample.load
 * since mavenproject2 is required, the serviceloader must return the loaded 
SampleImpl instance BUT IT DOES NOT

 

 

  was:
Please check the attached sample.

 

The sample is working with VS Code and IntelliJ Idea.

Also working when doing with "old school" netbeans (ant) projects.

 

Please fix urgently!

 

Some linker problem?


> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-13 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2397:
-
Attachment: vscode_sample.mp4

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-13 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2397:
-
Attachment: netbeans11_sample.mp4

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-13 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16816887#comment-16816887
 ] 

Martin commented on NETBEANS-2397:
--

I attached two short screen records hope those will explain everything, let me 
know if I can do more to help

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-15 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16817612#comment-16817612
 ] 

Martin commented on NETBEANS-2397:
--

The problem is that *the module mechanisms of java modular system are not 
working (when using maven projects)*, in particular the *java KEYWORDS _provide 
with_ are not working*.

The ServiceLoader in mavenproject1 must provide one instance in its iterator - 
the one provided by mavenproject2 with SamplImpl, but it does not, it does 
return 0 instances.

*You can reproduce the problem by either running or debugging mavenproject3 
(there is one main, it does make one call).*

When using the exact same project setup with the exact same files, but using 
classic netbeans ant project, everything runs fine.

So I think it is a good guess to assume that something with the linker is not 
correct.

 

I really do not know how to explain more. The sample project is already nailing 
it down to the very bottom.

 

 

I hope that helps to remove this issue. I have used NB for years and loving it. 
But right now, *I can neither run or debug my code with NB.* That's why I made 
this a "Blocker".

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-11 Thread Martin (JIRA)
Martin created NETBEANS-2397:


 Summary: Java's provide ... with NOT working in maven projects
 Key: NETBEANS-2397
 URL: https://issues.apache.org/jira/browse/NETBEANS-2397
 Project: NetBeans
  Issue Type: Bug
 Environment: Ubuntu 18, Java 12
Reporter: Martin
 Attachments: sample.zip

Please check the attached sample.

 

The sample is working with VS Code and IntelliJ Idea.

 

Please fix urgently!

 

Some linker problem?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-11 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2397:
-
Description: 
Please check the attached sample.

 

The sample is working with VS Code and IntelliJ Idea.

Also working when doing with "old school" netbeans (ant) projects.

 

Please fix urgently!

 

Some linker problem?

  was:
Please check the attached sample.

 

The sample is working with VS Code and IntelliJ Idea.

 

Please fix urgently!

 

Some linker problem?


> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
> Environment: Ubuntu 18, Java 12
>Reporter: Martin
>Priority: Blocker
> Attachments: sample.zip
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-11 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2397:
-
Affects Version/s: 11.0

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Ubuntu 18, Java 12
>Reporter: Martin
>Priority: Blocker
> Attachments: sample.zip
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-2396) Automatic import of package places the import clause at the bottom of the module-info.java file, causing a syntax error

2019-04-11 Thread Martin (JIRA)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-2396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-2396:
-
Summary: Automatic import of package places the import clause at the bottom 
of the module-info.java file, causing a syntax error  (was: Automatic import of 
package places the import clause at the bottom of the file, causing a syntax 
error)

> Automatic import of package places the import clause at the bottom of the 
> module-info.java file, causing a syntax error
> ---
>
> Key: NETBEANS-2396
> URL: https://issues.apache.org/jira/browse/NETBEANS-2396
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Ubuntu 18.10
> Java 12d
>Reporter: Martin
>Priority: Minor
>
> # Open a module-info.java file
>  # state "uses ClassName1", with ClassName1 available in the project
>  # the light bulb will show up at the left hand side of the editor window
>  # chose import mysample.namespace
>  
> => the import clause will be added to the bottom of the file (needs to be at 
> top)
> This will cause a syntax error of course



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-2396) Automatic import of package places the import clause at the bottom of the file, causing a syntax error

2019-04-11 Thread Martin (JIRA)
Martin created NETBEANS-2396:


 Summary: Automatic import of package places the import clause at 
the bottom of the file, causing a syntax error
 Key: NETBEANS-2396
 URL: https://issues.apache.org/jira/browse/NETBEANS-2396
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.0
 Environment: Ubuntu 18.10
Java 12d
Reporter: Martin


# Open a module-info.java file
 # state "uses ClassName1", with ClassName1 available in the project
 # the light bulb will show up at the left hand side of the editor window
 # chose import mysample.namespace

 

=> the import clause will be added to the bottom of the file (needs to be at 
top)

This will cause a syntax error of course



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-13 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16816880#comment-16816880
 ] 

Martin commented on NETBEANS-2397:
--

Not sure why the environment has been changed, but I am on Ubuntu 18.10 with 
Java 12

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: sample.zip
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-05-09 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16836457#comment-16836457
 ] 

Martin commented on NETBEANS-2397:
--

I see you also provided nbactions for debugging etc

thanks!

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-05-09 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16836233#comment-16836233
 ] 

Martin commented on NETBEANS-2397:
--

Thanks a lot !

 

(Yes the maven exec:exec is working, but that was missing in the sample, I 
figured it out later )

 

I do not have a lot of time right now but will get back to NBs asap (it 
provides so much overview)

 

I guess I will create one or two minor issues (request) so that this behavior 
is "out of the box" with Netbeans.

I mean when adding a module-info, a dialog pops up, upgrading the maven 
compiler plug in, so I assume one could also change the run/debug/profile 
actions?

Also it would be nice if the package shows the public/private icon like it does 
with an ant NB java modular project.

 

 

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Comment Edited] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-05-09 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16836233#comment-16836233
 ] 

Martin edited comment on NETBEANS-2397 at 5/9/19 9:31 AM:
--

Thanks a lot !

 

(Yes the maven exec:exec is working, but that was missing in the sample, I 
figured it out later )

 

I do not have a lot of time right now but will get back to NBs asap (it 
provides so much overview)

>From your input it is not 100% clear to me if debug/profiling is also working, 
>but I assume it does (as mentioned will go back soon)

 

 

I guess I will create one or two minor issues (request) so that this behavior 
is "out of the box" with Netbeans.

I mean when adding a module-info, a dialog pops up, upgrading the maven 
compiler plug in, so I assume one could also change the run/debug/profile 
actions?

Also it would be nice if the package shows the public/private icon like it does 
with an ant NB java modular project.

 

 


was (Author: meeser):
Thanks a lot !

 

(Yes the maven exec:exec is working, but that was missing in the sample, I 
figured it out later )

 

I do not have a lot of time right now but will get back to NBs asap (it 
provides so much overview)

 

I guess I will create one or two minor issues (request) so that this behavior 
is "out of the box" with Netbeans.

I mean when adding a module-info, a dialog pops up, upgrading the maven 
compiler plug in, so I assume one could also change the run/debug/profile 
actions?

Also it would be nice if the package shows the public/private icon like it does 
with an ant NB java modular project.

 

 

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Comment Edited] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-05-09 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16836233#comment-16836233
 ] 

Martin edited comment on NETBEANS-2397 at 5/9/19 9:32 AM:
--

Thanks a lot !

 

(Yes the maven exec:exec is working, but that was missing in the sample, I 
figured it out later, but that alone did not help with debugging - or I missed 
s.th. else )

 

I do not have a lot of time right now but will get back to NBs asap (it 
provides so much overview)

>From your input it is not 100% clear to me if debug/profiling is also working, 
>but I assume it does (as mentioned will go back soon)

 

 

I guess I will create one or two minor issues (request) so that this behavior 
is "out of the box" with Netbeans.

I mean when adding a module-info, a dialog pops up, upgrading the maven 
compiler plug in, so I assume one could also change the run/debug/profile 
actions?

Also it would be nice if the package shows the public/private icon like it does 
with an ant NB java modular project.

 

 


was (Author: meeser):
Thanks a lot !

 

(Yes the maven exec:exec is working, but that was missing in the sample, I 
figured it out later )

 

I do not have a lot of time right now but will get back to NBs asap (it 
provides so much overview)

>From your input it is not 100% clear to me if debug/profiling is also working, 
>but I assume it does (as mentioned will go back soon)

 

 

I guess I will create one or two minor issues (request) so that this behavior 
is "out of the box" with Netbeans.

I mean when adding a module-info, a dialog pops up, upgrading the maven 
compiler plug in, so I assume one could also change the run/debug/profile 
actions?

Also it would be nice if the package shows the public/private icon like it does 
with an ant NB java modular project.

 

 

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2397) Java's provide ... with NOT working in maven projects

2019-04-22 Thread Martin (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16823685#comment-16823685
 ] 

Martin commented on NETBEANS-2397:
--

I think the problem might be with nbactions.xml

 

Under  the exec-maven-plugin is in version 1.5, but 1.6 is required for 
java module system ( 
[here|https://github.com/mojohaus/exec-maven-plugin/issues/55] and 
[here2|https://github.com/mojohaus/exec-maven-plugin/milestone/3?closed=1 ] ).

 

 

Will this help solve the problem?

 

> Java's provide ... with NOT working in maven projects
> -
>
> Key: NETBEANS-2397
> URL: https://issues.apache.org/jira/browse/NETBEANS-2397
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.0
> Environment: Windows10
>Reporter: Martin
>Priority: Blocker
> Attachments: netbeans11_sample.mp4, sample.zip, vscode_sample.mp4
>
>
> Please check the attached sample.
>  
> The sample is working with VS Code and IntelliJ Idea.
> Also working when doing with "old school" netbeans (ant) projects.
>  
> Please fix urgently!
>  
> Some linker problem?
>  
> 
> Problem is
>  * mavenproject1 uses I_Sample
>  * mavenproject2 provides I_Sample with SampleImpl
>  * mavenproject3 requires mavenproject1 and mavenproject2
>  
> When you debug or run mavenproject3
>  * it will call mavenproject1.Sample.load
>  * since mavenproject2 is required, the serviceloader must return the loaded 
> SampleImpl instance BUT IT DOES NOT
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb_parser 1.7

2019-09-26 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16938364#comment-16938364
 ] 

Martin commented on NETBEANS-3165:
--

I made a fresh install, and just do not install the nb-javac

not sure if it has been necessary, but deactivated "Compile on save" for all 
projects

I am able to work so far

> Java Modular Projects (ant) do not open after installing nb_parser 1.7
> --
>
> Key: NETBEANS-3165
> URL: https://issues.apache.org/jira/browse/NETBEANS-3165
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.1
> Environment: Ubunut 19, Java 12.01
>Reporter: Martin
>Priority: Blocker
>
> Upon opening classic netbeans (ant) modular project, an exception 
> notifications shows immediately.
> None of my projects do open.
> Removed Nb completly and reinstalled, then again got asked to install 
> nb_parser 1.7.
> Same effect immediatly.
>  
> The exception is as follows:
>  
> Annotation: An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projectsxxx/src/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/xxxclasses/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/mtmscu/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
>  java.lang.AssertionError: duplicate context value at 
> com.sun.tools.javac.util.Context.put(Context.java:141) at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
>  at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
>  at 
> java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
>  at 
> java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
>  at 
> org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
>  at 
> org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
>  at 
> org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
>  at 
> org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
>  at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
>  at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
>  at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
> 

[jira] [Updated] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb-javac 1.7

2019-09-26 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3165?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3165:
-
Summary: Java Modular Projects (ant) do not open after installing nb-javac 
1.7  (was: Java Modular Projects (ant) do not open after installing nb_parser 
1.7)

> Java Modular Projects (ant) do not open after installing nb-javac 1.7
> -
>
> Key: NETBEANS-3165
> URL: https://issues.apache.org/jira/browse/NETBEANS-3165
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.1
> Environment: Ubunut 19, Java 12.01
>Reporter: Martin
>Priority: Blocker
>
> Upon opening classic netbeans (ant) modular project, an exception 
> notifications shows immediately.
> None of my projects do open.
> Removed Nb completly and reinstalled, then again got asked to install 
> nb_parser 1.7.
> Same effect immediatly.
>  
> The exception is as follows:
>  
> Annotation: An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projectsxxx/src/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/xxxclasses/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/mtmscu/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
>  java.lang.AssertionError: duplicate context value at 
> com.sun.tools.javac.util.Context.put(Context.java:141) at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
>  at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
>  at 
> java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
>  at 
> java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
>  at 
> org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
>  at 
> org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
>  at 
> org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
>  at 
> org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
>  at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
>  at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
>  at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
> 

[jira] [Updated] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb-javac 1.7

2019-09-26 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3165?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3165:
-
Environment: Ubuntu 19, Java 12.01  (was: Ubunut 19, Java 12.01)

> Java Modular Projects (ant) do not open after installing nb-javac 1.7
> -
>
> Key: NETBEANS-3165
> URL: https://issues.apache.org/jira/browse/NETBEANS-3165
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.1
> Environment: Ubuntu 19, Java 12.01
>Reporter: Martin
>Priority: Blocker
>
> Upon opening classic netbeans (ant) modular project, an exception 
> notifications shows immediately.
> None of my projects do open.
> Removed Nb completly and reinstalled, then again got asked to install 
> nb_parser 1.7.
> Same effect immediatly.
>  
> The exception is as follows:
>  
> Annotation: An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projectsxxx/src/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/xxxclasses/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/mtmscu/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
>  java.lang.AssertionError: duplicate context value at 
> com.sun.tools.javac.util.Context.put(Context.java:141) at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
>  at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
>  at 
> java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
>  at 
> java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
>  at 
> org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
>  at 
> org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
>  at 
> org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
>  at 
> org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
>  at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
>  at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
>  at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
> org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:83)
>  at 
> 

[jira] [Created] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb_parser 1.7

2019-09-25 Thread Martin (Jira)
Martin created NETBEANS-3165:


 Summary: Java Modular Projects (ant) do not open after installing 
nb_parser 1.7
 Key: NETBEANS-3165
 URL: https://issues.apache.org/jira/browse/NETBEANS-3165
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.1
 Environment: Ubunut 19, Java 12.01
Reporter: Martin


Upon opening classic netbeans (ant) modular project, an exception notifications 
shows immediately.

None of my projects do open.

Removed Nb completly and reinstalled, then again got asked to install nb_parser 
1.7.

Same effect immediatly.

 

The exception is as follows:

 

Annotation: An error occurred during parsing of 
'/home/martin/Projects/mtmscu/sarah.clientstub/src/sarah.clientstub/classes/module-info.java'.
 Please report a bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
 An error occurred during parsing of 
'/home/martin/Projects/mtmscu/sarah.clientstub/src/sarah.clientstub/classes/module-info.java'.
 Please report a bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
 An error occurred during parsing of 
'/home/martin/Projects/mtmscu/sarah.clientstub/src/sarah.clientstub/classes/module-info.java'.
 Please report a bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
error occurred during parsing of 
'/home/martin/Projects/mtmscu/sarah.clientstub/src/sarah.clientstub/classes/module-info.java'.
 Please report a bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
error occurred during parsing of 
'/home/martin/Projects/mtmscu/sarah.clientstub/src/sarah.clientstub/classes/module-info.java'.
 Please report a bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
 java.lang.AssertionError: duplicate context value at 
com.sun.tools.javac.util.Context.put(Context.java:141) at 
org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
 at 
org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
 at 
java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
 at 
java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
 at 
org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
 at 
org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
 at 
org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
 at 
org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
 at 
org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
 at 
org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
 at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
 at 
org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
 at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:83)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:6095)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:6091)
 at 

[jira] [Updated] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb_parser 1.7

2019-09-25 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3165?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3165:
-
Description: 
Upon opening classic netbeans (ant) modular project, an exception notifications 
shows immediately.

None of my projects do open.

Removed Nb completly and reinstalled, then again got asked to install nb_parser 
1.7.

Same effect immediatly.

 

The exception is as follows:

 

Annotation: An error occurred during parsing of 
'/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
 An error occurred during parsing of 
'/home/martin/Projectsxxx/src/xxx/classes/module-info.java'. Please report a 
bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
 An error occurred during parsing of 
'/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
error occurred during parsing of 
'/home/martin/Projects/xxxclasses/module-info.java'. Please report a bug 
against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
error occurred during parsing of 
'/home/martin/Projects/mtmscu/xxx/classes/module-info.java'. Please report a 
bug against java/source and attach dump file 
'/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
 java.lang.AssertionError: duplicate context value at 
com.sun.tools.javac.util.Context.put(Context.java:141) at 
org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
 at 
org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
 at 
java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
 at 
java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
 at 
org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
 at 
org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
 at 
org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
 at 
org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
 at 
org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
 at 
org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
 at 
org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
 at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
 at 
org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
 at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:83)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:6095)
 at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:6091)
 at 
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
 at 
org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
 at 
org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
 at 
org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) at 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.run(RepositoryUpdater.java:6091)
 at 

[jira] [Commented] (NETBEANS-3165) Java Modular Projects (ant) do not open after installing nb-javac 1.7

2019-10-03 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16943477#comment-16943477
 ] 

Martin commented on NETBEANS-3165:
--

I have v1.71 installed, am I supposed close this one?

> Java Modular Projects (ant) do not open after installing nb-javac 1.7
> -
>
> Key: NETBEANS-3165
> URL: https://issues.apache.org/jira/browse/NETBEANS-3165
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.1
> Environment: Ubuntu 19, Java 12.01
>Reporter: Martin
>Priority: Blocker
>
> Upon opening classic netbeans (ant) modular project, an exception 
> notifications shows immediately.
> None of my projects do open.
> Removed Nb completly and reinstalled, then again got asked to install 
> nb_parser 1.7.
> Same effect immediatly.
>  
> The exception is as follows:
>  
> Annotation: An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projectsxxx/src/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Annotation:
>  An error occurred during parsing of 
> '/home/martin/Projects/xxx/classes/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/xxxclasses/module-info.java'. Please report a bug 
> against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.An 
> error occurred during parsing of 
> '/home/martin/Projects/mtmscu/xxx/classes/module-info.java'. Please report a 
> bug against java/source and attach dump file 
> '/home/martin/snap/netbeans/common/data/11.1/var/log/module-info_3.dump'.Caused:
>  java.lang.AssertionError: duplicate context value at 
> com.sun.tools.javac.util.Context.put(Context.java:141) at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader.preRegister(TreeLoader.java:104)
>  at 
> org.netbeans.modules.java.source.nbjavac.parsing.TreeLoader$TreeLoaderRegistryImpl.enhance(TreeLoader.java:577)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.lambda$createJavacTask$10(JavacParser.java:796)
>  at 
> java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654)
>  at 
> java.base/java.util.stream.ReferencePipeline$Head.forEach(ReferencePipeline.java:658)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.createJavacTask(JavacParser.java:796)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.getJavacTask(CompilationInfoImpl.java:374)
>  at 
> org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:587)
>  at 
> org.netbeans.modules.java.source.parsing.CompilationInfoImpl.toPhase(CompilationInfoImpl.java:361)
>  at 
> org.netbeans.api.java.source.CompilationController.toPhase(CompilationController.java:84)
>  at 
> org.netbeans.modules.java.source.JavaSourceUtilImpl$1.parseModule(JavaSourceUtilImpl.java:290)
>  at 
> org.netbeans.modules.java.preprocessorbridge.api.ModuleUtilities.parseModule(ModuleUtilities.java:80)
>  at 
> org.netbeans.modules.java.api.common.classpath.ModuleClassPaths$ModuleInfoClassPathImplementation.getResources(ModuleClassPaths.java:844)
>  at org.netbeans.api.java.classpath.ClassPath.entries(ClassPath.java:363) at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.createResources(PathRegistry.java:719)
>  at 
> org.netbeans.modules.parsing.impl.indexing.PathRegistry.getSources(PathRegistry.java:275)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4888)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$InitialRootsWork.getDone(RepositoryUpdater.java:5821)[catch]
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3420)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:6183)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4300(RepositoryUpdater.java:5834)
>  at 
> org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:6099)
>  at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
> org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:83)
>  at 
> 

[jira] [Created] (NETBEANS-3928) Exception notification raises over and over again

2020-02-29 Thread Martin (Jira)
Martin created NETBEANS-3928:


 Summary: Exception notification raises over and over again
 Key: NETBEANS-3928
 URL: https://issues.apache.org/jira/browse/NETBEANS-3928
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
Reporter: Martin


java.util.ConcurrentModificationExceptionjava.util.ConcurrentModificationException
 at java.base/java.util.HashMap.computeIfAbsent(HashMap.java:1139) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.getParameterName(ParameterNameProviderImpl.java:130)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$1.invoke(ParameterNameProviderImpl.java:90)
 at com.sun.proxy.$Proxy26.getParameterName(Unknown Source) at 
com.sun.tools.javac.code.MissingInfoHandler.getParameterName(MissingInfoHandler.java:63)
 at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1746) 
at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1731) 
at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.lambda$visitMethod$0(ParameterNameProviderImpl.java:142)
 at 
java.base/java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:195)
 at java.base/java.util.Iterator.forEachRemaining(Iterator.java:133) at 
java.base/java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)
 at 
java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) 
at 
java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
 at 
java.base/java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913)
 at 
java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) 
at 
java.base/java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.visitMethod(ParameterNameProviderImpl.java:142)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.visitMethod(ParameterNameProviderImpl.java:138)
 at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:914) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:91) at 
com.sun.source.util.TreeScanner.scan(TreeScanner.java:106) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:114) at 
com.sun.source.util.TreeScanner.visitClass(TreeScanner.java:188) at 
com.sun.tools.javac.tree.JCTree$JCClassDecl.accept(JCTree.java:822) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
com.sun.source.util.TreeScanner.scan(TreeScanner.java:106) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:114) at 
com.sun.source.util.TreeScanner.visitCompilationUnit(TreeScanner.java:145) at 
com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:603) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.lambda$null$0(ParameterNameProviderImpl.java:146)
 at org.netbeans.api.java.source.JavaSource$MultiTask.run(JavaSource.java:502) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:586)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:130)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:114)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:181) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:178) 
at 
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
 at 
org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
 at 
org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
 at 
org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:178)
 at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:81) 
at 
org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:452)
 at 
org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:423) 
at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.lambda$getParameterName$1(ParameterNameProviderImpl.java:136)
 at java.base/java.util.HashMap.computeIfAbsent(HashMap.java:1138) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.getParameterName(ParameterNameProviderImpl.java:130)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$1.invoke(ParameterNameProviderImpl.java:90)
 at com.sun.proxy.$Proxy26.getParameterName(Unknown Source) at 

[jira] [Created] (NETBEANS-3946) Exception notification: StackOverflowError

2020-03-04 Thread Martin (Jira)
Martin created NETBEANS-3946:


 Summary: Exception notification: StackOverflowError
 Key: NETBEANS-3946
 URL: https://issues.apache.org/jira/browse/NETBEANS-3946
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
Reporter: Martin
 Attachments: ex.txt





--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3947) Exception notification: NoSuchField

2020-03-04 Thread Martin (Jira)
Martin created NETBEANS-3947:


 Summary: Exception notification: NoSuchField
 Key: NETBEANS-3947
 URL: https://issues.apache.org/jira/browse/NETBEANS-3947
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
Reporter: Martin
 Attachments: ex.txt





--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3949) Exception notification: IllegalStateException

2020-03-04 Thread Martin (Jira)
Martin created NETBEANS-3949:


 Summary: Exception notification: IllegalStateException
 Key: NETBEANS-3949
 URL: https://issues.apache.org/jira/browse/NETBEANS-3949
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
Reporter: Martin
 Attachments: ex2





--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3933) Exception notification: java.lang.ClassCastException

2020-03-02 Thread Martin (Jira)
Martin created NETBEANS-3933:


 Summary: Exception notification: java.lang.ClassCastException
 Key: NETBEANS-3933
 URL: https://issues.apache.org/jira/browse/NETBEANS-3933
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
Reporter: Martin
 Attachments: ex.txt

not sure why it occurs, neither if it has any impact on the ide (seems not)

 

however, nb is producing quite some exceptions (with Java 13) over a whole work 
day



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-3928) Exception notification: java.util.ConcurrentModificationException

2020-03-02 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3928?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3928:
-
Summary: Exception notification: java.util.ConcurrentModificationException  
(was: Exception notification raises over and over again: 
java.util.ConcurrentModificationException)

> Exception notification: java.util.ConcurrentModificationException
> -
>
> Key: NETBEANS-3928
> URL: https://issues.apache.org/jira/browse/NETBEANS-3928
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
>Reporter: Martin
>Priority: Minor
> Attachments: stacktrace.txt
>
>
> Only stacktrace provided - stacktrace attached as file now.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3937) Exception notification: java.lang.ClassCastException 2

2020-03-03 Thread Martin (Jira)
Martin created NETBEANS-3937:


 Summary: Exception notification: java.lang.ClassCastException 2
 Key: NETBEANS-3937
 URL: https://issues.apache.org/jira/browse/NETBEANS-3937
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
 Environment: Ubuntu 19, Java 13
Reporter: Martin
 Attachments: ex.txt





--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3931) Exception notification: java.lang.AssertionError

2020-03-01 Thread Martin (Jira)
Martin created NETBEANS-3931:


 Summary: Exception notification: java.lang.AssertionError
 Key: NETBEANS-3931
 URL: https://issues.apache.org/jira/browse/NETBEANS-3931
 Project: NetBeans
  Issue Type: Bug
Reporter: Martin
 Attachments: ex.txt

Reporting raised exception, when and why not clear, effects not clear,

ide still seems OK

 

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-3928) Exception notification raises over and over again: java.util.ConcurrentModificationException

2020-03-01 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3928?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3928:
-
Summary: Exception notification raises over and over again: 
java.util.ConcurrentModificationException  (was: Exception notification raises 
over and over again)

> Exception notification raises over and over again: 
> java.util.ConcurrentModificationException
> 
>
> Key: NETBEANS-3928
> URL: https://issues.apache.org/jira/browse/NETBEANS-3928
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
>Reporter: Martin
>Priority: Minor
> Attachments: stacktrace.txt
>
>
> Only stacktrace provided - stacktrace attached as file now.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012707#comment-17012707
 ] 

Martin commented on NETBEANS-3658:
--

sorry, I judged to quickly

 

might depend on the concrete rename case.

 

First, rename worked

 

then  I again tried to rename my I_Command getCompletableFuture() to 
getResult(), but I realized  that one of the classes implementing I_Command 
already has a method called getResult()

might this case the problem?

 

now, without nb-javac installed, rename renames all calls, but not the original 
method name

this behavior gets back to normal after restarting nb

 

Anyway I will ship around this for now and try without and with nb-javac, and 
will let you know if I observe more problems

 

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, Screenshot from 
> 2020-01-10 11-20-20.png, nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> 

[jira] [Updated] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3658:
-
Attachment: nb version.png

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING 

[jira] [Updated] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3658:
-
Attachment: nb rename problem.mp4

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012671#comment-17012671
 ] 

Martin commented on NETBEANS-3658:
--

when going to Tools->Plugins

i can not find something called nb-javac in none of the tabs

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012686#comment-17012686
 ] 

Martin commented on NETBEANS-3658:
--

totally missed the "show details", sry

 

it has version 2.0.1

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, Screenshot from 
> 2020-01-10 11-20-20.png, nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> 

[jira] [Comment Edited] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012671#comment-17012671
 ] 

Martin edited comment on NETBEANS-3658 at 1/10/20 10:15 AM:


when going to Tools->Plugins

i can not find something called nb-javac in none of the tabs (like in the video)


was (Author: meeser):
when going to Tools->Plugins

i can not find something called nb-javac in none of the tabs

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012692#comment-17012692
 ] 

Martin commented on NETBEANS-3658:
--

ok when uninstalled rename works (very fast).

 

I am unaware what nb-javac adds anyway so I am fine with that

 

thanks for the support!

 

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, Screenshot from 
> 2020-01-10 11-20-20.png, nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same 

[jira] [Updated] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3658:
-
Attachment: Screenshot from 2020-01-10 11-20-20.png

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, Screenshot from 
> 2020-01-10 11-20-20.png, nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012679#comment-17012679
 ] 

Martin commented on NETBEANS-3658:
--

it is not there  !Screenshot from 2020-01-10 11-20-20.png!

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, Screenshot from 
> 2020-01-10 11-20-20.png, nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012639#comment-17012639
 ] 

Martin commented on NETBEANS-3658:
--

reinstalled netbeans from scratch, still not able to rename

 

Module Java Refactoring threw java.lang.IllegalStateException: Cannot use 
Elements.getTypeElement before the TaskEvent.Kind.ENTER finished event.. Please 
report a bug against Java Refactoring module and attach your 
var/log/messages.log.

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012665#comment-17012665
 ] 

Martin commented on NETBEANS-3658:
--

uploaded quick video, many thanks in advance!

 

11.2 is installed, nb-javac is installed (I guess), no updates available when 
checking for updates in plugin manager

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: nb rename problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> 

[jira] [Updated] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin updated NETBEANS-3658:
-
Attachment: Screenshot from 2020-01-10 11-17-00.png

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, nb rename 
> problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> 

[jira] [Commented] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17012676#comment-17012676
 ] 

Martin commented on NETBEANS-3658:
--

does this screenshot help?  !Screenshot from 2020-01-10 11-17-00.png!

> Rename field throws exception
> -
>
> Key: NETBEANS-3658
> URL: https://issues.apache.org/jira/browse/NETBEANS-3658
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 11.2
> Environment: Ubuntu 19, Java 13
>Reporter: Martin
>Priority: Major
> Attachments: Screenshot from 2020-01-10 11-17-00.png, nb rename 
> problem.mp4, nb version.png
>
>
> ---
> >Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European 
> >Standard Time
> >System Info: 
>  Product Version = Apache NetBeans IDE 11.2
>  Operating System = Linux version 5.3.0-24-generic running on amd64
>  Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
>  Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
>  Java Home = /usr/lib/jvm/java-13-openjdk-amd64
>  System Locale; Encoding = en_US (nb); UTF-8
>  Home Directory = /home/martin
>  Current Directory = /home/martin
>  User Directory = /home/martin/snap/netbeans/common/data/11.2
>  Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
>  Installation = /snap/netbeans/18/netbeans/nb
>  /snap/netbeans/18/netbeans/ergonomics
>  /snap/netbeans/18/netbeans/ide
>  /snap/netbeans/18/netbeans/extide
>  /snap/netbeans/18/netbeans/java
>  /snap/netbeans/18/netbeans/apisupport
>  /snap/netbeans/18/netbeans/webcommon
>  /snap/netbeans/18/netbeans/websvccommon
>  /snap/netbeans/18/netbeans/enterprise
>  /snap/netbeans/18/netbeans/profiler
>  /snap/netbeans/18/netbeans/php
>  /snap/netbeans/18/netbeans/harness
>  /snap/netbeans/18/netbeans/groovy
>  /snap/netbeans/18/netbeans/extra
>  /snap/netbeans/18/netbeans/javafx
>  /snap/netbeans/18/netbeans/platform
>  Boot & Ext. Classpath = 
>  Application Classpath = 
> /snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
>  Startup Classpath = 
> /snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
> ---
> INFO [org.netbeans.modules.netbinox]: Install area set to 
> file:/snap/netbeans/18/netbeans/
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ide.kit, org.netbeans.modules.xml.text] use 
> org.netbeans.modules.editor.structure which is deprecated.
> WARNING [org.netbeans.core.modules]: the modules 
> [org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
> org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
> org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java 
> Hints SPI (org.netbeans.spi.java.hints) instead.
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
>  and 
> Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
> WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
> 

[jira] [Reopened] (NETBEANS-3658) Rename field throws exception

2020-01-10 Thread Martin (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin reopened NETBEANS-3658:
--

the problem is still present

 

java.util.ConcurrentModificationExceptionjava.util.ConcurrentModificationException
 at java.base/java.util.HashMap.computeIfAbsent(HashMap.java:1139) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.getParameterName(ParameterNameProviderImpl.java:130)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$1.invoke(ParameterNameProviderImpl.java:90)
 at com.sun.proxy.$Proxy25.getParameterName(Unknown Source) at 
com.sun.tools.javac.code.MissingInfoHandler.getParameterName(MissingInfoHandler.java:63)
 at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1746) 
at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1731) 
at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.lambda$visitMethod$0(ParameterNameProviderImpl.java:142)
 at 
java.base/java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:195)
 at java.base/java.util.Iterator.forEachRemaining(Iterator.java:133) at 
java.base/java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)
 at 
java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) 
at 
java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
 at 
java.base/java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913)
 at 
java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) 
at 
java.base/java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.visitMethod(ParameterNameProviderImpl.java:142)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$2.visitMethod(ParameterNameProviderImpl.java:138)
 at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:914) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:91) at 
com.sun.source.util.TreeScanner.scan(TreeScanner.java:106) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:114) at 
com.sun.source.util.TreeScanner.visitClass(TreeScanner.java:188) at 
com.sun.tools.javac.tree.JCTree$JCClassDecl.accept(JCTree.java:822) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
com.sun.source.util.TreeScanner.scan(TreeScanner.java:106) at 
com.sun.source.util.TreeScanner.scanAndReduce(TreeScanner.java:114) at 
com.sun.source.util.TreeScanner.visitCompilationUnit(TreeScanner.java:145) at 
com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:603) at 
com.sun.source.util.TreePathScanner.scan(TreePathScanner.java:82) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.lambda$null$0(ParameterNameProviderImpl.java:146)
 at org.netbeans.api.java.source.JavaSource$MultiTask.run(JavaSource.java:502) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:586)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:130)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:114)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:181) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:178) 
at 
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
 at 
org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
 at 
org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
 at 
org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:178)
 at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:81) 
at 
org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:452)
 at 
org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:423) 
at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.lambda$getParameterName$1(ParameterNameProviderImpl.java:136)
 at java.base/java.util.HashMap.computeIfAbsent(HashMap.java:1138) at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl.getParameterName(ParameterNameProviderImpl.java:130)
 at 
org.netbeans.modules.java.source.parsing.ParameterNameProviderImpl$1.invoke(ParameterNameProviderImpl.java:90)
 at com.sun.proxy.$Proxy25.getParameterName(Unknown Source) at 
com.sun.tools.javac.code.MissingInfoHandler.getParameterName(MissingInfoHandler.java:63)
 at com.sun.tools.javac.code.Symbol$ParamSymbol.getSimpleName(Symbol.java:1746) 
at 

[jira] [Created] (NETBEANS-3658) Rename field throws exception

2020-01-02 Thread Martin (Jira)
Martin created NETBEANS-3658:


 Summary: Rename field throws exception
 Key: NETBEANS-3658
 URL: https://issues.apache.org/jira/browse/NETBEANS-3658
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 11.2
 Environment: Ubuntu 19, Java 13
Reporter: Martin


---
>Log Session: Thursday, January 2, 2020 at 5:06:34 PM Central European Standard 
>Time
>System Info: 
 Product Version = Apache NetBeans IDE 11.2
 Operating System = Linux version 5.3.0-24-generic running on amd64
 Java; VM; Vendor = 13; OpenJDK 64-Bit Server VM 13+33-Ubuntu-1; Private Build
 Runtime = OpenJDK Runtime Environment 13+33-Ubuntu-1
 Java Home = /usr/lib/jvm/java-13-openjdk-amd64
 System Locale; Encoding = en_US (nb); UTF-8
 Home Directory = /home/martin
 Current Directory = /home/martin
 User Directory = /home/martin/snap/netbeans/common/data/11.2
 Cache Directory = /home/martin/snap/netbeans/common/cache/11.2
 Installation = /snap/netbeans/18/netbeans/nb
 /snap/netbeans/18/netbeans/ergonomics
 /snap/netbeans/18/netbeans/ide
 /snap/netbeans/18/netbeans/extide
 /snap/netbeans/18/netbeans/java
 /snap/netbeans/18/netbeans/apisupport
 /snap/netbeans/18/netbeans/webcommon
 /snap/netbeans/18/netbeans/websvccommon
 /snap/netbeans/18/netbeans/enterprise
 /snap/netbeans/18/netbeans/profiler
 /snap/netbeans/18/netbeans/php
 /snap/netbeans/18/netbeans/harness
 /snap/netbeans/18/netbeans/groovy
 /snap/netbeans/18/netbeans/extra
 /snap/netbeans/18/netbeans/javafx
 /snap/netbeans/18/netbeans/platform
 Boot & Ext. Classpath = 
 Application Classpath = 
/snap/netbeans/18/netbeans/platform/lib/boot.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-modules.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-lookup.jar:/snap/netbeans/18/netbeans/platform/lib/org-openide-util-ui.jar
 Startup Classpath = 
/snap/netbeans/18/netbeans/platform/core/asm-all-5.0.1.jar:/snap/netbeans/18/netbeans/platform/core/core-base.jar:/snap/netbeans/18/netbeans/platform/core/core.jar:/snap/netbeans/18/netbeans/platform/core/org-netbeans-libs-asm.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems-compat8.jar:/snap/netbeans/18/netbeans/platform/core/org-openide-filesystems.jar:/snap/netbeans/18/netbeans/nb/core/org-netbeans-upgrader.jar:/snap/netbeans/18/netbeans/nb/core/locale/core_nb.jar
---
INFO [org.netbeans.modules.netbinox]: Install area set to 
file:/snap/netbeans/18/netbeans/
WARNING [org.netbeans.core.modules]: the modules 
[org.netbeans.modules.java.editor.lib, org.netbeans.modules.xml.text] use 
org.netbeans.modules.editor.deprecated.pre65formatting which is deprecated.
WARNING [org.netbeans.core.modules]: the modules [org.netbeans.modules.ide.kit, 
org.netbeans.modules.xml.text] use org.netbeans.modules.editor.structure which 
is deprecated.
WARNING [org.netbeans.core.modules]: the modules 
[org.netbeans.modules.ant.hints, org.netbeans.modules.java.hints, 
org.netbeans.modules.jshell.support, org.netbeans.modules.maven.hints] use 
org.netbeans.modules.java.hints.legacy.spi which is deprecated: Use Java Hints 
SPI (org.netbeans.spi.java.hints) instead.
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
 and 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
 and 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
 and 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
 and 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-NpmDebugLogDataObject-Registration.xml
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageLockJsonDataObject-Registration.xml
 and 
Services/MIMEResolver/org-netbeans-modules-javascript-nodejs-file-PackageJsonDataObject-Registration.xml
WARNING [org.openide.filesystems.Ordering]: Found same position 127 for both 

[jira] [Created] (NETBEANS-5657) Order in Gradle Subprojects is NOT alphabetically

2021-05-04 Thread Martin (Jira)
Martin created NETBEANS-5657:


 Summary: Order in Gradle Subprojects is NOT alphabetically
 Key: NETBEANS-5657
 URL: https://issues.apache.org/jira/browse/NETBEANS-5657
 Project: NetBeans
  Issue Type: Bug
Affects Versions: 12.2, 12.3
Reporter: Martin
 Attachments: nb-gradle-order.png

If you open a gradle multi-module project there is "build scripts" and 
"subprojects".

Under subprojects, the projects are in some random order. I only have around 15 
projects but already I find this very annoying. Please fix!

Note: before 12.2 this was sorted

!nb-gradle-order.png!

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-5688) Gradle 7.0.2 with Java 16 NOT working

2021-05-18 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-5688?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17346829#comment-17346829
 ] 

Martin commented on NETBEANS-5688:
--

I purged java 16, deleted local /opt/gradle/7.0.2 (replaced with 6.7) and set 
the target- and source- version back to 15/

at least I can work now again

> Gradle 7.0.2 with Java 16 NOT working
> -
>
> Key: NETBEANS-5688
> URL: https://issues.apache.org/jira/browse/NETBEANS-5688
> Project: NetBeans
>  Issue Type: Bug
>  Components: projects - Gradle
>Affects Versions: 12.3
> Environment: I switched the project to Gradle 7.0.2. (from 6.?)
> Java is openJDK 16.0.2 (from 15.?)
> OS is Ubuntu Budgie 21
>  
>Reporter: Martin
>Assignee: Laszlo Kishalmi
>Priority: Major
>
> I switched the project to Gradle 7.0.2.
> Java is openJDK 16.0.2
> OS is Ubuntu Budgie 21
>  
> in /opt/gradle there is gradle 7.0.2
> in /home/martin/.gradle there are several gradles
>  
> within build.gradle
> I have
>  
> subprojects {
>  sourceCompatibility = JavaVersion.VERSION_16
>  targetCompatibility = JavaVersion.VERSION_16
> }
>  
> when in terminal
> gradle --version shows 7.0.2
> ./gradlew --version shows 7.0.2
> gradle build is working
> ./gradlew build is working
>  
> In NB right clicking root project -> "reload project" fails!
>  
> Message is:
> "
> Unsupported class file major version 60 (as if I am NOT using gradle 7)
> ...
> Could not run build action ... /home/martin/.gradle ... /gradle-6.7
> However under Options->Java->gradle version is set to 7.0.2 // no possible 
> option is working
> ---
> I am now struggling for hours with this / I am even struggling to be able to 
> go back to Java 15
> ---
> any quick help highly appreciated



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-5688) Gradle 7.0.2 with Java 16 NOT working

2021-05-18 Thread Martin (Jira)
Martin created NETBEANS-5688:


 Summary: Gradle 7.0.2 with Java 16 NOT working
 Key: NETBEANS-5688
 URL: https://issues.apache.org/jira/browse/NETBEANS-5688
 Project: NetBeans
  Issue Type: Bug
  Components: projects - Gradle
Affects Versions: 12.3
 Environment: I switched the project to Gradle 7.0.2. (from 6.?)

Java is openJDK 16.0.2 (from 15.?)

OS is Ubuntu Budgie 21

 
Reporter: Martin
Assignee: Laszlo Kishalmi


I switched the project to Gradle 7.0.2.

Java is openJDK 16.0.2

OS is Ubuntu Budgie 21

 

in /opt/gradle there is gradle 7.0.2

in /home/martin/.gradle there are several gradles

 

within build.gradle

I have

 

subprojects {

 sourceCompatibility = JavaVersion.VERSION_16
 targetCompatibility = JavaVersion.VERSION_16

}

 

when in terminal

gradle --version shows 7.0.2

./gradlew --version shows 7.0.2

gradle build is working

./gradlew build is working

 

In NB right clicking root project -> "reload project" fails!

 

Message is:

"

Unsupported class file major version 60 (as if I am NOT using gradle 7)

...

Could not run build action ... /home/martin/.gradle ... /gradle-6.7

However under Options->Java->gradle version is set to 7.0.2 // no possible 
option is working

---

I am now struggling for hours with this / I am even struggling to be able to go 
back to Java 15

---

any quick help highly appreciated



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-5688) Gradle 7.0.2 with Java 16 NOT working

2021-05-18 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-5688?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17347113#comment-17347113
 ] 

Martin commented on NETBEANS-5688:
--

thank you Geertjan for the information

> Gradle 7.0.2 with Java 16 NOT working
> -
>
> Key: NETBEANS-5688
> URL: https://issues.apache.org/jira/browse/NETBEANS-5688
> Project: NetBeans
>  Issue Type: Bug
>  Components: projects - Gradle
>Affects Versions: 12.3
> Environment: I switched the project to Gradle 7.0.2. (from 6.?)
> Java is openJDK 16.0.2 (from 15.?)
> OS is Ubuntu Budgie 21
>  
>Reporter: Martin
>Assignee: Laszlo Kishalmi
>Priority: Major
>
> I switched the project to Gradle 7.0.2.
> Java is openJDK 16.0.2
> OS is Ubuntu Budgie 21
>  
> in /opt/gradle there is gradle 7.0.2
> in /home/martin/.gradle there are several gradles
>  
> within build.gradle
> I have
>  
> subprojects {
>  sourceCompatibility = JavaVersion.VERSION_16
>  targetCompatibility = JavaVersion.VERSION_16
> }
>  
> when in terminal
> gradle --version shows 7.0.2
> ./gradlew --version shows 7.0.2
> gradle build is working
> ./gradlew build is working
>  
> In NB right clicking root project -> "reload project" fails!
>  
> Message is:
> "
> Unsupported class file major version 60 (as if I am NOT using gradle 7)
> ...
> Could not run build action ... /home/martin/.gradle ... /gradle-6.7
> However under Options->Java->gradle version is set to 7.0.2 // no possible 
> option is working
> ---
> I am now struggling for hours with this / I am even struggling to be able to 
> go back to Java 15
> ---
> any quick help highly appreciated



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-5691) Gradle 3rd level api-dependencies are not resolved correclty.

2021-05-18 Thread Martin (Jira)
Martin created NETBEANS-5691:


 Summary: Gradle 3rd level api-dependencies are not resolved 
correclty.
 Key: NETBEANS-5691
 URL: https://issues.apache.org/jira/browse/NETBEANS-5691
 Project: NetBeans
  Issue Type: Bug
  Components: projects - Gradle
Affects Versions: 12.3
 Environment: Java 15

Gradle 6.7

Ubuntu 21
Reporter: Martin
Assignee: Laszlo Kishalmi


First of all: gradle support in NB is great! Maybe best there is!

 

I have a multproject  java modular gradle build.

If a project has an api dependency to a second project, that works fine.

 

However if a 3rd project also has an dependency to the 2nd project, that does 
not work.

NB does not recognize the classes from the 1st project.

The gradle build works.

 

This can be overcome by manually adding the implementation dependency of 
project 1 to project 3 in project 3's build.gradle.

However that is what you do NOT want to do and why you are using gradle in the 
first place... (among other things of course)

Steps to reproduce: Create gradle project with java modular solution 
(infer-module-path = true). Create 3 projects with "requires transitive" in 
module-info.java and "api dependency" build.gradle as described .

 

 

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-5691) Gradle 3rd level api-dependencies are not resolved correclty.

2021-05-18 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-5691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17347155#comment-17347155
 ] 

Martin commented on NETBEANS-5691:
--

Dear NB-Dev-Team,

I am not able to support with sample project  - sry.

I can give s.o. a quick tour via some screen share solution if that is of any 
help.

 

I just learned about the close nb 12.4 release so I just wanted you to be aware 
of this.

> Gradle 3rd level api-dependencies are not resolved correclty.
> -
>
> Key: NETBEANS-5691
> URL: https://issues.apache.org/jira/browse/NETBEANS-5691
> Project: NetBeans
>  Issue Type: Bug
>  Components: projects - Gradle
>Affects Versions: 12.3
> Environment: Java 15
> Gradle 6.7
> Ubuntu 21
>Reporter: Martin
>Assignee: Laszlo Kishalmi
>Priority: Minor
>
> First of all: gradle support in NB is great! Maybe best there is!
>  
> I have a multproject  java modular gradle build.
> If a project has an api dependency to a second project, that works fine.
>  
> However if a 3rd project also has an dependency to the 2nd project, that does 
> not work.
> NB does not recognize the classes from the 1st project.
> The gradle build works.
>  
> This can be overcome by manually adding the implementation dependency of 
> project 1 to project 3 in project 3's build.gradle.
> However that is what you do NOT want to do and why you are using gradle in 
> the first place... (among other things of course)
> Steps to reproduce: Create gradle project with java modular solution 
> (infer-module-path = true). Create 3 projects with "requires transitive" in 
> module-info.java and "api dependency" build.gradle as described .
>  
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-5691) Gradle 3rd level api-dependencies are not resolved correclty.

2021-06-01 Thread Martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-5691?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17355347#comment-17355347
 ] 

Martin commented on NETBEANS-5691:
--

Can not reproduce with NB 12.4, Gradle 7, Java 16

not sure what happened, deactivated experimental features under 
options->java->gradle (was not aware those were activated),  changed 
SOURCE_COMPABILITY to JavaLanguageVersion.of(16) in build.gradle

should I just close this?

 

 

> Gradle 3rd level api-dependencies are not resolved correclty.
> -
>
> Key: NETBEANS-5691
> URL: https://issues.apache.org/jira/browse/NETBEANS-5691
> Project: NetBeans
>  Issue Type: Bug
>  Components: projects - Gradle
>Affects Versions: 12.3
> Environment: Java 15
> Gradle 6.7
> Ubuntu 21
>Reporter: Martin
>Assignee: Laszlo Kishalmi
>Priority: Minor
>
> First of all: gradle support in NB is great! Maybe best there is!
>  
> I have a multproject  java modular gradle build.
> If a project has an api dependency to a second project, that works fine.
>  
> However if a 3rd project also has an dependency to the 2nd project, that does 
> not work.
> NB does not recognize the classes from the 1st project.
> The gradle build works.
>  
> This can be overcome by manually adding the implementation dependency of 
> project 1 to project 3 in project 3's build.gradle.
> However that is what you do NOT want to do and why you are using gradle in 
> the first place... (among other things of course)
> Steps to reproduce: Create gradle project with java modular solution 
> (infer-module-path = true). Create 3 projects with "requires transitive" in 
> module-info.java and "api dependency" build.gradle as described .
>  
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-4853) Bad Font Rendering on Linux with any JDK

2020-10-12 Thread Enzo martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-4853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17212751#comment-17212751
 ] 

Enzo martin commented on NETBEANS-4853:
---

ok i guess i'll have to settle for that rendering :( thanks anyway

> Bad Font Rendering on Linux with any JDK 
> -
>
> Key: NETBEANS-4853
> URL: https://issues.apache.org/jira/browse/NETBEANS-4853
> Project: NetBeans
>  Issue Type: Bug
>  Components: ide - UI
>Affects Versions: 12.0, 12.1
> Environment: Fedora32
>Reporter: Enzo martin
>Priority: Major
>  Labels: Font, Linux, Rendering
> Attachments: Screenshot from 2020-09-27 13-50-59.png, Screenshot from 
> 2020-09-27 13-52-24.png, Screenshot from 2020-09-27 13-57-10.png
>
>
> Bad font rendering on linux, with any JDK, y tested the zulu JDK and OpenJDK 
> on his versions 8, 11, and 15, without better font rendering. 
> I also tried some of the solutions found in google, without any positive 
> results. 
> For example on  this link:
>  
> https://askubuntu.com/questions/32624/ugly-fonts-in-netbeans-how-can-i-make-it-use-the-system-font
>  
> I am using Fedora32 with GnomeDE, but the problem also occurs in other 
> desktop environments eg. KDE or Matte, with any linux distribution. Other 
> IDEs like Intellij or Eclipse have better font rendering. Attached Sample 
> Images



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-4853) Bad Font Rendering on Linux with any JDK

2020-09-27 Thread Enzo martin (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-4853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17202912#comment-17202912
 ] 

Enzo martin commented on NETBEANS-4853:
---

humm i think no, but try to change the font to "DejaVu Sans Mono" to compare 
exactly, it should look smooth like Intellij screenshot, however in my case it 
looks a "Full Hinting" rendering

> Bad Font Rendering on Linux with any JDK 
> -
>
> Key: NETBEANS-4853
> URL: https://issues.apache.org/jira/browse/NETBEANS-4853
> Project: NetBeans
>  Issue Type: Bug
>  Components: ide - UI
>Affects Versions: 12.0, 12.1
> Environment: Fedora32
>Reporter: Enzo martin
>Priority: Major
>  Labels: Font, Linux, Rendering
> Attachments: Screenshot from 2020-09-27 13-50-59.png, Screenshot from 
> 2020-09-27 13-52-24.png, Screenshot from 2020-09-27 13-57-10.png
>
>
> Bad font rendering on linux, with any JDK, y tested the zulu JDK and OpenJDK 
> on his versions 8, 11, and 15, without better font rendering. 
> I also tried some of the solutions found in google, without any positive 
> results. 
> For example on  this link:
>  
> https://askubuntu.com/questions/32624/ugly-fonts-in-netbeans-how-can-i-make-it-use-the-system-font
>  
> I am using Fedora32 with GnomeDE, but the problem also occurs in other 
> desktop environments eg. KDE or Matte, with any linux distribution. Other 
> IDEs like Intellij or Eclipse have better font rendering. Attached Sample 
> Images



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-4853) Bad Font Rendering on Linux with any JDK

2020-09-27 Thread Enzo martin (Jira)
Enzo martin created NETBEANS-4853:
-

 Summary: Bad Font Rendering on Linux with any JDK 
 Key: NETBEANS-4853
 URL: https://issues.apache.org/jira/browse/NETBEANS-4853
 Project: NetBeans
  Issue Type: Bug
  Components: ide - UI
Affects Versions: 12.0, 12.1
 Environment: Fedora32
Reporter: Enzo martin
 Attachments: Screenshot from 2020-09-27 13-52-24.png, Screenshot from 
2020-09-27 13-57-10.png

Bad font rendering on linux, with any JDK, y tested the zulu JDK and OpenJDK on 
his versions 8, 11, and 15, without better font rendering. 

I also tried some of the solutions found in google, without any positive 
results. 

For example on  this link:

 
https://askubuntu.com/questions/32624/ugly-fonts-in-netbeans-how-can-i-make-it-use-the-system-font
 

I am using Fedora32 with GnomeDE, but the problem also occurs in other desktop 
environments eg. KDE or Matte, with any linux distribution. Other IDEs like 
Intellij or Eclipse have better font rendering. Attached Sample Images



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists