[jira] [Updated] (NETBEANS-3932) java.lang.NullPointerExceptionjava GsfHintsProvider.computeErrors

2020-03-02 Thread bilu (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3932?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

bilu updated NETBEANS-3932:
---
Attachment: SimpleJava2.zip

> java.lang.NullPointerExceptionjava GsfHintsProvider.computeErrors
> -
>
> Key: NETBEANS-3932
> URL: https://issues.apache.org/jira/browse/NETBEANS-3932
> Project: NetBeans
>  Issue Type: Bug
>  Components: editor - Hints  Annotations, editor - Parsing  
> Indexing
>Affects Versions: 11.1
> Environment: Product Version: Apache NetBeans IDE 11.1
> Updates: NetBeans IDE is updated to version NetBeans 8.2 Patch 2
> Java: 1.8.0_181; Java HotSpot(TM) 64-Bit Server VM 25.181-b13
> Runtime: Java(TM) SE Runtime Environment 1.8.0_181-b13
> System: Windows 10 version 10.0 running on amd64; Cp1252; en_US (nb)
> User directory: C:\Users\\AppData\Roaming\NetBeans\11.1
> Cache directory: C:\Users\\AppData\Local\NetBeans\Cache\11.1
>Reporter: bilu
>Priority: Minor
> Attachments: SimpleJava2.zip
>
>
> Step to reproduce the problem:
> 1-Follow the tutorial: 
> [https://platform.netbeans.org/tutorials/nbm-javacc-parser.html]
> or get complete code source here: 
> [https://github.com/vparfonov/api-samples/tree/master/nb-api-samples~api-samples/versions/7.2/tutorials/SimpleJava2]
>  * At this step run the project and you will get:  
> java.lang.ClassCastException: org.simplejava.parser.SJParser$SJParserResult 
> cannot be cast to org.netbeans.modules.csl.spi.ParserResult
> 2-Update SJParserResult class to extend o.n.m.csl.spi.ParserResult instead of 
> o.n.m.parsing.spi.Parser.Result like suggest here  
> https://bz.apache.org/netbeans/show_bug.cgi?id=167064
> to fix precedent issue
> 3-Run the Project, you will get now :
> java.lang.NullPointerExceptionjava.lang.NullPointerException at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.computeErrors(GsfHintsProvider.java:114)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.processErrors(GsfHintsProvider.java:388)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.processErrorsRecursive(GsfHintsProvider.java:359)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.refreshErrors(GsfHintsProvider.java:327)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.access$200(GsfHintsProvider.java:79)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider$2.run(GsfHintsProvider.java:407)
>  at 
> org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:586)
>  at 
> org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:130)
>  at 
> org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:114)
>  at 
> org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:181)
>  at 
> org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:178)
>  at 
> org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
>  at 
> org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
>  at 
> org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
>  at 
> org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) 
> at 
> org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:178)Caused:
>  org.netbeans.modules.parsing.spi.ParseException at 
> org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:186)
>  at 
> org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:81)[catch]
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:405)
>  at 
> org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:79) 
> at 
> org.netbeans.modules.parsing.impl.TaskProcessor.callParserResultTask(TaskProcessor.java:561)
>  at 
> org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.run(TaskProcessor.java:786)
>  at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
> org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.execute(TaskProcessor.java:702)
>  at 
> org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:663)
>  at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) 
> at java.util.concurrent.FutureTask.run(FutureTask.java:266) at 
> org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418) at 
> org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:45) 
> at org.openide.util.lookup.Lookups.executeWith(Lookups.java:278) at 
> org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (NETBEANS-3932) java.lang.NullPointerExceptionjava GsfHintsProvider.computeErrors

2020-03-02 Thread bilu (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-3932?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

bilu updated NETBEANS-3932:
---
Description: 
Step to reproduce the problem:

Simply get the complete code from attached file or follow these steps:

1-Follow the tutorial: 
[https://platform.netbeans.org/tutorials/nbm-javacc-parser.html]
 * At this step run the project and you will get:  
java.lang.ClassCastException: org.simplejava.parser.SJParser$SJParserResult 
cannot be cast to org.netbeans.modules.csl.spi.ParserResult

2-Update SJParserResult class to extend o.n.m.csl.spi.ParserResult instead of 
o.n.m.parsing.spi.Parser.Result like suggest here  
[https://bz.apache.org/netbeans/show_bug.cgi?id=167064]

to fix precedent issue

3-Run the Project, you will get now :

java.lang.NullPointerExceptionjava.lang.NullPointerException at 
org.netbeans.modules.csl.hints.GsfHintsProvider.computeErrors(GsfHintsProvider.java:114)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrors(GsfHintsProvider.java:388)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrorsRecursive(GsfHintsProvider.java:359)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.refreshErrors(GsfHintsProvider.java:327)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.access$200(GsfHintsProvider.java:79)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider$2.run(GsfHintsProvider.java:407)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:586)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:130)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:114)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:181) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:178) 
at 
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
 at 
org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
 at 
org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
 at 
org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:178)Caused:
 org.netbeans.modules.parsing.spi.ParseException at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:186)
 at 
org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:81)[catch]
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:405) 
at 
org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:79) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor.callParserResultTask(TaskProcessor.java:561)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.run(TaskProcessor.java:786)
 at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.execute(TaskProcessor.java:702)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:663)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at 
java.util.concurrent.FutureTask.run(FutureTask.java:266) at 
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418) at 
org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:45) at 
org.openide.util.lookup.Lookups.executeWith(Lookups.java:278) at 
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)

 

 

  was:
Step to reproduce the problem:

1-Follow the tutorial: 
[https://platform.netbeans.org/tutorials/nbm-javacc-parser.html]

or get complete code source here: 
[https://github.com/vparfonov/api-samples/tree/master/nb-api-samples~api-samples/versions/7.2/tutorials/SimpleJava2]
 * At this step run the project and you will get:  
java.lang.ClassCastException: org.simplejava.parser.SJParser$SJParserResult 
cannot be cast to org.netbeans.modules.csl.spi.ParserResult

2-Update SJParserResult class to extend o.n.m.csl.spi.ParserResult instead of 
o.n.m.parsing.spi.Parser.Result like suggest here  
https://bz.apache.org/netbeans/show_bug.cgi?id=167064

to fix precedent issue

3-Run the Project, you will get now :

java.lang.NullPointerExceptionjava.lang.NullPointerException at 
org.netbeans.modules.csl.hints.GsfHintsProvider.computeErrors(GsfHintsProvider.java:114)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrors(GsfHintsProvider.java:388)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrorsRecursive(GsfHintsProvider.java:359)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.refreshErrors(GsfHintsProvider.java:327)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.access$200(GsfHintsProvider.java:79)
 at 

[jira] [Commented] (NETBEANS-2434) Can't install JIRA plugin

2020-03-02 Thread bilu (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17049342#comment-17049342
 ] 

bilu commented on NETBEANS-2434:


I have radar-netbeans *Version:* 3.2
*Source:* NetBeans Plugin Portal.

Which version do you have ?

> Can't install JIRA plugin
> -
>
> Key: NETBEANS-2434
> URL: https://issues.apache.org/jira/browse/NETBEANS-2434
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 9.0, 10.0, 11.0, 12.0, 11.1, 11.2
>Reporter: Ray Slater
>Priority: Major
> Attachments: extra.zip
>
>
> I'm trying to install the Jira plugin in Netbeans 11, but it fails to 
> download the REST client from atlassian:
> {noformat}
> SEVERE [org.netbeans.modules.autoupdate.ui.wizards.InstallStep]
> msg
> Caused: org.netbeans.api.autoupdate.OperationException[INSTALL]: Cannot 
> resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:768)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:642)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.access$600(InstallSupportImpl.java:73)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:153)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:125)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> [catch] at java.lang.Thread.run(Thread.java:745)
> There were some problems while storing JIRA REST Client.
> Cause: Cannot resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> {noformat}
> Searching threw up this old Bugzilla: 
> [https://netbeans.org/bugzilla/show_bug.cgi?id=244014]
> In that Bugzilla there are 2 links & the solution suggests that both would be 
> tried in a fixed version.
> For me, this link works: 
>  
> [https://maven.atlassian.com/content/repositories/atlassian-public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]
> but this link fails:
>  
> [https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-3932) java.lang.NullPointerExceptionjava GsfHintsProvider.computeErrors

2020-03-02 Thread bilu (Jira)
bilu created NETBEANS-3932:
--

 Summary: java.lang.NullPointerExceptionjava 
GsfHintsProvider.computeErrors
 Key: NETBEANS-3932
 URL: https://issues.apache.org/jira/browse/NETBEANS-3932
 Project: NetBeans
  Issue Type: Bug
  Components: editor - Hints  Annotations, editor - Parsing  
Indexing
Affects Versions: 11.1
 Environment: Product Version: Apache NetBeans IDE 11.1
Updates: NetBeans IDE is updated to version NetBeans 8.2 Patch 2
Java: 1.8.0_181; Java HotSpot(TM) 64-Bit Server VM 25.181-b13
Runtime: Java(TM) SE Runtime Environment 1.8.0_181-b13
System: Windows 10 version 10.0 running on amd64; Cp1252; en_US (nb)
User directory: C:\Users\\AppData\Roaming\NetBeans\11.1
Cache directory: C:\Users\\AppData\Local\NetBeans\Cache\11.1
Reporter: bilu


Step to reproduce the problem:

1-Follow the tutorial: 
[https://platform.netbeans.org/tutorials/nbm-javacc-parser.html]

or get complete code source here: 
[https://github.com/vparfonov/api-samples/tree/master/nb-api-samples~api-samples/versions/7.2/tutorials/SimpleJava2]
 * At this step run the project and you will get:  
java.lang.ClassCastException: org.simplejava.parser.SJParser$SJParserResult 
cannot be cast to org.netbeans.modules.csl.spi.ParserResult

2-Update SJParserResult class to extend o.n.m.csl.spi.ParserResult instead of 
o.n.m.parsing.spi.Parser.Result like suggest here  
https://bz.apache.org/netbeans/show_bug.cgi?id=167064

to fix precedent issue

3-Run the Project, you will get now :

java.lang.NullPointerExceptionjava.lang.NullPointerException at 
org.netbeans.modules.csl.hints.GsfHintsProvider.computeErrors(GsfHintsProvider.java:114)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrors(GsfHintsProvider.java:388)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.processErrorsRecursive(GsfHintsProvider.java:359)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.refreshErrors(GsfHintsProvider.java:327)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.access$200(GsfHintsProvider.java:79)
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider$2.run(GsfHintsProvider.java:407)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor.callUserTask(TaskProcessor.java:586)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:130)
 at 
org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:114)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:181) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor$2.call(TaskProcessor.java:178) 
at 
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:153)
 at 
org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:335)
 at 
org.netbeans.modules.parsing.nb.DataObjectEnvFactory.runPriorityIO(DataObjectEnvFactory.java:118)
 at 
org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:67) at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:178)Caused:
 org.netbeans.modules.parsing.spi.ParseException at 
org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:186)
 at 
org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:81)[catch]
 at 
org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:405) 
at 
org.netbeans.modules.csl.hints.GsfHintsProvider.run(GsfHintsProvider.java:79) 
at 
org.netbeans.modules.parsing.impl.TaskProcessor.callParserResultTask(TaskProcessor.java:561)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.run(TaskProcessor.java:786)
 at org.openide.util.lookup.Lookups.executeWith(Lookups.java:279) at 
org.netbeans.modules.parsing.impl.TaskProcessor$RequestPerformer.execute(TaskProcessor.java:702)
 at 
org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:663)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at 
java.util.concurrent.FutureTask.run(FutureTask.java:266) at 
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418) at 
org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:45) at 
org.openide.util.lookup.Lookups.executeWith(Lookups.java:278) at 
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)

 

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2434) Can't install JIRA plugin

2020-03-02 Thread bilu (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17049002#comment-17049002
 ] 

bilu commented on NETBEANS-2434:


Hello [~Irian], thanks you very much for sharing your workaround.

I have been able to get the plugins enable with the panel to enter Jira server 
URL and credentials. 

But the connection fail with a classcastException:

SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor 
org.netbeans.modules.jira.repository.JiraRepository$2SEVERE 
[org.openide.util.RequestProcessor]: Error in RequestProcessor 
org.netbeans.modules.jira.repository.JiraRepository$2java.lang.LinkageError: 
ClassCastException: attempting to 
castjar:file:/C:/Users/X/AppData/Roaming/NetBeans/11.1/modules/ext/org.radar.radar-netbeans/javax-ws-rs/javax.ws.rs-api.jar!/javax/ws/rs/ext/RuntimeDelegate.classtobundleresource://251.fwk1940656574:3/javax/ws/rs/ext/RuntimeDelegate.class
 at javax.ws.rs.ext.RuntimeDelegate.findDelegate(RuntimeDelegate.java:116) at 
javax.ws.rs.ext.RuntimeDelegate.getInstance(RuntimeDelegate.java:91) at 
javax.ws.rs.core.UriBuilder.newInstance(UriBuilder.java:69) at 
javax.ws.rs.core.UriBuilder.fromUri(UriBuilder.java:80) at 
com.atlassian.jira.rest.client.internal.jersey.JerseyJiraRestClient.(JerseyJiraRestClient.java:64)
 at 
com.atlassian.jira.rest.client.internal.jersey.JerseyJiraRestClientFactory.create(JerseyJiraRestClientFactory.java:39)
 at 
com.atlassian.connector.eclipse.internal.jira.core.service.rest.JiraRestClientAdapter.(JiraRestClientAdapter.java:159)
 at 

...

Hope this will be fixed soon. 
Regards

> Can't install JIRA plugin
> -
>
> Key: NETBEANS-2434
> URL: https://issues.apache.org/jira/browse/NETBEANS-2434
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 9.0, 10.0, 11.0, 12.0, 11.1, 11.2
>Reporter: Ray Slater
>Priority: Major
> Attachments: extra.zip
>
>
> I'm trying to install the Jira plugin in Netbeans 11, but it fails to 
> download the REST client from atlassian:
> {noformat}
> SEVERE [org.netbeans.modules.autoupdate.ui.wizards.InstallStep]
> msg
> Caused: org.netbeans.api.autoupdate.OperationException[INSTALL]: Cannot 
> resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:768)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:642)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.access$600(InstallSupportImpl.java:73)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:153)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:125)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> [catch] at java.lang.Thread.run(Thread.java:745)
> There were some problems while storing JIRA REST Client.
> Cause: Cannot resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> {noformat}
> Searching threw up this old Bugzilla: 
> [https://netbeans.org/bugzilla/show_bug.cgi?id=244014]
> In that Bugzilla there are 2 links & the solution suggests that both would be 
> tried in a fixed version.
> For me, this link works: 
>  
> [https://maven.atlassian.com/content/repositories/atlassian-public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]
> but this link fails:
>  
> [https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2434) Can't install JIRA plugin

2020-03-02 Thread bilu (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17049393#comment-17049393
 ] 

bilu commented on NETBEANS-2434:


Great. i am able to search and find issues. there is missing contents in the 
panel as you said. but this is a valuable workaround until i hope we get a 
proper integration later
Thank you very much

> Can't install JIRA plugin
> -
>
> Key: NETBEANS-2434
> URL: https://issues.apache.org/jira/browse/NETBEANS-2434
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 9.0, 10.0, 11.0, 12.0, 11.1, 11.2
>Reporter: Ray Slater
>Priority: Major
> Attachments: extra.zip
>
>
> I'm trying to install the Jira plugin in Netbeans 11, but it fails to 
> download the REST client from atlassian:
> {noformat}
> SEVERE [org.netbeans.modules.autoupdate.ui.wizards.InstallStep]
> msg
> Caused: org.netbeans.api.autoupdate.OperationException[INSTALL]: Cannot 
> resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:768)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:642)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.access$600(InstallSupportImpl.java:73)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:153)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:125)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> [catch] at java.lang.Thread.run(Thread.java:745)
> There were some problems while storing JIRA REST Client.
> Cause: Cannot resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> {noformat}
> Searching threw up this old Bugzilla: 
> [https://netbeans.org/bugzilla/show_bug.cgi?id=244014]
> In that Bugzilla there are 2 links & the solution suggests that both would be 
> tried in a fixed version.
> For me, this link works: 
>  
> [https://maven.atlassian.com/content/repositories/atlassian-public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]
> but this link fails:
>  
> [https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2434) Can't install JIRA plugin

2020-02-27 Thread bilu (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17046725#comment-17046725
 ] 

bilu commented on NETBEANS-2434:


Hello [~Irian], it will be very helpful.

I am desperate to have this plugin works on my Netbeans 11.1.

Thanks you in advance

> Can't install JIRA plugin
> -
>
> Key: NETBEANS-2434
> URL: https://issues.apache.org/jira/browse/NETBEANS-2434
> Project: NetBeans
>  Issue Type: Bug
>Affects Versions: 9.0, 10.0, 11.0, 12.0, 11.1, 11.2
>Reporter: Ray Slater
>Priority: Major
>
> I'm trying to install the Jira plugin in Netbeans 11, but it fails to 
> download the REST client from atlassian:
> {noformat}
> SEVERE [org.netbeans.modules.autoupdate.ui.wizards.InstallStep]
> msg
> Caused: org.netbeans.api.autoupdate.OperationException[INSTALL]: Cannot 
> resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:768)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.doDownload(InstallSupportImpl.java:642)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl.access$600(InstallSupportImpl.java:73)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:153)
> at 
> org.netbeans.modules.autoupdate.services.InstallSupportImpl$1.call(InstallSupportImpl.java:125)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> at 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> [catch] at java.lang.Thread.run(Thread.java:745)
> There were some problems while storing JIRA REST Client.
> Cause: Cannot resolve external reference to 
> https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar
> {noformat}
> Searching threw up this old Bugzilla: 
> [https://netbeans.org/bugzilla/show_bug.cgi?id=244014]
> In that Bugzilla there are 2 links & the solution suggests that both would be 
> tried in a fixed version.
> For me, this link works: 
>  
> [https://maven.atlassian.com/content/repositories/atlassian-public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]
> but this link fails:
>  
> [https://maven.atlassian.com/content/repositories/public/com/atlassian/jira/jira-rest-java-client/1.1-ide-m06/jira-rest-java-client-1.1-ide-m06.jar]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Created] (NETBEANS-5975) Git clone recursive submodules

2021-09-04 Thread bilu (Jira)
bilu created NETBEANS-5975:
--

 Summary: Git clone recursive submodules
 Key: NETBEANS-5975
 URL: https://issues.apache.org/jira/browse/NETBEANS-5975
 Project: NetBeans
  Issue Type: Improvement
Affects Versions: 12.4, 12.0
Reporter: bilu


{color:#1d1c1d}Netbeans git clone submodules 
{color}{color:#1d1c1d}{color:#1d1c1d}recursively {color}is 
not{color}{color:#1d1c1d} supported in 12.0 LTS. I checked also with latest 
12.4 same issue. 
 {color}

{color:#1d1c1d}Only first child submodules are found.{color}

{color:#1d1c1d}Exemple: this public git repo 
[https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}

{color:#1d1c1d}git submodule status --recursive
  bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
  00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 libndcrash/external/libcorkscrew-ndk 
(libcorkscrew_origin-8-g00654e8)
  7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
(libunwind_origin-9-g7baf912)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
  0717e9c849655f661ad303d8bff61ceb796505bd 
libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
 {color}

{color:#1d1c1d}But NB only found the first:{color}

{color:#1d1c1d}Output of the NB git clone action :
 {color}

==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
git init /home/xxx/NetBeansProjects/jndcrash
git fetch https://github.com/ivanarh/jndcrash 
+refs/heads/master:refs/remotes/origin/master
Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
Tag : r0.4
Result : NEW

Branch : origin/master
Old Id : null
New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
Result : NEW

Tag : r0.5
Result : NEW

Tag : r0.6
Result : NEW

Tag : r0.7
Result : NEW

Tag : r0.1
Result : NEW

Tag : r0.2
Result : NEW

Tag : r0.3
Result : NEW

Tag : r0.8
Result : NEW

setting up remote: origin
git branch --track master origin/master
git checkout master
git reset --hard master
git submodule status
git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.

Please enhance the Netbeans git integration to support recursive submodule 
clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Updated] (NETBEANS-5975) Git clone recursive submodules

2021-09-04 Thread bilu (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-5975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

bilu updated NETBEANS-5975:
---
Description: 
*{color:#1d1c1d}Description:{color}*

{color:#1d1c1d}Netbeans git clone submodules {color}{color:#1d1c1d}recursively 
{color}is not supported in 12.0 LTS. I checked also with latest 12.4 same 
issue. 

{color:#1d1c1d}Only first child submodules are found.{color}

{color:#1d1c1d}Exemple: this public git repo 
[https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}

{color:#1d1c1d}git submodule status --recursive
  bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
  00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 libndcrash/external/libcorkscrew-ndk 
(libcorkscrew_origin-8-g00654e8)
  7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
(libunwind_origin-9-g7baf912)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
  0717e9c849655f661ad303d8bff61ceb796505bd 
libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
 {color}

{color:#1d1c1d}But NB only found the first:{color}

{color:#1d1c1d}*Output of the NB git clone action :*
 {color}

==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
 ==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
 ==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
 git init /home/xxx/NetBeansProjects/jndcrash
 git fetch [https://github.com/ivanarh/jndcrash] 
+refs/heads/master:refs/remotes/origin/master
 Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
 Tag : r0.4
 Result : NEW

Branch : origin/master
 Old Id : null
 New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
 Result : NEW

Tag : r0.5
 Result : NEW

Tag : r0.6
 Result : NEW

Tag : r0.7
 Result : NEW

Tag : r0.1
 Result : NEW

Tag : r0.2
 Result : NEW

Tag : r0.3
 Result : NEW

Tag : r0.8
 Result : NEW

setting up remote: origin
 git branch --track master origin/master
 git checkout master
 git reset --hard master
 git submodule status
 git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
 git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
 ==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.

Please enhance the Netbeans git integration to support recursive submodule 
clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)

  was:
{color:#1d1c1d}Netbeans git clone submodules 
{color}{color:#1d1c1d}{color:#1d1c1d}recursively {color}is 
not{color}{color:#1d1c1d} supported in 12.0 LTS. I checked also with latest 
12.4 same issue. 
 {color}

{color:#1d1c1d}Only first child submodules are found.{color}

{color:#1d1c1d}Exemple: this public git repo 
[https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}

{color:#1d1c1d}git submodule status --recursive
  bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
  00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 libndcrash/external/libcorkscrew-ndk 
(libcorkscrew_origin-8-g00654e8)
  7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
(libunwind_origin-9-g7baf912)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
  0717e9c849655f661ad303d8bff61ceb796505bd 
libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
 {color}

{color:#1d1c1d}But NB only found the first:{color}

{color:#1d1c1d}Output of the NB git clone action :
 {color}

==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
git init /home/xxx/NetBeansProjects/jndcrash
git fetch https://github.com/ivanarh/jndcrash 
+refs/heads/master:refs/remotes/origin/master
Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
Tag : r0.4
Result : NEW

Branch : origin/master
Old Id : null
New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
Result : NEW

Tag : r0.5
Result : NEW

Tag : r0.6
Result : NEW

Tag : r0.7
Result : NEW

Tag : r0.1
Result : NEW

Tag : r0.2
Result : NEW

Tag : r0.3
Result : NEW

Tag : r0.8
Result : NEW

setting up remote: origin
git branch --track master origin/master
git checkout master
git reset --hard master
git submodule status
git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.

Please enhance the Netbeans git integration to support recursive submodule 
clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)


> Git clone recursive submodules
> --
>
> Key: NETBEANS-5975
> URL: 

[jira] [Updated] (NETBEANS-5975) Git clone recursive submodules

2021-09-04 Thread bilu (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-5975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

bilu updated NETBEANS-5975:
---
Description: 
*{color:#1d1c1d}Description:{color}*

{color:#1d1c1d}Netbeans git clone submodules {color}{color:#1d1c1d}recursively 
{color}is not supported in 12.0 LTS. I checked also with latest 12.4 same issue.

{color:#1d1c1d}Only first child submodules are found.{color}

{color:#1d1c1d}Exemple: this public git repo 
[https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}

{color:#1d1c1d}git submodule status --recursive
  bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
  00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 libndcrash/external/libcorkscrew-ndk 
(libcorkscrew_origin-8-g00654e8)
  7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
(libunwind_origin-9-g7baf912)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
  0717e9c849655f661ad303d8bff61ceb796505bd 
libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
 {color}

{color:#1d1c1d}But NB only found the first:{color}

{color:#1d1c1d}*Output of the NB git clone action :*
 {color}

==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
 ==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
 ==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
 git init /home/xxx/NetBeansProjects/jndcrash
 git fetch [https://github.com/ivanarh/jndcrash] 
+refs/heads/master:refs/remotes/origin/master
 Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
 Tag : r0.4
 Result : NEW

Branch : origin/master
 Old Id : null
 New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
 Result : NEW

Tag : r0.5
 Result : NEW

Tag : r0.6
 Result : NEW

Tag : r0.7
 Result : NEW

Tag : r0.1
 Result : NEW

Tag : r0.2
 Result : NEW

Tag : r0.3
 Result : NEW

Tag : r0.8
 Result : NEW

setting up remote: origin
 git branch --track master origin/master
 git checkout master
 git reset --hard master
 git submodule status
 git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
 git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
 ==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.

*Please enhance the Netbeans git integration to support recursive submodule 
clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)*

  was:
*{color:#1d1c1d}Description:{color}*

{color:#1d1c1d}Netbeans git clone submodules {color}{color:#1d1c1d}recursively 
{color}is not supported in 12.0 LTS. I checked also with latest 12.4 same 
issue. 

{color:#1d1c1d}Only first child submodules are found.{color}

{color:#1d1c1d}Exemple: this public git repo 
[https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}

{color:#1d1c1d}git submodule status --recursive
  bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
  00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 libndcrash/external/libcorkscrew-ndk 
(libcorkscrew_origin-8-g00654e8)
  7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
(libunwind_origin-9-g7baf912)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
  0717e9c849655f661ad303d8bff61ceb796505bd 
libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
  39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
 {color}

{color:#1d1c1d}But NB only found the first:{color}

{color:#1d1c1d}*Output of the NB git clone action :*
 {color}

==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
 ==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
 ==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
 git init /home/xxx/NetBeansProjects/jndcrash
 git fetch [https://github.com/ivanarh/jndcrash] 
+refs/heads/master:refs/remotes/origin/master
 Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
 Tag : r0.4
 Result : NEW

Branch : origin/master
 Old Id : null
 New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
 Result : NEW

Tag : r0.5
 Result : NEW

Tag : r0.6
 Result : NEW

Tag : r0.7
 Result : NEW

Tag : r0.1
 Result : NEW

Tag : r0.2
 Result : NEW

Tag : r0.3
 Result : NEW

Tag : r0.8
 Result : NEW

setting up remote: origin
 git branch --track master origin/master
 git checkout master
 git reset --hard master
 git submodule status
 git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
 git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
 ==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.

Please enhance the Netbeans git integration to support recursive submodule 
clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)


> Git clone recursive submodules
> --
>
> Key: NETBEANS-5975
>   

[jira] [Updated] (NETBEANS-5975) Git clone recursive submodules

2021-09-04 Thread bilu (Jira)


 [ 
https://issues.apache.org/jira/browse/NETBEANS-5975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

bilu updated NETBEANS-5975:
---
Component/s: versioncontrol - Git

> Git clone recursive submodules
> --
>
> Key: NETBEANS-5975
> URL: https://issues.apache.org/jira/browse/NETBEANS-5975
> Project: NetBeans
>  Issue Type: Improvement
>  Components: versioncontrol - Git
>Affects Versions: 12.0, 12.4
>Reporter: bilu
>Priority: Trivial
>
> *{color:#1d1c1d}Description:{color}*
> {color:#1d1c1d}Netbeans git clone submodules 
> {color}{color:#1d1c1d}recursively {color}is not supported in 12.0 LTS. I 
> checked also with latest 12.4 same issue. 
> {color:#1d1c1d}Only first child submodules are found.{color}
> {color:#1d1c1d}Exemple: this public git repo 
> [https://github.com/ivanarh/jndcrash] contains 6 submodules:{color}
> {color:#1d1c1d}git submodule status --recursive
>   bc1bd3491f5f58c3619e9fd0cf2884b15cef15f6 libndcrash (bc1bd34)
>   00654e8fcc51eb29f7e83fc0040f46ce268dc5d9 
> libndcrash/external/libcorkscrew-ndk (libcorkscrew_origin-8-g00654e8)
>   7baf9126235ee190d34ab24385dc1ea7d80dfa00 libndcrash/external/libunwind-ndk 
> (libunwind_origin-9-g7baf912)
>   39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
> libndcrash/external/libunwind-ndk/lzma (android-o-iot-preview-5)
>   0717e9c849655f661ad303d8bff61ceb796505bd 
> libndcrash/external/libunwindstack-ndk (libunwindstack_origin-129-g0717e9c)
>   39a0299cfdac41a2631cfdb4bbb637ffa66170fd 
> libndcrash/external/libunwindstack-ndk/lzma (android-o-iot-preview-5)
>  {color}
> {color:#1d1c1d}But NB only found the first:{color}
> {color:#1d1c1d}*Output of the NB git clone action :*
>  {color}
> ==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination...
>  ==[IDE]== 4 sept. 2021 à 13:09:10 Validating destination... finished.
>  ==[IDE]== 4 sept. 2021 à 13:09:10 Cloning
>  git init /home/xxx/NetBeansProjects/jndcrash
>  git fetch [https://github.com/ivanarh/jndcrash] 
> +refs/heads/master:refs/remotes/origin/master
>  Total 335 (delta 0), reused 0 (delta 0), pack-reused 335
>  Tag : r0.4
>  Result : NEW
> Branch : origin/master
>  Old Id : null
>  New Id : a283eb10fae54b01b084b4b8691fcb1deec9c03d
>  Result : NEW
> Tag : r0.5
>  Result : NEW
> Tag : r0.6
>  Result : NEW
> Tag : r0.7
>  Result : NEW
> Tag : r0.1
>  Result : NEW
> Tag : r0.2
>  Result : NEW
> Tag : r0.3
>  Result : NEW
> Tag : r0.8
>  Result : NEW
> setting up remote: origin
>  git branch --track master origin/master
>  git checkout master
>  git reset --hard master
>  git submodule status
>  git submodule initialize /home/xxx/NetBeansProjects/jndcrash/libndcrash
>  git submodule update /home/xxx/NetBeansProjects/jndcrash/libndcrash
>  ==[IDE]== 4 sept. 2021 à 13:09:18 Cloning finished.
> Please enhance the Netbeans git integration to support recursive submodule 
> clone as other IDEs (IntelliJ, VSCode, Android Studio etc...)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists