[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-11-07 Thread Joern (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16969912#comment-16969912
 ] 

Joern commented on NETBEANS-2415:
-

When nb-javac is installed, refactoring fails (NETBEANS-3257), if uninstalled, 
Wildfly copy static resources on save does not work (NETBEANS-3328). So I have 
to stick to NB11.1 for the moment - probably until  NETBEANS-3257 is resolved. 

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
> Attachments: image-2019-10-02-23-28-48-638.png, 
> image-2019-10-02-23-29-11-140.png
>
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-11-07 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16969410#comment-16969410
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

New plugin works in NB 11.2, bit has to be downloaded manually, I hope it will 
soon appear in Plugins installer insid IDE. Other than that I'm finally happy. 
I think it won't work in 11.0 or 11.1.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
> Attachments: image-2019-10-02-23-28-48-638.png, 
> image-2019-10-02-23-29-11-140.png
>
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-10-02 Thread Pedro Silva (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16943209#comment-16943209
 ] 

Pedro Silva commented on NETBEANS-2415:
---

I have installed NetBeans 11.0 LTS and the Wildfly Plugin for 11.0 (plugin 
v2.0). I'm getting the JAVA_EE_8_FULL error too.

!image-2019-10-02-23-29-11-140.png!

Is there a workaround for this ? Thanks !

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
> Attachments: image-2019-10-02-23-28-48-638.png, 
> image-2019-10-02-23-29-11-140.png
>
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-10-02 Thread T Gergely (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16942792#comment-16942792
 ] 

T Gergely commented on NETBEANS-2415:
-

Yes, I use 11.0 LTS. I patched the class files, not to reference 
JAVA_EE_8_FULL, but I have another problem: Run (F6) redeploys twice. (_Always 
perform build before running application_ is not enabled.)

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-25 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16937576#comment-16937576
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

The problem was Geertjan's comment:
{quote}
http://plugins.netbeans.org/plugin/76472/wildfly-application-server
Works perfectly fine in 11.0 and later. Take a moment and try it, please.
{quote}
...so I tried to install it into 11.0 which was working for me for a long time 
with 8.2 plugin (couldn't switch to 11.1 because 8.2 plugin didn't work in it 
at all). Perhaps T Gergely also used 11.0.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-25 Thread Emmanuel Hugonnet (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16937569#comment-16937569
 ] 

Emmanuel Hugonnet commented on NETBEANS-2415:
-

[~TGergely]Could you tell me which version of Apache NetBeans you are using ? 
Looking at the code JAVA_EE_8_FULL was introduced in July and is in 11.1 code 
base so it shouldn't be an issue

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-16 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16930816#comment-16930816
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

T Gergely, thanks for reporting this. I was in a hurry to do my job and failed 
to record the stack trace.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-16 Thread Emmanuel Hugonnet (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16930539#comment-16930539
 ] 

Emmanuel Hugonnet commented on NETBEANS-2415:
-

Maybe this is due to the fact that I built against master. i'll try to see what 
happens with the 11.x branch

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-16 Thread T Gergely (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16930500#comment-16930500
 ] 

T Gergely commented on NETBEANS-2415:
-

I've had the same ”no properties pane” and ”stuck initializing" problems with 
NetBeans 11. Here's the cause:
{quote}java.lang.NoClassDefFoundError: Could not initialize class 
org.netbeans.modules.javaee.wildfly.ide.WildflyJ2eePlatformFactory$J2eePlatformImplImpl
 at 
org.netbeans.modules.javaee.wildfly.ide.WildflyJ2eePlatformFactory.getJ2eePlatformImpl(WildflyJ2eePlatformFactory.java:86)
{quote}
caused by
{quote}java.lang.NoSuchFieldError: *JAVA_EE_8_FULL*
at 
org.netbeans.modules.javaee.wildfly.ide.WildflyJ2eePlatformFactory$J2eePlatformImplImpl.(WildflyJ2eePlatformFactory.java:111)
{quote}

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925608#comment-16925608
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

Well, if it works with 11.0, that's fine, that's the latest LTS release.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925601#comment-16925601
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

Will have to skip a version or two before the effort to migrate will again be 
justified. 10.0 and 11.0 did work with NB 8.2 WildFly plugin, 11.1 didn't, so 
had to go back to 11.0.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925594#comment-16925594
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

So use 11.1, the latest release, with the plugin provided above, i.e., created 
on Friday. The Properties window works fine for me, just tried it, no problem 
at all.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925585#comment-16925585
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

NetBeans 11.0, Linux Mint 19.2 Tina 64-bit.

Had to recreate userdir two weeks ago, after failed attempt to upgrade to NB 
11.1. Since I have to do it again, I'll go back to NB 8.2, since I can't afford 
any more disruptions in my work. Sorry that I can't be of more help, but I have 
deadlines.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925578#comment-16925578
 ] 

Tomáš Poledný commented on NETBEANS-2415:
-

Hi the plugin from the plugins site works to me. But first I had to remove 
Wildfly from Servers (because I had some old plugin for Wildfly) and add it 
again. Thank you guys it was huge pain for me after Netbeans 8.2. No I can show 
to people again how easy is developing Java EE (Jakarta EE) with Netbeans.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925577#comment-16925577
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

https://mobile.twitter.com/netbeans/status/1170974478639280130

That’s a pic of the latest WildFly running thanks to the plugin above in 11.1 
this morning on Mac OS X.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925574#comment-16925574
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

Please use the plugin that I pointed to above in 11.1, it is the latest version 
of the plugin, created and uploaded on Friday.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Hans Adler (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925572#comment-16925572
 ] 

Hans Adler commented on NETBEANS-2415:
--

I did try the easier work-around and found that NetBeans couldn't deploy that 
way (kept compiling the project instead) and never showed WildFly as running 
although it had started it successfully. After this experience I found out that 
it's a known Bug of the 8.0 plugin. I have linked to the bug report above. It 
was fixed for 8.2.

Maybe the bug doesn't affect all users, so the NBM route is worth a try. If you 
run into problems you can still uninstall the NBM and do what I described.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925571#comment-16925571
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

When clicked and nothing happens, maybe you see an error message that you can 
share here. Also, we need to know the version of NetBeans and the operating 
system you’re using.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925569#comment-16925569
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

Which version of NetBeans, which operating system? Best to start with a fresh 
userdir, then install the above plugin (which was created end of last week, so 
it is new) and then open your projects again. Any problems, please describe 
them in a way that they can be reproduced.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925565#comment-16925565
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

{quote}
Can you explain what that means? And steps to reproduce?
{quote}
Right cliking on Wildfly Application Server node in Services tab displays popup 
menu. Last item is "Properties". Nothing happens when clicked.


> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925563#comment-16925563
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

Also, many of my projects in project tree are now stuck with "initializing 
projects" node :(

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925562#comment-16925562
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

Can you explain what that means? And steps to reproduce?

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Jira


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925557#comment-16925557
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

Properties window doesn't appear when using that plugin.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925546#comment-16925546
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

http://plugins.netbeans.org/plugin/76472/wildfly-application-server

Works perfectly fine in 11.0 and later. Take a moment and try it, please.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-09 Thread Hans Adler (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16925539#comment-16925539
 ] 

Hans Adler commented on NETBEANS-2415:
--

I would recommend not to follow Geertjan Wielenga's advice to download and 
install the NBM for NetBeans 8.0 as described by Rik Giepmann. It has a known 
bug that prevents deployment via NetBeans. The bug was fixed in NetBeans 8.2, 
but since this was part of the core functionality in 8.2, there is no NBM to 
download.

See my post above for what needs to be done instead on Linux to transfer the 
plugin manually from NetBeans 8.2 to NetBeans 11. On other operating systems it 
will be similar. Maybe someone wants to post a similar procedure for Windows 
for everyone's convenience.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-04 Thread Geertjan Wielenga (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16922621#comment-16922621
 ] 

Geertjan Wielenga commented on NETBEANS-2415:
-

Read the above, download the NBM and install it into 11.1:

https://www.dropbox.com/s/w4pe1btxxxd2fkv/org-netbeans-modules-javaee-wildfly.nbm?dl=0

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-09-04 Thread Tom Eicher (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16922617#comment-16922617
 ] 

Tom Eicher commented on NETBEANS-2415:
--

so how do we get this to work for everybody ?

(I'm working in NB 8.2 right now. it's a long time...)

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-08-30 Thread Joern (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16919561#comment-16919561
 ] 

Joern commented on NETBEANS-2415:
-

The version works quite well - I was finally able to switch to NB 11.1. Thanks 
so for the effort! How do we handle bug reports? Create a new issue and link to 
this one? 

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-08-20 Thread Emmanuel Hugonnet (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16911262#comment-16911262
 ] 

Emmanuel Hugonnet commented on NETBEANS-2415:
-

Partly, as it still depends on old DTDs which are LGPL.


> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-08-20 Thread Tom Eicher (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16911245#comment-16911245
 ] 

Tom Eicher commented on NETBEANS-2415:
--

but, have the "licensing issues" been resolved around this ?

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Assignee: Emmanuel Hugonnet
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-08-19 Thread Emmanuel Hugonnet (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16910697#comment-16910697
 ] 

Emmanuel Hugonnet commented on NETBEANS-2415:
-

you can try and build https://github.com/ehsavoie/netbeans/tree/wildfly 

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-08-19 Thread Hans Adler (Jira)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16910582#comment-16910582
 ] 

Hans Adler commented on NETBEANS-2415:
--

I tried the workaround described by Rik Giepmann, but couldn't get it to work. 
NetBeans does not recognise that Wildfly is running, and tries to start it 
again. This prevents deployment. I think this is due to a known bug of the 8.0 
plugin. See [https://netbeans.org/bugzilla/show_bug.cgi?id=262252] .

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-06-08 Thread JIRA


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16859309#comment-16859309
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

Isn't that one for 8.0, even older than the version included in 8.2?

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-06-07 Thread Rik Giepmann (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16859118#comment-16859118
 ] 

Rik Giepmann commented on NETBEANS-2415:


Workaround available:
Download from  
[http://plugins.netbeans.org/plugin/5/wildfly-application-server]  and 
install manualy

 

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-05-17 Thread JIRA


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16841992#comment-16841992
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

Interesting, when I have enabled (by default it's ignored) the wildfly module 
to compile there was an error. But then I'm not an expert at building NetBeans.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-05-17 Thread Emmanuel Hugonnet (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16841981#comment-16841981
 ] 

Emmanuel Hugonnet commented on NETBEANS-2415:
-

hello, I just built it this morning without any changes.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-04-23 Thread JIRA


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16823799#comment-16823799
 ] 

Dominik Derwiński commented on NETBEANS-2415:
-

But besides license, there is still the problem that it doesn't compile.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists



[jira] [Commented] (NETBEANS-2415) Bring back support for WildFly server

2019-04-19 Thread Laszlo Kishalmi (JIRA)


[ 
https://issues.apache.org/jira/browse/NETBEANS-2415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16822355#comment-16822355
 ] 

Laszlo Kishalmi commented on NETBEANS-2415:
---

AFAIK, there are license issues with that plugin. We have a contributor from 
them who tries to push the management to provide the wildfly plugin stuff with 
an Apache compatible license. If that does not work out the plugin might need 
to move to an external portal.

> Bring back support for WildFly server
> -
>
> Key: NETBEANS-2415
> URL: https://issues.apache.org/jira/browse/NETBEANS-2415
> Project: NetBeans
>  Issue Type: Wish
>  Components: serverplugins - WildFly
>Affects Versions: 11.0
> Environment: n.a.
>Reporter: Dominik Derwiński
>Priority: Minor
>
> NetBeans 8.2 had WildFly server module, which helped greatly in debugging 
> Java EE applications directly from IDE. NetBeans 11.0 does not contain this 
> module, despite boasting to be the first version of Apache NetBeans to offer 
> full support for developing Java EE applications.
> I don't think it would be very hard to bring back WildFly server module 
> (currently it does not complile), because copying files of the module from 
> NetBeans 8.2 into NetBeans 11.0 installation, and recreating userdir is 
> enough to bring back that functionality (so the old module still works, but 
> for how long?).
> The files I have copied (after removing references to localization files) are:
>  * enterprise/config/Modules/org-netbeans-modules-javaee-wildfly.xml
>  * enterprise/modules/org-netbeans-modules-javaee-wildfly.jar
>  * enterprise/update_tracking/org-netbeans-modules-javaee-wildfly.xml
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: commits-unsubscr...@netbeans.apache.org
For additional commands, e-mail: commits-h...@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists