Author: stsp
Date: Thu Jul 28 17:51:08 2011
New Revision: 1151939

URL: http://svn.apache.org/viewvc?rev=1151939&view=rev
Log:
* subversion/libsvn_wc/wc_db.c
  (op_delete_txn): Remove local variable IS_VALID_MOVED_TO_RELPATH which
   I added in r1151824 but should have just left out. Its name is misleading,
   its purpose is bogus, and it was always TRUE in the code path where it
   was checked.

Modified:
    subversion/trunk/subversion/libsvn_wc/wc_db.c

Modified: subversion/trunk/subversion/libsvn_wc/wc_db.c
URL: 
http://svn.apache.org/viewvc/subversion/trunk/subversion/libsvn_wc/wc_db.c?rev=1151939&r1=1151938&r2=1151939&view=diff
==============================================================================
--- subversion/trunk/subversion/libsvn_wc/wc_db.c (original)
+++ subversion/trunk/subversion/libsvn_wc/wc_db.c Thu Jul 28 17:51:08 2011
@@ -6033,7 +6033,6 @@ op_delete_txn(void *baton,
   svn_sqlite__stmt_t *stmt;
   apr_int64_t select_depth; /* Depth of what is to be deleted */
   svn_boolean_t refetch_depth = FALSE;
-  svn_boolean_t is_valid_moved_to_relpath = TRUE;
 
   SVN_ERR(svn_sqlite__exec_statements(wcroot->sdb, STMT_CREATE_DELETE_LIST));
 
@@ -6096,9 +6095,6 @@ op_delete_txn(void *baton,
                                     moved_from_relpath, b->moved_to_relpath));
           SVN_ERR(svn_sqlite__step_done(stmt));
           SVN_ERR(svn_sqlite__reset(stmt));
-
-          /* Make the delete processing below ignore moved-to info. */
-          is_valid_moved_to_relpath = FALSE;
         }
     }
 
@@ -6169,7 +6165,7 @@ op_delete_txn(void *baton,
       /* Delete the node at LOCAL_RELPATH, and possibly mark it as moved. */
       SVN_ERR(svn_sqlite__get_statement(&stmt, wcroot->sdb,
                                  STMT_INSERT_DELETE_NODE));
-      if (b->moved_to_relpath && is_valid_moved_to_relpath)
+      if (b->moved_to_relpath)
         SVN_ERR(svn_sqlite__bindf(stmt, "isiis",
                                   wcroot->wc_id, local_relpath,
                                   select_depth, b->delete_depth,


Reply via email to