[jira] [Resolved] (HADOOP-15128) TestViewFileSystem tests are broken in trunk

2018-01-02 Thread Arpit Agarwal (JIRA)

 [ 
https://issues.apache.org/jira/browse/HADOOP-15128?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Arpit Agarwal resolved HADOOP-15128.

Resolution: Not A Problem

Reverted HADOOP-10054, let's make the right fix there.

> TestViewFileSystem tests are broken in trunk
> 
>
> Key: HADOOP-15128
> URL: https://issues.apache.org/jira/browse/HADOOP-15128
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: viewfs
>Affects Versions: 3.1.0
>Reporter: Anu Engineer
>Assignee: Hanisha Koneru
>
> The fix in Hadoop-10054 seems to have caused a test failure. Please take a 
> look. Thanks [~eyang] for reporting this.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org



Apache Hadoop qbt Report: branch2+JDK7 on Linux/x86

2018-01-02 Thread Apache Jenkins Server
For more details, see 
https://builds.apache.org/job/hadoop-qbt-branch2-java7-linux-x86/92/

[Jan 2, 2018 5:51:48 AM] (jitendra) HADOOP-15143. NPE due to Invalid 
KerberosTicket in UGI. Contributed by


[Error replacing 'FILE' - Workspace is not accessible]

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org

Apache Hadoop qbt Report: trunk+JDK8 on Linux/x86

2018-01-02 Thread Apache Jenkins Server
For more details, see 
https://builds.apache.org/job/hadoop-qbt-trunk-java8-linux-x86/644/

No changes


[Error replacing 'FILE' - Workspace is not accessible]

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org

[jira] [Created] (HADOOP-15155) Typo in javadoc of ReconfigurableBase#reconfigureProperty

2018-01-02 Thread Ajay Kumar (JIRA)
Ajay Kumar created HADOOP-15155:
---

 Summary: Typo in javadoc of ReconfigurableBase#reconfigureProperty
 Key: HADOOP-15155
 URL: https://issues.apache.org/jira/browse/HADOOP-15155
 Project: Hadoop Common
  Issue Type: Bug
Reporter: Ajay Kumar
Assignee: Ajay Kumar
Priority: Minor


There is a typo in javadoc of reconfigureProperty#reconfigurePropertyImpl

{code}
   * This method cannot be overridden, subclasses should instead override
   * reconfigureProperty.
{code}
should change to
{code}
   * This method cannot be overridden, subclasses should instead override
   * reconfigurePropertyImpl.
{code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org



[jira] [Created] (HADOOP-15154) Abstract new method assertCapability for StreamCapabilities testing

2018-01-02 Thread Xiao Chen (JIRA)
Xiao Chen created HADOOP-15154:
--

 Summary: Abstract new method assertCapability for 
StreamCapabilities testing
 Key: HADOOP-15154
 URL: https://issues.apache.org/jira/browse/HADOOP-15154
 Project: Hadoop Common
  Issue Type: Improvement
  Components: test
Reporter: Xiao Chen
Priority: Minor


>From Steve's 
>[comment|https://issues.apache.org/jira/browse/HADOOP-15149?focusedCommentId=16306806=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16306806]:
bq.  it'd have been cleaner for the asserts to have been one in a 
assertCapability(key, StreamCapabilities subject, bool outcome) and had it 
throw meaningful exceptions on a failure

We can consider abstract such a method to a test util class and use it for all 
{{StreamCapabilities}} tests as needed.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org



[jira] [Resolved] (HADOOP-15147) SnappyCompressor Typo

2018-01-02 Thread BELUGA BEHR (JIRA)

 [ 
https://issues.apache.org/jira/browse/HADOOP-15147?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

BELUGA BEHR resolved HADOOP-15147.
--
Resolution: Not A Problem

It sure confused me! Sorry! :)

> SnappyCompressor Typo
> -
>
> Key: HADOOP-15147
> URL: https://issues.apache.org/jira/browse/HADOOP-15147
> Project: Hadoop Common
>  Issue Type: Improvement
>  Components: common
>Affects Versions: 3.0.0
>Reporter: BELUGA BEHR
>Priority: Trivial
>
> {code:title=SnappyCompressor.java}
>   public boolean finished() {
> // Check if all uncompressed data has been consumed
> return (finish && finished && compressedDirectBuf.remaining() == 0);
>   }
> {code}
> Notice "finish" is checked twice



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org



[jira] [Created] (HADOOP-15153) [branch-2.8] Increase heap memory to avoid the OOM in pre-commit

2018-01-02 Thread Brahma Reddy Battula (JIRA)
Brahma Reddy Battula created HADOOP-15153:
-

 Summary: [branch-2.8] Increase heap memory to avoid the OOM in 
pre-commit
 Key: HADOOP-15153
 URL: https://issues.apache.org/jira/browse/HADOOP-15153
 Project: Hadoop Common
  Issue Type: Bug
  Components: build
Reporter: Brahma Reddy Battula


Refernce:
https://builds.apache.org/job/PreCommit-HDFS-Build/22528/consoleFull
https://builds.apache.org/job/PreCommit-HDFS-Build/22528/artifact/out/branch-mvninstall-root.txt

{noformat}
[ERROR] unable to create new native thread -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e 
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please 
read the following articles:
[ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/OutOfMemoryError
{noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org



[jira] [Created] (HADOOP-15152) Typo in javadoc of ReconfigurableBase#reconfigurePropertyImpl

2018-01-02 Thread Nanda kumar (JIRA)
Nanda kumar created HADOOP-15152:


 Summary: Typo in javadoc of 
ReconfigurableBase#reconfigurePropertyImpl
 Key: HADOOP-15152
 URL: https://issues.apache.org/jira/browse/HADOOP-15152
 Project: Hadoop Common
  Issue Type: Bug
  Components: common
Reporter: Nanda kumar
Assignee: Nanda kumar
Priority: Trivial


There is a typo in javadoc of ReconfigurableBase#reconfigurePropertyImpl

{code}
   * Subclasses must override this. This method applies the change to
   * all internal data structures derived from the configuration property
   * that is being changed. If this object owns other Reconfigurable objects
   * reconfigureProperty should be called recursively to make sure that
   * to make sure that the configuration of these objects is updated.
{code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: common-dev-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-dev-h...@hadoop.apache.org