Re: OT: Ubuntu phone HTML5 / QML

2015-03-16 Thread Francesco De Vita
Hi

 I'm using since 2008 the FR as my one and only cellphone. This is not
 lying, it is just a fact. And I do not know any other person from
 this list who is doing so. I will continue using the GTA02 until
 finaly breaks something, display or board, and will hope to update
 it. How and when such an update is possible?

I did it too until the last summer when audio and battery issues became 
an inconvenience during my work days. I searched for help but with no 
success. Since then I'm using some dumbphones.

If I should buy a new phone my choice is restricted to the GTA04, the 
Jolla phone and the Ubuntu phone. But a budget limit and the readiness 
of the device for the everyday usage constitute constraints to reckon 
with.

Is good to see some life in this ML (: thank you all.

Ciao
Francesco

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: GTA02 broken screen / What Nice Projekts to Do Without a Screen or Would Other Screens Work

2014-05-10 Thread Francesco De Vita

 If you think this is something you would like to try, please let me
 know, so i can provide you with the kernel and the rootfs image for you
 to flash.
 You need to write some scripts to fit everything to your needs, so i
 hope you have some scripting skills.

Probably I do not have the required skills but it is really interesting!
Have you already mention your work in the ML or in the Wiki? I'm sure it
deserves to be noted, I was looking for this kind of application from years.

Do you think your daemon could be easily integrated in QtMoko or other OS?

Best regards
Francesco

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: GTA02 broken screen / What Nice Projekts to Do Without a Screen or Would Other Screens Work

2014-05-07 Thread Francesco De Vita
 You could use the freerunner as a SMS gateway, you don't need a screen
 for that.
 That is something i use, i can send a text message and perform some action
 (switching lights on or off )
 Or have a text message send to my other phone if a long running job is
 done.

Would you like to explain how do you do that? (:

Regards
Francesco

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] new svg keyboard

2014-02-21 Thread Francesco De Vita
 your new keyboard is absolutely amazing, thanks a lot.
you're welcome (:

 There is only one small problem: it does not work well with x11vnc: it
 seems that the keys are not mapped or, in some case, not mapped correctly.

Actually I never thought it could work with x11vnc. I think we should
compare the different values between the x11vnc application and the
keyboard. Do you have any hints or details about the key mapping?

Ciao
Joif



___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


[QtMoko] new svg keyboard

2013-12-28 Thread Francesco De Vita
Hello everybody
I took advantage of the holidays and I made a new SVG keyboard, cute,
only qwerty, not so finger friendly but nailstylus friendly for sure.

Why I did that?
- no matter what, the Freerunner screen it is what it is (not so finger
friendly)
- no existing finger friendly keyboard suits my fingers
- I only use qwerty
- I wanted a better looking keyboard

Screenshots here [1], here [2], here [3] and here [4].

It is a replacement for the existing svgkbd, if you want to try it make
sure to backup the contents in /opt/qtmoko/etc/im/svgkbd/ and then
copy-past there the files in the archive [5] (don't wget it, it couldn't
work with dropbox). Restart QtMoko and enjoy.

For now the keyboard is designed for the italian language. If you're not
able to DIY and want a help for a different character set, I could help
on request.

Happy holidays and happy new year!
Joif

[1] https://www.dropbox.com/sh/5d5v33v4va2j5z9/RDIsCK-WpG/svg1.png
[2] https://www.dropbox.com/sh/5d5v33v4va2j5z9/W-V1dpphZe/svg2.png
[3] https://www.dropbox.com/sh/5d5v33v4va2j5z9/0aVKRpdmc1/svg3.png
[4] https://www.dropbox.com/sh/5d5v33v4va2j5z9/eUx_oAcuat/svg4.png
[5] https://www.dropbox.com/sh/5d5v33v4va2j5z9/CY3sKbPjnP/svgkbd.tar.gz

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: 2.6.39 failed resume

2013-12-22 Thread Francesco De Vita
 i am now running 2.6.39 on my Freerunner for 7days. It works well, except 
 that 
 3 times it failed to resume, or something like that. The symptom is that 
 after 
 pressing POWER button it does not react. I tried to make a call to my number 
 and it was not ringing the voice told me that my number is not responding. I 
 also tried long POWER button press - but it was not reacting. And last thing 
 i 
 tried to plub USB cable, but no response.
 
 Anyone else seen this too? I am using QtMoko v58

Yep, same here, QtMoko v58. I'm using my Freerunner as a daily phone and
it failed to resume at least once in a day in the past week.
Deep sleep is disabled, and the Power Management settings should not
give any problems.

Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v58 with 2.6.39 kernel and improved power management

2013-12-19 Thread Francesco De Vita
 So the question is : is it possible to have button order as below
 when the call is answered ?
 
 --
 | Hold | Hang up |
 --
 
 So, if I touch twice the Answer button, I just hold the call and
 I'll be able to take it back easier.
Maybe you can simply switch their positions, take a look at
/opt/qtmoko/etc/themes/mokofaen/callscreen.xml lines 108-129.
And it is not a bad idea, because the actual positions of the Hang up
button are inconsistent: if you're receiving a call the Hang Up is on
the right, but if you're in a call it is on the left.
Well, I'll try it myself tomorrow! ;)

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [gta02] cannot boot from NAND

2013-12-14 Thread Francesco De Vita
Thank you Radek, the jffs2 image works on NAND!
But, as happened for the uSD version, the system stops at the PIN
screen. However, as you suggested, enabling the modem logging solves the
problem.

Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [gta02] cannot boot from NAND

2013-12-13 Thread Francesco De Vita

 882cc204627226ffefda4e446fae3862 qtmoko-debian-gta02-v58.tar.gz
 
 a76072c1c9dce4eb2b07235f7cc307fe qtmoko-debian-gta02-v58.ubi
 
 50baec96657802b5a053fa0ef6b777a2 uImage.bin-2.6.39-qtmoko-v58
 
checksum ok

 This is strange - it works for me. Are you booting with qi-v58.udfu?
Yep, I also reflashed qi-v56 but the problem persists

Is  the tarball ok at least?
I'll try it soon

Regards
Joif




___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [gta02] cannot boot from NAND

2013-12-13 Thread Francesco De Vita

 Is the tarball ok at least?

Tested on the uSD and it is ok
...apart that I'm stuck at the PIN entry screen (that one with just the
notice Please wait...) no matter how many times I restart. But from
ssh all seems to work well.

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v58 with 2.6.39 kernel and improved power management

2013-12-12 Thread Francesco De Vita
Awesome! great job! I'll try it out immediately (:

Thank you guys!

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v58 with 2.6.39 kernel and improved power management

2013-12-12 Thread Francesco De Vita
Ehr... I have these ugly errors during the boot:

UBI error: process_eb: bad image sequence number 1588845893 in PEB 1971,
epxected 1933142073
slab error in kmem_cache_destroy(): cache `ubi_scan_slab': Can't free
all objects
UBI error: ubi_init: cannot attach mtd6
Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)
[c002b0f0] (unwind_backtrace+0x0/0xf0) from [c02aba94]
(panic+0x58/0x174)
[c02aba94] (panic+0x58/0x174) from [c0008cc0]
(mount_block_root+0x1d4/0x294)
[c0008cc0] (mount_block_root+0x1d4/0x294) from [c0008f6c]
(prepare_namespace+0x8c/0x1c8)
[c0008f6c] (prepare_namespace+0x8c/0x1c8) from [c00089b4]
(kernel_init+0xfc/0x130)
[c00089b4] (kernel_init+0xfc/0x130) from [c0027730]
(kernel_thread_exit+0x0/0x8)

I reflashed the v55 and there is not such issue.

Regards
Joif

  * Russo - rilevata
  * Inglese
  * Italiano
  * Russo
  * Francese
  * Tedesco
  * Spagnolo

  * Inglese
  * Italiano
  * Russo
  * Francese
  * Tedesco
  * Spagnolo

 javascript:void(0);

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v58 with 2.6.39 kernel and improved power management

2013-12-12 Thread Francesco De Vita
Sorry for the previous message, it seems that I'm not able to boot any
more from NAND :(

 Ehr... I have these ugly errors during the boot:
 
 UBI error: process_eb: bad image sequence number 1588845893 in PEB 1971,
 epxected 1933142073
 slab error in kmem_cache_destroy(): cache `ubi_scan_slab': Can't free
 all objects
 UBI error: ubi_init: cannot attach mtd6
 Kernel panic - not syncing: VFS: Unable to mount root fs on
 unknown-block(0,0)
 [c002b0f0] (unwind_backtrace+0x0/0xf0) from [c02aba94]
 (panic+0x58/0x174)
 [c02aba94] (panic+0x58/0x174) from [c0008cc0]
 (mount_block_root+0x1d4/0x294)
 [c0008cc0] (mount_block_root+0x1d4/0x294) from [c0008f6c]
 (prepare_namespace+0x8c/0x1c8)
 [c0008f6c] (prepare_namespace+0x8c/0x1c8) from [c00089b4]
 (kernel_init+0xfc/0x130)
 [c00089b4] (kernel_init+0xfc/0x130) from [c0027730]
 (kernel_thread_exit+0x0/0x8)







___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


[gta02] cannot boot from NAND

2013-12-12 Thread Francesco De Vita
Hello
Flashing QtMoko v58 I discovered that I'm not able to boot any more
from NAND. This is what I receive after pressing the power button:

UBI error: process_eb: bad image sequence number 1588845893 in PEB 1971,
epxected 1933142073
slab error in kmem_cache_destroy(): cache `ubi_scan_slab': Can't free
all objects
UBI error: ubi_init: cannot attach mtd6
Kernel panic - not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)
[c002b0f0] (unwind_backtrace+0x0/0xf0) from [c02aba94]
(panic+0x58/0x174)
[c02aba94] (panic+0x58/0x174) from [c0008cc0]
(mount_block_root+0x1d4/0x294)
[c0008cc0] (mount_block_root+0x1d4/0x294) from [c0008f6c]
(prepare_namespace+0x8c/0x1c8)
[c0008f6c] (prepare_namespace+0x8c/0x1c8) from [c00089b4]
(kernel_init+0xfc/0x130)
[c00089b4] (kernel_init+0xfc/0x130) from [c0027730]
(kernel_thread_exit+0x0/0x8)

With v55 it seems to boot correctly but the process stops after the
first configuration, and rebooting gives just a black screen.
With v56 I have similar errors like above.

Any hints on what's going on? I'm so sad...

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] landscape mode under QX

2011-09-14 Thread Francesco De Vita
Hi!
I found a workaround to use apps under qx and in a usable landscape mode.
You have to make a simple script but:
- you have to launch it within xterm with matchbox (+ virtual keyboard);
- the screen flickers a little (very little, it is usable), I think I have
to set a proper screen refresh rate but I didn't manage to get it yet;

example:

 #!/bin/sh
 killall matchbox-keyboard
 xrandr -o 1
 xinput set-int-prop Touchscreen Evdev Axis Inversion 8 0 1
 xinput set-int-prop Touchscreen Evdev Axes Swap 8 0
 xinput set-int-prop Touchscreen Evdev Axis Calibration 32 98 911 918
107

 YOUR_APP_HERE

 xrandr -o normal
 xinput set-int-prop Touchscreen Evdev Axis Inversion 8 0 0
 xinput set-int-prop Touchscreen Evdev Axes Swap 8 1
 xinput set-int-prop Touchscreen Evdev Axis Calibration 32 107 918 911
98

change YOUR_APP_HERE with for example:
openttd
numptyphysics -geometry 640x480
scummvm

enjoy ;)

Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] landscape mode under QX

2011-09-13 Thread Francesco De Vita
Il 12/09/2011 16:01, Radek Polak ha scritto:
 Hi,
 you can try:

 xinput set-int-prop S3C24XX TouchScreen Evdev Axis Calibration 32 107 918
 911 98
 xinput set-int-prop S3C24XX TouchScreen Evdev Axes Swap 8 1

Hi Radek
Thanks for the suggestions.
To correctly rotate the screen this works:
xrandr -o 1
xinput set-int-prop Touchscreen Evdev Axis Inversion 8 0 1
xinput set-int-prop Touchscreen Evdev Axes Swap 8 0

and to bring back the screen in the original position:
xrandr -o normal
xinput set-int-prop Touchscreen Evdev Axis Inversion 8 0 0
xinput set-int-prop Touchscreen Evdev Axes Swap 8 1

So with two simple scripts it is possible to switch the screen between
normal and landscape mode.
But there are some issues:
- when the screen is in landscape mode there is a little offset between
the cursor and the stylus (the cursor is a little below the area
effectively touched on the screen, is not very precise, I wonder why..);
- the screen flickers a little, maybe is it necessary to set a proper
refresh frequence?
- the scripts must be launched within xterm otherwise they do not work;
- for better result xterm must be launched using machbox otherwise, when
the screen is rotated, there is a black box on the right side (and it
seems to me that it has the same dimensions of the docked keyboard but
I don't know why xorg draws it), see screenshots below.

for example, if I want to run openttd, first I have to run xterm with
matchbox and then launch this script:
#!/bin/sh
killall matchbox-keyboard
xrandr -o 1
xinput set-int-prop Touchscreen Evdev Axis Inversion 8 0 1
xinput set-int-prop Touchscreen Evdev Axes Swap 8 0
openttd

screenshots:
openttd launched in xterm:
http://img195.imageshack.us/img195/8881/openttd.jpg
openttd launched in xterm with matchbox:
http://img843.imageshack.us/img843/5232/openttdmatchbox.jpg

Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


[QtMoko] landscape mode under QX

2011-09-12 Thread Francesco De Vita
Hi list!
I'm trying to use some applications under QX in landscape mode (screen
rotated, in 640x480 mode). Using xglamo the rotation is unpracticable
because the screen become splitted in four areas full of graphic artifacts.
Using xserver-xorg-video-glamo instead, using the fullscreen mode (qx
settings) I get a rotated screen but in 480x480 like size (with the right
part of the rotated screen completely black but reachable with the cursor)
or using matchbox a correctly rotated screen in 640x480. But in both cases
the touchscreen axes is flipped of 90 degrees: if i move the stylus on the
screen along the longitudinal axis I see the cursor moving along the
transversal axis and viceversa.
Currently I'm trying to rotate the screen in xterm using or the rotate
screen option under QX settings or typing in xterm xrandr -o 1 (xrandr
--output LCD --rotate left seems to not work).
So, I would like to know:
- how to have under QX a correctly rotated screen in landscape mode, maybe
in fullscreen without matchbox;
- how to correct the rotation of the touchscreen axes;
Thank you!

Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-13 Thread Francesco De Vita



Go to options-Scrolling, select

Options for Tap Scrollings
Delay beween scrollings, msec 10
Scrolling mode No overlapping

Then you can scroll if you press and hold touchscreen somewhere on the page
for 10ms (or longer).

If you press on bottom part of the page it shows next page, if you press upper
part shows previous page.
Thanks! Next/previous page works, but I'm still unable to scroll, if I 
press and hold somewhere the resultant action is a text selection. I 
tried also with up than 100ms but nothing...


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: battery life with QtMoko

2011-06-11 Thread Francesco De Vita



Do you have deep sleep enabled? Is your battery in good condition?

I had 5 days - that was measured with 2.6.37 kernel - but that kernel had some
bug for me which prevent from daily use (sometimes didnt wake or woken with
vibrator on).
Deep sleep enabled and the battery seems to be in good condition. I use 
my moko as a daily phone so I can't make an accurate test for now. Five 
days is really good!


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Shiftd

2011-06-10 Thread Francesco De Vita



Idea #4:
Easy navigation system (based on OSM), wifi enabled to sync (R/W) with 
PC, to update infos from your desk to your car...  reverse !


GTA04 + Navigation Board= GPS+Accelerometers+Gyros+WiFi/other 
connection= a possible DGPS / Inertial Navigation System




Idea #5:
Build brand new projects based on the community ideas ...

I agree

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: battery life with QtMoko

2011-06-10 Thread Francesco De Vita



Does anybody has flashed the latest QtMoko and can report something
about battery standby time ? I remember Radek mention a serious
improvment.

thanks,
Chris

Hi!
I didn't make any precise measure but I can say that my neo after 32 
hours is in (very) low battery, I only sent few messages (sms) and I 
used the gps for 5 minutes.


Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] (v35) Network connections

2011-06-07 Thread Francesco De Vita
Hi!
There is no need to type the ESSID, it is not clear at all but the faster
procedure is this one:
go to internet, open the option menu and search for available networks, in
the new window after few seconds open again the option menu and add a new
network, you'll see a list of available networks ;)

Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-07 Thread Francesco De Vita
Hi
can you tell us what is the complete command you used? export
LD_LIBRARY_PATH=...?
Thanks!

Joif


2011/6/7 Yury Sakarinen z...@onego.ru


 Thanks, Radek! It works, but a bit uncomfortable. I hope this issue will be
 fixed in future releases.
 I don't like to have a lot of gadgets, and have no time to mess around with
 the filling of the
 contents of e-books, which still have to carry around..

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko : typing text without stylus

2011-06-06 Thread Francesco De Vita
Sorry I was not precise: I use the predictive keyboard that is without the
predictive behaviour, I write letter by letter.

Joif

2011/6/6 Xavier Cremaschi omega.xav...@gmail.com

 So you write on your screen with your nail instead of stylus, and you
 have a predictive behaviour ? How do you enable it ? Mine -- in french
 -- doesn't seem predictive at all. Maybe I need to add a dictionary
 somewhere...

 And the keyboard named Predictive keyboard (the one from SHR ?)
 doesn't seem to be predictive either :(

 Xavier.


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko : typing text without stylus

2011-06-05 Thread Francesco De Vita
The default predictive keyboard and my finger! (: I use the index like the
stylus, the trick is to use just the tip of the fingernail. ..but I have to
say, though I have trained, I'm still faster with my thumb on a common
mobile keyboard with the T9 (:

Joif


2011/6/5 Xavier Cremaschi omega.xav...@gmail.com

 Hi folks,
 what are your best tips to type text (not shell command, normal french text
 in my case) in Qtmoko, without being too slow if possible.

 Do you use any kind of predictive keyboards ? Or qwo maybe ?

 Kind regards,
 Xavier.



 ___
 Openmoko community mailing list
 community@lists.openmoko.org
 http://lists.openmoko.org/mailman/listinfo/community

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: AtMoko v35 incoming SMS tone missing?

2011-05-17 Thread Francesco De Vita
Hi, I have a similar problem but only when I send a message long more than
one page, I explain: I send a sms, say it is long 2 pages, after that my
moko doesn't receive incoming sms and I have to restart it. But consider
that the issues with long sms' are old and to date they seem to be unsolved,
I don't know if it is really related to that issue.

Regards
Joif

2011/5/17 Hrabosh zbyne...@volny.cz


 Well, seems that we have a problem.


 There was a guy some time ago reporting having simmilar issue. He said
 that his FreeRunner is even not able to receive SMS until he restarts
 the phone.


 I was having simmilar issues also, but bonding pins on SIM connector
 helped. It was like one month ago.


 Earlier this week my phone started not report incoming messages by sound
 and now I have to restart it to get the messages.

 Do these two probles  have something in common? Is there any recomemnded
 way how to troubleshoot it?

 Thanks, Hrabosh


 Philip Rhoades píše v Po 16. 05. 2011 v 18:39 +1000:
  People,
 
  I don't get a tone when an SMS arrives - I can't find anything on the
  phone or googling that mentions this - is this a known issue?  Am I
  missing something?
 
  Thanks,
 
  Phil.




 ___
 Openmoko community mailing list
 community@lists.openmoko.org
 http://lists.openmoko.org/mailman/listinfo/community

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: About QtMoko future

2011-05-12 Thread Francesco De Vita

Wow, it would be great! :)

Joif

Btw, I've been thinking about integrating qtmoko to Debian. Perhaps as a
Debian Pure Blend, or even building single packages. I didn't go deeper yet,
but will try to share this ideia during Debconf. Actually, pabs mentioned it
once to me in some debian irc channel, so strictly speaking it's his idea :)
Had anyone here thought the same? It wouldn't change the current upstream
development model, so radek and qtmoko contributors don't need to worry.
Updating the system would be much easier for users having official Debian
packages for qtmoko.

Regards,

--
Tiago Bortoletto Vaz
http://tiagovaz.org
0xA504FECA - http://pgp.mit.edu


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community



___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [Faenqo theme] date/time

2011-03-08 Thread Francesco De Vita

Hi!
He is cyberesprit not cyberspirit ;) About the position of the date/time 
it is possibile to move it near the carghe indicator. But because we 
have much space in the homescreen, do you prefer to have the date/time 
indicator only in the titlebar (in the top) or to have it also in the 
homescreen (it is a redundancy, but a bigger date/time indicator here is 
easier to read)?
Well, it could be an interesting idea to have a date/time indicator that 
appears in the titlebar only when you are not at the homescreen.


Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-07 Thread Francesco De Vita
Wow ,how much work :)
I'll try to replace some icons with jpeg and see how qtmoko handles the
resizing of them and if it changes something (probably not :) )

Regards
Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-06 Thread Francesco De Vita

Il 05/03/2011 20:44, Radek Polak ha scritto:


New version is uploaded now. If you figure out PIN i can do new version.

Regards

Radek


   
I uploaded a new version with the PIN buttons fixed and the new Debian 
background pic suggested by Tiago Bortoletto Vaz.

Archive here: https://www.dropbox.com/s/2dnc2ld9pthmahn/faenqomod.tar.gz

Thanks!

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-06 Thread Francesco De Vita

Il 07/03/2011 07:02, Radek Polak ha scritto:

Hi,
i have downloaded the package and unpacked it to my git. But only change i see
is the debian2 backaground. Maybe i missed something... Which files are needed
to fix PIN buttons?

Regards

Radek
   

opt/qtmoko/pics/themes/faenqomod/pinbutton.svg
opt/qtmoko/pics/themes/faenqomod/pinbuttonp.svg
instead of the .PNGs.

Regards
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-05 Thread Francesco De Vita



Where do we find the updated version? All current .deb are dated from 6/feb in
the mirror. Should we get
https://www.dropbox.com/s/2dnc2ld9pthmahn/faenqomod.tar.gz ?

   
Yes, for now the updated version is only the archive on my dropbox page: 
https://www.dropbox.com/s/2dnc2ld9pthmahn/faenqomod.tar.gz


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-05 Thread Francesco De Vita

Radek Polak wrote:

  I was faster and made debian
package, but i am having trouble to upload it with current connection, so i
will upload it when i get home later today.
 

It's uploaded now and ready to be installed:

http://qtmoko.sourceforge.net/apps/category-themes.html

Regards

Radek
   


Thank you Radek! Please, if it is possible, make a new .deb, I forgot to 
upload two pics (context and title bar) and I uploaded a new archive 
with them: https://www.dropbox.com/s/2dnc2ld9pthmahn/faenqomod.tar.gz
On QtMoko v31 there were no issues, for now on v33 I have a problem with 
the PIN buttons... I'm trying to figure it out why.


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-05 Thread Francesco De Vita

Il 05/03/2011 16:30, Gennady Kupava ha scritto:

Guys, can i repeat my bug report?

In 'help', icon is absent for 'close' field (on right). It should be
easy to fix? I had big problems with that then i used qtmoko first time.
(it is frustrating to have no way to close 'help' which is first thing
many users open)

Gennady
   
 You're right. This is an old bug, I saw it first time in QtMoko v16. I 
think it is not related to themes, this bug is in fact present with 
every theme. The problem is that only the icon is not visualized. In 
fact if you click in the place where the back/close button should be, 
you obtain the back/close action even if there is no button (icon). 
But if you go in settings--appearance and you choose to not use icons 
for soft key, in help you'll see a Close button.


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: [QtMoko] faenqomod updated

2011-03-05 Thread Francesco De Vita

Il 05/03/2011 20:40, Gennady Kupava ha scritto:

Ok, changed close button to usual back arrow, now it's visible.

   

awesome! so what was the problem? :)

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko - Eyepiece fixed

2011-03-05 Thread Francesco De Vita
I have a question, how to go to a certain page? In v31 I was able only 
to go forward or backward page by page. Is there any button to doing so 
that I didn't see?


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: faenqo

2011-02-05 Thread Francesco De Vita
2011/2/5 Gennady Kupava g...@bsdmn.com

 Hi, guys.

 I didn't actually tried new theme yet, but i have few idea about themes
 is general :). I tried all themes from QTopia, all are not usable cause
 they designed for smaller resolution screens, but i noticed interesting
 thing that some themes include 3 buttons in bottom instead of 2, so i
 thinking, may be it would be nice to add button to show/hide keyboard in
 middle?

 Gennady.


I noticed it too, and the idea for a middle button to show/hide keyboard is
great. It could be really usefull!
But as I wrote in the previous post, I think that for this kind of
customization it is necessary to work with the qtextended server widgets. I
have to study some docs :)

Regards
Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: New theme by a french ..

2011-02-03 Thread Francesco De Vita
Nooo! I don't want to believe it! This guy stolen my idea, a theme with
the Faenza icons!! Noo!
Hahahaha never mind :) I am to busy too work on a new theme in this period
(but hey, there was the idea!), so... it is a really good work! :)
But I have a question, are these pictures a mock up? or are they about a
working theme?

Regards
Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: qtmoko v32 (experimental) - led indicators

2011-02-03 Thread Francesco De Vita
2011/1/21 Alfa21 freerun...@my.is.it

 [...]
 (also we don't have an icon on the display... eg like the G for gprs)


for what I saw, to insert a new icon (maybe in the top bar) it is necessary
to modify the theme and add the icon and the proper parameters.

Regards
Joif
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v31

2011-01-17 Thread Francesco De Vita

Yes, this is exactly what I meant!


I understood this to be a request for a notification of the form message sent
to GSM provider or couldn't send message so I stuck it in the pending
queue/draft folder/wherever so that you don't have to check the draft folder
each time to see whether the message actually made it to the network.

On the other hand FSO supports a wide variety of message status returns if
requested[1] so it could have been for a similar level of support.

[1]
http://git.freesmartphone.org/?p=specs.git;a=blob_plain;f=html/org.freesmartphone.GSM.SMS.html;hb=HEAD#SendTextMessage


   



___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v31 NeronGPS - trace stops after fix loss

2011-01-15 Thread Francesco De Vita
Same problem here, I suppose that we need a patch for NeronGPS. This 
problem is present from early versions of QtMoko!


Greetings
Joif

Il 15/01/2011 11:46, Philip Rhoades ha scritto:

People,

When I use this app and have recording On, if I go through a tunnel 
or something and lose the satellite fix, even very briefly - when I 
look at the trace of the journey later it is truncated from the point 
where I lost the fix - shouldn't the trace continue or at least start 
a new trace file?


Thanks,

Phil.



___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: qtmoko v30

2010-12-07 Thread Francesco De Vita

 Bugs:
 - GPS (I didn't try it yet, sorry) seems always powered on, or at least in
 Neo Tool it is always GPS: 1, also after powered it off with the
  
 I will take a look.


Update: GPS is off after a suspend. If GPS is then turned on, turn off 
GPS from devtools still seems to not work.
Ciao!
Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: qtmoko v28, strange behaviour with the earphones

2010-11-26 Thread Francesco De Vita
On Tuesday 09 November 2010 18:15:23 Joif wrote:

 hello
 Since I installed the v28 I noticed a strange behaviour with the openmoko
 earphones.
  
 Have you had the problems with older versions? It would be very useful to know
 if e.g. v26 works well (e.g. you can install and test from SD card). I think
 there was kernel patch for detecting jack inserting, so maybe we could just
 find it and apply. But first it would be nice to check if v26 has the same
 problem...

 Regards

 Radek

 ___


Dear Radek
Sorry for the delay but I was busy in the past weeks. Today I 
reinstalled the v26 and there are no problems with the earphones, it is 
an issue only of the v28.

Ciao!

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v26

2010-09-15 Thread Francesco De Vita
 I also noted this issue, but the proper icon is there! Maybe 
something went wrong during compilation and the conversion process form 
the .png to .pic. Anyway, just for a momentaneous workaround, put the 
call.png (attached) in to /opt/qtmoko/pics/themes/finximod and rename 
the file call.pic in something else like callOLD.pic or whatever you 
want (the theme configuration file looks for the files without the file 
extensions). Restart QtMoko and you will have the icon for missed calls ;)


Joif

Hello Radek and Team,

Just flashed v26 and I've got a totally new FR in my hands. Thanks alot
guys!

Just one thing: Is it possible that the icon for missed phone calls is
- well - missing? I'm using that new theme and it displays an icon for
missed text-messages. If I miss a call there's just a blank space and
the call counter.

Daniel

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community
   


attachment: call.png___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v26

2010-08-31 Thread Francesco De Vita
Radek please can you explain these commands in the devtools?
- AGPS dump
- AGPS lead
- Fast Charge Mod
- GPS standby enter
- GPS standy leave

Do you think to include a better wifi manager in next releases? the 
default one still causes problem (alias you must be lucky to have a 
working connection, at least for me).
I tried wicd-curses (from Squeeze repos) and it works very well, but of 
course it is an app without a GUI, it could be uncomfortable for some users.

thank you!

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: QtMoko v26

2010-08-29 Thread Francesco De Vita
Please keep in mind that the finximod theme I made is just the first 
theme I did for qtmoko and it has problem with rotated screen. If you 
rotate the screen you will experience some graphical glitches. But it 
works well in the default vertical orientation of the screen. Soon as I 
can I will fix it and improve it!

Greetings
Joif
 Radek Polak wrote:


 * New nice theme called finximod (Joif)
  
 Btw here are screenshots:

 http://activationrecord.net/radekp/qtmoko/screenshots/finximod_home.png
 http://activationrecord.net/radekp/qtmoko/screenshots/finximod_dialer.png
 http://activationrecord.net/radekp/qtmoko/screenshots/finximod_menu.png

 Regards

 Radek





___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community