Re: Qtmoko v35 FBreader

2011-06-15 Thread Radek Polak
On Tuesday 14 June 2011 22:06:17 Yury Sakarinen wrote:

  You can not scroll pages, especially when the tap enabled. This
  functionality is not provided.
  Also you can disable the text selection in the settings.
 
  To avoid an issue of particularly slow to tap pages, you need to
  install version 0.12.10, but it is
  not in the repository: http://www.fbreader.org/desktop/#debian (now
  only for i386 and amd64 platforms)
 
  In version 0.10.7 tap normally works only when you press screen by
  stylus.
  FBreader contains curve algorithm for determining gestures.
 
  to list: please advise if anyone knows other convenient bookreaders
  (may be without using QX if possible).

I want FBReader without QX too (and Navit is second on my list). It should be 
just matter of writing qbuild project files, but i am currently working on 
something else and dont want to interrupt it...

Regards

Radek

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-15 Thread Yury Sakarinen



I want FBReader without QX too (and Navit is second on my list). It
should be
just matter of writing qbuild project files, but i am currently 
working on

something else and dont want to interrupt it...



Radek


Yeah.. i see,,

FYI: I found FBreader that works fantastically,
without any problems with taps by finger.

http://www.mikecrash.com/index.php?name=Downloadsd_op=getitlid=81

Just remove fbreader and install modified version with dpkg:
fbreaderm_0.10.7dfsg-2_armel.deb

Might be worth to add it to qt-appl repository?

There are also several useful programs for debian.
I do not know who this man, but he did a good job.


http://www.mikecrash.com/index.php?name=Contentpa=showpagepid=10





___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-14 Thread Yury Sakarinen


You can not scroll pages, especially when the tap enabled. This 
functionality is not provided.

Also you can disable the text selection in the settings.

To avoid an issue of particularly slow to tap pages, you need to 
install version 0.12.10, but it is
not in the repository: http://www.fbreader.org/desktop/#debian (now 
only for i386 and amd64 platforms)


In version 0.10.7 tap normally works only when you press screen by 
stylus.

FBreader contains curve algorithm for determining gestures.

to list: please advise if anyone knows other convenient bookreaders 
(may be without using QX if possible).



On Mon, 13 Jun 2011 14:16:12 +0200, Francesco De Vita wrote:


Thanks! Next/previous page works, but I'm still unable to scroll, if
I press and hold somewhere the resultant action is a text selection. 
I

tried also with up than 100ms but nothing...

Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community




___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-13 Thread Radek Polak
On Sunday 12 June 2011 23:32:19 Joif wrote:

 FBreader works well but I'm unable to change the Scrolling. I tryed some
 options in the settings menu but nothing seems to change, I can only use
 the stylus and the scroll bar on the right. Is there something
 finger-friendly? Thanks!

It took me weeks to figure it out.

Go to options-Scrolling, select

Options for Tap Scrollings
Delay beween scrollings, msec 10
Scrolling mode No overlapping

Then you can scroll if you press and hold touchscreen somewhere on the page 
for 10ms (or longer).

If you press on bottom part of the page it shows next page, if you press upper 
part shows previous page.

I guess we should prepare patch for upstream so that settings show at least 
some help or make this more user friendly.

Regards

Radek


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-13 Thread Francesco De Vita



Go to options-Scrolling, select

Options for Tap Scrollings
Delay beween scrollings, msec 10
Scrolling mode No overlapping

Then you can scroll if you press and hold touchscreen somewhere on the page
for 10ms (or longer).

If you press on bottom part of the page it shows next page, if you press upper
part shows previous page.
Thanks! Next/previous page works, but I'm still unable to scroll, if I 
press and hold somewhere the resultant action is a text selection. I 
tried also with up than 100ms but nothing...


Joif

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-12 Thread Joif
FBreader works well but I'm unable to change the Scrolling. I tryed some
options in the settings menu but nothing seems to change, I can only use the
stylus and the scroll bar on the right. Is there something finger-friendly?
Thanks!

Joif

--
View this message in context: 
http://openmoko-public-mailinglists.1958.n2.nabble.com/Qtmoko-typing-text-without-stylus-tp6442999p6468192.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-08 Thread Radek Polak
On Wednesday 08 June 2011 00:23:35 Francesco De Vita wrote:

 can you tell us what is the complete command you used? export
 LD_LIBRARY_PATH=...?

There is nothing after the =. It means that it deletes this environment 
variable.

If you copy-paste this to FR shell you'll be able to use Favourites and 
there will be new icon for E-book reader QX which will launch FBReader 
correctly:

cat  /usr/share/applications/FBReaderQX.desktop __END__
[Desktop Entry]
Name=E-book reader QX
GenericName=E-book reader
Comment=E-book reader
TryExec=fbreader.sh
Exec=fbreader.sh %F
StartupNotify=true
Terminal=false
Type=Application
Icon=FBReader.png
Categories=Office;Viewer;Literature;
__END__

cat  /usr/bin/fbreader.sh __END__
#!/bin/sh
export LD_LIBRARY_PATH=
FBReader
__END__

chmod +x /usr/bin/fbreader.sh


Hope this helped

Regards

Radek

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-08 Thread Yury Sakarinen


Thanks Radek. Now my FR used for 100 pct without the tedious
procedure of running through qx xterm %)

If you copy-paste this to FR shell you'll be able to use Favourites 
and
there will be new icon for E-book reader QX which will launch 
FBReader

correctly:

cat  /usr/share/applications/FBReaderQX.desktop __END__
[Desktop Entry]
Name=E-book reader QX
GenericName=E-book reader
Comment=E-book reader
TryExec=fbreader.sh
Exec=fbreader.sh %F
StartupNotify=true
Terminal=false
Type=Application
Icon=FBReader.png
Categories=Office;Viewer;Literature;
__END__

cat  /usr/bin/fbreader.sh __END__
#!/bin/sh
export LD_LIBRARY_PATH=
FBReader
__END__

chmod +x /usr/bin/fbreader.sh


Hope this helped

Regards

Radek




___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-07 Thread Radek Polak
On Tuesday 07 June 2011 06:55:37 Yury Sakarinen wrote:

  there is a problem to run fbreader on qtmoko v35,
  need help from someone who uses fbreader on qtmoko v35.

You need to run it from QX. However there is problem that FBReader tries to 
use QtMoko's embedded QT instead of system QT. To start it correctly you need 
to do something like this (e.g. from QX xterm):

export LD_LIBRARY_PATH=
fbreader

Regards

Radek

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-07 Thread Yury Sakarinen


Thanks, Radek! It works, but a bit uncomfortable. I hope this issue 
will be fixed in future releases.
I don't like to have a lot of gadgets, and have no time to mess around 
with the filling of the

contents of e-books, which still have to carry around..



 there is a problem to run fbreader on qtmoko v35,
 need help from someone who uses fbreader on qtmoko v35.


You need to run it from QX. However there is problem that FBReader 
tries to

use QtMoko's embedded QT instead of system QT. To start it correctly
you need
to do something like this (e.g. from QX xterm):

export LD_LIBRARY_PATH=
fbreader

Radek




___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Qtmoko v35 FBreader

2011-06-07 Thread Francesco De Vita
Hi
can you tell us what is the complete command you used? export
LD_LIBRARY_PATH=...?
Thanks!

Joif


2011/6/7 Yury Sakarinen z...@onego.ru


 Thanks, Radek! It works, but a bit uncomfortable. I hope this issue will be
 fixed in future releases.
 I don't like to have a lot of gadgets, and have no time to mess around with
 the filling of the
 contents of e-books, which still have to carry around..

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Qtmoko v35 FBreader

2011-06-06 Thread Yury Sakarinen


Hi, list

there is a problem to run fbreader on qtmoko v35,
need help from someone who uses fbreader on qtmoko v35.


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community