Re: ventura upgrades, https and self-signed certificates

2010-04-22 Thread urodelo
Right, i agree. In my case, if I point the browser to my https web page,  
it shows a load of 10% and then stops. I just get a white page (which  
should mean: hey i'm not willing to load anything!). The same page is  
normally shown if ssl is disabled. Also for the https links I've  
experimented the same behaviour as Tom. It is great to know all this will  
be solved in the next release :-)
Thanks a lot again


On Tue, 20 Apr 2010 15:25:50 +0200, Tom Yates madhat...@teaparty.net  
wrote:

 On Tue, 20 Apr 2010, urodelo wrote:

 Since I use ventura, my whole shr experience is much better. finally a
 decent web browser! before it was impossible to surf the internet with
 woosh or others. only dillo was usable for me, but with ventura i can
 finally go through https too. i find the pg buttons etc very useful.
 thanks a lot

 i, too, am much enjoying ventura over previous browsers.  that said, i
 posted this query to shr-user originally, but got no answers, so i  
 thought
 i'd try here.  hope that's OK.

 i had thought i was having a problem with ventura and https pages,  
 because
 in menu - URL, the https drop-down doesn't select (i click it, but it
 keeps coming up http), plus i couldn't follow a link to an https page i
 wanted (my webmail service).

 but it seems that https links are fine provided the certificate is
 properly signed; it's only that i run my own webmail service and the
 certificate is self-signed.  is there any way to tell ventura not to  
 check
 the certificate chain, but just to load the page?




-- 
Creato con il rivoluzionario client e-mail di Opera:  
http://www.opera.com/mail/


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: ventura upgrades, https and self-signed certificates

2010-04-20 Thread Tom Yates
On Tue, 20 Apr 2010, urodelo wrote:

 Since I use ventura, my whole shr experience is much better. finally a
 decent web browser! before it was impossible to surf the internet with
 woosh or others. only dillo was usable for me, but with ventura i can
 finally go through https too. i find the pg buttons etc very useful.
 thanks a lot

i, too, am much enjoying ventura over previous browsers.  that said, i 
posted this query to shr-user originally, but got no answers, so i thought 
i'd try here.  hope that's OK.

i had thought i was having a problem with ventura and https pages, because 
in menu - URL, the https drop-down doesn't select (i click it, but it 
keeps coming up http), plus i couldn't follow a link to an https page i 
wanted (my webmail service).

but it seems that https links are fine provided the certificate is 
properly signed; it's only that i run my own webmail service and the 
certificate is self-signed.  is there any way to tell ventura not to check 
the certificate chain, but just to load the page?


-- 

   Tom Yates  -  http://www.teaparty.net

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: ventura upgrades, https and self-signed certificates

2010-04-20 Thread c_c

Hi,

Tom Yates-3 wrote:
 
  is there any way to tell ventura not to check 
 the certificate chain, but just to load the page?
 
  Not yet. Hopefully with the newer version of webkit-efl nearing release
this might be possible.
-- 
View this message in context: 
http://n2.nabble.com/ventura-upgrades-tp4905082p4931867.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-24 Thread Petr Vanek
  And can you tell me your version of ewebkit? Mine happens to be 
libewebkit0 -
1.1.11+gitr38213+3a5ee77664c898ed51a2b2d5759822f8c0a06472-r1.4 Thanks
-- 
View this message in context:
http://n2.nabble.com/Ventura-browser-NEW-release-15-Jan-tp4357081p4447871.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

libewebkit-webinspector
1.1.11+gitr38213+3a5ee77664c898ed51a2b2d5759822f8c0a06472-r1.4
libewebkit0
1.1.11+gitr38213+3a5ee77664c898ed51a2b2d5759822f8c0a06472-r1.4
libwebkit-1.0-2 1.1.18+svnr52207-r52207-r0.4
libwebkit-1.0-bin   1.1.18+svnr52207-r52207-r0.4

Petr


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-23 Thread Xavier Cremaschi
c_c a écrit :
 Hi,
   Can some users confirm the version of webkit that works? I have
 v1.1.18+svnr52207-r52207-r0.4 installed and I get an 'unable to create
 webview' error in eve.
 
 Thanks

Hi,
libwebkit-1.0-2 - 1.1.16+svnr50081-r50081-r0.4 here (shr testing). It 
seems fine.

Xavier.


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-23 Thread Petr Vanek
On Fri, 22 Jan 2010 23:11:25 -0800 (PST)
c_c cchan...@yahoo.com (C) wrote:


Hi,
  Can some users confirm the version of webkit that works? I have
v1.1.18+svnr52207-r52207-r0.4 installed and I get an 'unable to create
webview' error in eve.

libwebkit-1.0-bin - 1.1.18+svnr52207-r52207-r0.4

works just fine for me:

--start---
r...@om-gta02 ~ $ browser 
restoring state
db ver 0
3 SQL error: duplicate column name: full_screen
showing window
Error #0 while loading the group 'scrollbar.vertical'.
Error #0 while loading the group 'scrollbar.vertical'.
-running here---
-press close
browser: fccache.c:512: FcCacheFini: Assertion `fcCacheChains[i] ==
((void *)0)' failed. Aborted
-ended here---


Petr


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-23 Thread Davide Scaini
On Sat, Jan 23, 2010 at 12:06 PM, Petr Vanek van...@penguin.cz wrote:

 On Fri, 22 Jan 2010 23:11:25 -0800 (PST)
 c_c cchan...@yahoo.com (C) wrote:

 
 Hi,
   Can some users confirm the version of webkit that works? I have
 v1.1.18+svnr52207-r52207-r0.4 installed and I get an 'unable to create
 webview' error in eve.

 libwebkit-1.0-bin - 1.1.18+svnr52207-r52207-r0.4

 works just fine for me:

 --start---
 r...@om-gta02 ~ $ browser
 restoring state
 db ver 0
 3 SQL error: duplicate column name: full_screen
 showing window
 Error #0 while loading the group 'scrollbar.vertical'.
 Error #0 while loading the group 'scrollbar.vertical'.
 -running here---
 -press close
 browser: fccache.c:512: FcCacheFini: Assertion `fcCacheChains[i] ==
 ((void *)0)' failed. Aborted
 -ended here---


 Petr



are you running x11 in 16bit mode?
I got something similar and Valery Febvre gave me the right answer:
-
I think you choosed to use Evas Software X11 16 bit engine in SHR
settings (section Appearence).
elm-browser only runs with Software X11 engine.

A simple solution is to edit the file
/usr/share/applications/browser.desktop and to replace line:

Exec=browser

by

Exec=ELM_ENGINE=x11 browser

-
d



 ___
 Openmoko community mailing list
 community@lists.openmoko.org
 http://lists.openmoko.org/mailman/listinfo/community

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-23 Thread Petr Vanek
   Can some users confirm the version of webkit that works? I have
 v1.1.18+svnr52207-r52207-r0.4 installed and I get an 'unable to
 create webview' error in eve.

 libwebkit-1.0-bin - 1.1.18+svnr52207-r52207-r0.4

 works just fine for me:

 --start---
 r...@om-gta02 ~ $ browser
 restoring state
 db ver 0
 3 SQL error: duplicate column name: full_screen
 showing window
 Error #0 while loading the group 'scrollbar.vertical'.
 Error #0 while loading the group 'scrollbar.vertical'.
 -running here---
 -press close
 browser: fccache.c:512: FcCacheFini: Assertion `fcCacheChains[i] ==
 ((void *)0)' failed. Aborted
 -ended here---


 Petr



are you running x11 in 16bit mode?


sorry if this wasn't clear, i will repeat: works just fine for me.
the messages you have seen are from a successful run,

cheers anyways
Petr






___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: Ventura and https

2010-01-23 Thread c_c

Hi,
  And can you tell me your version of ewebkit? Mine happens to be 
libewebkit0 - 1.1.11+gitr38213+3a5ee77664c898ed51a2b2d5759822f8c0a06472-r1.4
Thanks
-- 
View this message in context: 
http://n2.nabble.com/Ventura-browser-NEW-release-15-Jan-tp4357081p4447871.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Ventura and https

2010-01-22 Thread c_c

Hi,
  Can some users confirm the version of webkit that works? I have
v1.1.18+svnr52207-r52207-r0.4 installed and I get an 'unable to create
webview' error in eve.

Thanks
-- 
View this message in context: 
http://n2.nabble.com/Ventura-browser-NEW-release-15-Jan-tp4357081p454.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community