Re: dfu-util upload problems

2008-07-22 Thread Gianluigi
Alle 02:50, lunedì 21 luglio 2008, Kevin Squire ha scritto:
 At least one other person (you?) has indicated a similar problem at
 http://wiki.openmoko.org/wiki/Pre-Flash_Backup.  Any ideas, anyone?

 Thanks,

    Kevin

 _

I've same problem.

# ./dfu-util -a rootfs -R -U good-rootfs.jffs2
dfu-util - (C) 2007 by OpenMoko Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

Opening USB Device 0x:0x...
Claiming USB DFU Runtime Interface...
Determining device status: state = appIDLE, status = 0
Device really in Runtime Mode, send DFU detach request...
Resetting USB...
Opening USB Device...
Found Runtime: [0x1d50:0x5119] devnum=15, cfg=0, intf=0, alt=6, name=rootfs
Claiming USB DFU Interface...
Setting Alternate Setting ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
Transfer Size = 0x1000
dfu_upload error -84


My system is:
OpenSuse 10.2 over AMD Athlon XP

-- 
Even historians fail to learn from history -- they repeat the same
mistakes.
-- John Gill, Patterns of Force, stardate 2534.7

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: dfu-util upload problems

2008-07-22 Thread xiangfu
there is something wrong -U option.
be careful use this option.
Gianluigi wrote:
 Alle 02:50, lunedì 21 luglio 2008, Kevin Squire ha scritto:
   
 At least one other person (you?) has indicated a similar problem at
 http://wiki.openmoko.org/wiki/Pre-Flash_Backup.  Any ideas, anyone?

 Thanks,

Kevin

 _
 

 I've same problem.

 # ./dfu-util -a rootfs -R -U good-rootfs.jffs2
 dfu-util - (C) 2007 by OpenMoko Inc.
 This program is Free Software and has ABSOLUTELY NO WARRANTY

 Opening USB Device 0x:0x...
 Claiming USB DFU Runtime Interface...
 Determining device status: state = appIDLE, status = 0
 Device really in Runtime Mode, send DFU detach request...
 Resetting USB...
 Opening USB Device...
 Found Runtime: [0x1d50:0x5119] devnum=15, cfg=0, intf=0, alt=6, name=rootfs
 Claiming USB DFU Interface...
 Setting Alternate Setting ...
 Determining device status: state = dfuIDLE, status = 0
 dfuIDLE, continuing
 Transfer Size = 0x1000
 dfu_upload error -84


 My system is:
 OpenSuse 10.2 over AMD Athlon XP

   


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: dfu-util upload problems

2008-07-20 Thread Kevin Squire
 Hi,

 I have a little problem with dfu-util and my new Freerunner.

 I thought I'd make a backup of my Neo's filesystem before flashing new
 images onto it, so I tried to use dfu-util in upload mode to transfer
 the content of the Neo's flash to my desktop PC. Backing up the kernel
 partition works, but when I back up the rootfs partition dfu-util
 transfers about 247MB and then dies with dfu_upload error -84, while
 the phone immediately reboots. It always dies at the same position, but
 I'm not sure whether the backup is complete or not.

Just wanted to say that I'm having the same problem (and same
questions): I was able to upload 258076672 bytes (=246 Mb), but then
dfu-util dies with dfu_upload error -16, and the FreeRunner reboots.
This is on Mac OS X.

 Further details: I've tried it on my desktop and on my laptop PC, with
 Ubuntu 7.10, Ubuntu 8.04 and a grml live-cd, with various dfu-util
 binaries and one built from SVN, but the error appeared every time. The
 phone was hooked up directly to the host (no hub or something), U-Boot
 version on the phone is the originally installed 1.3.2-moko12 from May
 9.

 Any ideas what's wrong?

At least one other person (you?) has indicated a similar problem at
http://wiki.openmoko.org/wiki/Pre-Flash_Backup.  Any ideas, anyone?

Thanks,

   Kevin

___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


dfu-util upload problems

2008-07-06 Thread Thomas B.
Hi,

I have a little problem with dfu-util and my new Freerunner.

I thought I'd make a backup of my Neo's filesystem before flashing new
images onto it, so I tried to use dfu-util in upload mode to transfer
the content of the Neo's flash to my desktop PC. Backing up the kernel
partition works, but when I back up the rootfs partition dfu-util
transfers about 247MB and then dies with dfu_upload error -84, while
the phone immediately reboots. It always dies at the same position, but
I'm not sure whether the backup is complete or not.

Further details: I've tried it on my desktop and on my laptop PC, with
Ubuntu 7.10, Ubuntu 8.04 and a grml live-cd, with various dfu-util
binaries and one built from SVN, but the error appeared every time. The
phone was hooked up directly to the host (no hub or something), U-Boot
version on the phone is the originally installed 1.3.2-moko12 from May
9.

Any ideas what's wrong?

Regards,
Thomas


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community