usb host mode on GTA02 - can't see any external devices

2011-05-31 Thread Uri Savoray
whatever I do I only get the following from lsusb:
Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle 
(HCI mode)
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


I use a powered hub to connect to usb peripherals...
I used echo host  /sys/devices/platform/s3c2410-ohci/usb_mode ...

Just to be sure, here is the output from usb-device :
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0001 Rev=02.06
S:  Manufacturer=Linux 2.6.34-qtmoko ohci_hcd
S:  Product=S3C24XX OHCI
S:  SerialNumber=s3c24xx
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0a12 ProdID=0001 Rev=19.58
C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb



any help would be appreciated...
Uri
___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community


Re: usb host mode on GTA02 - can't see any external devices

2011-05-31 Thread Timo Juhani Lindfors
Uri Savoray u...@septier.com writes:
 I use a powered hub to connect to usb peripherals...
 I used echo host  /sys/devices/platform/s3c2410-ohci/usb_mode ...

Try supplying power to the bus? That's

om usb charger-mode power-usb

or

echo 1  /sys/class/i2c-adapter/i2c-0/0-0073/neo1973-pm-host.0/hostmode


___
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community