Re: [SHR-U] Wifi stopped working

2010-04-26 Thread HansV
lsusb gives: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub. So I suppose my WiFi is dead. -- View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4961242.html Sent from the Openmoko Community mailing list

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Ben Thompson
On Sun, Apr 25, 2010 at 11:42:39PM -0700, HansV wrote: lsusb gives: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub. So I suppose my WiFi is dead. No, I don't think so. My wifi is fine and I get the same output. How are you using wifi by the way? Do you use wpa_supplicant or

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread HansV
I use Mokonnect. It doesn't seem to find the WiFi hardware. The WiFi indicator comes on in the shelf while Mokonnect is trying to power up the device. But Mokonnect waits forever. Maybe some modules are missing in my setup? -- View this message in context:

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Ben Thompson
On Mon, Apr 26, 2010 at 12:26:18AM -0700, HansV wrote: I use Mokonnect. It doesn't seem to find the WiFi hardware. The WiFi indicator comes on in the shelf while Mokonnect is trying to power up the device. But Mokonnect waits forever. Maybe some modules are missing in my setup? Hmm, I have

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Xavier Cremaschi
Wifi seems unavailable, but after seeking the ML I found there is a bug in FSO MS5 (MS5 is the revision ?) and I had to do : echo s3c2440-sdi /sys/bus/platform/drivers/s3c2440-sdi/unbind echo s3c2440-sdi /sys/bus/platform/drivers/s3c2440-sdi/bind in order to get eth0 back.

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread HansV
[quote]Wifi seems unavailable, but after seeking the ML I found there is a bug in FSO MS5 (MS5 is the revision ?) and I had to do : echo s3c2440-sdi /sys/bus/platform/drivers/s3c2440-sdi/unbind echo s3c2440-sdi /sys/bus/platform/drivers/s3c2440-sdi/bind in order to get eth0 back.

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Michele Brocco
to be honest. Mokonnect rarely worked for me. I would also suggest u to use wpa_supplicant or similar wifi tools. Usually I turn on wifi using the shr settings ui and then run wpa_supplicant and udhcpc. That works 99% of the time if the interface is up. Good luck On Mon, Apr 26, 2010 at 11:17

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread HansV
Strange thing is that I can't power on using shr settings: the dropdown only shows the 'Automatic' value, on and off are not available. -- View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4962328.html Sent from the

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Fox Mulder
Only when you switch the automatic value to manual the option to power it on and off appears. Am 26.04.2010 14:37, schrieb HansV: Strange thing is that I can't power on using shr settings: the dropdown only shows the 'Automatic' value, on and off are not available.

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Davide Scaini
On Mon, Apr 26, 2010 at 2:37 PM, HansV h...@vanpee.be wrote: Strange thing is that I can't power on using shr settings: the dropdown only shows the 'Automatic' value, on and off are not available. do you switched (the switch) from automatic to manual? -- View this message in context:

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread HansV
OK, I didn't see this is a switch, I thought it was a dropdown box. Now I can switch it on manually. Still finding out how to start wifi with wpa-supplicant. -- View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4963760.html

Re: [SHR-U] Wifi stopped working

2010-04-26 Thread Paul Fertser
HansV h...@vanpee.be writes: OK, I didn't see this is a switch, I thought it was a dropdown box. Now I can switch it on manually. Still finding out how to start wifi with wpa-supplicant. Hard to succeed when you're reluctant to read, eh? ;) http://wiki.openmoko.org/wiki/FSO_Resources

Re: [SHR-U] Wifi stopped working

2010-04-25 Thread HansV
I have the same problem, but upgrading didn't solve it. I tried everything I could think of, but no wifi so far. Any ideas? -- View this message in context: http://openmoko-public-mailinglists.1958.n2.nabble.com/SHR-U-Wifi-stopped-working-tp4562468p4959480.html Sent from the Openmoko Community

Re: [SHR-U] Wifi stopped working

2010-04-25 Thread Iain B. Findleton
I have had experience with a lot of WiFi chips that is that they stop working after a couple of years. Check that the device is found on your machine. I use lsusb HansV wrote: I have the same problem, but upgrading didn't solve it. I tried everything I could think of, but no wifi so far.

Re: [SHR-U] WiFi-related memory leak

2010-02-24 Thread Denis Shulyaka
2010/2/21 Timo Juhani Lindfors timo.lindf...@iki.fi: Can you try the same test again without swap? Here it is. Without swap and midori this time: ftp://shulyaka.org.ru/pub/memlog2.tar.bz2 The phone survived for 2 hours this time. I guess it could live a little longer without

Re: [SHR-U] WiFi-related memory leak

2010-02-24 Thread Timo Juhani Lindfors
Denis Shulyaka shuly...@gmail.com writes: Here it is. Without swap and midori this time: ftp://shulyaka.org.ru/pub/memlog2.tar.bz2 Hmm. The memory usage of frameworkd actually decreased during the test: $ grep frameworkd ps* ps.17:57:32:root 1219 46.6 16.4 32368 19876 ?Ss 17:31

Re: [SHR-U] WiFi-related memory leak

2010-02-24 Thread Denis Shulyaka
2010/2/24 Timo Juhani Lindfors timo.lindf...@iki.fi: Hmm. The memory usage of frameworkd actually decreased during the test: How can this happen? ;) Same for Xorg too: and hal: I have no idea why it decreased. I guess kernel unloads some parts of executable that are not executed ATM. (Why

Re: [SHR-U] WiFi-related memory leak

2010-02-24 Thread Timo Juhani Lindfors
Denis Shulyaka shuly...@gmail.com writes: I have no idea why it decreased. I guess kernel unloads some parts of executable that are not executed ATM. Ah that is true, read-only mappings do not need to be kept in memory. BTW, what kind of WiFi authentication and encryption do you use? I use

Re: [SHR-U] WiFi-related memory leak

2010-02-22 Thread Bastian Muck
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Am 21.02.2010 10:37, schrieb Timo Juhani Lindfors: Denis Shulyaka shuly...@gmail.com writes: It writes output of `ps auxf`, `free` and `df -h` to a corresponding file every 5 minutes. Hmm, you are using swap. I do not know how to see how many

Re: [SHR-U] WiFi-related memory leak

2010-02-22 Thread Timo Juhani Lindfors
Bastian Muck bastian.m...@gmx.de writes: I know, I can't help that much, but I am sure that midori is the problem. I often hear music with vagalume over wlan and it is no problem to hear 3 or 4 hours. But if I use Midori then after 10 minutes (and sometimes less) the system hangs because of no

Re: [SHR-U] WiFi-related memory leak

2010-02-21 Thread rixed
What additional info I can gather? Use slabtop to monitor kernel memory pools. It may be interresting. ___ Openmoko community mailing list community@lists.openmoko.org http://lists.openmoko.org/mailman/listinfo/community

Re: [SHR-U] WiFi-related memory leak

2010-02-21 Thread Timo Juhani Lindfors
Denis Shulyaka shuly...@gmail.com writes: It writes output of `ps auxf`, `free` and `df -h` to a corresponding file every 5 minutes. Hmm, you are using swap. I do not know how to see how many bytes each process has in swap. This would let us see which process is the one whose memory usage

Re: [SHR-U] WiFi-related memory leak

2010-02-20 Thread Denis Shulyaka
2010/2/19 Denis Shulyaka shuly...@gmail.com: I'll do some logging of `ps auxf`, `free` and `df -h` every 5 minutes. OK, I did some tests today, here are the logs: ftp://shulyaka.org.ru/pub/memlog.tar.bz2 I have rebooted the phone to get clear results, started WiFi, Midori and

Re: [SHR-U] WiFi-related memory leak

2010-02-19 Thread Timo Juhani Lindfors
Denis Shulyaka shuly...@gmail.com writes: Is it a known problem, or I have unique combination of AP software and FR settings? Never heard of such a problem. Can you make it happen again? Write a cron job that logs the output of ps axuf to file every 30 minutes for example. This makes it easy to

Re: [SHR-U] WiFi-related memory leak

2010-02-19 Thread omcomali . rhn
On Thu, 18 Feb 2010 16:18:32 -0800 (PST) vancel35 van...@thespazcat.com wrote: I don't know if what I saw was the same problem, but I left mine on my wifi ovenight and when I woke up, it wasn't responding very quickly, but as far as I know, nothing had been killed. I didn't even think

Re: [SHR-U] WiFi-related memory leak

2010-02-19 Thread William Kenworthy
On Fri, 2010-02-19 at 09:42 +0100, omcomali@porcupinefactory.org wrote: On Thu, 18 Feb 2010 16:18:32 -0800 (PST) vancel35 van...@thespazcat.com wrote: I don't know if what I saw was the same problem, but I left mine on my wifi ovenight and when I woke up, it wasn't responding very

Re: [SHR-U] WiFi-related memory leak

2010-02-19 Thread Denis Shulyaka
2010/2/19 Timo Juhani Lindfors timo.lindf...@iki.fi: Never heard of such a problem. Can you make it happen again? Write a cron job that logs the output of ps axuf to file every 30 minutes for example. This makes it easy to see if some process is consuming more and more memory. Yes, it happens

Re: [SHR-U] Wifi stopped working

2010-02-18 Thread vancel35
An update here. I upgraded my phone the night before last, and my wifi works again. I had just given up and was upgrading nightly. I'm not sure what specific package fixed it, but I noticed that some of the core packages were updated (such as phonefsod, libframeworkd, mdbus2, etc.). I think

Re: [SHR-U] WiFi-related memory leak

2010-02-18 Thread vancel35
I don't know if what I saw was the same problem, but I left mine on my wifi ovenight and when I woke up, it wasn't responding very quickly, but as far as I know, nothing had been killed. I didn't even think about the Wifi being the problem. If it's data-related, I probably didn't have enough

Re: [SHR-U] Wifi stopped working

2010-02-13 Thread Neil Jerram
On 12 February 2010 17:43, vancel35 van...@thespazcat.com wrote: On a recent update/upgrade, I lost my ability to see wifi connections.  [...] Sounds to me like a missing or not working kernel module - but I'm totally guessing. Have you also asked on the shr-users mailing list? Regards,

Re: [SHR-U] Wifi?

2010-01-12 Thread Al Johnson
On Monday 04 January 2010, Sebastian Krzyszkowiak wrote: I didn't try bluetooth, but WiFi just works here with plain wpa_supplicant, with open, WPA and WEP networks. When signal is weak, wmiconfig -i eth0 --power maxperf is sometimes very helpful. This is also needed for certain access points

Re: [SHR-U] Wifi?

2010-01-09 Thread Paul Fertser
Iain B. FIndleton ifindle...@videotron.ca writes: Anybody actually have reliable bluetooth and/or wifi working on the SHR-U using the .29 kernel from last December? Yes, bluetooth networking just worked for me. Please refer to [1]. Unfortunately, pidof trick doesnt't work anymore with the

Re: [SHR-U] Wifi?

2010-01-04 Thread Sebastian Krzyszkowiak
On Mon, Jan 4, 2010 at 20:03, Iain B. FIndleton ifindle...@videotron.ca wrote: After many spent hours trying to get wifi and bluetooth up and running on SHR-U, I am about to conclude that these features just do not work. Wifi, after doing the bind and module reload things, works for about 10

Re: [SHR-U] Wifi?

2010-01-04 Thread Neil Jerram
2010/1/4 Sebastian Krzyszkowiak seba.d...@gmail.com: I didn't try bluetooth, but WiFi just works here with plain wpa_supplicant, with open, WPA and WEP networks. Is plain wpa_supplicant the default SHR setup? Last time I checked, I thought it wasn't. I've always wondered why not, as none of

Re: [SHR-U] Wifi?

2010-01-04 Thread Christian Rüb
I didn't try bluetooth, but WiFi just works here with plain wpa_supplicant, with open, WPA and WEP networks. Is plain wpa_supplicant the default SHR setup? Last time I checked, I thought it wasn't. I've always wondered why not, as none of the other options (Mofi, wicd etc.) have ever

Re: [SHR-U] Wifi?

2010-01-04 Thread Michael Smith
On Mon, 4 Jan 2010 22:19:10 +0100 Christian Rüb christian.r...@gmx.net wrote: +1 for plain wpa_supplicant in SHR I tried several GUIs but none of them was sufficient - now I use wpa_supplicant (in roaming mode with config file, not dbus) and wpa_gui to configure my wpa_supplicant.conf.

Re: [SHR-U] Wifi?

2010-01-04 Thread Petr Vanek
Plain wpa_supplicant has been working for me for many months now (no encryption, WPA(2) PSK, WEP). Can you post a quick howto here on how you do that? http://wiki.openmoko.org/wiki/WiFi#Using_wpa_supplicant_manually P. ___ Openmoko community

Re: [SHR-U] Wifi?

2010-01-04 Thread Michael Smith
On Mon, 4 Jan 2010 22:35:24 +0100 Petr Vanek van...@penguin.cz wrote: Plain wpa_supplicant has been working for me for many months now (no encryption, WPA(2) PSK, WEP). Can you post a quick howto here on how you do that? http://wiki.openmoko.org/wiki/WiFi#Using_wpa_supplicant_manually

Re: [SHR-U] Wifi?

2010-01-04 Thread Petr Vanek
http://wiki.openmoko.org/wiki/WiFi#Using_wpa_supplicant_manually Okay thanks. I am thinking that it should be possible to put most of that procedure into a package, with a launcher icon to initiate the i myself use iwconfig (the dbus methods just don't work for me...), but it would not be too

Re: [SHR-U] Wifi?

2010-01-04 Thread Christian Rüb
Plain wpa_supplicant has been working for me for many months now (no encryption, WPA(2) PSK, WEP). Can you post a quick howto here on how you do that? http://wiki.openmoko.org/wiki/WiFi#Using_wpa_supplicant_manually P. I use it in conjunction with a wpa_action script (from Debian),

Re: [shr-u] wifi connection

2009-12-04 Thread Arigead
William Kenworthy wrote: On Thu, 2009-12-03 at 11:00 -0500, Iain B. Findleton wrote: Arigead wrote: Hello All, I was going to try and connect my FR to my laptop with an ad-hoc wifi connection but being as I've never even connected to infrastructure I decided that I'd start there. I

Re: [shr-u] wifi connection

2009-12-04 Thread Kosa
Arigead escribió: William Kenworthy wrote: On Thu, 2009-12-03 at 11:00 -0500, Iain B. Findleton wrote: Arigead wrote: Hello All, I was going to try and connect my FR to my laptop with an ad-hoc wifi connection but being as I've never even connected to infrastructure I decided that I'd

Re: [shr-u] wifi connection

2009-12-04 Thread Arigead
Kosa wrote: Arigead escribió: William Kenworthy wrote: On Thu, 2009-12-03 at 11:00 -0500, Iain B. Findleton wrote: Arigead wrote: Hello All, I was going to try and connect my FR to my laptop with an ad-hoc wifi connection but being as I've never even connected to infrastructure I

Re: [shr-u] wifi connection

2009-12-03 Thread Iain B. Findleton
Arigead wrote: Hello All, I was going to try and connect my FR to my laptop with an ad-hoc wifi connection but being as I've never even connected to infrastructure I decided that I'd start there. I followed the instructions in the wiki [1] but got some strange results: ifdown eth0 ifup

Re: [shr-u] wifi connection

2009-12-03 Thread William Kenworthy
On Thu, 2009-12-03 at 11:00 -0500, Iain B. Findleton wrote: Arigead wrote: Hello All, I was going to try and connect my FR to my laptop with an ad-hoc wifi connection but being as I've never even connected to infrastructure I decided that I'd start there. I followed the instructions

Re: SHR-U wifi problem!!

2009-10-31 Thread Mario Huelsegge
Aditya Gandhi wrote: I dont know about encryption problems And its recursive even after reboot The aux buttin red led starts blinking after about 5-10 secs I got the same problem with mokonnect using wep encryption (blinking aux light). After switching to wpa2 mokonnect worked without

Re: SHR-U wifi problem!!

2009-10-31 Thread Aditya Gandhi
Thanks I do use wep On Sat, Oct 31, 2009 at 9:16 PM, Mario Huelsegge huelse...@gmx.de wrote: Aditya Gandhi wrote: I dont know about encryption problems And its recursive even after reboot The aux buttin red led starts blinking after about 5-10 secs I got the same problem with

Re: SHR-U wifi problem!!

2009-10-30 Thread Aditya Gandhi
i use mokonet to connect On Sat, Oct 31, 2009 at 1:00 AM, Aditya Gandhi aditya...@gmail.com wrote: I flashed my freerunner with shr-u, did an opkg upgrade now when i try connecting to wifi it hangs, stops responding... ___ Openmoko community mailing

Re: SHR-U wifi problem!!

2009-10-30 Thread Matthias Huber
Aditya Gandhi schrieb: i use mokonet to connect On Sat, Oct 31, 2009 at 1:00 AM, Aditya Gandhi aditya...@gmail.com mailto:aditya...@gmail.com wrote: I flashed my freerunner with shr-u, did an opkg upgrade now when i try connecting to wifi it hangs, stops responding... strange. is

Re: SHR-U wifi problem!!

2009-10-30 Thread Aditya Gandhi
I dont know about encryption problems And its recursive even after reboot The aux buttin red led starts blinking after about 5-10 secs On Sat, Oct 31, 2009 at 1:35 AM, Matthias Huber matthias.hu...@wollishausen.de wrote: Aditya Gandhi schrieb: i use mokonet to connect On Sat, Oct 31, 2009

Re: SHR-U wifi problem!!

2009-10-30 Thread Aditya Gandhi
I did a reinstall using usbnet still the same problem On Sat, Oct 31, 2009 at 1:46 AM, Aditya Gandhi aditya...@gmail.com wrote: I dont know about encryption problems And its recursive even after reboot The aux buttin red led starts blinking after about 5-10 secs On Sat, Oct 31, 2009 at 1:35

Re: [SHR-u] Wifi, Keyboard and scripting

2009-10-28 Thread Al Johnson
On Wednesday 28 October 2009, Johan Kraft wrote: Hi all, I have got a couple of questions regarding the latest SHR-u. Is is possible to have it _not_ suspend as default when on battery? Settings - Power in the 'Power Settings' section How do I turn on the wifi radio from the command line

Re: [SHR-u] Wifi, Keyboard and scripting

2009-10-28 Thread Petr Vanek
Is is possible to have it _not_ suspend as default when on battery? Settings-Power-Auto-suspend: Off How do I turn on the wifi radio from the command line (instead of going through the settings)? opkg install fsoraw fsoraw --help How do I run a script automatically at the end of the start up

Re: [SHR-u] Wifi, Keyboard and scripting

2009-10-28 Thread Matthias Huber
Johan Kraft schrieb: How do I run a script automatically at the end of the start up process? make a script: /etc/init.d/johankraft chmod +x /etc/init.d/johankraft cd /etc/init.d/rc5.d ln -s ../init.d/johannkraft S99johannkraft ___ Openmoko community

Re: [SHR-u] Wifi, Keyboard and scripting

2009-10-28 Thread Johan Kraft
Hi, Thanks for the answers, they are just what I needed. I should have been more clear on the first one though. I asked: Is is possible to have it _not_ suspend as default when on battery? What I really meant was: Is is possible to have the FR _not_ suspend as default when on battery, without

Re: [SHR-u] Wifi, Keyboard and scripting

2009-10-28 Thread Matthias Huber
Johan Kraft schrieb: Hi, Thanks for the answers, they are just what I needed. I should have been more clear on the first one though. I asked: Is is possible to have it _not_ suspend as default when on battery? What I really meant was: Is is possible to have the FR _not_ suspend as

Re: [shr-u] wifi timeout with mokonnect

2009-08-23 Thread Rask Ingemann Lambertsen
On Thu, Aug 20, 2009 at 12:16:02AM +0200, Bernhard Reiter wrote: Am Sonntag, den 16.08.2009, 21:00 +0200 schrieb Rask Ingemann Lambertsen: Someone needs to sit down with the firmware interface specification (i.e. from the existing driver?) and match it up with the Linux network device API

Re: [shr-u] wifi timeout with mokonnect

2009-08-19 Thread Bernhard Reiter
Am Sonntag, den 16.08.2009, 21:00 +0200 schrieb Rask Ingemann Lambertsen: What little I've seen of that code does not look promising. The author didn't understand the netif_stop_queue()/netif_wake_queue() calls, so who knows what else might have gone wrong? Someone needs to sit down with the

Re: [shr-u] wifi timeout with mokonnect

2009-08-17 Thread Rask Ingemann Lambertsen
On Sat, Aug 15, 2009 at 01:14:37AM +0400, Paul Fertser wrote: I really hoped Werner would take care of that but he's too busy with gta02-core project currently and we lack another expert in Wifi in general and Atheros's crappy code in particular :( What little I've seen of that code does

Re: [shr-u] wifi timeout with mokonnect

2009-08-15 Thread Paul Fertser
arne anka openm...@ginguppin.de writes: and the fr is shock frozen. not really convincing a performance. Reproduced it. Thanks for the bugreport, will try to investigate. Sorry for misinformation, i guess i did something slightly different before so it didn't result in kernel panic. Sorry :(

Re: [shr-u] wifi timeout with mokonnect

2009-08-15 Thread arne anka
Sorry for misinformation, i don't think misinformation is the right word here -- at least it helped me to understnad, what is supposed to be done and to happen. and it looks like that instigated other people as well to try again. if you or someone else can make something from the output, i'd

Re: [shr-u] wifi timeout with mokonnect

2009-08-15 Thread William Kenworthy
The way I got around this is to use two scripts - the first just handles spawning wpa_suppliocant and stops at a read statement - then hitting a return key exits the script. The various rm and kill commands are to cleanup before and after - needed for reliable and repeatable connections! This

Re: [shr-u] wifi timeout with mokonnect

2009-08-14 Thread arne anka
well, i did right now # fsoraw -r WiFi -- wpa_supplicant -ieth0 -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf which resulted in ioctl[SIOCSIWENCODEEXT]: Operation not supported ioctl[SIOCSIWENCODEEXT]: Operation not supported ioctl[SIOCSIWENCODEEXT]: Operation not supported

Re: Re: [shr-u] wifi timeout with mokonnect

2009-08-14 Thread Peter Mogensen
arne anka wrote: well, i did right now # fsoraw -r WiFi -- wpa_supplicant -ieth0 -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf which resulted in [snip a lot] indefinitely. I get excatly the same. Only once have I managed to get a DHCP lease, but the network failed just after

Re: [shr-u] wifi timeout with mokonnect

2009-08-14 Thread Paul Fertser
Peter Mogensen a...@bigendian.dk writes: Some one must know what has changed? New kernel? Well, i must admit i collected several reports that despite huge gains from moving to upstream SDIO stack there're some regressions. Several people reported they can't connect to the networks they were able

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Adam Jimerson
On Wednesday 12 August 2009 11:19:55 am you wrote: Adam, i can't see a decent reason for you to omit the list from CC. On Wed, Aug 12, 2009 at 11:09:35AM -0400, Adam Jimerson wrote: On Wednesday 12 August 2009 04:57:48 am you wrote: Adam Jimerson vend...@gmail.com writes: On Tuesday 11

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Paul Fertser
Adam Jimerson vend...@gmail.com writes: wpa_supplicant never gets DHCP, that's something a dhcp client should be used for. Also you don't say if you tried the maxperf trick or not. I know that wpa_supplicant doesn't handle DHCP but when I was using it then the ifup command would say that it

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread arne anka
I know that wpa_supplicant doesn't handle DHCP but when I was using it then the ifup command would say that it connected, didn't return an error, but DHCP would always fail but it never did this before. ifup command is unnecessary here and quite possibly messes something up. ok, i

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Adam Jimerson
On Thursday 13 August 2009 10:55:38 am arne anka wrote: I know that wpa_supplicant doesn't handle DHCP but when I was using it then the ifup command would say that it connected, didn't return an error, but DHCP would always fail but it never did this before. ifup command is

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Paul Fertser
Adam Jimerson vend...@gmail.com writes: On Thursday 13 August 2009 10:55:38 am arne anka wrote: I know that wpa_supplicant doesn't handle DHCP but when I was using it then the ifup command would say that it connected, didn't return an error, but DHCP would always fail but it never did

Re: Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Peter Mogensen
Paul Fertser wrote: Adam Jimerson vend...@gmail.com writes: Same here I would like to know how to connect to a network without using the ifconfig commands 0. So, clean boot, you didn't touch resource policies in any way (SHR settings/mdbus/whatever). 1. Then ``vim

Re: [shr-u] wifi timeout with mokonnect

2009-08-13 Thread Paul Fertser
Peter Mogensen a...@bigendian.dk writes: Paul Fertser wrote: Adam Jimerson vend...@gmail.com writes: Same here I would like to know how to connect to a network without using the ifconfig commands 0. So, clean boot, you didn't touch resource policies in any way (SHR

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Paul Fertser
Bernhard Reiter ock...@raz.or.at writes: Am Dienstag, den 11.08.2009, 10:41 +0400 schrieb Paul Fertser: Please try wpa_supplicant method as described on FSO_Resources wikipage and report the results. ok, using fsoraw it seems to connect to the router (only the important part given here):

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Paul Fertser
Adam Jimerson vend...@gmail.com writes: On Tuesday 11 August 2009 02:41:53 am Paul Fertser wrote: Please try wpa_supplicant method as described on FSO_Resources wikipage and report the results. I know wpa_supplicant stopped working for me, I don't know what went wrong but when I started

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Rui Miguel Silva Seabra
On Wed, Aug 12, 2009 at 12:56:26PM +0400, Paul Fertser wrote: Bernhard Reiter ock...@raz.or.at writes: Am Dienstag, den 11.08.2009, 10:41 +0400 schrieb Paul Fertser: Please try wpa_supplicant method as described on FSO_Resources wikipage and report the results. ok, using fsoraw it seems

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Rui Miguel Silva Seabra
On Wed, Aug 12, 2009 at 11:39:18AM +0100, Rui Miguel Silva Seabra wrote: On Wed, Aug 12, 2009 at 12:56:26PM +0400, Paul Fertser wrote: Bernhard Reiter ock...@raz.or.at writes: Am Dienstag, den 11.08.2009, 10:41 +0400 schrieb Paul Fertser: Please try wpa_supplicant method as described on

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Adolph J. Vogel
i don't think i've ever got wifi to work I feel your pain :( ___ Openmoko community mailing list community@lists.openmoko.org http://lists.openmoko.org/mailman/listinfo/community

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Paul Fertser
Adolph J. Vogel ajvo...@tuks.co.za writes: i don't think i've ever got wifi to work I feel your pain :( Try to do what's written on FSO_Resources wiki page and report the results. The wlan chip _is_ compatible with most APs and the proposed method of using it _does_ in fact work. -- Be free,

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Nicola Mfb
On Mon, Aug 10, 2009 at 2:43 PM, Bernhard Reiterock...@raz.or.at wrote: hi, using shr-u and mokonnect, i get a timeout when trying to connect to my managed wpa-secured home wlan router (while it is trying to setup dhcp, though things work fine with my laptop). is this some well-known issue

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Paul Fertser
Adolph J. Vogel ajvo...@tuks.co.za writes: Im sorry if this is an obvious question, but what kernel is wifi bug free? There's no such kernel in existance. And wifi firmware is not bugfree and most probably will never be. Blame Canada^W Atheros. Or buy a decent usb wifi dongle. :( -- Be free,

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Al Johnson
On Wednesday 12 August 2009, Paul Fertser wrote: Adolph J. Vogel ajvo...@tuks.co.za writes: Im sorry if this is an obvious question, but what kernel is wifi bug free? There's no such kernel in existance. And wifi firmware is not bugfree and most probably will never be. Blame Canada^W

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Rui Miguel Silva Seabra
On Wed, Aug 12, 2009 at 03:04:26PM +0400, Paul Fertser wrote: Rui Miguel Silva Seabra r...@1407.org writes: On Wed, Aug 12, 2009 at 12:56:26PM +0400, Paul Fertser wrote: Bernhard Reiter ock...@raz.or.at writes: CTRL-EVENT-SCAN-RESULTS Trying to associate with mac address (SSID='SSID'

Re: [shr-u] wifi timeout with mokonnect

2009-08-12 Thread Rui Miguel Silva Seabra
On Wed, Aug 12, 2009 at 03:09:44PM +0200, Adolph J. Vogel wrote: Rui, what kernel are you using? r...@om-gta02 ~ $ uname -a Linux om-gta02 2.6.29-rc3 #1 PREEMPT Sun Aug 2 12:17:54 CEST 2009 armv4tl unknown (which I think is the most recent uImage available on 2009/08/08). With the shr-image

Re: [shr-u] wifi timeout with mokonnect

2009-08-11 Thread Robin Paulson
2009/8/11 Rui Miguel Silva Seabra r...@1407.org: To me it has never worked, but never means in images 20090721 and 20090808 of shr-u It doesn't even bother to set the SSID, but I don't know who's really at fault here, mokonnect or connman. Anyway, connman is a real piece of crap (but

Re: [shr-u] wifi timeout with mokonnect

2009-08-11 Thread Paul Fertser
Robin Paulson robin.paul...@gmail.com writes: 2009/8/11 Rui Miguel Silva Seabra r...@1407.org: Anyway, connman is a real piece of crap (but NetworkManager is just marginally lesser crap) sprout from people with NIH sindrome who don't understand NM. does wifi work yet with newer kernels? i

Re: [shr-u] wifi timeout with mokonnect

2009-08-11 Thread Rui Miguel Silva Seabra
On Tue, Aug 11, 2009 at 06:37:03PM +1200, Robin Paulson wrote: 2009/8/11 Rui Miguel Silva Seabra r...@1407.org: To me it has never worked, but never means in images 20090721 and 20090808 of shr-u It doesn't even bother to set the SSID, but I don't know who's really at fault here,

Re: [shr-u] wifi timeout with mokonnect

2009-08-11 Thread Adam Jimerson
On Tuesday 11 August 2009 02:41:53 am Paul Fertser wrote: Robin Paulson robin.paul...@gmail.com writes: 2009/8/11 Rui Miguel Silva Seabra r...@1407.org: Anyway, connman is a real piece of crap (but NetworkManager is just marginally lesser crap) sprout from people with NIH sindrome who don't

Re: [shr-u] wifi timeout with mokonnect

2009-08-11 Thread Bernhard Reiter
Am Dienstag, den 11.08.2009, 10:41 +0400 schrieb Paul Fertser: Please try wpa_supplicant method as described on FSO_Resources wikipage and report the results. ok, using fsoraw it seems to connect to the router (only the important part given here): CTRL-EVENT-SCAN-RESULTS Trying to associate

Re: [shr-u] wifi timeout with mokonnect

2009-08-10 Thread Adam Jimerson
On Monday 10 August 2009 08:43:40 am Bernhard Reiter wrote: hi, using shr-u and mokonnect, i get a timeout when trying to connect to my managed wpa-secured home wlan router (while it is trying to setup dhcp, though things work fine with my laptop). is this some well-known issue or do i have

Re: [shr-u] wifi timeout with mokonnect

2009-08-10 Thread Rui Miguel Silva Seabra
On Mon, Aug 10, 2009 at 11:11:54AM -0400, Adam Jimerson wrote: On Monday 10 August 2009 08:43:40 am Bernhard Reiter wrote: hi, using shr-u and mokonnect, i get a timeout when trying to connect to my managed wpa-secured home wlan router (while it is trying to setup dhcp, though things