Re: Freerunner LightSaber

2009-02-25 Thread KaZeR
kris Occhipinti wrote: I don't know what to tell you. I'm running om2008.9 and I don't think I did anything special other then install pygame as I posted above. As far as it running under Debian, I'm also running Hackable1 (based on Debian) and I can not get pygame to see the sound

Re: Freerunner LightSaber

2009-02-25 Thread kris Occhipinti
which link? this one: http://filmsbykris.com/freerunner-debian/ko-user/ko-lightsaber.tar.gz I just checked and it works On Wed, Feb 25, 2009 at 11:11 AM, KaZeR ka...@altern.org wrote: kris Occhipinti wrote: I don't know what to tell you. I'm running om2008.9 and I don't think I did

Re: Freerunner LightSaber

2009-01-30 Thread kris Occhipinti
I don't know what to tell you. I'm running om2008.9 and I don't think I did anything special other then install pygame as I posted above. As far as it running under Debian, I'm also running Hackable1 (based on Debian) and I can not get pygame to see the sound card. I'm still trying to figure

Re: Freerunner LightSaber

2009-01-29 Thread Daniel Spies
On Sun, 18 Jan 2009 09:18:56 -0500, kris Occhipinti metalx2...@gmail.com wrote: Well, I have Hackable1 installed on my Freerunner as well, and I thought it would work on that no problem after installing python-pygame. But, after installing pygame (apt-get install python-pygame) I tried to run

RE: Freerunner LightSaber

2009-01-29 Thread KaZeR
-Message d'origine- I guess SHR doesn't have pygame in the repos, and I don't feel like trying to brick my distro right now... :P Oh well. I also use SHR and installed the pygame and libsmpeg packages from http://rabenfrost.net/celtune/ipk/armv4t/ (without changing the

Re: Freerunner LightSaber

2009-01-28 Thread Daniel Spies
On Wed, 28 Jan 2009 18:21:51 -0500, kris Occhipinti metalx2...@gmail.com wrote: What OS are you running? when you installed it did it give any errors? I tried it on FSO-testing and installed all packages that could have been missing. How to install the app? I copied the files to /usr...

Re: Freerunner LightSaber

2009-01-27 Thread Daniel Spies
kris Occhipinti metalx2...@gmail.com wrote on Saturday 17 January 2009: Well, a few months ago, before I have a FreeRunner I saw a LightSaber application for the iPhone, I thought was neat. So, I made My own for the FreeRunner Yesterday. Here is the link

Re: Freerunner LightSaber

2009-01-25 Thread Jan Henkins
Hello Kris, Thanks a million!! What a laugh! I use it on OM2008.12. I'm starting it up with a dirty little script to set /sys/devices/platform/lis302dl.2/threshold value to 5 during play, and to then set it back to whatever the value was before. Thanks to matthias for this tip. --start---

Re: Freerunner LightSaber

2009-01-18 Thread Tim Dobson
kris Occhipinti wrote: I forgot to mention the need for pygame. I'm still running om2008.9 and I installed pygame like this g iopkg install http://www.angstrom-distribution.org/unstable/armv4t/python/python-pygame_1.7.1-ml2_armv4t.ipk If you have pygame installed it should work, I'll

Re: Freerunner LightSaber

2009-01-18 Thread Francesco de Virgilio
Stopping speech-sipatcher it works, but it seems a bit slow to percept the movements... however, great app, thanks!! Korbinian Rosenegger wrote: Hi On Sat, 2009-01-17 at 18:30 +0100, Francesco de Virgilio wrote: Great app, but... On 2008.12 I've installed python-pygame and this follows

Re: Freerunner LightSaber

2009-01-18 Thread matthias
For me (running OM2008.12) ko-lightsaber works fine with the following tweakings: echo 100 /sys/devices/platform/lis302dl.2/sample_rate echo5 /sys/devices/platform/lis302dl.2/threshold play around with threshold-values around 10. cat /sys/devices/platform/lis302dl.2/threshold says 0 (???), but

Re: Freerunner LightSaber

2009-01-18 Thread Davide Scaini
Someone tryed it with success on debian? d On Sun, Jan 18, 2009 at 12:18 PM, Francesco de Virgilio fradev...@gmail.com wrote: Stopping speech-sipatcher it works, but it seems a bit slow to percept the movements... however, great app, thanks!! Korbinian Rosenegger wrote: Hi On Sat,

Re: Freerunner LightSaber

2009-01-18 Thread Christian Reitwie├čner
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 The Digital Pioneer schrieb: I guess SHR doesn't have pygame in the repos, and I don't feel like trying to brick my distro right now... :P Oh well. I also use SHR and installed the pygame and libsmpeg packages from

Re: Freerunner LightSaber

2009-01-18 Thread kris Occhipinti
Well, I have Hackable1 installed on my Freerunner as well, and I thought it would work on that no problem after installing python-pygame. But, after installing pygame (apt-get install python-pygame) I tried to run it and I got an error message: open /dev/sequencer or /dev/snd/seq: No such file or

Re: Freerunner LightSaber

2009-01-18 Thread Charles-Henri Gros
matthias wrote: Fine, excactly the right thing for my boredom right now! but you should have mentioned the dependencies from python-pygame. on om2008.12 it seemed quite slow to me and did not recognized my movements, but let's try it a few more times! Accelerometers don't appear to work

Re: Freerunner LightSaber

2009-01-17 Thread Riccardo Centra
Upload it on opkg.org 2009/1/17 kris Occhipinti metalx2...@gmail.com Well, a few months ago, before I have a FreeRunner I saw a LightSaber application for the iPhone, I thought was neat. So, I made My own for the FreeRunner Yesterday. Here is the link

Re: Freerunner LightSaber

2009-01-17 Thread matthias
Fine, excactly the right thing for my boredom right now! but you should have mentioned the dependencies from python-pygame. on om2008.12 it seemed quite slow to me and did not recognized my movements, but let's try it a few more times! Good work! :) That's apps we need for making the freerunner

Re: Freerunner LightSaber

2009-01-17 Thread The Digital Pioneer
I guess SHR doesn't have pygame in the repos, and I don't feel like trying to brick my distro right now... :P Oh well. -- Thanks, The Digital Pioneer ___ Openmoko community mailing list community@lists.openmoko.org

Re: Freerunner LightSaber

2009-01-17 Thread Francesco de Virgilio
Great app, but... On 2008.12 I've installed python-pygame and this follows when I try to run the program: r...@om-gta02:~# export DISPLAY=:0 r...@om-gta02:~# ko-lightsaber Traceback (most recent call last): File /usr/bin/ko-lightsaber, line 32, in module pygame.mixer.init() pygame.error:

Re: Freerunner LightSaber

2009-01-17 Thread kris Occhipinti
I forgot to mention the need for pygame. I'm still running om2008.9 and I installed pygame like this g iopkg install http://www.angstrom-distribution.org/unstable/armv4t/python/python-pygame_1.7.1-ml2_armv4t.ipk If you have pygame installed it should work, I'll look into the pygame.error: No

Re: Freerunner LightSaber

2009-01-17 Thread The Digital Pioneer
On Sat, Jan 17, 2009 at 12:25 PM, kris Occhipinti metalx2...@gmail.comwrote: and installing pygame should brick your distro. How comforting. ;) Don't worry, I know what you mean. I tried installing it, and after just a little manual dependency following, I got concerned about upgrading my c

Re: Freerunner LightSaber

2009-01-17 Thread Korbinian Rosenegger
Hi On Sat, 2009-01-17 at 18:30 +0100, Francesco de Virgilio wrote: Great app, but... On 2008.12 I've installed python-pygame and this follows when I try to run the program: r...@om-gta02:~# export DISPLAY=:0 r...@om-gta02:~# ko-lightsaber Traceback (most recent call last): File