Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-13 Thread Didier Ptitjes
Believe me or not: A fresh new Makefile in a correct ~moko home. $ make setup $ make setup-machine-freerunner Edit build/conf/local.conf MACHINE = x86 DISTRO = openmoko BUILD_ARCH = i686 INHERIT += devshell TARGET_FPU = $ make image does the unable to open local.conf error. Add INHERIT +=

Re: Problems building ASU image

2008-09-12 Thread Davide Scaini
permissions??? maybe it's really silly... d On Fri, Sep 12, 2008 at 1:44 PM, Didier Ptitjes [EMAIL PROTECTED] wrote: Hello, Sorry this may be a dumb question. I'm trying to build an ASU image for x86 with the MokoMakefile for several days without success. I carefully followed the

Re: Problems building ASU image

2008-09-12 Thread Didier Ptitjes
But if you look at the log it can read the conf files! Anyway, I've got rw on all my files... Didier. Davide Scaini wrote: permissions??? maybe it's really silly... d On Fri, Sep 12, 2008 at 1:44 PM, Didier Ptitjes [EMAIL PROTECTED] mailto:[EMAIL PROTECTED] wrote: Hello,

Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Didier Ptitjes
Hello, It seems that the Wiki is outdated. For example, the Wiki says you have to make openmoko-devel-image or openmoko-qtopia-x11-image. But the MokoMakefile version I downloaded has no such target but you have to set OM_IMAGE_NAME := openmoko-asu-image in the Makefile and make

Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Didier Ptitjes
OK I found the problem finaly. The Wiki states what follows for the local.conf : MACHINE = x86 DISTRO = openmoko BUILD_ARCH = i686 INHERIT += devshell TARGET_FPU = but the INHERIT += rm_work is mandatory else the bitbake doesn't work at all as you can see in the errors of my previous

Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Rod Whitby
Didier Ptitjes wrote: OK I found the problem finaly. The Wiki states what follows for the local.conf : MACHINE = x86 DISTRO = openmoko BUILD_ARCH = i686 INHERIT += devshell TARGET_FPU = but the INHERIT += rm_work is mandatory else the bitbake doesn't work at all as you can see

Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Rod Whitby
Didier Ptitjes wrote: It seems that the Wiki is outdated. Yes, wiki's are always outdated. :-( For example, the Wiki says you have to make openmoko-devel-image or openmoko-qtopia-x11-image. But the MokoMakefile version I downloaded has no such target but you have to set

Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Didier Ptitjes
Rod Whitby wrote: Didier Ptitjes wrote: It seems that the Wiki is outdated. Please update the wiki to match reality. I'll do it. I'm wondering if anyone has done a fresh build restarting from scratch with the MokoMakefile as I can't explain my problems. Yes. Make sure you always make

Re: Wiki outdated ? was Re: Problems building ASU image

2008-09-12 Thread Rod Whitby
Didier Ptitjes wrote: I just noticed that this behavior only occurs when building for the x86 machine. I say this if this can help to identify the problem. Do you mean x86 as a host, or x86 as a target. x86 as a target is not supported, and x86 as a host is what everyone uses, so you can