Re: [compiz] Which effects are 3D and which are 2D?

2009-03-05 Thread Pierpaolo Follia
On Thu, Mar 5, 2009 at 20:12, Dotan Cohen dotanco...@gmail.com wrote:
 AMD is dropping support for the R300-R500 cards in their official drivers:
 http://www.phoronix.com/scan.php?page=articleitem=amd_r500_legacynum=1

 As the current open source drivers do not support 3D, I'd like to know
 which Compiz effects use 3D and which use 2D. Thanks.

This is not true. I'm using it right now on my r300 card. The new
driver now supports also r600-700 cards.

bye


 --
 Dotan Cohen

 http://what-is-what.com
 http://gibberish.co.il

 א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-נ-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת
 ا-ب-ت-ث-ج-ح-خ-د-ذ-ر-ز-س-ش-ص-ض-ط-ظ-ع-غ-ف-ق-ك-ل-م-ن-ه‍-و-ي
 А-Б-В-Г-Д-Е-Ё-Ж-З-И-Й-К-Л-М-Н-О-П-Р-С-Т-У-Ф-Х-Ц-Ч-Ш-Щ-Ъ-Ы-Ь-Э-Ю-Я
 а-б-в-г-д-е-ё-ж-з-и-й-к-л-м-н-о-п-р-с-т-у-ф-х-ц-ч-ш-щ-ъ-ы-ь-э-ю-я
 ä-ö-ü-ß-Ä-Ö-Ü
 ___
 compiz mailing list
 compiz@lists.freedesktop.org
 http://lists.freedesktop.org/mailman/listinfo/compiz




-- 
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Running Compiz in XGL

2008-04-30 Thread Pierpaolo Follia
To disable XGL without removing the package, you can do:

touch ~/.config/xserver-xgl/disable

Bye

On Wed, Apr 30, 2008 at 4:07 AM, Dotan Cohen [EMAIL PROTECTED] wrote:
 2008/4/30 Joel Bosveld [EMAIL PROTECTED]:

  You don't need to do anything to enable aiglx, just removing xgl should
   work. sudo apt-get remove xserver-xgl, though in ubuntu you can create an
   extra file, and it will just not start xgl, which will have the same effect
   (I am just not sure which file that is). Also, compiz won't work with that
   card and the open drivers, so you will have to use fglrx. (just uninstall
   xgl and see if the performance increases)
  
   Joel
   .

  Thank you very much, Joel. Removing xgl has made the machine very,
  very responsive. I'm still using Compiz and the fglrx driver. I'll
  file a bug at Ubuntu suggesting that they disable xgl in these
  configurations. Thanks!



  Dotan Cohen

  http://what-is-what.com
  http://gibberish.co.il
  א-ב-ג-ד-ה-ו-ז-ח-ט-י-ך-כ-ל-ם-מ-ן-נ-ס-ע-ף-פ-ץ-צ-ק-ר-ש-ת

  A: Because it messes up the order in which people normally read text.
  Q: Why is top-posting such a bad thing?
  ___
  compiz mailing list
  compiz@lists.freedesktop.org
  http://lists.freedesktop.org/mailman/listinfo/compiz




-- 
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Slow Scrolling in Compiz

2008-03-07 Thread Pierpaolo Follia
*It is* a driver issue. Sometimes downgrading the driver to version
8.40 can help (but I don't know if your card is supported).

Regards,
Pierpaolo

On Thu, Mar 6, 2008 at 3:34 PM, David C. Rankin
[EMAIL PROTECTED] wrote:
 Clemens Eisserer wrote:
   Well compiz adds some overhead, but without further description about
   your settup there's nothing anybody can say/do.
  
   lg Clemens
  
   2008/1/29, David C. Rankin [EMAIL PROTECTED]:
   Listmates,
  
   Hopefully this is a compiz only question. Using the mouse wheel to
scroll down web pages seems to be much slower in compiz than in kde. It
also affects scrolling through long directories in konqueror (ex:
/usr/share/doc/packages) but to a lesser extent than web content.
Is there any setting, fix or workaround that might help?
  

  Sorry Clemens,

 I should have included the specifics. The system is a Toshiba P35, P4
  3.3GHz, 2G RAM, ATI Mobility Radeon 9600/9700 series running openSuSE
  10.3 with the ATI 8.45.5 driver.

 I don't think it is a memory overhead issue. I have looked closely at
  this with top/free -tm and compiz adds no more that 20M of memory
  overhead which wouldn't be an issue here.

 The slowdown in scrolling I am talking about is by a factor of 2-4
  times slower than without compiz. With kwin, rolling the mouse wheel to
  scroll web pages or konqueror directories results in immediate and crisp
  scrolling of content either up or down depending on wheel rotate
  direction. With compiz there is a notable delay in the time between
  wheel input and scroll response (on the order of milliseconds ~ 400 or 500).

 The scroll delay problem is much improved with the latest 8.45.5 
 driver
  with the delay between wheel input and scroll decreasing greatly, but it
  is still noticeable. Testing now in response to your post, this is much
  improved over the 8.43 and earlier drivers. This leads me to suspect it
  may be more of a driver issue than a compiz issue. I will test with the
  8.47 driver later today or tomorrow and report back.

  --


 David C. Rankin, J.D., P.E.
  Rankin Law Firm, PLLC
  510 Ochiltree Street
  Nacogdoches, Texas 75961
  Telephone: (936) 715-9333
  Facsimile: (936) 715-9339
  www.rankinlawfirm.com
  ___
  compiz mailing list
  compiz@lists.freedesktop.org
  http://lists.freedesktop.org/mailman/listinfo/compiz




-- 
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Blur problems

2007-07-17 Thread Pierpaolo Follia
I have the same problem with a mobility radeon M300 and the same driver.
I don't use trevino packages, but I compile compiz from git almost
every day. Maybe (another) driver bug?

bye

On 7/17/07, Dario Zanzico [EMAIL PROTECTED] wrote:
 I'm using compiz compiled for feisty by trevino, on a mobility radeon x1600
 using fglrx 8.38.6 over Xgl 7.2.0.
 I'm experiencing some problems with the blur: after a short time using
 compiz the blur over
 the windows (most noticeably the terminal) becomes a opaque gray. I really
 don't know how to debug this problem... :(
 I'll be happy to give any information you'll need

 DisgustingAngel

 ___
 compiz mailing list
 compiz@lists.freedesktop.org
 http://lists.freedesktop.org/mailman/listinfo/compiz




-- 
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Blur problems

2007-07-17 Thread Pierpaolo Follia
Disabling video doesn't work for me.
After using blur for a while, alpha doesn't work anymore.

Regards,
Pierpaolo

On 7/17/07, Travis Watkins [EMAIL PROTECTED] wrote:
 On 7/17/07, Dario Zanzico [EMAIL PROTECTED] wrote:
  I'm using compiz compiled for feisty by trevino, on a mobility radeon x1600
  using fglrx 8.38.6 over Xgl 7.2.0.
  I'm experiencing some problems with the blur: after a short time using
  compiz the blur over
  the windows (most noticeably the terminal) becomes a opaque gray. I really
  don't know how to debug this problem... :(
  I'll be happy to give any information you'll need
 
  DisgustingAngel
 
  ___
  compiz mailing list
  compiz@lists.freedesktop.org
  http://lists.freedesktop.org/mailman/listinfo/compiz
 
 

 Disable the video plugin and restart compiz. For some reason with Xgl
 it seems to break alpha.

 --
 Travis Watkins
 http://www.realistanew.com
 ___
 compiz mailing list
 compiz@lists.freedesktop.org
 http://lists.freedesktop.org/mailman/listinfo/compiz



-- 
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


[compiz] --replace for gtk-window-decorator

2007-05-08 Thread Pierpaolo Follia

Hi. I noticed that the gtk-window-decorator now ignore the --replace
parameter (it always fails to load if another decorator is running).
I attach a simple patch to solve this problem.

Regards,
Pierpaolo

--
Pierpaolo Follia
http://madchicken.altervista.org/tech
--- gtk-window-decorator.old	2007-05-02 15:26:01.0 +0200
+++ gtk-window-decorator.c	2007-05-08 10:31:26.0 +0200
@@ -6638,6 +6638,10 @@
 
 for (i = 0; i  argc; i++)
 {
+	if (strcmp (argv[i], --replace) == 0)
+	{
+	replace = TRUE;
+	}
 	if (strcmp (argv[i], --minimal) == 0)
 	{
 	minimal = TRUE;
@@ -6759,7 +6763,7 @@
    dm_sn_timestamp);
 if (status != DECOR_ACQUIRE_STATUS_SUCCESS)
 {
-	if (status == DECOR_ACQUIRE_STATUS_OTHER_DM_RUNNING)
+	if (status != DECOR_ACQUIRE_STATUS_OTHER_DM_RUNNING)
 	{
 	fprintf (stderr,
 		 %s: Could not acquire decoration manager 
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Python plugin (Python API for Compiz)

2007-04-10 Thread Pierpaolo Follia

Thank you very much Mike, great work. I'm testing it, and it seems to
run quite well here.
For those who wants to try this plugin, remember to install
python-opengl and python-ctypes, because you need them to load sample
plugins.

Regards,
Pierpaolo


On 4/10/07, Mike Dransfield [EMAIL PROTECTED] wrote:

Here is my python loader plugin which loads plain python
scripts as full plugins.

There is not much documentation, but I have included a few
examples to get you going.

triangle - Just a basic plugin which shows a triangle on a button
press.  This shows using ctypes to pass values from compiz to the
python opengl bindings.

basiczoom - Zooms in on the screen (basically)

inactive - This is a port of my inactive plugin which I mentioned
earlier.  Its only a few lines of easy python code.

The OBJECTS file contains a brief list of each property and method.
I will try to get some proper documentation done soon.

I think most things are complete, the TODO list contains a list of
things I am aware of.  You should be able to do most things that
can be done with c plugins (without the hassle of pointers)

http://www.anykeysoftware.co.uk/compiz/plugins/python.tar.gz

Please report any bugs here or mail me offlist, there are probably
a few :)

___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz




--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


[compiz] gwd crash

2007-03-12 Thread Pierpaolo Follia

Hi, I have a problem when I right click over the title bar of some
windows: often gtk-window-decorator crashes and I have to reload it.
Here is the backtrace:

#0  0xb7f47677 in wnck_workspace_get_viewport_x ()
  from /usr/lib/libwnck-1.so.18
#1  0x080523b2 in action_menu_map (win=0x0, button=3, time=1170838320)
   at gtk-window-decorator.c:4261
#2  0x08052b5a in event_filter_func (gdkxevent=0xbfae3848, event=0x80ac510,
   data=0x0) at gtk-window-decorator.c:4820
#3  0xb7a95021 in gdk_x11_drawable_get_xdisplay ()
  from /usr/lib/libgdk-x11-2.0.so.0
#4  0xb7a9678c in gdk_events_pending () from /usr/lib/libgdk-x11-2.0.so.0
#5  0xb7a983bb in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#6  0xb7a987bf in _gdk_events_init () from /usr/lib/libgdk-x11-2.0.so.0
#7  0xb7785802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#8  0xb77887df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#9  0xb7788b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0xb7c0f574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x08056e6b in main (argc=Cannot access memory at address 0x0
) at gtk-window-decorator.c:6322

Can someone help me?

thanks

--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] gwd crash

2007-03-12 Thread Pierpaolo Follia

Uh! I forgot about that: I installed the avant-window-navigator using
this repository:

http://awn.wetpaint.com/page/Ubuntu+Edgy+Repository

Now I reverted to the original ubuntu packages and gwd works great.
Sorry, I really forgot about those packages.

Thanks,
Pierpaolo

On 3/12/07, dragoran [EMAIL PROTECTED] wrote:


are you using a patched libwnck? if yes with patches are you using?
 thanks






--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


[compiz] Strange issue with windows positioning

2007-03-06 Thread Pierpaolo Follia

Hi, I just compiled and installed the latest compiz from git head and
I have a strange issue with windows positioning: all newly created
windows are placed at 0,0 (upper left corner) of the screen, so the
title bar (and menu bar too) is under my gnome panel. I attach a
screenshot to show the problem. I can't understand if this is a
problem of compiz configuration (plugin order or something related),
or something else.

Compiz is running very well here, this is the only bug I have. Does
anyone has the same issue or can help me solving it?

thank you very much.

--
Pierpaolo Follia
http://madchicken.altervista.org/tech


screenshot1.png
Description: PNG image
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


[compiz] Re: Strange issue with windows positioning

2007-03-06 Thread Pierpaolo Follia

Ok, I solved while writing down the plugin list :)
I missed the place plugin. Sorry guys...and thank you for what you all
are doing.

regards,
Pierpaolo

On 3/6/07, Pierpaolo Follia [EMAIL PROTECTED] wrote:

Sorry, I forgot to write my gconf active plugin list:

gconf,decoration,png,wobbly,fade,minimize,cube,rotate,move,resize,switcher,scale,zoom,dbus,annotate,blur

regards,
Pierpaolo

On 3/6/07, Pierpaolo Follia [EMAIL PROTECTED] wrote:
 Hi, I just compiled and installed the latest compiz from git head and
 I have a strange issue with windows positioning: all newly created
 windows are placed at 0,0 (upper left corner) of the screen, so the
 title bar (and menu bar too) is under my gnome panel. I attach a
 screenshot to show the problem. I can't understand if this is a
 problem of compiz configuration (plugin order or something related),
 or something else.

 Compiz is running very well here, this is the only bug I have. Does
 anyone has the same issue or can help me solving it?

 thank you very much.

 --
 Pierpaolo Follia
 http://madchicken.altervista.org/tech




--
Pierpaolo Follia
http://madchicken.altervista.org/tech




--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


[compiz] Strange issue

2006-12-19 Thread Pierpaolo Follia

Hi to all.
Using Gnome some window are appearing in the task bar on all faces of
the cube. This happens only when I open an application using nautilus
(i.e. when I open a text file from nautilus using the right button of
the mouse the gedit is in the task on all faces).

Is this a known issue?

Regards,
Pierpaolo

--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Compiling under Fedora C6

2006-10-28 Thread Pierpaolo Follia

Thank you very much to all. I was missing the libwnck-devel package,
now I can compile compiz without problem.

Bye,
Pierpaolo

On 10/27/06, Julian Sikorski [EMAIL PROTECTED] wrote:

Mark Rosenstand napisał(a):
 On Fri, 2006-10-27 at 12:03 +0200, Pierpaolo Follia wrote:
 Hi to all. I've just installed a Fedora Core 6 on a Desktop here,
 adding the default distro compiz package. I've some problem when the
 screen saver starts: when I try to enter my password to unlock the
 system, the window has no textbox in which enter my password...I have
 to kill from a console the gnome-screensaver to unlock the system.

 You should file a bug at the Fedora site.

 I saw the version of compiz provided with the distro is really old
 (0.13) and I would like to compile the 0.3.2 to try if I can solve the
 problem.
 When I run the ./configure I get this:

 the following optional plugins will be compiled:
   gconf: yes
   place: yes
   dbus:  yes

 and the following optional features will be compiled:
   svg:  no
   gtk:  no
   metacity: no
   gnome:no
   kde:  no

 What is actually needed to compile compiz with metacity, gtk and gnome 
support?
 Is there somewhere a fc6 rpm of compiz 0.3.2?

 You are probably missing the respective -devel packages. That said,
 compiz on Fedora is patched to use AIGLX instead of Xgl - some of the
 patches have been merged, but I'm not sure if vanilla compiz is going to
 work with AIGLX.

 That said, nothing major has changed since CVS was called 0.0.13 (which
 never had a real release), except for metacity theme support.

 Cheers,
 Mark

 ___
 compiz mailing list
 compiz@lists.freedesktop.org
 http://lists.freedesktop.org/mailman/listinfo/compiz

Here is what I have done:
1. Grabbed fedora compiz source rpm
2. Checked out git compiz
3. Tarred it into compiz-current.tar.bz2
4. Tweaked the spec (you have to pass --enable-librsvg to configure for
svg supoort), built the rpm and installed it.
Keep in mind that desktop-effect will not work with latest vanilla
compiz, but everything else (apart form metacity theme support) works
like charm. Hope that helps. I'm attaching the tweaked spec.


___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz







--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz


Re: [compiz] Window title in bar doesn't change when application requests it

2006-10-20 Thread Pierpaolo Follia

Maybe is a driver problem? I'm using radeon OS driver...

On 10/20/06, Toby Smithe [EMAIL PROTECTED] wrote:

On Fri, 2006-10-20 at 10:05 +0200, Pierpaolo Follia wrote:
 Works well here with the Human default theme. The funny thing is that
 also the minimize button seems ok. I attach a screenshot from my
 desktop.

That is very weird. I have never seen it otherwise on my system, but I'm
running the same packages as you... Strange.





--
Pierpaolo Follia
http://madchicken.altervista.org/tech
___
compiz mailing list
compiz@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/compiz