Re: RFR [16/java.xml] 8248348: Regression caused by the update to BCEL 6.0

2020-06-25 Thread Bernd Eckenfels
Hello, What is the advantage of having such a narrow hashcode value space compared to the built in idendity hashcode? Would stocking to the object idendity not only reduce the footprint, but also make hash lookups faster? Without the unclear relationship to the op code? Gruss Bernd --

RFR [16/java.xml] 8248348: Regression caused by the update to BCEL 6.0

2020-06-25 Thread Joe Wang
Hi, Please review a fix to a BCEL regression. At issue was the addition of hashCode() method to Instruction.java in BCEL 6.0. This hashCode() method was implemented to return the instruction's opcode that unfortunately is mutable. The problem hasn't showed up until the code path led to calls

Re: RFR(T): 8248358: ProblemList sun/nio/ch/TestMaxCachedBufferSize.java on macOSX

2020-06-25 Thread Daniel D. Daugherty
Thanks for the fast review Igor! Dan On 6/25/20 6:38 PM, Igor Ignatyev wrote: Hi Dan, LGTM Thanks, -- Igor JDK-8248358 ProblemList serviceability/jvmti/ModuleAwareAgents/ThreadStart/MAAThreadStart.java on Windows https://bugs.openjdk.java.net/browse/JDK-8248358 I guess you

Re: RFR(T): 8248358: ProblemList sun/nio/ch/TestMaxCachedBufferSize.java on macOSX

2020-06-25 Thread Igor Ignatyev
Hi Dan, LGTM Thanks, -- Igor > JDK-8248358 ProblemList > serviceability/jvmti/ModuleAwareAgents/ThreadStart/MAAThreadStart.java on > Windows > https://bugs.openjdk.java.net/browse/JDK-8248358 I guess you meant JDK-8248358 ProblemList sun/nio/ch/TestMaxCachedBufferSize.java on macOSX

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread Remi Forax
- Mail original - > De: "Remi Forax" > À: "Daniel Fuchs" > Cc: "Patrick Concannon" , "core-libs-dev" > > Envoyé: Jeudi 25 Juin 2020 23:46:08 > Objet: Re: RFR[8238286]: 'Add new flatMap stream operation that is more > amenable to pushing’ > - Mail original - >> De: "Daniel

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread forax
- Mail original - > De: "Daniel Fuchs" > À: "Remi Forax" , "Patrick Concannon" > > Cc: "core-libs-dev" > Envoyé: Jeudi 25 Juin 2020 11:28:00 > Objet: Re: RFR[8238286]: 'Add new flatMap stream operation that is more > amenable to pushing’ > Hi Rémi, Hi Daniel, > > On 25/06/2020

RFR(T): 8248358: ProblemList sun/nio/ch/TestMaxCachedBufferSize.java on macOSX

2020-06-25 Thread Daniel D. Daugherty
Greetings, I'm doing another round of reduce-the-noise in the CI in preparation for the upcoming weekend... So I have another trivial review... Here's the bug for the failures:     JDK-8212812 sun/nio/ch/TestMaxCachedBufferSize.java timeout     https://bugs.openjdk.java.net/browse/JDK-8212812

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread forax
- Mail original - > De: "Brian Goetz" > À: "Remi Forax" , "Patrick Concannon" > > Cc: "core-libs-dev" > Envoyé: Jeudi 25 Juin 2020 22:04:27 > Objet: Re: RFR[8238286]: 'Add new flatMap stream operation that is more > amenable to pushing’ > On 6/24/2020 7:32 PM, Remi Forax wrote: >> I

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread Brian Goetz
On 6/24/2020 7:32 PM, Remi Forax wrote: I don't really like the name "mapMulti", because flatMap can also be called mapMulti. Public service announcement: remember just how frustrating it is for Patrick to have put in all this work and get only comments like "I don't like the name." If

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread Anthony Vanelverdinghe
Hi Given the signature of flatMap is: Stream flatMap​(FunctionR>> mapper) I'd like to propose the following signature for the new method: Stream builderMap(BiConsumerStream.Builder> mapper) This way both methods are named "...Map", and the name "builderMap" follows naturally from the

Re: RFR [1]6 8248326 Add a minimal serialization test for local records

2020-06-25 Thread Daniel Fuchs
Hi Chris, Looks good to me. It might also be beneficial to double check that the hash codes of the two objects are equal. best regards, -- daniel On 25/06/2020 16:01, Chris Hegarty wrote: While working on some record serialization changes recently, I noticed that we don’t have any coverage

RFR [1]6 8248326 Add a minimal serialization test for local records

2020-06-25 Thread Chris Hegarty
While working on some record serialization changes recently, I noticed that we don’t have any coverage for local records. Here is a simple extension to an existing records test. diff -r 4e186efa6cbf test/jdk/java/io/Serializable/records/BasicRecordSer.java ---

Re: RFR 8245302: Upgrade LogRecord to support long thread ids and remove its usage of ThreadLocal

2020-06-25 Thread Daniel Fuchs
Thanks for fixing that Rahul! Looks good. best regards, -- daniel On 25/06/2020 10:22, Rahul Yadav wrote: Hello, Deprecated tag in LogRecord getter and setter for threadID was missing "since" and so i have added it. webrev : http://cr.openjdk.java.net/~ryadav/webrev_8245302/webrev.00/ -

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread Daniel Fuchs
Hi Rémi, On 25/06/2020 00:32, Remi Forax wrote: I get that you want to keep Consumer instead of Consumer because Consumer is not a valid target type for a lambda, but the BiConsumer should be able to take a ? super Consumer instead of just Consumer. Though I don't dispute that a strict

Re: RFR 8245302: Upgrade LogRecord to support long thread ids and remove its usage of ThreadLocal

2020-06-25 Thread Rahul Yadav
Hello, Deprecated tag in LogRecord getter and setter for threadID was missing "since" and so i have added it. webrev : http://cr.openjdk.java.net/~ryadav/webrev_8245302/webrev.00/ - rahul On 22/06/2020 19:38, Daniel Fuchs wrote: Hi Rahul, Looks good to me as well. Reviewed. best

Re: RFR[8238286]: 'Add new flatMap stream operation that is more amenable to pushing’

2020-06-25 Thread Tagir Valeev
Hello! To me, it looks like it's possible to make the better default implementation. It could be done even as a separate static method: static Stream ofPusher(Consumer> pusher) { return StreamSupport.stream(new Spliterator<>() { private Spliterator delegate; @Override public