Integrated: 8287121: Fix typo in jlink's description resource key lookup

2022-05-24 Thread Christian Stein
On Sun, 22 May 2022 05:58:25 GMT, Christian Stein wrote: > Commit > https://github.com/openjdk/jdk/commit/655500a4f5e3abcff176599604deceefb6ca6640 > for issue [JDK-8286654](https://bugs.openjdk.java.net/browse/JDK-8286654) > added an optional description accessor on the `

Re: RFR: 8287121: Fix typo in jlink's description resource key lookup

2022-05-24 Thread Christian Stein
On Tue, 24 May 2022 04:58:44 GMT, Jaikiran Pai wrote: >> Commit >> https://github.com/openjdk/jdk/commit/655500a4f5e3abcff176599604deceefb6ca6640 >> for issue [JDK-8286654](https://bugs.openjdk.java.net/browse/JDK-8286654) >> added an optional description accessor on the `ToolProvider`

Re: RFR: 8279031: Add API note to ToolProvider about being reusable/reentrant [v2]

2022-05-23 Thread Christian Stein
On Tue, 24 May 2022 04:50:58 GMT, Jaikiran Pai wrote: >> Christian Stein has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Update src/java.base/share/classes/java/util/spi/ToolProvider.java >>

Re: RFR: 8279031: Add API note to ToolProvider about being reusable/reentrant [v2]

2022-05-23 Thread Christian Stein
On Mon, 23 May 2022 10:32:09 GMT, Anthony Vanelverdinghe wrote: >> Christian Stein has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Update src/java.base/share/classes/java/util/spi/ToolProvider.java >>

Re: RFR: 8279031: Add API note to ToolProvider about being reusable/reentrant [v2]

2022-05-23 Thread Christian Stein
> This commit adds an API note to ToolProvider about being reusable/reentrant. Christian Stein has updated the pull request incrementally with one additional commit since the last revision: Update src/java.base/share/classes/java/util/spi/ToolProvider.java Co-authored-by: Anth

RFR: 8279031: Add API note to ToolProvider about being reusable/reentrant

2022-05-23 Thread Christian Stein
This commit adds an API note to ToolProvider about being reusable/reentrant. - Commit messages: - 8286815: Add API note to ToolProvider about being reusable/reentrant Changes: https://git.openjdk.java.net/jdk/pull/8833/files Webrev:

RFR: 8287121: Fix typo in jlink's description resource key lookup

2022-05-22 Thread Christian Stein
Commit https://github.com/openjdk/jdk/commit/655500a4f5e3abcff176599604deceefb6ca6640 for issue [JDK-8286654](https://bugs.openjdk.java.net/browse/JDK-8286654) added an optional description accessor on the `ToolProvider` interface. It included a typo in` jlink`'s description resource key

Integrated: 8286654: Add an optional description accessor on ToolProvider interface

2022-05-19 Thread Christian Stein
On Wed, 18 May 2022 14:56:47 GMT, Christian Stein wrote: > This PR adds an optional description accessor on `ToolProvider` interface. > > This PR also adds short description for each of the listed tool: > - `jar` > - `javac` > - `javadoc` > - `javap` and `jdeps`

Re: RFR: 8286654: Add an optional description accessor on ToolProvider interface

2022-05-19 Thread Christian Stein
On Thu, 19 May 2022 06:21:40 GMT, Christian Stein wrote: >> src/jdk.compiler/share/classes/com/sun/tools/javac/resources/javac.properties >> line 387: >> >>> 385: >>> 386: javac.description=Read Java declarations and compile them into class >>

Re: RFR: 8286654: Add an optional description accessor on ToolProvider interface

2022-05-19 Thread Christian Stein
On Wed, 18 May 2022 21:47:25 GMT, Jonathan Gibbons wrote: >> This PR adds an optional description accessor on `ToolProvider` interface. >> >> This PR also adds short description for each of the listed tool: >> - `jar` >> - `javac` >> - `javadoc` >> - `javap` and `jdeps` >> - `jlink` and `jmod`

RFR: 8286654: Add an optional description accessor on ToolProvider interface

2022-05-19 Thread Christian Stein
This PR adds an optional description accessor on `ToolProvider` interface. This PR also adds short description for each of the listed tool: - `jar` - `javac` - `javadoc` - `javap` and `jdeps` - `jlink` and `jmod` - `jpackage` - Commit messages: - Add localized description for

Integrated: 8280825: Modules that "provide" ToolProvider should document the name that can be used

2022-02-15 Thread Christian Stein
On Wed, 9 Feb 2022 16:37:00 GMT, Christian Stein wrote: > A number of modules declare that the "provide" ToolProvider. > > These modules now specify the "name" of the argument used by > `ToolProvider.findFirst` to access an instance of the tool provide

Re: RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used [v3]

2022-02-14 Thread Christian Stein
> A number of modules declare that the "provide" ToolProvider. > > These modules now specify the "name" of the argument used by > `ToolProvider.findFirst` to access an instance of the tool provider within > the description part of a `@provides` API tag. C

Re: RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used [v2]

2022-02-14 Thread Christian Stein
> A number of modules declare that the "provide" ToolProvider. > > These modules now specify the "name" of the argument used by > `ToolProvider.findFirst` to access an instance of the tool provider within > the description part of a `@provides` API tag. C

Re: RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used

2022-02-14 Thread Christian Stein
On Thu, 10 Feb 2022 17:24:17 GMT, Jonathan Gibbons wrote: >>> Perhaps like this? >>> >>> ```java >>> /** >>> * ... >>> * @provides java.util.spi.ToolProvider >>> * Module {@code jdk.jartool} provides a tool named {@code "jar"}. >>> * Invoke {@link

Re: RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used

2022-02-09 Thread Christian Stein
On Thu, 10 Feb 2022 02:19:36 GMT, Jonathan Gibbons wrote: >> src/jdk.jartool/share/classes/module-info.java line 45: >> >>> 43: * Pass {@code "jar"} as the name to >>> 44: * {@link java.util.spi.ToolProvider#findFirst >>> ToolProvider.findFirst} >>> 45: * in order to

Re: RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used

2022-02-09 Thread Christian Stein
On Wed, 9 Feb 2022 16:37:00 GMT, Christian Stein wrote: > A number of modules declare that the "provide" ToolProvider. > > These modules now specify the "name" of the argument used by > `ToolProvider.findFirst` to access an instance of the tool provide

RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used

2022-02-09 Thread Christian Stein
A number of modules declare that the "provide" ToolProvider. These modules now specify the "name" of the argument used by `ToolProvider.findFirst` to access an instance of the tool provider within the description part of a `@provides` API tag. - Commit messages: - Separate

Integrated: 8281470: tools/jar/CreateMissingParentDirectories.java fails with "Should have failed creating jar file"

2022-02-09 Thread Christian Stein
On Wed, 9 Feb 2022 06:42:51 GMT, Christian Stein wrote: > This PR removes the redundant and failing test-case. > It also removes the test class from the problem list. > > Adds additional test-cases using long form option names of `jar`. This pull request has now been integrated

RFR: 8281470: tools/jar/CreateMissingParentDirectories.java fails with "Should have failed creating jar file"

2022-02-09 Thread Christian Stein
This PR removes the redundant and failing test-case. It also removes the test class from the problem list. Adds additional test-cases using long form option names of `jar`. - Commit messages: - Only assert non-zero exit code on failure - 8281470:

Integrated: 8281104: jar --create should create missing parent directories

2022-02-08 Thread Christian Stein
On Wed, 2 Feb 2022 20:21:54 GMT, Christian Stein wrote: > Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing > parent directories (here `a/b`) on the default file system before storing the > JAR file (here `foo.jar`) in the destination directory. This pull re

Re: RFR: 8281104: jar --create should create missing parent directories [v3]

2022-02-04 Thread Christian Stein
> Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing > parent directories (here `a/b`) on the default file system before storing the > JAR file (here `foo.jar`) in the destination directory. Christian Stein has updated the pull request incrementally with one a

Re: RFR: 8281104: jar --create should create missing parent directories

2022-02-04 Thread Christian Stein
On Wed, 2 Feb 2022 20:21:54 GMT, Christian Stein wrote: > Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing > parent directories (here `a/b`) on the default file system before storing the > JAR file (here `foo.jar`) in the destination directory. Should I al

Re: RFR: 8281104: jar --create should create missing parent directories [v2]

2022-02-04 Thread Christian Stein
> Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing > parent directories (here `a/b`) on the default file system before storing the > JAR file (here `foo.jar`) in the destination directory. Christian Stein has updated the pull request incrementally with one a

Re: RFR: 8281104: jar --create should create missing parent directories

2022-02-04 Thread Christian Stein
On Thu, 3 Feb 2022 21:43:30 GMT, Lance Andersen wrote: > I think this would be the appropriate place for documenting the behavior. Like this? -c, --create Create the archive. When the path specified by -f, --file contains a path, missing parent

Re: RFR: 8281104: jar --create should create missing parent directories

2022-02-03 Thread Christian Stein
On Wed, 2 Feb 2022 20:21:54 GMT, Christian Stein wrote: > Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing > parent directories (here `a/b`) on the default file system before storing the > JAR file (here `foo.jar`) in the destination directory. Thanks for t

RFR: 8281104: jar --create should create missing parent directories

2022-02-03 Thread Christian Stein
Calling `jar --create --file a/b/foo.jar INPUT-FILES` should create missing parent directories (here `a/b`) on the default file system before storing the JAR file (here `foo.jar`) in the destination directory. - Commit messages: - Expect at least jar file's name in error message

Integrated: 8271079: JavaFileObject#toUri and multi-release jars

2021-12-13 Thread Christian Stein
On Wed, 8 Dec 2021 15:26:23 GMT, Christian Stein wrote: > Prior to this PR, `toUri()` of class `ZipPath` in module `jdk.zipfs` and > class `PathFileObject` in module `jdk.compiler` were always composed by base > path names. Even for versioned entries of a multi-release JAR file.

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v3]

2021-12-11 Thread Christian Stein
On Fri, 10 Dec 2021 16:33:33 GMT, Jonathan Gibbons wrote: >> Christian Stein has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Turn `getRealPath()` into a no-arg helper method > > test/langtools/tools/javac/T

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v4]

2021-12-11 Thread Christian Stein
ath names using an > existing lookup function in the associated zip file system object. > > This PR also removes a superseded work around for > [JDK-8134451](https://bugs.openjdk.java.net/browse/JDK-8134451). > > Fixes https://bugs.openjdk.java.net/browse/JDK-8271079 Chr

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v3]

2021-12-11 Thread Christian Stein
On Fri, 10 Dec 2021 16:37:35 GMT, Jonathan Gibbons wrote: > javac changes look good. I suggest adding this bug number to the test to > check that URIs are not double-encoded. I can't find [`8134451`](https://bugs.openjdk.java.net/browse/JDK-8134451) as noted in the now removed comment

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v3]

2021-12-11 Thread Christian Stein
On Fri, 10 Dec 2021 16:30:37 GMT, Jonathan Gibbons wrote: >> Christian Stein has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Turn `getRealPath()` into a no-arg helper method > > test/langtools/tools/javac/T

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v2]

2021-12-10 Thread Christian Stein
On Thu, 9 Dec 2021 18:37:11 GMT, Alan Bateman wrote: >> Christian Stein has updated the pull request incrementally with two >> additional commits since the last revision: >> >> - Clean up reproducer test case >> - Keep helper in ZipFileSystem simple > >

Re: RFR: 8271079: JavaFileObject#toUri and multi-release jars [v3]

2021-12-10 Thread Christian Stein
ath names using an > existing lookup function in the associated zip file system object. > > This PR also removes a superseded work around for > [JDK-8134451](https://bugs.openjdk.java.net/browse/JDK-8134451). > > Fixes https://bugs.openjdk.java.net/browse/JDK-8271079 Chr

Integrated: 8273235: tools/launcher/HelpFlagsTest.java Fails on Windows 32bit

2021-11-08 Thread Christian Stein
On Thu, 4 Nov 2021 13:10:37 GMT, Christian Stein wrote: > This PR implements the fix as suggested by Adam Farley, which reads: > >> Note: Looks to be as simple as adding `jaccessinspector-32` and >> `jaccesswalker-32` to `TOOLS_NOT_TO_TEST` at the top of >> `HelpFla

RFR: 8273235: tools/launcher/HelpFlagsTest.java Fails on Windows 32bit

2021-11-04 Thread Christian Stein
This PR implements the fix as suggested by Adam Farley, which reads: > Note: Looks to be as simple as adding `jaccessinspector-32` and > `jaccesswalker-32` to `TOOLS_NOT_TO_TEST` at the top of `HelpFlagsTest.java`, > as the non-32bit versions are already there. - Commit messages:

Integrated: JDK-8262944: Improve exception message when automatic module lists provider class not in JAR file

2021-10-06 Thread Christian Stein
On Thu, 16 Sep 2021 09:06:20 GMT, Christian Stein wrote: > This commit appends the name of the JAR file to the exception message for > when automatic module lists a non-existing provider class. This pull request has now been integrated. Changeset: c10de353 Author:Christian

Re: RFR: JDK-8262944: Improve exception message when automatic module lists provider class not in JAR file [v3]

2021-09-23 Thread Christian Stein
> This commit appends the name of the JAR file to the exception message for > when automatic module lists a non-existing provider class. Christian Stein has updated the pull request incrementally with one additional commit since the last revision: Add JBS issue `8262944` to the `@bug

Re: RFR: JDK-8262944: Improve exception message when automatic module lists provider class not in JAR file [v2]

2021-09-23 Thread Christian Stein
> This commit appends the name of the JAR file to the exception message for > when automatic module lists a non-existing provider class. Christian Stein has updated the pull request incrementally with one additional commit since the last revision: Assert that only the name of the JA

Re: RFR: JDK-8262944: Improve exception message when automatic module lists provider class not in JAR file

2021-09-23 Thread Christian Stein
On Thu, 23 Sep 2021 11:26:26 GMT, Alan Bateman wrote: >> This commit appends the name of the JAR file to the exception message for >> when automatic module lists a non-existing provider class. > > src/java.base/share/classes/jdk/internal/module/ModulePath.java line 554: > >> 552:

jar --verify operation mode checking mrjar validity

2018-12-01 Thread Christian Stein
Hi, jar --create (and --update) perform type API validation checks when used in combination with --release option. This detects invalid "version overlays" at package time, where the API doesn't match a previous one. Having a jar --verify mode that performs the same checks consuming an already