Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe [v2]

2021-12-17 Thread liach
On Thu, 16 Dec 2021 21:38:30 GMT, liach wrote: >> Simply changes this to only read the static field once to prevent `null` on >> second read. > > liach has updated the pull request incrementally with two additional commits > since the last revision: > > - sorry, reintroduced the bug in last p

Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe [v2]

2021-12-17 Thread Roger Riggs
On Thu, 16 Dec 2021 21:38:30 GMT, liach wrote: >> Simply changes this to only read the static field once to prevent `null` on >> second read. > > liach has updated the pull request incrementally with two additional commits > since the last revision: > > - sorry, reintroduced the bug in last p

Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe [v2]

2021-12-16 Thread Mandy Chung
On Thu, 16 Dec 2021 21:38:30 GMT, liach wrote: >> Simply changes this to only read the static field once to prevent `null` on >> second read. > > liach has updated the pull request incrementally with two additional commits > since the last revision: > > - sorry, reintroduced the bug in last p

Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe [v2]

2021-12-16 Thread liach
> Simply changes this to only read the static field once to prevent `null` on > second read. liach has updated the pull request incrementally with two additional commits since the last revision: - sorry, reintroduced the bug in last patch - choose a concise name for the local var ---

Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe

2021-12-16 Thread Roger Riggs
On Thu, 16 Dec 2021 21:04:58 GMT, liach wrote: > Simply changes this to only read the static field once to prevent `null` on > second read. src/java.base/share/classes/java/lang/Class.java line 3828: > 3826: java.security.AccessController.doPrivileged > 3827:

Re: RFR: 8261404: Class.getReflectionFactory() is not thread-safe

2021-12-16 Thread Roger Riggs
On Thu, 16 Dec 2021 21:04:58 GMT, liach wrote: > Simply changes this to only read the static field once to prevent `null` on > second read. It would be easier to read and clearer if the local was not named the same as the static. - Changes requested by rriggs (Reviewer). PR: htt

RFR: 8261404: Class.getReflectionFactory() is not thread-safe

2021-12-16 Thread liach
Simply changes this to only read the static field once to prevent `null` on second read. - Commit messages: - 8261404: Class.getReflectionFactory() is not thread-safe Changes: https://git.openjdk.java.net/jdk/pull/6870/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=68