Re: JDK-8074023: Clock.system(ZoneId) could be optimized to always return the same clock for a given zone

2015-04-24 Thread Daniel Fuchs
On 4/23/15 11:28 PM, Roger Riggs wrote: Hi Peter, Setting the user.timezone property doesn't reset the value returned from getDefaultRef(). You can see the new value through java.util.TimeZone but not through java.time.ZoneId. Its a bad idea to allow the default timezone change and in

Re: Patch to improve primitives Array.sort()

2015-04-24 Thread Alan Bateman
On 24/04/2015 09:57, Paul Sandoz wrote: See here: http://cr.openjdk.java.net/~psandoz/tmp/gs/sort/webrev/ Some very quick comments as i have not yet had time to review more closely: - IANAL so i dunno about the GS copyright in the files. - The constant MAX_RUN_LENGTH is no longer used so

Re: JDK-8074023: Clock.system(ZoneId) could be optimized to always return the same clock for a given zone

2015-04-24 Thread Peter Levart
On 04/24/2015 11:32 AM, Stephen Colebourne wrote: The code in the webrev changes the behaviour of java.time, so cannot go in. Run this code: TimeZone zone = TimeZone.getDefault(); System.out.println(zone); ZoneId zoneId = ZoneId.systemDefault(); System.out.println(zoneId);

Re: JDK-8074023: Clock.system(ZoneId) could be optimized to always return the same clock for a given zone

2015-04-24 Thread Stephen Colebourne
No, the opposite. Those rules that do NOT have a fixed offset. ZoneId.of(Europe/London) should be cached, but not ZoneId.of(UTC+10:00). Note that the latter is an offset-based ZoneRegion, not a ZoneOffset. Stephen On 24 April 2015 at 14:58, Roger Riggs roger.ri...@oracle.com wrote: Hi

Re: RFR 9: 8077350 Process API Updates Implementation Review (Due 4/23)

2015-04-24 Thread Alan Bateman
On 17/04/2015 20:12, Roger Riggs wrote: The webrev for ProcessAPI updates has been updated to reflect recent comments. Please review and comment by April 23rd. The updates include: - Renaming Process/ProcessHandle supportsDestroyForcibly to supportsNormalTermination and updating related

RFR [9] 8078622: remove tidy warnings from JPDA docs

2015-04-24 Thread alexander stepanov
Hello, Could you please review the following fix http://cr.openjdk.java.net/~avstepan/8078622/webrev.00/ for https://bugs.openjdk.java.net/browse/JDK-8078622 Just some HTML cleanup for docs. Thanks, Alexander

RFR (XS) 8076759: AbstractStringBuilder.append(...) should ensure enough capacity for the upcoming trivial append calls

2015-04-24 Thread Aleksey Shipilev
Hi, This seems to be a simple one-liner fix, but the background is more complicated. See the bug: https://bugs.openjdk.java.net/browse/JDK-8076759 The bottom line is that our current resizing policy in ASB is hostile for long appends. There is a heuristics that extends the capacity to match

[9] RFR of 8078586: java/lang/Double/ParseHexFloatingPoint.java fails intermittently

2015-04-24 Thread Brian Burkhalter
Please review at your convenience. Issue: https://bugs.openjdk.java.net/browse/JDK-8078586 Patch: http://cr.openjdk.java.net/~bpb/8078586/webrev.00/ Summary: Add setting of Random seed via system property with fallback to a random seed from a separate Random instance and printing the seed

Re: RFR 9: 8077350 Process API Updates Implementation Review (Due 4/23)

2015-04-24 Thread Roger Riggs
Hi Alan, On 4/24/2015 8:06 AM, Alan Bateman wrote: On 17/04/2015 20:12, Roger Riggs wrote: The webrev for ProcessAPI updates has been updated to reflect recent comments. Please review and comment by April 23rd. The updates include: - Renaming Process/ProcessHandle supportsDestroyForcibly

Re: RFR 9: 8077350 Process API Updates Implementation Review (Due 4/23)

2015-04-24 Thread Alan Bateman
On 24/04/2015 16:49, Roger Riggs wrote: : I'm not sure about the @implSpec in Process::supportsNormalTermination. Shouldn't that just specify that the default implementation throws UOE. An @implNote could comment on how ProcessBuilder works. Same comment on Process::toHandle. There needs

Re: RFR 9: 8077350 Process API Updates Implementation Review (Due 4/23)

2015-04-24 Thread Roger Riggs
Hi Alan, On 4/24/2015 12:21 PM, Alan Bateman wrote: On 24/04/2015 16:49, Roger Riggs wrote: : I'm not sure about the @implSpec in Process::supportsNormalTermination. Shouldn't that just specify that the default implementation throws UOE. An @implNote could comment on how ProcessBuilder

RFR: 8077846: improve locking strategy for readConfiguration(), reset(), and initializeGlobalHandlers()

2015-04-24 Thread Daniel Fuchs
Hi, Please find below a patch that tries to improve the locking strategy in LogManager. The patch proposes to use a Reantrant lock to deal with configurations changes in reset() and readConfiguration(), and avoids lock contention in initializeGlobalHandlers()

Patch to improve primitives Array.sort()

2015-04-24 Thread Chan, Sunny
We are proposing a patch to improve the performance for the DualPivotQuickSort use by Array.sort to sort primitives array. We have identified two area for optimization: Firstly, we have changed the algorithm to determine what a run is. A run is how long you go through the array with it being

RE: Patch to improve primitives Array.sort()

2015-04-24 Thread Chan, Sunny
Sorry the spam filter we use didn't like the webrev.zip so I have attached the text patch file instead. From: Chan, Sunny [Tech] Sent: 24 April 2015 15:17 To: 'core-libs-dev@openjdk.java.net' Cc: O'Leary, Kristen [Tech] Subject: Patch to improve primitives Array.sort() We are proposing a

Re: Patch to improve primitives Array.sort()

2015-04-24 Thread Paul Sandoz
HI Chan, Attachments might be getting removed by the OpenJDK email server. If you send me the webrev privately i can upload to cr. If so could you do that please send the JMH tests as i think people might also be interested in those. Paul. On Apr 24, 2015, at 9:17 AM, Chan, Sunny

RE: Patch to improve primitives Array.sort()

2015-04-24 Thread Chan, Sunny
I have privately sent the webrev to Paul. I will make the JMH tests available once I have clear up with the compliance. Sunny -Original Message- From: Paul Sandoz [mailto:paul.san...@oracle.com] Sent: 24 April 2015 15:31 To: Chan, Sunny [Tech] Cc: 'core-libs-dev@openjdk.java.net';

Re: JDK 9 RFR of JDK-8078334: Mark regression tests using randomness

2015-04-24 Thread Alan Bateman
On 24/04/2015 02:54, Joseph D. Darcy wrote: Hello, Any additional comments on marking with tests in question with a randomness keyword? Thanks, -Joe I don't object to this keyword although I should say that most of the (apparent) randomness that I've seen hasn't been because of tests

Re: RFR [9] Add blocking bulk read to java.io.InputStream

2015-04-24 Thread Alan Bateman
On 23/04/2015 21:22, Remi Forax wrote: On 04/23/2015 04:41 PM, Alan Bateman wrote: On 23/04/2015 13:22, Remi Forax wrote: I think the name readBytes is not very informative and the name is too close to read + an array of bytes, we can not use readFully (from DataInput/DataInputStream)