RFR: 8223187: Investigate setLocale() call in jpackage native launcher

2020-09-11 Thread Alexander Matveev
setlocale() affects several C functions. We do not use most of these functions. We only using isspace() and toLower(). Based on how we use it I do not see any needs for setlocale(). After removing it I retested jpackage by changing locally on machine and using different language as input

Re: RFR: 8138732: Rename @HotSpotIntrinsicCandidate to @IntrinsicCandidate and move it to the jdk.internal.vm.annotation package [v2]

2020-09-11 Thread Vladimir Kozlov
On Wed, 9 Sep 2020 09:49:44 GMT, Philippe Marschall wrote: >> Hello, newbie here >> >> I picked JDK-8138732 to work on because it has a "starter" label and I >> believe I understand what to do. >> >> - I tried to update the copyright year to 2020 in every file. >> - I decided to change

Re: RFR: 8253066: typo in Stream.mapMulti

2020-09-11 Thread Lance Andersen
On Fri, 11 Sep 2020 22:20:48 GMT, Stuart Marks wrote: > A simple typo fix. Marked as reviewed by lancea (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/137

Integrated: 8253066: typo in Stream.mapMulti

2020-09-11 Thread Stuart Marks
On Fri, 11 Sep 2020 22:20:48 GMT, Stuart Marks wrote: > A simple typo fix. This pull request has now been integrated. Changeset: b1b0f0b2 Author:Stuart Marks URL: https://git.openjdk.java.net/jdk/commit/b1b0f0b2 Stats: 1 line in 1 file changed: 0 ins; 0 del; 1 mod 8253066: typo

Re: RFR: 8253066: typo in Stream.mapMulti

2020-09-11 Thread Joe Darcy
On Fri, 11 Sep 2020 22:20:48 GMT, Stuart Marks wrote: > A simple typo fix. Marked as reviewed by darcy (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/137

Re: RFR: 8173585: Intrinsify StringLatin1.indexOf(char)

2020-09-11 Thread Jason Tatton
On Tue, 8 Sep 2020 11:59:36 GMT, Jason Tatton wrote: > This is an implementation of the indexOf(char) intrinsic for StringLatin1 (1 > byte encoded Strings). It is provided for > x86 and ARM64. The implementation is greatly inspired by the indexOf(char) > intrinsic for StringUTF16. To

RE: 8173585: Intrinsify StringLatin1.indexOf(char)

2020-09-11 Thread Tatton, Jason
Hi Everyone, Please could some reviewers volunteer their time to have a look at this patch? It was marked as a starter bug so I don't expect it will consume a lot of time. Thanks, Jason -Original Message- From: hotspot-dev On Behalf Of Jason Tatton Sent: 11 September 2020 11:24 To:

RFR: 8253066: typo in Stream.mapMulti

2020-09-11 Thread Stuart Marks
A simple typo fix. - Commit messages: - fix typo in Stream.mapMulti Changes: https://git.openjdk.java.net/jdk/pull/137/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk=137=00 Issue: https://bugs.openjdk.java.net/browse/JDK-8253066 Stats: 1 line in 1 file changed: 0

Re: RFR: 8138732: Rename @HotSpotIntrinsicCandidate to @IntrinsicCandidate and move it to the jdk.internal.vm.annotation package [v2]

2020-09-11 Thread Vladimir Kozlov
On Fri, 11 Sep 2020 21:53:12 GMT, Vladimir Kozlov wrote: >> Marked as reviewed by psandoz (Reviewer). > > You should consider upstreaming Graal changes (jdk.internal.vm.compiler) into > https://github.com/oracle/graal > Otherwise next time we do "Update Graal" in JDK they will be overwritten.

Re: RFR: 8138732: Rename @HotSpotIntrinsicCandidate to @IntrinsicCandidate and move it to the jdk.internal.vm.annotation package [v2]

2020-09-11 Thread Vladimir Kozlov
On Thu, 10 Sep 2020 17:59:54 GMT, Paul Sandoz wrote: >> Philippe Marschall has refreshed the contents of this pull request, and >> previous commits have been removed. The >> incremental views will show differences compared to the previous content of >> the PR. > > Marked as reviewed by psandoz

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v3]

2020-09-11 Thread Mandy Chung
On Wed, 9 Sep 2020 16:41:22 GMT, Mandy Chung wrote: >> Gilles Duboscq has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Remove disableEagerInitialization concerns from BridgeMethod.java > > Looks good. I agree with Jan's suggestion that

Re: Case insensitive regexes and collators

2020-09-11 Thread Naoto Sato
Hi David, Glad to hear that you are delighted with the recent fix (JDK-8248655). The scope of the fix is limited to the String class, so it may or may not affect the said RegEx and/or Collator case insensitive operations. I created the following two issues to track your observations:

Re: RFR: 8173585: Intrinsify StringLatin1.indexOf(char)

2020-09-11 Thread Andrew Haley
On 11/09/2020 11:23, Jason Tatton wrote: > For the x86 implementation there may be two further improvements we > can make in order to improve performance of both the StringUTF16 and > StringLatin1 indexOf(char) intrinsics: > > 1. Make use of AVX-512 instructions. Is this really a good idea?

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-11 Thread Bradford Wetmore
On Fri, 11 Sep 2020 07:15:26 GMT, Dmitriy Dumanskiy wrote: >> 1) This is un-necessary churn. >> 2) I can't even be sure I am finding the ones in my area because there's so >> much here >> 3) The ones I can find have no need of whatever performance improvement this >> might bring. >> I think

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v3]

2020-09-11 Thread Gilles Duboscq
On Thu, 10 Sep 2020 16:34:02 GMT, Mandy Chung wrote: >> Gilles Duboscq has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Remove disableEagerInitialization concerns from BridgeMethod.java > >

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v3]

2020-09-11 Thread Gilles Duboscq
> [JDK-8232806](https://bugs.openjdk.java.net/browse/JDK-8232806) introduced the > jdk.internal.lambda.disableEagerInitialization system property to be able to > disable eager initialization of lambda > classes. This was necessary to prevent side effects of class initializers > triggered by such

Re: RFR: 8245194: Unix domain socket channel implementation

2020-09-11 Thread Michael McMahon
On Mon, 7 Sep 2020 12:05:07 GMT, Michael McMahon wrote: > Continuing this review as a PR on github with the comments below > incorporated. I expect there will be a few more > iterations before integrating. > On 06/09/2020 19:47, Alan Bateman wrote: >> On 26/08/2020 15:24, Michael McMahon wrote:

RFR: 8244706: GZIP "OS" header flag hard-coded to 0 instead of 255 (RFC 1952 non-compliance)

2020-09-11 Thread Jaikiran Pai
Can I please get a review and a sponsor for this patch which fixes the issue reported in https://bugs.openjdk.java.net/browse/JDK-8244706? The commit here sets the `OS` header flag to `255` (which represents `unknown`) as noted in [1]. A new test has been included in this commit to verify the

Re: RFR: 8227745: Enable Escape Analysis for Better Performance in the Presence of JVMTI Agents

2020-09-11 Thread Richard Reingruber
On Fri, 11 Sep 2020 09:54:50 GMT, Erik Helin wrote: > > > Sorry, now I see. Yes, please remove `, 8233915` from the title! Thanks for helping. The commit message does look better now. - PR: https://git.openjdk.java.net/jdk/pull/119

Re: RFR: 8245194: Unix domain socket channel implementation [v2]

2020-09-11 Thread Michael McMahon
> Continuing this review as a PR on github with the comments below > incorporated. I expect there will be a few more > iterations before integrating. > On 06/09/2020 19:47, Alan Bateman wrote: >> On 26/08/2020 15:24, Michael McMahon wrote: >>> >>> As I mentioned the other day, I wasn't able to

RFR: 8173585: Intrinsify StringLatin1.indexOf(char)

2020-09-11 Thread Jason Tatton
This is an implementation of the indexOf(char) intrinsic for StringLatin1 (1 byte encoded Strings). It is provided for x86 and ARM64. The implementation is greatly inspired by the indexOf(char) intrinsic for StringUTF16. To incorporate it I had to make a small change to StringLatin1.java

Re: RFR: JDK-8247589: Implementation of Alpine Linux/x64 Port [v2]

2020-09-11 Thread Aleksei Voitylov
On Tue, 8 Sep 2020 23:44:58 GMT, David Holmes wrote: >> Aleksei Voitylov has updated the pull request incrementally with one >> additional commit since the last revision: >> >> JDK-8247589: Implementation of Alpine Linux/x64 Port > > make/autoconf/platform.m4 line 536: > >> 534:

Withdrawn: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-11 Thread Dmitriy Dumanskiy
On Sun, 6 Sep 2020 13:57:19 GMT, Dmitriy Dumanskiy wrote: > **isEmpty** is faster + has less byte code + easier to read. Benchmarks could > be found > > [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). This pull request has been closed

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-11 Thread Dmitriy Dumanskiy
On Thu, 10 Sep 2020 23:57:38 GMT, Phil Race wrote: >> **isEmpty** is faster + has less byte code + easier to read. Benchmarks >> could be found >> >> [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). > > 1) This is un-necessary churn. > 2) I

Re: RFR: JDK-8247589: Implementation of Alpine Linux/x64 Port [v2]

2020-09-11 Thread Aleksei Voitylov
> continuing the review thread from here > https://mail.openjdk.java.net/pipermail/core-libs-dev/2020-September/068546.html > >> The download side of using JNI in these tests is that it complicates the >> setup a bit for those that run jtreg directly and/or just build the JDK >> and not the test