Re: RFR: 8274811: Remove superfluous use of boxing in java.base

2021-12-27 Thread Сергей Цыпанов
On Sat, 27 Nov 2021 17:41:58 GMT, Andrey Turbanov wrote: >> Usages of primitive types should be preferred and makes code easier to read. >> Similar cleanups: >> 1. [JDK-8273168](https://bugs.openjdk.java.net/browse/JDK-8273168) >> java.desktop >> 2.

Re: RFR: 8274811: Remove superfluous use of boxing in java.base

2021-12-27 Thread Lance Andersen
On Sat, 11 Sep 2021 12:11:50 GMT, Andrey Turbanov wrote: > Usages of primitive types should be preferred and makes code easier to read. > Similar cleanups: > 1. [JDK-8273168](https://bugs.openjdk.java.net/browse/JDK-8273168) > java.desktop > 2.

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo [v5]

2021-12-27 Thread Markus KARG
> Implementation of JDK-8279283 Markus KARG has updated the pull request incrementally with one additional commit since the last revision: fixed missing BufferedInputStream - Changes: - all: https://git.openjdk.java.net/jdk/pull/6935/files - new:

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo [v4]

2021-12-27 Thread Markus KARG
> Implementation of JDK-8279283 Markus KARG has updated the pull request incrementally with one additional commit since the last revision: removed unused code - Changes: - all: https://git.openjdk.java.net/jdk/pull/6935/files - new:

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo

2021-12-27 Thread Markus KARG
On Mon, 27 Dec 2021 09:30:25 GMT, Markus KARG wrote: > Have you surveyed the existing tests to see if transferTo is invoked on a > BIS? New tests may be needed. I have provided a test for BIS.transferTo in

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo [v3]

2021-12-27 Thread Markus KARG
> Implementation of JDK-8279283 Markus KARG has updated the pull request incrementally with one additional commit since the last revision: test for BufferedInputStream.transferTo - Changes: - all: https://git.openjdk.java.net/jdk/pull/6935/files - new:

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo

2021-12-27 Thread Markus KARG
On Mon, 27 Dec 2021 08:50:26 GMT, Alan Bateman wrote: > BIS is not specified to be thread safe but the existing read/write operations > are. If transferTo is overridden then this is an area that will require close > attention. In analogy to the other read/write operations I now have

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo [v2]

2021-12-27 Thread Markus KARG
> Implementation of JDK-8279283 Markus KARG has updated the pull request incrementally with one additional commit since the last revision: synchronized BufferedInputStream::transferTo - Changes: - all: https://git.openjdk.java.net/jdk/pull/6935/files - new:

Re: RFR: 8279283 - (ch) BufferedInputStream should override transferTo

2021-12-27 Thread Alan Bateman
On Sun, 26 Dec 2021 17:30:41 GMT, Markus KARG wrote: > Implementation of JDK-8279283 BIS is not specified to be thread safe but the existing read/write operations are. If transferTo is overridden then this is an area that will require close attention. Have you surveyed the existing tests to