RFR: 8281525: Enable Zc:strictStrings flag in Visual Studio build

2022-02-21 Thread Daniel JeliƄski
Please review this PR that enables [Zc:strictStrings](https://docs.microsoft.com/en-us/cpp/build/reference/zc-strictstrings-disable-string-literal-type-conversion?view=msvc-170) compiler flag, which makes assigning a string literal to a non-const pointer a compile-time error. This type of assig

Integrated: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Jaikiran Pai
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? This pull request has now been integrated.

Re: RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Jaikiran Pai
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? Thank you everyone for the reviews. -

Re: RFR: 8261407: ReflectionFactory.checkInitted() is not thread-safe [v9]

2022-02-21 Thread Mandy Chung
On Mon, 21 Feb 2022 16:35:09 GMT, liach wrote: >> liach has updated the pull request with a new target base due to a merge or >> a rebase. The incremental webrev excludes the unrelated changes brought in >> by the merge/rebase. The pull request contains 13 additional commits since >> the last

Re: RFR: 8261407: ReflectionFactory.checkInitted() is not thread-safe [v9]

2022-02-21 Thread Mandy Chung
On Sat, 19 Feb 2022 16:06:35 GMT, liach wrote: >> Upon review of [8261407](https://bugs.openjdk.java.net/browse/JDK-8261407), >> by design, duplicate initialization of ReflectionFactory should be safe as >> it performs side-effect-free property read actions, and the suggesting of >> making the

Re: RFR: JDK-8277520: Implement JDK-8 default methods for IdentityHashMap [v4]

2022-02-21 Thread liach
> Might need a CSR as now `computeIfAbsent` `computeIfPresent` `compute` > `merge` would throw CME if the functions modified the map itself, and there > are corresponding specification changes. liach has updated the pull request incrementally with two additional commits since the last revision:

Re: RFR: JDK-8277520: Implement JDK-8 default methods for IdentityHashMap [v3]

2022-02-21 Thread liach
On Mon, 21 Feb 2022 22:27:34 GMT, liach wrote: >> Might need a CSR as now `computeIfAbsent` `computeIfPresent` `compute` >> `merge` would throw CME if the functions modified the map itself, and there >> are corresponding specification changes. > > liach has updated the pull request with a new t

Re: RFR: JDK-8277520: Implement JDK-8 default methods for IdentityHashMap [v3]

2022-02-21 Thread liach
> Might need a CSR as now `computeIfAbsent` `computeIfPresent` `compute` > `merge` would throw CME if the functions modified the map itself, and there > are corresponding specification changes. liach has updated the pull request with a new target base due to a merge or a rebase. The incremental

Re: RFR: 8280035: Use Class.isInstance instead of Class.isAssignableFrom where applicable

2022-02-21 Thread Peter Levart
On Mon, 17 Jan 2022 08:28:35 GMT, Erik Gahlin wrote: >> src/jdk.jfr/share/classes/jdk/jfr/internal/TypeLibrary.java line 405: >> >>> 403: Object res = m.invoke(a, new Object[0]); >>> 404: if (res instanceof Annotation[]) { >>> 405:

Re: RFR: 8261407: ReflectionFactory.checkInitted() is not thread-safe [v9]

2022-02-21 Thread Peter Levart
On Mon, 21 Feb 2022 16:35:09 GMT, liach wrote: >> liach has updated the pull request with a new target base due to a merge or >> a rebase. The incremental webrev excludes the unrelated changes brought in >> by the merge/rebase. The pull request contains 13 additional commits since >> the last

Re: RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Iris Clark
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? Marked as reviewed by iris (Reviewer). --

Re: RFR: 8281962: Avoid unnecessary native calls in InflaterInputStream [v2]

2022-02-21 Thread Lance Andersen
On Mon, 21 Feb 2022 10:06:40 GMT, Volker Simonis wrote: > > The change looks innocuous so it is probably OK. I would like to kick of > > our Mach5 runs to see if it shakes out any potential issues. > > @LanceAndersen , did you manage to get any Mach5 results? Did you find any > issues? Tests

Re: RFR: 8282188: Unused static field MathContext.DEFAULT_DIGITS

2022-02-21 Thread Joe Darcy
On Fri, 18 Feb 2022 19:07:15 GMT, Andrey Turbanov wrote: > 8282188: Unused static field MathContext.DEFAULT_DIGITS Marked as reviewed by darcy (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/7538

Re: RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Lance Andersen
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? Marked as reviewed by lancea (Reviewer).

Re: RFR: 8261407: ReflectionFactory.checkInitted() is not thread-safe [v9]

2022-02-21 Thread liach
On Sat, 19 Feb 2022 16:06:35 GMT, liach wrote: >> Upon review of [8261407](https://bugs.openjdk.java.net/browse/JDK-8261407), >> by design, duplicate initialization of ReflectionFactory should be safe as >> it performs side-effect-free property read actions, and the suggesting of >> making the

Re: RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Roger Riggs
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? Marked as reviewed by rriggs (Reviewer).

RFR: 8282023: PropertiesStoreTest and StoreReproducibilityTest jtreg failures due to en_CA locale

2022-02-21 Thread Jaikiran Pai
Can I please get a review of this test only change which fixes the issue noted in https://bugs.openjdk.java.net/browse/JDK-8282023? As noted in that JBS issue these tests fail when the default locale under which those tests are run isn't `en_US`. Both these tests were introduced as part of http

Re: RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Daniel Fuchs
On Mon, 21 Feb 2022 12:42:37 GMT, Jaikiran Pai wrote: > Can I please get a review of this trivial change to the javadoc of > `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in > https://bugs.openjdk.java.net/browse/JDK-8282190? LGTM - Marked as reviewed by

Re: RFR: 8281962: Avoid unnecessary native calls in InflaterInputStream [v2]

2022-02-21 Thread Claes Redestad
On Thu, 17 Feb 2022 16:02:42 GMT, Volker Simonis wrote: >> Currently, `InflaterInputStream::read()` first does a native call to the >> underlying zlib `inflate()` function and only afterwards checks if the >> inflater requires input (i.e. `Inflater::needsInput()`) or has finished >> inflating

RFR: 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDecimalStyle

2022-02-21 Thread Jaikiran Pai
Can I please get a review of this trivial change to the javadoc of `DateTimeFormatter.getDecimalStyle()` method which fixes the typo noted in https://bugs.openjdk.java.net/browse/JDK-8282190? - Commit messages: - 8282190: Typo in javadoc of java.time.format.DateTimeFormatter#getDe

Re: RFR: 8280035: Use Class.isInstance instead of Class.isAssignableFrom where applicable

2022-02-21 Thread Andrey Turbanov
On Thu, 20 Jan 2022 01:34:20 GMT, Phil Race wrote: >In short I see insufficient value in the changes here and would prefer you >drop the client part so I don't have to worry about it. I think, usage of `isInstance` is much clear for most java developers. Everyone knows about java _instanceof_

Re: RFR: 8280035: Use Class.isInstance instead of Class.isAssignableFrom where applicable

2022-02-21 Thread Andrey Turbanov
On Thu, 13 Jan 2022 08:25:22 GMT, Andrey Turbanov wrote: > Method `Class.isAssignableFrom` is often used in form of: > > if (clazz.isAssignableFrom(obj.getClass())) { > Such condition could be simplified to more shorter and performarnt code > > if (clazz.isInstance(obj)) { > > Repl

RFR: 8282188: Unused static field MathContext.DEFAULT_DIGITS

2022-02-21 Thread Andrey Turbanov
8282188: Unused static field MathContext.DEFAULT_DIGITS - Commit messages: - [PATCH] Remove unused field MathContext.DEFAULT_DIGITS Changes: https://git.openjdk.java.net/jdk/pull/7538/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=7538&range=00 Issue: https://bugs.op

Re: RFR: 8281962: Avoid unnecessary native calls in InflaterInputStream [v2]

2022-02-21 Thread Alan Bateman
On Thu, 17 Feb 2022 16:02:42 GMT, Volker Simonis wrote: >> Currently, `InflaterInputStream::read()` first does a native call to the >> underlying zlib `inflate()` function and only afterwards checks if the >> inflater requires input (i.e. `Inflater::needsInput()`) or has finished >> inflating

Re: RFR: 8281962: Avoid unnecessary native calls in InflaterInputStream [v2]

2022-02-21 Thread Volker Simonis
On Fri, 18 Feb 2022 08:46:51 GMT, Volker Simonis wrote: > The change looks innocuous so it is probably OK. I would like to kick of our > Mach5 runs to see if it shakes out any potential issues. @LanceAndersen , did you manage to get any Mach5 results? Did you find any issues? - P