Re: Why isn't Object.notify() a synchronized method?

2015-06-03 Thread Andreas Lundblad
On Sun, May 31, 2015 at 02:31:25PM +1000, David Holmes wrote: As I recently fell into the trap of forgetting the synchronized block around a single notifyAll(), I believe, the current situation is just errorprone. How is it errorprone? You forgot to acquire the lock and you got an

Re: Optional.orElseChain ?

2015-04-17 Thread Andreas Lundblad
On Fri, Apr 17, 2015 at 03:01:29PM -0700, Steven Schlansker wrote: On Apr 17, 2015, at 2:37 PM, Remi Forax fo...@univ-mlv.fr wrote: As you can see the code is not bad but the code of chain() could be simplified if there was a way on Optional to call a Supplier of Optional if an

Re: 8050820: Please add java.util.Optional.stream() to convert OptionalT to StreamT

2015-01-21 Thread Andreas Lundblad
such contortions. A CCC will be filed. Thanks, Paul. Hi Paul, My name is Andreas Lundblad, and I joined the langtools team a little more than a year ago. I'm not a Reviewer or anything but I casually read through your patch out of curiosity. You don't seem to be a fan of the ?: operator. I would

Re: JDK 9 RFR of 8067669: Documentation for methods in Number incomplete regarding too large values.

2015-01-19 Thread Andreas Lundblad
On Fri, Jan 16, 2015 at 02:55:28PM -0800, Brian Burkhalter wrote: On Jan 8, 2015, at 7:13 AM, Andreas Lundblad andreas.lundb...@oracle.com wrote: Although I was the one who brought it up, I think the whole ComparatorNumber discussion is slightly off topic. I still think

Re: JDK 9 RFR of 8067669: Documentation for methods in Number incomplete regarding too large values.

2015-01-08 Thread Andreas Lundblad
On the matter of writing a ComparatorNumber, the basic problem is the Number interface is not strong enough to allow you to write such functionality. First, the Number type basically only means convertible to a primitive. There are no strict requirements on consistency between the

Re: JDK 9 RFR of 8067669: Documentation for methods in Number incomplete regarding too large values.

2015-01-07 Thread Andreas Lundblad
On Mon, Jan 05, 2015 at 05:43:26PM -0800, Joseph D. Darcy wrote: Hello, Getting back to this issue in the new year, taking a closer look at the existing class-level documentation, I don't really see a compelling case for an edit this large. I for one would be content if the bug were

Re: Documentation of methods in java.lang.Number

2014-12-17 Thread Andreas Lundblad
On Tue, Dec 16, 2014 at 03:18:49PM -0800, Brian Burkhalter wrote: Andreas, Doesn’t the class documentation of Number [1] provide sufficient clarity, to wit: The specific semantics of the conversion from the numeric value of a particular Number implementation to a given primitive type is

Documentation of methods in java.lang.Number

2014-12-16 Thread Andreas Lundblad
has gone missing. Where did the bug report go, and why didn't I get any notification about the removal?) -- Andreas Lundblad

Re: RFR 8065998: Avoid use of _ as a one-character identifier

2014-12-01 Thread Andreas Lundblad
On Mon, Dec 01, 2014 at 01:10:29PM +0100, Jan Lahoda wrote: Hi, In a preparation for JDK-8061549, I'd like to rename all uses of '_' as a one-character identifier in the jaxp and jdk repositories. All the uses I was able to find are in tests, and the identifier is used as a name of a catch

Re: RFR: 8027470: AnnotationSupport uses == rather than .equals to compare Class objects

2013-11-15 Thread Andreas Lundblad
On Thu, Nov 14, 2013 at 07:21:38PM -0800, Joseph Darcy wrote: Hello, Catching up on email, the specification of java.lang.Class does not explicitly promise that its notion of equality must be identity for all time. Therefore, while not required for today's implementations, I would prefer

RFR: 8006730: remove workaround tests when jtreg updated

2013-11-01 Thread Andreas Lundblad
reports: http://bugs.openjdk.java.net/browse/JDK-8006730 -- Andreas Lundblad

RFR: 8027470: AnnotationSupport uses == rather than .equals to compare Class objects

2013-10-31 Thread Andreas Lundblad
/browse/JDK-8027470 -- Andreas Lundblad

RFR: 8016725: TEST_BUG: java/lang/reflect/Method/DefaultMethodModeling.java failing intermittently

2013-10-29 Thread Andreas Lundblad
to web review: http://cr.openjdk.java.net/~alundblad/8016725/webrev.00 Link to bug report: https://bugs.openjdk.java.net/browse/JDK-8016725 -- Andreas Lundblad

Re: RFR: 8004912: Repeating annotations - getAnnotationsByType is not working as expected

2013-10-23 Thread Andreas Lundblad
. The test passes after applying the patch. best regards, Andreas Lundblad

Re: RFR: 8004912: Repeating annotations - getAnnotationsByType is not working as expected

2013-10-22 Thread Andreas Lundblad
On Tue 22 Oct 2013 12:21:36 PM CEST, Joel Borggrén-Franck wrote: Hi Andreas, A few nits: Class.java: import java.util.Collection; +import java.util.Collections; import java.util.HashSet; unused import. Right. Thanks. AnnotationSupport.java: +/** + * Equivalent to calling

Re: RFR: 8004912: Repeating annotations - getAnnotationsByType is not working as expected

2013-10-21 Thread Andreas Lundblad
. this file is in the langtools repo) Link to web review: http://cr.openjdk.java.net/~alundblad/8019420-and-8004912/ Link to bug reports: https://bugs.openjdk.java.net/browse/JDK-8004912 https://bugs.openjdk.java.net/browse/JDK-8019420 -- Andreas Lundblad

RFR: 8004912: Repeating annotations - getAnnotationsByType is not working as expected

2013-10-16 Thread Andreas Lundblad
review: http://cr.openjdk.java.net/~alundblad/8019420-and-8004912/ Link to bug reports: https://bugs.openjdk.java.net/browse/JDK-8004912 https://bugs.openjdk.java.net/browse/JDK-8019420 -- Andreas Lundblad