Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-27 Thread Claes Redestad
On 2020-04-27 17:16, Lance Andersen wrote: Hi Claes, The changes and the performance bump all look good and with the minor change below helps the readability. Thanks! Pushed. /Claes Thank you for using your performance expertise to improve this area. Best Lance On Apr 27, 2020, at 6:11

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-27 Thread Lance Andersen
Hi Claes, The changes and the performance bump all look good and with the minor change below helps the readability. Thank you for using your performance expertise to improve this area. Best Lance > On Apr 27, 2020, at 6:11 AM, Claes Redestad wrote: > > > > On 2020-04-27 11:49, Volker

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-27 Thread Claes Redestad
On 2020-04-27 11:49, Volker Simonis wrote: On Sun, Apr 26, 2020 at 11:34 PM Claes Redestad wrote: Hi again, On 2020-04-24 21:22, Claes Redestad wrote: It seems that 'getEntryHitUncached' is getting slightly slower with your change while all the other variants get significantly faster. I

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-27 Thread Volker Simonis
On Sun, Apr 26, 2020 at 11:34 PM Claes Redestad wrote: > > Hi again, > > On 2020-04-24 21:22, Claes Redestad wrote: > >> It seems that 'getEntryHitUncached' is getting slightly slower with > >> your change while all the other variants get significantly faster. I > >> don't think that's a problem,

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-26 Thread Claes Redestad
Hi again, On 2020-04-24 21:22, Claes Redestad wrote: It seems that 'getEntryHitUncached' is getting slightly slower with your change while all the other variants get significantly faster. I don't think that's a problem, but do you have an explanation why that's the case? I've noticed it swing

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-24 Thread Claes Redestad
On 2020-04-24 20:07, Lance Andersen wrote: Hi Claes, Thank you for continuing to improve the performance in this part of java.util.zip.  The changes I think look pretty good. Best Lance Thanks for the review, Lance! Hopefully a few more improvements to come.. /Claes

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-24 Thread Claes Redestad
Hi Volker, On 2020-04-24 20:37, Volker Simonis wrote: On Thu, Apr 23, 2020 at 2:35 PM Claes Redestad wrote: Hi, current implementation of ZipFile.getEntryPos takes the encoded byte[] of the String we're looking up. Which means when looking up entries across multiple jar files, we allocate

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-24 Thread Volker Simonis
On Thu, Apr 23, 2020 at 2:35 PM Claes Redestad wrote: > > Hi, > > current implementation of ZipFile.getEntryPos takes the encoded byte[] > of the String we're looking up. Which means when looking up entries > across multiple jar files, we allocate the byte[] over and over for each > jar file

Re: RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-24 Thread Lance Andersen
Hi Claes, Thank you for continuing to improve the performance in this part of java.util.zip. The changes I think look pretty good. Best Lance > On Apr 23, 2020, at 8:34 AM, Claes Redestad wrote: > > Hi, > > current implementation of ZipFile.getEntryPos takes the encoded byte[] > of the

RFR: 8243469: Lazily encode name in ZipFile.getEntryPos

2020-04-23 Thread Claes Redestad
Hi, current implementation of ZipFile.getEntryPos takes the encoded byte[] of the String we're looking up. Which means when looking up entries across multiple jar files, we allocate the byte[] over and over for each jar file searched. If we instead refactor the internal hash table to use a