Re: RFR: JDK-8303689: javac -Xlint could/should report on "dangling" doc comments

2024-03-28 Thread Vicente Romero
On Wed, 27 Mar 2024 22:04:30 GMT, Jonathan Gibbons wrote: > Please review the updates to support a proposed new > `-Xlint:dangling-doc-comments` option. > > The work can be thought of as in 3 parts: > > 1. An update to the `javac` internal class `DeferredLintHandler` so that it > is possible

Re: RFR: 8329138: Convert JFR FileForceEvent to static mirror event

2024-03-28 Thread Alan Bateman
On Fri, 29 Mar 2024 00:52:46 GMT, Tim Prinzing wrote: > Currently the JFR event FileForceEvent is generated by instrumenting the > sun.nio.ch.FileChannelImpl class. This needs to be changed to use the newer > mirror events with static methods. > > Added the event at

Re: Pattern matching refactoring proposal

2024-03-28 Thread Alan Bateman
On 29/03/2024 05:43, science2000 wrote: Hello Core Libs Dev team, I would like to propose a patch [1] that applies pattern matching for 'instanceof' (JEP-394) and 'switch-case' (JEP-433) on java.base. I suppose this enchantment will improve readability and reduce the code redundancy in

RFR: 8329138: Convert JFR FileForceEvent to static mirror event

2024-03-28 Thread Tim Prinzing
Currently the JFR event FileForceEvent is generated by instrumenting the sun.nio.ch.FileChannelImpl class. This needs to be changed to use the newer mirror events with static methods. Added the event at jdk.internal.event.FileForceEvent, and changed jdk.jfr.events.FileForceEvent to be a mirror

Integrated: JDK-8329118: Run MessageFormat additional subformat pattern tests under en_US locale

2024-03-28 Thread Justin Lu
On Tue, 26 Mar 2024 20:49:48 GMT, Justin Lu wrote: > Please review this PR which updates two MessageFormat sub format related > tests to be guaranteed to run under the `en_US` locale. > > There exists locale that do not provide distinct instances for separate > styles. For example, the

Re: RFR: 8314480: Memory ordering spec updates in java.lang.ref [v18]

2024-03-28 Thread Brent Christian
> Classes in the `java.lang.ref` package would benefit from an update to bring > the spec in line with how the VM already behaves. The changes would focus on > _happens-before_ edges at some key points during reference processing. > > A couple key things we want to be able to say are: > -

Pattern matching refactoring proposal

2024-03-28 Thread science2000
Hello Core Libs Dev team,I would like to propose a patch [1] that applies pattern matching for 'instanceof' (JEP-394) and 'switch-case' (JEP-433) on java.base. I suppose this enchantment will improve readability and reduce the code redundancy in cases of casts after 'inctanceof' checking.For

Re: RFR: 8326627: Document Double/Float.valueOf(String) behavior for numeric strings with non-ASCII digits

2024-03-28 Thread Justin Lu
On Wed, 27 Mar 2024 19:58:17 GMT, Naoto Sato wrote: > Clarifying the behavior for non-ASCII digits in Double/Float.valueOf(String) > method descriptions. A draft CSR has also been created. New wording LGTM - Marked as reviewed by jlu (Committer). PR Review:

Re: InetAddress API extension proposal

2024-03-28 Thread Sergey Chernyshev
Hi Alan, Thank you for your comments! I will post this to net-nev too as you suggested. Am 28.03.24 um 00:23 schrieb Alan Bateman: On 27/03/2024 17:05, Sergey Chernyshev wrote: In the discussion of .ofLiteral() it was not concluded that .ofPosixLiteral() would be insecure or

Re: RFR: JDK-8319516 - Native library suffix impact on the library loading in AIX- Java Class Loader [v6]

2024-03-28 Thread Mandy Chung
On Wed, 27 Mar 2024 17:23:50 GMT, Suchismith Roy wrote: >> Allow support for both .a and .so files in AIX. >> If .so file is not found, allow fallback to .a extension. >> JBS Issue: [JDK-8319516](https://bugs.openjdk.org/browse/JDK-8319516) > > Suchismith Roy has updated the pull request with a

Re: RFR: 8328821: Map.of().entrySet() mutators should throw UnsupportedOperationException

2024-03-28 Thread Liam Miller-Cushon
On Wed, 27 Mar 2024 21:49:10 GMT, Chen Liang wrote: >> This change overrides mutator methods in the implementation returned by >> `Map.of().entrySet()` to throw `UnsupportedOperationException`. > > src/java.base/share/classes/java/util/ImmutableCollections.java line 1321: > >> 1319:

Re: RFR: 8328821: Map.of().entrySet() mutators should throw UnsupportedOperationException

2024-03-28 Thread Chen Liang
On Wed, 27 Mar 2024 17:36:28 GMT, Liam Miller-Cushon wrote: > This change overrides mutator methods in the implementation returned by > `Map.of().entrySet()` to throw `UnsupportedOperationException`. src/java.base/share/classes/java/util/ImmutableCollections.java line 1321: > 1319:

RFR: 8328821: Map.of().entrySet() mutators should throw UnsupportedOperationException

2024-03-28 Thread Liam Miller-Cushon
This change overrides mutator methods in the implementation returned by `Map.of().entrySet()` to throw `UnsupportedOperationException`. - Commit messages: - Use AbstractImmutableSet - Throw UOE for all Map.of().entrySet() mutator methods - 8328821: Make the ImmutableCollections

RFR: 8329013: StackOverflowError when starting Apache Tomcat with signed jar

2024-03-28 Thread Sean Coffey
Calling extra logging calls during initialization of Logger libraries can cause recursion leading to StackOverflowError This patch adds logic to the EventHelper class to detect recursion and prevent it. - Commit messages: - 8329013 Changes:

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview) [v5]

2024-03-28 Thread Jan Lahoda
> This is a patch for javac, that adds the Derived Record Creation expressions. > The current draft specification for the feature is: > https://cr.openjdk.org/~gbierman/jep468/jep468-20240326/specs/derived-record-creation-jls.html > > The current CSR is here: >

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview) [v4]

2024-03-28 Thread Jan Lahoda
> This is a patch for javac, that adds the Derived Record Creation expressions. > The current draft specification for the feature is: > https://cr.openjdk.org/~gbierman/jep468/jep468-20240326/specs/derived-record-creation-jls.html > > The current CSR is here: >

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview) [v3]

2024-03-28 Thread Jan Lahoda
> This is a patch for javac, that adds the Derived Record Creation expressions. > The current draft specification for the feature is: > https://cr.openjdk.org/~gbierman/jep468/jep468-20240326/specs/derived-record-creation-jls.html > > The current CSR is here: >

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview) [v3]

2024-03-28 Thread Jan Lahoda
On Thu, 28 Mar 2024 11:00:42 GMT, Aggelos Biboudis wrote: >> Jan Lahoda has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Renaming visitReconstruction to visitDerivedInstance as suggested. > >

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview) [v2]

2024-03-28 Thread Jan Lahoda
> This is a patch for javac, that adds the Derived Record Creation expressions. > The current draft specification for the feature is: > https://cr.openjdk.org/~gbierman/jep468/jep468-20240326/specs/derived-record-creation-jls.html > > The current CSR is here: >

Re: RFR: 8324651: Compiler Implementation for Derived Record Creation (Preview)

2024-03-28 Thread Aggelos Biboudis
On Wed, 27 Mar 2024 10:24:51 GMT, Jan Lahoda wrote: > This is a patch for javac, that adds the Derived Record Creation expressions. > The current draft specification for the feature is: > https://cr.openjdk.org/~gbierman/jep468/jep468-20240326/specs/derived-record-creation-jls.html > > The

Re: RFR: JDK-8319516 - Native library suffix impact on the library loading in AIX- Java Class Loader [v6]

2024-03-28 Thread Martin Doerr
On Wed, 27 Mar 2024 17:23:50 GMT, Suchismith Roy wrote: >> Allow support for both .a and .so files in AIX. >> If .so file is not found, allow fallback to .a extension. >> JBS Issue: [JDK-8319516](https://bugs.openjdk.org/browse/JDK-8319516) > > Suchismith Roy has updated the pull request with a