Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v6]

2022-07-06 Thread Lance Andersen
On Mon, 4 Jul 2022 19:30:50 GMT, Alan Bateman wrote: > The updated TestDelegation test is looking a bit better now but I think it > would be simplified a lot more by getting rid of the data providers, just > aren't needed in this test. Unless you feel this is a must, I would prefer to keep

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v6]

2022-07-06 Thread Alan Bateman
On Tue, 5 Jul 2022 09:54:15 GMT, Lance Andersen wrote: > Unless you feel this is a must, I would prefer to keep the DataProviders. The > benefit I see is the test code does not need to be duplicated per parameter, > each test scenario can be run as an individual test so that you do not need >

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v7]

2022-07-05 Thread Alan Bateman
On Tue, 5 Jul 2022 19:17:27 GMT, Lance Andersen wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v7]

2022-07-05 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v6]

2022-07-05 Thread Lance Andersen
On Tue, 5 Jul 2022 10:56:45 GMT, Alan Bateman wrote: > > Unless you feel this is a must, I would prefer to keep the DataProviders. > > The benefit I see is the test code does not need to be duplicated per > > parameter, each test scenario can be run as an individual test so that you > > do

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v6]

2022-07-05 Thread Alan Bateman
On Mon, 4 Jul 2022 19:30:40 GMT, Lance Andersen wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v6]

2022-07-05 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v5]

2022-07-05 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v4]

2022-07-01 Thread Alan Bateman
On Mon, 27 Jun 2022 16:43:55 GMT, Lance Andersen wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v4]

2022-06-27 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-27 Thread Alan Bateman
On Sun, 26 Jun 2022 13:33:40 GMT, Lance Andersen wrote: > I thought about using TestProvider and then talked myself out of it. So yes, > I can do that. If you have a preferred name other than > `TestOverRideFSPMethods` please let me know The only change that should be needed to TestProvider

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v3]

2022-06-26 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Lance Andersen
On Sun, 26 Jun 2022 13:13:35 GMT, Alan Bateman wrote: > The implementation changes in latest version address my previous points, > thanks! I don't the test as it duplicates most of the existing of the > TestProvider in this directory and the naming is inconsistent with the > existing tests. I

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Alan Bateman
On Sun, 26 Jun 2022 11:13:58 GMT, Lance Andersen wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-24 Thread Brian Burkhalter
On Thu, 23 Jun 2022 07:18:07 GMT, Alan Bateman wrote: >> src/java.base/unix/classes/sun/nio/fs/UnixFileAttributes.java line 80: >> >>> 78: static UnixFileAttributes getIfExists(UnixPath path) throws >>> UnixException { >>> 79: UnixFileAttributes attrs = new UnixFileAttributes();

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-24 Thread Lance Andersen
On Thu, 23 Jun 2022 10:55:00 GMT, Alan Bateman wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-24 Thread Lance Andersen
On Wed, 22 Jun 2022 22:26:23 GMT, Brian Burkhalter wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> -

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-24 Thread Lance Andersen
On Thu, 23 Jun 2022 08:05:42 GMT, Chris Hegarty wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-23 Thread Alan Bateman
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-23 Thread Alan Bateman
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-23 Thread Chris Hegarty
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-23 Thread Alan Bateman
On Wed, 22 Jun 2022 22:18:05 GMT, Brian Burkhalter wrote: > I think that this is the only use of `stat2()`. It could be deleted if this > method were replaced with this: The purpose of these additions to the SPI is to improve the performance of user facing methods that don't throw an

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Brian Burkhalter
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Brian Burkhalter
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Brian Burkhalter
On Wed, 22 Jun 2022 19:54:47 GMT, Lance Andersen wrote: >> src/java.base/share/classes/java/nio/file/spi/FileSystemProvider.java line >> 1218: >> >>> 1216: >>> 1217: /** >>> 1218: * Reads a file's attributes as a bulk operation if it exists. >> >> Maybe instead "it" put "the file"?

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Lance Andersen
On Wed, 22 Jun 2022 19:22:50 GMT, Brian Burkhalter wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> -

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Brian Burkhalter
On Wed, 22 Jun 2022 19:05:41 GMT, Lance Andersen wrote: > Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A

RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider

2022-06-22 Thread Lance Andersen
Hi, Please review the following patch which will: - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include the methods - public boolean exists(Path path, LinkOption... options) - public A readAttributesIfExists(Path path, Class type, LinkOption... options) This