Re: RFR: 8286825: Linker naming cleanup [v2]

2022-05-23 Thread Jorn Vernee
On Fri, 20 May 2022 10:57:44 GMT, Jorn Vernee  wrote:

>> This patch is a batch naming cleanup for the foreign linker implementation.
>> 
>> The naming changes are as follows:
>> 
>>   - ProgrammableInvoker -> DowncallLinker
>>   - ProgrammableUpcallHandler -> UpcallLinker
>>   - 'native invoker' -> 'downcall stub'
>>   - 'optimzed entry blob' -> 'upcall stub'
>>   - OptimizedEntryBlob -> UpcallStub
>>   - optimized_entry_frame -> upcall_stub_frame
>> 
>> Then renaming of some hotspot files:
>> 
>>   - universalNativeInvoker* -> downcallLinker*
>>   - universalUpcallHandler* -> upcallLinker*
>>   - foreign_globals* -> foreignGlobals* (to match existing convention)
>>   
>> Method, field, and other variable names are also adjusted accordingly.
>> 
>> Testing: Tier 1-4
>
> Jorn Vernee has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Comments + cleanup

Thanks. The down/upcall terminology is the one we use in the public Java API as 
well, so using that everywhere seems the most consistent.

I'm fine with revisiting.

-

PR: https://git.openjdk.java.net/jdk/pull/8777


Re: RFR: 8286825: Linker naming cleanup [v2]

2022-05-22 Thread Robbin Ehn
On Fri, 20 May 2022 10:57:44 GMT, Jorn Vernee  wrote:

>> This patch is a batch naming cleanup for the foreign linker implementation.
>> 
>> The naming changes are as follows:
>> 
>>   - ProgrammableInvoker -> DowncallLinker
>>   - ProgrammableUpcallHandler -> UpcallLinker
>>   - 'native invoker' -> 'downcall stub'
>>   - 'optimzed entry blob' -> 'upcall stub'
>>   - OptimizedEntryBlob -> UpcallStub
>>   - optimized_entry_frame -> upcall_stub_frame
>> 
>> Then renaming of some hotspot files:
>> 
>>   - universalNativeInvoker* -> downcallLinker*
>>   - universalUpcallHandler* -> upcallLinker*
>>   - foreign_globals* -> foreignGlobals* (to match existing convention)
>>   
>> Method, field, and other variable names are also adjusted accordingly.
>> 
>> Testing: Tier 1-4
>
> Jorn Vernee has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Comments + cleanup

Note that some find downcall/upcall unintuitive.
We may need revisit this.

Thanks

-

Marked as reviewed by rehn (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/8777


Re: RFR: 8286825: Linker naming cleanup [v2]

2022-05-20 Thread Maurizio Cimadamore
On Fri, 20 May 2022 10:57:44 GMT, Jorn Vernee  wrote:

>> This patch is a batch naming cleanup for the foreign linker implementation.
>> 
>> The naming changes are as follows:
>> 
>>   - ProgrammableInvoker -> DowncallLinker
>>   - ProgrammableUpcallHandler -> UpcallLinker
>>   - 'native invoker' -> 'downcall stub'
>>   - 'optimzed entry blob' -> 'upcall stub'
>>   - OptimizedEntryBlob -> UpcallStub
>>   - optimized_entry_frame -> upcall_stub_frame
>> 
>> Then renaming of some hotspot files:
>> 
>>   - universalNativeInvoker* -> downcallLinker*
>>   - universalUpcallHandler* -> upcallLinker*
>>   - foreign_globals* -> foreignGlobals* (to match existing convention)
>>   
>> Method, field, and other variable names are also adjusted accordingly.
>
> Jorn Vernee has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Comments + cleanup

Marked as reviewed by mcimadamore (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/8777


Re: RFR: 8286825: Linker naming cleanup [v2]

2022-05-20 Thread Jorn Vernee
> This patch is a batch naming cleanup for the foreign linker implementation.
> 
> The naming changes are as follows:
> 
>   - ProgrammableInvoker -> DowncallLinker
>   - ProgrammableUpcallHandler -> UpcallLinker
>   - 'native invoker' -> 'downcall stub'
>   - 'optimzed entry blob' -> 'upcall stub'
>   - OptimizedEntryBlob -> UpcallStub
>   - optimized_entry_frame -> upcall_stub_frame
> 
> Then renaming of some hotspot files:
> 
>   - universalNativeInvoker* -> downcallLinker*
>   - universalUpcallHandler* -> upcallLinker*
>   - foreign_globals* -> foreignGlobals* (to match existing convention)
>   
> Method, field, and other variable names are also adjusted accordingly.

Jorn Vernee has updated the pull request incrementally with one additional 
commit since the last revision:

  Comments + cleanup

-

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/8777/files
  - new: https://git.openjdk.java.net/jdk/pull/8777/files/7b0e3a88..b362a822

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=8777&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=8777&range=00-01

  Stats: 14 lines in 3 files changed: 0 ins; 0 del; 14 mod
  Patch: https://git.openjdk.java.net/jdk/pull/8777.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/8777/head:pull/8777

PR: https://git.openjdk.java.net/jdk/pull/8777