Openbox gray screen

2007-04-24 Thread Omar Yasseen
Hi All,
 
Problem: Opening CygwinX with Openbox and getting a window with gray
screen background. Like this: grayscreen.GIF
 
Part(1) My installation steps:
 
* Downloaded CygwinX setup.exe.
* Invoked exe and installed default packages.
* I then invoked the exe again and selected ALL modules under X11R
packages.
* I opened C:\Cygwin\usr\X11R6\bin\startxwin.bat and inserted REM in
front of all the %RUN% statements, this is comment them out.
* I then inserted two new statements at the end of the bat file like so:
run XWin
run openbox
* I invoke the bat file and get the gray screen attached.
* Please see Part(1) logs below.
 
Part(2) But the funny thing is:
* When I get the gray window and invoke the startxwin.bat again (whilst
the first X server is already running).
* I get an error message like this: cygwerror.GIF.
* When I ok and close the error box.
* The first window that was gray is now showing the Openbox GUI
correctly like this openbox.GIF
* Please see Part(2) logs below.
 
The question is why am I getting the gray screen?
 
Any help or tips will be appreciated thanks.
 
JavaGeek
 
 
Logs:
 
* From Part(1)
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4
 
Contact: cygwin-xfree@cygwin.com
 
_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not
be created.
XWin was started with the following command line:
 
/usr/X11R6/bin/XWin 
 
(II) XF86Config is not supported
(II) See for more information winCreateBoundingWindowWindowed - Setting
normal windowstyle MIT-SHM extension disabled due to lack of kernel
support XFree86-Bigfont extension local-client optimization disabled due
to lack of shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: 0809 (0809)
(--) Using preset keyboard for English (United Kingdom) (809), type
4
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing
from list!

* From Part(2)
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4
 
Contact: cygwin-xfree@cygwin.com
 
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
 
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't
already running winDeinitMultiWindowWM - Noting shutdown in progress
winProcEstablishConnection - Clipboard is not enabled, returning.
 
 
 

 
The information contained in this email is strictly confidential and for the 
use of the addressee only, unless otherwise indicated. If you are not the 
intended recipient, please do not read, copy, use or disclose to others this 
message or any attachment. Please also notify the sender by replying to this 
email or by telephone +44 (0)20 7896 0011 and then delete the email and any 
copies of it. Opinions, conclusions (etc.) that do not relate to the official 
business of this company shall be understood as neither given nor endorsed by 
it. IG Markets Limited and IG Index Plc are authorised and regulated by the 
Financial Services Authority and, in Australia, by the Australian Securities 
and Investments Commission.

--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/



Re: Windows Vista

2007-04-24 Thread Scott Fordin

Brian Dessent wrote:

Scott Fordin wrote:

Also make sure that you run the Cygwin setup as Administrator.


Eh?  I just installed on Vista yesterday and all I had to do was click
on setup.exe.  Vista asked to run it as administrator since the
executable is named setup.exe.   I didn't have to do anything special.


Dunno. It was the only I way I could get it to work, and I was
following advice I read elsewhere. In any case, it did work when
I ran it as Administrator. Are there any downsides to doing it
this way?

Scott


--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/



problems with startx

2007-04-24 Thread Mariana Silva
Hello

I finally completed the installation of cygwin/X in my computer (thank you for 
the previous help with that!).
When I try to run startx following the instruction on the user guide, the 
program stops and I can not do anything else but close the windows. I have no 
idea how to fix that... Any help? :-(

Thanks
Mariana

PS. This is the message I get:


$ startx

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4

Contact: cygwin-xfree@cygwin.com

XWin was started with the following command line:

X :0 -multiwindow -clipboard

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 1280 height: 1024 depth: 32
winInitVisualsShadowGDI - Masks 00ff ff00 00ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of 
shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: 0409 (0409) 
(--) Using preset keyboard for English (USA) (409), type 7
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from 
list!
winInitMultiWindowWM - pthread_mutex_lock () returned.
__
Mariana F. Silva
Graduate Research Assistant
Department of Theoretical and Applied Mechanics
University of Illinois
213 Talbot Laboratory
104 South Wright Street
Urbana, Illinois 61801 USA
phone:(217)333-0498
e-mail: [EMAIL PROTECTED]


--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/