Re: newbie xlib/xt question

2007-02-28 Thread René Berber
and the libraries, the problem with unresolved symbols is caused by the order in which the libraries are searched. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ

Re: X forwarding

2007-02-23 Thread René Berber
if you are doing X forwarding. The suggestion meant to set DISPLAY on the client side (Cygwin), you are correct about not changing it on the server side. Just do: export DISPLAY=localhost:0:0 ssh -Y ... -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem

Re: Xlib connection refused

2007-01-16 Thread René Berber
address should be 127.0.0.1 (or the IP of the server) not the client address. Many people gave you the wrong information, in short ssh takes care of setting DISPLAY when you use -X or -Y or both, no need for anything else. -- René Berber -- Unsubscribe info: http://cygwin.com/ml

Re: Xlib connection refused

2007-01-16 Thread René Berber
sets for a good reason: ssh itself is listening to the respective port on the remote side, and will tunnel all the X protocol, encrypted and compressed or not, to the client side, where it will connect to localhost:0.0 which is where your Cygwin X server is listening. -- René Berber -- Unsubscribe

Re: Cygwin/X and cygrunsrv

2006-12-03 Thread René Berber
something similar, not a service that starts on boot, but a background X server that is running without the usual xterm that you can't close (the next step would be to test cygrunsrv with, and w/o, the -i option). -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple

Re: ERROR: Cannot open X display

2006-10-31 Thread René Berber
(the 10.0). The reason it works from some computers and not from others is that even if the X server exists at myipaddress:0.0 it could be blocked by any firewall between computers; the ssh tunnel is the way to avoid being blocked. [snip] -- René Berber -- Unsubscribe info: http://cygwin.com/ml

Re: Error

2006-10-27 Thread René Berber
try to start it again... won't work, the original problem is still there. Wild guess: you have anti-virus or internet security software that block the X server ports. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: xterm Xt error: Can't open display

2006-10-13 Thread René Berber
? If you did get a xterm, as you say above, then these errors are probably not important since that xterm means X was running fine, at least once. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation

Re: 1.5.21: startxwin.sh works, startxwin.bat does not work

2006-10-01 Thread René Berber
a vis this particular problem. I've attached the diff output. I can't even figure out where the lapack libraries are being called... Nowhere... so what is being run? -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: 1.5.21: startxwin.sh works, startxwin.bat does not work

2006-09-29 Thread René Berber
tried totally removing and reinstalling Cygwin a couple of times already. Did you check what was left on the above directory? If Cygwin did not install whatever is there it will not delete it. [snip] -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem

Re: 1.5.21: startxwin.sh works, startxwin.bat does not work

2006-09-29 Thread René Berber
Scott Fordin wrote: Thanks for replying, René. My responses are embedded inline. René Berber wrote: When I tried running the C:\cygwin\lib\Singular\startxserver.bat -^ That is not from the Cygwin distribution. Dunno. I ran

Re: error

2006-09-27 Thread René Berber
Cygwin list as being the result of running McAfee antivirus. The solution is: disable the buffer overrun protection Ref: http://permalink.gmane.org/gmane.os.cygwin/82086 -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: XF86Config file

2006-09-27 Thread René Berber
). The answer to the OP is no (as shown in the messages when X starts and stored in /tmp/XWin.log: (II) XF86Config is not supporte), but look at the comments in /usr/X11R6/bin/startxwin.bat (i.e. you can specify your own -- don't know if it works but that's what the file says). -- René Berber

Re: XWin -silent-dup-error not so silent

2006-09-09 Thread René Berber
-error fi \cygwin\bin\run xterm -e /usr/bin/bash -l You can also use pgrep in PID=... if you have it (makes that part clearer and more portable). -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation

Re: Starting XServer

2006-09-07 Thread René Berber
does not exist. What do I do to fix this? What's the output of running mount -m ? -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http

Re: Cygwin Error

2006-09-01 Thread René Berber
are you using? -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: Cygwin/X on multiple displays, nothing displayed

2006-08-29 Thread René Berber
(Not for Windows NT4 and 95). Examples: -screen 0 [EMAIL PROTECTED] ; 2nd monitor offset 100,100 size 800x600 -screen 0 [EMAIL PROTECTED]; 3rd monitor size 1024x768 -screen 0 @1 ; on 1st monitor using its full resolution (the default) ... -- René Berber

Re: Unfixable(?) fatal error with X Server 6.8.99.901-4

2006-08-22 Thread René Berber
. [snip] Looking at the log and from what you describe there are 2 differences with respect of what I use, I start it with startx and I have cygserver running (so XWin can use shared memory), also I have the environment variable CYGWIN=server set. Can you test that with 6.8.99.901-1? -- René Berber

Re: Error: procedure entry point in cygreadline6.dll

2006-08-17 Thread René Berber
asked for problem reporting http://cygwin.com/problems.html . -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs

Re: TCP/IP Security Limits - WinXP and XWIN.exe

2006-08-16 Thread René Berber
Alexander Gottwald wrote: René Berber wrote: XWin only opens a couple of connections, with ssh -X it's only one connection. XWin opens no connection (except for xdmcp). It's a server and will only react on incoming connections. To clarify, and I knew when I wrote the above it wasn't quite

Re: TCP/IP Security Limits - WinXP and XWIN.exe

2006-08-15 Thread René Berber
for the failing connection attempts. And fix the application. Anyone run into this one before with XWin.exe? No. If so a nudge in the right direction would be much appreciated. netstat -nb (and a lot of patience) or netstat -anb (which of course will take a long time). -- René Berber

Re: TCP/IP Security Limits - WinXP and XWIN.exe

2006-08-15 Thread René Berber
Mark Edwards wrote: On 8/16/06, René Berber wrote: [snip] netstat -nb (and a lot of patience) or netstat -anb (which of course will take a long time). Thanks for the comments René, however my point was that it is XWin.exe that seems to be invoking this behaviour. What is not clear to me

Re: TCP/IP Security Limits - WinXP and XWIN.exe

2006-08-15 Thread René Berber
Mark Edwards wrote: On 8/16/06, René Berber wrote: Mark Edwards wrote: [snip] My point was that you need to run netstat to make sure it is XWin... saying seems will not encourage anybody to look into this. FWIW I don't think XWin is going to come out as the problem, as I said I haven't

Re: Error: procedure entry point in cygreadline6.dll

2006-08-13 Thread René Berber
usually other packages install and is what breaks a Cygwin installation. I've cc'ed this reply to the main Cygwin list because this has nothing to do with cygwin-xfree. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: XWindows version of Java?

2006-07-27 Thread René Berber
for Windows has been done under MingW, which by the way also has its own X server, but even there the AWT and Swing stuff has been replaced with SwingWT. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation

Re: modification of startx.bat not work

2006-07-26 Thread René Berber
that you can't troubleshoot the network. I really was thinking of troubleshooting in the regular way, on a terminal window, but if only SC has problems then perhaps is a timeout or some option that can be set inside SC. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe

Re: modification of startx.bat not work

2006-07-25 Thread René Berber
where I can start a Xserver without any bash window and SC. More to explain I am not able with my English. Your original post says that you had a network problem, can you show the actual message? -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports

Re: modification of startx.bat not work

2006-07-25 Thread René Berber
and to start SC? I was thinking that this is easy... It probably is, I just don't use it that way, but what you describe seems possible with CygwinX. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation

Re: modification of startx.bat not work

2006-07-25 Thread René Berber
René Berber wrote: [snip] You probably can just run a Windows shortcut to XWin with all the parameters, and use .xinitrc or .xsession to start up SC. [snip] I made a little experiment and the above sentence is not true: if I start XWindows from an icon/shortcut (using C:\cygwin\bin\run.exe -p

Re: problem when starting the X server

2006-06-30 Thread René Berber
OVERBEY, ALFRED wrote: I am having a problem starting the x-server, see snippet below. Would you be able to direct me to what needs to be configured or setup? Your server started fine but you probably have a firewall blocking all connections. -- René Berber -- Unsubscribe info: http

Re: can't open fontforge--get error cygxml2-2.dll not found

2006-06-28 Thread René Berber
need the XWin bin directory in there. My Windows PATH starts with %CYGHOME%\bin;%CYGHOME%\usr\X11R6\bin;%SystemRoot%\system32;%SystemRoot%;... CYGHOME is c:\cygwin -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: using cadence with xfree?

2006-06-02 Thread René Berber
the comments inside /usr/X11R6/bin/startxwin.sh, it only works with --fullscreen). 2. Don't use XWindows use VNC. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs

Re: startx does not work

2006-05-12 Thread René Berber
executable script on your home directory? Do you have it in /etc/X11/xinit/xinitrc?; one or the other should be executed and the one in /etc does open an xterm at the end. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: i can't start wmaker on cygwin

2006-05-09 Thread René Berber
script. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: Newbie help

2006-04-03 Thread René Berber
need for the moment is the ability to start the server first. The rest I'll ask about later (if people are kind) Type startx in a Cygwin window. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html

Re: How to run _X_ Session from RH8 via ssh -X? How to run vnc via ssh?

2006-03-17 Thread René Berber
. HTH -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: How to run _X_ Session from RH8 via ssh -X?

2006-03-17 Thread René Berber
PROTECTED] # echo $DISPLAY localhost:10.0 Notice that ssh created a pseudo display that will be used to tunnel the X protocol back to your local X server. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html

Re: How to run _X_ Session from RH8 via ssh -X?

2006-03-17 Thread René Berber
$DISPLAY' -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: cygwin gnome-terminal pty error

2006-03-17 Thread René Berber
, a window with no shell prompt? -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: probelems with installation of kde

2006-03-08 Thread René Berber
. Probably the easy way to do this is to add the parameter -x to ash, something like this from the Windows command line: bin\ash -x bin/rebaseall ... and all the rest. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: I have a problem starting Xwin under cygwin on XP

2006-03-08 Thread René Berber
-- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: Xwin

2006-02-27 Thread René Berber
=132.147.177.33:0 xwin -query 132.147.160.33 or the equivalent changing the startx or startxwin.sh scripts. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ

Re: Problem Starting X-Windows

2006-02-22 Thread René Berber
not clear. 1. Does XWin starts fine? (is your question really about a problem starting XWin?) 2. How do you launch X applications? (there shouldn't be any sh.exe started if you run something else) 3. Does disabling McAfee helps? -- René Berber -- Unsubscribe info: http://cygwin.com/ml

Re: Cygwin/X and AIX - client 6 rejected

2006-02-20 Thread René Berber
René Berber wrote: [snip] Looks like XWin access needs to be set, use either xhost + (that gives access from all computers to your workstation, if you want to be more specific then it's xhost +10.19.20.221) or xauth (I don't know how to use this). I found how to use xauth. On the remote

Re: Problem Starting X-Windows

2006-02-17 Thread René Berber
of the startup. One thing that may be usefull is to see what process is really hung. It has to be a child of the shell (startx) and it may be xkbcomp or something else. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: Problem Starting X-Windows

2006-02-16 Thread René Berber
touch /tmp/my-test and see if the (empty) file was created. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs

Re: Qt3 breakage since 1.5.19

2006-02-02 Thread René Berber
could be to do the porting of the newer 3.x/4.x version. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: Qt3 breakage since 1.5.19

2006-02-02 Thread René Berber
René Berber wrote: The library is as close as it gets to a regular library, I separated the debug info, it's just not optimized. It would be interesting to test a rebuilt regular library, have you done that? Answering my own question: no, it doesn't work. Just tested it, rebuilt Qt

Re: Qt3 breakage since 1.5.19

2006-02-02 Thread René Berber
be doing something wrong, but your notes above point in another direction. Regards. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http

Re: Mutex lock failure: Resource deadlock avoided

2006-02-01 Thread René Berber
. If I can help just ask, I could show the way I built the debug version of the QT library for instance, and I could do some testing if needed. Regards. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html

Re: I have a problem with cygwin's running

2006-01-16 Thread René Berber
@cygwin.com XWin was started with the following command-line: X :0 -multiwindow -clipboard And what does /tmp/XWin.log says? Sorry, my crystal ball ran is recharging ;-) -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http

Re: Errors when starting Cygwin/X on Windows XP SP2

2006-01-12 Thread René Berber
this error? I haven't seen that error message but it looks like it is a firewall problem: xinit uses a tcp and an udp port (XWin uses a bunch of them). Check if XWin is enabled in the Exceptions list of Windows Firewall. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple

Re: problems with xfree86 and x11 in Cygwin on notebook

2005-12-31 Thread René Berber
(which didn't know what a rxvt term was), it may not work on other Unix version. HTH -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http

Re: Can't launch an xterm under windows xp-pro

2005-12-27 Thread René Berber
all McAfee SecurityCenter features Any advice or leads very much appreciated. Best regards, In your home directory, do you have a .xinitrc? If nothing works you should look into the log produced by Xwin, it's in /tmp/XWin.log. HTH -- René Berber -- Unsubscribe info: http://cygwin.com/ml

Re: problems with xfree86 and x11 in Cygwin on notebook

2005-12-22 Thread René Berber
for more information Could you post the output of running startx? The part about winDetectSupportedEngines ... or just below that should indicate what is the problem. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com

Re: Mutex init failure trying to run Scribus

2005-12-15 Thread René Berber
I've advanced a bit. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs/faq/

Re: Mutex init failure trying to run Scribus

2005-12-11 Thread René Berber
used the code (build script, patches and original code) downloaded using setup.exe. Problem solved. - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

Re: Mutex init failure trying to run Scribus

2005-12-11 Thread René Berber
/thread.cc:129 - From what you said, the initializer=0x0 is what casuses the SIGSEGV. I'll take a closer look at the qt3 library. Thanks! - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

Re: Mutex init failure trying to run Scribus

2005-12-11 Thread René Berber
. I'm rebuilding the library now w/o debugging. Thanks again. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ: http://x.cygwin.com/docs

Re: scribus: cygjpeg-62.dll not found

2005-12-10 Thread René Berber
the mailing list at CygGnome project, which also looks appropiate: http://sourceforge.net/mail/?group_id=67909 BTW the OP problem was probably the result of not using setup.exe to install Scribus, the instruction in cygwinports.dotsrc.org should be followed. HTH - -- René Berber -BEGIN PGP

Re: scribus: cygjpeg-62.dll not found

2005-12-10 Thread René Berber
opening up the cygwin mailing list to discuss their efforts. OK, understood. - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iEYEARECAAYFAkObY6YACgkQL3NNweKTRgz5gQCgzBTZ31A/fPQOSecVDwq/HL+t

Re: Mutex init failure trying to run Scribus

2005-12-10 Thread René Berber
qt3), but only after it stabilizes more. Thanks for your reply. - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iEYEARECAAYFAkObtJAACgkQL3NNweKTRgxbTgCeOtHMF1Ssr0A6FDQ5+9sVgl3Q

Re: Mutex init failure trying to run Scribus

2005-12-09 Thread René Berber
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Yaakov S (Cygwin Ports) wrote: René Berber wrote: [snip] FWIW, I'm just running with CYGWIN=server. I copied that along with setting cygserver and it made no difference. Thanks. I'll report later if I find something. I tried using cygwin1.dll

Re: Serious X problem, cannot start xterm.

2005-12-09 Thread René Berber
be in /etc/hosts for the case where localhost is not defined as 127.0.0.1. HTH - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iEYEARECAAYFAkOaOp4ACgkQL3NNweKTRgxn9gCg+72MMvfsOH0qF54WkQCmger1

Re: scribus: cygjpeg-62.dll not found

2005-12-09 Thread René Berber
you have some old version of some of those, better check manually (I mean using setup.exe or cygcheck to see what version you have installed). HTH - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

Mutex init failure trying to run Scribus

2005-12-08 Thread René Berber
really starts. Anyone seen this? Any solutions? Thanks. - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iEYEARECAAYFAkOYnysACgkQL3NNweKTRgylFgCfa6w9cWUSSrd5rE2lfEMLvfYD KHcAoP0FevNIkZPJV/VQe8nCc65GBXDa

Re: Mutex init failure trying to run Scribus

2005-12-08 Thread René Berber
I'm using (one of the snapshots) didn't change something that affected this. Thanks for your reply. - -- René Berber -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.2 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org iEYEARECAAYFAkOYvNIACgkQL3NNweKTRgwPNQCeNlN9

Re: Mutex init failure trying to run Scribus

2005-12-08 Thread René Berber
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 René Berber wrote: [snip] You mean Scribus runs anyway? Perhaps I missed something, I didn't see any window or anything else appear. Nope, the program just dies. Anyway I'm recompiling Scribus from sources, let's see if the invalid argument

Re: Mutex init failure trying to run Scribus

2005-12-08 Thread René Berber
next week I can look into this further. Thanks. I'll report later if I find something. -- René Berber -- Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple Problem reports: http://cygwin.com/problems.html Documentation: http://x.cygwin.com/docs/ FAQ