Re: BunZip and an extra question

2002-01-03 Thread Christopher Faylor
On Thu, Jan 03, 2002 at 07:28:24PM +0100, Wilhelm Person wrote: IIRC bzip wasn't in the packages selected by default when I installed cygwin, perhaps if it was added we'd see fewer newbie-unable-to-unpack-questions. cygwin-xfree != cygwin. cgf

Please remove sourcemaster link from cygwin-xfree page

2002-01-05 Thread Christopher Faylor
I'd like to request that the '[EMAIL PROTECTED] address be removed from the cygwin-xfree web pages. In 99.99% of the cases, I've found that people send inappropriate mail there -- mail that should really go to the project mailing list. My theory is that sourcemaster sounds like an individual

Re: Please remove sourcemaster link from cygwin-xfree page

2002-01-05 Thread Christopher Faylor
On Sat, Jan 05, 2002 at 07:32:18PM -0500, Christopher Faylor wrote: I'd like to request that the '[EMAIL PROTECTED] address be removed from the cygwin-xfree web pages. In 99.99% of the cases, I've found that people send inappropriate mail there -- mail that should really go to the project

Re: Help with xfree86 cygwin install on NT4

2002-01-15 Thread Christopher Faylor
Wrong mailing list. Redirected to correct mailing list. cgf On Tue, Jan 15, 2002 at 05:35:28PM -0500, Mcelhatten, Rhuel wrote: Hello - I recently installed Cygwin on an NT4 machine, service pack 5. After doing so I installed the XFree86 binaries, version 4.1.0, but I get the error

Re: Cyg xfree86 webpage suggestion

2002-01-16 Thread Christopher Faylor
On Wed, Jan 16, 2002 at 11:46:13AM -0600, David Kohn wrote: Hi Cygwin and Christopher Faylor, There is no reason to personally address email to a mailing list. Just a quick suggestion, from someone who just went through downloading/installing Cygwin/Xfree86: It might cut down on confusion,etc

Re: X server hangs when adding fonts server

2002-01-16 Thread Christopher Faylor
This must be a new record. This is the WRONG MAILING LIST. I've redirected your request to the proper mailing list. cgf On Wed, Jan 16, 2002 at 08:37:22PM +0200, Tzafrir Cohen wrote: Hi I'm using standard cygwin (1.3.6) with XFree 4.1.0 and test server 53 (I'm not totally sure. Anyway, its

Re: adjust the number of bash windows opened

2002-01-16 Thread Christopher Faylor
Wrong mailing list. Redirected to the correct mailing list. On Wed, Jan 16, 2002 at 02:39:19PM -0500, hongxun lee wrote: When the command 'startx' is run, 3 bash wins are launched automatically, any way to customize this number? Thanks -- Unsubscribe info:

Cygwin XFree web page looks odd in Mozilla

2002-01-16 Thread Christopher Faylor
Anyone else noticing that the XFree86 web page looks odd in Mozilla? Maybe it's because I'm using the latest snapshot but the Project Overview is showing up under the left bar. Btw, I was wondering if you would mind putting a big flashing Send Questions Here! somewhere at the top of the site.

Re: xfree in cygwin Setup program

2002-02-04 Thread Christopher Faylor
On Mon, Feb 04, 2002 at 09:48:31PM +1100, Rasjid Wilcox wrote: Just wondering what the status of getting XFree into the Cygwin Setup program? I followed the discussion on 21st Jan, and a few weeks ago I saw some binaries up on the ftp site that looked like they were in progress, but they are

Re: printing from cygwin-xfree remote printer

2002-02-25 Thread Christopher Faylor
I don't see anything in this email that would indicate that this is an issue for the Cygwin/XFree project. I think you're sending to the wrong mailing list. cgf On Mon, Feb 25, 2002 at 10:45:00PM +0100, Bernard Revet wrote: Dear Cygwinnies I am trying to install LPRng program in Cygwin-Xfree

Re: KDE under cygwin?

2002-03-07 Thread Christopher Faylor
On Thu, Mar 07, 2002 at 09:43:05AM +0100, Ralf Habacker wrote: Is anyone using KDE, KOffice, (especially) KDevelop with Cygwin? I assume it would need the qt library. Is this all workable? Look at http://kde-cygwin.sourceforge.net. There are alpha releases of some kde packages And this is

Re: Blackbox ?

2002-03-07 Thread Christopher Faylor
On Thu, Mar 07, 2002 at 03:34:05PM +0100, Rick Oosterling wrote: Anybody know where to download this windowsmanager ? The original site is up but the download links are down :-( Thanks Wrong mailing list. cgf

Re: KDE under cygwin?

2002-03-07 Thread Christopher Faylor
On Thu, Mar 07, 2002 at 11:32:36AM -0500, [EMAIL PROTECTED] wrote: In a message dated 3/7/02 8:04:30 AM, [EMAIL PROTECTED] writes: On Thu, Mar 07, 2002 at 09:43:05AM +0100, Ralf Habacker wrote: Is anyone using KDE, KOffice, (especially) KDevelop with Cygwin? I assume it would need the qt

Re: KDE under cygwin?

2002-03-08 Thread Christopher Faylor
On Fri, Mar 08, 2002 at 08:59:41AM +, Chris January wrote: Is anyone using KDE, KOffice, (especially) KDevelop with Cygwin? I assume it would need the qt library. Is this all workable? Look at http://kde-cygwin.sourceforge.net. There are alpha releases of some kde packages I would

Re: DDraw Blt vs BltFast

2002-03-12 Thread Christopher Faylor
On Wed, Mar 13, 2002 at 03:14:53PM +1100, Robert Collins wrote: I'm glad it sounds logical. Cygwin already has lots of code that is NT specific, e.g., CYGWIN=ntsec. I agree. I got the impression from Corinna's email that what Ralf was suggesting needed a 9x equivalent to be seriously

Re: Installation on CD-Rom, Copying a whole installation

2002-03-19 Thread Christopher Faylor
On Tue, Mar 19, 2002 at 06:49:05PM +1100, Robert Collins wrote: -Original Message- From: Andrew Markebo [mailto:[EMAIL PROTECTED]] Sent: Tuesday, March 19, 2002 6:44 PM First thoughts, do a package with all required tgz's and then do packages with the fonts not required.. docs.. Hmm

Re: cygwin/xfree86

2002-03-19 Thread Christopher Faylor
On Tue, Mar 19, 2002 at 05:30:51PM +0100, Jean-Marc Nuzillard wrote: Hi, I have downloaded today's version of cygwin, installed all packages, downloaded the todays's files for xfree86, installed as described. From bash I went to /usr/X11R6/bin and ran sh startxwin.sh. I got a white window that

Re: And we have a xfree cygwin package.. (What are they called?)

2002-03-19 Thread Christopher Faylor
On Wed, Mar 20, 2002 at 06:16:31AM +0100, Andrew Markebo wrote: separate .tgz? I The executable tgz's of the xfree package? I am considering giving it a try using them instead.. small ptoblem might be version numbering, can I put version numbers in the hints file? (the dist tgz files today is

Re: And we have a xfree cygwin package.. (What are they called?)

2002-03-19 Thread Christopher Faylor
On Tue, Mar 19, 2002 at 11:27:18PM -0500, Harold Hunt wrote: Okay, I mirrored the files: http://www.msu.edu/~huntharo/xbase/xbase-4.2.0-1.tar.bz2 http://www.msu.edu/~huntharo/xbase/setup.hint http://www.msu.edu/~huntharo/xbase/md5.sum I'm not clear on whether these (mirrored) files are being

Re: And we have a xfree cygwin package.. (What are they called?)

2002-03-19 Thread Christopher Faylor
On Wed, Mar 20, 2002 at 04:13:06PM +1100, Robert Collins wrote: -Original Message- From: Christopher Faylor [mailto:[EMAIL PROTECTED]] Sent: Wednesday, March 20, 2002 3:40 PM To: [EMAIL PROTECTED] Cc: [EMAIL PROTECTED] Subject: Re: And we have a xfree cygwin package.. (What

Re: Launching Term

2002-03-22 Thread Christopher Faylor
On Fri, Mar 22, 2002 at 12:41:14PM +0100, Andrew Markebo wrote: It is wrong for XFree, and wrong for Bash.. but there is a small exception.. bash translates PATH, TMP and TEMP and maybe some more.. if my memory doesn't fail me as usual. It's actually cygwin that translates some environment

Re: missing telnet, solution

2002-03-22 Thread Christopher Faylor
On Fri, Mar 22, 2002 at 08:48:41AM -0800, Phil Burk wrote: Perhaps the Cygwin/XFree86 User Guide could be modified to make sure telnet and ssh get included in the installation the first time. It currently tells people to leave the default settings alone but the default does not include telnet.

Re: missing telnet, solution

2002-03-22 Thread Christopher Faylor
On Fri, Mar 22, 2002 at 02:10:32PM -0500, Harold Hunt wrote: You are referring to the process of installing that which you wish to use. I don't see any problem here. Ditto. I can't update the User's Guide to say install inetutils and ssh because Cygwin is always changes its mind about which

Re: missing telnet, solution

2002-03-23 Thread Christopher Faylor
On Sat, Mar 23, 2002 at 06:18:05PM +0100, Palic, Darko wrote: Hello Christopher, okay it is nice to follow the request of the users, but why isn't a selectbox available, there something like basic/minimal, common/typical and complete could be selected instead of changing the whole setup? It

XFree86 work with Japanese characters?

2002-03-26 Thread Christopher Faylor
Someone is asking me internally at Red Hat if Cygwin/XFree86 correctly handles Japanese characters. Can anyone confirm or deny that it does/doesn't? cgf

Re: xfree86 work with Japanese characters?

2002-03-26 Thread Christopher Faylor
On Tue, Mar 26, 2002 at 06:45:47PM +0100, PD Dr. Edward Wornar wrote: For me (emacs/mew, mozilla, konqueror) it does. xterm, too? cgf

Re: xfree86 work with Japanese characters?

2002-03-27 Thread Christopher Faylor
On Wed, Mar 27, 2002 at 08:14:53AM +0100, PD Dr. Edward Wornar wrote: From: Christopher Faylor [EMAIL PROTECTED] Subject: Re: xfree86 work with Japanese characters? Date: Tue, 26 Mar 2002 14:44:17 -0500 On Tue, Mar 26, 2002 at 06:45:47PM +0100, PD Dr. Edward Wornar wrote: For me (emacs/mew

Re: xfree86 not working with 1.3.10-1

2002-03-31 Thread Christopher Faylor
On Sun, Mar 31, 2002 at 01:15:08PM -0800, Bob Calco wrote: Anybody: I just tried to install XFree86, and I'm getting the Cannot open display 127.0.0.1:0.0 error described as a bug in some versions of cygwin1.dll in the startxwin.sh startup script. I have the latest greatest cygwin 1.3.10-1

Re: Michigan State University is using cygwin/xfree86 in the Public Microcomputer Labs

2002-04-03 Thread Christopher Faylor
On Wed, Apr 03, 2002 at 06:02:34PM -0500, Harold Hunt wrote: Imagine my surprise when I walked into a computer lab at Michigan State University today, logged in, and found Cygwin/XFree86 in the Start menu of my very own university (40,000+ students). I was utterly amazed. I haven't got a link

Re: App Unable to Acceess X Display

2002-04-05 Thread Christopher Faylor
Redirected to proper mailing list. On Thu, Apr 04, 2002 at 08:50:10PM -0500, Mike wrote: Hello. My name is Mike. I am running Win 2000 Pro. I have recently tried to install the Lyx Latex editor. I had a successful Cygwin and, by all indications, Lyx install. When I try to launch Lyx, I

Re: cx-logos

2002-04-05 Thread Christopher Faylor
wondering if he would like to send just the cygwin logo part. I'd like to use it for the cygwin stuff. In fact, I'd like to use it for Cygwin Setup. cgf On Fri, Apr 05, 2002 at 12:04:25PM -0500, Christopher Faylor wrote: On Fri, Apr 05, 2002 at 12:02:04PM -0500, Nikolaus Bates-Haus wrote: Thanks

Re: cygwin/xfree86 logged into KDE3 causes strange cygwin error

2002-04-05 Thread Christopher Faylor
On Fri, Apr 05, 2002 at 08:22:26PM -0500, Harold Hunt wrote: Oh yeah, by sketchy I meant that after it happens a few times and I switch the focus away from Cygwin/XFree86 two things happen: 1) Cygwin/XFree86 freezes solid. 2) The Windows mouse cursor disappears and the Windows mouse doesn't

Re: cx-logos

2002-04-06 Thread Christopher Faylor
On Sat, Apr 06, 2002 at 06:43:50PM -0800, Tucker McLean wrote: Hey, I sure as heck am listening! I got a big ego trip when I read this message. The GIMP .xcf file is attached to this message. This is the dual logo, right? Could you separate out just the Cygwin part? cgf

Re: cx-logos

2002-04-07 Thread Christopher Faylor
On Sun, Apr 07, 2002 at 11:18:12PM -0400, Harold Hunt wrote: It would be best if you didn't send 193 KB attachments to the entire mailing list (I don't know how many people that is, but it could be a few hundred). 518, actually! Wow. That includes 122 who are subscribed to the digest. cgf

Re: info: single install xfree86 + minimal cygwin?

2002-04-08 Thread Christopher Faylor
On Mon, Apr 08, 2002 at 04:02:06PM -0400, Green, Keith wrote: However, we would prefer to give customers an environment they could use for this. Some months ago I downloaded cygwin/xfree86 onto my system (with some help) and installed it on my pc. It appears to support everything we want to do.

Re: info: single install xfree86 + minimal cygwin?

2002-04-09 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 05:56:36PM -0700, Ian Burrell wrote: Robert Collins wrote: I'm not clear not the hierarchy there - that reads like a list to me. You've got two clauses you can independently use to make a hierarchy and package dependencies - category:(i.e. the devel tarball belongs in

Re: info: single install xfree86 + minimal cygwin?

2002-04-09 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 09:43:54PM -0400, Charles Wilson wrote: If it is upset I'll be upset. It should be acceptable to have bin without source. If it causes a problem, I'll fix it. That's great. (I'm not planning on needlessly changing my packages, but perhaps the next time they must be

Re: info: single install xfree86 + minimal cygwin?

2002-04-09 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 06:34:29PM -0700, Ian Burrell wrote: Is the script for building setup.ini files from a directory hierarchy available anywhere? I want to setup a test install directory with the full hierarchy and setup.hint files. Also, I ran into a problem with the xfree-fonts-100dpi

Re: info: single install xfree86 + minimal cygwin?

2002-04-09 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 07:10:15PM -0700, Ian Burrell wrote: Christopher Faylor wrote: Yes, a -75dpi part of a tar file will look like a version number. Can you use an underscore instead? I could use an underscore. I got it to work by changing it to dpi75. Shouldn't the name in the setup.ini

Re: info: single install xfree86 + minimal cygwin?

2002-04-09 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 07:50:04PM -0700, Ian Burrell wrote: Christopher Faylor wrote: Name? Do you mean version? If you put a version in setup.hint it is currently ignored. The name from the line and the version header could be used to override the parsing of file names into name and version

Re: xfree packages

2002-04-10 Thread Christopher Faylor
On Wed, Apr 10, 2002 at 09:47:31AM +0200, Jan Nieuwenhuizen wrote: Robert Collins [EMAIL PROTECTED] writes: Setup is case insensitive to package names. I don't see any technical issue either way. Me neither, I only see a social issue: it's just plain irritating for people? tar xjf

Re: Problems installing cygwin-xfree86 on a Dell WIN2K box

2002-04-11 Thread Christopher Faylor
Redirecting to the proper mailing list. cgf On Thu, Apr 11, 2002 at 10:17:28AM -0500, Dr. Lawrence Ward Spradley wrote: Sirs: This is a (hopefully more illuminating) follow-up to a post from yesterday. I am midstroke in installing cygwin-XFree86 on a Dell Win2000 box. As of yesterday,

Re: xfree packages

2002-04-11 Thread Christopher Faylor
On Wed, Apr 10, 2002 at 05:27:14PM -0400, Charles Wilson wrote: Ian, Chris wants the setup hint files IN the mailing list archive permanently. Not sitting on an external, subject-to-change website. I've pasted them here. These look ok except the version: field is a no-op in setup.hint and

Re: Suggested FAQ Update: 6.5. Fatal server error: could not open default font 'fixed'

2002-04-14 Thread Christopher Faylor
On Sun, Apr 14, 2002 at 07:19:37PM -0400, Warren Postma wrote: The FAQ listing for section 6.5. Fatal server error: could not open default font 'fixed' does not work. For one thing, the suggested remedy does NOT change the mounting of the /usr directory. A more direct fix would be to update the

Re: xfree packages

2002-04-16 Thread Christopher Faylor
On Wed, Apr 10, 2002 at 01:22:52PM -0700, Ian Burrell wrote: Christopher Faylor wrote: Yes, please post the setup.hint files that you used. Check out http://www.znark.com/cygwin/. It doesn't include the archive files; my web account doesn't have the bandwidth or quota for them. To generate

Re: xfree packages

2002-04-16 Thread Christopher Faylor
On Tue, Apr 16, 2002 at 11:23:37PM -0400, Roland Glenn McIntosh wrote: If I understood you correctly you wanted the Xfree gzipped archives turned into bzipped archives. I have done this using the 4.2.0 cygwin binaries provided at xfree86.org. I stuck with the .tar.bz2 convention most cygwin

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-17 Thread Christopher Faylor
On Thu, Apr 18, 2002 at 01:02:51AM -0400, Harold Hunt wrote: Looks like you figured out upset. Sorry about not responding. Actually, I did the same thing that Ian did and reverted to the upset from: [EMAIL PROTECTED]:/cvs/src in the directory: winsup/cinstall/temp I'd forgotten about that

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-17 Thread Christopher Faylor
On Thu, Apr 18, 2002 at 01:18:19AM -0400, Harold Hunt wrote: The syntax for upset should just be upset dir where `dir' is the directory containing the distribution. setup.ini will go to stdout. upset -u setup.ini dir will update an existing setup.ini. I beg to differ. Try setting it up

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages with dependencies

2002-04-17 Thread Christopher Faylor
On Thu, Apr 18, 2002 at 01:30:22AM -0400, Harold Hunt wrote: 2) upset took the list of requirements from XFree86-base/setup.hint and put them in quotes (cygwin ...) when it created setup.ini. upset didn't do this for any other packages and the Cygwin setup.ini doesn't have quotes around

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-17 Thread Christopher Faylor
On Thu, Apr 18, 2002 at 01:37:08AM -0400, Harold Hunt wrote: Try setting it up like sourceware then. The directory defaults to 'release'. Just do 'upset -u setup.ini' in a directory containing a the 'release' directory. I just moved contrib to release and the new upset works like a dream!

Re: info: single install xfree86 + minimal cygwin?

2002-04-17 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 11:00:23PM -0400, Christopher Faylor wrote: On Tue, Apr 09, 2002 at 07:50:04PM -0700, Ian Burrell wrote: Christopher Faylor wrote: Name? Do you mean version? If you put a version in setup.hint it is currently ignored. The name from the line and the version header could

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-19 Thread Christopher Faylor
On Fri, Apr 19, 2002 at 12:52:27PM -0400, Christopher Faylor wrote: On Fri, Apr 19, 2002 at 01:24:48AM -0400, Harold Hunt wrote: Chris, Shall we add this to the cygwin distro or are we still waiting for some postinstall shell script work? These will forever be known as Harold's Famous Last

Re: cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-19 Thread Christopher Faylor
On Fri, Apr 19, 2002 at 11:17:56PM +0200, Benjamin Riefenstahl wrote: Harold Hunt [EMAIL PROTECTED] writes: Excellent idea. Now I just need someone to write that script. Shouldn't be too hard. Any takers? How about fontdir=/usr/X11R6/lib/X11/fonts wfontdir=`cygpath -w $fontdir` mount

Send an announcement to cygwin-announce?

2002-04-19 Thread Christopher Faylor
Harold, do you want to send an announcement to cygwin-announce? If so, I'd appreciate it if you'd pattern it on one of the announcements that you find in the cygwin-announce archives, e.g., see below. The important bit is to set Reply-To to cygwin-xfree and mention cygwin-xfree in the

Re: [ANNOUNCEMENT] cygwin/xfree86 setup.exe packages available for comments and testing

2002-04-19 Thread Christopher Faylor
On Fri, Apr 19, 2002 at 10:59:29PM -0400, Charles Wilson wrote: P.S. Chris, where'd upset go? the current version used to be in htdocs, but it's gone now. AND, the old version which lived in cinstall/temp, is still there -- and you said you were going to remove it.

Re: info: single install xfree86 + minimal cygwin?

2002-04-20 Thread Christopher Faylor
On Tue, Apr 09, 2002 at 09:53:34PM -0400, Christopher Faylor wrote: On Tue, Apr 09, 2002 at 06:34:29PM -0700, Ian Burrell wrote: Is the script for building setup.ini files from a directory hierarchy available anywhere? I want to setup a test install directory with the full hierarchy

Re: info: single install xfree86 + minimal cygwin?

2002-04-20 Thread Christopher Faylor
On Sat, Apr 20, 2002 at 08:01:12PM -0400, Harold Hunt wrote: Btw, the new version of 'upset' does the right thing with things like this. If you have a directory called 'XFree86-fonts-100dpi' it will no longer assume that 100dpi is part of the version string. It just uses the directory name as a

Re: xfree86 install makes wininit not working

2002-04-20 Thread Christopher Faylor
On Sun, Apr 21, 2002 at 12:59:26PM +1000, Robert Collins wrote: What's your prognosis on this? Is this a problem that is specific to Sylvain's machine or is this going to be a problem because Cygwin/XFree86 has over 4000 files in the font directories? I haven't come to a root cause yet.

Re: xfree86 install makes wininit not working

2002-04-21 Thread Christopher Faylor
On Sun, Apr 21, 2002 at 03:15:05PM -0400, Harold Hunt wrote: In related news: I think I'm going to hold off on making any wide-spread announcements about Cygwin/XFree86 being available via setup.exe. I'm not comfortable with the installation process causing several minute delays in starting the

Re: Error Installing imlib 1.9.14

2002-04-25 Thread Christopher Faylor
I've redirected your comment to the cygwin-xfree mailing list. cgf On Thu, Apr 25, 2002 at 04:48:13PM -0700, Peter None wrote: Thanks for your reply, Ive installed tiff-3.5.7.1 and tried to install imlib again, and now receive this error checking for jpeg_destroy_decompress in -ljpeg... yes

Re: cygjpeg6b.dll not found

2002-04-29 Thread Christopher Faylor
On Mon, Apr 29, 2002 at 12:26:10PM -0700, Lars Jensen wrote: Harold, Did you read more than the subject title of my posting? ;-) The message states that cygjpeg6b.dll is not in my \cygwin directory tree at all. Further I am using startxwin.bat to start wmaker! Where does the cygjpeg.dll come

Re: cygjpeg6b.dll not found

2002-04-29 Thread Christopher Faylor
On Mon, Apr 29, 2002 at 12:59:52PM -0700, Lars Jensen wrote: I guess a crucial not was missing. -Anyhow, it was only meant as a joke. I hope you didn't take any offense. Anyway, where does cygjpeg6b.dll come from? Wow. This thread is getting painful now. cgf

Re: Best place for WindowMaker, Openbox, etc.?

2002-04-30 Thread Christopher Faylor
On Tue, Apr 30, 2002 at 03:39:40PM +0100, Sam Edge wrote: Christopher Faylor wrote in [EMAIL PROTECTED] in gmane.os.cygwin.xfree on Tue, 30 Apr 2002 10:12:15 -0400: Other things that can use X such as rxvt and WindowMaker aren't part of XFree86 itself. In my opinion they should have their own

Re: lesstif mwm bug

2002-05-07 Thread Christopher Faylor
On Tue, May 07, 2002 at 09:21:52AM +0200, Hans Werner Strube wrote: From: Hans Werner Strube [EMAIL PROTECTED] The mwm from lesstif eats up 99 % of CPU time, both in the binary package and in a self-compiled version. I found that the select() calls in events.c do not wait but immediately

Re: lesstif mwm bug

2002-05-10 Thread Christopher Faylor
On Fri, May 10, 2002 at 02:41:03PM -0400, Harold L Hunt wrote: One other thing: please keep the lesstif cygwin packages (on sourceforge and the 'official' cygwin-XFree86 package) synchronised: i.e agree on same prefix etc. Maybe the sourceforge page should point to the official cygwin-XFree86

Re: lesstif mwm bug

2002-05-10 Thread Christopher Faylor
On Fri, May 10, 2002 at 03:45:05PM -0400, Harold L Hunt wrote: Chris, I don't think I ever gave an opinion on the /usr/bin vs. /usr/X11R6/bin. I'm going to dig up your message when I get home. I *know* that you did say to use /usr as the prefix. I might have said to use /usr rather than

Re: new user in cygwin - how?

2002-05-12 Thread Christopher Faylor
On Sun, May 12, 2002 at 04:54:26PM +0200, [EMAIL PROTECTED] wrote: Hi everybody, could anyone advise me, how can I add new user account in Cygwin ? if it`s possible ? or how can I set up Pine, accept another user name (different from windows user I`m log in) An obvious first step would be to

Re: Repackaging of WindowMaker and openbox needed ?

2002-05-13 Thread Christopher Faylor
On Mon, May 13, 2002 at 03:38:42PM -0400, Harold L Hunt wrote: Now it seems that there is a consensus that all X specific stuff should go in /usr/X11R6/bin, /usr/X11R6/lib, Well, if you call Chuck reversing his original position, and Harold agreeing with Chuck's new position, and Earnie smugly

Re: Some other window manager.

2002-05-13 Thread Christopher Faylor
Please confine these types of observations to cygwin-xfree. This is off-topic for cygwin-apps. Thank you. On Tue, May 14, 2002 at 03:49:17AM +0200, daffy wrote: I have tryed to compile some other great window manager and I can say that some of them look working well with cygwin/xfree. You wil

Re: Some other window manager

2002-05-13 Thread Christopher Faylor
On Tue, May 14, 2002 at 04:13:45AM +0200, daffy wrote: PS: my previous mail has been ejected because it contains html :)) And we care about this because...? cgf

Re: cygwin/xfree86 Unable to open X display after first success

2002-05-17 Thread Christopher Faylor
Wrong mailing list. Redirected. cgf On Fri, May 17, 2002 at 05:39:30PM -0400, Dennis Hui wrote: Hi, I'm having problem with X display after first successful launch of an X application. (Prior to this I did xhost +) When I remote logged in to a remote host, I first exported the

Re: ImageMagick-5.4.5-1 package ready for review/testing [take a look Chuck]

2002-05-28 Thread Christopher Faylor
On Tue, May 28, 2002 at 04:31:15AM -0700, Nicholas Wourms wrote: Another option would be to see if the ImageMagick people would host your port, since it does add signifcant improvements to the now 3 year old static port. Perhaps you could ask on the [EMAIL PROTECTED] mainling list I don't

Re: AmiWM Port

2002-06-02 Thread Christopher Faylor
Should lower the message size limit here? I think it's currently 100K. cgf On Sun, Jun 02, 2002 at 05:40:04PM -0400, Harold Hunt wrote: Don't send 57 KB (or whatever) attachments to the Cygwin/XFree86 mailing list.

Re: AmiWM Port

2002-06-02 Thread Christopher Faylor
without attachments that were larger than 50 KB. I therefore request that the message size limit be dropped to 50 KB. Thanks, Harold -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of Christopher Faylor Sent: Sunday, June 02, 2002 9:36 PM To: [EMAIL

Re: AmiWM Port

2002-06-02 Thread Christopher Faylor
On Sun, Jun 02, 2002 at 11:37:28PM -0400, Harold Hunt wrote: I looked back at the mailing list archives over the last 5 months or so and I see no legitimate messages without attachments that were larger than 50 KB. I therefore request that the message size limit be dropped to 50 KB. Oops.

Re: use cygwin/xfree in XDMCP under Windows 98

2002-06-06 Thread Christopher Faylor
Wrong mailing list. Redirected. On Thu, Jun 06, 2002 at 11:33:33AM +0200, EXT / EUREKA LE CUNFF Laurent wrote: Hello, I do not manage to make function CygWin/XFree in XDMCP under Windows 98. The Xfree window appears with the grayed bottom but that does not go further. I does not obtain the

Re: [ANNOUNCEMENT] xwinclip Test 04 (cygwin/xfree86 and Windows clipboard integration)

2002-06-11 Thread Christopher Faylor
On Tue, Jun 11, 2002 at 02:33:11PM -0400, Harold L Hunt wrote: Eric Peabody's messages are getting bounced by the list server. Apparently his mail server is changing the format of the message somehow. Anyway, his reply is below. And here's why: Sorry, a message part has an unacceptable MIME

Re: [ANNOUNCEMENT] Server Test 58

2002-06-12 Thread Christopher Faylor
On Thu, Jun 13, 2002 at 01:29:42AM -0400, Harold Hunt wrote: I just posted Test 58 to the server development page: http://xfree86.cygwin.com/devel/shadow/ Harold, Why not just install the latest server test packages in the normal cygwin place but mark it as test in setup.hint? Then you can

Re: broken lndir so cant build tree

2002-06-18 Thread Christopher Faylor
On Mon, Jun 17, 2002 at 06:25:49AM -0700, Nicholas Wourms wrote: I can confirm this with the the latest snapshot of cygwin on WindowsME. I'll run an strace later and see what the problem is. Was this ever posted? I never saw it, if so. cgf

Re: broken lndir so cant build tree

2002-06-18 Thread Christopher Faylor
that fixed it: 2002-06-09 Christopher Faylor [EMAIL PROTECTED] * fhandler_disk_file.cc (fhandler_disk_file::fstat_helper): Correctly set number of links for directory, if appropriate. This was fixing a thinko on my part, not Pierre's. This was fixed in CVS and subsequent

Troubles with 1.3.11? Try a snapshot.

2002-06-25 Thread Christopher Faylor
A couple of problems have been fixed in the recent cygwin snapshots, so please try one out and report success/failure to cygwin at cygwin dot com. I'll try to get a 1.3.12 out ASAP but I want to make sure that it fixes as many problems as possible first. Snapshot installation instructions: To

Re: Troubles with 1.3.11? Try a snapshot.

2002-06-25 Thread Christopher Faylor
On Tue, Jun 25, 2002 at 12:06:35PM -0400, Christopher Faylor wrote: A couple of problems have been fixed in the recent cygwin snapshots, so please try one out and report success/failure to cygwin at cygwin dot com. I'll try to get a 1.3.12 out ASAP but I want to make sure that it fixes as many

Your problems may be solved in the latest cygwin snapshot! Try it out!

2002-06-26 Thread Christopher Faylor
A few problems have been fixed in the recent cygwin snapshots, so please try one out and report success/failure to cygwin at cygwin dot com. I'll try to get a 1.3.12 out ASAP but I want to make sure that it fixes as many problems as possible first. Snapshot installation instructions: To

Re: x-windows

2002-06-27 Thread Christopher Faylor
On Thu, Jun 27, 2002 at 08:36:43AM -0500, Henning, Brian wrote: hello- I have installed the XFree86 package for cygwin. how to I start up X? i have tried 'xterm' 'startx' and i get nothing. I found an xterm binary but when I start it up i get an error about setting the display. thanks, brian

Re: Progress? Still debugging [cgf or someone from cygwin list please comment]

2002-06-27 Thread Christopher Faylor
On Thu, Jun 27, 2002 at 10:50:28AM -0400, Harold L Hunt wrote: [Please be careful to only reply to [EMAIL PROTECTED], I am only sending this to [EMAIL PROTECTED] so that the Cygwin folks know what is going on.] Non-xterm clients work fine. xterm does not work. The base problem here is that

Re: Progress? (again, please try a snapshot)

2002-06-27 Thread Christopher Faylor
On Thu, Jun 27, 2002 at 11:10:16AM -0400, Christopher Faylor wrote: On Thu, Jun 27, 2002 at 10:50:28AM -0400, Harold L Hunt wrote: [Please be careful to only reply to [EMAIL PROTECTED], I am only sending this to [EMAIL PROTECTED] so that the Cygwin folks know what is going on.] Non-xterm clients

Re: Progress? (again, please try a snapshot)

2002-06-27 Thread Christopher Faylor
On Thu, Jun 27, 2002 at 02:30:59PM -0400, Harold L Hunt wrote: Chris, I just (at 1430 EDT) tried: cygwin1-20020627.dll.bz2 The problem is still present. Just to be clear, this is just as simple as running the xserver and opening up an xterm, right? Unfortunately, that works fine for me under

Re: Progress? (again, please try a snapshot)

2002-06-27 Thread Christopher Faylor
On Thu, Jun 27, 2002 at 08:24:55PM -0400, Harold Hunt wrote: Chris, Does the log file contain any useful information, by any chance? None. Cygwin/XFree86 doesn't get an error, only xterm does. Do you think you could do a strace -ox:\somewhere\strace.out sh startxwin.sh , bzip2 strace.out,

Please try 2002-06-29 snapshot

2002-06-29 Thread Christopher Faylor
I just refreshed the 2002-06-29 snapshot a couple of minutes ago. Please try it. Thanks, cgf Snapshot installation instructions: To install a snapshot: 1) Download the latest cygwin-20020???.dll.bz2 file from http://cygwin.com/snapshots/ . 2) bunzip2 cygwin-20020???.dll.bz2 3)

Re: current cygwin includes xfree86?

2002-06-29 Thread Christopher Faylor
Redirecting to correct mailing list. On Sat, Jun 29, 2002 at 05:04:38PM -0400, hongxun lee wrote: I remember that formerly i have to setup Xfree86 after Cygwin installation is finished..Now i found that with the present version Cygwin, the dir 'cygwin/usr/X11R6' is already there, and 'x11R6/bin'

Re: cygwin1-20020701.dll from 1613 EDT still doesn't work with xterm

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 04:15:18PM -0400, Harold L Hunt wrote: Huh... the subject says it all. Same error as before: setuid failed: Permission denied You know, xterm is calling perror (setuid failed)... so perror must know the last errno... ah, I don't know what else to say... Since I can't

Re: Progress? (again, please try a snapshot)

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 04:41:42PM -0400, Harold L Hunt wrote: Chris, Hmm. If you do a: mount -f -X -b c:\cygwin\usr\X11R6\bin /usr/X11R6/bin does the problem go away, perchance? I would expect it to. Tried it, didn't work. See below. Any other syntax hints? Yeah, if you are going

Re: cygwin1-20020701.dll from 1613 EDT still doesn't work with xterm

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 05:16:00PM -0400, Harold L Hunt wrote: I actually took a look at the strace log and saw the problems with creating registry keys and I sent my email with that note before I read your email Yep, understood. I thought it was funny that I supposed something that actually

Re: xfree problem

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 09:03:30PM -0400, Harold L Hunt wrote: Chris, Pierre, Oh yeah, and now ssh seems to be challenged by the 2043 EDT cygwin1-20020701.dll snapshot. Output follows. (Remote host ip obscured as all 0's for privacy). Harold Administrator@NUCFAC13 ~ $ ssh [EMAIL PROTECTED]

Re: xfree problem

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 09:43:14PM -0400, Christopher Faylor wrote: On Mon, Jul 01, 2002 at 09:03:30PM -0400, Harold L Hunt wrote: Chris, Pierre, Oh yeah, and now ssh seems to be challenged by the 2043 EDT cygwin1-20020701.dll snapshot. Output follows. (Remote host ip obscured as all 0's

Re: Unable to use X session under cygwin 1.3.11-3 on NT 4.0 sp. 6

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 09:04:44PM -0400, Harold L Hunt wrote: No, it won't go into the documentation. It is a bug that will be fixed soon. Right, (as Harold knows) that's kinda the whole point of several threads in this mailing list. There is no way that we should have to tell anyone to stand

Re: xfree problem (new snapshot available)

2002-07-01 Thread Christopher Faylor
On Mon, Jul 01, 2002 at 11:28:42PM -0400, Harold Hunt wrote: Doh. system_printf != syscall_printf. I've checked in a fix and am rebuilding the snapshot. And, additionally, I put Pierre's patch in the wrong place in the code. Sigh. I had to interpret it because the formatting was GNU standard

Re: Local xterm x-client won't display/start

2002-07-03 Thread Christopher Faylor
On Wed, Jul 03, 2002 at 09:53:12PM -0500, Rex Kidwell wrote: Sorry if this is ends being the UID/GID, USER/HOME directory, or font problem. If it is the first two then the just released version of cygwin, 1.3.12-1, should fix it. cgf

Re: xfs (font server) crashes under cygwin. Anyone got it to work?

2002-07-05 Thread Christopher Faylor
On Sat, Jul 06, 2002 at 12:47:15PM +1000, Greg Lane wrote: On Fri, Jul 05, 2002 at 04:35:07PM +0200, Alexander Gottwald [EMAIL PROTECTED] wrote: Just a thought: How are the fonts mounted? Some programs don't like textmode files. G'day Alexander, I've only really got in to cygwin since

Re: xfs (font server) crashes under cygwin. Anyone got it to work?

2002-07-05 Thread Christopher Faylor
On Sat, Jul 06, 2002 at 01:17:13PM +1000, Greg Lane wrote: Then I have tried pointing my font path to it (with xset fp= ...) from a number of sources 1) remote machine running freebsd 2) from cygwin x-server on the same machine 3) from XWinPro on the machine Can you send what, exactly, you are

  1   2   3   4   5   6   >