Re: XWin.exe not running on Vista

2008-07-24 Thread felix.maurer
Hi Scott,

Thanks for your help.

Unfortunatly I didn't succeed with Admin privs. I want to use XWin
because I'm using wmaker inside of startxwin.bat.

Felix


--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/



Re: XWin.exe not running on Vista

2008-07-19 Thread Scott Fordin

Have you tried starting Cygwin using Vista's Run as Administrator
option? I've found that Cygwin and Vista don't get along at all
unless you run the bash shell explicitly as Administrator.

Also, your message indicates that you're starting XWin directly
from bash, rather than using the startx script. FWIW, I find it
more generally useful to use startx.

Hope this helps,

Scott

[EMAIL PROTECTED] wrote:

Hi all,

I have installed the following Cygwin version on a Vista WS ( AMD 64 X2
Dual Core Processor with 32-bits Operating System):

$ uname -a
CYGWIN_NT-6.0 nodename 1.5.25(0.156/4/2) 2008-06-12 19:34 i686 Cygwin


When I try to start XWin.exe, I get the following message:


[EMAIL PROTECTED] /usr/X11R6/bin
$ XWin -screen 0 1280 1024 -logverbose 10
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 6.8.99.901-4

Contact: cygwin-xfree@cygwin.com

XWin was started with the following command line:

XWin -screen 0 1280 1024 -logverbose 10

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
winValidateArgs - Returning.
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more
information
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 0007
winScreenInit - dwWidth: 1280 dwHeight: 1024
winSetEngine - Using Shadow DirectDraw NonLocking
winAdjustVideoModeShadowDDNL - Using Windows display depth of 32 bits
per pixel
winCreateBoundingWindowWindowed - User w: 1280 h: 1024
winCreateBoundingWindowWindowed - Current w: 1280 h: 1024
winAdjustForAutoHide - Original WorkArea: 0 0 1170 1920
winAdjustForAutoHide - Adjusted WorkArea: 0 0 1170 1920
winCreateBoundingWindowWindowed - WindowClient w 1280 h 1024 r 1280 l 0
b 1024 t
 0
winWindowProc - WM_ACTIVATEAPP
winCreateBoundingWindowWindowed -  Returning
winCreatePrimarySurfaceShadowDDNL - Creating primary surface
winCreatePrimarySurfaceShadowDDNL - Created primary surface
winCreatePrimarySurfaceShadowDDNL - Attached clipper to primary surface
winAllocateFBShadowDDNL - lPitch: 5120
winAllocateFBShadowDDNL - Created shadow pitch: 5120
winAllocateFBShadowDDNL - Created shadow stride: 1280
winFinishScreenInitFB - Masks: 00ff ff00 00ff
winInitVisualsShadowDDNL - Masks 00ff ff00 00ff BPRGB 8 d 24
bpp 32
winRandRInit ()
winCreateDefColormap - Deferring to fbCreateDefColormap ()
winFinishScreenInitFB - returning
winScreenInit - returning
InitOutput - Returning.
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack
of shar
ed memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: 100C (100c)
(--) Using preset keyboard for French (Switzerland) (100c), type 4
Rules = xorg Model = pc105 Layout = fr_CH Variant = (null)
Options = (n
ull)
The XKEYBOARD keymap compiler (xkbcomp) reports:

Error:Can't find file pc/fr_CH for symbols include
  Exiting
  Abandoning symbols file default

Errors from xkbcomp are not fatal to the X server
(--) 3 mouse buttons found


Then XWin.exe stops working with the following message:


roblem signature:
  Problem Event Name:   APPCRASH
  Application Name: XWin.exe
  Application Version:  0.0.0.0
  Application Timestamp:43603add
  Fault Module Name:ntdll.dll
  Fault Module Version: 6.0.6001.18000
  Fault Module Timestamp:   4791a7a6
  Exception Code:   c710
  Exception Offset: 00088e7a
  OS Version:   6.0.6001.2.1.0.256.4
  Locale ID:2055
  Additional Information 1: e0b3
  Additional Information 2: 3381a2bb347d2a7fd93caef5716d692f
  Additional Information 3: 3301
  Additional Information 4: 18b93e7bb56d45169c16a0a55fcb86c0

Read our privacy statement:
  http://go.microsoft.com/fwlink/?linkid=50163clcid=0x0409


Has anone an idea what it could be and what can I do?

Many thanks for your help.


Felix Maurer

Die Schweizerische Post 
Informationstechnologie 
IT244 Softwareintegration I
Webergutstrasse 12 
CH-3030 Bern


Tel:  +41 (0)58 338 98 49 
Fax: +41 (0)31 667 61 13 
Email: mailto:[EMAIL PROTECTED]




--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/





--
Unsubscribe info:  http://cygwin.com/ml/#unsubscribe-simple
Problem reports:   http://cygwin.com/problems.html
Documentation: http://x.cygwin.com/docs/
FAQ:   http://x.cygwin.com/docs/faq/