RE: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-17 Thread Karicheri, Muralidharan
snip Can you post your latest proposal for the s_bus op? I propose a few changes: the name of the struct should be something like v4l2_bus_settings, the master/slave bit should be renamed to something like 'host_is_master', and we should have two widths: subdev_width and host_width. That way

Re: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-17 Thread Hans Verkuil
On Wednesday 17 June 2009 17:02:01 Karicheri, Muralidharan wrote: snip Can you post your latest proposal for the s_bus op? I propose a few changes: the name of the struct should be something like v4l2_bus_settings, the master/slave bit should be renamed to something like

RE: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-16 Thread Karicheri, Muralidharan
Hans, Thanks for the response. snip Polarities have to be set for each side, that's correct. The other parameters are common for both. Although I can think of scenarios where the bus width can differ between host and subdev (e.g. subdev sends data on 8 pins and the host captures on 10 with the

RE: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-15 Thread Karicheri, Muralidharan
+       /* set the default image parameters in the device */ +       ret = vpfe_config_image_format(vpfe_dev, +                               vpfe_standards[vpfe_dev- std_index].std_id); +       if (ret) +               goto unlock_out; Why you check ret value and go to label below? Probably

RE: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-15 Thread Karicheri, Muralidharan
Hans, I am not clear about some of your comments. Please see below with a [MK] prefix. +static int debug; +static u32 numbuffers = 3; +static u32 bufsize = (720 * 576 * 2); + +module_param(numbuffers, uint, S_IRUGO); +module_param(bufsize, uint, S_IRUGO); +module_param(debug, int, 0644);

Re: [PATCH 1/10 - v2] vpfe capture bridge driver for DM355 and DM6446

2009-06-15 Thread Hans Verkuil
On Monday 15 June 2009 23:47:07 Karicheri, Muralidharan wrote: Hans, I am not clear about some of your comments. Please see below with a [MK] prefix. snip + /* set if client specific interface param is available */ + if (subdev-pdata) { + /* each client will have different