[PATCH 05/16] i2c: i2c-davinci: Drop class based scanning to improve bootup time

2014-07-10 Thread Wolfram Sang
This driver has been flagged to drop class based instantiation. The removal
improves boot-up time and is unneeded for embedded controllers. Users have been
warned to switch for some time now, so we can actually do the removal. Keep the
DEPRECATED flag, so the core can inform users that the behaviour finally
changed now. After another transition period, this flag can go, too.

Signed-off-by: Wolfram Sang w...@the-dreams.de
---
 drivers/i2c/busses/i2c-davinci.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/i2c/busses/i2c-davinci.c b/drivers/i2c/busses/i2c-davinci.c
index 389bc68c55ad..4d9614719128 100644
--- a/drivers/i2c/busses/i2c-davinci.c
+++ b/drivers/i2c/busses/i2c-davinci.c
@@ -712,7 +712,7 @@ static int davinci_i2c_probe(struct platform_device *pdev)
adap = dev-adapter;
i2c_set_adapdata(adap, dev);
adap-owner = THIS_MODULE;
-   adap-class = I2C_CLASS_HWMON | I2C_CLASS_DEPRECATED;
+   adap-class = I2C_CLASS_DEPRECATED;
strlcpy(adap-name, DaVinci I2C adapter, sizeof(adap-name));
adap-algo = i2c_davinci_algo;
adap-dev.parent = pdev-dev;
-- 
2.0.0

___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source


[PATCH 00/16] i2c: drop class based instantiaion for selected drivers

2014-07-10 Thread Wolfram Sang
Some drivers were flagged to remove class based instantiation soon to improve
boot-up time. Originally, I was planning for a longer deprecation time so users
could switch over to some other kind of instantiation. However, the demand for
the speed up is high enough and class based instantiation is used rarely, so
the removal takes place now. To make up for the deprecation time, another
warning is added to the i2c core pointing out that the behaviour has now
changed:

+   /* Warn that the adapter lost class based instantiation */
+   if (adapter-class == I2C_CLASS_DEPRECATED) {
+   dev_dbg(adapter-dev,
+   This adapter dropped support for I2C classes and 
+   won't auto-detect %s devices anymore. If you need it, 
check 
+   'Documentation/i2c/instantiating-devices' for 
alternatives.\n,
+   driver-driver.name);
+   return 0;
+   }

A branch can be found here (with two other cleanups - driver removals):
git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git i2c/deprecate_stuff

I hope this meets all the needs. Please comment, ack, test...

Thanks,

   Wolfram


Wolfram Sang (16):
  i2c: add debug info when class instantiation was dropped
  i2c: i2c-at91: Drop class based scanning to improve bootup time
  i2c: i2c-bcm2835: Drop class based scanning to improve bootup time
  i2c: i2c-bfin-twi: Drop class based scanning to improve bootup time
  i2c: i2c-davinci: Drop class based scanning to improve bootup time
  i2c: i2c-designware-platdrv: Drop class based scanning to improve
bootup time
  i2c: i2c-mv64xxx: Drop class based scanning to improve bootup time
  i2c: i2c-nomadik: Drop class based scanning to improve bootup time
  i2c: i2c-ocores: Drop class based scanning to improve bootup time
  i2c: i2c-omap: Drop class based scanning to improve bootup time
  i2c: i2c-rcar: Drop class based scanning to improve bootup time
  i2c: i2c-s3c2410: Drop class based scanning to improve bootup time
  i2c: i2c-sirf: Drop class based scanning to improve bootup time
  i2c: i2c-stu300: Drop class based scanning to improve bootup time
  i2c: i2c-tegra: Drop class based scanning to improve bootup time
  i2c: i2c-xiic: Drop class based scanning to improve bootup time

 drivers/i2c/busses/i2c-at91.c   |  2 +-
 drivers/i2c/busses/i2c-bcm2835.c|  2 +-
 drivers/i2c/busses/i2c-bfin-twi.c   |  2 +-
 drivers/i2c/busses/i2c-davinci.c|  2 +-
 drivers/i2c/busses/i2c-designware-platdrv.c |  2 +-
 drivers/i2c/busses/i2c-mv64xxx.c|  2 +-
 drivers/i2c/busses/i2c-nomadik.c|  8 
 drivers/i2c/busses/i2c-ocores.c | 12 ++--
 drivers/i2c/busses/i2c-omap.c   |  2 +-
 drivers/i2c/busses/i2c-rcar.c   | 14 +++---
 drivers/i2c/busses/i2c-s3c2410.c|  8 
 drivers/i2c/busses/i2c-sirf.c   |  2 +-
 drivers/i2c/busses/i2c-stu300.c |  2 +-
 drivers/i2c/busses/i2c-tegra.c  |  2 +-
 drivers/i2c/busses/i2c-xiic.c   | 12 ++--
 drivers/i2c/i2c-core.c  | 10 ++
 16 files changed, 47 insertions(+), 37 deletions(-)

-- 
2.0.0

___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source


Re: [PATCH 1/2] net: davinci_mdio: reuse for keystone2 arch

2014-07-10 Thread Grygorii Strashko
Hi David,

On 07/10/2014 02:52 AM, David Miller wrote:
 From: Grygorii Strashko grygorii.stras...@ti.com
 Date: Wed, 9 Jul 2014 16:10:50 +0300
 
   Required properties:
 -- compatible: Should be ti,davinci_mdio
 +- compatible: Should be ti,davinci_mdio or 
 ti,keystone-mdio
 
 Why the inconsistency in naming schemes?  I don't see any reason
 to be different wrt. _ vs. - in the name string.
 

Hm. Looks like the common way is to use -, but I can rename it if you insist.

Regards,
-grygorii
___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source


Re: [PATCH 00/16] i2c: drop class based instantiaion for selected drivers

2014-07-10 Thread Wolfram Sang

  +   /* Warn that the adapter lost class based instantiation */
  +   if (adapter-class == I2C_CLASS_DEPRECATED) {
  +   dev_dbg(adapter-dev,
  +   This adapter dropped support for I2C classes and 
  +   won't auto-detect %s devices anymore. If you need it, 
  check 
  +   'Documentation/i2c/instantiating-devices' for 
  alternatives.\n,
 
 It's usually a bad idea to split kernel messages across source lines

Yes, usually. Not for this message, though, it's specific. The lines
would have been quite long.

 You could at least do the split at the sentence boundary.

OK, this would have been a compromise.



signature.asc
Description: Digital signature
___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source


Re: [PATCH 1/2] net: davinci_mdio: reuse for keystone2 arch

2014-07-10 Thread David Miller
From: Grygorii Strashko grygorii.stras...@ti.com
Date: Thu, 10 Jul 2014 15:58:31 +0300

 Hi David,
 
 On 07/10/2014 02:52 AM, David Miller wrote:
 From: Grygorii Strashko grygorii.stras...@ti.com
 Date: Wed, 9 Jul 2014 16:10:50 +0300
 
   Required properties:
 -- compatible   : Should be ti,davinci_mdio
 +- compatible   : Should be ti,davinci_mdio or 
 ti,keystone-mdio
 
 Why the inconsistency in naming schemes?  I don't see any reason
 to be different wrt. _ vs. - in the name string.
 
 
 Hm. Looks like the common way is to use -, but I can rename it if you 
 insist.

I'm just saying, is there a strong reason to be inconsistent?
___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source


Re: [PATCH 2/2] net: davinci_mdio: allow to create phys from dt

2014-07-10 Thread Mugunthan V N
On Wednesday 09 July 2014 06:40 PM, Grygorii Strashko wrote:
 This patch allows to create PHYs from DT in case
 if they are explicitly defined. The of_mdiobus_register() is
 used for such purposes.

 For backward compatibility, call  of_mdiobus_register() only in case
 if at least one PHY's child is defined in DT, otherwise rollback to
 mdiobus_register().

 Signed-off-by: Grygorii Strashko grygorii.stras...@ti.com

Except Santhosh comment patch looks good to me.

Acked-by: Mugunthan V N mugunthan...@ti.com

Regards
Mugunthan V N
___
Davinci-linux-open-source mailing list
Davinci-linux-open-source@linux.davincidsp.com
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source