Re: [PATCH 0/10]: First DCCP batch for 2.6.23

2007-06-16 Thread David Miller
From: Arnaldo Carvalho de Melo [EMAIL PROTECTED] Date: Fri, 15 Jun 2007 23:52:46 -0300 Hi David, Please consider pulling from: master.kernel.org:/pub/scm/linux/kernel/git/acme/net-2.6.23 All looks great, pulled, thanks a lot Arnaldo. - To unsubscribe from this list: send the line

Re: [PATCH 1/3]: Inline for time delta

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/11/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Ian McDonald: | --- a/net/dccp/dccp.h | +++ b/net/dccp/dccp.h | @@ -421,6 +421,11 @@ static inline suseconds_t timeval_delta( | return secs * USEC_PER_SEC + usecs; | } | | +static inline s64 ktime_delta(ktime_t later,

Re: [PATCH 1/6]: Avoid accumulation of large send credit

2007-06-16 Thread Gerrit Renker
| Agree with Gerrit's comments in patchset description that there is | still discussion around this. Still doing something is better than | doing nothing. Also agree with what you are saying. This is really why I would like to get the experimental test tree for DCCP/CCID3 started soon. With

Re: [PATCH 1/3]: Inline for time delta

2007-06-16 Thread Gerrit Renker
Quoting Arnaldo Carvalho de Melo: | The name was chosen for consistency with timeval_delta(), which is the current | function for microsecond time differences in net/dccp/dccp.h. | | I'm going to rename ktime_delta() to ktime_us_delta(), as it receives | two ktime_t values, but returns a

Re: [PATCH 0/10] First DCCP batch for 2.6.23

2007-06-16 Thread Gerrit Renker
Thanks for the update. Just for information - I will be updating all my patches based on this set of 10, as I expect them to be in David Miller's tree soon. If people would like me to resubmit the updates, please give me a shout as I will otherwise prepare these updates for the test tree.

Re: [PATCH 1/3]: Inline for time delta

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/16/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Arnaldo Carvalho de Melo: | The name was chosen for consistency with timeval_delta(), which is the current | function for microsecond time differences in net/dccp/dccp.h. | | I'm going to rename ktime_delta() to ktime_us_delta(),

Re: [PATCH 0/10] First DCCP batch for 2.6.23

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/16/07, Gerrit Renker [EMAIL PROTECTED] wrote: Thanks for the update. Just for information - I will be updating all my patches based on this set of 10, as I expect them to be in David Miller's tree soon. If people would like me to resubmit the updates, please give me a shout as I will

Re: [PATCH 1/3]: Inline for time delta

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/16/07, Arnaldo Carvalho de Melo [EMAIL PROTECTED] wrote: On 6/16/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Arnaldo Carvalho de Melo: | The name was chosen for consistency with timeval_delta(), which is the current | function for microsecond time differences in

Re: [PATCH 1/3]: Inline for time delta

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/16/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Arnaldo Carvalho de Melo: | I am going to change that in my tree as well, since I am busy updating with regard | to most recent changes anyway. | | I just checked with Thomas Gleixner, the ktime_t guy and he is ok with | adding

Re: [PATCH 3/3]: Update computation of X to use newer timeofday interface

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/11/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Ian McDonald: | This looks OK but... | -static void ccid3_hc_tx_update_x(struct sock *sk, struct timeval *now) | +static void ccid3_hc_tx_update_x(struct sock *sk, ktime_t *stamp) | | I don't see callers updated. Is this what you

Re: [PATCH 3/3]: Update computation of X to use newer timeofday interface

2007-06-16 Thread Gerrit Renker
Quoting Arnaldo Carvalho de Melo: | We'll have to avoid it, I'm looking at how to do it... | | | I'm just stuck with t_ld not having being converted to ktime_t, so | I'll fix this up by... | | -                       hctx-ccid3hctx_t_ld = now; | +                      

Re: [PATCH 3/3]: Update computation of X to use newer timeofday interface

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/16/07, Gerrit Renker [EMAIL PROTECTED] wrote: Quoting Arnaldo Carvalho de Melo: | We'll have to avoid it, I'm looking at how to do it... | | | I'm just stuck with t_ld not having being converted to ktime_t, so | I'll fix this up by... | | - hctx-ccid3hctx_t_ld = now; | +

Re: [PATCH 3/3]: Update computation of X to use newer timeofday interface

2007-06-16 Thread Gerrit Renker
| OK, but doing the simple ktime_to_timeval above I was able to merge | something that moves us further, its clear and self contained, so I | loved it and merged. Oh, sorry - I think I misunderstood you. Yes, of course, I was talking experimental tree and didn't exactly know what you were

Re: [PATCH 1/5]: Shorten statement for updating p

2007-06-16 Thread Arnaldo Carvalho de Melo
On 6/11/07, Gerrit Renker [EMAIL PROTECTED] wrote: [CCID 3]: Shorten statement for updating p This shortens the statement for updating the loss event rate p when a feedback packet is received. Signed-off-by: Gerrit Renker [EMAIL PROTECTED] --- net/dccp/ccids/ccid3.c |7 ++- 1 file

Re: [PATCH 3/6]: Ignore trivial amounts of elapsed time

2007-06-16 Thread Ian McDonald
On 6/10/07, Gerrit Renker [EMAIL PROTECTED] wrote: [CCID3]: Ignore trivial amounts of elapsed time This patch fixes a previously undiscovered bug: * the receive timestamp is taken when the skb enters the CCID3 module; * RFC 4342 requires to send an Elapsed Time estimate to the sender; * the

Re: [PATCH 4/6]: Simplify interface of dccp_sample_rtt

2007-06-16 Thread Ian McDonald
On 6/10/07, Gerrit Renker [EMAIL PROTECTED] wrote: [DCCP]: Simplify interface of dccp_sample_rtt Don't quite understand this yet but that's just me needing to look at longer I think!! +extern u32dccp_sample_rtt(struct sock *sk, long candidate); What's candidate? Do you mean delta

Re: [PATCH 5/6]: Add history query/lookup function

2007-06-16 Thread Ian McDonald
On 6/12/07, Gerrit Renker [EMAIL PROTECTED] wrote: [TFRC]: Add history query/lookup function This completes the basic TX history functions that are implemented by this patch set, by adding a lock-protected lookup function to look up the send time of a particular sent packet. I notice there is

Re: [PATCH 6/6]: Update TX RTT sampling to use ktime_t

2007-06-16 Thread Ian McDonald
On 6/12/07, Gerrit Renker [EMAIL PROTECTED] wrote: [CCID3]: Update TX RTT sampling to use ktime_t Using the new TX history interface (which looks up send time in ktime_t units), the CCID3 sender side is now upgraded to use the ktime_t interface for sampling RTT values. Signed-off-by: Gerrit