Re: [PATCH 5/6]: Add history query/lookup function

2007-06-17 Thread Gerrit Renker
| I notice there is other functionality here also... | | +/** | + * tfrc_tx_hist_when - Retrieve send time of past packet | + * If successful, it garbage-collects older (irrelevant) entries and returns 1. | + */ | +int tfrc_tx_hist_when(ktime_t *stamp, struct tfrc_tx_hist_head

Re: [PATCH 5/6]: Add history query/lookup function

2007-06-17 Thread Gerrit Renker
Quoting Ian McDonald: | And I see why from the following patch now. Perhaps you could add | something to commit description to elude to this. Ah coming through to this one - I just answered the other email:) Yes, I have changed the commit message as follows: Note: When the lookup is

Re: [PATCH 3/6]: Migrate to new naming scheme, using macro to declare cache

2007-06-17 Thread Gerrit Renker
Quoting Ian McDonald: | On 6/17/07, Gerrit Renker [EMAIL PROTECTED] wrote: | Ian McDonald wrote: | | [TFRC]: Migrate to new naming scheme, using macro to declare cache | | | | I agree totally with the intent. I reworked li_hist as well but | | Arnaldo decided to do in a better way

Re: [PATCH 3/6]: Ignore trivial amounts of elapsed time

2007-06-17 Thread Gerrit Renker
Quoting Ian McDonald: | On 6/10/07, Gerrit Renker [EMAIL PROTECTED] wrote: | [CCID3]: Ignore trivial amounts of elapsed time | | This patch fixes a previously undiscovered bug: | |* the receive timestamp is taken when the skb enters the CCID3 module; |* RFC 4342 requires to send

[PATCH 0/1]: Impedance matching

2007-06-17 Thread Gerrit Renker
As promised, I went through my patch set and isolated the sections which overlap with recent changes made to the TFRC/CCID3 code. With this patch, all the new functionality becomes available. I have cross-checked it this against the old variant and it works fine. - To unsubscribe from this list:

[PATCH 1/9]: Ringbuffer to track loss interval history

2007-06-17 Thread Gerrit Renker
[TFRC]: Ringbuffer to track loss interval history A ringbuffer-based implementation of loss interval history is easier to maintain, allocate, and update. This patch provides the basic data structures for a ringbuffer-based loss interval history, from which the principles of the implementation

[PATCH 3/9]: Cache allocation of entries

2007-06-17 Thread Gerrit Renker
[TFRC]: Cache allocation of entries This updates and simplifies the allocation of kmem_cache entries with regard to the new structure. Main changes: 1. On-demand allocation: no memory consumption when running over loss-free links. 2. Since cache allocation is local to the module, the cache

[PATCH 4/9]: Recompute average loss interval

2007-06-17 Thread Gerrit Renker
[TFRC]: Recompute average loss interval This patch: * adds routines for recomputing I_mean/p as required by TFRC; * places the average, I_mean, into the loss_hist structure; * supports continued detection of new loss intervals. The second point is in keeping with the objective: loss history

[PATCH 5/9]: Insert and Update routines for the Loss Interval Database

2007-06-17 Thread Gerrit Renker
[TFRC]: Insert and Update routines for the Loss Interval Database This provides an `insert' function for the Loss Interval database. It only inserts when a loss is new, i.e. either * no loss record has been allocated before (uninitialised) or * the most recent loss is in a different RTT than

[PATCH 6/9]: Integrate RX history loss detection with loss interval update

2007-06-17 Thread Gerrit Renker
[TFRC]: Integrate RX history loss detection with loss interval update This adds the missing link between * TFRC loss detection as provided by the RX history code and * Loss Intervals update whenever a new loss is detected. Handling is conform to the TFRC semantics and conveniently transparent

[PATCH 7/9]: Let calling module compute First Loss Interval; convert to ktime_t

2007-06-17 Thread Gerrit Renker
[TFRC]: Let calling module compute First Loss Interval; convert to ktime_t TFRC [RFC 3448] requires a synthetic value of the first loss interval length. Since computing this value requires access to the internals of the calling module (parameters s, RTT, and X_recv), it is better to let the

[PATCH 8/9]: Fix and simplify header includes

2007-06-17 Thread Gerrit Renker
[TFRC]: Fix and simplify header includes This updates the header-include structure so that any module wishing to use the service of the tfrc_lib module needs only include tfrc.h and has access to all declarations it needs. Signed-off-by: Gerrit Renker [EMAIL PROTECTED] ---

[PATCH 9/9]: Interface CCID3 code with newer TFRC LI database

2007-06-17 Thread Gerrit Renker
[CCID]: Interface CCID3 code with newer TFRC LI database This hooks up the TFRC Loss Interval database with CCID 3 packet reception. Signed-off-by: Gerrit Renker [EMAIL PROTECTED] --- net/dccp/ccids/ccid3.c | 26 +- 1 file changed, 17 insertions(+), 9 deletions(-) ---

[PATCH 0/4]: DCCP ktime_t initial work

2007-06-17 Thread Arnaldo Carvalho de Melo
Hi David, Please consider pulling from: master.kernel.org:/pub/scm/linux/kernel/git/acme/net-2.6.23 I briefed Thomas Gleixner about the new ktime_us_delta and ktime_add_us functions and he is OK with having them added to ktime.h. More work on this are going on Gerrit

[PATCH 1/4] [KTIME]: Introduce ktime_us_delta

2007-06-17 Thread Arnaldo Carvalho de Melo
This provides a reusable time difference function which returns the difference in microseconds, as often used in the DCCP code. Commiter note: renamed ktime_delta to ktime_us_delta and put it in ktime.h. Signed-off-by: Gerrit Renker [EMAIL PROTECTED] Signed-off-by: Arnaldo Carvalho de Melo

[PATCH 2/4] [KTIME]: Introduce ktime_add_us

2007-06-17 Thread Arnaldo Carvalho de Melo
Signed-off-by: Arnaldo Carvalho de Melo [EMAIL PROTECTED] --- include/linux/ktime.h |5 + 1 files changed, 5 insertions(+), 0 deletions(-) diff --git a/include/linux/ktime.h b/include/linux/ktime.h index a208f9f..9800bae 100644 --- a/include/linux/ktime.h +++ b/include/linux/ktime.h @@

[PATCH 3/4] [CCID3]: Sending time: update to ktime_t

2007-06-17 Thread Arnaldo Carvalho de Melo
This updates the computation of t_nom and t_last_win_count to use the newer gettimeofday interface. Committer note: used ktime_to_timeval to set the 'now' variable to t_ld in ccid3hctx_no_feedback_timer Signed-off-by: Gerrit Renker [EMAIL PROTECTED] Signed-off-by: Arnaldo

[PATCH 4/4] [CCID3]: Fix a bug in the send time processing

2007-06-17 Thread Arnaldo Carvalho de Melo
ccid3_hc_tx_send_packet currently returns 0 when the time difference between current time and t_nom is less than 1000 microseconds. In this case the packet is sent immediately; but, unlike other packets that can be emitted on first attempt, it will not have its window counter updated and its

Re: [PATCH 0/4]: DCCP ktime_t initial work

2007-06-17 Thread David Miller
From: Arnaldo Carvalho de Melo [EMAIL PROTECTED] Date: Sun, 17 Jun 2007 23:05:40 -0300 Please consider pulling from: master.kernel.org:/pub/scm/linux/kernel/git/acme/net-2.6.23 I briefed Thomas Gleixner about the new ktime_us_delta and ktime_add_us functions and he is OK with