Re: [deal.II] Installation didn't give any errors but when I tried make test, it failed all tests

2017-08-12 Thread Japan Patel
Hi Dr. Bangerth, Thank you for your reply. You are right. When I checked for compilers I have two versions of each compilers. I don't know why that isI do have petsc installed and I think that might have used different compilers. Is there a way to tell dealii to choose compilers? I have the

Re: [deal.II] Line Integral of function

2017-08-12 Thread Wolfgang Bangerth
Rajat, The geometry is a cubical box [0 1] X [0 1] X [0 1] with a uniform rectilinear mesh in the domain. I have obtained the scalar solution vector u in the domain. I need to find the line integral of the solution along the boundary. For example: lets say I want to integrate the solution

Re: [deal.II] Installation didn't give any errors but when I tried make test, it failed all tests

2017-08-12 Thread Wolfgang Bangerth
On 08/12/2017 05:21 PM, drgeoffschr...@gmail.com wrote: I'm wondering if I could tag onto this message. I'm having a similar problem. Installed with no problems. However, when I run the tests, they all fail with the error: symbol lookup error: /usr/lib/libumfpack.so.3.1.0: undefined symbol:

Re: [deal.II] Installation didn't give any errors but when I tried make test, it failed all tests

2017-08-12 Thread drgeoffschrank
I'm wondering if I could tag onto this message. I'm having a similar problem. Installed with no problems. However, when I run the tests, they all fail with the error: symbol lookup error: /usr/lib/libumfpack.so.3.1.0: undefined symbol: amd_realloc To Wolfgang's question... I have both gcc and

Re: [deal.II] Installation didn't give any errors but when I tried make test, it failed all tests

2017-08-12 Thread Wolfgang Bangerth
On 08/11/2017 06:42 PM, japa...@gmail.com wrote: step.debug: RUN failed. Output: ./step.debug: /home/japan/anaconda3/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./step.debug) ./step.debug: /home/japan/anaconda3/lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found