Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-12 Thread yuesu jin
Hi Dr.Bangerth, I know where is the problem. My bash is in the anaconda environment (with (base) in front of the command line.), so all the library links are referenced to anaconda library. I modified the bashrc scripts then all goes well!! Thanks a lot! I have learned a lesson about linux

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-12 Thread Wolfgang Bangerth
On 8/12/19 11:01 AM, yuesu jin wrote: > >    Installation completed, what a stupid mistake I made! Appreciate for > your support! > All the problem should be the symbol mkl_blas_dsyrk. It may be caused by > my anaconda package manager because the message said: > /*/step-5_sec: symbol lookup

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-12 Thread yuesu jin
Hi Dr.Bangerth, Installation completed, what a stupid mistake I made! Appreciate for your support! All the problem should be the symbol mkl_blas_dsyrk. It may be caused by my anaconda package manager because the message said: */step-5_sec: symbol lookup error:

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-12 Thread Wolfgang Bangerth
On 8/11/19 9:08 PM, yuesu jin wrote: > AH... I understand,/*cmake -DCMAKE_INSTALL_PREFIX=[Directory you want to > install] [Directory you build the program]*/ No, the second [...] block is the directory where the sources are located, not where you build the program. The directory where you

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread yuesu jin
AH... I understand,* cmake -DCMAKE_INSTALL_PREFIX=[Directory you want to install] [Directory you build the program]* I have installed it again in a new folder, the folder now is 3.6GB, which means something has been installed in that. But the message is still there:

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread yuesu jin
Hi Daniel, Thank you for your reply. I misunderstood build and install. I thought after I setup the build folder and make install, the program should be compiled in that build folder, because I installed the 9.0.1 version just run the command as those in README file. Now, I first input *cmake

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread Daniel Arndt
Yuesu, Hello Daniel, > Thank you very much! I make a new folder to save the compile file for > cmake, and I used the command > *cmake -DCMAKE_INSTALL_PREFIX=${HOME}**/deal.II > home/yjin6/Deal.II/dealii-9.0.1* (substituted with my directory), > but cmake gave error warning. I substitute it

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread yuesu jin
Hello Daniel, Thank you very much! I make a new folder to save the compile file for cmake, and I used the command *cmake -DCMAKE_INSTALL_PREFIX=${HOME}**/deal.II home/yjin6/Deal.II/dealii-9.0.1* (substituted with my directory), but cmake gave error warning. I substitute it with *cmake

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread Daniel Arndt
> Thank you for your timely reply! > I changed the installation direction according to the README document and > redirected it to the deal.ii-9.0.1 source code. > It seems that you still set the installation directory to a non-existent path. If you want to install in your home directory

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread Wolfgang Bangerth
On 8/11/19 3:49 PM, yuesu jin wrote: > > CMake Error at cmake/scripts/cmake_install.cmake:36 (file): >   file INSTALL cannot set permissions on >   "/path/to/install/dir/share/deal.II/scripts/normalize.pl > " What you call cmake initially, you need to replace the string

Re: [deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-11 Thread yuesu jin
Hi,all I re-installed Deal.II-9.1.1, the message is listed below: *** Install the project... -- Install configuration: "DebugRelease" CMake Error at cmake/scripts/cmake_install.cmake:36 (file): file INSTALL cannot

[deal.II] undefined symbol: mkl_blas_dsyrk

2019-08-10 Thread yuesu jin
Hi, all, I am a novice of deal.II, I begun to learn deal.II since version 9.0.1, after I updated it from 9.0.1 to 9.1.1, I found the executable file cannot run, the message is: ./step-5_sec: symbol lookup error: /home/yjin6/anaconda3/lib/libmkl_intel_lp64.so: undefined symbol: