Bug#856635: apt-cacher-ng: amplified remote disk space exhaustion on filesystems that support fallocate

2017-03-02 Thread Helmut Grohne
Package: apt-cacher-ng Version: 0.4.1 Severity: important Tags: security Summary --- I accidentally stumbled into what I believe to be a pretty bad denial of service vulnerability in apt-cacher-ng. If an attacker is able to issue http requests to apt-cacher-ng and apt-cacher-ng stores its

Bug#855273: diffoscope: still fails to clean up after SIGTERM

2017-03-02 Thread Chris Lamb
Hi, > diffoscope: still fails to clean up after SIGTERM Can we reproduce this outside of Jenkins? Would really love a testcase so I can my teeth into this... Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#856592: Multiple security issues

2017-03-02 Thread Mattia Rizzolo
On Fri, Mar 03, 2017 at 06:43:03AM +0100, Salvatore Bonaccorso wrote: > in the above list. aheam, what a list. Anyway, you (Moritz) opened this bug as RC, but is it fine to downgrade to important if I deem the issues not grave enough to be RC? They are all crashes, with maliciously crafted PDFs…

Bug#855906: golang-codegangsta-cli: FTBFS: FAIL: TestCommandYamlFileTestDefaultValueFileWins (0.00s) helpers_test.go:10: Expected 15 (type int) - Got 7 (type int)

2017-03-02 Thread Vincent Bernat
❦ 23 février 2017 16:57 +0800, Chris Lamb  : > dh_auto_test: go test -v -p 1 github.com/codegangsta/cli > github.com/codegangsta/cli/altsrc returned exit code 1 > debian/rules:4: recipe for target 'build' failed > make: *** [build] Error 1 > dpkg-buildpackage: error:

Bug#856386: Rename the package to android-sdk-helper

2017-03-02 Thread 殷啟聰
Control: retitle -1 ITP: android-sdk-helper -- Helper tools for building Android apps using Debian's Android SDK Control: owner -1 !

Bug#856405: unblock: libdebian-installer/0.109 and others

2017-03-02 Thread Bastian Blank
Control: submitter ! Moin I'm taking over this matter as maintainer of this code and discrepances on what needs to be changed exactly. On Wed, Mar 01, 2017 at 07:00:00AM +, Niels Thykier wrote: > Strictly speaking, the ".deb" variants of libdebian-installer would need > a "Breaks" and the

Bug#809625: empire-hub: maintainer address bounces

2017-03-02 Thread Tobias Frost
Control: Severity -1 serious Raising back the severity to RC. -- tobi

Bug#856632: woof: Please package latest release

2017-03-02 Thread pitchum
Package: woof Version: 20091227-2.1 Severity: minor Dear Maintainer, a more "recent" version of woof is available which contains nice features like "content-disposition" header making wget happy and the URL containing the filename being shared. Is there a chance to have it packaged in Debian

Bug#855788: 855788 severity

2017-03-02 Thread Paul Wise
On Thu, 2017-03-02 at 23:30 +0100, Yann Dirson wrote: > FWIW, no such problem here. Is that high severity really warranted ? The package is not working for me at all. I assumed that the reason no-one else reported the same issue was that no-one else was using the package and verifying that it

Bug#856592: Multiple security issues

2017-03-02 Thread Salvatore Bonaccorso
Hello, On Thu, Mar 02, 2017 at 07:28:23PM +0100, Moritz Muehlenhoff wrote: > Source: libpodofo > Severity: grave > Tags: security > > New podofo issues (no CVEs yet): > > http://www.openwall.com/lists/oss-security/2017/03/02/10 > http://www.openwall.com/lists/oss-security/2017/03/02/9 >

Bug#856615: Second Look

2017-03-02 Thread Michael Lustfield
After taking a closer look at the source code, I believe the included Apache-2.0 reference is a mistake. The source code that is licensed with Apache-2.0 is available here: https://neil.fraser.name/software/diff_match_patch/svn/trunk/ None of this source code is present in this source code:

Bug#856536: munin: regression from DSA-3794-2: spams munin logs with unitialized warnings: [PERL WARNING] Use of uninitialized value $size_x in string eq at /usr/lib/munin/cgi/munin-cgi-graph line 453

2017-03-02 Thread Salvatore Bonaccorso
Hi On Fri, Mar 03, 2017 at 01:45:10AM +0100, Jonas Meurer wrote: > Hi Salvatore, hi Holger, > > On Thu, 02 Mar 2017 08:12:24 +0100 Salvatore Bonaccorso > wrote: > > Source: munin > > Version: 2.0.25-1+deb8u1 > > Severity: serious > > Tags: upstream > > > > Only after

Bug#856603: RFS: arc-theme/20170302-1

2017-03-02 Thread Adam Borowski
On Thu, Mar 02, 2017 at 09:11:32PM +, David Mohammed wrote: > I am looking for a sponsor for my package "arc-theme" > > * Package name: arc-theme >Version : 20170302-1 > Changes since the last upload: > >* New upstream release >

Bug#854658: unblock pre-approval request for gitlab

2017-03-02 Thread Pirate Praveen
On ശനി 25 ഫെബ്രുവരി 2017 11:03 രാവിലെ, Pirate Praveen wrote: > Attaching the source debdiffs. > ping signature.asc Description: OpenPGP digital signature

Bug#856631: RFS: dh-runit/2.7

2017-03-02 Thread Dmitry Bogatov
Package: sponsorship-requests Severity: wishlist Dear mentors, I am looking for a sponsor for my package "dh-runit" * Package name : dh-runit Version : 2.7 Upstream Author : Dmitry Bogatov * Url :

Bug#820437: nss: Please install nsssysinit module

2017-03-02 Thread Mike Hommey
On Wed, Mar 01, 2017 at 05:14:45PM +0100, Laurent Bigonville wrote: > On Fri, 08 Apr 2016 14:56:09 +0200 Laurent Bigonville > wrote: > > > Hi, > > > > Please find a patch (split from the patch previously proposed in bug > > #537866) attached to this mail that install the

Bug#856630: Creates empty /etc/default/rcS

2017-03-02 Thread Michael Biebl
Package: installation-reports Severity: normal I've installed a Stretch system using the rc2 installer. After a successful installation I had an empty /etc/default/rcS. Since initscripts (which owns that file) is no longer essential and installed by default, I guess there is a component in the

Bug#856619: python-requests: New version released

2017-03-02 Thread Thomas Goirand
On 03/02/2017 11:50 PM, Carlo Stemberger wrote: > Package: python-requests > Version: 2.12.4-1 > Severity: normal > > Dear Maintainer, > a new upstrem version is available (2.13). > > Best regards, > Carlo Hi, First of all, Debian Stretch is frozen, so now is *not* a good time for upgrading

Bug#856439: fakeroot doesn't detect and handle message queue and semaphore id collision

2017-03-02 Thread Martin Dorey
I've had a failure with the same symptom from a patched build. I see a flaw in my patch that could lead to it closing the same id twice if it has to retry twice - I should have reset the ids after cleanup(). I don't see how that could explain the remaining issue. Perhaps there's something

Bug#841144: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514!

2017-03-02 Thread Russell Mosemann
Package: src:linux Version: 4.9.2-2~bpo8+1 Severity: important Dear Maintainer, This is utterly ridiculous. * What led up to the situation? Mar 02 17:30:09 vhost172 kernel: [ cut here ] Mar 02 17:30:09 vhost172 kernel: kernel BUG at

Bug#856536: munin: regression from DSA-3794-2: spams munin logs with unitialized warnings: [PERL WARNING] Use of uninitialized value $size_x in string eq at /usr/lib/munin/cgi/munin-cgi-graph line 453

2017-03-02 Thread Jonas Meurer
Hi Salvatore, hi Holger, On Thu, 02 Mar 2017 08:12:24 +0100 Salvatore Bonaccorso wrote: > Source: munin > Version: 2.0.25-1+deb8u1 > Severity: serious > Tags: upstream > > Only after releasing the DSA, I noticed that the update introduced > another regression, causing to spam

Bug#856629: scid: pgnscid is not installed

2017-03-02 Thread Charles Allen
Package: scid Version: 1:4.6.4+dfsg1-2 Severity: normal Dear Maintainer, * What led up to the situation? Noticed that the pgnscid executable was no longer installed (it certainly used to be, and is mentioned in "apt info scid"). * What exactly did you do (or not

Bug#824098: cryptsetup: systemd timeouts on reboot due to failed crypto disk umount

2017-03-02 Thread Michael Biebl
On Thu, 12 May 2016 11:48:32 +0300 Dmitry Nezhevenko wrote: > Package: cryptsetup > Version: 2:1.7.0-2 > Severity: normal > > Hi, > > For some reason systemd timeouts while trying to reboot/shutdown machine. > It stuck for around ~2min. > > I think it's caused by cryptsetup

Bug#856624: 勿更新!

2017-03-02 Thread 積丹尼 Dan Jacobson
Debian experimental, unstable 勿更新 scim and gtk stuff! 會摧毀您的 configuration. 導致 everything becomes small. http://bugs.debian.org/856624 I replaced scim with the old one. At least I got HANYU PINYIN back. Now I have to replace all the gtk stuff (?) to get the font size 18 back instead of the tiny

Bug#856628: live-wrapper: Fails with AttributeError: 'Package' object has no attribute 'version_list'

2017-03-02 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.6 Severity: normal Dear Maintainer, invoking live-wrapper on unstable with -d unstable fails with AttributeError: 'Package' object has no attribute 'version_list': Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/cliapp/app.py", line

Bug#767389: module hpsa no longer detects MSL2024 tape changer

2017-03-02 Thread Sergio Gelato
control: tags -1 - moreinfo + fixed-upstream control: found -1 3.16.39-1+deb8u1 There is a report at https://wiki.debian.org/HP/ProLiant to the effect that this was no longer an issue in kernel 4.6.3 from jessie-backports. Upstream commit

Bug#856624: pre-disaster set up

2017-03-02 Thread 積丹尼 Dan Jacobson
Pre-disaster: :: .scim/config :: /DefaultIMEngineFactory/en_US = fcff66b6-4d3e-4cf2-833c-01ef66ac6025 /DefaultIMEngineFactory/si_LK = IMEngine-M17N-si-wijesekera /DefaultIMEngineFactory/ta_IN = IMEngine-M17N-ta-tamil99 /DefaultIMEngineFactory/zh_CN =

Bug#856624: damaged gtk too

2017-03-02 Thread 積丹尼 Dan Jacobson
Also now even after reverting to the previous version, the fonts are now too small, and hitting the Sans 18 button just causes the menu to collapse.

Bug#856627: jessie-pu: package libdatetime-timezone-perl/1:1.75-2+2017a

2017-03-02 Thread gregor herrmann
Package: release.debian.org Severity: normal Tags: jessie User: release.debian@packages.debian.org Usertags: pu -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 I've prepared an update for libdatetime-timezone-perl in jessie, adding a patch to update to Olson DB 2017a. As usual, the patch

Bug#856626: solr-tomcat: fails to start

2017-03-02 Thread Matthias Liertzer
Package: solr-tomcat Version: 3.6.2+dfsg-9 Severity: grave Justification: renders package unusable solr doesn't start with the following error message(s) in the log 03-Mar-2017 00:04:42.268 SEVERE [localhost-startStop-1] org.apache.tomcat.util.digester.Digester.startElement Begin event threw

Bug#856625: parsedatetime: FTBFS (AssertionError: 0.0666666666667 is not less than 0.05)

2017-03-02 Thread Santiago Vila
Package: src:parsedatetime Version: 2.1-2 Severity: serious Dear maintainer: I tried to build this package in stretch with "dpkg-buildpackage -A" but it failed: [...] debian/rules build-indep dh build-indep --with

Bug#856624: what happened to my conf file?

2017-03-02 Thread 積丹尼 Dan Jacobson
Why did you do this? diff -U0 /home/jidanni/.scim/config-old /home/jidanni/.scim/config --- /home/jidanni/.scim/config-old 2013-01-25 09:20:57.0 +0800 +++ /home/jidanni/.scim/config 2017-03-03 07:50:46.094513222 +0800 @@ -6,0 +7,2 @@ +/FrontEnd/ChangeFactoryGlobally = false

Bug#856615: Will Fix

2017-03-02 Thread Michael Lustfield
I'll get this fixed and re-uploaded tonight. Thanks for catching this! I'll go through and re-check my other packages for accuracy as well.

Bug#856624: HANYU PINYIN DESTROYED

2017-03-02 Thread 積丹尼 Dan Jacobson
Package: scim Version: 1.4.17-1+b1 Severity: grave This update, has destroyed scim. I no longer can type hanyu pinyin. You also wiped out the user's configuration file.

Bug#856623: unblock: libdatetime-timezone-perl/1:2.09-1+2017a

2017-03-02 Thread gregor herrmann
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 unblock libdatetime-timezone-perl/1:2.09-1+2017a Some days ago, a new tzdata release was made upstream (Olson DB 2017a):

Bug#856487: pulseaudio: SIGSEGV upon streaming to bluetooth headset

2017-03-02 Thread Felipe Sateler
Control: tags -1 = help On Thu, Mar 2, 2017 at 8:01 PM, Linus Lüssing wrote: > On Thu, Mar 02, 2017 at 06:29:12PM -0300, Felipe Sateler wrote: >> Could you install the debug symbols for libsbc and see if we can get a >> reasonable function name for that call? > >

Bug#856621: Missing packages

2017-03-02 Thread Carlo Stemberger
block 856621 by 856577 block 856621 by 856581 block 856621 by 856583 block 856621 by 856617 block 856621 by 818942 block 856621 by 856619 thanks See: https://github.com/ReinProject/python-rein/blob/master/requirements.txt Best regards, Carlo

Bug#856622: unblock: texlive-lang/2016.20170123-4

2017-03-02 Thread Norbert Preining
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package texlive-lang This release only adds three links from /usr/bin to /usr/share/texlive/texmf-dist/scripts/... which have been lost during a upstream internal renaming.

Bug#856621: RFP: rein -- Rein client integration/staging tree

2017-03-02 Thread Carlo Stemberger
Package: wnpp Severity: wishlist * Package name: rein Version : 0.3.0 Upstream Author : David Sterry * URL : https://reinproject.org * License : BSD Programming Lang: Python, JavaScript, HTML, CSS Description : Rein client

Bug#856602: postinst sed delimiter causes failure

2017-03-02 Thread Emmanuel Bourg
Hi Joshua, The tomcat7/7.0.75-1 package no longer exist in unstable/testing. Did you mean to report this issue against the Jessie backport? Emmanuel Bourg

Bug#856253: game-data-packager: xcom-ufo.yaml swapped (_orig) names under size_and_md5 section.

2017-03-02 Thread Alexandre Detiste
Hi, Thank you verry much for you patch. I cherry picked two of your commits & then cleaned-up the yaml file further using group syntax. I used check_equivalence.py to avoid regressions. Then I also worked on adding support for the GOG archive, but there's an handfull of files that can't be

Bug#856618: unblock: dkimpy/0.6.1-1

2017-03-02 Thread Ivo De Decker
Control: tags -1 confirmed moreinfo Hi, On Thu, Mar 02, 2017 at 05:41:42PM -0500, Scott Kitterman wrote: > Please unblock package dkimpy > > After dkimpy 0.6.0 was released, we found a few significant bugs that it would > be good to get fixed for Stretch. One can cause Python tracebacks and

Bug#841144: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514!

2017-03-02 Thread Russell Mosemann
Package: src:linux Version: 4.9.2-2~bpo8+1 Severity: important Dear Maintainer, Mar 02 16:30:09 vhost172 kernel: [ cut here ] Mar 02 16:30:09 vhost172 kernel: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514! Mar 02 16:30:09 vhost172 kernel: invalid opcode:

Bug#856620: kmail: KMail does not attach files > 500 KiB

2017-03-02 Thread Martin Manns
Package: kmail Version: 4:16.04.3-3 Severity: normal Dear Maintainer, when creating a new e-mail with kmail / kontact, I cannot attach files > 500 KiB. I am using kmail on xfce with kde services running. When such a file is chosen, a dialog appears, and the file is not attached. Dialog:

Bug#856487: pulseaudio: SIGSEGV upon streaming to bluetooth headset

2017-03-02 Thread Linus Lüssing
On Thu, Mar 02, 2017 at 06:29:12PM -0300, Felipe Sateler wrote: > Could you install the debug symbols for libsbc and see if we can get a > reasonable function name for that call? Now with sbc-dbg installed:

Bug#855377: genwqe-user: FTBFS on 32-bit arches

2017-03-02 Thread Breno Leitao
Hi Aaron, On Fri, 17 Feb 2017 09:48:32 -0500 "Aaron M. Ucko" wrote: > For the record, the (immediate) problem is that the gzseek64 and > gzoffset64 wrappers in software.c specify the wrong return type > (z_off_t rather than the correct z_off64_t, which is equivalent only > on

Bug#856619: python-requests: New version released

2017-03-02 Thread Carlo Stemberger
Package: python-requests Version: 2.12.4-1 Severity: normal Dear Maintainer, a new upstrem version is available (2.13). Best regards, Carlo -- System Information: Debian Release: 9.0 APT prefers unstable APT policy: (500, 'unstable') Architecture: amd64 (x86_64) Kernel: Linux 4.9.0-1-amd64

Bug#855673: rubocop: FTBFS: RuboCop::Cop::Lint::UselessAssignment when a variable is reassigned in loop body but won't be referenced either next iteration or loop condition registers an offense

2017-03-02 Thread Miguel Landaeta
On Tue, Feb 21, 2017 at 05:01:03PM +1300, Chris Lamb wrote: > Source: rubocop > Version: 0.47.1+dfsg-1 > Severity: serious > Justification: fails to build from source > User: reproducible-bui...@lists.alioth.debian.org > Usertags: ftbfs > X-Debbugs-Cc: reproducible-b...@lists.alioth.debian.org >

Bug#856618: unblock: dkimpy/0.6.1-1

2017-03-02 Thread Scott Kitterman
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package dkimpy After dkimpy 0.6.0 was released, we found a few significant bugs that it would be good to get fixed for Stretch. One can cause Python tracebacks and the can

Bug#856617: python-socks: New version released

2017-03-02 Thread Carlo Stemberger
Package: python-socks Version: 1.6.5-1 Severity: normal Dear Maintainer, a new upstream version is available (1.6.6). Best regards, Carlo -- System Information: Debian Release: 9.0 APT prefers unstable APT policy: (500, 'unstable') Architecture: amd64 (x86_64) Kernel: Linux 4.9.0-1-amd64

Bug#854607: [Pkg-samba-maint] Bug#854607: fixed in cifs-utils 6.7

2017-03-02 Thread Chad William Seys
Hi Mathieu, Unfortunately, I believe all patches between 6.6 and now is the fix for the regression. There are quite a few. :) The patches were in cifs-utils git branch 'next'. Thanks! Chad.

Bug#856569: open-vm-tools: Depend on either libssl1.0-dev or libssl-dev

2017-03-02 Thread Bernd Zeimetz
Hi Tiago, >> I'm not sure how Ubuntu handles these things, but in Debian the >> autobuilders only consider the first alternative of build dependencies >> to keep a build reproducible - so if you have A | B as build-dep, they >> will always use A. > > If A is not available then the builds will

Bug#856334: libdevice-cdio-perl: FTBFS when autobuilder has a CDROM drive

2017-03-02 Thread gregor herrmann
On Wed, 01 Mar 2017 23:13:57 +0100, Santiago Vila wrote: > > My CD-ROM "looks" like: > > > > % ll /dev/cdrom > > lrwxrwxrwx 1 root root 3 Feb 16 19:06 /dev/cdrom -> sr0 > > % ll /dev/sr0 > > brw-rw 1 root cdrom 11, 0 Feb 16 19:06 /dev/sr0 > > That's how my CD-ROM looks as well: > >

Bug#841144: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514!

2017-03-02 Thread Russell Mosemann
Package: src:linux Version: 4.9.2-2~bpo8+1 Severity: important Dear Maintainer, * What led up to the situation? Mar 02 14:30:10 vhost172 kernel: [ cut here ] Mar 02 14:30:10 vhost172 kernel: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514! Mar 02

Bug#856334: Pending fixes for bugs in the libdevice-cdio-perl package

2017-03-02 Thread pkg-perl-maintainers
tag 856334 + pending thanks Some bugs in the libdevice-cdio-perl package are closed in revision f37b526ef055d9bfb44d5c25fa7edbeafafe8351 in branch 'master' by gregor herrmann The full diff can be seen at https://anonscm.debian.org/cgit/pkg-perl/packages/libdevice-cdio-perl.git/commit/?id=f37b526

Bug#856616: unblock: libdevice-cdio-perl/0.3.0-6

2017-03-02 Thread gregor herrmann
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 unblock libdevice-cdio-perl/0.3.0-6 Please unblock package libdevice-cdio-perl, 0.3.0-6: The upload only changes debian/rules to skip two

Bug#855788: 855788 severity

2017-03-02 Thread ydirson
FWIW, no such problem here. Is that high severity really warranted ?

Bug#856615: golang-github-sergi-go-diff: Incomplete debian/copyright?

2017-03-02 Thread Chris Lamb
Source: golang-github-sergi-go-diff Version: 0.0~git20170118.0.24e2351-1 Severity: serious Justication: Policy 12.5 X-Debbugs-CC: Michael Lustfield Hi, I just ACCEPTed golang-github-sergi-go-diff from NEW but noticed it was missing attribution in debian/copyright for at

Bug#856333: bear can not be used for multiarch tools

2017-03-02 Thread Norbert Lange
Hello Sebastian, think of this patch more of a proof of concept, I am not fluent with all the requirements and conventions of the deb packages, especially the logic behind the "breaks". >> + python:any, >> + python3:any, > > Why? Is it required that python is the same arch? I built the package

Bug#673565: RFP: ftpsync -- Debian mirror scripts

2017-03-02 Thread Philippe Thierry
retitle 673565 ITP: ftpsync -- Debian mirror scripts owner 673565 ! thanks Hello, I'm using ftpsync for some times now (working mostly offline, requiring local mirrors). I propose to try making a package for it. I've pushed a basic content on mentors.debian.net (clearly incomplete, just

Bug#856614: dask.distributed: please make the build reproducible

2017-03-02 Thread Chris Lamb
Source: dask.distributed Version: 1.14.3+ds.1-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org Usertags: environment X-Debbugs-Cc: reproducible-b...@lists.alioth.debian.org Hi, Whilst working on the Reproducible Builds effort [0], we noticed that

Bug#856612: radiotray: No launch with icon or command line as normal user. Root command line reports Dbus connection error

2017-03-02 Thread cliff hull
Package: radiotray Version: 0.7.3-3 Severity: important Dear Maintainer, NB: just switched to Debian from Ubuntu, so I might be doing something stupid... New install of Debian Jessie. Fresh install of radiotray from apt. Clicking on icon - nothing happens (no program launch). Running from

Bug#856611: python-dkim: The arcverify script added in 0.6.0 produces erroneous results

2017-03-02 Thread Scott Kitterman
Package: python-dkim Version: 0.6.0-1 Severity: serious Tags: upstream An error in the arcverify script prevents it from producing correct verification results. Depending on how this script is used on an end user system, it may cause incorrect email rejections. This is fixed upstream in version

Bug#856610: unblock: sqlalchemy/1.1.5+ds1-1

2017-03-02 Thread Piotr Ożarowski
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package sqlalchemy 1.1 - it was in unstable for a very long time and was my plan to ship it in Strech since the first beta release of 1.1.0. Upstream author provides best

Bug#856608: unblock: libcolor-library-perl/0.021-3

2017-03-02 Thread gregor herrmann
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 unblock libcolor-library-perl/0.021-3 Please unblock package libcolor-library-perl, version 0.021-3. This upload fixes #856562:

Bug#856609: python3-dkim: DNS query errors with python3 and dkimpy

2017-03-02 Thread Scott Kitterman
Package: python3-dkim Version: 0.5.4-1 Severity: important Tags: upstream dkim/dnsplug.py is designed to work with multiple Python DNS modules. In some cases, the DNS TXT record is not returned as type string and so, in Python 3, conversion to UTF-8 will fail, causing a fatal error. This is

Bug#811806: Path for bug 811806

2017-03-02 Thread Francois Mazen
Hello, I've succeeded to build the package on current debian testing (stretch) with the patch below. The trick is to remove the "using namespace std" in some files to avoid mix between std::tuple and pam/tuple. I've also changed an implicit conversion from bool(false) to NULL that generated

Bug#856562: Pending fixes for bugs in the libcolor-library-perl package

2017-03-02 Thread pkg-perl-maintainers
tag 856562 + pending thanks Some bugs in the libcolor-library-perl package are closed in revision c5934a6d98d46d63201042be2fe986e7a340f575 in branch 'master' by gregor herrmann The full diff can be seen at

Bug#856562: libcolor-library-perl: debian patch breaks some package functionality

2017-03-02 Thread gregor herrmann
Control: severity -1 important # breaks a function On Thu, 02 Mar 2017 08:06:07 -0600, Jeff Norden wrote: > The debian patch to this library disables the parse_rgb_color() subroutine: > > jeff@norden:~$ perl -d -e1 > ... > DB<1> use Color::Library::Color > DB<2> @rgb=

Bug#856607: kernel-common: WinTV Aero-M Card fails with 4.9.x kernels

2017-03-02 Thread Barry Fishman
Package: kernel-common Version: 4.9.0-2-amd64 Severity: important Tags: upstream Dear Maintainer, A security change in the 4.9 kernels breaks a variety of dvd-usb devices including this WinTV Aero-M TV usb card. I play video via mplayer and vlc. The bug shows up with messages like The errors

Bug#217243:

2017-03-02 Thread Gwern Branwen
Has there been any word from upstream on the patch for this? (The bug is now at least 14 years old, and breaks the blacklist option entirely.) -- gwern https://www.gwern.net

Bug#856487: pulseaudio: SIGSEGV upon streaming to bluetooth headset

2017-03-02 Thread Felipe Sateler
On Thu, Mar 2, 2017 at 5:15 PM, Linus Lüssing wrote: > On Thu, Mar 02, 2017 at 03:27:25AM +0100, Linus Lüssing wrote: >> Two more notes to maybe eliminate some potential causes: >> >> * Removing the ~/.config/pulse/default.pa mentioned earlier did not help. >> * Using a

Bug#856532: Error: Can't locate object method "get_user"

2017-03-02 Thread gregor herrmann
Control: tag -1 + confirmed Control: tag -1 - upstream # we are upstream :) On Thu, 02 Mar 2017 14:10:19 +0930, David Nebauer wrote: > When trying to build Dn::Role using dh-make-perl with the following > command: > > dh-make-perl Dn-Role-v0.1 > > the following error occurred: > >

Bug#856474: stap: include runtime_defines.h not found

2017-03-02 Thread Gerald Turner
FWIW, I attempted to kludge around the mangled include argument by running stap with "-B 'EXTRA_CFLAGS += -I/usr/share/systemtap/runtime'". This seems to work around the compilation failure of missing runtime_defines.h in include path, however compiliation then fails due to what appears to be API

Bug#856569: open-vm-tools: Depend on either libssl1.0-dev or libssl-dev

2017-03-02 Thread Tiago Daitx
Hi Bernd, Thank you for the quick reply. =) On Thu, Mar 2, 2017 at 5:42 PM, Bernd Zeimetz wrote: > Hi Tiago, > >> Please consider improving Build-depends to accept either >> libssl1.0-dev or libssl-dev as that will make backporting easier. > > I'm not sure how Ubuntu handles

Bug#856605: recoll does not index the new Libreoffice file format in flat plain xml: FODPT, FODP, etc

2017-03-02 Thread Martin Monperrus
Package: recoll Version: 1.22.4-1 Severity: normal Dear Maintainer, recoll does not index the new Libreoffice file formats: FODPT, FODP, etc. (flat plain xml files, usable with Git) Some changes in mimemap, mimeconf and mimeview are required to handle those files. -- System Information:

Bug#855493: ejabberd: Please consider adding more examples to default ejabberd.yml

2017-03-02 Thread Johannes Schauer
Hi, Quoting Philipp Huebner (2017-03-02 22:17:20) > Am 19.02.2017 um 08:30 schrieb Johannes Schauer: > > Source: ejabberd > > Severity: wishlist > > > > Hi, > > > > I recently configured my ejabberd server for compliance with the > > ComplianceTester by Daniel Gultsch [1] and with the IM

Bug#856604: RM: rt-authen-externalauth -- ROM; FTBFS; code is now included in request-tracker4 >= 4.4

2017-03-02 Thread Tom Jampen
Package: ftp.debian.org Severity: normal Hi, Please remove the source package rt-authen-externalauth from unstable as its functionality is included in request-tracker4 (>= 4.4). The bug report #852258 contains more details. The package has already been removed from testing. Kind regards, Tom

Bug#855493: ejabberd: Please consider adding more examples to default ejabberd.yml

2017-03-02 Thread Philipp Huebner
Hi, Am 19.02.2017 um 08:30 schrieb Johannes Schauer: > Source: ejabberd > Severity: wishlist > > Hi, > > I recently configured my ejabberd server for compliance with the > ComplianceTester by Daniel Gultsch [1] and with the IM Observatory [2]. > I would like to propose adding more example

Bug#850731: xorp: segfaults at initialization, linker flags

2017-03-02 Thread Ben Greear
Just FYI, I pushed this change plus an additional null check in related code. If fixes the crash I was seeing on my Fedora-24 systems, and it would appear to be the same bug earlier reported. Thanks, Ben On 01/10/2017 12:50 PM, Dhionel Díaz wrote: El 10/01/17 a las 15:59, Jose M Calhariz

Bug#856603: RFS: arc-theme/20170302-1

2017-03-02 Thread David Mohammed
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "arc-theme" * Package name: arc-theme Version : 20170302-1 Upstream Author : horst3180 * URL : https://github.com/horst3180/arc-theme

Bug#856474: stap: include runtime_defines.h not found

2017-03-02 Thread Jack Henschel
On 03/02/2017 06:40 PM, Ritesh Raj Sarraf wrote: > I just pushed 3.1 to Experimental, the reason being 3.0 is going to be useless > for Debian Stretch. We need 3.1 to get it working proper with 4.9 kernel too. Did I get that right: you are planning to ship SystemTap 3.1 with Stretch? (If so:

Bug#856569: open-vm-tools: Depend on either libssl1.0-dev or libssl-dev

2017-03-02 Thread Bernd Zeimetz
Hi Tiago, > Please consider improving Build-depends to accept either > libssl1.0-dev or libssl-dev as that will make backporting easier. I'm not sure how Ubuntu handles these things, but in Debian the autobuilders only consider the first alternative of build dependencies to keep a build

Bug#841144: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514!

2017-03-02 Thread Russell Mosemann
Package: src:linux Version: 4.9.2-2~bpo8+1 Severity: important Dear Maintainer, * What led up to the situation? Mar 02 11:30:09 vhost172 kernel: [ cut here ] Mar 02 11:30:09 vhost172 kernel: kernel BUG at /home/zumbi/linux-4.9.2/fs/ocfs2/alloc.c:1514! Mar 02 11:30:09

Bug#856485: xpra: terminating xpra server destroys current X session

2017-03-02 Thread Dmitry Smirnov
On Wednesday, 1 March 2017 3:23:34 PM AEDT mviereck wrote: > The above steps destroy current X session, leaving a black screen with some > startup messages. This does not happen with current xpra v1.0.3-r15051 > from xpra repository. I've seen that before -- it started to happen at some point

Bug#856498: webkit2gtk: FTBFS on x32

2017-03-02 Thread Thorsten Glaser
Alberto Garcia dixit: >Great, can you confirm that the build finishes successfully? Does the Yes. >browser work? I don't have an x32 system available to test it. If How do I do that? I only used it as Build-Depends for libproxy. >there's an x32 Debian machine available for developers I can do

Bug#856487: pulseaudio: SIGSEGV upon streaming to bluetooth headset

2017-03-02 Thread Linus Lüssing
On Thu, Mar 02, 2017 at 03:27:25AM +0100, Linus Lüssing wrote: > Two more notes to maybe eliminate some potential causes: > > * Removing the ~/.config/pulse/default.pa mentioned earlier did not help. > * Using a different bluetooth stick did not help (Some Logilink > one now which worked with

Bug#856602: postinst sed delimiter causes failure

2017-03-02 Thread Joshua Powers
Package: tomcat7 Version: 7.0.75-1 Similiar to Debian bug #597814, the sed statement in the postinst assumes there is no '%' in a user's JAVA_OPTS. However, this is a valid possiblity, for example: -XX:ErrorFile=/var/log/tomcat7/java_error%p.log This will cause the sed command to fail as it

Bug#827182: hplip: HP C3180 failing halted with blinking display

2017-03-02 Thread Brian Potkin
tags 827182 moreinfo thanks On Mon 13 Jun 2016 at 14:51:42 +0200, José Luis González wrote: > Package: hplip > Version: 3.16.5+repack0-1 > > After printing inverted even pages on range 1-55 from the > follwing document: > >

Bug#825552: hplip: printing doesn't honour settings paper size

2017-03-02 Thread Brian Potkin
tags 825552 moreinfo thanks On Fri 27 May 2016 at 20:23:09 +0200, José Luis González wrote: > Print dialog on apps shows US Letter as paper size when I have set it > up to A4 in the printer preferences. Please clarify: what printer preferences are you referring to? And which apps? An example

Bug#856601: libmagickcore-dev is wrongly marked Multi-Arch: foreign

2017-03-02 Thread Helmut Grohne
Package: libmagickcore-dev Version: 8:6.9.7.4+dfsg-1 Severity: important User: helm...@debian.org Usertags: rebootstrap Control: affects -1 + src:hhvm src:nip2 src:vips src:inkscape src:performous src:k3d src:synfig src:synfigstudio src:zbar src:dx src:emacs24 src:gem src:gst-plugins-bad1.0

Bug#832941: RFS: 4pane

2017-03-02 Thread David Hart
Dear Sean, I'd not lost interest, just slowed down during the stretch freeze. I've now uploaded an altered d/ >> Many thanks for the offer. I don't mind packaging Bakefile, and it shouldn't >> be difficult to do. >> >> However will it be accepted into debian? The project is moribund... >> Do

Bug#856600: python-libtorrent: to-Python converter already registered

2017-03-02 Thread Sebastian Ramacher
Package: python-libtorrent Version: 1.1.1-1 Severity: minor On every import the module reports the following warning: $ python >>> import libtorrent __console__:3: RuntimeWarning: to-Python converter for boost::shared_ptr already registered; second conversion method ignored. Cheers -- System

Bug#789567: [pkg-wicd-maint] Override wicd.service file

2017-03-02 Thread Axel Beckert
Hi Salvo, Salvo Tomaselli wrote: > I think wicd should ship a .service file. I know you about https://bugs.debian.org/789567 :-) > We can basically use the autogenerated one but we should override the > timeout from 5 minutes to something like 10 seconds. I'm fine to do that although I'm not

Bug#856598: mark thunar-data Multi-Arch: foreign

2017-03-02 Thread Helmut Grohne
Package: thunard-data Version: 1.6.10-6 Tags: patch User: helm...@debian.org Usertags: rebootstrap Control: affects -1 + src:gtkhash src:thunar-archive-plugin src:thunar-media-tags-plugin src:thunar-vcs-plugin src:xfdesktop4 The affected packages cannot satisfy their cross build dependencies,

Bug#856599: libktpcommoninternals9: please add Breaks: libktpcommoninternalsprivate7

2017-03-02 Thread Andreas Beckmann
Package: libktpcommoninternals9 Version: 15.08.3-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed apt does not find a clean upgrade path from jessie to stretch in some cases with libktpcommoninternalsprivate7 is installed. I tried

Bug#856597: ITP: python-biotools -- Python bioinformatics utilities for high-throughput genomic sequencing

2017-03-02 Thread Andreas Tille
Package: wnpp Severity: wishlist Owner: Andreas Tille * Package name: python-biotools Version : 1.2.12 Upstream Author : Andrew Kassen * URL : https://github.com/sonwell/biotools * License : BSD Programming Lang: Python

Bug#856596: makedumpfile: kdump-tools does not support diskless live systems

2017-03-02 Thread Benjamin Drung
Package: makedumpfile Version: 1:1.6.1-1 Severity: normal Hi, I want to use kdump-tools to dump the kernel for a diskless live systems. This live system uses a custom made root tarball and initrd. On boot, the root tarball is downloaded and extracted into tmpfs. The system runs entirely on

Bug#856595: RFP: kiwix-tools -- Kiwix (http://www.kiwix.org) command line tools

2017-03-02 Thread Emmanuel Engelhart
Package: wnpp Severity: wishlist * Package name: kiwix-tools Version : 1.0 Upstream Author : Emmanuel Engelhart , Matthieu Gautier * URL : https://github.com/kiwix/kiwix-tools * License : GPL Programming Lang: C++

Bug#856594: makedumpfile: In a chroot, kdump-tools.postinst creates initramfs for the host kernel

2017-03-02 Thread Benjamin Drung
Package: makedumpfile Version: 1:1.6.1-1 Severity: normal Hi, I am using debootstrap to create minimal Debian system and chroot to install a bunch of additional packages (including a kernel and kdump-tools). Then I create an tarball out of it to boot from. The postinst script from kdump-tools

  1   2   3   >