Bug#924858: also can't reproduce

2019-03-21 Thread Kunal Mehta
While working on #925068, I built the version of doxygen in buster multiple times, and was unable to reproduce any build failures. -- Kunal signature.asc Description: OpenPGP digital signature

Bug#925068: doxygen: search.php uses

2019-03-21 Thread Kunal Mehta
n (1.8.13-11) UNRELEASED; urgency=medium + + * QA upload. + * Fix search.php to be compatible with PHP 7.0+. (Closes: #925068) + + -- Kunal Mehta Wed, 20 Mar 2019 18:23:59 -0700 + doxygen (1.8.13-10) unstable; urgency=medium * Orphan the package. See: #888580. diff -Nru doxygen-1.8.13/debia

Bug#856595:

2019-02-17 Thread Kunal Mehta
Hi, On 2/16/19 7:35 PM, Pavel Minaev wrote: > It looks like all the dependencies are now in Buster, thanks to Kunal. > It would be a shame to have it all, except for the actual user-facing > app that uses it... > > Is there any chance that this package might make it into Buster? Is > there any

Bug#909752: #909752 fixed in git but not uploaded

2019-01-06 Thread Kunal Mehta
control: tags -1 pending Hi Ondřej, It looks like you fixed this #909752 in git back in November[1], but it was never uploaded to the archive. Is there anything blocking its upload? [1] https://salsa.debian.org/php-team/pecl/php-apcu-bc/commit/a4c7df39a4775cbf2988bb97bb07153ffbdb5f9e Thanks,

Bug#918310: php-respect-validation: Drop dependency upon php-symfony-polyfill-mbstring

2019-01-04 Thread Kunal Mehta
/fzpctqnmDKX/sy7ngiPSw6YGmbNMlAfYvh9Vt2GPcCL8R79XDmGxl60 ekByNFdF87rZNb7bNkWaaJKPGFnQ92wo/Z+Y6JC9AE61d6Cq5p8DP2u8e71Ei0RG xw7oB5PX7zzkMQ== =bd+z -END PGP SIGNATURE- >From 025b159765ca33f2c49b66c2e68b3964a7491e30 Mon Sep 17 00:00:00 2001 From: Kunal Mehta Date: Fri, 4 Jan 2019 14:15:03 -0

Bug#918307: civicrm-common: Drop dependency upon php-symfony-polyfill-iconv

2019-01-04 Thread Kunal Mehta
SIGNATURE- >From 53113969df12cbc463ad1e480370cd3fa3191a4d Mon Sep 17 00:00:00 2001 From: Kunal Mehta Date: Fri, 4 Jan 2019 13:45:41 -0800 Subject: [PATCH] Don't depend on php-symfony-polyfill-iconv The iconv extension is included in php-common, so there's no need to include a polyfill for it.

Bug#911832: polyfill should be dropped

2019-01-03 Thread Kunal Mehta
Hi, On 1/3/19 6:57 PM, David Prévot wrote: > Le 04/01/2019 à 12:50, Kunal Mehta a écrit : >> This patch adds overrides for all symfony/polyfill-* packages to >> pkg-php-tools itself, so all packages will automatically use it and no >> longer automatically depend upon

Bug#911832: polyfill should be dropped

2019-01-03 Thread Kunal Mehta
On 1/2/19 11:57 PM, Kunal Mehta wrote: > I'm not sure how exactly the best way to remove the dependency is since > it's automatically generated from composer.json. We could update > pkg-php-tools to modify php-symfony-polyfill-* dependencies? https://salsa.debian.org/php-team/pear/pkg-

Bug#911832: polyfill should be dropped

2019-01-03 Thread Kunal Mehta
Hi, First, I filed upstream about the test failures. However, as I looked a bit more, I'm not sure why this package exists in Debian in the first place. The purpose of the polyfill is to have pure PHP fallback implementations for when the PHP

Bug#916680: RM: mediawiki-math -- ROM; removed upstream

2018-12-17 Thread Kunal Mehta
Package: ftp.debian.org Severity: normal -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi, texvc (built from mediawiki-math) was removed upstream, and is no longer supported in favor of a nodejs web service ("mathoid") that has a lot more features. See

Bug#886120: ctpp2: diff for NMU version 2.8.3-25.1

2018-12-02 Thread Kunal Mehta
Hi, On 12/2/18 11:56 AM, gregor herrmann wrote: > I've prepared an NMU for ctpp2 (versioned as 2.8.3-25.1) and > uploaded it to DELAYED/5. Please feel free to tell me if I > should delay it longer. Thanks, it seems fine to me. I'm also happy to do a standard upload, I'm not sure if that would be

Bug#915244: quassel: New 0.13.0 version available

2018-12-01 Thread Kunal Mehta
Source: quassel Severity: wishlist -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Quassel 0.13.0 was released on 2018-11-17: . This release is expected to bring UI improvements, better IRCv3 support, and increased support for mobile clients, among plenty of

Bug#913773: dh-php: pkg-pecl.mk does not run extension tests during build

2018-11-14 Thread Kunal Mehta
Package: dh-php Version: 0.34 Severity: wishlist Tags: patch -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 I was looking into porting php-luasandbox to fully build with pkg-pecl.mk, and I noticed that it wasn't running the luasandbox tests during the package build process. I have provided a

Bug#913705: transition: zimlib

2018-11-13 Thread Kunal Mehta
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: transition -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi, I'd like to upgrade zimlib to v4 to get up to date with upstream once again. The only dependency affected is libkiwix, which will

Bug#913620: Happened before in #905187

2018-11-13 Thread Kunal Mehta
This is the same regression as #905187 - is there a good way we can prevent this from happening again? HTH, -- Kunal signature.asc Description: OpenPGP digital signature

Bug#913506: libkiwix FTBFS with ICU 63.1

2018-11-11 Thread Kunal Mehta
control: tags -1 fixed-upstream Hi, On 11/11/18 11:13 AM, László Böszörményi (GCS) wrote: > ICU 63.1 recently released, packaged and uploaded to experimental. > Its transition is going to start soon. However your package fails to > build with this version. I attach a patch which fixes the

Bug#871594: mediawiki-extensions-universallanguageselector - package description not really understandable

2018-10-23 Thread Kunal Mehta
Hi, On Fri, 18 Aug 2017 20:48:09 +0200 (CEST) Tomas Pospisek wrote: > Hello Kartik Mistry, > > the description you chose for your package is: "Tool to select a language > and configure for MediaWiki". > > What does "select a configure" mean? Do you mean "select a configuration"? > > Or do

Bug#911666: mediawiki: Does not work with PHP 7.3

2018-10-23 Thread Kunal Mehta
Hi, On 10/23/18 2:51 AM, Joseph Nuthalapati wrote: > MediaWiki doesn't recognize the packages php-mbstring, php-xml > and php-sqlite3 if their PHP 7.3 versions are installed. > > On Debian testing, the installation fails. > On Debian unstable, the installation works but MediaWiki fails to >

Bug#911460: upstream

2018-10-20 Thread Kunal Mehta
control: tags -1 upstream This is being worked on upstream at .

Bug#911480: ITP: php-excimer -- PHP extension that provides a non-static, non-global profiler

2018-10-20 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 * Package name: php-excimer Version : 0.0.1 Upstream Author : Tim Starling * URL : https://www.mediawiki.org/wiki/Excimer * License : Apache-2.0 Programming

Bug#909110: serious

2018-10-15 Thread Kunal Mehta
Hi, On 10/14/18 11:45 PM, Ondřej Surý wrote: > Version: 7.3.0~rc2-2 > > This had been already fixed in version in both unstable and testing. That's not what I see... $ php -v PHP 7.3.0RC2 (cli) (built: Oct 14 2018 10:21:01) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.3.0-dev,

Bug#909110: serious

2018-10-15 Thread Kunal Mehta
severity serious affects php-wikidiff2 php-luasandbox thanks With the transition to PHP 7.3, the lack of run-tests.php causes wikidiff2 and luasandbox to FTBFS since "make test" fails. -- Kunal

Bug#910709: devscripts: uscan fails to create git archive in mode=git

2018-10-10 Thread Kunal Mehta
Hi, On 10/9/18 10:11 PM, Xavier wrote: > Hello, > > I found this (old) bug: git clones repo using --depth=1 so sometimes > tags are missing. It's easy to fix but it will launch a full clone which > may take a long time. > > @mattia: any idea on how to avoid this ? According to

Bug#910709: devscripts: uscan fails to create git archive in mode=git

2018-10-09 Thread Kunal Mehta
Package: devscripts Version: 2.18.6 Severity: important -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 uscan fails to create git archives when using mode=git in debian/watch. The specific watch file is

Bug#909589: mediawiki: /usr/share/mediawiki/skins/CologneBlue/skin.json, does not exist! [upgrading to 1:1.31.1-2]

2018-09-25 Thread Kunal Mehta
Hi Davide, On 9/25/18 10:34 AM, Davide Prina wrote: > upgrading mediawiki to the version 1:1.31.1-2 after connecting to the > page http://localhost/mediawiki/mw-config and selecting the language to > use I have the error: > /usr/share/mediawiki/skins/CologneBlue/skin.json does not exist! Thank

Bug#909290: php-defaults: Please add php-dba dependency package

2018-09-21 Thread Kunal Mehta
Source: php-defaults Version: 62 Severity: normal Nearly all PHP extensions that are in separate packages have an unversioned php-* dependency package. However, php-dba is missing - could it be added please? The other two packages I noticed that were missing are opcache and xsl. I'm not sure if

Bug#908181: pytest: new version available upstream

2018-09-07 Thread Kunal Mehta
Source: pytest Version: 3.6.4-1 Severity: wishlist Hi, pytest 3.8.0 is now available - it seems it was released today, I originally planned on filing this bug for 3.7.4. I plan on using some newer pytest features in my ITP for poolcounter (#907122), so I would appreciate having a newer pytest

Bug#907122: ITP: poolcounter -- network daemon which provides mutex-like functionality

2018-08-23 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta * Package name: poolcounter Version : 1.0.0 Upstream Author : Platonides * URL : https://wikitech.wikimedia.org/wiki/PoolCounter * License : GPL-3.0-or-later Programming Lang: C Description : network

Bug#905187: php7.2/7.2.8-1 appears to break multiple autopkgtest: /usr/bin/phpize: 1: /usr/bin/phpize: /usr/bin/sed: not found

2018-08-01 Thread Kunal Mehta
Hi, On 08/01/2018 04:08 AM, Paul Gevers wrote: > Currently this regression is delaying the migration of php7.2 to > testing by 13 days. From the error it seems that a dependency on sed is > missing somewhere, but that is just a hunch. Could you please > investigate the situation? If

Bug#897732: patches

2018-07-20 Thread Kunal Mehta
this myself, so feel free to take any parts of these patches to make the package build again, or just upload my series of patches as is. Thanks! -- Kunal From 943ce8a954f2ba959cbadeda0fc9dc9b0a0fefcc Mon Sep 17 00:00:00 2001 From: Kunal Mehta Date: Sat, 21 Jul 2018 01:54:06 +0200 Subject: [PATCH 1/3

Bug#863332: mediawiki: poweredby_debian image links broken unless ScriptPath is /wiki

2018-07-19 Thread Kunal Mehta
tags -1 pending thanks Apologies for the delay in responding. This will be fixed by , and included in the 1.31+ versions of the package. -- Kunal signature.asc Description: OpenPGP digital signature

Bug#903876: File extension 'xlsx' does not match the detected MIME type of the file (application/zip)

2018-07-19 Thread Kunal Mehta
Hi, On 07/16/2018 04:14 AM, Chad Seys wrote: > The line > $wgMimeTypeFile = '/etc/mime.types'; > in LocalSettings.php causes mediawiki to refuse to upload 'xlsx' files with > the error > "File extension 'xlsx' does not match the detected MIME type of the file > (application/zip)". > >

Bug#812159: Needed by kiwix

2018-07-09 Thread Kunal Mehta
Hi, The latest upstream version of libkiwix depends upon libaria2, so it would be great if this package could start providing the library as well. -- Kunal signature.asc Description: OpenPGP digital signature

Bug#884440: zimlib: Please package new 3.1.0 upstream version

2018-06-10 Thread Kunal Mehta
retitle 884440 Please package new 3.3.0 upstream version thanks upstream is now at 3.3.0. I went ahead and prepared most of the packaging for this at . Would it help if I created a merge request on salsa? The remaining tasks should be

Bug#900747: dh-make: Vcs- URLs in generated control should use salsa.debian.org

2018-06-04 Thread Kunal Mehta
Package: dh-make Version: 2.201701 Severity: normal The control file generated by dh_make should have its Vcs-* fields point to salsa.debian.org instead of the deprecated/shutdown anonscm.debian.org. -- System Information: Debian Release: buster/sid APT prefers unstable APT policy: (500,

Bug#900744: ITP: zimwriterfs -- creates ZIM files from a locally-stored directory containing "self-sufficient" HTML content

2018-06-03 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta * Package name: zimwriterfs Version : 1.1 Upstream Author : Emmanuel Engelhart * URL : https://github.com/openzim/zimwriterfs * License : GPL-3.0-or-later Programming Lang: C/C++ Description

Bug#884440: zimlib: Please package new 3.1.0 upstream version

2017-12-15 Thread Kunal Mehta
Source: zimlib Version: 2.0.0-2 Severity: wishlist Upstream has released zimlib 3.0.0 and 3.1.0. A new libkiwix version will depend upon zimlib >=3.0.0. Note that upstream has not issued 3.x tarballs yet, nor tagged 3.1.0 in git yet. I've requested that they do so at

Bug#881160: please package mediawiki extension

2017-11-26 Thread Kunal Mehta
Hi, On Wed, 8 Nov 2017 12:45:39 +0100 Daniel Baumann wrote: > we're trying to use your package, however, there's nothing > /usr/share/mediawiki/extensions*/Math/extension.json or the like. > > I gather from the ITP that this is on purpose.. hence.. here my

Bug#878147: Your mail

2017-11-17 Thread Kunal Mehta
On Fri, 13 Oct 2017 01:41:52 +0200 Jan Bergner wrote: > Sorry, if I am not familiar with the processes involved in packaging as > this is my first usage of the Debian reporting system. Thus, I also > apologize for the duplicate #878263, as I simply did not realize I do > not

Bug#878549: uprightdiff FTBFS with OpenCV 3.2

2017-10-31 Thread Kunal Mehta
tags 878549 + pending thanks This has been fixed upstream, and I've asked my sponsor to review and upload the new version. -- Kunal signature.asc Description: OpenPGP digital signature

Bug#878147: Extensions for mediawiki like additional authentication plugins.

2017-10-12 Thread Kunal Mehta
On Tue, 10 Oct 2017 14:51:30 +0200 Jan Bergner wrote: > This package already existed in Wheezy and Jessie and was removed as > obsolete, when mediawiki itself was dropped: > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=810127 > > Since mediawiki was reintroduced, it

Bug#781051: php-wikidiff2: Not configured correctly when short_open_tag is false

2017-09-19 Thread Kunal Mehta
On Mon, 23 Mar 2015 20:59:36 +0100 Sebastien Koechlin wrote > Can you switch to "https://anonscm.debian.org/cgit/collab-maint/wikidiff2.git/commit/?id=d83ceb2ff550ff0831738cda29477cbe46e64281>. wikidiff2 1.4.1+ no longer includes a PHP file anyways. -- Kunal

Bug#871533: ITP: uprightdiff -- examine differences between two images

2017-08-08 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta <lego...@member.fsf.org> * Package name: uprightdiff Version : 1.1.0 Upstream Author : Tim Starling <tstarl...@wikimedia.org> * URL : https://www.mediawiki.org/wiki/Uprightdiff * License : BSD

Bug#871416: libcxxtools-dev: Please provide pkg-config .pc files for cxxtools

2017-08-07 Thread Kunal Mehta
Package: libcxxtools-dev Version: 2.2.1-2 Severity: wishlist Dear Maintainer, Please provide the pkg-config .pc files for cxxtools that are included in the upstream tarball. I noticed that this was implemented in the git repository[1], but never uploaded to the archive. This is currently

Bug#856552: progress on Kiwix RFPs?

2017-07-21 Thread Kunal Mehta
block 856552 by 868641 retitle 856552 ITP: libkiwix -- Kiwix underlying library owner 856552 ! thanks Hi, On Wed, 7 Jun 2017 20:20:05 -0400 Antoine Beaupre wrote: > Any progress here? Anything holding this up that we can help with? I talked with Vasudev and I'll be taking

Bug#868641: libzim-dev: Upgrade libzim to 2.0.0

2017-07-17 Thread Kunal Mehta
Hi, On 07/16/2017 09:56 PM, Vasudev Kamath wrote: > When you are considering to change the packaging style please ask the > maintainer first, > if he/she is willing to change their packaging style. I observed that > you removed my CDBS > packaging effort without asking me. This is not

Bug#868641: libzim-dev: Upgrade libzim to 2.0.0

2017-07-16 Thread Kunal Mehta
Package: libzim-dev Version: 1.4-2.1 Severity: wishlist -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Dear Maintainer, Please upgrade libzim to 2.0.0. - From the release announcement[1]: Here are the major changes: * Move to meson build system (instead of autotools) * Move to C++11

Bug#849810: patch

2017-07-11 Thread Kunal Mehta
@km-tp:~/projects/debian$ pkg-config --modversion pugixml 1.8 :) From 8fc55741e13e814dc72655a7a3ee5bc8eb6fd461 Mon Sep 17 00:00:00 2001 From: Kunal Mehta <lego...@member.fsf.org> Date: Mon, 10 Jul 2017 23:54:15 -0700 Subject: [PATCH] Fix pkg-config path --- debian/libpugixml-dev.install | 2

Bug#868010: pugixml: Vcs-Git URL is incorrect

2017-07-11 Thread Kunal Mehta
=C.UTF-8 (charmap=UTF-8) Shell: /bin/sh linked to /bin/dash Init: systemd (via /run/systemd/system) >From 09292f12562d7e9eff4ff5dc7bb2db4e999fdcc8 Mon Sep 17 00:00:00 2001 From: Kunal Mehta <lego...@member.fsf.org> Date: Mon, 10 Jul 2017 23:44:42 -0700 Subject: [PATCH] Fix Vcs-Git

Bug#865724: ITP: php-luasandbox -- PHP extension that provides a sandboxed Lua environment

2017-06-24 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta <lego...@member.fsf.org> * Package name: php-luasandbox Version : 2.0.13 Upstream Author : MediaWiki developers <wikitec...@lists.wikimedia.org> * URL : https://www.mediawiki.org/wiki/Extension:Scribun

Bug#861628: unblock: mediawiki/1:1.27.3-1

2017-05-01 Thread Kunal Mehta
11.0 -0700 @@ -1,10 +1,17 @@ +mediawiki (1:1.27.3-1) unstable; urgency=medium + + * Imported Upstream version 1.27.3 (security release), that +actually contains the fix for CVE-2017-0372 (Closes: #861585) + + -- Kunal Mehta <lego...@member.fsf.org> Mon, 01 May 2017 13:20:11 -0700

Bug#857773: mediawiki: broken symlinks: /etc/mediawiki-extensions/extensions-available/{Vector, Asirra}.php

2017-04-11 Thread Kunal Mehta
Hi, Sorry about the delayed response. On 03/14/2017 01:04 PM, Andreas Beckmann wrote: > /var/lib/mediawiki/LocalSettings.php -> /etc/mediawiki/LocalSettings.php > /usr/share/mediawiki/LocalSettings.php -> > /var/lib/mediawiki/LocalSettings.php These two are expected and intentional. >

Bug#859754: unblock: mediawiki/1:1.27.2-1

2017-04-06 Thread Kunal Mehta
1) unstable; urgency=medium + + * Improve NEWS file (Closes: #852862, #854352) + * Imported Upstream version 1.27.2 (security release), fixing +CVE-2017-0363, CVE-2017-0364, CVE-2017-0365, CVE-2017-0361, +CVE-2017-0362, CVE-2017-0368, CVE-2017-0366, CVE-2017-0370, +CVE-2017-0369, CVE-2017

Bug#854352: [mediawiki] stretch - clean install of mediawiki.postinst fails

2017-02-07 Thread Kunal Mehta
Hi, On 02/06/2017 02:28 AM, Dana Johnson wrote: > Package: mediawiki > Version: 1:1.27.1-3 > > > is trying to configure a dangling link: > > /etc/apache2/conf-available/mediawiki.conf -> /etc/mediawiki/apache.conf > > but apache.conf is installed instead as > > /etc/mediawiki/mediawiki.conf

Bug#852862: mediawiki: please have a NEWS file.

2017-01-30 Thread Kunal Mehta
Control: tags -1 pending On 01/30/2017 03:48 AM, shirish शिरीष wrote: > Beautiful, exactly what we need. Possible to push it in the next > update or something ? Yep. There should be a MediaWiki security release soon so I'll bundle it with that update. -- Kunal signature.asc Description:

Bug#852862: mediawiki: please have a NEWS file.

2017-01-29 Thread Kunal Mehta
Hi, On 01/27/2017 11:58 PM, shirish शिरीष wrote: > What seems to be missing is a high-level overview. For instance, if I > were to ask you what were the biggest 5-10 changes between mediawiki > 1.26 and mediawiki 1.27 I'm sure you would be able to share/tell in a > jiffy. > > That sort of

Bug#852862: mediawiki: please have a NEWS file.

2017-01-27 Thread Kunal Mehta
Hi, On 01/27/2017 04:17 PM, shirish शिरीष wrote: > Dear Maintainer, > I just had a look in mediawikis debian packaging via > > $ apt-get source --diff-only mediawiki > $ tar xvf mediawiki_1.27.1-3.debian.tar.xz > > and seeing the output of the resultant debian directory. I saw the >

Bug#850254: ITP: node-extract-zip -- unzip a zip file into a directory using 100% pure gluten-free organic javascript

2017-01-06 Thread Kunal Mehta
On 01/06/2017 05:04 AM, Holger Levsen wrote: > On Thu, Jan 05, 2017 at 05:21:11PM +0530, Sumedh Pendurkar wrote: >> Description : unzip a zip file into a directory using 100% pure >> gluten-free organic javascript > > uhm, could you please remove that "gluten-free organic" from the short >

Bug#849810: libpugixml-dev: Provide pugixml.pc for pkg-config support

2016-12-31 Thread Kunal Mehta
Package: libpugixml-dev Version: 1.7-2 Severity: wishlist Dear Maintainer, Please provide a pugixml.pc file for pkg-config support. According to the upstream maintainer[1], passing -DBUILD_PKGCONFIG=1 to cmake will enable the creation of this file. This option/functionality was added in 1.8

Bug#831424: RFP: parsoid -- Web service converting HTML+RDFa to MediaWiki wikitext and back

2016-12-30 Thread Kunal Mehta
Here's a quick overview of the dependencies that would need to be packaged/updated: $ LANG=C.UTF-8 npm2deb depends parsoid Dependencies: NPM Debian parsoid (0.6.1) None ├─ async (^0.9.2)

Bug#842628: forwarded

2016-12-30 Thread Kunal Mehta
I proposed your patch as a pull request upstream: . Thanks! signature.asc Description: OpenPGP digital signature

Bug#785612: patch

2016-12-29 Thread Kunal Mehta
Control: tags -1 patch I've attached a pretty simple patch that updates the link, link text, and switches the protocol to HTTPS. Index: developer.wml === --- developer.wml (revision 3584) +++ developer.wml (working copy) @@ -358,8

Bug#849257: dh-php: Vcs-Browser field is outdated

2016-12-24 Thread Kunal Mehta
Package: dh-php Version: 0.25 Severity: minor Dear Maintainer, The Vcs-Browser field points to a link that no longer works. It should probably point to instead. -- System Information: Debian Release: stretch/sid APT prefers unstable APT

Bug#849256: tideways: Please add Vcs-Git and Vcs-Browser fields

2016-12-24 Thread Kunal Mehta
Source: tideways Severity: minor Dear Maintainer, Please add Vcs-Git and Vcs-Browser fields to the debian/control file. I believe the following should be correct: Vcs-Browser: https://anonscm.debian.org/cgit/pkg-php/tideways.git/ Vcs-Git: git://anonscm.debian.org/pkg-php/tideways.git Thank

Bug#847293: php-ast: does not install ast.so

2016-12-06 Thread Kunal Mehta
Package: php-ast Version: 0.1.2-2 Severity: grave Justification: renders package unusable Dear Maintainer, Installing php-ast does not actually provide the ast.so file, so the extension isn't usable. $ apt-file list php-ast php-ast: /etc/php/7.0/mods-available/ast.ini php-ast:

Bug#846138: Upstream

2016-12-02 Thread Kunal Mehta
For reference, is the upstream ticket about fixing PHP 7 support, but there has been no recent activity on it. :( signature.asc Description: OpenPGP digital signature

Bug#845281: mediawiki: backport version does not play well with extensions

2016-11-27 Thread Kunal Mehta
Hi, On 11/23/2016 11:11 PM, Marc Dequènes (duck) wrote: > Quack, > > On 2016-11-24 14:41, Kunal Mehta wrote: > >> This is somewhat intentional as the new package only contains some of >> those packages (those that are shipped by upstream as part of the >>

Bug#845281: mediawiki: backport version does not play well with extensions

2016-11-23 Thread Kunal Mehta
Hi, On 11/21/2016 09:55 PM, Marc Dequènes (duck) wrote: > If you try to upgrade to the bpo version and you already add > mediawiki-extensions installed, the later is to be uninstalled. I > understand that the new mediawiki package replaces (and in fact > provides) the content of

Bug#843994: mediawiki: Please recommend also MariaDB

2016-11-12 Thread Kunal Mehta
Hi, On 11/11/2016 07:55 AM, Matteo Cypriani wrote: > Currently, with MariaDB installed, apt's default behaviour upon > installing mediawiki is to propose removal of mariadb-server and > installation of mysql-server. MediaWiki being officially compatible with > MariaDB [1], I believe the

Bug#842681: mediawiki: upgraded wiki (from squeeze) fails due to missing PSR-3

2016-11-03 Thread Kunal Mehta
On 11/01/2016 04:24 AM, Jonathan Dowland wrote: > Some more info: it's an sqlite-backended mediawiki, I'm not sure how it was > originally set up but it exists in a user's home directory with a lot of > symlinks into /usr/share/mediawiki. (was this a recommended way of deploying > mediawiki on

Bug#842681: mediawiki: upgraded wiki (from squeeze) fails due to missing PSR-3

2016-10-31 Thread Kunal Mehta
Hi, On 10/31/2016 03:47 AM, Jonathan Dowland wrote: > After doing so, our wiki says the following > >> MediaWiki requires the PSR-3 logging library to be present. This library is >> not embedded directly in MediaWiki's git repository and must be installed >> separately by the end user. Please

Bug#828097: Possible to keep old tidy?

2016-10-04 Thread Kunal Mehta
Hi, The upgrade of tidy to the newer version breaks what MediaWiki expects (see test failures: ), and updating MediaWiki to be compatible with the newer tidy isn't an option either:

Bug#838965: mediawiki: NEWS.Debian would be useful for the upgrade from 1.19 to 1.27

2016-09-29 Thread Kunal Mehta
Hi, On 09/27/2016 12:32 AM, John Lines wrote: > The fix, which should be in a NEWS.Debian, so users find it on upgrade, > rather than when > using the software, was Thanks for the suggestion, I've added a NEWS file for the next package version (),

Bug#838551: mediawiki: Update breaks mediawiki-extensions, leaving unusable system

2016-09-22 Thread Kunal Mehta
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi, On 09/22/2016 01:06 AM, Thomas Erichsen wrote: > Today I installed a pending upgrade for mediawiki, leaving my > system in a complete mess: obviously, the upgrade breaks > mediawiki-extensions, from which I used several and specifically > the

Bug#831874: mediawiki: fails to install: mediawiki.postinst: php5enmod: not found

2016-07-26 Thread Kunal Mehta
Hi, On 07/20/2016 05:11 AM, Andreas Beckmann wrote: > Selecting previously unselected package mediawiki. > (Reading database ... > (Reading database ... 9448 files and directories currently installed.) > Preparing to unpack .../mediawiki_1%3a1.27.0-1_all.deb ... > Unpacking mediawiki

Bug#831227: mediawiki: fails to upgrade from 'jessie' - trying to overwrite /var/lib/mediawiki/extensions/Cite

2016-07-15 Thread Kunal Mehta
Hi, On 07/14/2016 02:49 AM, Andreas Beckmann wrote: >>From the attached log (scroll to the bottom...): > > Selecting previously unselected package mediawiki. > Preparing to unpack .../mediawiki_1%3a1.25.5-1_all.deb ... > Unpacking mediawiki (1:1.25.5-1) ... > dpkg: error processing

Bug#829701: mediawiki: nōn-DFSG-free files in package

2016-07-13 Thread Kunal Mehta
severity 829701 minor block 829701 by 760306 thanks On 07/08/2016 02:34 AM, Thorsten Glaser wrote: > On Fri, 8 Jul 2016, Faidon Liambotis wrote: >> On Wed, Jul 06, 2016 at 12:21:36PM +0200, Thorsten Glaser wrote: >>> Let me quote: >>>You are authorized to use our trademarks subject to this

Bug#810290: Your mail

2016-07-11 Thread Kunal Mehta
Hi! On 07/08/2016 04:03 PM, Nye Liu wrote: > 1) Will upgrading from the legacy mediawiki 1.19.20 deb work seamlessly? I tested the upgrade path from the old 1.19 package to my new (not yet uploaded) 1.27 package on jessie, and for the most part, yes, it should just work. The package has a new

Bug#830780: ITP: texvc -- validates and converts LaTeX expressions into HTML, MathML or PNG

2016-07-11 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta <lego...@member.fsf.org> * Package name: texvc Version : 3.0.0+git20160613 Upstream Author : MediaWiki developers <wikitec...@lists.wikimedia.org> * URL : https://www.mediawiki.org/wiki/Texvc * License

Bug#829701: mediawiki: nōn-DFSG-free files in package

2016-07-06 Thread Kunal Mehta
which MediaWiki complies with), not copyright. -- Kunal Mehta

Bug#821633: php-wikidiff2: PHP 7.0 Transition

2016-06-13 Thread Kunal Mehta
This is currently being worked on upstream at and additionally tracked at . I additionally was able to fix up all the packaging to be compatible with PHP7 and use dh_php, but the upstream patch is currently

Bug#810290: ITP: mediawiki -- website engine for collaborative work

2016-03-10 Thread Kunal Mehta
On 03/10/2016 09:25 AM, The Wanderer wrote: > Is there any update or status on this? The package was rejected from the NEW queue last week due to some upstream copyright issues and lintian warnings. These issues have now been resolved and my sponsor should be uploading the new version to the NEW

Bug#789878: lintian: should not warn unusual-interpreter for hiphip virtual machine

2016-02-28 Thread Kunal Mehta
On Thu, 25 Jun 2015 10:42:31 +0200 Jakub Wilk wrote: > This is not a bug, at least for the time being. The primary purpose of > Lintian is to check packages that are going to be uploaded to Debian, > and there is no /usr/bin/hhvm in Debian yet. HHVM is now in Debian and will

Bug#810290: ITP: mediawiki -- website engine for collaborative work

2016-01-12 Thread Kunal Mehta
On 01/08/2016 09:23 PM, Paul Wise wrote: > Please remember to follow the steps needed when reintroducing packages: > > https://www.debian.org/doc/manuals/developers-reference/pkgs.html#reintroducing-pkgs Thanks for the link :-) The package was removed because it was severely out of date, using a

Bug#810290: ITP: mediawiki -- website engine for collaborative work

2016-01-07 Thread Kunal Mehta
Package: wnpp Severity: wishlist Owner: Kunal Mehta <lego...@member.fsf.org> * Package name: mediawiki Version : 1.25.5 Upstream Author : MediaWiki developers <wikitec...@lists.wikimedia.org> * URL : https://www.mediawiki.org/ * License : GPL-2.0+

Bug#756888: ITP: python-mwparserfromhell - a parser for MediaWiki wikicode

2014-08-02 Thread Kunal Mehta
Package: wnpp Severity: wishlist * Package name: python-mwparserfromhell Version : 0.3.3 Upstream Author : Ben Kurtovic ben.kurto...@gmail.com * URL : https://github.com/earwig/mwparserfromhell * License : Expat Programming Lang: Python, C Description :