Bug#901296: luabind is outdated, please fix it with one or more of the forks with a recent version

2018-06-10 Thread shirish शिरीष
Source: luabind Severity: wishlist Dear Maintainer, There are number of issues with the version of luabind in Debian. The homepage given is no longer available and hence I guess even the upstream sources are no longer available. I have been trying to work with couple of upstream games which use

Bug#891706: #891706 ITP: golang-github-tonistiigi-fsutil -- Incremental file directory sync tools in golang

2018-06-10 Thread Dmitry Smirnov
On Monday, 11 June 2018 2:53:12 PM AEST Arnaud Rebillout wrote: > I didn't push this package to salsa yet. The issue I have is that it > depends on docker-dev, and it doesn't have any vendoring, so I can't > keep the vendored directory with a smart "Files-Excluded" field. The > solution I came up

Bug#901148: timidity: upgrading to 2.14.0-2 broke sound in KDE plasma

2018-06-10 Thread Arthur Marsh
Package: timidity Followup-For: Bug #901148 Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? * What exactly did you do (or not do) that was effective (or ineffective)? Upgrading to timidity 2.14.0-3 and

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Mon, Jun 11, 2018 at 1:05 AM, Chris Lamb wrote: > > > Hi Bastien ROUCARIES, > >> On Mon, Jun 11, 2018 at 12:07 AM, Chris Lamb wrote: >> > Hi Bastien, >> > >> >> > Unfortunately, I don't think these commits reach the level of quality >> >> > that Debian Developers would expect from Lintian. >>

Bug#891706: #891706 ITP: golang-github-tonistiigi-fsutil -- Incremental file directory sync tools in golang

2018-06-10 Thread Arnaud Rebillout
On 06/11/2018 11:47 AM, Dmitry Smirnov wrote: > Also could you please ask upstream to tag releases? https://github.com/tonistiigi/fsutil/issues/43

Bug#891706: #891706 ITP: golang-github-tonistiigi-fsutil -- Incremental file directory sync tools in golang

2018-06-10 Thread Arnaud Rebillout
Hi ! On 06/11/2018 11:47 AM, Dmitry Smirnov wrote: > There is no repository under > > https://salsa.debian.org/go-team/packages?filter=fsutil I didn't push this package to salsa yet. The issue I have is that it depends on docker-dev, and it doesn't have any vendoring, so I can't keep the

Bug#901295: apt-cacher-ng.8: typo: that vs those

2018-06-10 Thread Paul Wise
Package: apt-cacher-ng Version: 3.1-1 Severity: minor File: /usr/share/man/man8/apt-cacher-ng.8.gz There is a typo in the manual page, it uses the word 'that' where the word 'those' should be used instead. $ man apt-cacher-ng | grep -C1 that Variables can override previously configured

Bug#901293: matrix-synapse: Improper event filtering in get_missing_events handler

2018-06-10 Thread Salvatore Bonaccorso
Source: matrix-synapse Version: 0.30.0+dfsg-1 Severity: grave Tags: patch security upstream Forwarded: https://github.com/matrix-org/synapse/pull/3371 Control: fixed -1 0.31.1+dfsg-1 From https://matrix.org/blog/2018/06/08/synapse-0-31-1-released/ > v0.31.1 fixes a security bug in the

Bug#901294: apt-cacher-ng.8: typo: find vs found

2018-06-10 Thread Paul Wise
Package: apt-cacher-ng Version: 3.1-1 Severity: minor File: /usr/share/man/man8/apt-cacher-ng.8.gz There is a typo in the manual page, it uses 'find' where the past tense equivalent 'found' should be used instead: $ man apt-cacher-ng | grep -B1 find Scan the specified

Bug#644998: iftop: chooses eth0 as the default interface instead of the default route

2018-06-10 Thread Shawn Landden
Package: iftop Version: 1.0~pre4-4 Followup-For: Bug #644998 New version of the patch that supports ipv6-only hosts -- System Information: Debian Release: 9.4 APT prefers stable-updates APT policy: (500, 'stable-updates'), (500, 'stable') Architecture: amd64 (x86_64) Kernel: Linux

Bug#891706: #891706 ITP: golang-github-tonistiigi-fsutil -- Incremental file directory sync tools in golang

2018-06-10 Thread Dmitry Smirnov
There is no repository under https://salsa.debian.org/go-team/packages?filter=fsutil Also could you please ask upstream to tag releases? Thanks. -- All the best, Dmitry Smirnov --- Human beings, who are almost unique in having the ability to learn from the experience of others, are also

Bug#901292: apt-cacher-ng.8: typo: -c vs -C

2018-06-10 Thread Paul Wise
Package: apt-cacher-ng Version: 3.1-1 Severity: minor File: /usr/share/man/man8/apt-cacher-ng.8.gz There is a typo in the manual page, it says -C is used for adjusting the configuration directory but earlier in the manual page it says -c is used for that. Running the binary confirms that the -C

Bug#901291: RFA: pynliner -- CSS-to-inline-styles conversion tool for HTML - Python 2.x

2018-06-10 Thread Sandro Tosi
Package: wnpp Severity: normal I request an adopter for the pynliner package. The package description is: Because Pynliner uses BeautifulSoup to find the tags specified in the CSS it aggressively converts to HTML. This means that templating languages like Mako, Genshi, and Jinja will be

Bug#901290: chromium: version 68 arm build causes internal compiler error

2018-06-10 Thread Michael Gilbert
package: src:chromium-browser severity: grave version: 68.0.3440.7-1 The version just uploaded to experimental causes an internal compiler error in gcc on arm [0]. Best wishes, Mike [0]https://buildd.debian.org/status/package.php?p=chromium-browser=experimental

Bug#901021: Provide a GTK+ 2 version of Chromium.

2018-06-10 Thread Michael Gilbert
On Sun, Jun 10, 2018 at 11:34 PM, Gong S wrote: >>This is normal. GTK2 will eventually be deprecated, just like GTK1 > But GTK3 is dumbed down and lacks many configurations present in GTK2. Also, > it uses `dconf` and has no bitmap font support. > Also, existing GTK2 themes cannot be used in

Bug#901289: Drop the `logsave` requirement in `/etc/init.d/checkfs.sh`.

2018-06-10 Thread Gong S____
Package: initscripts Version: 2.88dsf-59.10 The current version used `logsave` to save `fsck` results. When `logsave` is not present, the script will fail regardless of the actual FS state. /etc/init.d/checkfs.sh line 101 and 121: logsave -s $FSCK_LOGFILE fsck $spinner -M -A $fix $force

Bug#901254: gnome-terminal: unable to init server, failed with result 'signal', segfault at 8

2018-06-10 Thread Ernesto Alfonso
I'm not aware of using broadway. I don't have a broadway service based on service --status-all, a broadwayd executable, nor either of the packages libgtk-3-bin libgtk-3-0-dbg installed in my system. On Sun, Jun 10, 2018 at 7:27 PM Jason Crain wrote: > On 2018-06-10, Ernesto Alfonso wrote: > >

Bug#901041: libviennacl-doc: fails to upgrade from 'testing' - trying to overwrite /usr/share/doc/libviennacl-dev/README.gz

2018-06-10 Thread Andreas Beckmann
Followup-For: Bug #901041 Control: found -1 1.7.1+dfsg1-4 You fixed the wrong problem. The Breaks+Replaces may still be needed, but the underlying problem is not fixed - both libviennacl-dev and libviennacl-doc ship these files: usr/share/doc/libviennacl-dev/README.gz

Bug#901048: gnat-*-x86-64-linux-gnu: missing Conflicts: gnat-5, gnat-6

2018-06-10 Thread Andreas Beckmann
On 2018-06-08 17:51, Matthias Klose wrote: > you should not run piuparts against outdated binaries. These tests take everything available in the Packages files ... >  I filed #899045 > to remove these packages, but that didn't get yet processed.  Closing > this issue now. Interestingly these

Bug#901185: remove unlisted bash dependecy

2018-06-10 Thread 積丹尼 Dan Jacobson
Why use bash at all if e.g., $ checkbashisms /usr/sbin/update-exim4.conf.template could not find any possible bashisms in bash script /usr/sbin/update-exim4.conf.template means one can just use #!/bin/sh ?

Bug#901220: libreoffice-dictionaries: FTBFS: can't cd to /<>/debian/hunspell-es/usr/share/hunspell

2018-06-10 Thread Andreas Beckmann
Hi Rene, On 2018-06-10 11:10, Rene Engelhard wrote: > On Sun, Jun 10, 2018 at 10:56:31AM +0200, Andreas Beckmann wrote: >> libreoffice-dictionaries/experimental FTBFS: > Yes, I have seen this. I *do* look at buildlogs after uploads. Unfortunately not everone does ... Anyway, I just needed a bug

Bug#901254: gnome-terminal: unable to init server, failed with result 'signal', segfault at 8

2018-06-10 Thread Jason Crain
On 2018-06-10, Ernesto Alfonso wrote: > I'm suddenly unable to start gnome terminal after an unexpected shutdown due > to a hard-disk being > removed while the system was running. > > Looking at the logs, I see the following: > > >Jun 10 09:26:21 debian-x1 systemd[1008]: Starting GNOME

Bug#901283: iftop: v4tunnel support (IPv6 tunnels like Hurricane Electric)

2018-06-10 Thread Shawn Landden
Package: iftop Version: 1.0~pre4-4 Followup-For: Bug #901283 Dear Maintainer, submitted upstream: https://github.com/the-tcpdump-group/libpcap/issues/725 -- System Information: Debian Release: 9.4 APT prefers stable-updates APT policy: (500, 'stable-updates'), (500, 'stable') Architecture:

Bug#644998: iftop: chooses eth0 as the default interface instead of the default route

2018-06-10 Thread Shawn Landden
> > Here is a patch to fix the problem. > This will make iftop (soft) depend on "iproute2"

Bug#644998: iftop: chooses eth0 as the default interface instead of the default route

2018-06-10 Thread Shawn Landden
Package: iftop Version: 1.0~pre4-4 Followup-For: Bug #644998 tags 644998 patch Dear Maintainer, Here is a patch to fix the problem. submitted upstream: http://lists.beasts.org/pipermail/iftop-users/2018-June/000472.html -- System Information: Debian Release: 9.4 APT prefers stable-updates

Bug#867461: Bug#858539: should ca-certificates certdata.txt synchronize across all suites?

2018-06-10 Thread Michael Shuler
On 06/08/2018 03:37 PM, Adam D. Barratt wrote: Ping? We're a week away from the final chance to get an update into jessie-as-oldstable before it becomes jessie-lts. Thanks for the ping. I updated the debian-jessie branch of ca-certificates with mozilla bundle 2.22, and it's ready to be

Bug#901287: RFS: deepin-qt5dxcb-plugin/1.1.8.8-1

2018-06-10 Thread Yanhao Mo
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "deepin-qt5dxcb-plugin" * Package name: deepin-qt5dxcb-plugin Version : 1.1.8.8-1 Upstream Author : Deepin Technology Co., Ltd. * URL :

Bug#901286: RFS: deepin-screenshot/4.0.15-1

2018-06-10 Thread Yanhao Mo
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "deepin-screenshot" * Package name: deepin-screenshot Version : 4.0.15-1 Upstream Author : Deepin Technology Co., Ltd. * URL :

Bug#901284: RFS: deepin-movie-reborn/3.2.7-1

2018-06-10 Thread Yanhao Mo
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "deepin-movie-reborn" * Package name: deepin-movie-reborn Version : 3.2.7-1 Upstream Author : Deepin Technology Co., Ltd. * URL :

Bug#901285: RFS: deepin-notifications/3.3.3-1

2018-06-10 Thread Yanhao Mo
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "deepin-notifications" * Package name: deepin-notifications Version : 3.3.3-1 Upstream Author : Deepin Technology Co., Ltd. * URL :

Bug#899267: Reopen: Bug#899267: ruby2.5: FTBFS on kfreebsd-any

2018-06-10 Thread Antonio Terceiro
On Sun, 10 Jun 2018 23:38:18 +0200 Svante Signell wrote: > reopen -1 > found 899267 2.5.1-2 > thanks > > Hello, > > Unfortunately the patch 0006-fix-kfreebsd-build.patch was not applied, > resulting in a failing build. I'm attaching that file again, now named > 0007-fix-kfreebsd-build.patch

Bug#884484: python-cryptography-vectors/2.2.2-1 appears to break python-cryptography in testing

2018-06-10 Thread Tristan Seligmann
On Sun, 10 Jun 2018 at 21:57 Paul Gevers wrote: > Hi > > On 10-06-18 21:34, Tristan Seligmann wrote: > > -vectors exists purely for the benefit of the tests, nothing outside the > > tests uses the vectors. If you are not running the tests, having a > > mismatched version of -vectors will have no

Bug#901283: iftop: v4tunnel support (IPv6 tunnels like Hurricane Electric)

2018-06-10 Thread Shawn Landden
Package: iftop Version: 1.0~pre4-4 Severity: wishlist Dear Maintainer, It would be nice if you could attach iftop to v4tunnels. Instead iftop reports nothing for such interfaces, and reports the traffic under the ipv4 interface as a single connection to the ipv4 end of the tunnel. Here is my

Bug#884440: zimlib: Please package new 3.1.0 upstream version

2018-06-10 Thread Kunal Mehta
retitle 884440 Please package new 3.3.0 upstream version thanks upstream is now at 3.3.0. I went ahead and prepared most of the packaging for this at . Would it help if I created a merge request on salsa? The remaining tasks should be

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien, > On Mon, Jun 11, 2018 at 12:07 AM, Chris Lamb wrote: > > Hi Bastien, > > > >> > Unfortunately, I don't think these commits reach the level of quality > >> > that Debian Developers would expect from Lintian. > >> > >> Ok could you get a glimpse at README branch > > > > Could you

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien ROUCARIES, > On Mon, Jun 11, 2018 at 12:07 AM, Chris Lamb wrote: > > Hi Bastien, > > > >> > Unfortunately, I don't think these commits reach the level of quality > >> > that Debian Developers would expect from Lintian. > >> > >> Ok could you get a glimpse at README branch > > > >

Bug#901274: [lintian] warn about *.md,.eslinltrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien ROUCARIES, > On Mon, Jun 11, 2018 at 12:07 AM, Chris Lamb wrote: > > Hi Bastien, > > >> > Unfortunately, I don't think these commits reach the level of quality > >> > that Debian Developers would expect from Lintian. > >> > >> Ok could you get a glimpse at README branch > > > >

Bug#901185: [Debconf-devel] Bug#901185: me too

2018-06-10 Thread Colin Watson
On Sun, Jun 10, 2018 at 04:04:13PM +0200, Andreas Metzler wrote: > On 2018-06-10 Colin Watson wrote: > > On Sun, Jun 10, 2018 at 03:03:28PM +0200, Andreas Metzler wrote: > >> I have tried debugging the issue to get a minimal testcase. I have had > >> some success. The issue is triggered by

Bug#899006: stretch-pu: package intel-microcode/3.20180425.1~deb9u1

2018-06-10 Thread Henrique de Moraes Holschuh
On Sat, 09 Jun 2018, Adam D. Barratt wrote: > Control: tags -1 + confirmed > > On Fri, 2018-05-18 at 10:32 -0300, Henrique de Moraes Holschuh wrote: > > I'd like to update the intel-microcode package in Debian stretch. > > > > This update adds the microcode-side fix for CVE-2017-5715 aka Spectre

Bug#901243: nm-applet

2018-06-10 Thread Le Déchaîné
I'm guessing it's the same for nm-applet. I got no network manager applet and trash applet either. System/Preferences is kinda empty too. It may be the reason why I have to login and "startx" now (well... sudo ifconfig eth0 up, sudo dhclient, and then startx). Some interesting logs/crash.

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Mon, Jun 11, 2018 at 12:07 AM, Chris Lamb wrote: > Hi Bastien, > >> > Unfortunately, I don't think these commits reach the level of quality >> > that Debian Developers would expect from Lintian. >> >> Ok could you get a glimpse at README branch > > Could you move the other changes to this

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien, > > Unfortunately, I don't think these commits reach the level of quality > > that Debian Developers would expect from Lintian. > > Ok could you get a glimpse at README branch Could you move the other changes to this branch too (or a "901274" branch/MR or something?) :) Best

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Sun, Jun 10, 2018 at 11:09 PM, Chris Lamb wrote: > Hi Bastien > >> Just see it. Will corects thanks > > May I kindly suggest doing this work on a branch? > > I am happy to review your grammar and spelling but I would very much > like to keep the "master" branch releasable at any time. > >

Bug#898809: lintian -F internal error: cannot run shared-libs check on package binary

2018-06-10 Thread Chris Lamb
tags 898809 + pending thanks Fixed in Git, pending upload: https://salsa.debian.org/lintian/lintian/commit/b8e38a685f1bd13217c7ae7e89b455a296177b33 debian/changelog | 5 + helpers/coll/objdump-info-helper | 3 ++- 2 files changed, 7 insertions(+), 1 deletion(-)

Bug#777439: Hello..........

2018-06-10 Thread Rosita
Hello my dear My name is Rosita i am interested in you please i will like us to know much better if you don't mind you can reply me in this email,(rosita.di...@yahoo.com)so that i can send you my picture and tell you more about myself, i will wait for your reply thank you,from Rosita

Bug#901021: Provide a GTK+ 2 version of Chromium.

2018-06-10 Thread Michael Gilbert
control: tag -1 wontfix control: severity -1 wishlist On Fri, Jun 8, 2018 at 12:51 AM, USER 65534 wrote: > Starting from version 63.0.3239.84-1, Chromium is compiled against GKT+ 3. > This is a bad idea. > I have noticed the huge trend in Debian's repo. More and more packages are > compiled

Bug#901269: radeontop FTCBFS: uses the build architecture pkg-config

2018-06-10 Thread John Paul Adrian Glaubitz
Hi Helmut! On 06/10/2018 08:55 PM, Helmut Grohne wrote: > Please consider applying the attached patch. Thanks for the patch. Wouldn't it make more sense though to just send the patch upstream? Upstream has a github repository, so opening a pull request should be easy. I can do that if you don't

Bug#899267: Reopen: Bug#899267: ruby2.5: FTBFS on kfreebsd-any

2018-06-10 Thread Svante Signell
reopen -1 found 899267 2.5.1-2 thanks Hello, Unfortunately the patch 0006-fix-kfreebsd-build.patch was not applied, resulting in a failing build. I'm attaching that file again, now named 0007-fix-kfreebsd-build.patch Thanks! On Mon, 2018-05-21 at 21:45 +, Debian Bug Tracking System wrote:

Bug#901282: anarchism: typo in section C9

2018-06-10 Thread Jeff Cliff
Package: anarchism Version: 15.0-2 Severity: minor Tags: patch Dear Maintainer, as per ubuntu bug https://bugs.launchpad.net/ubuntu/+source/anarchism/+bug/1412104 in both 15.0-2 and 15.1-6, there is an extra 'e' in 'meet' ( Expectations are not "meet", expectations are met ) in section C9

Bug#898024: [Pkg-javascript-devel] Bug#898024: Bug#898024: trying to overwrite '/usr/include/nodejs/common.gypi', which is also in package nodejs-dev 10.0.0~dfsg-2

2018-06-10 Thread Jonas Smedegaard
Quoting Jérémy Lal (2018-06-10 22:04:43) > 2018-06-10 20:14 GMT+02:00 Jonas Smedegaard : > > Quoting Jérémy Lal (2018-06-10 16:51:14) > > > 2018-06-10 10:26 GMT+02:00 Andreas Beckmann : > > > > The 8 -> 10 upgrade path does not work either: > > > > > > > > Selecting previously unselected package

Bug#901281: O: doschk -- SYSV and DOS filename conflicts check

2018-06-10 Thread Ben Pfaff
Package: wnpp Severity: normal This package has no reported bugs, the last upstream release was in 1993, and zero recent users according to popularity-contest (https://qa.debian.org/popcon.php?package=doschk). It has questionable value these days. If no one wants to adopt it, it can probably be

Bug#873456: Bug#876075: Bug#879048: Bug#876075: Anchors are non-unique in the single-HTML version

2018-06-10 Thread Bill Allombert
On Sun, Jun 10, 2018 at 03:01:51PM +0200, Bill Allombert wrote: > On Sun, Jun 10, 2018 at 01:37:11PM +0100, Sean Whitton wrote: > > Hello all, > > > > On Mon, Dec 25 2017, Russ Allbery wrote: > > > > > I'm not sure where we landed with this, but it feels like the > > > single-HTML output from

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien > Just see it. Will corects thanks May I kindly suggest doing this work on a branch? I am happy to review your grammar and spelling but I would very much like to keep the "master" branch releasable at any time. Unfortunately, I don't think these commits reach the level of quality

Bug#900838: menu: Use noawait triggers

2018-06-10 Thread Bill Allombert
On Thu, Jun 07, 2018 at 02:23:15PM -0700, Julian Andres Klode wrote: > On Thu, Jun 07, 2018 at 10:57:54PM +0200, Bill Allombert wrote: > > On Thu, Jun 07, 2018 at 09:57:51AM -0700, Julian Andres Klode wrote: > > > > Are you sure the upgrade failure are not caused by another patch that it > > > >

Bug#901185: Checkbashisms

2018-06-10 Thread 積丹尼 Dan Jacobson
I also note /etc/exim4/update-exim4.conf.conf got overwritten without asking the user Y/N. I also note exim4-config contains #!/bin/bash scripts without Depends: bash. D> Be sure the package passes Checkbashisms! JN> Which package? Is there a particular bashism you noticed? All the shell

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Sun, Jun 10, 2018 at 10:59 PM, Chris Lamb wrote: > Hi Bastien, > >> Will begin to wrok on this bug > > (I trust you are seeing my comments on salsa.) Just see it. Will corects thanks Sorry for the delay I was removing a scratch on my screen with toothpaste... Bastien > > Regards, > > -- >

Bug#900545: dput: Emit error response body as a debug message

2018-06-10 Thread Alexandre Viau
On Sun, 10 Jun 2018 14:41:59 +1000 Ben Finney wrote: > I have an implementation of this feature, that is awaiting review at > https://salsa.debian.org/debian/dput/merge_requests/1>. Thank you for your work! I have tested and reviewed your merge request[1]. 1.

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien, > Will begin to wrok on this bug (I trust you are seeing my comments on salsa.) Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#901280: Hangs when creating a new files or opening an existing file

2018-06-10 Thread Gaudenz Steinlin
Package: quickroute-gps Version: 2.4-15 Severity: important Hi If I create a new file, select a map image and GPX route and then click on OK, quickroute just hangs indefinitely without using much CPU. The same happens when I open a QRT file created on Windows. The same map image and GPX track

Bug#897242:

2018-06-10 Thread Michael Gilbert
version: 67.0.3396.62-2

Bug#901255: netcfg-static: Unable to configure fe80::1 as a gateway

2018-06-10 Thread Philipp Kern
On 6/10/18 7:25 PM, Samuel Thibault wrote: > Igor Scheller, le dim. 10 juin 2018 18:57:50 +0200, a ecrit: >> When I try to configure fe80::1 (next router) as a gateway in an IPv6 only >> network the installer stops with an "Unreachable gateway" error. >> >> Looking at

Bug#901215: mirror submission for freedom.dicea.unifi.it

2018-06-10 Thread Leonardo Boselli
On Sun, 10 Jun 2018, Marco d'Itri wrote: On Jun 10, Leonardo Boselli wrote: Archive-http: /ftp/pub/linux/debian/ We are trying not to add new mirrors that do not use the standard /debian/ path. I see that it works, would it be OK for you to advertise it? non posso dirtelo ora, e comunque

Bug#901257: Please consider adopting zchunk for efficient updates

2018-06-10 Thread David Kalnischkies
On Sun, Jun 10, 2018 at 07:14:55PM +0200, Michael Stapelberg wrote: > The zchunk format, outlined in the post, is being introduced in Fedora for > efficient metadata transfer. As I understand it, zchunk isn't competition for pdiff (per se), but competition for the compressed files xz/bz2/gz as

Bug#901279: grub-common: update-grub overwrites /boot/grub/grub.cfg

2018-06-10 Thread Greg Alexander
Package: grub-common Version: 2.02+dfsg1-4 Severity: important Dear Maintainer, I upgraded from an old version of grub using Debian's "apt-get install grub-pc", and it overwrote my /boot/grub/grub.cfg without prompting me, and without making a backup copy. My old grub.cfg was hand-crafted,

Bug#895868: munin-cron: Fontconfig error: failed reading config file

2018-06-10 Thread Lars Kruse
Source: munin Followup-For: Bug #895868 Hello, I took a look at the bugs reported for fontconfig [1]. I did not find a description of this problem. Maybe someone could report it there? Since munin is likely only affected indirectly by this problem, we should probably solve it in fontconfig,

Bug#900203: guile-2.2 FTCBFS for mipsel: In procedure load-thunk-from-memory: No such file or directory

2018-06-10 Thread Rob Browning
[If possible, please preserve the 900203-forwarded address in replies] We're currently unable to cross-build guile 2.2 on all of the debian release architectures, which is important given that through make, etc., guile's now part of the core bootstrap set for new architectures. You can see

Bug#901278: apt removing packages: Depends: xorg-video-abi-23 which is a virtual package...

2018-06-10 Thread 積丹尼 Dan Jacobson
Package: xserver-xorg-video-nvidia-legacy-304xx Version: 304.137-5 Every day apt(itude) asks me to remove the package: xserver-xorg-video-nvidia-legacy-304xx : Depends: xorg-video-abi-23 which is a virtual package, provided by: -

Bug#898024: [Pkg-javascript-devel] Bug#898024: Bug#898024: trying to overwrite '/usr/include/nodejs/common.gypi', which is also in package nodejs-dev 10.0.0~dfsg-2

2018-06-10 Thread Jérémy Lal
2018-06-10 20:14 GMT+02:00 Jonas Smedegaard : > Hi Jérémy, > > Quoting Jérémy Lal (2018-06-10 16:51:14) > > 2018-06-10 10:26 GMT+02:00 Andreas Beckmann : > > > The 8 -> 10 upgrade path does not work either: > > > > > > Selecting previously unselected package libnode64-dev. > > > Preparing to

Bug#901277: node-mime: CVE-2017-16138

2018-06-10 Thread Salvatore Bonaccorso
Source: node-mime Version: 1.3.4-1 Severity: important Tags: security upstream Forwarded: https://github.com/broofa/node-mime/issues/167 Hi, The following vulnerability was published for node-mime. CVE-2017-16138[0]: | The mime module is vulnerable to regular expression denial of service | when

Bug#884484: python-cryptography-vectors/2.2.2-1 appears to break python-cryptography in testing

2018-06-10 Thread Paul Gevers
Hi On 10-06-18 21:34, Tristan Seligmann wrote: > -vectors exists purely for the benefit of the tests, nothing outside the > tests uses the vectors. If you are not running the tests, having a > mismatched version of -vectors will have no effect. Thanks for clarifying. Just for my understanding,

Bug#898809: lintian -F internal error: cannot run shared-libs check on package binary

2018-06-10 Thread Chris Lamb
atthias Klose wrote: > This causes the gcc-8-cross packages built on amd64 and i386 failing the > lintian > -F check during upload (packages at p.d.o/~d.../tmp). > > $ lintian -F ../gcc-8-cross_16_amd64.changes 2>&1 | tee ../log.lintian > Use of uninitialized value $lib in pattern match (m//)

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Sun, Jun 10, 2018 at 9:33 PM, Bastien ROUCARIES wrote: > On Sun, Jun 10, 2018 at 9:31 PM, Chris Lamb wrote: >> Hi Bastien, >> >>> > (This seems like a candidate for data/files/fnames.) >>> >>> Will add the fonts name ASAP, thanks >> >> I don't understand this, sorry... My remark about

Bug#884484: python-cryptography-vectors/2.2.2-1 appears to break python-cryptography in testing

2018-06-10 Thread Tristan Seligmann
On Sun, 10 Jun 2018 at 21:06 Paul Gevers wrote: > need to stay in lock step. In this bug (#884484) the solution was to > tighten the test dependencies, which is one way to achieve this (albeit > it will only work for the next time without the help of the RT or me), > but I wonder if this

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Sun, Jun 10, 2018 at 9:31 PM, Chris Lamb wrote: > Hi Bastien, > >> > (This seems like a candidate for data/files/fnames.) >> >> Will add the fonts name ASAP, thanks > > I don't understand this, sorry... My remark about data/files/fnames > refers to this entire bug report, not to the fonts

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Hi Bastien, > > (This seems like a candidate for data/files/fnames.) > > Will add the fonts name ASAP, thanks I don't understand this, sorry... My remark about data/files/fnames refers to this entire bug report, not to the fonts specifically. Regards, -- ,''`. : :' : Chris

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIES
On Sun, Jun 10, 2018 at 9:25 PM, Chris Lamb wrote: > Bastien, > >> Documentation file (*.md, LICENSE, CHANGES, PATENTS) do not belong to this >> dir >> >> .eslintrc are jslint config file and should not be installed >> >> .npmignore is used in order to publish file under npm so do not install >>

Bug#900410: mtools: please make the output reproducible (directory timestamps)

2018-06-10 Thread Chris Lamb
Dear Vagrant, > > + else if (*endptr != '\0') > > + fprintf(stderr, "SOURCE_DATE_EPOCHh has > > trailing garbage\n"); > > > Minor typo in error message? Or is the error message trying to indicate > the problem by example? :) Very well spotted. I'll

Bug#900410: mtools: please make the output reproducible (directory timestamps)

2018-06-10 Thread Vagrant Cascadian
On 2018-05-30, Chris Lamb wrote: > Chris Lamb wrote: > Updated patch attached - I left a debug "printf" call in there by > accident. ... > + else if (*endptr != '\0') > + fprintf(stderr, "SOURCE_DATE_EPOCHh has > trailing garbage\n"); Minor typo

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Chris Lamb
Bastien, > Documentation file (*.md, LICENSE, CHANGES, PATENTS) do not belong to this dir > > .eslintrc are jslint config file and should not be installed > > .npmignore is used in order to publish file under npm so do not install > > *.woff, *.ttf, *.woff. are fonts so go to fonts package

Bug#901275: ipvsadm FTCBFS: uses the build architecture pkg-config

2018-06-10 Thread Helmut Grohne
Source: ipvsadm Version: 1:1.28-3 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap ipvsadm fails to cross build from source, because the upstream build system hard codes the build architecture pkg-config. After making it substitutable, ipvsadm cross builds successfully. Please

Bug#901276: jessie-pu: package lame/3.99.5+repack1-7+deb8u2

2018-06-10 Thread Hugo Lefeuvre
Package: release.debian.org Severity: normal Tags: jessie User: release.debian@packages.debian.org Usertags: pu Hi, lame 3.99.5+repack1-7+deb8u1 is affected by several vulnerabilities in the code used to read the input file. These issues are not present in any Debian release after Jessie

Bug#900918: debian-installer: Please make the generated images reproducible

2018-06-10 Thread Vagrant Cascadian
Control: block 900918 by 900409 900410 This requires fixes to mtools, marked as blocking bugs. live well, vagrant signature.asc Description: PGP signature

Bug#901273: bootpc FTCBFS: does not pass cross tools to make

2018-06-10 Thread Helmut Grohne
Source: bootpc Version: 0.64-7 Tags: patch User: helm...@debian.org Usertags: rebootstrap bootpc fails to cross build from source, because it does not pass cross tools to make. After indirecting make through dh_auto_build, bootpc cross builds successfully. Please consider applying the attached

Bug#901274: [lintian] warn about *.md,.eslintrc, .npmignore, LICENSE, CHANGES, PATENTS, *.woff, *.ttf, *.woff.? under /usr/lib/node (may be /usr/lib ?)

2018-06-10 Thread Bastien ROUCARIÈS
Package: lintian Version: 2.5.89 Severity: normal Hi, Documentation file (*.md, LICENSE, CHANGES, PATENTS) do not belong to this dir .eslintrc are jslint config file and should not be installed .npmignore is used in order to publish file under npm so do not install *.woff, *.ttf, *.woff. are

Bug#901256: dak: dakweb: allow for looking up files by sha256sum

2018-06-10 Thread Chris Lamb
forwarded 901256 https://salsa.debian.org/ftp-team/dak/merge_requests/76 thanks Hi Alexandre et al., > Please consider applying the attached patch which also fixes an error in > the docstring of file_in_archive. Just to close the loop, this was "forwarded" as an MR here.

Bug#901272: atomix FTCBFS: configures for the build architecture

2018-06-10 Thread Helmut Grohne
Source: atomix Version: 3.22.0-2 Tags: patch User: helm...@debian.org Usertags: rebootstrap atomix fails to cross build from source, because it configures for the build architecture. It actually configures twice. Once through autogen.sh and another time through dh_auto_configure. The first

Bug#901271: ntpstat FTCBFS: does not pass cross tools to make

2018-06-10 Thread Helmut Grohne
Source: ntpstat Version: 0.0.0.1-1 Tags: patch User: helm...@debian.org Usertags: rebootstrap ntpstat fails to cross build from source, because it does not pass cross tools to make. The easiest way to fix that is removing the override_dh_auto_build, because dh_auto_build does what is needed for

Bug#884484: python-cryptography-vectors/2.2.2-1 appears to break python-cryptography in testing

2018-06-10 Thread Paul Gevers
Dear maintainers, With a recent upload of python-cryptography-vectors the autopkgtest of python-cryptography version 2.1.4-1 started to fail in testing. See: https://ci.debian.net/packages/p/python-cryptography/testing/amd64/ and

Bug#901270: trickle FTCBFS: configures for the build architecture

2018-06-10 Thread Helmut Grohne
Source: trickle Version: 1.07-10.1 Tags: patch User: helm...@debian.org Usertags: rebootstrap trickle fails to cross build from source, because it configures for the build architecture. The easiest way of fixing that is using dh_auto_configure. After doing so trickle continues to fail due to its

Bug#900552: Bug #900552: Add privacy policy to the Debian website

2018-06-10 Thread Laura Arjona Reina
Hello all I have read the document and I have some questions and comments. 1.- Once that we publish a "Privacy Policy" document in the website, if there are changes to the text, do we need to do something "special"? (e.g. put a banner in the site saying "we have updated our privacy policy", or

Bug#901269: radeontop FTCBFS: uses the build architecture pkg-config

2018-06-10 Thread Helmut Grohne
Source: radeontop Version: 1.0-1 Tags: patch User: helm...@debian.org Usertags: rebootstrap radeontop fails to cross build from source, because the upstream Makefile hard codes the build architecture pkg-config. After making it substitutable, it still fails, because make install insists on

Bug#901268: libsoil FTCBFS: uses the build architecture compiler

2018-06-10 Thread Helmut Grohne
Source: libsoil Version: 1.07~20080707.dfsg-4 Tags: patch User: helm...@debian.org Usertags: rebootstrap libsoil fails to cross build from source, because it does not pass cross tools to make. Using dh_auto_build is the easiest way to fix that. Still the alternate makefile hard codes gcc in one

Bug#901228: lintian: False positive for "r => littler (usr/lib/R/site-library/rjson/rpc_server/server.r) #!/usr/bin/r"

2018-06-10 Thread Chris Lamb
tags 901228 + pending thanks Fixed in Git, pending upload: https://salsa.debian.org/lintian/lintian/commit/95eaa1261286f18a8e286cec184f5f1a970336c3 data/scripts/interpreters | 2 +- debian/changelog | 4 2 files changed, 5 insertions(+), 1 deletion(-) Regards, --

Bug#899384: vlc: Hardware acceleration fails after upgrade to 3.0.2

2018-06-10 Thread Antoni Marcinek
OK. So basically this means 3 possible upstreams: optirun, Qt or VLC, since I guess this is beyond Debian. I think you can close the issue. Actually I managed to find a workaround that I will report at https://forum.videolan.org/viewtopic.php?f=13=144411 as I still believe that there is a

Bug#901085: libur-perl: FTBFS with Perl 5.28: test failures

2018-06-10 Thread gregor herrmann
On Sun, 10 Jun 2018 16:45:06 +0300, Niko Tyni wrote: > > > > Confirmed, and I can offer even more failures: > > > > # died: Error while autoloading with 'use > > > > CmdTest::Thing::/build/libur-perl-0.460+ds/t//CmdTest/Thing/Create': > > > > Unknown regexp modifier "/b" at (eval 234) line 1,

Bug#901264: mirror submission for mirror.yannic-bonenberger.com

2018-06-10 Thread Marco d'Itri
On Jun 10, Yannic Bonenberger wrote: > Country: DE Germany It looks in Switzerland to me. Can you clarify this please? Also, please remove the 6to4 address from the mirror.yannic-bonenberger.com name: it does not help anybody and does not not work anyway. -- ciao, Marco signature.asc

Bug#901252: vlc: Fail to launch, QPainter not active

2018-06-10 Thread Sebastian Ramacher
[Please keep the bug in CC] On 2018-06-10 17:50:20, John Hendricks wrote: > I apologize, this is the first bug report I've ever filed. I'm not sure where > VLC keeps the log file, so I will attach the output of vlc -vvv in a text > file. > I am unable to produce output from the given reportbug

Bug#898024: [Pkg-javascript-devel] Bug#898024: Bug#898024: trying to overwrite '/usr/include/nodejs/common.gypi', which is also in package nodejs-dev 10.0.0~dfsg-2

2018-06-10 Thread Jonas Smedegaard
Hi Jérémy, Quoting Jérémy Lal (2018-06-10 16:51:14) > 2018-06-10 10:26 GMT+02:00 Andreas Beckmann : > > The 8 -> 10 upgrade path does not work either: > > > > Selecting previously unselected package libnode64-dev. > > Preparing to unpack .../libnode64-dev_10.3.0~dfsg-1_amd64.deb ... > >

Bug#900650: lua-nvim: autopkgtest regression

2018-06-10 Thread Paul Gevers
Hi On 10-06-18 15:51, James McCoy wrote: > Is there any work being planned/done to help ensure the versions tested > are what's expected? Yup. See ¹ if your extremely interested. > A fix has been merged into upstream lua-nvim and a release should be > happening once some technicalities are

Bug#901267: diffpdf FTCBFS: multiple reasons

2018-06-10 Thread Helmut Grohne
Source: diffpdf Version: 2.1.3-1.2 Tags: patch User: helm...@debian.org Usertags: rebootstrap diffpdf fails to cross build from source. It runs the host architecture qmake through dh_auto_configure and then runs the build architecture qmake through override_dh_auto_build. The latter fails and is

  1   2   3   >