Bug#907723: link package versions on security-tracker to source packages

2018-08-31 Thread Paul Wise
On Sat, Sep 1, 2018 at 5:48 AM, Mike Gabriel wrote: > when working for the LTS team, I regularly need to download source packages > from the LTS version of Debian. My development machine normally runs a newer > Debian version, having deb-src URLs for Debian LTS in sources.list is > possible but

Bug#907668: dicoweb: Search feature does not work

2018-08-31 Thread Власенко Михаил Викторович
> dicoweb depends on python-memcache, which in turns *suggests* memcached, > probably I need to add memcached to depends or recommends ? As I understand it, dicoweb depends on memcached. After all, he is practically non-working without him. Therefore, given my suffering, my answer is: you need

Bug#907736: smartmontools: smartd starts on every boot, ignoring /etc/default/smartmontools

2018-08-31 Thread Bob Bib
Package: smartmontools Version: 6.5+svn4324-1 Severity: normal Dear Maintainer, on my system, smartd starts on every boot, no matter what I put into "/etc/default/smartmontools", commenting the relevant parameter out: #start_smartd=yes or explicitly assigning a "no" value to it:

Bug#907722: youtube-dl unable to download channels

2018-08-31 Thread Rogério Brito
I am very far from my computer (with my keys to sign uploads) until September 12th, so, if anybody is interested in doing an NMU, please go ahead and send me a debdiff after making sure that it is fixed upstream. Regards, Rogério Brito. -- Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key

Bug#705344: pwgen: please implement the diceware password generation scheme

2018-08-31 Thread Paul Wise
Control: tags -1 + wontfix Control: close -1 On Fri, 2018-08-31 at 16:22 -0400, Antoine Beaupre wrote: > I don't think pwgen should be rewritten that way when there are > alternatives like diceware and xkcdpass in the archive now. That seems OK, especially considering the age of this feature

Bug#907735: new upstream release 0.9.2

2018-08-31 Thread Sanford Rockowitz
Package: ddcutil Version: 0.9.2-1 Severity: Normal New upstream release. Tarball at www.ddcutil.com/releases/ddcutil-0.9.2.tar.gz

Bug#907734: package-contains-documentation-outside-usr-share-doc false positive

2018-08-31 Thread Russ Allbery
Package: lintian Version: 2.5.99 Severity: minor On a personal package of a documentation tool (not in Debian yet): I: docknot: package-contains-documentation-outside-usr-share-doc usr/share/perl5/auto/share/module/App-DocKnot/templates/readme-md.tmpl I: docknot:

Bug#907668: dicoweb: Search feature does not work

2018-08-31 Thread أحمد المحمودي
On Sat, Sep 01, 2018 at 02:21:59AM +0600, Власенко Михаил Викторович wrote: > I fixed search bug by installation memcached. ---end quoted text--- dicoweb depends on python-memcache, which in turns *suggests* memcached, probably I need to add memcached to depends or recommends ? -- ‎أحمد

Bug#892183:

2018-08-31 Thread Hashem Nasarat
I packaged a new version which fixes this bug and also addressed some other small issues kanashiro on irc mentioned that they'd help me with sponsorship, but just for documentation, here's the package out for review. https://mentors.debian.net/package/ruby-rbpdf

Bug#907733: RFA: curlpp

2018-08-31 Thread Ximin Luo
Package: wnpp Severity: normal I no longer have interest in maintaining this package. There are 2 RC bugs which are fairly simple to fix but I'd like to focus my attention elsewhere. If someone is interested in becoming a Debian contributor, these two RC bugs are pretty easy to fix, and are a

Bug#907732: maildir-utils: May need versioned depend on libxapian30

2018-08-31 Thread Mark J. Nelson
Package: maildir-utils Version: 1.0-6 Severity: normal Dear Maintainer, After upgrading maildir-utils from 1.0-5 to 1.0-6, some 'mu' commands stopped working with the following error message: mu: symbol lookup error: mu: undefined symbol: _ZN6Xapian4MSetaSEOS0_ Since I suspected this was some

Bug#907731: steam-devices: Steam Controller undetected in Steam due to incorrect udev rules from steam-devices package

2018-08-31 Thread Evan Goers
Package: steam-devices Version: 1.0.0.55-1 Severity: normal Dear Maintainer, * What exactly did you do (or not do) that was effective (or ineffective)? Uninstalled the steam-devices package and used the recommended udev rules from the Steam community. The recommended rules suggest 0666

Bug#907729: knot-resolver: kresd fails on arm64 with "PANIC: unprotected error in call to Lua API (bad light userdata pointer)"

2018-08-31 Thread Daniel Kahn Gillmor
Package: knot-resolver Version: 3.0.0-4 Tags: upstream, help Control: affects -1 hddemux On the arm64 build daemons, kresd fails with the error: PANIC: unprotected error in call to Lua API (bad light userdata pointer)

Bug#907730: knot-resolver: kresd fails on armhf with Bus error

2018-08-31 Thread Daniel Kahn Gillmor
Package: knot-resolver Version: 3.0.0-4 Tags: help When running debian/tests/roundtrip on the armhf buildd arm-arm-01, kresd fails with: debian/tests/roundtrip: line 82: 19523 Bus error "$kresd" "${kresd_args[@]}" "$d" 2> "$d/kresd.err" The process doesn't even get to the

Bug#907728: please package new upstream version 1.4.0

2018-08-31 Thread Steinar H. Gunderson
Package: cubemap Version: 1.3.2-1 Severity: wishlist Hi, After a long time, I found some new features I wanted to put into Cubemap, so there's a new release 1.4.0 out :-) It features TLS support (via kTLS; given that buster seems to release with 4.17, that should be a great match), HLS/fMP4

Bug#885781: petri-foo: Depends on libgnomecanvas

2018-08-31 Thread trebmuh
For information, there is someone working on porting petri-foo out of libgnomecanvas. See : - https://github.com/petri-foo/Petri-Foo/issues/37 - https://github.com/petri-foo/Petri-Foo/pull/40 Olivier

Bug#891700: Converting ll-scope bug to a removal bug

2018-08-31 Thread Jeremy Bicha
Control: retitle -1 RM: ll-scope -- RoQA; unmaintained for years, depend on libglademm2.4 Control: reassign -1 ftp.debian.org Control: severity -1 normal ll-scope was removed from Testing in January because it depends on the unmaintained libglademm2.4. ll-scope's last upload was in 2011 and it

Bug#900581: linux: Enable Buster kernel features for newer ARM64 servers.

2018-08-31 Thread Geoff Levand
Hi, I've rebased my two kernel config patches, attached, to the latest v4.17.17-1 buster kernel. These patches enable kernel features for newer ARM64 servers. 0001-arm64-Use-default-of-CONFIG_ACPI_NFIT-m.patch 0002-arm64-Updates-for-ACPI-servers.patch The issue that Riku brought up of how

Bug#907727: source-contains-empty-directory when a patch adds a file to that directory

2018-08-31 Thread Russ Allbery
Package: lintian Version: 2.5.99 Severity: minor xfonts-jmk 3.0-22 (just now uploaded to the archive) receives the tag: P: xfonts-jmk source: source-contains-empty-directory neep/ascii/ but a patch in the quilt series adds a file to that directory. I believe this addresses the concerns

Bug#905908: libGL.so.1: cannot open shared object file: No such file or directory when updating to 4.4.1~rc2-3

2018-08-31 Thread Andreas Beckmann
On Sat, 11 Aug 2018 16:00:18 +0200 Kyle Robbertze wrote: > When updating octave to 4.4.1~rc2-3, I received the following error: > > Setting up octave (4.4.1~rc2-3) ... > /usr/bin/octave-cli: error while loading shared libraries: libGL.so.1: cannot > open shared object file: No such file or

Bug#907726: virtualenv: automatically downloads untrusted code

2018-08-31 Thread Benjamin Moody
Package: virtualenv Version: 15.1.0+ds-1 Severity: normal Dear Maintainer, The man page for virtualenv does not mention the --no-download option, and does not indicate that the program's default behavior - i.e., upon invoking 'virtualenv foo' - is to automatically download and install code from

Bug#900581: linux: Enable Buster kernel features for newer ARM64 servers.

2018-08-31 Thread Geoff Levand
Hi, I've rebased my two kernel config patches, attached, to the latest v4.17.17-1 buster kernel. These patches enable kernel features for newer ARM64 servers. 0001-arm64-Use-default-of-CONFIG_ACPI_NFIT-m.patch 0002-arm64-Updates-for-ACPI-servers.patch The issue that Riku brought up of how

Bug#907725: xfonts packages are not using the x11 section in practice

2018-08-31 Thread Russ Allbery
Package: lintian Version: 2.5.99 Severity: normal In #878609, xfonts packages were reclassified to be in the x11 section, resulting in the wrong-section-according-to-package-name tag being issued if they go to the fonts section. This was based on the text in https://packages.debian.org/en/sid/,

Bug#901605: minissdpd: lots of "peer ... is not from a LAN" messages

2018-08-31 Thread Vinicius Couto
Package: minissdpd Version: 1.5.20180223-3 Followup-For: Bug #901605 Dear Maintainer, In my computer, after some time, the wired connection shows that is connected, but sometimes blocks the IPv4, other times all the IPvX connection. This not happen in the wireless connection in the same network

Bug#907723: link package versions on security-tracker to source packages

2018-08-31 Thread Mike Gabriel
Control: close -1 Control: tags -1 wontfix HI Moritz, On Fr 31 Aug 2018 23:59:07 CEST, Moritz Mühlenhoff wrote: On Fri, Aug 31, 2018 at 09:48:52PM +, Mike Gabriel wrote: Package: security-tracker Severity: wishlist X-Debbugs-Cc: debian-...@lists.debian.org Hi, when working for the LTS

Bug#907696: Plasma system tray icon and notification missing after recently upgrades of plasmashell

2018-08-31 Thread Bernhard Übelacker
Hello, this sounds like it could be a duplicate of bug #907301 [1][2]. There are currently two workarounds: - either rebuild plasma-workspace locally. - or (probably easier) install packages from unstable: libkf5runner5_5.49.0-1_amd64.deb libkf5plasma5_5.49.0-1_amd64.deb Kind regards,

Bug#907723: link package versions on security-tracker to source packages

2018-08-31 Thread Moritz Mühlenhoff
On Fri, Aug 31, 2018 at 09:48:52PM +, Mike Gabriel wrote: > Package: security-tracker > Severity: wishlist > X-Debbugs-Cc: debian-...@lists.debian.org > > Hi, > > when working for the LTS team, I regularly need to download source packages > from the LTS version of Debian. My development

Bug#901123: xfonts-jmk: Add Unicode 7.0 runic characters to neep

2018-08-31 Thread Russ Allbery
Ben Wong writes: > The neep font has surprisingly good Unicode coverage, but it is > missing some characters. In particular, I noticed it is missing the > eight RUNIC LETTERS, U+16F1 to U+16F8, that were added in Unicode 7.0 > a few years ago. These glyphs are necessary for rendering things like

Bug#907724: Don't ship with buster

2018-08-31 Thread Moritz Muehlenhoff
Source: twitter-bootstrap Severity: serious src:twitter-bootstrap is a 6.5 year old version of Bootstrap which is orphaned since 2013. "Current" packages are in the archive as src:twitter-bootstrap3. The vintage version should not be in buster, reverse deps should migrate to

Bug#302584: [installation-guide] Problems with the hppa installer-manual

2018-08-31 Thread Holger Wansing
Control: tags -1 + wontfix > I just took a little time to review the sarge installation manual > at http://www.debian.org/releases/testing/hppa/ . > It's a big improvement over the woody one! > I do have some nits I'd like fixed before release: Since hppa is not a release architecture for

Bug#248261: [installation-guide] Problem in hppa.xml

2018-08-31 Thread Holger Wansing
Control: tags -1 + wontfix > Subject: Problem in hppa.xml > Date: Monday 10 May 2004 03:52 > From: "Bruno Barrera C." > To: debian-b...@lists.debian.org > > Hello, > > Reading > "installer/doc/manual/en/partitioning/partition/hppa.xml" I found this: > > "This is where the boot loader and an

Bug#907723: link package versions on security-tracker to source packages

2018-08-31 Thread Mike Gabriel
Package: security-tracker Severity: wishlist X-Debbugs-Cc: debian-...@lists.debian.org Hi, when working for the LTS team, I regularly need to download source packages from the LTS version of Debian. My development machine normally runs a newer Debian version, having deb-src URLs for Debian

Bug#900936: Problem solved

2018-08-31 Thread Arnaud Courtès
Everything is fine again since the last geoclue-2 update. Redshift works like a charm. Thank you !

Bug#907722: youtube-dl unable to download channels

2018-08-31 Thread shirish शिरीष
Package: youtube-dl Version: 2018.06.18-1.1 Severity: normal Dear Maintainer, Tried couple of playlists getting the same thing - $ youtube-dl -v -c -f 22 "https://www.youtube.com/playlist?list=PLhk2InOhK1bccqgUhR31u2Sqffmwv9iLv; [debug] System config: [] [debug] User config: [] [debug] Custom

Bug#907721: [lxde] black screen after resume

2018-08-31 Thread Christa Grüttmüller
Package: lxde Version: 9 Severity: normal --- Please enter the report below this line. --- I recently installed Debian 9.5.0 on a Dell Latitude E5400. The following error now occurs: When I press the moon key or close the lid to suspend the laptop and later press the power key or open the

Bug#907720: cminpack: autopkgtest fails with glibc 2.28 due to precision changes

2018-08-31 Thread Adam Conrad
Package: cminpack Version: 1.3.6-2 Severity: normal In Ubuntu, as we've moved on the glibc 2.28, we've seen the cminpack[1] test suite "fail", due to what appears to be improved precision in the results. While this can be fixed by adjusting the ref files (as upstream has done more than once in

Bug#907676: autopkgtests fail with LO 6.1 because LibreOfficeKit writes to stderr

2018-08-31 Thread Olly Betts
On Fri, Aug 31, 2018 at 11:18:37AM +0200, Olivier Tilloy wrote: > Looks like I was too fast in assuming that Debian suffered the same > issue as observed on Ubuntu. > > Tests seem to pass at > https://ci.debian.net/packages/l/lloconv/unstable/amd64/, no output > observed on stderr. Except for one

Bug#907668: dicoweb: Search feature does not work

2018-08-31 Thread Власенко Михаил Викторович
Package: dicoweb Version: 2.3-2 Followup-For: Bug #907668 I fixed search bug by installation memcached. ... Michael

Bug#705344: pwgen: please implement the diceware password generation scheme

2018-08-31 Thread Antoine Beaupre
I don't think pwgen should be rewritten that way when there are alternatives like diceware and xkcdpass in the archive now. So I think this bug should be closed. signature.asc Description: PGP signature

Bug#907659: nageru: FTBFS against x264 0.155

2018-08-31 Thread Steinar H. Gunderson
On Fri, Aug 31, 2018 at 08:19:31AM +0200, Sebastian Ramacher wrote: > The attached (untested) patch should be enough to adopt to this change. I didn't use your patch, but it was useful in making my own -- I wanted things ever so slightly differently. :-) Upload coming, thanks for the help. /*

Bug#907719: stretch-pu: package libtirpc/0.2.5-1.2+deb9u1

2018-08-31 Thread Salvatore Bonaccorso
Package: release.debian.org Severity: normal Tags: stretch User: release.debian@packages.debian.org Usertags: pu Hi libtirpc is affected by a flaw which got assigned CVE-2018-14622, #907608 but we won't issue a DSA for it. Qutoing the SUSE report: > libtirpc has a built-in limit on the file

Bug#907608: libtirpc: diff for NMU version 0.2.5-1.3

2018-08-31 Thread Salvatore Bonaccorso
Control: tags 907608 + pending Dear maintainer, I've prepared an NMU for libtirpc (versioned as 0.2.5-1.3) and uploaded it to DELAYED/10. Please feel free to tell me if I should delay it longer. Regards, Salvatore diff -Nru libtirpc-0.2.5/debian/changelog libtirpc-0.2.5/debian/changelog ---

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Paul Gevers
Hi Jonas, On 31-08-18 16:19, Jonas Smedegaard wrote: > Currently¹ I cannot (easily) setup a CUPS testing environment, so would > appreciate if someone else can confirm if the version now in testing > _also_ causes this same failure - and if so then please help ensure that > this issue does not

Bug#907655: xserver-xorg-video-mga: X don't start with the latest package version

2018-08-31 Thread Davide Prina
On 31/08/2018 17:15, Julien Cristau wrote: Please provide the full Xorg logs from the working and not-working cases. I attached the following Xorg.0.log: * bad_var_log_Xorg.0.log is /var/log/Xorg.0.log * good_local_share_xorg_Xorg.0.log is ~/.local/share/xorg/Xorg.0.log *

Bug#907718: python-dateutil breaks python-vobject autopkgtest

2018-08-31 Thread Paul Gevers
Source: python-dateutil, python-vobject Control: found -1 python-dateutil/2.7.3-1 Control: found -1 python-vobject/0.9.5-2 X-Debbugs-CC: debian...@lists.debian.org User: debian...@lists.debian.org Usertags: breaks needs-update Dear maintainers, With a recent upload of python-dateutil the

Bug#868179: xserver-xorg-video-radeon: SEGV when starting X11

2018-08-31 Thread bartek 'basz' szurgot
On 08/07/2018 11:21 AM, Simon McVittie wrote: > On Sat, 15 Jul 2017 at 12:13:34 +0900, Michel Dänzer wrote: >> On 15/07/17 03:57 AM, bartek 'basz' szurgot wrote: >>> knowing the exact conditions under which SEGV occurs >>> (i.e. rotated screen in xorg.conf), i agree it is not a "grave" bug. >>

Bug#907681: lintian: false positive source-only-upload-to-non-free-without-autobuild

2018-08-31 Thread Chris Lamb
Hi Andreas, > source-only-upload-to-non-free-without-autobuild does not seem to work > as intended ... it flags the nvidia-graphics-drivers package which has > been autobuilt for years ... Ah, whoops, we are checking the .changes file instead of the .dsc. Regards, -- ,''`. : :' :

Bug#905586: lxc: diff for NMU version 1:2.0.9-6.1

2018-08-31 Thread Salvatore Bonaccorso
Hi Antonio, On Fri, Aug 31, 2018 at 04:07:56PM -0300, Antonio Terceiro wrote: > On Fri, Aug 31, 2018 at 02:42:15PM +0200, Salvatore Bonaccorso wrote: > > Hi Antonio, > > > > On Fri, Aug 31, 2018 at 08:14:57AM -0300, Antonio Terceiro wrote: > > > On Thu, Aug 30, 2018 at 10:06:15PM +0200,

Bug#906380: libtool: FTBFS in buster/sid

2018-08-31 Thread shirish शिरीष
at bottom :- On 31/08/2018, Juhani Numminen wrote: > Dear Shirish, > > shirish शिरीष kirjoitti 31.08.2018 klo 07:58:> Could you upload the built > libtool binary somewhere so I could install >> it and see if the issue goes away ? > > I've now put the build sources and binaries there: >

Bug#892183: ruby-rbpdf: FTBFS and Debci failure with Ruby 2.5

2018-08-31 Thread Hashem Nasarat
I made some good progress with packaging a new version of ruby-rbpdf: https://salsa.debian.org/hnasarat-guest/ruby-rbpdf/network/master Now to find a sponsor?

Bug#905586: lxc: diff for NMU version 1:2.0.9-6.1

2018-08-31 Thread Antonio Terceiro
On Fri, Aug 31, 2018 at 02:42:15PM +0200, Salvatore Bonaccorso wrote: > Hi Antonio, > > On Fri, Aug 31, 2018 at 08:14:57AM -0300, Antonio Terceiro wrote: > > On Thu, Aug 30, 2018 at 10:06:15PM +0200, Salvatore Bonaccorso wrote: > > > Control: tags 905586 + pending > > > > > > > > > Dear

Bug#907717: linux-image-4.17.0-0.bpo.3-amd64: random backtrace caused by refcount on Xorg

2018-08-31 Thread m . alfaeko
Package: src:linux Version: 4.17.17-1~bpo9+1 Severity: normal Dear Maintainer, I had installed new kernel from debian backports repository, but im experiencing some backtrace logs in system kern.log file. This does not affect systems stability. Backtrace is caused by refcount and its affecting

Bug#907715: lua-mode: FTBFS in buster/sid ("No buffer named *lua5.3*")

2018-08-31 Thread Santiago Vila
Package: src:lua-mode Version: 20151025-3 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in buster but it failed: [...] debian/rules build-indep dh build-indep --with elpa

Bug#907713: golang-github-fsouza-go-dockerclient: FTBFS in buster/sid (failing tests)

2018-08-31 Thread Santiago Vila
Package: src:golang-github-fsouza-go-dockerclient Version: 1.2.1-1 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in buster but it failed: [...] debian/rules build-indep dh

Bug#907714: golang-x-text: FTBFS in buster/sid (failing tests)

2018-08-31 Thread Santiago Vila
Package: src:golang-x-text Version: 0.3.0-1 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in buster but it failed: [...] debian/rules build-indep dh build-indep --buildsystem=golang

Bug#907716: rpyc: FTBFS in buster/sid (failing tests)

2018-08-31 Thread Santiago Vila
Package: src:rpyc Version: 3.4.4-1 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in buster but it failed: [...] debian/rules build-indep dh build-indep --with python3,sphinxdoc

Bug#907712: src:requestpolicy: please package upstream version 1.0.beta13.2

2018-08-31 Thread Daniel Kahn Gillmor
Package: src:requestpolicy Version: 1.0.0~beta12.3+dfsg-1 Severity: wishlist according to https://github.com/RequestPolicyContinued/requestpolicy/releases a new beta release has been available for nearly a year. In git (https://github.com/RequestPolicyContinued/requestpolicy) there are many new

Bug#907711: libsdl2 FTCBFS: lintian tag autotools-pkg-config-macro-not-cross-compilation-safe

2018-08-31 Thread Helmut Grohne
Source: libsdl2 Version: 2.0.8+dfsg1-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap libsdl2 fails to cross build from source, because it uses the build architecture pkg-config and thus fails finding a number of dependencies. Lintian has a more detailed explanation. The

Bug#907706: devscripts: Incorrect output of dcontrol

2018-08-31 Thread Adam D. Barratt
Control: reassign -1 qa.debian.org On Fri, 2018-08-31 at 20:18 +0300, Dmitry Bogatov wrote: > I stumbled at following behaviour of `dcontrol' utility: As per the manpage, dcontrol is an interface to https://qa.debian.org/c gi-bin/dcontrol . If you perform the same queries via that script

Bug#906189: linux-image-4.17.0-1-amd64: Laptop does not suspend in 4.17 - worked up to 4.16

2018-08-31 Thread Ben Hutchings
Control: tag -1 moreinfo On Wed, 2018-08-15 at 12:32 +0200, Christoph Haas wrote: > Package: src:linux > Version: 4.17.8-1 > Severity: important > > Dear Maintainer, > > I am using Debian Sid. Since the upgrade to linux-image-4.17.x I cannot > suspend my Lenovo X230 laptop any more. I close the

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Paul Gevers
Hi Jonas, On 31-08-18 01:25, Jonas Smedegaard wrote: > Do the freshly released experimental Ghostscript release help anything? I'll trigger the test shortly and report back with the results. Paul signature.asc Description: OpenPGP digital signature

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Paul Gevers
Dear all, On 31-08-18 15:48, Till Kamppeter wrote: > On 31/08/18 15:36, Didier 'OdyX' Raboud wrote: >> Le vendredi, 31 août 2018, 01.25:24 h CEST Jonas Smedegaard a écrit : >>> Do the freshly released experimental Ghostscript release help anything? >> >> It doesn't seem to, unfortunately. :-( >>

Bug#907709: cowbuilder should create directory when basepath is given

2018-08-31 Thread shirish शिरीष
Package: cowbuilder Version: 0.87+b1 Severity: normal Dear Maintainer, I am a newbie to cowbuilder. A gentleman helped me to create the pbuilderrc - ~$ cat .pbuilderrc BASEPATH="/var/cache/pbuilder/sid-amd64/base.cow" DISTRIBUTION="sid" MIRRORSITE="http://deb.debian.org/debian/; # Enable build

Bug#742624: Find it very annoying too

2018-08-31 Thread Eric Valette
file test_mime_type.vym test_mime_type.vym: Zip archive data, at least v2.0 to extract -- eric

Bug#907707: xfce4-sntray-plugin FTBFS with vala-panel 0.4.61

2018-08-31 Thread Adrian Bunk
Source: xfce4-sntray-plugin Version: 0.4.10-2 Severity: serious Tags: ftbfs https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/xfce4-sntray-plugin.html ... /build/1st/xfce4-sntray-plugin-0.4.10/src/vala-panel-sntray-applet.vala:23.39-23.56: error: SNApplet: Classes cannot have

Bug#907706: devscripts: Incorrect output of dcontrol

2018-08-31 Thread Dmitry Bogatov
Package: devscripts Version: 2.18.3 Severity: normal Dear Maintainer, I stumbled at following behaviour of `dcontrol' utility: $ dcontrol debhelper/sid Package: debhelper Binary: debhelper, dh-systemd Version: 11.3.5 Maintainer: Debhelper

Bug#907708: vala-panel-appmenu FTBFS with vala-panel 0.4.61

2018-08-31 Thread Adrian Bunk
Source: vala-panel-appmenu Version: 0.6.94+repack1-2 Severity: serious Tags: ftbfs https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/vala-panel-appmenu.html ... /build/1st/vala-panel-appmenu-0.6.94+repack1/lib/valapanel-plugin-appmenu.vala:24.44-24.61: error: AppmenuApplet:

Bug#907705: ITP: mmm -- minimalistic media manager

2018-08-31 Thread Felix C. Stegerman
Package: wnpp Severity: wishlist Owner: "Felix C. Stegerman" * Package name: mmm Version : 0.4.1 Upstream Author : Felix C. Stegerman * URL : https://github.com/obfusk/m * License : GPLv3+ Programming Lang: Python Description : minimalistic media

Bug#905377: Re%3A Bug#905377%3A kontact%3A Kontact opens introduction in konqueror on each start

2018-08-31 Thread Dr Nicholas Bailey
> El viernes, 3 de agosto de 2018 15:17:24 -03 Matt Stamp escribió: > > Package: kontact > > Version: 4:17.12.3-1 > > Severity: normal > > > > Dear Maintainer, > > > > On upgrade kontact:amd64 4:17.08.3-1 to 4:17.12.3-1 I am now getting the > > Konqueror introduction page on each start. I am

Bug#907704: choose-mirror: default to deb.debian.org

2018-08-31 Thread Julien Cristau
Package: choose-mirror Severity: wishlist X-Debbugs-Cc: tfh...@debian.org I think it's time for choose-mirror to stop asking by default. AFAIK deb.debian.org works well enough now that we don't need users to manually select a mirror close to them. PoC patch, completely untested: diff --git

Bug#907698: libdrm2: regression: breaks firefox WebGL

2018-08-31 Thread Jörg-Volker Peetz
Hi Julien, thanks for taking care and the info which I obviously didn't know about :-( Regards, Jörg.

Bug#907703: ghostscript: Bug 699654(2): preserve LockSafetyParams in the nulldevice

2018-08-31 Thread Salvatore Bonaccorso
Source: ghostscript Version: 9.22~dfsg-3 Severity: grave Tags: patch security upstream Control: found -1 9.20~dfsg-1 There is one more followup fix needed: http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=79cccf641486 https://bugs.ghostscript.com/show_bug.cgi?id=699654 Decoupling this

Bug#906012: libxcursor: CVE-2015-9262

2018-08-31 Thread Julien Cristau
Process questions are very much off-topic for this bug report, but... On 08/30/2018 09:43 AM, Bjoern wrote: > As I am clearly unfamiliar with your processes, I really would > appreciate the clarification to better my understanding and perhaps > quell my concerns: > >  * How far away is the 9.6

Bug#907701: Unable to load GDM on hybrid system after switching to nvidia driver

2018-08-31 Thread Anton Vorobyov
Package: nvidia-driver Version: 390.77-1 New laptop with hybrid video system. Installed debian testing with Gnome desktop. GDM and gnome shell were functioning correctly until i installed nvidia-driver package (i do not know which driver system used at that point). Optimus packages are not

Bug#907702: iwd: drop libexecdir override once bumping to compat 12

2018-08-31 Thread Andreas Henriksson
Package: iwd Version: 0.7-2 Severity: wishlist Filing this as a reminder for the future, and as a followup on future improvements beyond https://salsa.debian.org/debian/iwd/commit/23998f71d84c82c71a48574321dba5e38b698ec3 " Properly escape libexecdir path configure argument " I think it would

Bug#907661: freecol: Does not start up with OpenJDK 10

2018-08-31 Thread Markus Koschany
Control: tags -1 pending confirmed Control: severity -1 grave On Thu, 30 Aug 2018 21:42:17 +0100 Johannes Kloos wrote: > Package: freecol > Version: 0.11.6+dfsg2-1 > Severity: important > Tags: patch > > Dear Maintainer, > > The freecol package tries to start up the JVM for freecol with the >

Bug#907700: ITP: python-guizero -- tkinter wrapper to simplify GUI creation

2018-08-31 Thread Nick Morrott
Package: wnpp Owner: Nick Morrott Severity: wishlist X-Debbugs-CC: debian-de...@lists.debian.org * Package name: python-guizero Version : 0.5.3 Upstream Author : Laura Sach * URL : https://github.com/lawsie/guizero * License : BSD-3-clause Programming Lang:

Bug#892841: Opening a file with O_CREAT fails

2018-08-31 Thread Alexander Volkov
The fix is in the attached patch. >From d4720c44fb2c8c2b891bd07fbf6d44a2333f8c56 Mon Sep 17 00:00:00 2001 From: Alexander Volkov Date: Wed, 29 Aug 2018 13:54:23 +0300 Subject: [PATCH] fix opening a file with O_CREAT and reading created files FUSE calls fgetattr() for a created file which leads

Bug#907699: ITP: python-nudatus -- tool to remove comments from Python scripts

2018-08-31 Thread Nick Morrott
Package: wnpp Owner: Nick Morrott Severity: wishlist X-Debbugs-CC: debian-de...@lists.debian.org * Package name: python-nudatus Version : 0.0.3 Upstream Author : Zander Brown * URL : https://github.com/ZanderBrown/nudatus * License : Expat Programming Lang:

Bug#907655: xserver-xorg-video-mga: X don't start with the latest package version

2018-08-31 Thread Julien Cristau
Control: tag -1 moreinfo On 08/30/2018 09:10 PM, Davide Prina wrote: > Package: xserver-xorg-video-mga > Version: 1:1.6.5-1 > Severity: grave > Justification: renders package unusable > > Dear Maintainer, > > upgrading the system to the latest version don't let X to start: screen > black with a

Bug#906189: linux-image-4.17.0-1-amd64: Laptop does not suspend in 4.17 - worked up to 4.16

2018-08-31 Thread David Bremner
Felix Hagemann writes: > Package: src:linux > Version: 4.17.17-1 > Followup-For: Bug #906189 > > Dear Maintainer, > > I do see exactly the same behaviour on a Thinkpad X1 Carbon (Gen. 2). > I had the same problem on my dell e7270, but it was fixed by a BIOS upgrade. Something to try? d

Bug#905722: gcovr: Missing runtime dependency - python-pkg-resources

2018-08-31 Thread Julian Andres Klode
Control: severity -1 serious On Wed, Aug 08, 2018 at 03:40:44PM +, Bodo-Merle Sandor wrote: > Package: gcovr > Version: 4.1-1 > Severity: normal > > Dear Maintainer, > > Starting gcovr results in the following error: > > # gcovr > Traceback (most recent call last): > File

Bug#907698: libdrm2: regression: breaks firefox WebGL

2018-08-31 Thread Julien Cristau
Control: tag -1 upstream fixed-upstream patch Control: severity -1 important On 08/31/2018 04:46 PM, Jörg-Volker Peetz wrote: > Package: libdrm2 > Version: 2.4.94-1 > Severity: normal > > Dear Maintainer(s), > > since update to version 2.4.93-1 the Hardware support in firefox is > broken.

Bug#907686: npm2deb: chokes on parsing mocha when locale is C

2018-08-31 Thread Pirate Praveen
On 2018, ഓഗസ്റ്റ് 31 4:57:54 PM IST, Jonas Smedegaard wrote: >Package: npm2deb >Version: 0.2.8-1 >Severity: normal > >-BEGIN PGP SIGNED MESSAGE- >Hash: SHA512 > >Attempting to follow https://wiki.debian.org/Javascript/Nodejs/Tasks to >resolve dependencies of node-server, in a limited

Bug#907697: fortunes-br: Inconsistent use of accents in fortunes-br

2018-08-31 Thread Rafael Vargas
Package: fortunes-br Version: 20160820 Severity: minor Dear Maintainer, Throughout the entire fortune file, several phrases uses some accents (mainly the tilde) but don't use the other accents needed to be grammatically correct. I could offer myself to correct the file, but I couldn't find the

Bug#907698: libdrm2: regression: breaks firefox WebGL

2018-08-31 Thread Jörg-Volker Peetz
Package: libdrm2 Version: 2.4.94-1 Severity: normal Dear Maintainer(s), since update to version 2.4.93-1 the Hardware support in firefox is broken. Calling for example https://get.webgl.org/ shows the text "While your browser seems to support WebGL, it is disabled or unavailable." In the log

Bug#907696: Plasma system tray icon and notification missing after recently upgrades of plasmashell

2018-08-31 Thread M0xkLurk3r
Package: kde-plasma-desktop Version: 5:102 Severity: important Dear maintainer: my desktop loses ALL system tray icon and notifications after recently upgrades. seems the notification were *just* failed to show, i heard the bell ringing when new notification arrives. and the desktop also had

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Jonas Smedegaard
Quoting Jonas Smedegaard (2018-08-31 15:43:28) > Quoting Didier 'OdyX' Raboud (2018-08-31 15:36:09) > > Le vendredi, 31 août 2018, 01.25:24 h CEST Jonas Smedegaard a écrit : > > > Do the freshly released experimental Ghostscript release help anything? > > > > It doesn't seem to, unfortunately.

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Till Kamppeter
On 31/08/18 15:36, Didier 'OdyX' Raboud wrote: Le vendredi, 31 août 2018, 01.25:24 h CEST Jonas Smedegaard a écrit : Do the freshly released experimental Ghostscript release help anything? It doesn't seem to, unfortunately. :-( To reproduce the issue; just run this as root:

Bug#903010: golang-gopkg-inf.v0: No Breaks/Replaces/Conflics with golang-speter-go-exp-math-dec-inf-dev

2018-08-31 Thread Sascha Steinbiss
Hi Dmitry, [...] >> I guess it would then only need removing the obsolete b-dep from >> golang-github-appc-spec-dev and an upload of the new golang-gopkg-inf.v0? > > That's not enough unfortunately, as if somebody already have "golang-speter- > go-exp-math-dec-inf-dev" installed they will

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Didier 'OdyX' Raboud
Le vendredi, 31 août 2018, 01.25:24 h CEST Jonas Smedegaard a écrit : > Do the freshly released experimental Ghostscript release help anything? It doesn't seem to, unfortunately. :-( To reproduce the issue; just run this as root: /usr/share/cups/test-drivers Surprisingly; it will fail

Bug#907493: ghostscript breaks cups autopkgtest: test times out

2018-08-31 Thread Jonas Smedegaard
Quoting Didier 'OdyX' Raboud (2018-08-31 15:36:09) > Le vendredi, 31 août 2018, 01.25:24 h CEST Jonas Smedegaard a écrit : > > Do the freshly released experimental Ghostscript release help anything? > > It doesn't seem to, unfortunately. :-( > > To reproduce the issue; just run this as root: >

Bug#906358: gimp-help: FTBFS in buster/sid (You must have automake 1.10 or newer installed)

2018-08-31 Thread Juhani Numminen
Control: forwarded 906358 https://bugzilla.gnome.org/show_bug.cgi?id=794819 Control: tags 906358 patch fixed-upstream On Fri, 17 Aug 2018 11:19:44 + Santiago Vila wrote: > Package: src:gimp-help > Version: 2.8.2-0.1 > Severity: serious > Tags: ftbfs > > Dear maintainer: > > I tried to

Bug#907695: ITP: python-metaextract -- collect metadata about a python module

2018-08-31 Thread Thomas Bechtold
Package: wnpp Severity: wishlist Owner: Thomas Bechtold * Package name: python-metaextract Version : 1.0.4 Upstream Author : Thomas Bechtold * URL : https://pypi.org/project/metaextract/ * License : Apache-2.0 Programming Lang: Python Description :

Bug#902716: (no subject)

2018-08-31 Thread Brian Minton
I just verified that this is still occurring for reportbugs.debian.org port 443 (certificate not valid for this hostname), and ports 587 and 25 using STARTTLS (self-signed certificate). I've reassigned the bug since it's not really an issue with the reportbug package itself. -- Brian Minton

Bug#907694: ITP: neutron-tempest-plugin -- OpenStack Integration Test Suite - Neutron plugin

2018-08-31 Thread Thomas Goirand
Package: wnpp Severity: wishlist Owner: Thomas Goirand * Package name: neutron-tempest-plugin Version : 0.2.0 Upstream Author : OpenStack Foundation * URL : https://github.com/openstack/neutron-tempest-plugin * License : Apache-2.0 Programming Lang: Python

Bug#907693: RFP: exodus-standalone -- εxodus CLI client for local APK static analysis

2018-08-31 Thread Pierre Rudloff
Package: wnpp Severity: wishlist * Package name: exodus-standalone * URL : https://github.com/Exodus-Privacy/exodus-standalone * License : AGPL-3.0 Programming Lang: Python Description : εxodus CLI client for local APK static analysis exodus-standalone is a CLI

Bug#896970: RFS: odp/1.19.0.0-1 [ITP]

2018-08-31 Thread Dmitry Eremin-Solenikov
Hello, I've uploaded new 1.19.0.2-1 version to mentors.d.o. I've added manpages, fixed copyright info, fixed alternatives and enabled auto-tests. Could you please review it? сб, 2 июн. 2018 г. в 7:08, Lumin : > > On Sat, Jun 02, 2018 at 03:24:07AM +, Lumin wrote: > > Please fix the

Bug#905586: lxc: diff for NMU version 1:2.0.9-6.1

2018-08-31 Thread Salvatore Bonaccorso
Hi Antonio, On Fri, Aug 31, 2018 at 08:14:57AM -0300, Antonio Terceiro wrote: > On Thu, Aug 30, 2018 at 10:06:15PM +0200, Salvatore Bonaccorso wrote: > > Control: tags 905586 + pending > > > > > > Dear maintainer, > > > > I've prepared an NMU for lxc (versioned as 1:2.0.9-6.1) and > > uploaded

Bug#907692: Feature request for CMST and/or Connman/Connman-VPN

2018-08-31 Thread scrap
Package: cmst Version: 2016.10.03-2 Actually this is more a feature request, not a bug. Because of the fact that CMST is also relevant for the Connman-developers I also put its maintainers as recipients in here. While browsing through the internet I found an interesting entry on StackExchange

  1   2   >