Bug#926432: apache2: Internal error: error fetching from cache 'dbm:/var/cache/apache2/gnutls_cache'

2019-04-07 Thread Damir Islamov
Hello, Unfortunately, not. apache2 2.4.39-1 is installed, but I can see these errors in apache2/error.log Best regards, Damir -Original Message- From: Xavier Sent: Friday, April 5, 2019 11:40 AM To: Damir R. Islamov Cc: 926...@bugs.debian.org; 926...@bugs.debian.org Subject: Re:

Bug#926623: ITP: ruby-parallel-tests -- Run Test::Unit / RSpec / Cucumber / Spinach in parallel

2019-04-07 Thread Hideki Yamane
Package: wnpp Severity: wishlist Owner: Hideki Yamane * Package name: ruby-parallel-tests Version : 2.28.0 Upstream Author : Michael Grosser * URL : https://github.com/grosser/parallel_tests * License : MIT Programming Lang: Ruby Description : Run

Bug#925411: kernel-package: Not suitable for release

2019-04-07 Thread Nicholas D Steeves
Hi Ben, On Sun, Mar 24, 2019 at 11:23:58PM +, Ben Hutchings wrote: > Control: severity -1 serious > > On Sun, 2019-03-24 at 16:19 -0600, Nicholas D Steeves wrote: > > Control: severity -1 important > > Justification: essential package that works flawlessly for me > > This was agreed with

Bug#926618: RFP: webext-plasma-integration -- provides integration of web browsers with the Plasma desktop

2019-04-07 Thread Nicholas D Steeves
Hi Scarlett, On Sun, Apr 07, 2019 at 06:59:10PM -0400, John Scott wrote: > Package: wnpp > Severity: wishlist > > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > * Package name: webext-plasma-integration > Version : 1.4 > Upstream Author : Kai Uwe Broulik > * URL

Bug#926622: unblock: zulucrypt/5.4.0-3

2019-04-07 Thread Marcio de Souza Oliveira
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package zulucrypt This debian release fixes the bug #922038. This bug affect the working of zulucrypt-cli and zulumount-cli. Because of ordering the linker flags the linker

Bug#926596: fwupdate: arm64 version of PE/COFF efi binary is corrupt

2019-04-07 Thread Ard Biesheuvel
On Mon, 8 Apr 2019 at 02:07, wrote: > > Would you be able to check if this also affects fwupd? The fwupdate binary > was also merged into that project a while back and I would suspect it's > affecting both. > I've had a report that Fedora's version of the fwupdmgr .efi helper is broken, but

Bug#926621: ITP: ruby-strptime -- fast strptime/strftime engine

2019-04-07 Thread Hideki Yamane
Package: wnpp Severity: wishlist Owner: Hideki Yamane * Package name: ruby-strptime Version : 0.2.3 Upstream Author : NARUSE, Yui * URL : https://github.com/nurse/strptime * License : BSD-2-Clause Programming Lang: C, Ruby Description : fast

Bug#926596: fwupdate: arm64 version of PE/COFF efi binary is corrupt

2019-04-07 Thread Mario.Limonciello
Would you be able to check if this also affects fwupd? The fwupdate binary was also merged into that project a while back and I would suspect it's affecting both. -Original Message- From: Ard Biesheuvel Sent: Sunday, April 7, 2019 10:46 PM To: Debian Bug Tracking System Subject:

Bug#925785: neovim: ftbfs with GCC-9

2019-04-07 Thread James McCoy
Control: tag -1 + upstream fixed-upstream On Wed, Mar 27, 2019 at 07:47:15PM +, Matthias Klose wrote: > From test_mksession.vim: > Found errors in Test_mksession_arglist(): > Caught exception in Test_mksession_arglist(): Vim(set):E539: Illegal > character : shortmess=aoO @ >

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-04-07 Thread Guilhem Moulin
On Sun, 07 Apr 2019 at 20:56:41 +0200, gregor herrmann wrote: > Alright, after purging libssl1.0.2 (and the outdated packages which > depended on it *cough*) I get the hang as well: > […] > Thanks for the push in the right direction! You're welcome :-) Does clearing the SSL_MODE_AUTO_RETRY

Bug#926603: Debian fails to start after installation into Virtualbox

2019-04-07 Thread Michael Biebl
Control: tags -1 moreinfo Am 07.04.19 um 18:51 schrieb Andy Ruddock: > Package: systemd > Severity: critical > > I'm running Windows 10 (Home edition - up to date) on the desktop, with > Virtualbox (v6.0.4). > I've used both the netinst CD & the testing DVD (downloaded today - > 07/Apr/2019) to

Bug#926620: debsums: [INTL:pt] Update on Portuguese translation of manpage

2019-04-07 Thread Américo Monteiro
Package: debsumsr Version: 2.2.3 3ags: l10n, patch- Severity: wishlist Updated Portuguese translation for debsums's manpage Translator: Américo Monteiro Feel free to use it. For translation updates please contact 'Last Translator' -- Melhores cumprimentos/Best regards, Américo Monteiro

Bug#926306: RFS: socklog/2.1.0-9

2019-04-07 Thread Mathieu Mirmont
On Sat, Apr 06, 2019 at 07:13:56PM +, Dmitry Bogatov wrote: > > [2019-04-04 13:30] Mathieu Mirmont > > > * I know, it is pain, but there should be init.d script. You may want to > > > take a look at bcron=0.11-8. > > > > Sure, no worries. How about systemd service files? It makes little

Bug#926619: deborphan: [INTL:pt] Update on Portuguese translation of manpage

2019-04-07 Thread Américo Monteiro
Package: deborphan Version: 1.7.31 3ags: l10n, patch- Severity: wishlist Updated Portuguese translation for deborphan's manpage Translator: Américo Monteiro Feel free to use it. For translation updates please contact 'Last Translator' -- Melhores cumprimentos/Best regards, Américo Monteiro

Bug#926618: RFP: webext-plasma-integration -- provides integration of web browsers with the Plasma desktop

2019-04-07 Thread John Scott
Package: wnpp Severity: wishlist -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 * Package name: webext-plasma-integration Version : 1.4 Upstream Author : Kai Uwe Broulik * URL : https://community.kde.org/Plasma/Browser_Integration * License : GPL 3

Bug#926617: plasma-pa: Speakers test doesn't work if libcanberra-pulse is not installed

2019-04-07 Thread Alexander Kernozhitsky
Package: plasma-pa Version: 4:5.14.5-1 Severity: normal The speakers test functionality in the settings of the plasmoid didn't work for me. When I tried to use it, I saw the following in the console: ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM 2 ALSA lib

Bug#926616: CVE-2018-3750: Prototype Pollution

2019-04-07 Thread Jeff Cliff
Package: node-deep-extend Version: 0.4.1-1 Severity: important Dear Maintainer, As per the ubuntu bug report: from https://snyk.io/vuln/npm:deep-extend:20180409 : deep-extend "all the listed modules can be tricked into modifying the prototype of "Object" when the attacker control part of

Bug#925185: unblock pre-approval: sysstat/12.0.3-1 (actually 12.0.3-2)

2019-04-07 Thread Robert Luberda
Control: tags -1 -moreinfo Control: retitle -1 unblock sysstat/12.0.3-2 Hi, >> [...] > Please go ahead with 12.0.3-1 for buster and remove the moreinfo tag > when it is ready for unblocks. > Thanks. I uploaded 12.0.3-2 to unstable yesterday. Could you please unblock it? Comparing to

Bug#926408: Scrolling makes kdiff3 crash

2019-04-07 Thread Bernhard Übelacker
Control: tags 926408 + upstream patch Control: tags 926408 - moreinfo unreproducible Dear Maintainer, Hello Gudjon, I forgot to mention that this little "save" button should be on the developers information tab of DrKonqi. Then you should not need to do something in gdb manually. However, I

Bug#926615: bug#314: Acknowledgement (gpsd: ..2'nd roll over bug: gpsd "clock is 56 years wrong", like "1963-07-18T08:57:40.584Z")

2019-04-07 Thread Arnt Karlsen
..upstream bug reports: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=926615 https://savannah.nongnu.org/bugs/index.php?56094 ..our bug report: https://bugs.devuan.org//cgi/bugreport.cgi?bug=314 -- ..med vennlig hilsen = with Kind Regards from Arnt Karlsen ...with a number of polar bear

Bug#926615: gpsd: ..2'nd roll over bug: gpsd "clock is 56 years wrong", like "1963-07-18T08:57:40.584Z"

2019-04-07 Thread Arnt Karlsen
Package: gpsd Version: 3.16-4 Severity: important ..upstream bug. Hi, ..reportbug reports our (Devuan) BTS is down, bug report on gpsd: Content-Type : text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit From: Arnt To: Devuan Bug Tracking System Subject:

Bug#925909: [Help] Re: pbgenomicconsensus: autopkgtest regression

2019-04-07 Thread Andreas Tille
On Sun, Apr 07, 2019 at 02:08:54PM +0200, Liubov Chuprikova wrote: > I have just added python-pytest and one more missing library. Now the tests > should pass. Finally it passes now. Thanks a lot, Andreas. -- http://fam-tille.de

Bug#921176: redis-server service is failing to start in buster lxc container

2019-04-07 Thread Antonio Terceiro
On Sun, Apr 07, 2019 at 08:37:53PM +0200, Pierre-Elliott Bécue wrote: > Le dimanche 24 février 2019 à 15:01:14+0100, intrigeri a écrit : > > Control: reassign -1 lxc > > Control: severity -1 important > > > > Hi, > > > > Pirate Praveen: > > > In dmesg inside container (same error on the host as

Bug#926613: openssh-server: Locked out of server after upgrading to buster.

2019-04-07 Thread Sam Bull
Package: openssh-server Severity: serious Justification: Policy 8.2 Dear Maintainer, Due to a change in how some options are handled in sshd_config, upgrading to buster can result in the user getting locked out of their system if the config is not updated. Probably the most likely cause (and

Bug#916145: closure-compiler: Not working with recent JS code

2019-04-07 Thread Markus Koschany
Am 07.04.19 um 20:36 schrieb Adrian Bunk: > On Sun, Apr 07, 2019 at 11:12:30AM -0700, tony mancill wrote: >> ... >> Somewhat related, given that closure-compiler upstream releases about >> once a month on average, perhaps it is a candidate for doing Something >> Different. > > That's pretty

Bug#926595: cache policy

2019-04-07 Thread Laurent Debian
Dear maintainers, Below is the output you required (in French). I hope I am not just making you lose time because of a bad config Regards, python3-numpy: Installé : 1:1.16.2-1 Candidat : 1:1.16.2-1 Table de version : *** 1:1.16.2-1 500 500 http://ftp.fr.debian.org/debian

Bug#926612: missing hp-laserjet_200_colormfp_m276-ps.ppd

2019-04-07 Thread Richard Kettlewell
Package: hpijs-ppds Version: 3.16.11+repack0-3 Hi, I have a HP LaserJet 200 colorMFP M276n. The PPD for this printer is in the hplip source package: $ pwd /home/rjk/junk/hplip-3.16.11+repack0 $ find . -name *m276* ./prnt/ps/hp-laserjet_200_colormfp_m276-ps.ppd.gz However it is not in the

Bug#900912: Enabling jaw (Java-atk-wrapper) by default ? (Bug#900912)

2019-04-07 Thread Samuel Thibault
Vincent Privat, le dim. 07 avril 2019 21:55:33 +0200, a ecrit: > Disabling it only through accessibility.properties means we have no control > over it from JOSM. So when the next bug appears, we'll have to tell all of our > impacted Ubuntu users to modify the file. We are here only talking about

Bug#919929: python-scipy's autopkgtests break again

2019-04-07 Thread Helmut Grohne
Control: reopen -1 I'm seeing this failure again: https://ci.debian.net/data/autopkgtest/testing/amd64/p/python-scipy/2213599/log.gz Helmut

Bug#926611: unblock: schema2ldif/1.3-3

2019-04-07 Thread Mike Gabriel
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package schema2ldif + [ Ondřej Nový ] + * d/copyright: ++ Change Format URL to correct one Formalistic auto-commit that already was in git log for next upload. + [

Bug#147164: ping and new proposal

2019-04-07 Thread Thomas Lange
Remove the outdated /doc/docpolicy. Even the "current draft of the new policy" is outdated and deprecated. Instead of a whole policy manual which is outdated for a long time my proposal is to just list a few things to consider on /doc. Currently we have these items on /doc about the policy:

Bug#926610: unblock: ceph/12.2.11+dfsg1-2.1

2019-04-07 Thread Bernd Zeimetz
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Hi release team, please unblock package ceph. I've NMUed it to add a missing systemd @.service file, which basically renedered the package unusuable (unless you'd be doing crazy stuff

Bug#926609: unblock: apache2/2.4.38-3

2019-04-07 Thread Stefan Fritsch
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package apache2, it fixes various security issues (no other changes). Debdiff is attached unblock apache2/2.4.38-3 diff -Nru apache2-2.4.38/debian/changelog

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-04-07 Thread gregor herrmann
On Sun, 07 Apr 2019 18:39:44 +0200, Guilhem Moulin wrote: > > I can't reproduce this problem: > Interesting, are you talking TLS 1.3? Good question :) > $ dpkg-query -l "libssl*" "libnet-ssleay-perl" "liblwp-protocol-https-perl" > "libio-socket-ssl-perl" >

Bug#926607: tracetuner FTCBFS: upstream Makefiles hard code build architecture compiler

2019-04-07 Thread Helmut Grohne
Source: tracetuner Version: 3.0.6~beta+dfsg-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap tracetuner fails to cross build from source, because it seeds the LINK.c variable from the build architecture compiler in two occasions. Defaulting them to $(CXX) fixes the cross

Bug#926606: hawknl FTCBFS: does not pass cross tools to make

2019-04-07 Thread Helmut Grohne
Source: hawknl Version: 1.6.8+dfsg2-1 Tags: patch User: helm...@debian.org Usertags: rebootstrap hawknl fails to cross build from source, because it does not pass cross tools to make. The easiest way of doing so - using dh_auto_build - makes hawknl cross buildable. Please consider applying the

Bug#926608: duktape FTCBFS: does not pass cross tools to make

2019-04-07 Thread Helmut Grohne
Source: duktape Version: 2.3.0-1 Tags: patch User: helm...@debian.org Usertags: rebootstrap duktape fails to cross build from source, because it does not pass cross tools to make. The easiest way of fixing that - using dh_auto_build - makes duktape cross buildable. Please consider applying the

Bug#926605: webissues FTCBFS: uses the build architecture qmake

2019-04-07 Thread Helmut Grohne
Source: webissues Version: 1.1.5-3 Tags: patch User: helm...@debian.org Usertags: rebootstrap webissues fails to cross build from source, because it uses the build architecture qmake. The attached patch passes a suitable qmake via -qmake to ./configure and makes webissues cross buildable. Plase

Bug#925167: kmod: add softdep dwc3 to have GBit network on Odroid

2019-04-07 Thread Marco d'Itri
Control: reassign -1 src:linux Control: retitle -1 add a modules softdep to dwc3 to fix it on odroid On Mar 22, Jochen Sprickerhof wrote: > Not apart from that I was not aware of that option :). I've send a patch > upstream: > > https://marc.info/?l=linux-usb=155321315512949=2 > > and will

Bug#921176: redis-server service is failing to start in buster lxc container

2019-04-07 Thread Pierre-Elliott Bécue
Le dimanche 24 février 2019 à 15:01:14+0100, intrigeri a écrit : > Control: reassign -1 lxc > Control: severity -1 important > > Hi, > > Pirate Praveen: > > In dmesg inside container (same error on the host as well), so it seems > > apparmor is blocking it. > > > [14760.307180] audit:

Bug#926062: qbitorrent crashes, blames QNetworkAccessM

2019-04-07 Thread sledgehammer999
This seems the same bug as https://github.com/qbittorrent/qBittorrent/issues/9667 A possible workaround is in PR: https://github.com/qbittorrent/qBittorrent/pull/10445 Or you can just disable the download of tracker favicons from the advanced settings. Out of curiosity: How many trackers do you

Bug#916145: closure-compiler: Not working with recent JS code

2019-04-07 Thread Adrian Bunk
On Sun, Apr 07, 2019 at 11:12:30AM -0700, tony mancill wrote: >... > Somewhat related, given that closure-compiler upstream releases about > once a month on average, perhaps it is a candidate for doing Something > Different. That's pretty normal for a package, and we aren't even close to the

Bug#925899: lxc: Unprivileged containers fail to start after recent updates

2019-04-07 Thread Pierre-Elliott Bécue
Le dimanche 31 mars 2019 à 14:55:52+0200, intrigeri a écrit : > Hi, > > Regis Smith: > >> > lxc-start: test: lsm/apparmor.c: apparmor_prepare: 974 Cannot use > > generated profile: apparmor_parser not available > > I've reproduced this problem and I could fix it with: > > lxc.apparmor.profile

Bug#916145: closure-compiler: Not working with recent JS code

2019-04-07 Thread tony mancill
On Sun, Apr 07, 2019 at 11:16:53AM +0300, Adrian Bunk wrote: > On Sat, Apr 06, 2019 at 06:13:05PM +0200, Chris Hofstaedtler wrote: > > * Roland Gruber [190406 16:07]: > > > the current version is so old that it got incompatible with recent JS > > > code. > > > E.g. jQuery 3.3.1 cannot be

Bug#913823: apache2: dav.load does not check for an already loaded dav_module

2019-04-07 Thread Stefan Fritsch
On Friday, 1 February 2019 03:49:22 CEST Nye Liu wrote: > Package: apache2 > Version: 2.4.38-1 > Followup-For: Bug #913823 > > Workaround in /etc/apache2/mods-available/dav.load: > > > LoadModule dav_module /usr/lib/apache2/modules/mod_dav.so > > > Alternately just make dav_fs not depend

Bug#926212: gnome-shell crashed (segfault)

2019-04-07 Thread Bernhard Übelacker
Hello Guenter Grodotzki, (I guess you wanted me to receive your last message, so you should use "reply all", or it gets just attached to your bug report.) I have left a note in this upstream report [1], lets see if they agree. Kind regards, Bernhard [1]

Bug#869318: libimage-sane-perl FTBFS randomly: build hangs during tests

2019-04-07 Thread Santiago Vila
retitle 869318 libimage-sane-perl: FTBFS randomly: build hangs during tests tags 869318 - unreproducible thanks Greetings. I can reproduce the random nature of this bug on START1-S instances from Scaleway (amd64). The failure rate is around 25% here. I've put a bunch of build logs here:

Bug#925455: alsa volume never saved/restored

2019-04-07 Thread Elimar Riesebieter
* gregor herrmann [2019-04-07 18:16 +0200]: > On Sun, 07 Apr 2019 18:05:06 +0200, Elimar Riesebieter wrote: > > > > There is a commit in the packaging repo which claims to fix this bug: > > > https://salsa.debian.org/alsa-team/alsa-utils/commit/af161676131e94bbaed72f37d0c5d4c6685a119e > > Jordi

Bug#920665: xwayland: Crash with external display, notifications, and screen idle [upstream patch attached]

2019-04-07 Thread Andreas Boll
Hi, On Thu, Apr 04, 2019 at 04:30:31PM +0300, csaavedra...@gmail.com wrote: > I see that this landed in unstable (in the next upstream release) but > testing is still affected, as it's frozen. I installed testing in a new > machine and I have hit this crasher again. I think this should be >

Bug#926603: Debian fails to start after installation into Virtualbox

2019-04-07 Thread Andy Ruddock
Package: systemd Severity: critical I'm running Windows 10 (Home edition - up to date) on the desktop, with Virtualbox (v6.0.4). I've used both the netinst CD & the testing DVD (downloaded today - 07/Apr/2019) to install Buster. After installation the system fails to start with many errors. The

Bug#919914: gnome-tweaks now equates "don't suspend on lid close" with "don't lock on lid close" (security issue)

2019-04-07 Thread intrigeri
intrigeri: > Would you be interested in testing whether > https://gitlab.gnome.org/GNOME/gnome-settings-daemon/merge_requests/84 > fixes this problem for you? FWIW the patch proposed upstream applies nicely on top of our debian/unstable branch:

Bug#926602: jinja2: CVE-2019-10906

2019-04-07 Thread Salvatore Bonaccorso
Source: jinja2 Version: 2.10-1 Severity: grave Tags: patch security upstream Hi, The following vulnerability was published for jinja2. CVE-2019-10906[0]: | In Pallets Jinja before 2.10.1, str.format_map allows a sandbox | escape. If you fix the vulnerability please also make sure to include

Bug#649492: libimdi0: Typo in package description

2019-04-07 Thread Jörg Frings-Fürst
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 reassign 649492 libimdi0 thanks Hi, libimdi0 is not part of argyll. CU Jörg - -- New: GPG Fingerprint: 63E0 075F C8D4 3ABB 35AB 30EE 09F8 9F3C 8CA1 D25D GPG key (long) : 09F89F3C8CA1D25D GPG Key: 8CA1D25D CAcert Key S/N : 0E:D4:56

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-04-07 Thread Guilhem Moulin
On Sun, 07 Apr 2019 at 18:12:45 +0200, gregor herrmann wrote: > On Sun, 18 Nov 2018 19:41:05 +0200, Niko Tyni wrote: > >> Reiterating a bit: the underlying issue with TLSv1.3 seems to be related >> to handling of 'non-application_data_records'. >> >> The client tries to POST but gets an 'SSL

Bug#926601: VarDirInode-n reports link count mismatches

2019-04-07 Thread Marc Haber
Package: aide Version: 0.16.1-1 Severity: normal Hi, this might be a bug or a user error. aide --update reports: --- Removed and changed entries: --- d ...n .. : /run

Bug#881771: release-notes: No mention of "predictable network interface names" in Debian 10

2019-04-07 Thread Justin B Rye
Andrei POPESCU wrote: >> In issues.dbk: >> >> >> Migrating from legacy network interface names >> >> If your system was upgraded from an earlier release, and still uses >> the old-style network interface names that were deprecated with >> stretch (such as eth0 or wlan),

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-04-07 Thread gregor herrmann
On Sun, 18 Nov 2018 19:41:05 +0200, Niko Tyni wrote: > Reiterating a bit: the underlying issue with TLSv1.3 seems to be related > to handling of 'non-application_data_records'. > > The client tries to POST but gets an 'SSL wants a read first' error, > then waits until timeout for the socket to

Bug#925455: alsa volume never saved/restored

2019-04-07 Thread gregor herrmann
On Sun, 07 Apr 2019 18:05:06 +0200, Elimar Riesebieter wrote: > > There is a commit in the packaging repo which claims to fix this bug: > > https://salsa.debian.org/alsa-team/alsa-utils/commit/af161676131e94bbaed72f37d0c5d4c6685a119e > Jordi is MIA at the moment. Tried to reach him since a few

Bug#925455: alsa volume never saved/restored

2019-04-07 Thread Elimar Riesebieter
* gregor herrmann [2019-04-07 17:46 +0200]: > Control: tag -1 + patch pending > > On Mon, 25 Mar 2019 12:05:36 +0100, Laurent Bigonville wrote: > > > The more obvious solution would of course be to remove the condition in the > > .service file > > There is a commit in the packaging repo which

Bug#926600: eom: missing depends for gir1.2-eom-1.0

2019-04-07 Thread Bernhard Helmling
Package: eom Version: 1.20.2-2 Severity: normal Dear Maintainer, * What led up to the situation? start eom * What was the outcome of this action? an error: loading Eom typelib: Typelib file for namespace 'Eom', version '1.0' not found * What outcome did you expect instead?

Bug#926305: nis startup scripts are completely broken

2019-04-07 Thread Andreas Henriksson
Hello everyone, Greetings from the Gothenburg BSP. If someone is interested in modernizing the nis package it seems like ArchLinux has native systemd units for nis and related services so I'd suggest importing those: https://aur.archlinux.org/packages/nis-utils/

Bug#925455: alsa volume never saved/restored

2019-04-07 Thread gregor herrmann
Control: tag -1 + patch pending On Mon, 25 Mar 2019 12:05:36 +0100, Laurent Bigonville wrote: > The more obvious solution would of course be to remove the condition in the > .service file There is a commit in the packaging repo which claims to fix this bug:

Bug#914034: bug in Net::SSLeay?

2019-04-07 Thread Guilhem Moulin
Control: usertag -1 bsp-2019-04-se-gothenburg Hi there, strace(1) shows a select(2) syscall indicating that the socket is ready for both read and write, but is later blocking on a read(2) without any write(2) taking place. select(8, [3], [3], NULL, {tv_sec=180, tv_usec=0}) = 2 (in [3], out

Bug#916332: local tiled installation

2019-04-07 Thread nyov
I had the same or a similar error to what you see. The issue was for me (and I think is likely the same for you) that I had an older local tiled installation, built from source. This installed a version of `libtiled.so` which get's looked up by the newer tiled, but doesn't work with it, so you

Bug#926598: xmlstarlet fo --omit-decl exits with non-zero code

2019-04-07 Thread Etienne Dechamps
Package: xmlstarlet Version: 1.6.1-2 Steps to reproduce: $ echo '' | xmlstarlet fo --omit-decl; echo $? Expected result: 0 Actual result: 5 What's really weird is that the returned error code is always identical to the number of bytes written to the output. This bug seems to only occur

Bug#924365: www.debian.org: FTBFS in buster: turkish vs. tr_TR locale

2019-04-07 Thread Laura Arjona Reina
Hello Ömer To avoid such errors you need to make the english folder first, I think make -j1 -C english STRICT_ERROR_CHECKS=1 USE_SAMPLE_FILES=1 and then make -j1 -C turkish STRICT_ERROR_CHECKS=1 USE_SAMPLE_FILES=1 I cannot reproduce the error in Stretch, the error happens only in Buster.

Bug#887101: (no subject)

2019-04-07 Thread Gordon Ball
It is planned to ship the IPython LTS branch (5.x) for buster, maintaining single-source python2 and python3 compatibility. IPython and related tools 6.x and later drop python2 support. We'll aim to update and python3 versions and retain the existing python2 versions of interactive tools only

Bug#926576: ghostscript: printer stopped working: ghostscript fails with ""Unable to determine number of pages"

2019-04-07 Thread Till Kamppeter
I have released cups-filters 1.22.5 upstream now with the fix. Till

Bug#926597: unblock: golang-github-puerkitobio-purell/1.1.0-2

2019-04-07 Thread Andreas Henriksson
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Greetings from the Gothenburg BSP. Please unblock package golang-github-puerkitobio-purell unblock golang-github-puerkitobio-purell/1.1.0-2 Fixes FTBFS (testsuite failure) (Sorry, this

Bug#881771: release-notes: No mention of "predictable network interface names" in Debian 10

2019-04-07 Thread Andrei POPESCU
On Du, 07 apr 19, 15:32:32, Justin B Rye wrote: > Okay, here's a significantly trimmed-down version that we might be > able to use if it's bulked out with good external references. > > In issues.dbk: > > > Migrating from legacy network interface names > > If your system was

Bug#863468: (no subject)

2019-04-07 Thread Gordon Ball
I can confirm this bug is still present in 0.8.10, but I don't have a clear sense of how to fix it; awaiting an upstream fix.

Bug#926576: ghostscript: printer stopped working: ghostscript fails with ""Unable to determine number of pages"

2019-04-07 Thread Till Kamppeter
Thanks for reporting this. I have fixed the problem now by changing the Ghostscript call to count pages in a PDF file. See https://github.com/OpenPrinting/cups-filters/commit/297cc2d I found this solution with the help of a bug report to Arch Linux: https://bugs.archlinux.org/task/62251

Bug#926342: libprotobuf17: I was forced to download libprotobuf17 on this site: https://packages.debian.org/buster/amd64/libprotobuf17/download

2019-04-07 Thread GCS
On Fri, Apr 5, 2019 at 8:18 PM wrote: > C]I have just a file which name is apt-listbugs in /etc/apt/preferences.d : > > /etc/apt/preferences.d# ls -ail > total 12 > 1044672 drwxr-xr-x 2 root root 4096 mars 6 2018 . > 1044507 drwxr-xr-x 8 root root 4096 avril 5 08:44 .. > 1045052 -rw-r--r-- 1

Bug#926596: fwupdate: arm64 version of PE/COFF efi binary is corrupt

2019-04-07 Thread Ard Biesheuvel
Package: fwupdate Version: 12-4 Severity: important Dear Maintainer, Version 12-4 of fwupdate is broken for arm64. The included binary fwupaa64.efi is corrupt, resulting in EFI_LOAD_ERROR to be returned by the firmware when trying to invoke it. The binary layout looks like this: Detected

Bug#923930: testsuite comes with built-in time-bomb

2019-04-07 Thread Andreas Henriksson
Control: forwarded -1 https://github.com/heimdal/heimdal/issues/533 Greetings from the Gothenburg BSP. To summarize the above issue: - certs used in test-suite expired - upstream regenerated certs with 500 years expiration time set - this solves the issue on machines with 64bit time_t but

Bug#926577: eeschema: assert failed with more than one instance of hierarchical sheet

2019-04-07 Thread Carsten Schoenert
Hi, On Sun, Apr 07, 2019 at 11:45:50AM +0200, Cobra wrote: > When I try to create more than one instance of a hierarchical sheet, > an assert fails. After hitting "continue", the same error appears again > and again. I gave up after 10 repetitions and hit stop to kill kicad, > losing any

Bug#926380: golang-github-puerkitobio-purell: FTBFS (failing tests)

2019-04-07 Thread Shengjing Zhu
Hi, On Sun, Apr 7, 2019 at 10:09 PM Andreas Henriksson wrote: > > Greetings from the Gothenburg BSP. > > This is the output I get when reproducing this issue: > > ---8<->8- > > --- FAIL: TestEncodeNecessaryEscapesAll (0.00s) > purell_test.go:761: Got error parse http://host/ > > > �

Bug#882179: (no subject)

2019-04-07 Thread Gordon Ball
Unable to reproduce this. The output of `jupyter kernelspec list` provided shows that there is a custom install of ipykernel (python2) in /usr/local/share/jupyter/kernels/python2 shadowing python-ipykernel - maybe installed with `sudo pip install`? Try removing that version and see if the

Bug#881771: release-notes: No mention of "predictable network interface names" in Debian 10

2019-04-07 Thread Justin B Rye
Karl O. Pinc wrote: >> Whether I'm accessing it physically or via ssh, can't I use something >> like: >> udevadm test /sys/class/net/$ETHX 2>/dev/null | grep NET >> or >> udevadm test-builtin net_id /sys/class/net/$ETHX 2>/dev/null >> ...? That worked for me even on Jessie machine. > > I don't

Bug#926576: ghostscript: printer stopped working: ghostscript fails with ""Unable to determine number of pages"

2019-04-07 Thread Leonardo Canducci
c Il giorno dom 7 apr 2019 alle ore 11:56 Till Kamppeter < till.kamppe...@gmail.com> ha scritto: > Does > > gs -o - -dNODISPLAY > > using Ghostscript 9.27, with being a PDF file which you do > not succeed to print due to this problem, give you a list of "Page XX" > lines for each page in the

Bug#926595: python3 can't import scipy.misc

2019-04-07 Thread Stuart Prescott
Control: tags -1 + unreproducible moreinfo Hi Laurent, Perhaps you could include the output of $ apt-cache policy python3-numpy python3-scipy libblas3 for this report. > APT policy: (500, 'unstable'), (500, 'stable') this is not a promising sign btw. regards Stuart -- Stuart Prescott

Bug#919914: gnome-tweaks now equates "don't suspend on lid close" with "don't lock on lid close" (security issue)

2019-04-07 Thread intrigeri
Hi Josh, Josh Triplett: > Recently, disabling the setting "Suspend when laptop lid is closed" > seems to have started preventing *any* action on lid close, including > locking the screen; Would you be interested in testing whether

Bug#913110: (no subject)

2019-04-07 Thread Gordon Ball
The report above appears to reference .local/jupyter/kernels/python3/kernel.json , which would be a user-local kernel file not installed by the package. If the kernel file is wrong, I don't think this is a bug in jupyter-notebook. If the system-installed kernel file

Bug#926595: python3 can't import scipy.misc

2019-04-07 Thread laurent
Package: python3 Version: 3.7.3-1 Severity: important Tags: upstream Dear Maintainer, When trying to import scipy.misc in python3 [numpy scipy are both installed and were fonctionning correctly some weeks ago] I got the error below which accordingly to the debian user mailing list seems to be

Bug#374039: #374039 shutdown -h -H: warn that then cannot poweroff perhaps

2019-04-07 Thread Jesse Smith
> Halt action is to halt or drop into boot monitor on systems that > support it." is not enough to convey, that in many cases it brings > machine into state, when it is still on, display still showing > letters, but no interation (except physical poweroff) is possible. That is what halt means -

Bug#926380: golang-github-puerkitobio-purell: FTBFS (failing tests)

2019-04-07 Thread Andreas Henriksson
Greetings from the Gothenburg BSP. This is the output I get when reproducing this issue: ---8<->8- --- FAIL: TestEncodeNecessaryEscapesAll (0.00s) purell_test.go:761: Got error parse http://host/ � net/url: invalid control character in URL FAIL exit status 1 FAIL

Bug#924840: highwayhash: FTBFS - symbol missing

2019-04-07 Thread Rebecca N. Palmer
I do see this bug in both sid and mostly-buster (I haven't tried creating a new buster chroot). If only some people see this bug, but who sees it is reproducible, that could be a sign of another problem such as the package doing build-time hardware detection.

Bug#926575: Debidiff as a suggestion

2019-04-07 Thread Paul Wise
On Sun, 2019-04-07 at 11:52 +0200, Christian Ehrhardt wrote: > This debdiff was test built against gpsd in experimental and works > fine with it. I expect I'll just make a new upstream release after buster. -- bye, pabs https://wiki.debian.org/PaulWise signature.asc Description: This is a

Bug#926594: unblock: jupyter-notebook/5.7.8-1

2019-04-07 Thread Gordon Ball
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package jupyter-notebook, 5.7.4-2.1 -> 5.7.8-1 (pending approval before the latter version is uploaded to unstable). There are two new CVEs since 5.7.4: * CVE-2019-9644

Bug#926475: Uploads

2019-04-07 Thread Stefan Potyra
Hi Bruno, On Sat, Apr 06, 2019 at 04:56:29AM +0200, Bruno Kleinert wrote: > Hi Stefan, > > that's great! I offer reviews and will sponsor uploads :) cool, thanks for the offer :). Preliminary package available: dget http://potyra.de/dlt-viewer/dlt-viewer_2.18.0+dfsg-1.dsc Please give it a

Bug#926418: [Pkg-libvirt-maintainers] Bug#926418: libvirt: CVE-2019-3886: virsh domhostname command discloses guest hostname in readonly mode

2019-04-07 Thread Salvatore Bonaccorso
Hi Guido, On Fri, Apr 05, 2019 at 09:54:30PM +0200, Salvatore Bonaccorso wrote: > Hi Guido, > > On Fri, Apr 05, 2019 at 07:10:25PM +0200, Guido Günther wrote: > > Hi, > > On Thu, Apr 04, 2019 at 10:30:14PM +0200, Salvatore Bonaccorso wrote: > > > Source: libvirt > > > Version: 5.0.0-1 > > >

Bug#925473: tomcat9: sysvinit script missing (Policy §9.11¶2 “must”)

2019-04-07 Thread Thorsten Glaser
On Sun, 7 Apr 2019, Ivo De Decker wrote: > Also, I'm not sure adding an init script now is an approriate change > for the freeze. It is, it only touches systems on which it previously did not work. > Some other changes suggested in this bug (like changes in systemd) > certainly are not. This

Bug#925473: tomcat9: sysvinit script missing (Policy §9.11¶2 “must”)

2019-04-07 Thread Ivo De Decker
Control: tags -1 buster-ignore Hi, On Wed, Apr 03, 2019 at 02:33:47PM +0200, Thorsten Glaser wrote: > On Wed, 3 Apr 2019, Emmanuel Bourg wrote: > > > > I really insist on being able to install tomcat9 without having to > > > install a whole other init system, even if it is not used. > > > >

Bug#923986: ruby-pygments.rb: FTBFS randomly (failing tests)

2019-04-07 Thread Chris Lamb
Santiago Vila wrote: > I tried to build this package in buster but it failed: Hm, I've just built this package 20 times in sid and the tests pass every time. > My recommendation is that the failing tests are simply disabled for buster. If it's a specific test, then I recommend just disabling

Bug#916145: closure-compiler: Not working with recent JS code

2019-04-07 Thread Ivo De Decker
Control: severity -1 important Hi, On Sun, Apr 07, 2019 at 11:16:53AM +0300, Adrian Bunk wrote: > > Adrian: you raised the severity, care to lower it until buster is > > out (or say some words on why)? > > IMHO the release team adding a buster-ignore tag would be the best way > forward here -

Bug#905446: haskell-hackage-mirror: FTBFS: Module `Control.Monad.Trans.Resource' does not export `monadThrow'

2019-04-07 Thread Alexandre Peyroux
This package is deprecated. https://github.com/fpco/hackage-mirror Regards

Bug#917203: FTBFS on at least two architectures: test failure in the enigma algorithm

2019-04-07 Thread Chris Lamb
tags 917203 + pending thanks I've uploaded libmcrypt 2.5.8-3.4 to DELAYED/5: libmcrypt (2.5.8-3.4) unstable; urgency=medium * Non-maintainer upload. * Fix FTBFS on at least two architectures due to test failures in the "enigma". Thanks to Göran Weinholt (weinholt) for the

Bug#900912: Enabling jaw (Java-atk-wrapper) by default ? (Bug#900912)

2019-04-07 Thread Vincent Privat
If enabled by default, please offer a reliable way for applications to disable it. We don't need it for JOSM, and we have been so impacted with jaw's problems in the past years that we will never want it enabled by default for us. Le dim. 7 avr. 2019 à 12:08, Samuel Thibault a écrit : > Hello,

Bug#926479: Interesting ..

2019-04-07 Thread Christian Ehrhardt
Hi, that is very interesting, thanks for pulling me in. Since the same tests ran in Ubuntu for quite a while I checked it, but it looks good across the board [1] and since you posted an amd64 fail I checked that for Xenial [2] and Bionic [3] which both look non flaky to me on our infrastructure

Bug#926592: Buffer overflow in readlink running under fakechroot

2019-04-07 Thread John Williams
Package: fakechroot Version: 2.19-3 In an up-to-date installation of stretch, I do this: fakechroot readlink /etc/ssl/certs/* and get this: *** Error in readlink: free(): invalid next size (fast): 0xee312140 *** Note that this is *not* in a faked chroot. Looking at the source

  1   2   >