Bug#914747: bs1770gain FTCBFS: fails running tests despite DEB_BUILD_OPTIONS=nocheck

2018-11-26 Thread Helmut Grohne
(0.5.1-2.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Support DEB_BUILD_OPTIONS=nocheck. (Closes: #-1) + + -- Helmut Grohne Mon, 26 Nov 2018 22:32:02 +0100 + bs1770gain (0.5.1-2) unstable; urgency=medium [ Ondřej Nový ] diff --minimal -Nru bs1770gain-0.5.1/debian/rules

Bug#914740: agg FTCBFS: configures for the build architecture

2018-11-26 Thread Helmut Grohne
2018-11-26 21:57:00.0 +0100 @@ -1,3 +1,10 @@ +agg (1:2.4-r127+dfsg1-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Let dh_auto_configure pass --host to configure. (Closes: #-1) + + -- Helmut Grohne Mon, 26 Nov 2018 21:57:00 +0100 + agg (1:2.4-r127+dfsg1-1

Bug#914739: rdiff-backup-fs FTCBFS: uses the wrong pkg-config

2018-11-26 Thread Helmut Grohne
Source: rdiff-backup-fs Version: 1.0.0-5 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap rdiff-backup-fs fails to cross build from source, because configure.ac hard codes the build architecture pkg-config. The attached patch makes it use PKG_CHECK_MODULES, which automatically

Bug#914726: statserial FTCBFS: uses the build architecture compiler for linking

2018-11-26 Thread Helmut Grohne
Source: statserial Version: 1.1-23 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap statserial fails to cross build from source. Its Makefile uses the variables CC and LD to store the compiler. dh_auto_build only supplies CC. I propose that the Makefile should default LD to

Bug#914724: openssn FTCBFS: make install relinks with the wrong compiler

2018-11-26 Thread Helmut Grohne
Source: openssn Version: 1.4-2 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap openssn fails to cross build from source, because a bad makefile dependency causes make install to relink the main binary. dh_auto_install (unlike dh_auto_build) does not pass cross tools to make,

Bug#914715: mafft FTCBFS: builds for the wrong architecture

2018-11-26 Thread Helmut Grohne
17:20:38.0 +0100 @@ -1,3 +1,11 @@ +mafft (7.402-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Let dh_auto_build pass cross tools to make. (Closes: #-1) + * Also simplify debian/rules using --sourcedirectory. + + -- Helmut Grohne Mon, 26 Nov 2018 17:20:38

Bug#914660: entr FTCBFS: builds for the wrong architecture

2018-11-26 Thread Helmut Grohne
Please don't forget to Cc the bug. On Mon, Nov 26, 2018 at 08:16:39AM +0100, Yuri D'Elia wrote: > Hi Helmut, I'm aware of how the configure/Makefile of entr is far from > optimal. However, did you try to send and/or discuss the patch upstream? I did not. At the same time, my implementation is

Bug#914663: gxtuner does not trap errors from make

2018-11-25 Thread Helmut Grohne
Source: gxtuner Version: 3.0-1 Severity: serious Justification: policy 4.6 gxtuner's upstream Makefile does not trap errors from the compiler. Most compiler invocations carry a "-" prefix used for ignoring errors. That prefix violates policy section 4.6. It also makes debugging build failures

Bug#914661: parchive FTCBFS: builds for the wrong architecture

2018-11-25 Thread Helmut Grohne
+ + * Non-maintainer upload. + * Fix FTCBFS: Let dh_auto_build pass cross tools to make. (Closes: #-1) + + -- Helmut Grohne Mon, 26 Nov 2018 06:15:14 +0100 + parchive (1.1-4.1) unstable; urgency=medium * Non-maintainer upload. diff -u parchive-1.1/debian/rules parchive-1.1/debian/rules

Bug#914660: entr FTCBFS: builds for the wrong architecture

2018-11-25 Thread Helmut Grohne
without uname. ++ cross.patch: Make pkg-config substitutable. + + -- Helmut Grohne Mon, 26 Nov 2018 06:07:33 +0100 + entr (4.1-1) unstable; urgency=low [ Otto Kekäläinen ] diff --minimal -Nru entr-4.1/debian/patches/cross.patch entr-4.1/debian/patches/cross.patch --- entr-4.1/debian/patches

Bug#914645: zita-at1 FTBFS: freetype-config not found

2018-11-25 Thread Helmut Grohne
Source: zita-at1 Version: 0.6.0-1 Severity: serious Tags: ftbfs zita-at1 fails to build from source, because freetype-config cannot be found. freetype-config was removed from Debian and one is supposed to use pkg-config now. Helmut

Bug#914644: libicns FTCBFS: debian/rules uses the wrong pkg-config

2018-11-25 Thread Helmut Grohne
) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Use the host pkg-config. (Closes: #-1) + + -- Helmut Grohne Sun, 25 Nov 2018 22:01:14 +0100 + libicns (0.8.1-3.1) unstable; urgency=medium * Non-maintainer upload. diff --minimal -Nru libicns-0.8.1/debian/rules libicns-0.8.1

Bug#914642: netsniff-ng FTCBFS: builds for the wrong architecture

2018-11-25 Thread Helmut Grohne
-maintainer upload. + * Fix FTCBFS: Tell ./configure about the host architecture. (Closes: #-1) + + -- Helmut Grohne Sun, 25 Nov 2018 21:47:27 +0100 + netsniff-ng (0.6.5-1) unstable; urgency=low * New upstream release. diff --minimal -Nru netsniff-ng-0.6.5/debian/rules netsniff-ng-0.6.5

Bug#914638: ambdec FTBFS: freetype-config not found

2018-11-25 Thread Helmut Grohne
Source: ambdec Version: 0.5.1-5 Severity: serious Tags: ftbfs ambdec fails to build from source, because it uses freetype-config, which got removed from Debian. Please use pkg-config instead. Helmut

Bug#914637: jwm FTCBFS: uses the wrong pkg-config

2018-11-25 Thread Helmut Grohne
Source: jwm Version: 2.3.7-2 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap jwm fails to cross build from source, because it uses the wrong pkg-config. The attached patch fixes that and makes jwm cross buildable. Please consider applying it. Helmut ---

Bug#914636: stringencoder FTFBS: CC_FOR_BUILD turns out to be empty

2018-11-25 Thread Helmut Grohne
Source: stringencoders Version: 3.10.3+git20180306-1 Severity: serious Tags: ftbfs stringencoders fails to build from source on the buildds (e.g. https://buildd.debian.org/status/fetch.php?pkg=stringencoders=arm64=3.10.3%2Bgit20180306-1=1542718062=0). It seems that the variable CC_FOR_BUILD turns

Bug#914630: ht FTCBFS: tools/bin2c: Exec format error

2018-11-25 Thread Helmut Grohne
Source: ht Version: 2.1.0+repack1-3 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap ht fails to cross build from source, because it fails running tools/bin2hc. That file is a build tool and needs to be built with the build architecture compiler rather than the host

Bug#914628: darkstat FTCBFS: uses the host architecture compiler for build tool c-ify

2018-11-25 Thread Helmut Grohne
.0 +0100 +++ darkstat-3.0.719/debian/changelog 2018-11-25 20:38:41.0 +0100 @@ -1,3 +1,10 @@ +darkstat (3.0.719-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Supply HOSTCC to make. (Closes: #-1) + + -- Helmut Grohne Sun, 25 Nov 2018 20:38:41 +0100 +

Bug#914626: playmidi FTCBFS: builds for the wrong architecture

2018-11-25 Thread Helmut Grohne
; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Let dh_auto_build pass cross tools to make. ++ xplaymidi.sh also needs to use cross tools. + + -- Helmut Grohne Sun, 25 Nov 2018 19:34:37 +0100 + playmidi (2.4debian-11) unstable; urgency=medium * QA upload

Bug#914622: foobillardplus FTCBFS: uses the wrong pkg-config

2018-11-25 Thread Helmut Grohne
Source: foobillardplus Version: 3.43~svn170+dfsg-5 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap The patch that fixed #892338 in 3.43~svn170+dfsg-5 regressed cross building, because it improperly uses pkg-config and thus uses the wrong one. The attached patch defers

Bug#914593: mosquitto FTCBFS: uses the wrong compiler

2018-11-25 Thread Helmut Grohne
: Let dh_auto_build pass cross tools to make. (Closes: #-1) + + -- Helmut Grohne Sun, 25 Nov 2018 13:56:45 +0100 + mosquitto (1.5.4-1) unstable; urgency=medium * New upstream release (Closes: #911104). diff --minimal -Nru mosquitto-1.5.4/debian/rules mosquitto-1.5.4/debian/rules --- mosquitto

Bug#914588: normaliz FTCBFS: AC_RUN_IFELSE

2018-11-25 Thread Helmut Grohne
Source: normaliz Version: 3.6.3+ds-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap normaliz fails to cross build from source, because it uses AC_RUN_IFELSE to find a library. Normally, I'd just switch that to AC_LINK_IFELSE, but the comments kindly explain thet AC_RUN_IFELSE

Bug#914586: xfe FTCBFS: uses the wrong pkg-config

2018-11-25 Thread Helmut Grohne
Source: xfe Version: 1.42.1-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap The patch for #892445 included in version 1.42.1-1 regressed cross building of xfe. It now uses the wrong pkg-config. The attached patch fixes that. Please consider applying it. Helmut ---

Bug#914554: clxclient FTBFS: freetype-config not found

2018-11-24 Thread Helmut Grohne
Source: clxclient Version: 3.9.0-4 Severity: serious Tags: ftbfs patch upstream clxclient fails to build from source in unstable, because freetype-config got removed. You're supposed to use pkg-config instead. The attached patch fixes the build. Helmut --- clxclient-3.9.0.orig/Makefile +++

Bug#914486: libsdl2-ttf FTCBFS: uses the wrong pkg-config

2018-11-23 Thread Helmut Grohne
Source: libsdl2-ttf Version: 2.0.14+dfsg1-3 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap The patch for fixing #892441 in 2.0.14+dfsg1-3 uses the wrong pkg-config and that makes libsdl2-ttf fail to cross build. My attached patch fixes that. Please consider applying it.

Bug#914485: funtools FTCBFS: wrongly calls mklib

2018-11-23 Thread Helmut Grohne
Source: funtools Version: 1.4.7-3 Tags: patch User: helm...@debian.org Usertags: rebootstrap Hi Ole, thank you for fixing #882357. That made debugging funtools quite a bit easier. I fear that the fix is insufficient though. When the mklib script calls the linker and the linker fails, mklib

Bug#914480: fltk1.1 FTCBFS: uses the wrong pkg-config

2018-11-23 Thread Helmut Grohne
(1.1.10-25.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix usage of wrong pkg-config. (Closes: #-1) + + -- Helmut Grohne Fri, 23 Nov 2018 20:02:37 +0100 + fltk1.1 (1.1.10-25) unstable; urgency=medium * debian/rules (override_dh_auto_build-indep): Cover more subdirectories

Bug#914479: sdl-ttf2.0 FTCBFS: uses the wrong pkg-config

2018-11-23 Thread Helmut Grohne
Source: sdl-ttf2.0 Version: 2.0.11-5 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap sdl-ttf2.0 fails to cross build from source, because it uses the wrong pkg-config. It is a regression introduced in 2.0.11-5 for fixing #892435. The attached patch fixes it. Helmut ---

Bug#914476: flint-arb FTCBFS: ./configure needs to be told about crossing

2018-11-23 Thread Helmut Grohne
) + + -- Helmut Grohne Fri, 23 Nov 2018 19:41:26 +0100 + flint-arb (1:2.14.0-4) unstable; urgency=medium * Team upload. diff --minimal -Nru flint-arb-2.14.0/debian/rules flint-arb-2.14.0/debian/rules --- flint-arb-2.14.0/debian/rules 2018-09-26 20:25:16.0 +0200 +++ flint-arb-2.14.0

Bug#914386: fritzing FTBFS: arch-only build

2018-11-22 Thread Helmut Grohne
Source: fritzing Version: 0.9.3b+dfsg-6 Severity: serious Tags: ftbfs User: helm...@debian.org Usertags: rebootstrap While trying to cross build fritzing, I noticed that it fails to build from source natively. An arch-only build fails: | find /<>/fritzing-0.9.3b+dfsg/debian/fritzing-data/ -type

Bug#914375: canlock FTCBFS: AC_RUN_IFELSE

2018-11-22 Thread Helmut Grohne
Source: canlock Version: 3.0.2-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap canlock fails to cross build from source, because it uses AC_RUN_IFELSE to determine whether memset_s is available. For simply checking availability and checking whether the prototype matches,

Bug#913845: closed by Abhijith PA (Bug#913845: fixed in httping 2.5-4)

2018-11-19 Thread Helmut Grohne
Control: reopen -1 On Sat, Nov 17, 2018 at 12:09:08PM +, Debian Bug Tracking System wrote: > [Helmut Grohne] >* Fix FTCBFS: Export a cross compiler for ./configure and make. > (Closes: #913845) You applied the patch partially. Without including buildtools.mk, CC simpl

Bug#914110: cargo FTCBFS: uses plain cc for linking

2018-11-19 Thread Helmut Grohne
Source: cargo Version: 0.31.0-3 User: helm...@debian.org Usertags: rebootstrap Thank you for making cross building with rust work so well. Unfortunately, it doesn't quite work with cargo yet. Cross building it for armel yields: |Compiling cargo v0.31.0 (/<>) | Running `rustc

Bug#914044: HOME=/tmp kbuildsycoca5 is bad

2018-11-18 Thread Helmut Grohne
Source: tuxpaint Version: 1:0.9.23-1 Severity: important Tags: security tuxpaint runs "HOME=/tmp kbuildsycoca5" during build. I'm not exactly sure what this does, but I see a number of issues with doing so: * kbuildsycoca5 reads /tmp/.config/QtProject/qtlogging.ini. I'm not sure whether that

Bug#914039: zerofree FTCBFS again: passes CC=cc to make

2018-11-18 Thread Helmut Grohne
0:56.0 +0100 +++ zerofree-1.1.1/debian/changelog 2018-11-18 19:18:34.0 +0100 @@ -1,3 +1,10 @@ +zerofree (1.1.1-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS again: Don't force CC=cc. (Closes: #-1) + + -- Helmut Grohne Sun, 18 Nov 2018 19:18:34 +0100

Bug#914033: libterralib FTCBFS: runs qmake for the build architecture

2018-11-18 Thread Helmut Grohne
) + + -- Helmut Grohne Sun, 18 Nov 2018 16:49:13 +0100 + libterralib (4.3.0+dfsg.2-11) unstable; urgency=medium * Ack. patch and close bug: Closes: #831903 diff --minimal -Nru libterralib-4.3.0+dfsg.2/debian/rules libterralib-4.3.0+dfsg.2/debian/rules --- libterralib-4.3.0+dfsg.2/debian/rules

Bug#914019: qmodule.pri: leaks -fdebug-prefix-map

2018-11-18 Thread Helmut Grohne
Package: qt5-qmake File: /usr/lib//qt5/mkspecs/qmodule.pri Control: affects -1 + src:qtdeclarative-opensource-src While building qtdeclarative-opensource-src, I noticed that its build log contains -fdebug-prefix-map= flags that correspond to a qtbase-opensource-src build. Apparently those flags

Bug#910990: openttd FTCBFS: uses the build architecture pkg-config

2018-11-18 Thread Helmut Grohne
Hi Matthijs, On Sat, Nov 17, 2018 at 09:28:54PM +0100, Matthijs Kooijman wrote: > Thanks for testing and provide a patch. I've included in the build, and > verified it works. I did run into a problem running on a system where > buildtools.mk did not exist, due to the % wildcard rule (see >

Bug#870468: grdesktop FTCBFS: broken PKG_CHECK_MODULES copy uses build arch pkg-config

2018-11-16 Thread Helmut Grohne
I suggest that we end the discussion here. It's much easier to simply try cross building grdesktop than it is to argue what is going on. Turns out, grdesktop does find the right pkg-config despite shipping the outdated macro in aclocal.m4. Yavor's closure is correct. On Sat, Nov 17, 2018 at

Bug#913927: gemdropx FTCBFS: builds for the wrong architecture

2018-11-16 Thread Helmut Grohne
2018-11-17 06:36:27.0 +0100 @@ -1,3 +1,10 @@ +gemdropx (0.9-7.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Let dh_auto_build pass cross tools to make. (Closes: #-1) + + -- Helmut Grohne Sat, 17 Nov 2018 06:36:27 +0100 + gemdropx (0.9-7) unstable

Bug#913866: [Debian-ha-maintainers] Bug#913866: dlm FTCBFS: uses the wrong pkg-config

2018-11-16 Thread Helmut Grohne
On Fri, Nov 16, 2018 at 09:09:56AM +0100, Valentin Vidic wrote: > > dlm fails to cross build from source, because the upstream Makefile hard > > codes the build architecture pkg-config. The attached patch makes > > pkg-config substitutable. dh_auto_build substitutes it and dlm becomes > > cross

Bug#913866: dlm FTCBFS: uses the wrong pkg-config

2018-11-15 Thread Helmut Grohne
Source: dlm Version: 4.0.7-3 Tags: patch upstream dlm fails to cross build from source, because the upstream Makefile hard codes the build architecture pkg-config. The attached patch makes pkg-config substitutable. dh_auto_build substitutes it and dlm becomes cross buildable. Please consider

Bug#870468: grdesktop FTCBFS: broken PKG_CHECK_MODULES copy uses build arch pkg-config

2018-11-15 Thread Helmut Grohne
Hi Jeremy, On Thu, Nov 15, 2018 at 05:19:15PM -0500, Jeremy Bicha wrote: > grdesktop 0.23+d040330-3.1 uploaded today uses autoreconf with dh > compat 11. Is that enough to fix this bug or is something else still > needed? Using autoreconf is part of the solution. Usually though, autoreconf

Bug#913845: httping FTCBFS: builds for the wrong architecture

2018-11-15 Thread Helmut Grohne
On Fri, Nov 16, 2018 at 08:49:10AM +0530, Abhijith PA wrote: > BTW, can you tell, on which architecture build you are trying to fix ? I'm performing almost all of my builds on amd64, cause fast machines are affordable there. However the nature of cross builds is to build for another

Bug#913845: httping FTCBFS: builds for the wrong architecture

2018-11-15 Thread Helmut Grohne
upload. + * Fix FTCBFS: Export a cross compiler for ./configure and make. (Closes: #-1) + + -- Helmut Grohne Thu, 15 Nov 2018 22:47:14 +0100 + httping (2.5-3.1) unstable; urgency=medium * Non-maintainer upload. diff --minimal -Nru httping-2.5/debian/rules httping-2.5/debian/rules --- httping-2.5

Bug#913842: mergerfs FTCBFS: builds for the wrong architecture

2018-11-15 Thread Helmut Grohne
2018-11-15 22:26:40.0 +0100 @@ -1,3 +1,10 @@ +mergerfs (2.24.2-3.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Let dh_auto_configure pass --host to libfuse/configure. ++ Pass CXX to make install as it insists on relinking. + + -- Helmut

Bug#913841: xfireworks FTCBFS: builds for the wrong architecture

2018-11-15 Thread Helmut Grohne
) ++ Let dh_auto_bild pass cross tools to make. ++ cross.patch: Use the build architecture compiler for mkconf.c. + + -- Helmut Grohne Thu, 15 Nov 2018 21:59:55 +0100 + xfireworks (1.3-10) unstable; urgency=low [ Yukiharu YABUKI ] diff --minimal -Nru xfireworks-1.3/debian/control xfireworks

Bug#913735: mergerfs: unregistered embedded copy of libfuse

2018-11-14 Thread Helmut Grohne
Source: mergerfs Version: 2.24.2-3 Severity: important mergerfs contains an embedded copy of libfuse that is not registered with the security tracker. It does Build-Depend on libfuse-dev, but rather than using it, it uses its own embedded copy. Please remove the embedded copy. Failing that,

Bug#869952: update build profile patch

2018-11-14 Thread Helmut Grohne
ian/changelog 2018-11-14 09:28:47.0 +0100 @@ -1,3 +1,10 @@ +db5.3 (5.3.28+dfsg1-0.3) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Use build profiles. (Closes: #869952) + + -- Helmut Grohne Wed, 14 Nov 2018 09:28:47 +0100 + db5.3 (5.3.28+dfsg1-0.2) unstable; urgency=medium

Bug#913734: snake4 FTCBFS: make install strips with the wrong strip

2018-11-14 Thread Helmut Grohne
/changelog 2018-11-14 06:18:56.0 +0100 @@ -1,3 +1,10 @@ +snake4 (1.0.14-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Don't strip during make install. (Closes: #-1) + + -- Helmut Grohne Wed, 14 Nov 2018 06:18:56 +0100 + snake4 (1.0.14-1) unstable; urgency

Bug#898571: build dependency cycle between icu and icu-le-hb

2018-11-13 Thread Helmut Grohne
Control: reopen -1 Control: found -1 icu/63.1-4 On Sun, May 13, 2018 at 07:52:14PM +0200, Helmut Grohne wrote: > icu introduces a build dependency cycle with icu-le-hb. Doing so breaks > architecture bootstrap. The full cycle is: > > src:icu Build-Depends: libicu-le-hb-dev > l

Bug#913668: collectd confuses build/host

2018-11-13 Thread Helmut Grohne
Source: collectd Version: 5.8.0-5.2 Tags: patch User: helm...@debian.org Usertags: rebootstrap I looked into cross building collectd and that turns out to be difficult. However one thing became apparent quite quickly to me: debian/rules confuses build and host. These terms are defined in man

Bug#913589: pqiv FTCBFS: builds for the wrong architecture

2018-11-12 Thread Helmut Grohne
. + + -- Helmut Grohne Mon, 12 Nov 2018 17:38:48 +0100 + pqiv (2.10.4-1) unstable; urgency=medium * New maintainer. diff --minimal -Nru pqiv-2.10.4/debian/patches/cross.patch pqiv-2.10.4/debian/patches/cross.patch --- pqiv-2.10.4/debian/patches/cross.patch 1970-01-01 01:00:00.0 +0100

Bug#913579: converseen FTCBFS: does not pass cross flags to cmake

2018-11-12 Thread Helmut Grohne
@@ +converseen (0.9.7.2-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Let dh_auto_* work correctly. (Closes: #-1) + + -- Helmut Grohne Mon, 12 Nov 2018 16:00:10 +0100 + converseen (0.9.7.2-1) unstable; urgency=medium * New upstream release. diff --minimal -Nru

Bug#913545: outguess FTCBFS: uses the wrong compiler for jpeg-6b-steg

2018-11-11 Thread Helmut Grohne
Source: outguess Version: 1:0.2+dfsg.1-4 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap outguess fails to cross build from source, because it uses the build architecture compiler for the jpeg-6b-steg subdirectory. The ./configure script correctly detects and forwards the

Bug#913519: glyr: successfully cross builds a broken package

2018-11-11 Thread Helmut Grohne
:44.0 +0100 @@ -1,3 +1,10 @@ +glyr (1.0.10-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix build/host confusion. (Closes: #-1) + + -- Helmut Grohne Sun, 11 Nov 2018 21:08:44 +0100 + glyr (1.0.10-1) unstable; urgency=medium * New upstream release. diff --minimal -Nru

Bug#913518: brisk-menu: successfully cross builds a broken package

2018-11-11 Thread Helmut Grohne
2018-11-11 21:04:51.0 +0100 @@ -1,3 +1,10 @@ +brisk-menu (0.5.0-8.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix build/host confusion. (Closes: #-1) + + -- Helmut Grohne Sun, 11 Nov 2018 21:04:51 +0100 + brisk-menu (0.5.0-8) unstable; urgency=medium [ Martin

Bug#913515: mupdf FTCBFS: ld/pkg-config woes

2018-11-11 Thread Helmut Grohne
+ + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Supply a cross LD for wrapping fonts. ++ Supply PKG_CONFIG to all make targets. + + -- Helmut Grohne Sun, 11 Nov 2018 19:58:22 +0100 + mupdf (1.14.0+ds1-2) unstable; urgency=medium * Fix FTBFS on mips64el diff --minimal

Bug#913500: cargo FTBFS: rustc segfaults

2018-11-11 Thread Helmut Grohne
Source: cargo Version: 0.31.0-3 Severity: serious Tags: ftbfs rustc segfauls while building cargo. For instance on amd64: https://buildd.debian.org/status/fetch.php?pkg=cargo=amd64=0.31.0-3=1541763110=0 | process didn't exit successfully: `rustc --crate-name build_script_build

Bug#913499: qtbase-5-dev: /usr/lib//cmake/Qt5Core/Qt5CoreConfigExtras.cmake: wrong path for Qt5::qmake

2018-11-11 Thread Helmut Grohne
Package: qtbase5-dev Version: 5.11.2+dfsg-4 File: /usr/lib//cmake/Qt5Core/Qt5CoreConfigExtras.cmake User: helm...@debian.org Usertags: rebootstrap Control: affects -1 + src:libqtxdg Qt5CoreConfigExtras.cmake defines the IMPORTED_LOCATION of Qt5::qmake as

Bug#913432: thunar-media-tags-plugin: Build-Depends: libxml-parser-perl is cross-unsatisfiable

2018-11-10 Thread Helmut Grohne
) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Drop unused Build-Depends: libxml-parser-perl. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 22:20:34 +0100 + thunar-media-tags-plugin (0.3.0-1) unstable; urgency=medium [ Evgeni Golov ] diff --minimal -Nru thunar-media-tags

Bug#913430: mark libxml-commons-external-java Multi-Arch: foreign

2018-11-10 Thread Helmut Grohne
2018-11-10 22:05:25.0 +0100 @@ -1,3 +1,10 @@ +xml-commons-external (1.4.01-3.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Mark all packages Multi-Arch: foreign. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 22:05:25 +0100 + xml-commons-external (1.4.01-3

Bug#913429: highlight build/host confusion with $Config{vendorarch}

2018-11-10 Thread Helmut Grohne
/changelog 2018-11-10 21:48:26.0 +0100 @@ -1,3 +1,10 @@ +highlight (3.41-2.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Install the perl module to the host's $vendorarch. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 21:48:26 +0100 + highlight (3.41-2) unstable

Bug#913425: debhelper: wrong CMAKE_SYSTEM_PROCESSOR for ppc64el when crossing

2018-11-10 Thread Helmut Grohne
the usual CMAKE_SYSTEM_PROCESSOR for ppc64el when +cross compiling. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 21:26:52 +0100 + debhelper (11.5.1) unstable; urgency=medium * dh_systemd_start: Fix bug introduced in debhelper/11.5 where diff --minimal -Nru debhelper-11.5.1/lib

Bug#913422: serd FTCBFS: waf/python

2018-11-10 Thread Helmut Grohne
~dfsg0/debian/changelog 2018-11-10 20:55:05.0 +0100 @@ -1,3 +1,10 @@ +serd (0.28.0~dfsg0-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Build-Depends request build architecture python. ++ Tell waf what we build for. + + -- Helmut Grohne

Bug#913417: python-stdlib-extensions FTCBFS: multiple reasons

2018-11-10 Thread Helmut Grohne
@@ +python-stdlib-extensions (2.7.15-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Multiarchify Build-Depends. ++ Set up PYTHONPATH for cross compilation. ++ cross.patch: Don't import built modules. + + -- Helmut Grohne Sat, 10 Nov 2018 15:34

Bug#913416: mate-polkit misbuilds due to build/host confusion

2018-11-10 Thread Helmut Grohne
--- mate-polkit-1.20.1/debian/changelog 2018-07-05 18:31:46.0 +0200 +++ mate-polkit-1.20.1/debian/changelog 2018-11-10 19:47:50.0 +0100 @@ -1,3 +1,10 @@ +mate-polkit (1.20.1-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix build/host confusion. (Closes: #-1) + + -

Bug#913415: debhelper: cmake buildsystem should pass QMAKE_EXECUTABLE for cross

2018-11-10 Thread Helmut Grohne
+1,10 @@ +debhelper (11.5.1+nmu1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * cmake buildsystem: Pass QMAKE_EXECUTABLE for cross. (Closes: #-1) + + -- Helmut Grohne Fri, 09 Nov 2018 20:03:20 +0100 + debhelper (11.5.1) unstable; urgency=medium * dh_systemd_start: Fix bug

Bug#911944: neovim FTBFS: tests fail

2018-11-10 Thread Helmut Grohne
Hi James, On Sat, Nov 10, 2018 at 09:29:42AM -0500, James McCoy wrote: > On Fri, Oct 26, 2018 at 03:30:54PM +0200, Helmut Grohne wrote: > > neovim fails to build from source in unstable. > > > > | [ ERROR ] 6 errors, listed below: > > | [ ERROR ] test/f

Bug#913401: cracklib2 FTCBFS: python stuff

2018-11-10 Thread Helmut Grohne
; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Multiarchify python Build-Depends. ++ Tell setup.py what to cross for. ++ Honour DEB_BUILD_OPTIONS=nocheck. + + -- Helmut Grohne Sat, 10 Nov 2018 15:06:23 +0100 + cracklib2 (2.9.2-5.2) unstable; urgency=med

Bug#913394: gparted FTCBFS: Build-Depends: libxml-parser-perl unsatisfiable

2018-11-10 Thread Helmut Grohne
from Build-Depends. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 09:05:44 +0100 + gparted (0.32.0-2) unstable; urgency=medium * Really suggest e2fsprogs (Closes: #887225) diff --minimal -Nru gparted-0.32.0/debian/control gparted-0.32.0/debian/control --- gparted-0.32.0/debian/control

Bug#913399: mark libjs-excanvas Multi-Arch: foreign

2018-11-10 Thread Helmut Grohne
) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Mark libjs-excanvas Multi-Arch: foreign. (Closes: #-1) + + -- Helmut Grohne Sat, 10 Nov 2018 14:24:47 +0100 + explorercanvas (0.r3-4) unstable; urgency=low * Use canonical Vcs-fields diff --minimal -Nru explorercanvas-0.r3/debian

Bug#913376: mousepad FTCBFS: dependency on libxml-parser-perl unsatisfiable

2018-11-10 Thread Helmut Grohne
:53:34.0 +0200 +++ mousepad-0.4.1/debian/changelog 2018-11-10 08:56:51.0 +0100 @@ -1,3 +1,11 @@ +mousepad (0.4.1-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Drop unused libxml-parser-perl from Build-Depends. +(Closes: #-1) + + -- Helmut Grohne

Bug#913375: iotop FTCBFS: python build dependency not satisfiable

2018-11-09 Thread Helmut Grohne
as pybuild needs that as well. + + -- Helmut Grohne Sat, 10 Nov 2018 08:41:46 +0100 + iotop (0.6-24-g733f3f8-1) unstable; urgency=medium * New upstream snapshot diff --minimal -Nru iotop-0.6-24-g733f3f8/debian/control iotop-0.6-24-g733f3f8/debian/control --- iotop-0.6-24-g733f3f8/debian

Bug#913291: wireless-tools misbuilds: installs to build architecture multiarch directory

2018-11-08 Thread Helmut Grohne
:30.0 +0100 @@ -1,3 +1,11 @@ +wireless-tools (30~pre9-13.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix misbuild: install to host architecture multiarch directory. +(Closes: #-1) + + -- Helmut Grohne Fri, 09 Nov 2018 06:16:30 +0100 + wireless-tools (30~pre9-13

Bug#913267: ki18n FTCBFS: build dependency python3 not installable

2018-11-08 Thread Helmut Grohne
16:18:34.0 +0200 +++ ki18n-5.49.0/debian/changelog 2018-11-08 21:02:47.0 +0100 @@ -1,3 +1,10 @@ +ki18n (5.49.0-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Annotate python3 build dependency with :any. (Closes: #-1) + + -- Helmut Grohne Thu

Bug#913263: meson: wrongly caches dependency() results

2018-11-08 Thread Helmut Grohne
Package: meson Version: 0.48.1-1 User: helm...@debian.org Usertags: rebootstrap Meson wrongly caches the result of a dependency() call. If you need a dependency for both the build architecture and host architecture, meson caches uses the results from the first invocation for the other invocation.

Bug#913244: liblinear FTCBFS: python build dependencies not installable

2018-11-08 Thread Helmut Grohne
16:56:30.0 +0200 +++ liblinear-2.1.0+dfsg/debian/changelog 2018-11-08 17:42:05.0 +0100 @@ -1,3 +1,10 @@ +liblinear (2.1.0+dfsg-2.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Move python Build-Depends to Build-Depends-Indep. (Closes: #-1) + + -- Helmut

Bug#913243: qtdeclarative-opensource-src FTCBFS: Build-Depends: python is not installable

2018-11-08 Thread Helmut Grohne
@@ -1,3 +1,10 @@ +qtdeclarative-opensource-src (5.11.2-2.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Annotate Build-Depends: python with :any. (Closes: #-1) + + -- Helmut Grohne Thu, 08 Nov 2018 17:36:20 +0100 + qtdeclarative-opensource-src (5.11.2-2) unstable

Bug#913241: libgit2 FTCBFS: python-minimal dependency not installable

2018-11-08 Thread Helmut Grohne
) + + -- Helmut Grohne Thu, 08 Nov 2018 17:28:35 +0100 + libgit2 (0.27.4+dfsg.1-0.1) unstable; urgency=medium * Non-maintainer upload. diff --minimal -Nru libgit2-0.27.4+dfsg.1/debian/control libgit2-0.27.4+dfsg.1/debian/control --- libgit2-0.27.4+dfsg.1/debian/control2018-08-07 07:48

Bug#913150: libnatpmp FTCBFS: python Build-Depends not installable

2018-11-07 Thread Helmut Grohne
tpmp-20150609/debian/changelog 2018-11-07 16:18:08.0 +0100 @@ -1,3 +1,10 @@ +libnatpmp (20150609-5.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: multiarchify python Build-Depends. (Closes: #-1) + + -- Helmut Grohne Wed, 07 Nov 2018 16:18:08 +0100 + libnatpmp (

Bug#913149: gtkspell FTCBFS: libxml-parser-perl unsatisfiable

2018-11-07 Thread Helmut Grohne
+embeds intltool. (Closes: #-1) + + -- Helmut Grohne Wed, 07 Nov 2018 16:10:18 +0100 + gtkspell (2.0.16-1.2) unstable; urgency=medium * Non-maintainer upload. diff --minimal -Nru gtkspell-2.0.16/debian/control gtkspell-2.0.16/debian/control --- gtkspell-2.0.16/debian/control 2018-01-26

Bug#913148: libpwquality FTCBFS: issues with python

2018-11-07 Thread Helmut Grohne
00 @@ -1,3 +1,12 @@ +libpwquality (1.4.0-2.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: (Closes: #-1) ++ Transform Build-Depends. ++ Export PYTHONPATH for python2.7. + + -- Helmut Grohne Wed, 07 Nov 2018 15:39:04 +0100 + libpwquality (1.4.0-2) unstable; urge

Bug#913117: libplist FTCBFS: python build dependencies not installable

2018-11-06 Thread Helmut Grohne
@@ +libplist (2.0.0-5.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Update python build depends for cross building. (Closes: #-1) + + -- Helmut Grohne Wed, 07 Nov 2018 07:53:50 +0100 + libplist (2.0.0-5) unstable; urgency=medium * QA upload. diff --minimal -Nru

Bug#913115: libssh FTCBFS: python3 build dependency not installable

2018-11-06 Thread Helmut Grohne
/changelog 2018-11-07 07:47:00.0 +0100 @@ -1,3 +1,10 @@ +libssh (0.8.4-3.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Fix FTCBFS: Annotate python3 build dependency with :any. (Closes: #-1) + + -- Helmut Grohne Wed, 07 Nov 2018 07:47:00 +0100 + libssh (0.8.4-3

Bug#913113: libqmi FTCBFS: python build depends, gtk-doc failure

2018-11-06 Thread Helmut Grohne
S: (Closes: #-1) ++ Annotate python build dependency with :any. ++ Disable gtk-doc for arch-only builds. + + -- Helmut Grohne Wed, 07 Nov 2018 06:17:30 +0100 + libqmi (1.20.0-1.1) unstable; urgency=medium * Non-maintainer upload. diff --minimal -Nru libqmi-1.20.0/debian/control lib

Bug#913094: apache2 FTCBFS: multiple reasons

2018-11-06 Thread Helmut Grohne
) ++ Annotate perl build dependency with :any. ++ cross.patch: Use AC_PATH_TOOL to find pkg-config. ++ Generate server/test_char.h ahead of the build + + -- Helmut Grohne Tue, 06 Nov 2018 20:19:31 +0100 + apache2 (2.4.37-1) unstable; urgency=medium * New upstream version diff --minimal

Bug#913081: liblouis FTCBFS: python* Build-Depends unsatisfiable

2018-11-06 Thread Helmut Grohne
:53.0 +0100 @@ -1,3 +1,10 @@ +liblouis (3.7.0-1.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Demote python stuff to Build-Depends-Indep. (Closes: #-1) + + -- Helmut Grohne Tue, 06 Nov 2018 06:26:53 +0100 + liblouis (3.7.0-1) unstable; urgency=medium * New upstream

Bug#913006: move libmpeg3.pc to a multiarch location

2018-11-05 Thread Helmut Grohne
:08.0 +0100 +++ libmpeg3-1.8.dfsg/debian/changelog 2018-11-05 21:31:32.0 +0100 @@ -1,3 +1,10 @@ +libmpeg3 (1.8.dfsg-2.2) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Move libmpeg3.pc to a multiarch location. (Closes: #-1) + + -- Helmut Grohne Mon, 05 Nov 2018 21:31

Bug#912942: pygobject-2: please annotate test dependencies with

2018-11-04 Thread Helmut Grohne
+++ pygobject-2-2.28.6/debian/changelog 2018-11-05 05:50:23.0 +0100 @@ -1,3 +1,10 @@ +pygobject-2 (2.28.6-13.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Reduce build dependencies using profile. (Closes: #-1) + + -- Helmut Grohne Mon, 05 Nov 2018 05:50:23 +0100 + pygobject-2

Bug#912846: grub2: stop depending on ttf-dejavu-core

2018-11-04 Thread Helmut Grohne
Control: reassign -1 ttf-dejavu-core Control: found -1 ttf-dejavu-core/2.37-1 Control: retitle -1 ttf-dejavu-core has a misleading package description Hi Colin, On Mon, Nov 05, 2018 at 12:22:11AM +, Colin Watson wrote: > On Sun, Nov 04, 2018 at 03:57:50PM +0100, Helmut Grohne wr

Bug#912911: redland FTCBFS: (host) perl dependency unsatisfiable

2018-11-04 Thread Helmut Grohne
:47:31.0 +0100 +++ redland-1.0.17/debian/changelog 2018-11-04 21:36:00.0 +0100 @@ -1,3 +1,10 @@ +redland (1.0.17-1.2) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Annotate perl build dependency with :any. (Closes: #-1) + + -- Helmut Grohne Sun, 04 Nov 2018 21

Bug#912907: jackd2 FTCBFS

2018-11-04 Thread Helmut Grohne
) ++ Request the build architecture python for waf. ++ Tell waf which CC/CXX/PKGCONFIG to use. + + -- Helmut Grohne Sun, 04 Nov 2018 21:13:15 +0100 + jackd2 (1.9.12~dfsg-2) unstable; urgency=medium * Source-only re-upload to avoid pre-built amd64 binary diff --minimal -Nru jackd2-1.9.12~dfsg

Bug#912904: v4l-utils FTCFBS due to clang dependency

2018-11-04 Thread Helmut Grohne
=medium + + * Non-maintainer upload. + * Annotate clang Build-Depends with :native. (Closes: #-1) + + -- Helmut Grohne Sun, 04 Nov 2018 20:44:51 +0100 + v4l-utils (1.16.1-1) unstable; urgency=low * Imported Upstream version 1.16.1 diff --minimal -Nru v4l-utils-1.16.1/debian/control v4l-utils

Bug#912899: python3-defaults FTCBFS: dependency python3.7 is not installable

2018-11-04 Thread Helmut Grohne
with :any (Closes: #-1) + + -- Helmut Grohne Sun, 04 Nov 2018 20:00:08 +0100 + python3-defaults (3.6.7-1) unstable; urgency=high * Really ship the policy in the python3 package, and update from the last diff --minimal -Nru python3-defaults-3.6.7/debian/control python3-defaults-3.6.7/debian

Bug#912898: gpgme1.0 FTCBFS: python issues

2018-11-04 Thread Helmut Grohne
Fix FTCBFS: (Closes: #-1) ++ Update Python Build-Depends for cross compilation. ++ Export Python's fancy cross compilation variables. + + -- Helmut Grohne Sun, 04 Nov 2018 17:34:40 +0100 + gpgme1.0 (1.12.0-4) unstable; urgency=medium * no need to clean up build-py3.7 any longer diff --m

Bug#912892: pybuild confuses host and target

2018-11-04 Thread Helmut Grohne
Package: dh-python Version: 3.20180927 File: /usr/bin/pybuild /usr/bin/pybuild has: | try: | # Set _PYTHON_HOST_PLATFORM to ensure debugging symbols on, f.e. i386 | # emded a constant name regardless of the 32/64-bit kernel. | env.setdefault( |

Bug#912859: mark python3-distutils-extra Multi-Arch: foreign

2018-11-04 Thread Helmut Grohne
: #-1) + + -- Helmut Grohne Sun, 04 Nov 2018 17:22:53 +0100 + python-distutils-extra (2.41) unstable; urgency=medium * Update Vcs-* for the move to salsa.debian.org diff --minimal -Nru python-distutils-extra-2.41/debian/control python-distutils-extra-2.41+nmu1/debian/control --- python

Bug#912857: libruby2.5 is wrongly marked Multi-Arch: same

2018-11-04 Thread Helmut Grohne
Package: libruby2.5 Version: 2.5.1-6+b1 Severity: important User: helm...@debian.org Usertags: rebootstrap libruby2.5 is wrongly marked Multi-Arch: same. It fails to coinstall on amd64 and arm64: | Unpacking libruby2.5:arm64 (2.5.1-6+b1) ... | dpkg: error processing archive

Bug#912846: grub2: stop depending on ttf-dejavu-core

2018-11-04 Thread Helmut Grohne
@@ -1,3 +1,10 @@ +grub2 (2.02+dfsg1-8.1) UNRELEASED; urgency=medium + + * Non-maintainer upload. + * Transition ttf-dejavu-core dependency to fonts-dejavu-core. (Closes: #-1) + + -- Helmut Grohne Sun, 04 Nov 2018 15:55:41 +0100 + grub2 (2.02+dfsg1-8) unstable; urgency=medium * Revise grub

<    3   4   5   6   7   8   9   10   11   12   >