Bug#930367: cloud.debian.org: vagrant images: use systemd-networkd for virtualbox provider

2019-06-15 Thread Antonio Terceiro
On Fri, Jun 14, 2019 at 02:42:23PM +0200, Emmanuel Kasper wrote: > Le 11/06/2019 à 17:07, Antonio Terceiro a écrit : > > Control: retitle -1 vagrant images: network setup in libvirt images are not > > consistent with Debian defaults > > > > On Tue, Jun 11, 2019 a

Bug#929214: release.debian.org - Add package constraint for cloud images

2019-06-12 Thread Antonio Terceiro
On Wed, Jun 12, 2019 at 09:03:04PM +0200, Paul Gevers wrote: > Hi Bastian, > > [CC adding debian-ci@l.d.o, please drop the bug in the next reply as it > starts to become off-topic there.] > > On 12-06-2019 20:52, Bastian Blank wrote: > > On Wed, Jun 12, 2019 at 08:42:27PM +0200, Paul Gevers

Bug#930367: cloud.debian.org: vagrant images: use systemd-networkd for virtualbox provider

2019-06-11 Thread Antonio Terceiro
Control: retitle -1 vagrant images: network setup in libvirt images are not consistent with Debian defaults On Tue, Jun 11, 2019 at 04:15:12PM +0200, Nicolas Quiniou-Briand wrote: > Package: cloud.debian.org > Severity: normal > > Dear Maintainer, > > I noticed a difference between providers

Bug#929957: autodep8: allow customization of python module name

2019-06-04 Thread Antonio Terceiro
Hi, On Tue, Jun 04, 2019 at 11:46:52AM +0200, Alexandre Rossi wrote: > Package: autodep8 > Version: 0.18 > Severity: normal > > Dear Maintainer, > > For django packages, autodep8 fails to determine the proper python module > name: > > $ autodep8 > Test-Command: set -e ; for py in $(pyversions

Bug#929899: unblock: ruby2.5/2.5.5-3

2019-06-02 Thread Antonio Terceiro
--- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,9 @@ +ruby2.5 (2.5.5-3) unstable; urgency=medium + + * ia64: Don't clear register_stack_start (Closes: #928068) + + -- Antonio Terceiro Sun, 02 Jun 2019 10:16:57 -0300 + ruby2.5 (2.5.5-2) unstable; urgency=medium * debian/tests/excludes

Bug#702577: Would like to resolve this issue

2019-05-24 Thread Antonio Terceiro
On Fri, May 24, 2019 at 10:17:00PM +0530, Manas Kashyap wrote: > Hola , > I would like to work on this issue and get it resolved . I'm not sure we really want to do this. Bundler is now bundled together with Ruby 2.6 as a "default gem", so it does not make sense for us to expect upstream code to

Bug#928068: ruby2.5: FTBFS on ia64 due to segfault

2019-05-14 Thread Antonio Terceiro
On Tue, May 14, 2019 at 09:06:15AM +0200, John Paul Adrian Glaubitz wrote: > Hello Antonio! > > On 4/27/19 2:00 PM, James Clarke wrote: > > Currently, ruby2.5 FTBFS, segfaulting when building documentation. > > Please include the above patch applied[1] upstream (currently only to > > trunk) to

Bug#928940: unblock: ruby2.5/2.5.5-2

2019-05-13 Thread Antonio Terceiro
nda tests that depend on +network availability, by moving the existing excludes files to the correct +location. (Closes: #927122) + + -- Antonio Terceiro Mon, 13 May 2019 10:55:06 -0300 + ruby2.5 (2.5.5-1) unstable; urgency=medium * New upstream version 2.5.5. Includes a series of bug fi

Bug#928622: autodep8 integration with dh

2019-05-09 Thread Antonio Terceiro
On Thu, May 09, 2019 at 02:03:50PM +0200, Paul Gevers wrote: > Hi Antonio, > > On 09-05-2019 13:59, Antonio Terceiro wrote: > >> Actually, I don't know where this mapping is documented, except for in > >> the code. > > > > the mapping comes from the na

Bug#928622: autodep8 integration with dh

2019-05-09 Thread Antonio Terceiro
On Thu, May 09, 2019 at 09:32:32AM +0200, Paul Gevers wrote: > Hi Daniel, > > On 08-05-2019 23:01, Daniel Kahn Gillmor wrote: > > Thanks for the pointer to this documentation! I still have no idea how > > to apply this for a go package like slt (where i encountered this). Do > > i use

Bug#927917: firmware-atheros: missing ath10k/QCA9377/hw1.0/firmware-6.bin

2019-04-24 Thread Antonio Terceiro
-atheros recommends no packages. Versions of packages firmware-atheros suggests: ii initramfs-tools 0.133 From b8ac831929a6d684b647162c3831e1950644cd5e Mon Sep 17 00:00:00 2001 From: Antonio Terceiro Date: Wed, 24 Apr 2019 23:06:50 -0300 Subject: [PATCH] firmware-atheros: ship ath10k/QCA9377/hw1.0

Bug#926278: Please build a separate binary package to ship rubygems

2019-04-23 Thread Antonio Terceiro
On Tue, Apr 02, 2019 at 10:09:07PM +0200, Moritz Muehlenhoff wrote: > Package: libruby2.5 > Version: 2.5.5-1 > Severity: wishlist > > rubygems are currently a part of libruby2.5. Can you please split them into a > separate binary package like ruby2.5-rubygems (which libruby2.5 would still >

Bug#927241: unblock: ruby-concurrent/1.0.5-3

2019-04-16 Thread Antonio Terceiro
cy=medium + + * Team upload. + * debian/control: drop `Testsuite: autopkgtest-pkg-ruby` to let autopkgtest +run only the explicit debian/tests/control in this package, and not also +run the default test produced by autodep8 (Closes: #926782) + + -- Antonio Terceiro Mon, 15 Apr 2019 12:52:29 -030

Bug#927127: unblock: ruby-websocket/1.2.8-2

2019-04-15 Thread Antonio Terceiro
r (Closes: #926254) + + -- Antonio Terceiro Sun, 14 Apr 2019 20:23:47 -0300 + ruby-websocket (1.2.8-1) unstable; urgency=medium * New upstream release diff --git a/debian/control b/debian/control index 27f764d..2304613 100644 --- a/debian/control +++ b/debian/control @@ -20,6 +20,8 @@ XB-Ruby

Bug#921176: redis-server service is failing to start in buster lxc container

2019-04-07 Thread Antonio Terceiro
On Sun, Apr 07, 2019 at 08:37:53PM +0200, Pierre-Elliott Bécue wrote: > Le dimanche 24 février 2019 à 15:01:14+0100, intrigeri a écrit : > > Control: reassign -1 lxc > > Control: severity -1 important > > > > Hi, > > > > Pirate Praveen: > > > In dmesg inside container (same error on the host as

Bug#903448: [DRE-maint] Bug#903448: ruby-websocket-parser, ruby-websocket: error when trying to install together

2019-03-29 Thread Antonio Terceiro
Control: reassign -1 ruby-websocket-parser Control: retitle -1 ruby-websocket-parser: hijacks namespace from ruby-websocket Control: found -1 1.0.0-1 On Tue, Jul 10, 2018 at 10:13:32AM +0200, Andreas Beckmann wrote: > Package: ruby-websocket-parser,ruby-websocket > Severity: serious > User:

Bug#925923: unblock: ruby2.5/2.5.5-1

2019-03-28 Thread Antonio Terceiro
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package ruby2.5. This is a maintainance-only new upstream release that includes fixes for important bugs, and 6 security bugs. Changelog: ruby2.5 (2.5.5-1) unstable;

Bug#924912: pristine-tar: Failed to reproduce original tarball python-django_1.11.20.orig.tar.gz

2019-03-18 Thread Antonio Terceiro
Control: tag -1 + moreinfo On Mon, Mar 18, 2019 at 11:25:33AM +0100, Andreas Beckmann wrote: > Package: pristine-tar > Version: 1.46 > Severity: important > > In this repository: > > https://salsa.debian.org/python-team/modules/python-django.git > > $ pristine-tar checkout

Bug#924876: debci: Unable to get network up when following documentation

2019-03-18 Thread Antonio Terceiro
Control: tag -1 + moreinfo On Sun, Mar 17, 2019 at 10:31:54PM +0100, Xavier Guimard wrote: > Package: debci > Version: 2.0 > Severity: normal > > Hi all, > > I followed exactly > https://ci.debian.net/doc/file.MAINTAINERS.html#label-How+can+I+reproduce+the+test+run+locally-3F > steps to get a

Bug#924497: unblock: bundler/1.17.3-3

2019-03-13 Thread Antonio Terceiro
-- Antonio Terceiro Sat, 09 Mar 2019 08:41:37 -0300 A diff against the version in testing is attached. unblock bundler/1.17.3-3 -- System Information: Debian Release: buster/sid APT prefers unstable-debug APT policy: (500, 'unstable-debug'), (500, 'testing-debug'), (500, 'unstable'), (500

Bug#923931: upgrade breaks old containers

2019-03-11 Thread Antonio Terceiro
On Mon, Mar 11, 2019 at 09:54:14AM +0100, Harald Dunkel wrote: > Hi Pierre, > > On 3/8/19 2:30 PM, Pierre-Elliott Bécue wrote: > > > > I'm sorry, but lxc-templates is not needed to have lxc3 working, so it > > won't become a Dependency. Moving the files from src:lxc-templates to > > src:lxc and

Bug#923202: stretch-pu: package ruby2.3/2.3.3-1+deb9u5

2019-03-09 Thread Antonio Terceiro
On Sat, Mar 09, 2019 at 02:12:26PM +, Adam D. Barratt wrote: > Control: tags -1 -moreinfo +confirmed > > On Sat, 2019-03-09 at 11:01 -0300, Antonio Terceiro wrote: > > On Sat, Mar 09, 2019 at 01:56:02PM +, Adam D. Barratt wrote: > > > Control: tags -1 + moreinfo &

Bug#923202: stretch-pu: package ruby2.3/2.3.3-1+deb9u5

2019-03-09 Thread Antonio Terceiro
On Sat, Mar 09, 2019 at 01:56:02PM +, Adam D. Barratt wrote: > Control: tags -1 + moreinfo > > On Sun, 2019-02-24 at 21:27 -0300, Antonio Terceiro wrote: > > this update fixes 2 FTBFS bugs on stretch. All of the changes are in > > the test suite, so there are

Bug#914771: Re: Bug#914771: bundler: cannot load such file -- bundler-1.16.1/exe/bundle

2019-03-08 Thread Antonio Terceiro
On Sat, Mar 09, 2019 at 01:43:30AM +0100, Daniel Leidert wrote: > Am Freitag, den 08.03.2019, 16:23 -0300 schrieb Antonio Terceiro: > > On Fri, Mar 08, 2019 at 07:10:55PM +0100, Daniel Leidert wrote: > > > Can we maybe change Gem.bin_path to fall back to /usr/bin o

Bug#914771: Re: Bug#914771: bundler: cannot load such file -- bundler-1.16.1/exe/bundle

2019-03-08 Thread Antonio Terceiro
On Fri, Mar 08, 2019 at 07:10:55PM +0100, Daniel Leidert wrote: > Can we maybe change Gem.bin_path to fall back to /usr/bin or even $path? Not at this point in the release cycle. signature.asc Description: PGP signature

Bug#914771: bundler: cannot load such file -- bundler-1.16.1/exe/bundle

2019-03-08 Thread Antonio Terceiro
Hello, On Thu, Nov 29, 2018 at 02:06:29AM +0800, Andrew Lee wrote: > ┌──┐ > │ Run tests for ruby2.5 from debian/ruby-tests.rake > │ >

Bug#923931: upgrade breaks old containers

2019-03-07 Thread Antonio Terceiro
On Thu, Mar 07, 2019 at 12:49:21PM +0100, Harald Dunkel wrote: > Package: lxc > Version: 1:3.1.0+really3.0.3-5 > > After the upgrade to lxc 3 the old containers created by > lxc 2 don't work anymore, even though lxc-update-config has > been run (manually). The config files still contain template

Bug#922300: unblock: chef/13.8.7-3, ohai/13.8.0-1

2019-02-26 Thread Antonio Terceiro
On Thu, Feb 14, 2019 at 09:42:42AM -0200, Antonio Terceiro wrote: > Package: release.debian.org > Severity: normal > User: release.debian@packages.debian.org > Usertags: unblock > > Hello, > > Please unblock package chef > > Hi, > > The ci.debian.net nod

Bug#923202: stretch-pu: package ruby2.3/2.3.3-1+deb9u5

2019-02-24 Thread Antonio Terceiro
FTBFS due to expired SSL certificate and timezone changes (Closes: #91) - imap: update test certificate - timezone changes for Japan and Kiritimati * test/ruby/test_gc.rb: skip entirely; some tests in there can fail unpredictably on buildds (Closes: #912740) -- Antonio Terceiro

Bug#922713: vmdb2: please add a step to create /etc/fstab in the image (PATCH)

2019-02-21 Thread Antonio Terceiro
On Wed, Feb 20, 2019 at 11:02:34AM -0300, Antonio Terceiro wrote: > On Wed, Feb 20, 2019 at 10:46:35AM +0200, Lars Wirzenius wrote: > > On Tue, Feb 19, 2019 at 03:34:35PM -0300, Antonio Terceiro wrote: > > > Only vmdb2 can know exactly what device is mounted as the image rootf

Bug#922713: vmdb2: please add a step to create /etc/fstab in the image (PATCH)

2019-02-20 Thread Antonio Terceiro
On Wed, Feb 20, 2019 at 10:46:35AM +0200, Lars Wirzenius wrote: > On Tue, Feb 19, 2019 at 03:34:35PM -0300, Antonio Terceiro wrote: > > Only vmdb2 can know exactly what device is mounted as the image rootfs. > > Therefore, the only reliable way of creating /etc/fstab to have a &g

Bug#922713: vmdb2: please add a step to create /etc/fstab in the image (PATCH)

2019-02-19 Thread Antonio Terceiro
suggests no packages. -- no debconf information From 31f486ae3e7fc88f4a1dde3582d1197ccff6c0db Mon Sep 17 00:00:00 2001 From: Antonio Terceiro Date: Tue, 19 Feb 2019 14:59:49 -0300 Subject: [PATCH] Add: step to create /etc/fstab --- vmdb/plugins/fstab.mdwn | 12 + vmdb/plugins

Bug#922709: vmdb2: variable for rootfs caching is incorrectly documented

2019-02-19 Thread Antonio Terceiro
17 00:00:00 2001 From: Antonio Terceiro Date: Tue, 19 Feb 2019 15:25:28 -0300 Subject: [PATCH] Change: fix variable name for rootfs caching in documentation This was renamed internally and the documentation wasn't updated. --- vmdb2.mdwn | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions

Bug#922671: autopkgtest-build-qemu image does not boot due to wrong root device

2019-02-19 Thread Antonio Terceiro
Hi, On Tue, Feb 19, 2019 at 08:33:51AM +0100, Martin Pitt wrote: > Package: autopkgtest > Version: 5.9 > > Even after fixing #916407 and #922501, these images still don't work: > > # autopkgtest-build-qemu stretch /tmp/s.img http://ftp.de.debian.org/debian > > This succeeds, and gives me an

Bug#922501: ERROR: No runner implements step with keys grub, root-part, device, console, root-fs

2019-02-18 Thread Antonio Terceiro
Control: reassign -1 autopkgtest On Sun, 17 Feb 2019 09:49:41 +0100 Martin Pitt wrote: > Package: vmdb2 > Version: 0.13.2+git20190215-1 > > I'm trying to build a stretch VM image using autopkgtest's tool: > >autopkgtest-build-qemu stretch /tmp/autopkgtest-stretch-amd64.qcow2 > > which

Bug#922660: vmdb2: minimal specification file does not really work

2019-02-18 Thread Antonio Terceiro
c0e2b8ceda068522dc29111e754d485abadb0c71 Mon Sep 17 00:00:00 2001 From: Antonio Terceiro Date: Mon, 18 Feb 2019 22:39:56 -0300 Subject: [PATCH] Change: make "getting started" example work This makes the minimal example presented in the "Getting started" section of the documentat

Bug#922447: lighttpd: autopkgtest regression

2019-02-18 Thread Antonio Terceiro
On Mon, Feb 18, 2019 at 07:38:49PM +0100, Paul Gevers wrote: > Hi Helmut, > > [Adding the debian-ci team into the discussion] > > On 18-02-2019 08:06, Helmut Grohne wrote: > >> autopkgtest [00:11:07]: test defconfig: [--- > >> 2019-02-16 00:11:07: (configfile.c.1599)

Bug#922300: unblock: chef/13.8.7-3, ohai/13.8.0-1

2019-02-14 Thread Antonio Terceiro
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Hello, Please unblock package chef Hi, The ci.debian.net nodes are managed with chef, and during the weekend I realized that it was not in testing. There was an RC bug against chef

Bug#921667: lxc, lava-dev: lxc fails to install along lava-dev --install-recommends

2019-02-13 Thread Antonio Terceiro
t; >Control: retitle -1 lxc,apparmor: lxc fails to install in a chroot with > >apparmor installed > > > >On 2019-02-10 20:06, Antonio Terceiro wrote: > >> I can reproduce this on a clean chroot (but not on a clean VM) > > > >I can also reproduce this in piuparts by

Bug#921667: [pkg-lxc-devel] Bug#921667: lxc, lava-dev: lxc fails to install along lava-dev --install-recommends

2019-02-10 Thread Antonio Terceiro
On Sun, Feb 10, 2019 at 12:13:43AM +0100, Pierre-Elliott Bécue wrote: > Le samedi 09 février 2019 à 22:19:13+0100, Andreas Beckmann a écrit : > > On 2019-02-09 21:51, Pierre-Elliott Bécue wrote: > > > I'm not sure that there is something we can do regarding lxc. Am I > > > wrong? > > > > You

Bug#921847: rails breaks ruby-combustion autopkgtest: cannot load such file -- active_model/secure_password

2019-02-09 Thread Antonio Terceiro
Control: reassign -1 ruby-combustion Control: found -1 1.0.0-1 Control: done -1 1.0.0-2 On Sat, Feb 09, 2019 at 01:13:41PM +0100, Paul Gevers wrote: > Source: rails, ruby-combustion > Control: found -1 rails/2:5.2.2+dfsg-5 > Control: found -1 ruby-combustion/1.0.0-1 > X-Debbugs-CC:

Bug#921179: FTBFS: several test failures

2019-02-02 Thread Antonio Terceiro
Source: coquelicot Version: 0.9.6-1.1 Severity: serious Tags: ftbfs Justification: fails to build from source coquelicot currently fails to build in both unstable and buster, with several test failures. Log attached. -- System Information: Debian Release: buster/sid APT prefers unstable-debug

Bug#919962: Errors caused by not installing Recommend packages

2019-01-28 Thread Antonio Terceiro
Control: severity -1 normal Control: retitle -1 goaccess: absence of optional packages looks like an error, but it's not On Sun, Jan 20, 2019 at 03:57:22PM +0800, 積丹尼 Dan Jacobson wrote: > X-Debbugs-Cc: goacc...@prosoftcorp.com > Package: goaccess > Version: 1:1.2-4 > > Versions of packages

Bug#907718: python-dateutil breaks python-vobject autopkgtest

2019-01-24 Thread Antonio Terceiro
On Wed, Jan 09, 2019 at 05:55:47PM +0200, Adrian Bunk wrote: > On Thu, Dec 13, 2018 at 11:21:35PM +0100, Jonas Smedegaard wrote: > > Control: tags -1 help > > > > Quoting Guido Günther (2018-12-13 19:21:45) > > > On Thu, Dec 13, 2018 at 05:53:03PM +0100, Jonas Smedegaard wrote: > > > > @Guido,

Bug#920208: lists.debian.org: please add giov...@debian.org and kanash...@debian.org to debconf-sponsors-team@l.d.o

2019-01-22 Thread Antonio Terceiro
Package: lists.debian.org Severity: normal Please add Giovani Ferreira (giov...@debian.org) and Lucas Kanashiro (kanash...@debian.org) to the debconf-sponsors-team mailing list. -- System Information: Debian Release: buster/sid APT prefers unstable-debug APT policy: (500, 'unstable-debug'),

Bug#919721: [Pkg-fonts-devel] Bug#919721: fonts-firacode: looks broken on at least kitty and hexchat

2019-01-19 Thread Antonio Terceiro
Em 19 de janeiro de 2019 17:43:20 BRST, Fabian Greffrath escreveu: >Control: severity -1 normal > >Hi Antonio, > >thanks for the report, but I fail to see how a change in vertical >spacing could justify grave severity for a font package. Well this issue does make the package unusable, and

Bug#918026: ruby-sinatra-contrib: uninstallable; depends on versions not present in the archive

2019-01-19 Thread Antonio Terceiro
On Wed, Jan 16, 2019 at 10:50:03AM +0900, Hideki Yamane wrote: > On Fri, 4 Jan 2019 10:22:08 -0300 > Antonio Terceiro wrote: > > Are you working on updating sinatra? I started working on a new sinatra > > upstream release to unbreak debci after a new rack was uploaded, a

Bug#918179: debci: configure error: undefined method `migrate'

2019-01-07 Thread Antonio Terceiro
Control: reassign -1 debci 1.14 Control: severity -1 serious Control: tag -1 + pending On Sun, Jan 06, 2019 at 08:12:58PM +0100, Paul Gevers wrote: > reassign 918179 src:rails 2:5.2.0+dfsg-2 > severity 918179 serious > > Hi Scott, > > On 04-01-2019 02:31, Scott Talbert wrote: > > I just updated

Bug#918026: ruby-sinatra-contrib: uninstallable; depends on versions not present in the archive

2019-01-04 Thread Antonio Terceiro
On Fri, Jan 04, 2019 at 10:22:08AM -0300, Antonio Terceiro wrote: > On Wed, Jan 02, 2019 at 10:58:15AM -0300, Antonio Terceiro wrote: > > Package: ruby-sinatra-contrib > > Version: 2.0.5-1 > > Severity: serious > > Justification: unsatisfiable dependencies > >

Bug#918026: ruby-sinatra-contrib: uninstallable; depends on versions not present in the archive

2019-01-04 Thread Antonio Terceiro
On Wed, Jan 02, 2019 at 10:58:15AM -0300, Antonio Terceiro wrote: > Package: ruby-sinatra-contrib > Version: 2.0.5-1 > Severity: serious > Justification: unsatisfiable dependencies > > # apt install ruby-sinatra-contrib > Reading package lists... Done > Building depende

Bug#918026: ruby-sinatra-contrib: uninstallable; depends on versions not present in the archive

2019-01-02 Thread Antonio Terceiro
Package: ruby-sinatra-contrib Version: 2.0.5-1 Severity: serious Justification: unsatisfiable dependencies # apt install ruby-sinatra-contrib Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have

Bug#916372: pastebinit: multiple deprecation warnings under Python 3.7

2018-12-13 Thread Antonio Terceiro
Description: move away from deprecated platform functions The linux_distribution function from the platform has been deprecated in Python 3.5. `distro` is the natural sucessor, however it is a new dependency. Author: Antonio Terceiro --- a/pastebinit +++ b/pastebinit @@ -38,8 +38,8 @@ defaultPB = &

Bug#912857: libruby2.5 is wrongly marked Multi-Arch: same

2018-11-29 Thread Antonio Terceiro
Control: done -1 2.5.3-3 On Sun, Nov 04, 2018 at 05:18:24PM +0100, Helmut Grohne wrote: > Package: libruby2.5 > Version: 2.5.1-6+b1 > Severity: important > User: helm...@debian.org > Usertags: rebootstrap > > libruby2.5 is wrongly marked Multi-Arch: same. It fails to coinstall on > amd64 and

Bug#914771: bundler: cannot load such file -- bundler-1.16.1/exe/bundle

2018-11-28 Thread Antonio Terceiro
On Tue, Nov 27, 2018 at 03:15:07PM +0800, Andrew Lee wrote: > Package: bundler > Version: 1.16.1-3 > Severity: normal > > Dear Maintainer, > > I'm preparing open-build-service 2.9 package for Debian. While that I > got to update some build-deps and noticed that there is an issue in > bundler

Bug#914191: autopkgtest: fabulous tests fail in unstable

2018-11-20 Thread Antonio Terceiro
Control: reassign -1 autopkgtest Control: affects -1 + src:fabulous Control: retitle -1 autopkgtest: fails to unpack source for fabulous On Tue, Nov 20, 2018 at 12:32:31PM +0200, Graham Inggs wrote: > Source: autopkgtest > Version: 5.6 > X-Debbugs-CC: debian...@lists.debian.org > User:

Bug#910684: Reopen Bug#910684: fixed in munin 2.0.42-2

2018-10-22 Thread Antonio Terceiro
On Fri, Oct 19, 2018 at 08:49:08PM +0200, Paul Gevers wrote: > Hi Jim > > On 10/19/18 20:44, Jim Popovitch wrote: > > Is it possible that munin-async is running on the build host? > > These tests run in an LXC container which is supposed to be both clean > and minimal. > > @Antonio, what I say

Bug#910544: tzdata: Brazil 2018-2019 DST changed

2018-10-11 Thread Antonio Terceiro
On Mon, Oct 08, 2018 at 05:55:25AM +0200, Aurelien Jarno wrote: > On 2018-10-07 18:49, Antonio Terceiro wrote: > > Package: tzdata > > Version: 2018e-1 > > Severity: important > > Tags: upstream > > > > Hi, > > > > Recently it was decided that

Bug#910734: dpkg-source: please expand @builddeps@ in Testsuite-Triggers

2018-10-10 Thread Antonio Terceiro
On Wed, Oct 10, 2018 at 07:56:39PM +0200, Guillem Jover wrote: > Hi! > > On Wed, 2018-10-10 at 15:34:02 +0200, Mattia Rizzolo wrote: > > Package: dpkg-dev > > Version: 1.19.1 > > Severity: wishlist > > X-Debbugs-Cc: debian...@lists.debian.org > > > From to dsc(5): > > Testsuite-Triggers:

Bug#910544: tzdata: Brazil 2018-2019 DST changed

2018-10-07 Thread Antonio Terceiro
Package: tzdata Version: 2018e-1 Severity: important Tags: upstream Hi, Recently it was decided that this year DST will start in Brazil on November 18th instead of November 4th. The corresponding thread on the upstream mailing list starts at:

Bug#909119: stretch-pu: package vagrant/1.9.1+dfsg-1+deb9u1

2018-10-07 Thread Antonio Terceiro
On Sat, Oct 06, 2018 at 05:50:33PM +0100, Adam D. Barratt wrote: > Control: tags -1 + confirmed > > On Tue, 2018-09-18 at 10:22 -0700, Antonio Terceiro wrote: > > vagrant from stretch currently refuses to work with VirtualBox 5.2 > > from > > stretch-backports. This up

Bug#910459: openssl: broken autopkgtest

2018-10-06 Thread Antonio Terceiro
Source: openssl Version: 1.1.1-1 Severity: normal Tags: patch The autopkgtests for openssl are currently broken due to a set of typos: blame: openssl badpkg: debian/tests/run-25-test-verify does not exist autopkgtest [15:01:50]: ERROR: erroneous package: debian/tests/run-25-test-verify does not

Bug#900161: ruby-openssl: FTBFS against openssl 1.1.1

2018-10-06 Thread Antonio Terceiro
On Thu, Oct 04, 2018 at 12:10:53PM +0100, peter green wrote: > i tried to modify the testsuite to use stronger keys (patch > attatched), however after doing so the testsuite now hangs (relavent > output pasted at end of message). Not sure what is going wrong here (I > am neither a ruby expert or

Bug#910371: stretch-pu: package lxcfs/2.0.7-1.1

2018-10-06 Thread Antonio Terceiro
On Sat, 6 Oct 2018 14:21:45 +0200 Michael Banck wrote: > On Fri, Oct 05, 2018 at 05:18:51PM +0200, Michael Banck wrote: > > Package: release.debian.org > > Severity: normal > > Tags: stretch > > User: release.debian@packages.debian.org > > Usertags: pu > > > > Hi, > > > > I would like to

Bug#907118: error:141a318a:ssl routines:tls_process_ske_dhe:dh key too small

2018-10-04 Thread Antonio Terceiro
tc.net"; port = 6697; }; }; network { name = "freenode"; ssl = true; server { host = "irc.freenode.net"; port = 6697; }; }; network { name = "gimpnet"; ssl = true; server { host = "irc.gimp.org"; port = 6697; }; }; user { name = &qu

Bug#909264: [PATCH] Fix test for need to use qemu

2018-09-20 Thread Antonio Terceiro
The output of arch-test needs to have its trailing newline removed before comparing with the expected string. Found this while trying to use mmdebstrap without having qemu-user installed. --- mmdebstrap | 1 + 1 file changed, 1 insertion(+) diff --git a/mmdebstrap b/mmdebstrap index

Bug#909205: FTBFS: 3 test failures

2018-09-19 Thread Antonio Terceiro
Source: chef Version: 13.8.7-2 Severity: serious Justification: fails to build from source This is the bottom of the build log: Finished in 1 minute 57.8 seconds (files took 6.76 seconds to load) 11422 examples, 3 failures, 24 pending Failed examples: rspec

Bug#896698: deprecating needs-recommends

2018-09-18 Thread Antonio Terceiro
On Tue, Sep 18, 2018 at 08:53:05PM +0200, Paul Gevers wrote: > Hi, > > On 18-09-18 17:21, gregor herrmann wrote: > > On Mon, 17 Sep 2018 15:11:30 -0700, Antonio Terceiro wrote: > > > >>> So if needs-recommends vanishes, there will be at least dozens if not >

Bug#909119: stretch-pu: package vagrant/1.9.1+dfsg-1+deb9u1

2018-09-18 Thread Antonio Terceiro
100644 --- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,10 @@ +vagrant (1.9.1+dfsg-1+deb9u2) stretch; urgency=medium + + * Backport support for VirtualBox 5.2 (available in stretch-backports) +(Closes: #908826) + + -- Antonio Terceiro Sat, 15 Sep 2018 09:23:23 -0300 + vagrant (1.9.1+dfsg

Bug#896698: deprecating needs-recommends

2018-09-17 Thread Antonio Terceiro
On Mon, Sep 17, 2018 at 10:50:01PM +0200, gregor herrmann wrote: > On Sat, 15 Sep 2018 15:40:33 +0200, Michael Biebl wrote: > > > On Thu, 30 Aug 2018 12:03:31 +0200 Paul Gevers wrote: > > > I have just pushed commit 9fade8dcb501250f704da9c77af1f8e6165dc941 that > > > documents that we want to

Bug#908826: vagrant/stable is incompatible with virtualbox/stretch-backports (now 5.2)

2018-09-17 Thread Antonio Terceiro
On Mon, Sep 17, 2018 at 03:16:05PM +0200, Lucas Nussbaum wrote: > On 15/09/18 at 09:46 -0300, Antonio Terceiro wrote: > > On Fri, Sep 14, 2018 at 05:10:48PM +0200, Lucas Nussbaum wrote: > > > Package: vagrant > > > Version: 1.9.1+dfsg-1+deb9u1 > > &

Bug#908826: vagrant/stable is incompatible with virtualbox/stretch-backports (now 5.2)

2018-09-15 Thread Antonio Terceiro
On Fri, Sep 14, 2018 at 05:10:48PM +0200, Lucas Nussbaum wrote: > Package: vagrant > Version: 1.9.1+dfsg-1+deb9u1 > Severity: normal > > Hi, > > vagrant 1.9.1+dfsg-1+deb9u1 is now incompatible with virtualbox from > stretch-backports (version 5.2.18-dfsg-1~bpo9+1). It worked fine with >

Bug#908813: [PATCH] spec: user xdelta v3 for rpm builds, too

2018-09-14 Thread Antonio Terceiro
Control: tags -1 + pending On Fri, Sep 14, 2018 at 12:39:08PM +0300, Markus Lehtonen wrote: > Package: pristine-tar > Version: 1.44 > Tags: patch > > Nowadays, it's ubiquitous and pristine-tar supports it. applied, thanks signature.asc Description: PGP signature

Bug#907846: autopkgtest: Please consider additional section for tutorial web page

2018-09-05 Thread Antonio Terceiro
On Tue, Sep 04, 2018 at 08:59:12PM +0200, Paul Gevers wrote: > Control: reassign -1 debci > > Dear Paul > > You're looking at this file: > https://salsa.debian.org/ci-team/debci/blob/master/docs/TUTORIAL.md > > It would be awesome if you could propose changes to that file instead of > the

Bug#905586: lxc: diff for NMU version 1:2.0.9-6.1

2018-08-31 Thread Antonio Terceiro
On Fri, Aug 31, 2018 at 02:42:15PM +0200, Salvatore Bonaccorso wrote: > Hi Antonio, > > On Fri, Aug 31, 2018 at 08:14:57AM -0300, Antonio Terceiro wrote: > > On Thu, Aug 30, 2018 at 10:06:15PM +0200, Salvatore Bonaccorso wrote: > > > Control: tags 905586 + pending

Bug#905586: lxc: diff for NMU version 1:2.0.9-6.1

2018-08-31 Thread Antonio Terceiro
On Thu, Aug 30, 2018 at 10:06:15PM +0200, Salvatore Bonaccorso wrote: > Control: tags 905586 + pending > > > Dear maintainer, > > I've prepared an NMU for lxc (versioned as 1:2.0.9-6.1) and > uploaded it to DELAYED/5. Thanks! > Please feel free to tell me if I should delay it longer. on the

Bug#907118: error:141a318a:ssl routines:tls_process_ske_dhe:dh key too small

2018-08-28 Thread Antonio Terceiro
On Thu, Aug 23, 2018 at 03:24:52PM -0600, dann frazier wrote: > Package: bip > Version: 0.8.9-1.1 > Severity: normal > Tags: patch > > I run bip on a stretch system, and connect to it from a hexchat client on > sid. After a recent upgrade of the client, which pulled in openssl 1.1, > hexchat

Bug#907118: error:141a318a:ssl routines:tls_process_ske_dhe:dh key too small

2018-08-24 Thread Antonio Terceiro
Control: severity -1 important Hi, I would like to reinforce the request for a stable update: - according to the openssl maintainer, this is a security issue and should be fixed in stable - without such fix, bip on stable will soon be unusable to any client using a recent enough openssl

Bug#906130: allow autopkg restrictions in debian/control

2018-08-14 Thread Antonio Terceiro
Control: tag -1 + wontfix Control: close -1 On Tue, Aug 14, 2018 at 06:46:56PM +0200, Matthias Klose wrote: > Package: autopkgtest > Version: 5.5 > > Seen when the Python autodep8 tests were enabled. Tests start failing when > these have e.g. output on stderr. It should be possible to specify

Bug#905317: autopkgtest: "flaky" restriction seems not to work when dep unsatisfiable

2018-08-06 Thread Antonio Terceiro
Control: close -1 Control: tag -1 + wontfix On Fri, Aug 03, 2018 at 10:54:44AM +0800, Ralf Treinen wrote: > Package: autopkgtest > Version: 5.4.1 > Severity: normal > > Hi, > > the flaky restriction does not seem to work in case of an unsatisfiable > test dependency. This can be observed on

Bug#905527: `apt show` fails to parse record for librust-winapi-dev (while `apt-cache show` succeeds)

2018-08-05 Thread Antonio Terceiro
On Sun, Aug 05, 2018 at 12:20:54PM -0300, Antonio Terceiro wrote: > Package: apt > Version: 1.6.3 > Severity: normal > > ~$ apt-cache show librust-winapi-dev > [... stuff ...] > ~$ apt show librust-winapi-dev > E: Unable to parse package fi

Bug#905527: `apt show` fails to parse record for librust-winapi-dev (while `apt-cache show` succeeds)

2018-08-05 Thread Antonio Terceiro
Package: apt Version: 1.6.3 Severity: normal ~$ apt-cache show librust-winapi-dev [... stuff ...] ~$ apt show librust-winapi-dev E: Unable to parse package file /var/lib/apt/lists/ftp.br.debian.org_debian_dists_unstable_main_binary-amd64_Packages (2) E: Internal Error, Unable to parse a package

Bug#905439: su from util-linux breaks autopkgtest

2018-08-04 Thread Antonio Terceiro
Control: tag -1 + moreinfo unreproducible On Sat, Aug 04, 2018 at 03:11:17PM +, Lumin wrote: > Package: autopkgtest > Version: 5.4.2 > Severity: serious > > the "su" command from util-linux breaks autopkgtest. The previous > working one comes from shadow. > > python-h5py-dbg is already the

Bug#905153: autodep8: set Restrictions: allow-stderr on generated tests

2018-08-01 Thread Antonio Terceiro
On Wed, Aug 01, 2018 at 07:53:12AM +0100, Rebecca N. Palmer wrote: > On 01/08/18 02:58, Antonio Terceiro wrote: > > FWIW, most of the supported package types do already set allow-stderr. > > From a quick look, of 4 of 9 explictly set allow-stderr, and 2 append > > `2&g

Bug#905153: autodep8: set Restrictions: allow-stderr on generated tests

2018-07-31 Thread Antonio Terceiro
On Tue, Jul 31, 2018 at 11:15:58PM +0100, Rebecca N. Palmer wrote: > Package: autodep8 > Severity: wishlist > > (Moving to a new bug: note that I have not decided whether I agree with this > proposal.) > > On 31/07/18 14:59, Paul Gevers wrote: > > Hi Rebecca, > > > > On 30-07-18 08:57, Rebecca

Bug#904921: wand: Wrong dependencies on libmagickcore-6.q16-6 instead of libmagickwand-6.q16-6

2018-07-30 Thread Antonio Terceiro
Hi On Mon, Jul 30, 2018 at 10:27:57AM -0300, Antonio Terceiro wrote: > FWIW, I intend to upload the patch below. wand is used as a test case in > the test suite of autopkgtest, and this bug causes it to fail. I noticed you are working in the git repository, so I will *not* be making

Bug#904921: wand: Wrong dependencies on libmagickcore-6.q16-6 instead of libmagickwand-6.q16-6

2018-07-30 Thread Antonio Terceiro
Hi, On Sun, Jul 29, 2018 at 10:57:44AM -0300, Antonio Terceiro wrote: > Source: wand > Version: Wrong dependencies on libmagickcore-6.q16-6 instead of > libmagickwand-6.q16-6 > Severity: serious > Justification: missing dependencies > > I think there is a typo in

Bug#904921: wand: Wrong dependencies on libmagickcore-6.q16-6 instead of libmagickwand-6.q16-6

2018-07-29 Thread Antonio Terceiro
Source: wand Version: Wrong dependencies on libmagickcore-6.q16-6 instead of libmagickwand-6.q16-6 Severity: serious Justification: missing dependencies I think there is a typo in Depends: which causes this: $ python3 -c 'from wand.image import Image' Traceback (most recent call last): File

Bug#893501: ruby2.5 FTCBFS: configures for the build architecture

2018-07-22 Thread Antonio Terceiro
Em 22 de julho de 2018 10:57:16 BRT, Chris Hofstaedtler escreveu: >Hi Helmut, > >* Helmut Grohne [180722 13:55]: >> ruby2.5 fails to cross build from source, because it fails passing >> --host to ./configure. The simple solution to this problem is >deferring >> the task to dh_auto_configure.

Bug#903408: Uploading new version of autodep8 to unstable

2018-07-11 Thread Antonio Terceiro
On Wed, Jul 11, 2018 at 09:10:46AM +0200, Rafael Laboissière wrote: > The packages that use the Octave support of autodep8 are starting to fail on > ci.d.n. This will become epidemic. Please, react to my message below. > > Cheers, > > Rafael > > * Rafael Laboissière [2018-07-10 13:21]: > >

Bug#893595: marked as done (autopkgtest doesn't handle long package names (>= 55 char) properly)

2018-06-13 Thread Antonio Terceiro
Control: reopen -1 Actually, the debci upload does *not* fix this, it just works around the limitation on the debci side. This is a limitation in *lxc*, which does not support containers names longer than 50-something characters. This should be handled in autopkgtest-virt-lxc signature.asc

Bug#897308: O: ruby-setup -- the setup.rb install tool for Ruby

2018-06-12 Thread Antonio Terceiro
On Tue, 01 May 2018 12:17:17 +0200 Vincent Fourmond wrote: > Package: wnpp > Severity: normal > > > Hello, > > I intend to orphan the ruby-setup package. It is technically > team-maintained by the Debian Ruby team, but the other listed uploader > hasn't touched the package for a very long

Bug#901030: some context

2018-06-12 Thread Antonio Terceiro
On Tue, Jun 12, 2018 at 02:34:57PM +0200, Hans-Christoph Steiner wrote: > > I agree that there can't be a Restriction for every config under the > sun. I'm thinking more like Ian, where there can be some useful chunks > with a finer grain than "needs isolation". Allowing a test definition to

Bug#899267: Reopen: Bug#899267: ruby2.5: FTBFS on kfreebsd-any

2018-06-10 Thread Antonio Terceiro
On Sun, 10 Jun 2018 23:38:18 +0200 Svante Signell wrote: > reopen -1 > found 899267 2.5.1-2 > thanks > > Hello, > > Unfortunately the patch 0006-fix-kfreebsd-build.patch was not applied, > resulting in a failing build. I'm attaching that file again, now named > 0007-fix-kfreebsd-build.patch

Bug#901030: some context

2018-06-08 Thread Antonio Terceiro
Control: severity -1 wishlist Control: tag -1 + wontfix On Fri, Jun 08, 2018 at 12:35:13PM +0200, Hans-Christoph Steiner wrote: > > This issue was discovered while working on getting autopkgtest running > smoothly in Docker containers running in Gitlab CI on salsa.debian.org: >

Bug#899124: fonts-font-awesome: completely breaks web applications, with no notice

2018-05-27 Thread Antonio Terceiro
On Sat, May 26, 2018 at 02:29:56AM +0200, Pierre-Elliott Bécue wrote: > Le mardi 22 mai 2018 à 21:16:14+0530, Vasudev Kamath a écrit : > > Hi Antonio, > > > > Antonio Terceiro <terce...@debian.org> writes: > > > > > Control: forwarded -1 > >

Bug#900046: ifupdown doesn't work inside lxc

2018-05-25 Thread Antonio Terceiro
Control: severity -1 grave On Fri, 25 May 2018 08:11:53 +0200 Ivan Sergio Borgonovo wrote: > Package: ifupdown > Version: 0.8.33 > > upgrading from 0.8.32 to 0.8.33 ifupdown doesn't work anymore inside > lxc. Downgrading fix the problem, but dpkg takes a lot in the set up

Bug#900046: ifupdown doesn't work inside lxc

2018-05-25 Thread Antonio Terceiro
root@test:~# reboot of course this is not great. The attached patch fixes the issue From d2f8480107882f65ff72607bec7504174cec8855 Mon Sep 17 00:00:00 2001 From: Antonio Terceiro <terce...@debian.org> Date: Fri, 25 May 2018 09:23:08 -0300 Subject: [PATCH] ifupdown-pre.service: only call udevadm if pr

Bug#899324: ruby-font-awesome-rails: broken with fonts-font-awesome 5

2018-05-22 Thread Antonio Terceiro
Package: ruby-font-awesome-rails Version: 4.7.0.2-1 Severity: grave Justification: renders package unusable Recently fonts-font-awesome 5 has been uploaded to ustable. There are some significant changes upstream, including but not limited to font files being renamed. fonts-font-awesome 5.0.10-4

Bug#899124: fonts-font-awesome: completely breaks web applications, with no notice

2018-05-21 Thread Antonio Terceiro
Control: forwarded -1 https://salsa.debian.org/fonts-team/fonts-font-awesome/merge_requests/1 On Sun, May 20, 2018 at 06:15:08PM -0300, Antonio Terceiro wrote: > Control: reopen -1 > > On Sun, May 20, 2018 at 10:32:38PM +0530, Vasudev Kamath wrote: > > Antonio Terceiro <t

Bug#899124: fonts-font-awesome: completely breaks web applications, with no notice

2018-05-20 Thread Antonio Terceiro
Control: reopen -1 On Sun, May 20, 2018 at 10:32:38PM +0530, Vasudev Kamath wrote: > Antonio Terceiro <terce...@debian.org> writes: > > 2) revert the changes in fonts-font-awesome in unstable, upload the > > new release to experimental, and give people a few months to

  1   2   3   4   5   6   7   8   9   10   >