Bug#882353: GIO lists removable storage devices even after they have been unplugged when using Linux kernel v4.14

2018-01-06 Thread Ben Caradoc-Davies
Still present in linux-image-4.14.0-3-amd64 4.14.12-2. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <https://transient.nz/> New Zealand

Bug#883425: linux-image-4.14.0-1-amd64: stale Android device entries in Thunar after USB disconnection

2018-01-06 Thread Ben Caradoc-Davies
Still present in linux-image-4.14.0-3-amd64 4.14.12-2. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <https://transient.nz/> New Zealand

Bug#882353: GIO lists removable storage devices even after they have been unplugged when using Linux kernel v4.14

2017-12-27 Thread Ben Caradoc-Davies
the behaviour. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <https://transient.nz/> New Zealand

Bug#883425: linux-image-4.14.0-1-amd64: stale Android device entries in Thunar after USB disconnection

2017-12-27 Thread Ben Caradoc-Davies
This bug is also present in linux-image-4.14.0-2-amd64 4.14.7-1. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <https://transient.nz/> New Zealand

Bug#882048: apparmor should let thunderbird use signatures from files

2017-12-07 Thread Ben Caradoc-Davies
and apparmor/apparmor-utils 2.11.1-4 on up-to-date sid amd64. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <https://transient.nz/> New Zealand

Bug#883425: linux-image-4.14.0-1-amd64: stale Android device entries in Thunar after USB disconnection

2017-12-03 Thread Ben Caradoc-Davies
. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#883425: linux-image-4.14.0-1-amd64: stale Android device entries in Thunar after USB disconnection

2017-12-03 Thread Ben Caradoc-Davies
Package: src:linux Version: 4.14.2-1 Severity: normal Dear Maintainer, since upgrade to linux-image-4.14.0-1-amd64 4.14.2-1, USB disconnection of Android devices leaves stale entries in Thunar. Repeated connection and disconnection leaves multiple stale device entries. Only the most recent

Bug#882043: apparmor should allow thunderbird to open links with firefox via exo-helper on xfce

2017-11-24 Thread Ben Caradoc-Davies
On 24/11/17 07:04, intrigeri wrote: Could you please try reproducing this with thunderbird 1:52.4.0-2~exp1 or newer, currently available in Debian experimental? This bug is still present in thunderbird 1:52.4.0-2~exp1. journalctl reports: Nov 25 11:55:28 ripley audit[1401]: AVC

Bug#882047: [pkg-apparmor] Bug#882047: Bug#882047: apparmor-utils: aa-complain thunderbird fails

2017-11-19 Thread Ben Caradoc-Davies
no profile /etc/apparmor.d/usr.bin.thunderbird /usr/bin/thunderbird ERROR: /etc/apparmor.d/usr.bin.thunderbird contains no profile Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#882048: apparmor should let thunderbird use signatures from files

2017-11-18 Thread Ben Caradoc-Davies
, and thus required for interoperability. Expanding this to ~/.signature* seems straightforward and should not introduce any security concerns. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#882047: [pkg-apparmor] Bug#882047: apparmor-utils: aa-complain thunderbird fails

2017-11-18 Thread Ben Caradoc-Davies
On 19/11/17 07:47, Christian Boltz wrote: Can you please send (to me or the bugreport) your /etc/apparmor.d/usr.bin.thunderbird profile so that I have the correct profile to test? Attached. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited

Bug#882048: apparmor should let thunderbird use signatures from files

2017-11-17 Thread Ben Caradoc-Davies
Package: apparmor Version: 2.11.1-3 Severity: normal Dear Maintainer, when apparmor is enabled, thunderbird signatures from files disappear. For example, one account uses: "Attach the signature from a file instead": /home/ben/.signature-...@transient.nz If I disable apparmor with "systemctl

Bug#882047: apparmor-utils: aa-complain thunderbird fails

2017-11-17 Thread Ben Caradoc-Davies
Package: apparmor-utils Version: 2.11.1-3 Severity: normal Dear Maintainer, # aa-complain thunderbird Setting /usr/bin/thunderbird to complain mode. ERROR: /etc/apparmor.d/usr.bin.thunderbird contains no profile Guessing that it might be the same as this upstream, but we do not have a

Bug#882045: apparmor should let thunderbird open images with viewnior

2017-11-17 Thread Ben Caradoc-Davies
Package: apparmor Version: 2.11.1-3 Severity: normal Dear Maintainer, thunderbird, xfce, error dialog: Failed to execute default File Manager. Failed to execute child process “/usr/bin/Thunar” (Permission denied). journalctl: Nov 18 14:18:14 ripley audit[27896]: AVC apparmor="DENIED"

Bug#882044: apparmor should allow thunderbird to open text files with geany under xfce

2017-11-17 Thread Ben Caradoc-Davies
Package: apparmor Version: 2.11.1-3 Severity: normal Dear Maintainer, opening a text attachment in thunderbird under xfce results in an error dialog: Failed to execute default File Manager. Failed to execute child process “/usr/bin/Thunar” (Permission denied). journalctl: Nov 18 14:10:30

Bug#882043: apparmor should allow thunderbird to open links with firefox via exo-helper on xfce

2017-11-17 Thread Ben Caradoc-Davies
Package: apparmor Version: 2.11.1-3 Severity: normal Dear Maintainer, clicking on an email link in thunderbird results in an error dialog: Failed to execute default Web Browser. Failed to execute child process “/usr/bin/firefox” (Permission denied). journalctl reports: Nov 18 14:02:57 ripley

Bug#881314: lvm2 upgrade causes boot failure

2017-11-10 Thread Ben Caradoc-Davies
On 10/11/17 23:33, Bastian Blank wrote: On Fri, Nov 10, 2017 at 11:22:11PM +1300, Ben Caradoc-Davies wrote: installation of 2.02.176-3 (etc) *fails* in /usr/share/initramfs-tools/hooks/lvm2. Installed debs hot off incoming: I see. This is added error checking that now shows another problem

Bug#881314: lvm2 upgrade causes boot failure

2017-11-10 Thread Ben Caradoc-Davies
encountered while processing: initramfs-tools Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#881314: lvm2 upgrade causes boot failure

2017-11-10 Thread Ben Caradoc-Davies
On 10/11/17 20:02, Bastian Blank wrote: On Fri, Nov 10, 2017 at 06:37:36PM +1300, Ben Caradoc-Davies wrote: Severity: critical Justification: breaks the whole system Nope, it only breaks itself. Well, it only breaks systems that use it. upgrading to lvm2 2.02.176-2 (and related packages

Bug#881314: lvm2 upgrade causes boot failure

2017-11-10 Thread Ben Caradoc-Davies
On 10/11/17 22:22, Ben Caradoc-Davies wrote: I will reproduce and try to get better information. Bastian, you are too quick for me. Instead I will test 2.02.176-3 (etc) as soon as it is built. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software L

Bug#881314: lvm2 upgrade causes boot failure

2017-11-09 Thread Ben Caradoc-Davies
Package: lvm2 Version: 2.02.176-1 Severity: critical Justification: breaks the whole system Dear Maintainer, upgrading to lvm2 2.02.176-2 (and related packages) results in boot failure. Photo of boot message attached. Upgrade was: dmeventd:amd64 (2:1.02.145-1, 2:1.02.145-2) dmsetup:amd64

Bug#877729: freeplane startup fails with FileNotFoundException for MANIFEST.MF

2017-10-04 Thread Ben Caradoc-Davies
d (1.6.6-2); stale list?: https://packages.debian.org/sid/all/freeplane/filelist Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#877729: freeplane startup fails with FileNotFoundException for MANIFEST.MF

2017-10-04 Thread Ben Caradoc-Davies
Package: freeplane Version: 1.6.6-2 Severity: grave Justification: renders package unusable Dear Maintainer, startup of 1.6.6-2 fails with: org.knopflerfish.framework.readonly=true org.knopflerfish.gosg.jars=reference:file:/usr/share/freeplane/core/ org.freeplane.user.dir=/home/ben

Bug#876052: libregexp-pattern-license-perl installs /usr/share/man/man3/Regexp::Pattern::License.3pm.gz without proper Replaces/Breaks

2017-09-17 Thread Ben Caradoc-Davies
Laurent, I was hoping this was fixed in 3.0.31-2. See my report in #876056: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876056 I was able to fix my packages with "apt-get install -f" even with 3.0.31-1. Kind regards, -- Ben Caradoc-Davies <b...@wintersun.org>

Bug#876056: libregexp-pattern-license-perl file conflict with licensecheck

2017-09-17 Thread Ben Caradoc-Davies
Preparing to unpack .../19-licensecheck_3.0.31-1_all.deb ... Unpacking licensecheck (3.0.31-1) over (3.0.30-1) ... The problem is the installation order, which is likely fixed in 3.0.31-2 (with a Breaks:?). Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Softwa

Bug#876056: libregexp-pattern-license-perl file conflict with licensecheck

2017-09-17 Thread Ben Caradoc-Davies
See similar report in #876052 for 3.0.31-2. This might not be fixed: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876052 -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#876056: libregexp-pattern-license-perl file conflict with licensecheck

2017-09-17 Thread Ben Caradoc-Davies
Package: libregexp-pattern-license-perl Version: 3.0.31-1 Severity: grave Justification: renders package unusable Dear Maintainer, libregexp-pattern-license-perl has a file conflict with licensecheck: Selecting previously unselected package libregexp-pattern-license-perl. Preparing to unpack

Bug#874611: python-shapely,python3-shapely: uninstallable in sid

2017-09-08 Thread Ben Caradoc-Davies
It looks like this bug has been fixed by 1.6.1-1+b1. Andreas, please confirm. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#874611: python-shapely,python3-shapely: uninstallable in sid

2017-09-07 Thread Ben Caradoc-Davies
This also makes qgis uninstallable on sid. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#873627: udisks2 in sid apparently left me with a borked system in plasma(?))

2017-09-01 Thread Ben Caradoc-Davies
I can confirm that udisks2 2.7.2-2 fixes the thunar problems that I reported above: I see only the "usual" filesystems and can mount and unmount removable devices as expected. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <

Bug#873627: udisks2 in sid apparently left me with a borked system in plasma(?)

2017-08-30 Thread Ben Caradoc-Davies
udisks2 is now uninstallable on sid because of #873748: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=873748 Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#873627: udisks2 in sid apparently left me with a borked system in plasma(?)

2017-08-29 Thread Ben Caradoc-Davies
/debian/20170827T034402Z/ sid main Then ran the following to downgrade and hold: apt-get update apt-get install udisks2=2.6.5-2 libudisks2-0=2.6.5-2 apt-mark hold udisks2 libudisks2-0 A system restart was required. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Tra

Bug#871629: thunderbird UI unusable with many widgets not drawn

2017-08-10 Thread Ben Caradoc-Davies
Downgrading to thunderbird and lightning 52.2.1-4 restores usability. Reinstallation of libevent-2.0-5 (autoremoved) is also required. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#871629: thunderbird UI unusable with many widgets not drawn

2017-08-09 Thread Ben Caradoc-Davies
Package: thunderbird Version: 1:52.2.1-4+b1 Severity: grave Justification: renders package unusable Dear Maintainer, the thunderbird UI is unusable with many widgets not drawn. See attached screenshot. Mouse hover causes some to be drawn. Using XFCE with Clearlooks Phenix theme. Changing theme

Bug#870772: libgsl misses some breaks/replaces

2017-08-06 Thread Ben Caradoc-Davies
Is there something wrong with libgsl23 2.4+dfsg-4? nco which depends on libgsl23 and {inkscape, qgis} which depend on libgsl2 are not coinstallable. Should libgsl23 have libgsl2 in its "Replaces:"? I do not understand, but I suspect that something is wrong. Kind regards, -- B

Bug#867529: thermald.service should be a conffile

2017-07-08 Thread Ben Caradoc-Davies
Workaround is to copy thermald.service to (for example) thermald-custom.service and apply local customisations, stop+disable+mask thermald.service, and enable+start thermald-custom.service. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited

Bug#867529: thermald.service should be a conffile

2017-07-06 Thread Ben Caradoc-Davies
Package: thermald Version: 1.6.0-4 Severity: normal Dear Maintainer, thermald.service is the only place where options such as --poll-interval can be set, so this file should be considered a package conffile. Because thermald.service is not a conffile, local changes to the command line are

Bug#866685: libfreetype6: full hinting ignored

2017-07-02 Thread Ben Caradoc-Davies
FREETYPE_PROPERTIES="truetype:interpreter-version=35" Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#866685: libfreetype6: full hinting ignored

2017-06-30 Thread Ben Caradoc-Davies
Package: libfreetype6 Version: 2.8-0.2 Severity: normal Dear Maintainer, upgrading to libfreetype6 2.8-0.2 causes full hinting to be ignored. Tested on Liberation Sans and Deja Vu Sans Mono under XFCE, with effects seen in both GTK2 (full hinting set in XFCE desktop appearance) and GTK3 (full

Bug#863851: [Pkg-xfce-devel] Bug#863851: xfce4-terminal: command and execute options do not work

2017-06-14 Thread Ben Caradoc-Davies
/ Why do shorter running programs display no output? Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#863851: [Pkg-xfce-devel] Bug#863851: xfce4-terminal: command and execute options do not work

2017-06-12 Thread Ben Caradoc-Davies
the failure with either of these?: xfce4-terminal -H -x ls xfce4-terminal -H -e ls (Note the typo in my original report (should be "-x" not "-c")) Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#863851: xfce4-terminal: command and execute options do not work

2017-05-31 Thread Ben Caradoc-Davies
Package: xfce4-terminal Version: 0.8.4-1 Severity: normal Dear Maintainer, the command and execute options have no effect. Invoking either: xfce4-terminal -H -c ls xfce4-terminal -H -e ls results in a blank held terminal window. Without -H the terminal does not even appear, but this is

Bug#857997: firmware-misc-nonfree: Include Intel Kabylake GuC 9.14 and Broxton GuC 8.7

2017-03-16 Thread Ben Caradoc-Davies
Package: firmware-misc-nonfree Version: 20161130-2 Severity: normal Dear Maintainer, update-initramfs reports missing i915 firmware: Processing triggers for initramfs-tools (0.127) ... update-initramfs: Generating /boot/initrd.img-4.9.0-2-amd64 W: Possible missing firmware

Bug#851066: flashplugin-nonfree broken for all new installations on jessie and sid

2017-03-13 Thread Ben Caradoc-Davies
ttp://www.adobe.com/software/flash/about/ For future manual updates, only the tar command is required. ** Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#856628: live-wrapper: Fails with AttributeError: 'Package' object has no attribute 'version_list'

2017-03-02 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.6 Severity: normal Dear Maintainer, invoking live-wrapper on unstable with -d unstable fails with AttributeError: 'Package' object has no attribute 'version_list': Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/cliapp/app.py", line

Bug#800723: [Pkg-xfce-devel] Processed: found 800723 in 1.6.10-5

2017-02-12 Thread Ben Caradoc-Davies
was unable to reproduce #800723. Thank you so much for this fix. I hope that you can get it into stretch. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#818484: Bug #818484: Renaming or moving files or dirs leads to segfault

2017-02-11 Thread Ben Caradoc-Davies
is that, in 1.6.10-5, if there is no segfault, thumbnails of the dragged files are missing until the folder is refreshed (either by Ctrl-R or navigating away and back). Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#800723: intermittent segfault on file drag and drop

2017-02-11 Thread Ben Caradoc-Davies
the move has succeeded. A new observation is that, in 1.6.10-5, if there is no segfault, thumbnails of the dragged files are missing until the folder is refreshed (either by Ctrl-R or navigating away and back). Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Tra

Bug#800723: [Pkg-xfce-devel] Processed: found 800723 in 1.6.10-5

2017-02-11 Thread Ben Caradoc-Davies
until one or both Thunar segfaults. Usually the target Thunar segfaults, often both. The drag is always successful (the files are moved). Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847343: firmware-misc-nonfree: breaks update-initramfs (initramfs-tools <= 0.125) if plymouth installed

2016-12-07 Thread Ben Caradoc-Davies
bug back. Thanks very much. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847343: firmware-misc-nonfree: breaks update-initramfs (initramfs-tools <= 0.125) if plymouth installed

2016-12-07 Thread Ben Caradoc-Davies
lacks "Breaks: initramfs-tools (<= 0.125)" which it will need even after #847340 is fixed. If you are sure that you want this bug on initramfs-tools, I will defer to your expertise, but I do not see how this addresses my points above. Kind regards, -- Ben Caradoc-Davies <b...@transi

Bug#847343: firmware-misc-nonfree: breaks update-initramfs (initramfs-tools <= 0.125) if plymouth installed

2016-12-07 Thread Ben Caradoc-Davies
c-nonfree bug. :-) Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847343: firmware-misc-nonfree: breaks update-initramfs if plymouth installed

2016-12-07 Thread Ben Caradoc-Davies
ffects systems with plymouth installed. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847340: initramfs-tools: fails to copy DRM modules with plymouth, firmware-misc-nonfree 20161130-1, kernel 4.9~rc8

2016-12-07 Thread Ben Caradoc-Davies
Also reported as grave bug #847343 against firmware-nonfree/20161130-1 to warn apt-listbugs users against upgrading: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847343 -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847343: firmware-misc-nonfree: breaks update-initramfs

2016-12-07 Thread Ben Caradoc-Davies
apt-listbugs users from the breakage upgrading firmware-misc-nonfree triggers. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#847343: firmware-misc-nonfree: breaks update-initramfs

2016-12-07 Thread Ben Caradoc-Davies
Package: firmware-misc-nonfree Version: 20161130-1 Severity: grave Justification: renders package unusable Dear Maintainer, the following upgrade breaks update-initramfs: firmware-amd-graphics (20160824-1 => 20161130-1) firmware-atheros (20160824-1 => 20161130-1) firmware-brcm80211 (20160824-1

Bug#846637: live-wrapper: grub2 memtest86 fails with "error: version too old for 32-bit boot"

2016-12-02 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.5 Severity: normal Dear Maintainer, a live ISO booted via UEFI (so using grub2) fails to run memtest86. Live ISO built with: lwr --memtest -d unstable Tested on QEMU with: qemu-system-x86_64 -enable-kvm -m 2048 -bios /usr/share/ovmf/OVMF.fd -hda live.iso

Bug#846632: live-wrapper: cdrom not detected when installing from thumb drive

2016-12-02 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.5 Severity: normal Dear Maintainer, when installing from a thumb drive, d-i fails to detect the "cdrom". Workaround is to select No for external media, manually set the driver to none, and set /dev/sda1 as the cdrom device. Installation then proceeds. This test

Bug#846631: live-wrapper: graphical installer option invokes text installer

2016-12-02 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.5 Severity: normal Dear Maintainer, selecting the graphical installer results in a text mode installation. The graphical and text mode installers contained in the ISO are identical: # find /mnt/d-i -type f -exec md5sum {} \; a54d4e60c0475a8d67fce9c162653e30

Bug#845480: /bin/ps depends on /usr/lib/... which makes the system unbootable

2016-11-25 Thread Ben Caradoc-Davies
because critical bugs cause apt-get upgrade to prompt for user input. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#840254: [Pkg-xfce-devel] Bug#840254: thunar: freeze when mounting USB drive

2016-10-10 Thread Ben Caradoc-Davies
On 11/10/16 09:39, Ben Caradoc-Davies wrote: Only once during testing, 1.6.10-3 appeared to start working correctly for all drives. This behaviour did not survive a reboot. Mounting with 1.6.10-2 is always successful. Failures only start after reboot! Upgrading to 1.6.10-3 appears to work

Bug#840254: [Pkg-xfce-devel] Bug#840254: thunar: freeze when mounting USB drive

2016-10-10 Thread Ben Caradoc-Davies
different drives. Only once during testing, 1.6.10-3 appeared to start working correctly for all drives. This behaviour did not survive a reboot. Mounting with 1.6.10-2 is always successful. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited

Bug#840254: thunar: freeze when mounting USB drive

2016-10-09 Thread Ben Caradoc-Davies
Downgrading libthunarx-2-0, thunar, thunar-data, and thunar-dbg to 1.6.10-2 restores the ability to mount and unmount USB devices. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#840254: thunar: freeze when mounting USB drive

2016-10-09 Thread Ben Caradoc-Davies
Package: thunar Version: 1.6.10-3 Severity: normal Dear Maintainer, thunar displays an unmounted ext4 USB thumb drive. Clicking on it causes the progress icon to be displayed but thunar then freezes and must be killed via window manager or command line. The device is successfully mounted.

Bug#835553: [Pkg-utopia-maintainers] Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-09-25 Thread Ben Caradoc-Davies
On 26/09/16 11:04, Michael Biebl wrote: If that doesn't fix the issue, please re-open the bug report upstream. Just to be sure, reboot the system. Michael, Upstream instructed me to open a new issue: https://bugzilla.gnome.org/show_bug.cgi?id=771966 Kind regards, -- Ben Caradoc-Davies &l

Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-09-25 Thread Ben Caradoc-Davies
, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#837606: general: system freeze

2016-09-12 Thread Ben Caradoc-Davies
ry errors? Overheating? - Wireless keyboard low battery or lost connection? In any case, the Debian Bug Tracking System is not the most suitable forum for general support unless you can determine specific steps to reproduce this problem. Kind regards, -- Ben Caradoc-Davies <b...@transient

Bug#836997: i965-va-driver: Missing i965-va-driver 1.7.2-1 for amd64

2016-09-07 Thread Ben Caradoc-Davies
Package: i965-va-driver Version: 1.7.2-1 Severity: normal Dear Maintainer, i965-va-driver 1.7.2-1 for amd64 is missing. Noticed on multiarch where it causes i386 to be held back: The following packages have been kept back: i965-va-driver:i386 (1.7.1-1 => 1.7.2-1) The build looks OK:

Bug#836533: firefox segfault in 48.0-1+b1 but not 48.0-1

2016-09-03 Thread Ben Caradoc-Davies
nd regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand $ gdb --args firefox GNU gdb (Debian 7.11.1-2) 7.11.1 Copyright (C) 2016 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://

Bug#836533: Firefox crashes in js::jit::SnapshotIterator::numAllocations(). Possibly GCC 6-related?

2016-09-03 Thread Ben Caradoc-Davies
ks for me. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835273: closed by Fabian Greffrath <fab...@debian.org> (Bug#835273: fixed in fonts-liberation 1:1.07.4-2)

2016-08-30 Thread Ben Caradoc-Davies
Thanks very much, Fabian. Confirmed fixed in 1:1.07.4-2. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835553: [Pkg-utopia-maintainers] Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-08-29 Thread Ben Caradoc-Davies
n succeeds. The upstream bug is a possible duplicate of: https://bugzilla.gnome.org/show_bug.cgi?id=770456 I have supplied a log file and left it to the maintainers to decide. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835553: [Pkg-utopia-maintainers] Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-08-27 Thread Ben Caradoc-Davies
:f2:6d:10:c5:09 A2=ec:cb:30:60:58:32 Aug 28 15:01:06 ripley wpa_supplicant[8462]: nl80211: wlxf4f26d10c509: Ignore MLME frame event for foreign address Workaround is to downgrade to 1.2.4. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited

Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-08-26 Thread Ben Caradoc-Davies
ager/ http://ftp.debian.org/debian/pool/main/n/network-manager-applet/ Fortunately USB tethering to a phone still works in 1.4.0. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835553: network-manager: WiFi authentication fails after upgrade to 1.4.0

2016-08-26 Thread Ben Caradoc-Davies
Package: network-manager Version: 1.2.4-2 Severity: normal Dear Maintainer, WiFi authentication fails after upgrading to network-manager 1.4.0. Workaround is to downgrade to 1.2.4, which restores connection. This bug looks different to #817123 as the device (external USB WiFi adapter) is

Bug#829188: icedove segfault in nsDisplayList::DeleteAll

2016-08-26 Thread Ben Caradoc-Davies
I still see occasional crashes with 1:45.2.0-4, a couple of times a week, mainly while browsing debian-devel. ;-) I will set layers.offmainthreadcomposition.enabled=false and see if this helps. -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited

Bug#835273: [Pkg-fonts-devel] Bug#835273: Bug#835273: fonts-liberation: Liberation 2 fonts poorly hinted

2016-08-25 Thread Ben Caradoc-Davies
merits of hinting in Liberation 1 versus croscore. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835273: [Pkg-fonts-devel] Bug#835273: fonts-liberation: Liberation 2 fonts poorly hinted

2016-08-24 Thread Ben Caradoc-Davies
to a virtual package. This might require the advice of an apt guru. Splitting out the condensed (I think they call it narrow?) font might be unnecessary complexity at this stage. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835273: [Pkg-fonts-devel] Bug#835273: fonts-liberation: Liberation 2 fonts poorly hinted

2016-08-24 Thread Ben Caradoc-Davies
name; if they had chosen a new name, we would not be having this problem. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#835273: fonts-liberation: Liberation 2 fonts poorly hinted

2016-08-23 Thread Ben Caradoc-Davies
Package: fonts-liberation Version: 2.00.1-2 Severity: normal Dear Maintainer, Liberation 2 fonts lack the high-quality hinting used in Liberation 1 fonts. Please allow users to choose Liberation 1 fonts. I have attached two tiny snapshots snippets showing a Thunar toolbar with Liberation Sans

Bug#829188: icedove segfault in nsDisplayList::DeleteAll

2016-08-13 Thread Ben Caradoc-Davies
I have not had a single crash since upgrading yesterday to icedove 1:45.2.0-3 amd64. The upgrade fixes #833532 (crash on startup blamed on iceowl), but it also seems to have stopped the folder navigation crashes for me. I will report back if I see another crash. -- Ben Caradoc-Davies &l

Bug#829188: icedove segfault in nsDisplayList::DeleteAll

2016-08-07 Thread Ben Caradoc-Davies
/mail/app/nsMailApp.cpp:332 -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand MOZILLA_FIVE_HOME=/usr/lib/icedove LD_LIBRARY_PATH=/usr/lib/icedove:/usr/lib/icedove/plugins:/usr/lib/icedove DISPLAY=:0.0 DYLD_LIBRARY_PATH=/us

Bug#831637: live-wrapper: kernel panic: Can't open /scripts/live

2016-07-17 Thread Ben Caradoc-Davies
On 18/07/16 14:58, Ben Caradoc-Davies wrote: Quoting problem? This GRUB2 command line option: boot=live components should be: boot="live components" I take that back. All this does is disable live boot and allows failure to occur elsewhere. Kind regards, -- Ben Caradoc

Bug#831637: live-wrapper: kernel panic: Can't open /scripts/live

2016-07-17 Thread Ben Caradoc-Davies
drop back to an (initramfs) prompt. Tested with an emulated UEFI boot: qemu-system-x86_64 -machine q35 -m 1024 -bios /usr/share/ovmf/OVMF.fd -hda live.iso Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#831368: live-wrapper: output live.iso not isohybrid, cannot be booted from thumb drive

2016-07-17 Thread Ben Caradoc-Davies
699c7 GPT partition flags: 2 0x GPT start and size : 2 312 832 GPT partition path : 2 /boot/grub/efi.img Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#831368: live-wrapper: output live.iso not isohybrid, cannot be booted from thumb drive

2016-07-17 Thread Ben Caradoc-Davies
0x00832 78 El Torito img path : 1 /boot/isolinux/isolinux.bin El Torito img opts : 1 boot-info-table isohybrid-suitable El Torito img path : 2 /boot/grub/efi.img xorriso : NOTE : No System Area was loaded Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Di

Bug#831368: live-wrapper: output live.iso not isohybrid, cannot be booted from thumb drive

2016-07-14 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.3 Severity: normal Dear Maintainer, the output live.iso produced by lwr has neither MBR nor any partitions (MBR or GPT). It appears to be a plain ISO image. It cannot be booted from a thumb drive. Kind regards, Ben. -- System Information: Debian Release:

Bug#831367: live-wrapper: Missing dependencies on isolinux and xorriso

2016-07-14 Thread Ben Caradoc-Davies
Package: live-wrapper Version: 0.3 Severity: normal Dear Maintainer, if isolinux and xorriso are not installed, lwr fails with: ERROR: [Errno 2] No such file or directory: '/usr/lib/ISOLINUX/isolinux.bin' After manually installing isolinux, lwr still fails with: ERROR: No such file or

Bug#830522: xfce4-session: re-login fails with dbus connection error

2016-07-08 Thread Ben Caradoc-Davies
Package: xfce4-session Version: 4.12.1-4 Severity: normal Dear Maintainer, xfce4 login via lightdm succeeds, but after logout, logging in again fails with first this dialog: "Unable to contact settings server. Failed to connect socket /tmp/dbus- XX: connection refused." and after

Bug#824902: tar: -X / --exclude-from silent failure

2016-05-24 Thread Ben Caradoc-Davies
res --exclude option Date: Wed, 25 May 2016 15:35:30 +1200 From: Ben Caradoc-Davies <b...@transient.nz> To: Sergey Poznyakoff <g...@gnu.org.ua> CC: bug-...@gnu.org On 26/05/16 09:05, Sergey Poznyakoff wrote: > Hi Ben, > The --exclude option is position-sensitive, which means it appli

Bug#824902: tar: -X / --exclude-from silent failure

2016-05-22 Thread Ben Caradoc-Davies
There is a report on the upstream bug-tar mailing list that --exclude is also broken: http://lists.gnu.org/archive/html/bug-tar/2016-05/msg00012.html Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#824902: tar: -X / --exclude-from silent failure

2016-05-20 Thread Ben Caradoc-Davies
And it makes no difference if "base/" is prepended to the patterns in "excludes", the same behaviour is observed: success in 1.28-2.2 and failure in 1.29-1. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#824902: tar: -X / --exclude-from silent failure

2016-05-20 Thread Ben Caradoc-Davies
And although -X / --exclude-from is missing from the latest man page, it is still documented in the HTML manual: https://www.gnu.org/software/tar/manual/html_section/tar_49.html Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://tra

Bug#824902: tar: -X / --exclude-from silent failure

2016-05-20 Thread Ben Caradoc-Davies
Package: tar Version: 1.29-1 Severity: normal Dear Maintainer, the -X / --exclude-from option silently fails in 1-29-1. Consider this example (see attached tar file): The file "includes" contains: base The file "excludes" contains: dir-2 dir-glob-* With tar 1.28-2.2, the patterns listed in

Bug#820294: openjdk-7-jre-headless: uninstallable since tzdata-java is gone

2016-04-13 Thread Ben Caradoc-Davies
?bug=818308 In a nutshell, I installed openjdk-7 from experimental: apt-get -t experimental install openjdk-7-jdk and apt-listbugs led me here. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#818308: openjdk-7-jre-headless: openjdk-7 uninstallable because tzdata-java removed

2016-04-13 Thread Ben Caradoc-Davies
n created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: openjdk-7-jdk : Depends: openjdk-7-jre (= 7u95-2.6.4-1+b1) but it is not going to be installed E: Unable to correct problems, you have held bro

Bug#818308: openjdk-7-jre-headless: openjdk-7 uninstallable because tzdata-java removed

2016-04-04 Thread Ben Caradoc-Davies
openjdk-7 is still uninstallable on unstable because 7u95-2.6.4-3 is only available in experimental and has not yet been accepted into unstable. -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#819618: openjdk-8-source: "source" package is empty (does not contain src.zip anymore)

2016-04-01 Thread Ben Caradoc-Davies
Chris, looks like this just got fixed in 8u77-b03-3. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#819618: openjdk-8-source: "source" package is empty (does not contain src.zip anymore)

2016-04-01 Thread Ben Caradoc-Davies
Chris, is the incomplete debug information worthy of a separate bug report against openjdk-8-jdk-headless? This sounds to me like a separate issue. Kind regards, -- Ben Caradoc-Davies <b...@transient.nz> Director Transient Software Limited <http://transient.nz/> New Zealand

Bug#819618: openjdk-8-source: "source" package is empty (does not contain src.zip anymore)

2016-03-31 Thread Ben Caradoc-Davies
Chris, according the file list <https://packages.debian.org/sid/amd64/openjdk-8-jdk-headless/filelist> openjdk-8-jdk-headless contains /usr/lib/jvm/java-8-openjdk-amd64/src.zip Perhaps openjdk-8-source is now obsolete? Kind regards, -- Ben Caradoc-Davies <b...@transient.nz&

  1   2   3   >