Bug#913008: devscripts: Useless use of concatenation (.) or string in void context at /usr/share/perl5/Devscripts/Uscan/Downloader.pm line 106.

2018-11-05 Thread Francois Marier
Package: devscripts Version: 2.18.7 Severity: normal Tags: patch When running uscan, I get the following warning message: $ mkdir test $ cd test $ uscan --report Useless use of concatenation (.) or string in void context at /usr/share/perl5/Devscripts/Uscan/Downloader.pm line 106.

Bug#911054: workrave: desktop instability in multimonitor (3) setup

2018-10-15 Thread Francois Marier
On 2018-10-15 at 09:03:54, wim wrote: > in about 80% of the cases, whenever workrave tries to "intervene" with a > break or other notice, > the desktop flickers and needs reloading, > sometimes the desktop needs to be restarted > > this could be related to #503684 ? I just closed that old bug.

Bug#910743: etbemon: Sample config in README.monitors is outdated and invalid

2018-10-10 Thread Francois Marier
Source: etbemon Version: 1.3.3-3 Severity: normal Tags: patch The sample config in README.monitors under the "freespace.monitor" section is invalid and I suspect now outdated. Here's a fix for it: --- README.monitors 2018-10-10 08:28:58.426445460 -0700 +++ README.monitors.fixed

Bug#910741: etbemon: By default mon listens on port 2583 (UDP) on all network interfaces

2018-10-10 Thread Francois Marier
Source: etbemon Version: 1.3.3-3 Severity: important After installing mon, I got the following tiger warning email: # Checking listening processes NEW: --WARN-- [lin003w] The process `mon' is listening on socket 2583 (UDP on every interface) is run by mon. I realized that the fix for

Bug#907399: Logs with systemd-coredump

2018-09-01 Thread Francois Marier
On 2018-09-01 at 14:44:16, Till Kamppeter wrote: > Bernhard, thank for the patch. I have applied it now (and also done an > additional fix for DomainSocket) and committed it to the upstream GIT repo. > > Please test. Happy to test things. Just to be clear, do you want me to clone the repo, build

Bug#907399: Logs with systemd-coredump

2018-08-28 Thread Francois Marier
I installed systemd-coredump and this is what I see in my logs now: Aug 27 23:04:37 hostname systemd[1]: Listening on Process Core Dump Socket. Aug 27 23:05:34 hostname cups-browsed[29428]: munmap_chunk(): invalid pointer Aug 27 23:05:34 hostname systemd[1]: Created slice

Bug#907399: cups-browsed: munmap_chunk(): invalid pointer

2018-08-27 Thread Francois Marier
Package: cups Version: 2.2.8-5 Severity: normal Once a day, I get a message like this in my logs: Aug 27 00:00:02 hostname cups-browsed[6122]: munmap_chunk(): invalid pointer Aug 27 00:00:02 hostname systemd[1]: cups-browsed.service: Main process exited, code=dumped, status=6/ABRT Aug 27

Bug#907351: tor: TLS error while constructing a TLS context: dh key too small (in SSL routines:ssl3_ctx_ctrl:---)

2018-08-26 Thread Francois Marier
Package: tor Version: 0.3.3.9-1 Severity: normal I get the following error in my logs approximately every 2 hours: Aug 26 05:05:01 hostname Tor[25963]: TLS error while constructing a TLS context: dh key too small (in SSL routines:ssl3_ctx_ctrl:---) I tried upgrading to the version in

Bug#902875: Patch

2018-08-14 Thread Francois Marier
tags 902875 +patch thanks According to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=902413#12, all that's needed is to change `/var/run/` to `/run/` in /usr/lib/tmpfiles.d/postgresql.conf. I've attached a patch. Francois -- https://fmarier.org/ diff --git

Bug#759410: Different approach for safe-rm

2018-08-04 Thread Francois Marier
I took a look at the details of the diversion that the latest version of dash sets up and it's really quite complicated. It's not clear that I could easily get it right, even copying that code, and the consequences of getting it wrong could be disastrous. So instead I went for an easier approach:

Bug#902929: units: /var/lib/units/currency.units should be installed in a maintainer script

2018-07-03 Thread Francois Marier
Package: units Version: 2.17-1 Severity: normal It looks like /var/lib/units/currency.units is updated on cron once a day. This means that this file no longer matches the checksum that was generated at package creation time and so tools like reportbug and debsums will warn about it: System

Bug#902875: postgresql-common: systemd warning message: Line references path below legacy directory /var/run/

2018-07-02 Thread Francois Marier
Package: postgresql-common Version: 191 Severity: normal Once a day, I get the following systemd warning message in my logs: Jul 1 20:50:01 hostname systemd-tmpfiles[21472]: [/usr/lib/tmpfiles.d/postgresql.conf:2] Line references path below legacy directory /var/run/, updating

Bug#898078: Alternative for decoding qr codes?

2018-05-12 Thread Francois Marier
Is there an alternative for decoding QR codes in Debian? The closest thing I could find was dmtx-utils but that looks like a different kind of code and it's also dead upstream (https://web.archive.org/web/20150808104301/http://www.libdmtx.org:80/). It seems like everything that decodes QR codes

Bug#895456: axlisten: Could not initialize color support.

2018-04-11 Thread Francois Marier
Package: ax25-apps Version: 0.0.8-rc4-2 Severity: normal When I start axlisten with the "-c" option, I get the following error message: $ axlisten -cart Could not initialize color support. This happens in both gnome-terminal and xterm. Francois -- System Information: Debian Release:

Bug#895147: firefox: Safe Browsing updates fail due to insufficient quota on the Google API key

2018-04-07 Thread Francois Marier
On 2018-04-08 at 06:38:14, Mike Hommey wrote: > We're using the same API key as the chromium in Debian, so presumably > the same problem applies to the chromium package. Yes, presumably the Chromium package has the same problem. I did a quick check and none of the test entries from

Bug#895147: firefox: Safe Browsing updates fail due to insufficient quota on the Google API key

2018-04-07 Thread Francois Marier
Package: firefox Version: 59.0.2-1 Severity: important Tags: security After enabling browser.safebrowsing.debug in about:config, I saw this on my terminal: listmanager: 17:45:17 GMT+ (UTC): download error for

Bug#893169: rkhunter won't update definitions: Invalid WEB_CMD

2018-03-31 Thread Francois Marier
On 2018-03-30 at 12:52:23, Kudrettin Güleryüz wrote: > This message apparently refers to the bug itself. Can you please point to > the bug report that has the details for this issue? Sorry, I meant to point to this bug instead: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765895. Also see

Bug#829589: RFP: jedi-el -- Python auto-completion package for Emacs

2018-03-06 Thread Francois Marier
> This package needs other software, that is not yet in Debian: > > - EPC (https://github.com/kiwanami/emacs-epc) Now available as elpa-epc. > - deferred.el (https://github.com/kiwanami/emacs-deferred) elpa-deferred > - python-environment.el

Bug#882322: Another bug fixed upstream

2018-03-06 Thread Francois Marier
The new upstream release also fixes #871249. -- https://fmarier.org/

Bug#882322: python-paramiko: Please upgrade python-paramiko to the latest upstream version (2.4.0)

2017-11-21 Thread Francois Marier
Package: python-paramiko Version: 2.0.0-1 Severity: normal Version 2.4.0 is out: https://github.com/paramiko/paramiko/releases/tag/2.4.0 It fixes bugs #851474 and #882319. Francois

Bug#882319: python-paramiko: DeprecationWarning when using duplicity

2017-11-21 Thread Francois Marier
Package: python-paramiko Version: 2.0.0-1 Severity: normal When using duplicity, the following DeprecationWarning (from cryptography) is emitted by python-paramiko: /usr/lib/python2.7/dist-packages/paramiko/rsakey.py:119: DeprecationWarning: signer and verifier have been deprecated. Please

Bug#880615: linux-latest: systemd complains about CONFIG_BPF_SYSCALL not being set

2017-11-02 Thread Francois Marier
Source: linux-latest Version: 86 Severity: normal systemd complains in syslog about Debian kernels not supporting BPF/cgroup firewalling: systemd[1]: File /lib/systemd/system/systemd-udevd.service:32 configures an IP firewall (IPAddressDeny=any), but the local system does not support

Bug#879168: RFP: radamsa -- test case generator for robustness testing

2017-10-19 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: radamsa Version : 0.5 Upstream Author : Aki Helin * URL : https://github.com/aoh/radamsa * License : MIT Programming Lang: LISP Description : test case generator for robustness testing

Bug#878099: libhdhomerun: Please make libhdhomerun4 Multi-Arch: same

2017-10-10 Thread Francois Marier
On 2017-10-10 at 21:37:30, Ian Campbell wrote: > Sorry, looks like I accidentally missed out a hunk in the orignal patch > I sent, see below. Like last time note the mode as well as the content > change. > > Sorry again for the confusion. Thanks. That was the problem. I've uploaded the package.

Bug#878099: libhdhomerun: Please make libhdhomerun4 Multi-Arch: same

2017-10-10 Thread Francois Marier
On 2017-10-10 at 19:38:18, Ian Campbell wrote: > On Tue, 2017-10-10 at 11:20 -0700, Francois Marier wrote: > > E: libhdhomerun4: ldconfig-symlink-missing-for-shlib > > usr/lib/x86_64-linux-gnu/libhdhomerun.so.4 > > usr/lib/x86_64-linux-gnu/libhdhomerun.so.4.0.0 libh

Bug#878099: libhdhomerun: Please make libhdhomerun4 Multi-Arch: same

2017-10-10 Thread Francois Marier
Thanks for the patch Ian. I merged it [1] but then noticed that it introduces two lintian problems: E: libhdhomerun4: ldconfig-symlink-missing-for-shlib usr/lib/x86_64-linux-gnu/libhdhomerun.so.4 usr/lib/x86_64-linux-gnu/libhdhomerun.so.4.0.0 libhdhomerun.so.4 W: libhdhomerun4:

Bug#876118: youtube-dl: Please upgrade to latest upgrade version (2017-09-11)

2017-09-18 Thread Francois Marier
Package: youtube-dl Version: 2017.05.18.1-1 Severity: important Downloading from dailymotion.com no longer works in the version that's in Debian. Presumably, upgrading to the latest version will help. Francois

Bug#871938: .delta file

2017-08-12 Thread Francois Marier
Here's the .delta file I forgot to include. ‹,PYKIÍ)Id -03mhnj€Lƒ€¡±ƒ¡±¡‰±™©)P¡‘‘™1ƒ‚Ý¥Å%‰E iE‰yÉù™Å¸Ô’¢àÚá# ¬L²ùE™éÀpHJÌÉÑ×/JM.JM,I… °¶l``h.’ìÅâQ»dk/¶²þ5¯Šˆšð_è¦#ƒ"#Ý?ÃqΦ†K± Ò½Nߘ¯wÉ^Ž h\^Îgd«êòò­?Äìš^ *-zø#Æ(×ÑÉ3wåå@

Bug#871938: pristine-tar: Cannot reproduce planetfilter-0.7.4.tar.gz

2017-08-12 Thread Francois Marier
Package: pristine-tar Version: 1.40 Severity: normal $ wget 'https://pypi.python.org/packages/3b/f5/71cc36f37b2e91aa36cb4234adfa6eaad5f55947eddc9035efe7280cf400/planetfilter-0.7.4.tar.gz#md5=1f810bb2398890a464665f2eaea168e2' ... $ tar zxf planetfilter-0.7.4.tar.gz $ cd planetfilter-0.7.4/ $ git

Bug#865972: #865972 - same problem of false positive regarding PermitRootLogin parameter

2017-08-09 Thread Francois Marier
On 2017-08-08 at 18:57:25, Jean-Marc wrote: > So, if the default value "prohibit-password" is secure enough, maybe changing > this line > > ALLOW_SSH_ROOT_USER=unset > > can solve this. It looks fine to me, but I'm not entirely sure that we should stop recommending that root logins be

Bug#868106: jessie-pu: package rkhunter/1.4.2-0.4

2017-07-11 Thread Francois Marier
=high + + * Disable remote updates to fix CVE-2017-7480 and prevent bugs like +it in the future (closes: #765895, #866677) + + -- Francois Marier <franc...@debian.org> Tue, 11 Jul 2017 20:17:08 -0700 + rkhunter (1.4.2-0.4) unstable; urgency=medium * Non-maintainer upload. diff -Nru rk

Bug#868105: stretch-pu: package rkhunter/1.4.2-6

2017-07-11 Thread Francois Marier
+ + * Disable remote updates to fix CVE-2017-7480 and prevent bugs like +it in the future (closes: #765895, #866677) + + -- Francois Marier <franc...@debian.org> Wed, 12 Jul 2017 03:07:17 + + rkhunter (1.4.2-6) unstable; urgency=medium * Fix logcheck rule ("1 seconds&

Bug#868099: rkhunter: clean up legacy conffile

2017-07-11 Thread Francois Marier
On 2017-07-12 at 02:50:27, Christoph Anton Mitterer wrote: > Apparently the package used to contain: > /etc/default/rkhunter > as a dpkg conffile but no longer does and ships it manually managed instead. > > This file was however not properly cleaned up as conffile and is still marked > as such.

Bug#856170: molly-guard: hostname should not be case-sensitive

2017-07-05 Thread Francois Marier
On 2017-07-05 at 20:26:03, Simó Albert i Beltran wrote: > The tr command is introducing a dependency of coreutils package. I think it's fine to add a dependency on coreutils. > I can change the default value of the option, but if you prefer I will > remove the option. Yes, I think we don't need

Bug#856170: molly-guard: hostname should not be case-sensitive

2017-07-03 Thread Francois Marier
On 2017-07-04 at 00:23:14, Simó Albert i Beltran wrote: > What do you think about this patch? > > https://gitlab.com/sim6/molly-guard/compare/master...sim6_hostname_case_insensitive Thanks for the patch! I'd be tempted to make it even simpler: always do a case-insentive match (no option).

Bug#657641: Patch doesn't work

2017-04-27 Thread Francois Marier
I can also confirm that the patch fails to work, at least on my machine. I still get daily cron emails about the kill command in that cleanup function. Francois

Bug#856024: molly-guard: causes failure to update systemd-sysv

2017-04-09 Thread Francois Marier
On 2017-04-09 at 15:42:46, Francois Marier wrote: > Here's what I thought would trigger the bug: > > 1. installed stretch from scratch in a lxc container (amd64) > 2. apt install molly-guard (0.6.4) > 3. apt install sysvinit-core (which removes systemd-sysv) > 4. apt install sys

Bug#856024: molly-guard: causes failure to update systemd-sysv

2017-04-09 Thread Francois Marier
On 2017-02-24 at 13:02:05, Jonas Smedegaard wrote: > On an ARM system bootstrapped from Stretch yesterday, today failed to > update systemd-sysv: > > Setting up systemd (232-18) ... > addgroup: The group `systemd-journal' already exists as a system group. > Exiting. > (Reading database ... 40888

Bug#859596: RFA: molly-guard -- 9027b495eb885926ceab360590ed53b7

2017-04-05 Thread Francois Marier
Package: wnpp Severity: normal I request an adopter for the molly-guard package. The main thing that needs fixing at the moment are the diversions (bug #837928) since that's causing issues with usrmerge. There is also a reported problem with systemd-sysv (bug #856024) that needs to be

Bug#856024: Processed: Adding a conflict in systemd-sysv

2017-03-18 Thread Francois Marier
Control: reassign -1 systemd-sysv This looks like a genuine bug in molly-guard, Yes and that's tracked in bug #837928. The present bug is specifically about the interaction between molly-guard and systemd-sysv. so this RC bug should be assigned to molly-guard. Adding a Breaks to

Bug#856170: molly-guard: hostname should not be case-sensitive

2017-02-27 Thread Francois Marier
On 2017-02-25 16:17, Nicolas Braud-Santoni wrote: Would a patch changing this behaviour be considered for inclusion? If so, I would happily provide one. That sounds like a good idea. I'd be happy to review and merge that. Francois

Bug#856024: molly-guard: causes failure to update systemd-sysv

2017-02-24 Thread Francois Marier
On 2017-02-24 at 13:02:05, Jonas Smedegaard wrote: > This seems quite similar to bug#837928. Filing separately as I believe > this (instance of a common) issue is so severe that in my opinion it is > better to release _without_ molly-guard than status quo. Or perhaps a Conflict in systemd-sysv?

Bug#851931: RFP: apache2-mod-brotli -- Brotli compression module for Apache

2017-01-19 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: apache2-mod-brotli Version : 0.3.1 Upstream Author : kj * URL : https://github.com/kjdev/apache-mod-brotli * License : Apache 2 Programming Lang: C Description : Brotli compression

Bug#848621: tiger: 1:3.2.3-14.3 NMU

2016-12-18 Thread Francois Marier
efivarfs (Closes: #848377) + + -- Francois Marier <franc...@debian.org> Sun, 18 Dec 2016 17:16:39 -0800 + tiger (1:3.2.3-14.2) unstable; urgency=medium * Non-maintainer upload. diff -u tiger-3.2.3/systems/Linux/2/gen_mounts tiger-3.2.3/systems/Linux/2/gen_mounts --- tiger-3.2.3/systems/L

Bug#848377: tiger: Filesystem 'efivarfs' used by 'efivarfs' is not recognised as a valid filesystem

2016-12-16 Thread Francois Marier
Package: tiger Version: 1:3.2.3-14.2 Severity: normal I'm getting this error message on an EFI-enabled laptop running stretch: --CONFIG-- [con010c] Filesystem 'efivarfs' used by 'efivarfs' is not recognised as a valid filesystem Francois -- System Information: Debian Release: stretch/sid

Bug#837928: Possible usrmerge-safe diversion

2016-11-30 Thread Francois Marier
Looking at how dash does the dpkg-divert (as suggested by Josh): https://sources.debian.net/src/dash/0.5.8-2.3/debian/dash.preinst/ It appears that this approach might work for both symlinks and real files because it manually handles the creation of the symlink using "cp -d". Francois --

Bug#843450: [pkg-lxc-devel] Bug#843450: Bug#843450: lxc: Corrupt /proc/self/cgroup / Failed to get list of controllers

2016-11-07 Thread Francois Marier
On 2016-11-07 at 13:00:31, Evgeni Golov wrote: > Can you please try booting with > systemd.legacy_systemd_cgroup_controller > and see if that fixes the issue for you for now? It seems to work fine. Thanks for the pointer! Should there be a versioned conflict on systemd or the kernel? Maybe a

Bug#759410: Should not install /usr/bin/rm conflicting with /bin/rm (blocks /bin -> /usr/bin)

2016-11-07 Thread Francois Marier
On 2016-10-25 at 09:12:30, Sven Joachim wrote: > >> In order to fix this while preserving safe-rm's default of automatic > >> protection on installation, safe-rm will need to divert and replace > >> /bin/rm. This will require quite a bit of care to do safely; see dash's > >> maintainer scripts

Bug#837928: Bug#837925: usrmerge: fails to merge with molly-guard installed

2016-11-07 Thread Francois Marier
On 2016-11-02 at 03:02:29, Jonas Smedegaard wrote: > I am busy getting that system to production use (yes, stretch is not yet > stable, but more stable than stable on the ARM device I use), but if you > have suggestions for closer inspections that might help shed some light > on this issue,

Bug#842795: email-reminder: Fail to send email as release version cannot be detect

2016-11-07 Thread Francois Marier
On 2016-11-06 at 10:09:21, Jack.R wrote: > I start to suspect a right access as that part is executed as > email-reminder user. > > So I try with a normal user by putting > my $distro = `/bin/su - alain -s /bin/sh -c "/usr/bin/lsb_release -s > -d"`; > I am prompt for the password and then it

Bug#843450: [pkg-lxc-devel] Bug#843450: lxc: Corrupt /proc/self/cgroup / Failed to get list of controllers

2016-11-07 Thread Francois Marier
On 2016-11-07 at 08:17:09, Evgeni Golov wrote: > Can you please post the outputs of > cat /proc/1/mountinfo # cat mountinfo | grep cgroup 26 16 0:22 / /sys/fs/cgroup ro,nosuid,nodev,noexec shared:9 - tmpfs tmpfs ro,mode=755 27 26 0:23 / /sys/fs/cgroup/systemd rw,nosuid,nodev,noexec,relatime

Bug#843456: tiger: Filesystem 'cgroup2' used by 'cgroup' is not recognised as a valid filesystem

2016-11-06 Thread Francois Marier
Package: tiger Version: 1:3.2.3-14.2 Severity: normal As of kernel 4.8, I'm getting this error message: --CONFIG-- [con010c] Filesystem 'cgroup2' used by 'cgroup' is not recognised as a valid filesystem A patch is attached. Francois -- System Information: Debian Release: stretch/sid APT

Bug#843455: lxc: Corrupt /proc/self/cgroup / Failed to get list of controllers

2016-11-06 Thread Francois Marier
Package: lxc Version: 1:2.0.5-1 Severity: normal Since I upgraded to a 4.8.0 kernel, I get these messages in my logs: Nov 5 18:02:08 hostname PAM-CGFS[6968]: Corrupt /proc/self/cgroup Nov 5 18:05:01 hostname PAM-CGFS[8574]: Corrupt /proc/self/cgroup Nov 5 18:05:01 hostname

Bug#843452: tiger: Filesystem 'cgroup2' used by 'cgroup' is not recognised as a valid filesystem

2016-11-06 Thread Francois Marier
Package: tiger Version: 1:3.2.3-14.2 Severity: normal As of kernel 4.8, I'm getting this error message: --CONFIG-- [con010c] Filesystem 'cgroup2' used by 'cgroup' is not recognised as a valid filesystem A patch is attached. Francois -- System Information: Debian Release: stretch/sid APT

Bug#843450: lxc: Corrupt /proc/self/cgroup / Failed to get list of controllers

2016-11-06 Thread Francois Marier
Package: lxc Version: 1:2.0.5-1 Severity: normal Since I upgraded to a 4.8.0 kernel, I get these messages in my logs: Nov 5 18:02:08 hostname PAM-CGFS[6968]: Corrupt /proc/self/cgroup Nov 5 18:05:01 hostname PAM-CGFS[8574]: Corrupt /proc/self/cgroup Nov 5 18:05:01 hostname

Bug#842795: email-reminder: Fail to send email as release version cannot be detect

2016-11-04 Thread Francois Marier
On 2016-11-02 at 22:15:34, Jack.R wrote: > With double quotes instead of backticks > # sudo su - email-reminder -s /bin/bash -c "/usr/bin/lsb_release -a" > No LSB modules are available. > Distributor ID: Debian > Description:Debian GNU/Linux testing (stretch) > Release:testing >

Bug#367347: Not fixed?

2016-11-04 Thread Francois Marier
Hi Rhonda, You reopened 367347 without any comments. Do you mind expanding on why you think it wasn't fixed as part of fixing 592917? Francois

Bug#837928: Bug#837925: usrmerge: fails to merge with molly-guard installed

2016-11-01 Thread Francois Marier
On 2016-11-01 at 18:48:51, Jonas Smedegaard wrote: > I don't know how to be more exact than how I wrote it initially for this > bugreport. > > Could you perhaps elaborate on what details you are missing? You wrote this: "molly-guard adds wrappers for commands like pm-hibernate and poweroff.

Bug#837928: Bug#837925: usrmerge: fails to merge with molly-guard installed

2016-11-01 Thread Francois Marier
On 2016-10-23 at 18:15:15, Marco d'Itri wrote: > Control: severity -1 grave > > On Sep 15, Marco d'Itri wrote: > > > Looks like molly-guard is still buggy after #660064 and #812535. > > Can it be fixed quickly or should I add an unversioned Conflict? > Merged /usr is the default

Bug#842795: email-reminder: Fail to send email as release version cannot be detect

2016-11-01 Thread Francois Marier
On 2016-11-01 at 12:31:28, Jack.R wrote: > Not sure if this must be reported on email-reminder or lsb-release. It looks like a bug in lsb-release since it's a Python backtrace and email-reminder is written in Perl, but if there's a way to work-around this bug in email-reminder, I'm happy to do

Bug#839704: spamassassin 3.4.1-5.1 NMU

2016-10-03 Thread Francois Marier
Package: spamassassin Version: 3.4.1-5 Severity: normal Tags: patch I just uploaded 3.4.1-5.1 as an NMU to fix bug #760277. The debdiff that Peter Colberg prepared is attached here. Francois -- https://fmarier.org/ diff -Nru spamassassin-3.4.1/debian/changelog

Bug#837925: usrmerge: fails to merge with molly-guard installed

2016-09-16 Thread Francois Marier
On 2016-09-15 at 16:54:36, Marco d'Itri wrote: > On Sep 15, Jonas Smedegaard wrote: > > With molly-guard installed, usrmerge fails to do its job. > > > > molly-guard adds wrappers for commands like pm-hibernate and poweroff. > > > > The wrappers are added not using dpkg-divert

Bug#833979: O: pidgin-privacy-please -- plugin for enhanced privacy in pidgin

2016-08-11 Thread Francois Marier
On Thu, 11 Aug 2016 02:13:19 +0200 Stefan Ott wrote: > Since I am no longer using Debian as my primary operating system I am > not in a position to look after this package anymore. Is this the new official upstream repository, now that Google Code is gone?

Bug#831535: See also

2016-07-17 Thread Francois Marier
This Ubuntu answer was quite useful and pointed me in the right direction: http://askubuntu.com/questions/617955/problem-with-kde-programs-after-upgrading-to-15-04/617956 Francois -- https://fmarier.org/

Bug#831535: akregator: missing dependencies prevent akregator from fetching feeds

2016-07-16 Thread Francois Marier
Package: akregator Version: 4:16.04.2-2 Severity: grave Justification: renders package unusable The last update to akregator broke feed fetching with the following error: could not start process cannot talk to klauncher the name org.kde.klauncher5 was not provided by any .service files This

Bug#830716: tiger: 1:3.2.3-14.1 NMU

2016-07-10 Thread Francois Marier
/debian/changelog --- tiger-3.2.3/debian/changelog +++ tiger-3.2.3/debian/changelog @@ -1,3 +1,10 @@ +tiger (1:3.2.3-14.1) unstable; urgency=medium + + * Non-maintainer upload. + * Teach tiger about tracefs (Closes: #791352) + + -- Francois Marier <franc...@debian.org> Sat, 16 Jan 2016 20:41:02

Bug#830714: tiger: 1:3.2.3-14.2 NMU

2016-07-10 Thread Francois Marier
/debian/changelog --- tiger-3.2.3/debian/changelog +++ tiger-3.2.3/debian/changelog @@ -1,3 +1,10 @@ +tiger (1:3.2.3-14.2) unstable; urgency=medium + + * Non-maintainer upload. + * Teach tiger about fuse.lxcfs (Closes: #829643) + + -- Francois Marier <franc...@debian.org> Sun, 10 Jul 2016 10

Bug#830275: Test suite

2016-07-07 Thread Francois Marier
The network access are probably due to the test suite. Francois

Bug#830162: RM: confargparse -- ROM; No rdepends, low popcon.

2016-07-06 Thread Francois Marier
Package: ftp.debian.org Severity: normal The reason I initially packaged this was because it was a dependency of letsencrypt. However that package has since moved to python-configargparse so confargparse is no longer used by anything. Francois

Bug#829643: tiger: Filesystem 'fuse.lxcfs' used by 'lxcfs' is not recognised as a valid filesystem

2016-07-04 Thread Francois Marier
Package: tiger Version: 1:3.2.3-14.1 Severity: normal Tags: patch The cronjob generates the following output everytime it runs gen_mounts: --CONFIG-- [con010c] Filesystem 'fuse.lxcfs' used by 'lxcfs' is not recognised as a valid filesystem Attached is a simple patch which fixes that.

Bug#816170: False positive deleted files after upgrade from wheezy to jessie

2016-07-03 Thread Francois Marier
On 2016-04-26 at 13:50:21, Klaus Ethgen wrote: > Find attached a patch, cherry-picked from upstream, that fixes the > issue. Particular, it is c4d6d8b, 1e5e79a and b4a21a8. Which upstream repo did you pull that from? The only repo I know about is a CVS one on Sourceforge:

Bug#826021: improvements to the data processing scripts

2016-06-03 Thread Francois Marier
On 2016-06-01 at 11:07:36, Antoine Beaupré wrote: > This is a followup for bug#825982. > > The scripts mentionned in that bug report don't actually work so well, > so I have made the following patch so that the collection script > actually runs properly and that it deals with corrupted data a

Bug#814062: RFP: maybe -- run a command and see what it does to your files without actually doing it

2016-02-07 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: maybe Version : 0.3.0 Upstream Author : Philipp Emanuel Weidmann * URL : https://github.com/p-e-w/maybe * License : GPL Programming Lang: Python Description : run a command and

Bug#813809: RFP: usbguard -- basic whitelisting/blacklisting capabilities based on USB device attributes

2016-02-05 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: usbguard Version : 0.3p3 Upstream Author : Daniel Kopeček * URL : https://github.com/dkopecek/usbguard * License : GPL Programming Lang: C++ Description : basic

Bug#812545: pm-utils: Relative pm-* symlinks in /usr/sbin/ cannot be diverted by molly-guard

2016-01-24 Thread Francois Marier
Package: pm-utils Version: 1.4.1-15 Severity: normal The symlinks installed by pm-utils in /usr/sbin/ are all relative: $ ls -l /usr/sbin/pm-* /usr/sbin/pm-hibernate -> ../lib/pm-utils/bin/pm-action /usr/sbin/pm-powersave /usr/sbin/pm-suspend -> ../lib/pm-utils/bin/pm-action

Bug#811346: RFP: photobackup -- Python PhotoBackup server implementation

2016-01-17 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: photobackup Version : 0.1.2 Upstream Author : Stéphane Péchard * URL : https://github.com/PhotoBackup/server-bottle * License : GPL Programming Lang: Python Description :

Bug#791352: Uploaded a fix to DELAYED/7-day

2016-01-17 Thread Francois Marier
I just fixed this in a 3.2.3-14.1 NMU and uploaded to the 7-day delayed queue. I wanted to make sure that it gets fixed before the next Ubuntu LTS merge. Francois -- http://fmarier.org/

Bug#810482: RFP: rtags -- C/C++ client/server indexer with integration for Emacs

2016-01-08 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: rtags Version : 2.0 Upstream Author : Anders Bakken * URL : https://github.com/Andersbakken/rtags * License : GPL Programming Lang: C++ Description : C/C++ client/server indexer with

Bug#809355: [Letsencrypt-devel] Bug#809355: Bug#809355: letsencrypt: should delegate dir management (e.g. /etc/letsencrypt) to dpkg

2015-12-30 Thread Francois Marier
On 2015-12-30 at 08:30:01, Ian Campbell wrote: > FYI you've got half a dozen lines of spurious cut-and-paste-o at the > end of debian/letsencrypt.postrm (looks like you accidentally pasted a > second copy of the last few lines of the file). Indeed. It's fixed now. Thanks! Francois --

Bug#809355: [Letsencrypt-devel] Bug#809355: letsencrypt: should delegate dir management (e.g. /etc/letsencrypt) to dpkg

2015-12-29 Thread Francois Marier
On 2015-12-29 at 20:15:31, Leo Antunes wrote: > letsencrypt creates /etc/letsencrypt and /var/log/letsencrypt when first > run, instead of having dpkg manage them. This means purging the package > won't get rid of these folders. I've added a postrm script to clean up these directories. This

Bug#806532: [Letsencrypt-devel] Bug#806532: FTBFS on jessie

2015-12-27 Thread Francois Marier
On 2015-12-28 at 07:44:01, Daniel Pocock wrote: > Yes, I was in a repository with a ".git" directory > > I frequently build packages that way when I am tinkering with them so it > would be good to find a way to support that reliably. Maybe upstream > needs to test for some environment variable

Bug#806532: [Letsencrypt-devel] Bug#806532: FTBFS on jessie

2015-12-27 Thread Francois Marier
On 2015-12-06 at 09:00:06, Daniel Pocock wrote: > > Are you sure you're trying this on a clean and up-to-date jessie system? > > Yes > > I had noticed that the gnulib package was required and was not mentioned > in the build-deps. Could there be any other missing build dependency > that you

Bug#808572: giflib-tools: gitinter is no longer shipped with the package

2015-12-20 Thread Francois Marier
Package: giflib-tools Version: 5.1.1-0.2 Severity: normal It looks like the gifinter tool was removed in version 5.1 of the giflib-tools package. However, it's still in upstream CVS: http://giflib.cvs.sourceforge.net/viewvc/giflib/giflib/util/gifinter.c?view=log Was that a mistake? the

Bug#791352: [PATCH] Added tracefs (Debian bug 791352)

2015-12-05 Thread Francois Marier
--- systems/Linux/2/gen_mounts | 2 ++ 1 file changed, 2 insertions(+) diff --git a/systems/Linux/2/gen_mounts b/systems/Linux/2/gen_mounts index dd5efdf..4f8a1df 100755 --- a/systems/Linux/2/gen_mounts +++ b/systems/Linux/2/gen_mounts @@ -69,6 +69,7 @@ # Linux/2/gen_mounts - 22/11/2015 - Fix

Bug#806532: [Letsencrypt-devel] Bug#806532: FTBFS on jessie

2015-12-05 Thread Francois Marier
On 2015-11-28 at 15:57:20, Daniel Pocock wrote: > dh clean --with python2 --buildsystem=pybuild >dh_testdir -O--buildsystem=pybuild >dh_auto_clean -O--buildsystem=pybuild > I: pybuild base:170: python2.7 setup.py clean > Converting the Git log into ChangeLog format... Traceback (most

Bug#740625: tiger bug re-introduced

2015-11-22 Thread Francois Marier
While this was fixed in tiger 1:3.2.3-12.1 (see #765342), the NMU fixes were reverted in the 1:3.2.3-13 upload and so this bug is back. Francois

Bug#774387: ITP: letsencrypt -- Let's Encrypt client that can update Apache configurations

2015-10-27 Thread Francois Marier
On 2015-10-28 04:25, Jan Wagner wrote: What's the status of your work, and do you need assistance? Looks like the package live at https://github.com/letsencrypt/letsencrypt-debian That's the old package. Harlan has split the packaging to account for upstream splitting everything up in

Bug#802791: apparmor-profiles-extra: AppArmor profile prevents pidgin from starting

2015-10-23 Thread Francois Marier
Package: apparmor-profiles-extra Version: 1.5 Severity: important Tags: patch The latest version of pidgin will not start anymore if AppArmor is in enforcing mode. The fix (from bug 793152) is to add this to /etc/apparmor.d/local/usr.bin.pidgin: # Site-specific additions and overrides for

Bug#793152: For users of apparmor-profile-extra

2015-10-23 Thread Francois Marier
I filed 802791 for the AppArmor bug. Francois

Bug#802510: GNOME shell extension not compatible with recent GNOME versions

2015-10-20 Thread Francois Marier
On 2015-10-20 at 19:38:55, Michael Biebl wrote: > According to > /usr/share/gnome-shell/extensions/workr...@workrave.org/metadata.json > the latest supported version is 3.14, while the current gnome-shell > version in unstable is 3.18. Based on this upstream commit:

Bug#801617: RM: vimperator/stable -- ROM; keeps breaking with Iceweasel security updates

2015-10-12 Thread Francois Marier
Package: ftp.debian.org Severity: normal I would like to request removal of vimperator from stable since it constantly gets out of sync with new security releases of Iceweasel and breaks. In fact, it is currently broken at the moment (800508). There is also some uncertainty around the upcoming

Bug#801617: RM: vimperator/stable -- ROM; keeps breaking with Iceweasel security updates

2015-10-12 Thread Francois Marier
On 2015-10-12 at 17:37:17, Adam D. Barratt wrote: > Removals from {,old}stable are handled by the Release Team. Interesting, I guess there's a bug in reportbug :) > Should the package also be removed from oldstable? Yes, it's definitely broken in oldstable too (and has been for a long time).

Bug#801473: RM: vimperator -- ROM; keeps breaking with Iceweasel security updates

2015-10-10 Thread Francois Marier
Package: ftp.debian.org Severity: normal I would like to request removal of vimperator from unstable since it constantly gets out of sync with new security releases of Iceweasel and breaks (e.g. 800508). There is also some uncertainty around the upcoming add-on signing enforcement. The

Bug#797477: No longer marked as "forwarded upstream"

2015-09-20 Thread Francois Marier
Removing the "forwarded" flag since upstream are wanting a much more complicated change (and are not actually working on it, it seems): https://lists.gnu.org/archive/html/emacs-devel/2015-05/msg00110.html In Debian, we can assume that GnuTLS will be present and skip the whole HTTP failback.

Bug#798069: libhdhomerun1: ABI changes without soname changes

2015-09-05 Thread Francois Marier
On 2015-09-05 at 08:46:53, Christian Marillat wrote: > hdhomerun_discover_find_devices_custom() function has been renamed to > hdhomerun_discover_find_devices_custom_v2() in 20150826-1 Do you know whether or not hdhomerun_discover_find_devices_custom() is used in MythTV? Upstream claims that

Bug#797477: emacs24: emacs should use HTTPS with the default elpa.gnu.org package repo

2015-08-30 Thread Francois Marier
this change upstream too, but it would be great if Debian users could be protected before emacs25. Francois From 8b194e2ce9850c40f75d8a79aa6fc952971710b7 Mon Sep 17 00:00:00 2001 From: Francois Marier franc...@debian.org Date: Sun, 30 Aug 2015 11:31:21 -0700 Subject: Use HTTPS when talking

Bug#793502: workrave: Workrave doesn't show icon in system tray of kde plasma 5

2015-08-22 Thread Francois Marier
On 2015-07-24 at 12:25:47, Michael Meier wrote: workrave needs to be updated to show an icon in the new kde plasma 5 system tray. as a lot of older applications it can't show them there anymore. I don't know anything about the KDE Plasma 5 system tray. Is that something packaging-related

Bug#796599: openssh-client: ssh -G no longer returns illegal option (6.0) or unknown option (6.7)

2015-08-22 Thread Francois Marier
Package: openssh-client Version: 1:6.9p1-1 Severity: critical Tags: security Justification: root security hole Sorry for the alarmist bug report. Hopefully this is a false positive and it can be reassigned to chkrootkit, but just in case... The ssh -G test [1] for Linux output has changed:

Bug#794864: planetfilter ftbfs when python3.5 becomes a supported python version

2015-08-07 Thread Francois Marier
On 2015-08-07 at 13:12:20, Matthias Klose wrote: Replaces all this: python3 | python3-all | python3-dev | python3-all-dev with just python3-all. No idea what you want to achieve with these alternatives ... I copied that from somewhere else, but I can't find it anymore. Just to be clear,

Bug#794624: RFP: web-mode -- web template editing mode for emacs

2015-08-04 Thread Francois Marier
Package: wnpp Severity: wishlist * Package name: web-mode Version : 12 Upstream Author : François-Xavier Bois fxb...@gmail.com * URL : http://web-mode.org/ * License : GPL Programming Lang: emacs lisp Description : web template editing mode for emacs

  1   2   3   4   5   6   7   8   9   10   >