Bug#969291: RFS: sane-backends/1.0.31-1~experimental1 [RC] -- API library for scanners [transitional package]

2020-09-18 Thread Raphael Hertzog
Hi, On Thu, 10 Sep 2020, Jörg Frings-Fürst wrote: > > I'd like to see this new upstream release in sid so I'm taking a look > > but I'm quite surprised by many things. And actually I want this fix > > in the package too: > > https://gitlab.com/sane-project/backends/-/merge_requests/502 > > I

Bug#969291: RFS: sane-backends/1.0.31-1~experimental1 [RC] -- API library for scanners [transitional package]

2020-09-18 Thread Raphael Hertzog
Hi, On Sat, 05 Sep 2020, Jörg Frings-Fürst wrote: > > First of all, why is this packaging git repository not hosted on > > salsa.debian.org? I can create you a repository in the "debian" > > namespace and grant you commit rights on this repository. It > > would make it easier for random DD to

Bug#969291: RFS: sane-backends/1.0.31-1~experimental1 [RC] -- API library for scanners [transitional package]

2020-09-04 Thread Raphael Hertzog
Hello, I'd like to see this new upstream release in sid so I'm taking a look but I'm quite surprised by many things. And actually I want this fix in the package too: https://gitlab.com/sane-project/backends/-/merge_requests/502 First of all, why is this packaging git repository not hosted on

Bug#969458: perl crash in eval command trying a failing require statement

2020-09-04 Thread Raphael Hertzog
On Thu, 03 Sep 2020, Niko Tyni wrote: > > The $name tried is "Kali" and we don't ship any Dpkg::Vendor::Kali. The > > code should fallback to Dpkg::Vendor::Debian and this works a few times > > but after multiples calls, at some point it no longer works and the > > require statement in the eval

Bug#969320: aflplusplus: please make the build reproducible

2020-08-31 Thread Raphael Hertzog
Hi, On Mon, 31 Aug 2020, Chris Lamb wrote: > Whilst working on the Reproducible Builds effort [0] we noticed that > aflplusplus could not be built reproducibly. The reprotest CI job fails too and seems to show other issues: https://salsa.debian.org/pkg-security-team/aflplusplus/-/jobs/964936/raw

Bug#697781: ITP

2020-08-07 Thread Raphael Hertzog
Control: retitle -1 ITP: hamster-time-tracker -- a GNOME time tracker Control: owner -1 ! I'm going to reintroduce the hamster time tracker into Debian. I was using hamster-applet up to today but I just realized that it was dropped from Debian a long time ago... I will use

Bug#967086: Empty pages when authenticated

2020-08-06 Thread Raphael Hertzog
On Thu, 06 Aug 2020, Stéphane Glondu wrote: > Le 05/08/2020 à 14:36, Raphael Hertzog a écrit : > >> tracker.debian.org does not seem to respond or responds always empty > >> pages (no error) when I use a client certificate. > > > > I don't have the issue with m

Bug#967086: Empty pages when authenticated

2020-08-05 Thread Raphael Hertzog
Hi, On Tue, 04 Aug 2020, Stéphane Glondu wrote: > tracker.debian.org does not seem to respond or responds always empty > pages (no error) when I use a client certificate. I don't have the issue with my own certificate. I see this in the error log: [Wed Aug 05 11:17:05.798925 2020] [ssl:error]

Bug#964399: Should ganglia be removed?

2020-07-28 Thread Raphael Hertzog
Hi, On Tue, 07 Jul 2020, Marcos Fouces wrote: > I also done some work on ganglia-web and ganglia-linux-modules packages > (also unpublished). > > I believe that it is still a good piece of software that deserve its > place on Debian so i would like to step up as uploader (co-uploaders >

Bug#966368: lintian gets stuck when run by sbuild within rebuildd

2020-07-27 Thread Raphael Hertzog
Hi, On Mon, 27 Jul 2020, Chris Lamb wrote: > > In Kali, our build daemons run "rebuildd" with a build script that calls > > sbuild --run-lintian. Since lintian 2.85 (I believe 2.84.0 is not affected), > > the build process get stuck at the point when lintian is run. I see two > > lintian > >

Bug#959963: Updating qterminal to version 0.15.0

2020-07-24 Thread Raphael Hertzog
Hi, is there any chance that one of you can take care of updating qterminal to the latest upstream version? Version 0.15 is available and it seems to fix a bunch of issues for many persons. It's our main terminal in Kali and we would like to see the latest version in Debian.

Bug#966022: lintian: False positive on missing-depends-on-sensible-utils with commands like i3-sensible-pager

2020-07-22 Thread Raphael Hertzog
Hello, I just want to point out that the search for the "sensible-*" commands might be a bit too broad. It also finds the strings in /usr/share/lintian/overrides/i3-wm-gaps... Same issue in i3-wm in Debian: https://lintian.debian.org/sources/i3-wm/4.17.1-1.html Cheers, On Wed, 22 Jul 2020,

Bug#963887: UDD: 'duck' importer broken since 2020-05-25

2020-06-29 Thread Raphael Hertzog
On Mon, 29 Jun 2020, Baptiste BEAUPLAT wrote: > > Indeed, creating a dedicated service for this does not seem a good idea. > > I would love to have this feature integrated directly with > distro-tracker. However, I'm wondering about the load that would case > for the service. Network request do

Bug#963887: UDD: 'duck' importer broken since 2020-05-25

2020-06-29 Thread Raphael Hertzog
Hi, On Sun, 28 Jun 2020, Bastian Blank wrote: > > Baptiste (CCed) volunteered to write it over again, but for now there is > > no clear timeline as for when the new project will be started. > > Maybe you could add that to vcswatch? or distro-tracker? Indeed, creating a dedicated service for

Bug#962862: debci: XSS in web interface

2020-06-24 Thread Raphael Hertzog
Hi, On Mon, 15 Jun 2020, Sebastien Delafond wrote: > See for instance the following URL: > > > https://ci.debian.net/user/debci/jobs?package=abc;>alert(document.domain) The issue is present in multiple parameters and even in the URL itself: XSS Param URL:

Bug#963020: impacket breaks smbmap autopkgtest: No module named 'pkg_resources'

2020-06-18 Thread Raphael Hertzog
Hi, On Thu, 18 Jun 2020, Raphael Hertzog wrote: > Actually your fix does not work because pkg_resources is not documented in > setup.py or requirements.txt and thus it will not magically appear in > ${python3:Depends} just by adding it in Build-Depends. > > I opened htt

Bug#963020: impacket breaks smbmap autopkgtest: No module named 'pkg_resources'

2020-06-18 Thread Raphael Hertzog
On Wed, 17 Jun 2020, Emmanuel Arias wrote: > I've just pushed to salsa the fix, could anyone review it and sponsor > it, please? Actually your fix does not work because pkg_resources is not documented in setup.py or requirements.txt and thus it will not magically appear in ${python3:Depends} just

Bug#963020: impacket breaks smbmap autopkgtest: No module named 'pkg_resources'

2020-06-18 Thread Raphael Hertzog
Hi, On Wed, 17 Jun 2020, Emmanuel Arias wrote: > I've just pushed to salsa the fix, could anyone review it and sponsor > it, please? I'll take care of it right now. Cheers, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook: https://debian-handbook.info/get/ ⠈⠳⣄

Bug#962042: smuxi-frontend-gnome: clicking on a link does not open it in the web browser

2020-06-15 Thread Raphael Hertzog
Hi, On Mon, 15 Jun 2020, Mirco Bauer wrote: > I can't reproduce this issue on buster with Google Chrome as the default > browser set in GNOME preferences. I have firefox as default browser. > > For opening any links Smuxi relies on Mono's > System.Diagnostics.Process.Start() implementation

Bug#830572: UNRELEASED entry and new upstream version

2020-06-11 Thread Raphael Hertzog
On Wed, 10 Jun 2020, Guido Günther wrote: > Happy to apply a patch. I'm using > > ``` > [import-orig] > # Automatically forward the changelog after importing a new upstream version > postimport = gbp dch -S -a --debian-branch=$GBP_BRANCH && git commit --amend > -C@{0} debian/changelog > ``` > >

Bug#830572: UNRELEASED entry and new upstream version

2020-06-10 Thread Raphael Hertzog
Hi, I was about to report that "gbp dch" was not updating the version number in an UNRELEASED entry even after you have merged a new upstream version. But I found this (broader) bug report, covering this and more. It would be really nice to get the changes documented in this bug report...

Bug#962000: Duplicated news for php-horde-image

2020-06-02 Thread Raphael Hertzog
Control: forcemerge 884933 -1 On Mon, 01 Jun 2020, s3v wrote: > I have noticed that tracker.debian.org reports duplicated news for > php-horde-image package [1] and others packages in php-horde ecosystem > (php-horde-data, php-horde-cache, php-horde-crypt, et al.). This was already documented in

Bug#960926: developers-reference: updating the packages copyright notices

2020-05-18 Thread Raphael Hertzog
Hi, On Mon, 18 May 2020, Holger Levsen wrote: > I'd like to update the copyright statements in d/changelog and and > source/index.rst and bring them in sync as well. Thus I have prepared > the following diff. > > I'd appreciate a quick review and possible corrections from you! Fine for me.

Bug#960890: python-django: New upstream 3.x release

2020-05-18 Thread Raphael Hertzog
Hi, On Sun, 17 May 2020, Chris Lamb wrote: > This is a bug to track the progress of uploading Django 3.x to > unstable. Hum, this is a long term goal right? Because the next LTS in 3.x is 3.2 and upstream has not yet released 3.1 and we will get 3.2 only in 2021 AFAIK. And IIRC our goal was to

Bug#959923: dh-linktree: "replace" fails on files in linked directories

2020-05-18 Thread Raphael Hertzog
Hi, On Thu, 07 May 2020, Norbert Preining wrote: > When dh-linktree replace is called with a file in a "directory" which is > a symlink, dh-linktree dies because dpkg-query fails: > > dpkg-query: no path found matching pattern > /usr/share/javascript/jquery/jquery.js > dh_linktree: error: dpkg

Bug#959931: qa.debian.org: udd.debian.org/dmd no more able to display HTML report

2020-05-13 Thread Raphael Hertzog
Hi, On Wed, 13 May 2020, Xavier wrote: > can someone take a look to this issue ? It becomes difficult to manage > JS Team package without having a view on what to do I can suggest an alternative which is working fine: https://tracker.debian.org/teams/debian-javascript/ :-) Cheers, --

Bug#938438: scap-security-guide: Python2 removal in sid/bullseye

2020-05-11 Thread Raphael Hertzog
Hi, On Fri, 08 May 2020, Jeremy Bicha wrote: > Maintainers, please indicate whether you are working on a fix or else > this package will be removed from Debian Unstable soon. (You can > always reintroduce the package if you remove the Python2 > dependencies.) I just looked at the upstream source

Bug#936206: binplist: Python2 removal in sid/bullseye

2020-05-11 Thread Raphael Hertzog
Hi, On Fri, 08 May 2020, Moritz Mühlenhoff wrote: > > Your package either build-depends, depends on Python2, or uses Python2 > > in the autopkg tests. Please stop using Python2, and fix this issue > > by one of the following actions. > > https://github.com/google/binplist/issues/6 is without

Bug#922075: npm: segfault during extract on i386

2020-04-29 Thread Raphael Hertzog
On Tue, 31 Mar 2020, Christian Walther wrote: > Any news on this? I am seeing the same crash (same gdb backtrace) with > the nodejs 10.15.2~dfsg-2 and npm 5.8.0+ds6-4 provided by Debian 10 i386 > (on a virtual machine) while using "npm install" on an internal package. We also have experienced

Bug#876643: Another case of conflicting binaries allowed in the archive

2020-04-22 Thread Raphael Hertzog
Control: severity -1 important While syncing my Debian mirror with reprepro in the Kali archive, I got a failure due to a file conflict: > File "pool/main/z/zeroc-ice/libzeroc-ice-dev_3.7.3-1_arm64.deb" is already > registered with > different checksums! > md5 expected:

Bug#819136: Bugs included in #819136 patches

2020-04-11 Thread Raphael Hertzog
Hello, On Fri, 09 Jun 2017, Elliott Mitchell wrote: > Guess I should give at least a partial list of the extra bugfixes > included in the #819136 patch series: I was looking at bugs with patchs and saw this one. I believe most of the patches are obsolete, the only thing that should remain is the

Bug#956226: linux: dh-thin-pool module missing in md-modules udeb, d-i unable to remove thinly provisioned logical volume

2020-04-08 Thread Raphael Hertzog
Source: linux Version: 4.19.67-2+deb10u2 Severity: normal Tags: d-i patch The dm-thin-pool module is required when you want to run d-i on a machine which contains thinly provisioned logical volumes. Otherwise d-i is unable to remove them and you see messages like this from partman-lvm: >

Bug#955474: FTBFS: fatal error: stropts.h: No such file or directory

2020-04-01 Thread Raphael Hertzog
Control: retitle 954582 FTBFS: fatal error: stropts.h: No such file or directory Control: forcemerge 954582 -1 I was mislead by the title of the other RC bug, it looks like both are reporting the same underlying issue. The proper solution seems to be to rebuild python 3.8 against glibc 2.30 and

Bug#937521: pyrit: Python2 removal in sid/bullseye

2020-03-30 Thread Raphael Hertzog
Hi, On Sun, 29 Mar 2020, Sandro Tosi wrote: > so maybe it's time to drop pyrit and it's only reverse dependency > wifite? Ack for pyrit. I requested the removal of the package from unstable. However, wifite works without pyrit. I uploaded a new version dropping the build-dependency and the

Bug#955339: tracker.debian.org: improper bounce-process

2020-03-30 Thread Raphael Hertzog
Hello Tom, On Mon, 30 Mar 2020, Thomas Dickey wrote: >* yesterday, I received multiple messages from ow...@tracker.debian.org > notifying me that my subscription was cancelled. I saw them. >* on the next activity (a followup for byacc) I _immediately_ received > again >

Bug#955213: Version information on tracker.d.o in many cases wrong

2020-03-30 Thread Raphael Hertzog
Control: forcemerge 901500 -1 On Sun, 29 Mar 2020, Daniel Leidert wrote: > Today I found several packages for which the version and release information > is > completely wrong. rmadison and the tracker report different releases for the > same versions. Examples: > > ruby-capistrano-colors >

Bug#922533: Review of proposed move of /var/log/account to /var/account

2020-03-28 Thread Raphael Hertzog
Hi, On Wed, 18 Mar 2020, Marcos Fouces wrote: > Any DD available for review and upload this new release. Uploaded! Cheers, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook: https://debian-handbook.info/get/ ⠈⠳⣄ Debian Long Term Support: https://deb.li/LTS

Bug#944553: midori deletes my files

2020-03-26 Thread Raphael Hertzog
Control: severity -1 important On Tue, 18 Feb 2020, Sergio Durigan Junior wrote: > Thanks for the report. > > It's not clear from your description whether tmpa_crtoef.htm is the > only file that triggers this behaviour, or if this happens with any file > when you try opening it with Midori. > >

Bug#952733: dnsrecon fails in Google Search enumeration due to incorrect urllib functions being used

2020-03-03 Thread Raphael Hertzog
On Fri, 28 Feb 2020, Jonas Andradas wrote: > new updates performed along the day fixed the issue... sorry for reporting it > too soon! What updates? It seems weird that this issue would fix itself. Cheers, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook:

Bug#939641: dnsrecon: Python2 removal in sid/bullseye

2020-02-26 Thread Raphael Hertzog
Control: forwarded -1 https://github.com/darkoperator/dnsrecon/issues/115 On Tue, 25 Feb 2020, Scott Kitterman wrote: > There is evidence in the upstream commit history [1] that this will work with > either python2 or python3, so I sould appreciate it if you could see if > switching to python3

Bug#946519: iptables fails to update rules from fwbuilder

2020-02-12 Thread Raphael Hertzog
Hello, On Mon, 20 Jan 2020, Arturo Borrero Gonzalez wrote: > >After upgrading to buster from strech, the iptables defined in fwbuilder > > don't works when changed: > > iall I get is a message "iptables: Chain already exists" for each rule and > > they don't work. > > > >Moreover as I

Bug#951120: hydra: Non-free licence exception

2020-02-12 Thread Raphael Hertzog
Control: forwarded -1 https://github.com/vanhauser-thc/thc-hydra/issues/497 On Tue, 11 Feb 2020, Dominik George wrote: > The licence of hydra states: Actually the LICENSE file does not contain that sentence. It's only in the README and it has been added 3 years ago > The additional

Bug#947847: please install systemd-sysusers using update-alternatives

2020-01-29 Thread Raphael Hertzog
On Wed, 29 Jan 2020, Thomas Goirand wrote: > echo 'u radvd - "radvd daemon"' | \ >systemd-sysusers --replace=/usr/lib/sysusers.d/radvd.conf Does opensysusers support this use case? If not, you just provided a good reason why it's not a good idea to use an alternative for systemd-sysusers. >

Bug#947847: please install systemd-sysusers using update-alternatives

2020-01-29 Thread Raphael Hertzog
On Tue, 28 Jan 2020, Thomas Goirand wrote: > This is exactly what should be avoided. It's perfectly fine to try to > use opensysusers with systemd if one wants. In fact, that's exactly the > best way we could do to be able to test it. Also, dpkg-divert is really > ugly, and something you use as

Bug#939260: Ready for Python 3

2020-01-20 Thread Raphael Hertzog
FTR, upstream just notified me that the latest version available on GitHub is now ready for Python 3: https://github.com/websploit/websploit Cheers, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook: https://debian-handbook.info/get/ ⠈⠳⣄ Debian Long Term Support:

Bug#948257: Bug#948350: depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '[...]/lib/modules/[kernelversion]/modules.builtin.bin'

2020-01-16 Thread Raphael Hertzog
Hello, On Tue, 07 Jan 2020, Marco d'Itri wrote: > #948257 In https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948257#105, Ben is wondering whether the fix should not be done in kmod since the ERROR displayed is due to a Debian-specific patch that you applied

Bug#936243: brutespray: Python2 removal in sid/bullseye

2020-01-14 Thread Raphael Hertzog
On Fri, 10 Jan 2020, Emmanuel Arias wrote: > I was working on python2 support remove. I prepare a NMU in two MR: > https://salsa.debian.org/pkg-security-team/brutespray/merge_requests/1 > https://salsa.debian.org/pkg-security-team/brutespray/merge_requests/2 > > Please, consider apply it. Thanks

Bug#842565: buildd.debian.org: XDG_RUNTIME_DIR is set but directory does not seem to exist

2020-01-04 Thread Raphael Hertzog
Control: affects -1 schroot Hi, On Sun, 30 Oct 2016, Hilko Bengen wrote: > it seems that at least on the i386 and amd64 buildds, XDG_RUNTIME_DIR is > set to a nonexisting directory, /run/user/2952. I have been bitten by this too and chatted with Aurélien Jarno on #debian-buildd and it seems

Bug#948009: blhc: Don't scan dwz invocations seen with DH_VERBOSE=true

2020-01-04 Thread Raphael Hertzog
Hi, On Sat, 04 Jan 2020, Simon Ruderich wrote: > On Fri, Jan 03, 2020 at 10:44:10AM +0100, Raphaël Hertzog wrote: > > https://salsa.debian.org/pkg-security-team/aflplusplus/-/jobs/481494/raw > > Hello, > > could you please provide me with the full raw (= text-only) build > log so I can

Bug#934207: [Pkg-javascript-devel] Bug#934207: new upstream (12.8.0)

2019-12-26 Thread Raphael Hertzog
On Thu, 8 Aug 2019 10:08:52 +0200 =?UTF-8?B?SsOpcsOpbXkgTGFs?= wrote: > Yes, take for granted that if you're thinking about upgrading that package, > i've already started doing it ;) Thanks for your work on nodejs! What are your plans to upload nodejs 12.x to unstable? Cheers, PS: version

Bug#939260: websploit: Python2 removal in sid/bullseye

2019-12-26 Thread Raphael Hertzog
On Mon, 16 Dec 2019 14:28:33 +0100 Raphael Hertzog wrote: > Great. Looking forward to it. Do you have any idea how much time you need > to complete this Python 3 port of websploit? On the 21th, I got a private reply saying that he might need 20 days to complete the Python 3 port.

Bug#947387: [Python-modules-team] Bug#947387: python3-pcapy: missing Breaks+Replaces: python-pcapy

2019-12-26 Thread Raphael Hertzog
On Wed, 25 Dec 2019, Emmanuel Arias wrote: > Raphaël, please could you review my patch? Reviewed and uploaded. Cheers, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook: https://debian-handbook.info/get/ ⠈⠳⣄ Debian Long Term Support: https://deb.li/LTS

Bug#945723: Upstream progress on python 3 port

2019-12-26 Thread Raphael Hertzog
Hello, upstream seems to be close to release a Python 3 version, current WIP is in https://github.com/epinna/weevely3/tree/Debian-master according to https://github.com/epinna/weevely3/pull/119#issuecomment-568770367 Sending this mail to reset the auto-rm clock, hoping that Samuel will upload a

Bug#897137: live-build: man -k and apropos don't work in live system

2019-12-19 Thread Raphael Hertzog
Control: tag -1 - patch On Sat, 28 Apr 2018, Robert Munyer wrote: > The cause is the command "rm -rf /var/cache/man/*" in > "/usr/share/live/build/hooks/normal/0190-remove-temporary-files.hook.chroot". > > You can prevent the problem by doing the following before "lb config": While this fixes

Bug#945131: dpkg: implement a way to wait to detect whether dpkg is running

2019-12-18 Thread Raphael Hertzog
On Wed, 18 Dec 2019, Guillem Jover wrote: > > We could add hundreds of path-based triggers, one for each binary that we > > reference in our desktop files but we would likely miss any path > > change... and it would be a bit tedious to maintain. > > I checked the kali package, and the solutions

Bug#939260: websploit: Python2 removal in sid/bullseye

2019-12-16 Thread Raphael Hertzog
Hello, On Tue, 10 Dec 2019, 0X0Ptim0Us wrote: > Got it, thank you. I will work on it Great. Looking forward to it. Do you have any idea how much time you need to complete this Python 3 port of websploit? Regards, -- ⢀⣴⠾⠻⢶⣦⠀ Raphaël Hertzog ⣾⠁⢠⠒⠀⣿⡁ ⢿⡄⠘⠷⠚⠋The Debian Handbook:

Bug#946460: tcmu: Fix for 32 bit builds

2019-12-11 Thread Raphael Hertzog
Hi, On Mon, 09 Dec 2019, James Page wrote: > In Ubuntu, the attached patch was applied to achieve the following: > > * Resolve issues with compilation on 32 bit architectures: > - d/p/32bit-size_t-cast.patch: Ensure same type comparison > avoiding compilation error. Thanks, merged

Bug#939260: websploit: Python2 removal in sid/bullseye

2019-11-28 Thread Raphael Hertzog
Control: forwarded -1 https://github.com/websploit/websploit/issues/24 On Mon, 02 Sep 2019, Stefano Rivera wrote: > Python2 becomes end-of-live upstream, and Debian aims to remove > Python2 from the distribution, as discussed in > https://lists.debian.org/debian-python/2019/07/msg00080.html I

Bug#895787: Fwd: RFS: pcapy/0.11.3-1 [ITA]

2019-11-26 Thread Raphael Hertzog
Hello, On Mon, 25 Nov 2019, Emmanuel Arias wrote: > Yes, I will need sponsorship please :) I sponsored the upload but the package was not 100% ready so I had to fix a few things: - it installed documentation in /usr/share/doc/pcapy/ in addition to /usr/share/doc/python3-pcapy/ - there was a

Bug#945131: dpkg: implement a way to wait to detect whether dpkg is running

2019-11-23 Thread Raphael Hertzog
On Fri, 22 Nov 2019, Guillem Jover wrote: > That still does not explain why this needs to be done outside the dpkg's > execution context, though? I don't know any point in dpkg's execution context where we are sure that we will not install/remove other packages later on. > Triggers right now

Bug#943525: Namespaces for Lintian Tags

2019-11-22 Thread Raphael Hertzog
Hi, On Wed, 20 Nov 2019, Felix Lechner wrote: > There are many motivations: Among those motivations, which one is the one that triggered this process and which one are there as "additional benefits" that you could identify to justify the change? > 1. Shortens tag names. I don't see that as a

Bug#945206: tracker.debian.org: Broken binaries link in glibc page

2019-11-22 Thread Raphael Hertzog
Hello, On Thu, 21 Nov 2019, Alexandros Prekates wrote: > Visiting https://tracker.debian.org/pkg/glibc > i noticed many dead links in the binaries section > of the page. Those are binary packages that the glibc source package can build but that it only builds on non-release architectures... so

Bug#945131: dpkg: implement a way to wait to detect whether dpkg is running

2019-11-20 Thread Raphael Hertzog
Hi, On Wed, 20 Nov 2019, Guillem Jover wrote: > > To achieve this in a more elegant way, could you possibly implement some > > "dpkg --is-running" test ? And/or maybe "dpkg --wait-lock-release" or > > something similar ? > > I'm not sure I understand why this is not done say via a trigger >

Bug#943953: linux: DKMS module builds are failing on arm64 due to lack of armhf cross-compiler

2019-11-04 Thread Raphael Hertzog
Control: tags -1 - moreinfo Hi, On Sat, 02 Nov 2019, Ben Hutchings wrote: > I already communicated this via IRC, but I thought it should be logged > in the BTS too: I have a tentative fix for this in < > https://salsa.debian.org/benh/linux.git> branch bug943953. I don't > have an arm64 system

Bug#943709: Pyside2 package dependencies do not reflect Python module dependencies

2019-10-29 Thread Raphael Hertzog
Hi, On Mon, 28 Oct 2019, Mark Weyer wrote: > Package: python3-pyside2.qtgui > Version: 5.11.2-3+rpi1 > Severity: normal > > This bug is reported against an example package but is more general. Thus it > pertains to more binary packages built from the same source package pyside2 Can you be a bit

Bug#942126: gvfs-fuse: /run/user/ID/gvfs/ empty after upgrade

2019-10-28 Thread Raphael Hertzog
Control: severity -1 serious Hi, On Tue, 22 Oct 2019, Cesare Leonardi wrote: > Ok, I confirm that replacing fuse with fuse3, as reported by Bert, make > gvfs-fuse works as expected, with /run/user/ID/gvfs/ populated again. > So please, consider to tighten gvfs-fuse dependencies on fuse3. I was

Bug#938797: volatility: Python2 removal in sid/bullseye

2019-10-19 Thread Raphael Hertzog
Control: tag -1 + fixed-upstream On Fri, 30 Aug 2019, Matthias Klose wrote: > Python2 becomes end-of-live upstream, and Debian aims to remove > Python2 from the distribution, as discussed in > https://lists.debian.org/debian-python/2019/07/msg00080.html There's a volatility 3.0 that works with

Bug#927135: src:rekall: Please update to python3 version

2019-10-18 Thread Raphael Hertzog
Hi, On Fri, 18 Oct 2019, Moritz Mühlenhoff wrote: > > I started having a look at packaging the new upstream release of > > rekall, to support python 3 (mostly because rekall is a r-dep of some > > of the packages i maintain). For now it looks like the most immediate > > need is to get aff4 ported

Bug#942487: [Pkg-rust-maintainers] Bug#942487: Bug#942487: Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-18 Thread Raphael Hertzog
On Thu, 17 Oct 2019, Ximin Luo wrote: > Who is using reprepro to archive Debian Rust packages? That's the first Anybody who is mirroring Debian unstable with reprepro right now. I have no special interest in rust, but I do maintain a debian derivative that we build with reprepro merging debian

Bug#942487: [Pkg-rust-maintainers] Bug#942487: Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-17 Thread Raphael Hertzog
Hello Ximin, On Thu, 17 Oct 2019, Ximin Luo wrote: > >> Do you have some concrete suggestions on how to improve the tool to reduce > >> this "abuse"? > > > > Yes, I gave you one. > > It doesn't work. Look, I'm not a cargo/rust expert, I won't design the tool for you but I implemented

Bug#942487: [Pkg-rust-maintainers] Bug#942487: Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-17 Thread Raphael Hertzog
On Thu, 17 Oct 2019, Ximin Luo wrote: > Can you please explain why 256 KB provides field is "abuse"? Because that's the amount of metadata required for 250 common packages. > Do you have some concrete suggestions on how to improve the tool to reduce > this "abuse"? Yes, I gave you one. > BTW,

Bug#942487: [Pkg-rust-maintainers] Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-17 Thread Raphael Hertzog
Hi, On Thu, 17 Oct 2019, Sylvestre Ledru wrote: > I will see how to add a lintian check to block that from happening again. FWIW, I already filed #942493 against lintian this morning. Cheers, -- Raphaël Hertzog ◈ Debian Developer Support Debian LTS:

Bug#942487: [Pkg-rust-maintainers] Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-17 Thread Raphael Hertzog
On Thu, 17 Oct 2019, Ximin Luo wrote: > Control: tags -1 + wontfix This is clearly not acceptable. You can't ignore problems like this one. I saw you already broke debian-installer once with the former packages that overflowed the 16K limit of cdebootstrap. Now it's the turn of reprepro and this

Bug#942487: rust-web-sys: Provides header is more than 256K long and it breaks reprepro...

2019-10-17 Thread Raphael Hertzog
On Thu, 17 Oct 2019, Raphaël Hertzog wrote: > For this reason, I'm going to NMU the package and disable/reduce the Provides > field until you find a reasonable solution. Uploaded rust-web-sys_0.3.28-1.1_source.changes. It's still 150K but should make reprepro happy. I believe it's unreasonable

Bug#936730: [Python-modules-team] Bug#936730: impacket: Python2 removal in sid/bullseye

2019-10-17 Thread Raphael Hertzog
Hi, On Wed, 16 Oct 2019, Emmanuel Arias wrote: > Hello! Raphael > > I've write a comments on mentors. I don't know if you coulld see it No, I didn't get any mail through mentors. Anyway, reviewed and uploaded. Cheers, -- Raphaël Hertzog ◈ Debian Developer Support Debian LTS:

Bug#942104: release.debian.org: Will fail if "Suite" field is missing

2019-10-10 Thread Raphael Hertzog
Control: tag -1 + patch On Thu, 10 Oct 2019, Ansgar wrote: > https://wiki.debian.org/DebianRepository/Format#A.22Release.22_files > says one of Suite and Codename is required. Codename itself is not required. Ok. > I wouldn't be surprised if many tools just use one and assume it always >

Bug#939626: Upstream

2019-10-04 Thread Raphael Hertzog
Control: tag -1 fixed-upstream On Wed, 11 Sep 2019 14:00:54 +0200 =?utf-8?Q?S=C3=A9bastien?= Delafond wrote: > Upstream indicates that: > > We are working actively on that subject. So the next release of > centreon-broker won't need qt4 nor qt5. Qt will be completely removed > from it.

Bug#936730: [Python-modules-team] Bug#936730: impacket: Python2 removal in sid/bullseye

2019-10-03 Thread Raphael Hertzog
Hello, On Tue, 01 Oct 2019, Emmanuel Arias wrote: > I've just push to salsa and mentors > (https://mentors.debian.net/package/python-ldapdomaindump) > ldapdomaindump, maybe you can sponsor it :) thanks I can sponsor it but first I'd like you to make some changes: 1/ fix the Vcs-Git and

Bug#875190: [shiboken] Future Qt4 removal from Buster

2019-10-01 Thread Raphael Hertzog
On Tue, 01 Oct 2019, Didier 'OdyX' Raboud wrote: > > There are no reverse dependencies of src:shiboken in unstable and it has > > been replaced by src:pyside2, let's remove from the archive? > > As maintainer: agreed! Can you file the RM request then? Thank you. -- Raphaël Hertzog ◈ Debian

Bug#936730: [Python-modules-team] Bug#936730: impacket: Python2 removal in sid/bullseye

2019-09-30 Thread Raphael Hertzog
El dom., 29 de sep. de 2019 a la(s) 10:42, Raphael Hertzog > (hert...@debian.org) escribió: > > > > Hi, > > > > On Fri, 27 Sep 2019, Emmanuel Arias wrote: > > > I've just push to salsa the last changes. > > > I will need sponsorship to upload it. > &

Bug#936730: [Python-modules-team] Bug#936730: impacket: Python2 removal in sid/bullseye

2019-09-29 Thread Raphael Hertzog
Hi, On Fri, 27 Sep 2019, Emmanuel Arias wrote: > I've just push to salsa the last changes. > I will need sponsorship to upload it. I took care of it. But I reverted the removal of python-impacket for now, it still has reverse dependencies in Debian (and even more in Kali). I had to cleanup a

Bug#936730: impacket: Python2 removal in sid/bullseye

2019-09-26 Thread Raphael Hertzog
control: forwarded -1 https://github.com/SecureAuthCorp/impacket/issues/663 control: tag -1 + fixed-upstream Hi, On Fri, 30 Aug 2019, Matthias Klose wrote: > Python2 becomes end-of-live upstream, and Debian aims to remove > Python2 from the distribution, as discussed in >

Bug#940699: scapy: Please drop the "Breaks" on python-scapy or restore the python 2 package

2019-09-19 Thread Raphael Hertzog
Hi, On Thu, 19 Sep 2019, Iain R. Learmonth wrote: > I've prepared an upload that drops the Breaks: from the package. I am > not using the Python 2 version of the package, nor do I really want to > have to test that version. If you wanted to adopt the package, > especially as it has more rdeps in

Bug#934691: rekall: maintainer address bounces

2019-09-11 Thread Raphael Hertzog
Control: tag -1 + pending On Tue, 13 Aug 2019, peter green wrote: > While sending https://lists.debian.org/debian-python/2019/08/msg00072.html I > got > > forensics-de...@lists.alioth.debian.org > (generated fromrek...@packages.debian.org) > host alioth-lists-mx.debian.net

Bug#927135: src:rekall: Please update to python3 version

2019-08-26 Thread Raphael Hertzog
Hi, On Sun, 25 Aug 2019, Scott Kitterman wrote: > If you have lost interest in the package, please let me know so I can ask to > have it removed. Don't remove rekall please. There's a new upstream release with Python 3 support. We will get to it eventually. Cheers, -- Raphaël Hertzog ◈ Debian

Bug#935278: postrm does not remove user/group on purge

2019-08-21 Thread Raphael Hertzog
Hello, On Wed, 21 Aug 2019, INetSim wrote: > Package: inetsim > Version: 1.2.7+dfsg.1-1 > Severity: normal > > The postrm script does not remove user/group inetsim on purge. That's actually a common practice, in particular when the user/group tends to own data files that might survive the

Bug#934483: virtualbox-guest-dkms: Doesn't build with latest kernel in unstable 5.2.0-2-686-pae

2019-08-19 Thread Raphael Hertzog
On Sun, 11 Aug 2019, Christian Marillat wrote: > But bevare fixind the include file path (drm/ttm/ttm_page_alloc.h) doesn't > work at all the virtualbox doesn't start. I fixed the path, the build went through. I rebooted my VM and it worked. What exactly was the failure that you had? Did you

Bug#934483: virtualbox-guest-dkms: Doesn't build with latest kernel in unstable 5.2.0-2-686-pae

2019-08-19 Thread Raphael Hertzog
Hi, On Thu, 15 Aug 2019, Darsey Litzenberger wrote: > I haven't gotten around to testing, but it looks like maybe all that needs > to be done is to disable building some of these modules after a certain > kernel version. At least I can confirm that if you disable "vboxvideo" from the dkms

Bug#932506: elastalert: (build-)depends on cruft packages.

2019-08-17 Thread Raphael Hertzog
Control: tag -1 + confirmed upstream fixed-upstream Hi, On Sat, 20 Jul 2019, peter green wrote: > elastalert (build-)depends on the python-croniter binary package which > is no longer built by the python-croniter binary package. > > If you want to keep your package in Debian you will probablly

Bug#931516: tracker.debian.org: fixtures reference testing/updates instead of testing-security

2019-07-20 Thread Raphael Hertzog
Hi, On Sun, 07 Jul 2019, Paul Wise wrote: > The fixtures reference testing/updates but with bullseye that suite has > been renamed to testing-security. The fixtures in the code need to be > updated and then updated on the live server. I've no idea how to do the > latter, which is why I'm filing

Bug#931919: debian-handbook: Debian Handbook for Debian Buster

2019-07-13 Thread Raphael Hertzog
Hello, On Fri, 12 Jul 2019, tkoeck wrote: > are there any plans to update the book to Debian Buster? As far as I > have seen it's just for Debian Jessie. Yes, we're working on it in the git repository. We don't know yet when we will be done... Cheers, -- Raphaël Hertzog ◈ Debian Developer

Bug#931361: ettercap: Please update to new version 0.8.3

2019-07-03 Thread Raphael Hertzog
Hi, On mer., 03 juil. 2019, Sophie Brun wrote: > I would like to propose you to join the pkg-security-team > to maintain this package. If you are interested: > https://wiki.debian.org/Teams/pkg-security Barak, if you are interested, we can help you to move/setup the packaging repository and to

Bug#929469: systemd-networkd: systemd-networkd: fails with "could not set address: Permission denied"

2019-07-02 Thread Raphael Hertzog
Hi, sorry for the delay. On Fri, 28 Jun 2019, Michael Biebl wrote: > Could you give the packages at > https://people.debian.org/~biebl/systemd/buster/ a try? It seems to work for me: $ sudo sysctl net.ipv6.conf.default.disable_ipv6=1 net.ipv6.conf.default.disable_ipv6 = 1 $ cat

Bug#930719: autopkgtest: Hangs with qemu backend when copyup destination failed

2019-06-28 Thread Raphael Hertzog
On Wed, 19 Jun 2019, Raphaël Hertzog wrote: > In Kali we do have a debci setup at autopkgtest.kali.org, we have > configured it to use the qemu backend. Unfortunately, after a while > all our workers were stuck... upon investigation it looks like that > autopkgtest can get stuck with the qemu

Bug#929469: systemd-networkd: systemd-networkd: fails with "could not set address: Permission denied"

2019-06-27 Thread Raphael Hertzog
Hi, On Wed, 26 Jun 2019, Michael Biebl wrote: > I agree. While setting up an IPv6 address and at the same time disabling > IPv6 on the kernel side could be seen as a misconfiguration, it might > just as well be plain oversight on the admin's side. > networkd behaving more sensibly in that case is

Bug#931017: dkms: "install" loads modules immediately, and loads more than the newly installed modules

2019-06-25 Thread Raphael Hertzog
Control: forwarded -1 https://github.com/dell/dkms/issues/85 On Mon, 24 Jun 2019, Raphaël Hertzog wrote: > The reason is that "dkms install" runs this: > find /sys/devices -name modalias -print0 | xargs -0 cat | xargs modprobe -a > -b -q This was added in this commit:

Bug#930929: [Pkg-libvirt-maintainers] Bug#930929: marked as done (libvirt: is no longer able to use kvm)

2019-06-23 Thread Raphael Hertzog
Hi, On Sun, 23 Jun 2019, Guido Günther wrote: > > But after a reboot with the good systemd, it began again to work... sorry > > for the noise! > > Thanks for reporting all the details! Should we expect issues with newer > systemd then or do you deem the problems related to the patches you >

Bug#930929: libvirt: is no longer able to use kvm

2019-06-22 Thread Raphael Hertzog
On Sat, 22 Jun 2019, Raphael Hertzog wrote: > And despite this I still have the error and yet the libvirt-qemu user > is part of the kvm group: > $ id libvirt-qemu > uid=124(libvirt-qemu) gid=130(kvm) groupes=130(kvm),132(libvirt-qemu) Still I confirm that the libvirt-qemu user

Bug#930929: libvirt: is no longer able to use kvm

2019-06-22 Thread Raphael Hertzog
Control: found -1 5.0.0-3 Control: found -1 5.2.0-2 On Sat, 22 Jun 2019, Raphaël Hertzog wrote: > For a few days/weeks (I'm not sure when it started exactly), I can no > longer run my VM with virt-manager. I tried downgrading to the version in testing, but the problem stayed the same. I also

Bug#820597: Devuan ... let's remove such reference

2019-06-21 Thread Raphael Hertzog
On Thu, 20 Jun 2019, Jorge wrote: > I wouldn't add Trisquel, because it's based on Ubuntu. Yes, ultimately, an > Ubuntu derivative is a Debian derivative, but do we really want to add > those? PureOS is a FSF-supported Debian derivative, so I plan to add that > one to fill that free software

  1   2   3   4   5   6   7   8   9   10   >