Bug#871664: thunderbird: Since the upgrade to 52.2.1-4~deb9u1 thunderbird is so slow that it is basically unusable

2017-08-10 Thread Georges Toth
Package: thunderbird Version: 1:52.2.1-4~deb9u1 Severity: important Dear Maintainer, Since the upgrade to the latest stable version, in combination with enigmail and lightning; thunderbird has become so slow that it is basically unusable. Scrolling required 2s to move anything. Mails open very

Bug#871665: python-hiredis: requires a more strict b-d on libhiredis-dev

2017-08-10 Thread Sandro Tosi
Source: python-hiredis Version: 0.2.0-2 Severity: important Hello, python-hiredis/0.2.0 cant be built with libhiredis-dev from jessie (v0.11.0-4) FingTBFS with the following error: ``` x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -g -O2

Bug#871673: nmu: libnet-ssh2-perl_0.66-1

2017-08-10 Thread Salvatore Bonaccorso
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: binnmu Hi Apparently when I did upload libnet-ssh2-perl (I think I did not during the perl transition), in the i386 chroot on the buildd was still perl 5.24 installed. Now libnet-ssh2-perl cannot

Bug#869020: logback: FTBFS: find: '/usr/share/maven-repo/org/codehaus/plexus/plexus-containers/*/*.jar': No such file or directory

2017-08-10 Thread Apollon Oikonomopoulos
Control: tags -1 unreproducible moreinfo Control: severity -1 normal Hi Lucas, Thanks for the report. On 07:40 Thu 20 Jul , Lucas Nussbaum wrote: > Hi, > > During a rebuild of all packages in sid, your package failed to build on > amd64. > > Relevant part (hopefully): > > debian/rules

Bug#871282: insighttoolkit4.10: requires rebuild against GCC 7 and symbols/shlibs bump

2017-08-10 Thread Matthias Klose
Control: tags -1 - wontfix > Version 4.12 is in unstable, was already build using gcc-7, and will > soon transition to testing thereby removing v4.10 from the archives. No, it is not. According to the build logs at least 4.12.0-dfsg1-1 on i386 was built using gcc-6. You really should fix that.

Bug#869946: installation-reports: When the computer shuts down abruptly in Stratch 9.0.1 with any kind of cryptography, the computer won't boot again.

2017-08-10 Thread Steve McIntyre
On Thu, Aug 10, 2017 at 05:04:00PM +0200, marcopellegr...@tutamail.com wrote: >Hello Steve, > >Unfortunately I formatted every system that had cryptography, can you check >with a fresh installation on a machine of yours or do you need me to format >again with encryption and write all the errors?

Bug#838291: wpasupplicant: networking.service fails to bring up wlan interface, when VERBOSE set to yes

2017-08-10 Thread Dmitriy Matrosov
On August 10, 2017 3:02:03 PM GMT+03:00, Kilian Krause wrote: >Hi Dmitriy, > >since your bug actually breaks non-VERBOSE mode, I'd suggest using as >patch: >--(snip)-- ># diff -u /etc/wpa_supplicant/functions.sh /tmp/functions.sh >--- /etc/wpa_supplicant/functions.sh

Bug#859867: [buildd-tools-devel] Bug#859867: Bug#859867: Bug#859867: Please add a package which automatically configures sbuild for Debian packaging

2017-08-10 Thread Raphael Hertzog
On Thu, 10 Aug 2017, Michael Stapelberg wrote: > Sounds good. Are you willing to contribute to this? I have no experience > with autopkgtest at all. Yes, I'm willing to help. As for the proper umbrella for this work, maybe it can be part of the "packaging-dev" source package ? Benjamin, have a

Bug#871674: mini-dinstall is impossible to send notification email on alioth

2017-08-10 Thread Carsten Schoenert
Package: mini-dinstall Severity: important Dear Maintainer, after upload a new set of packages to Alioth mini-dinstall is failing to send the notification email we wanted to use for announcing a new upload within the team. The follwoing error is happen. > mini-dinstall [140015964731136] ERROR:

Bug#871264: ejabberd 16.09 on Stretch can't use ECDSA certificates

2017-08-10 Thread Philipp Huebner
Hi, thank you very much for the patch! I have prepared an update for stretch and filed the necessary bugreport against release.debian.org: #871661 Best wishes, -- .''`. Philipp Huebner : :' : pgp fp: 6719 25C5 B8CD E74A 5225 3DF9 E5CA 8C49 25E4 205F `. `'` `-

Bug#871667: libicu52: ucol_strcollUTF8() stuck allocating in loop until segfault

2017-08-10 Thread Daniel Verite
Package: libicu52 Version: 52.1-8+deb8u5 Severity: normal Tags: upstream Dear Maintainer, While testing PostgreSQL 10 beta with ICU-52.1, crashing bugs were found on certain combinations of inputs and collations. One crash can be distilled to the following standalone test case: #include

Bug#871671: Please treat non-uploader Debian Members like Debian Maintainers

2017-08-10 Thread Enrico Zini
Package: ftp.debian.org Severity: whishlist Hello, I would like dak to consider non-uploader Debian Members the same as Debian Maintainers. There is currently a new situation with a NM applicant[1] where he is a DM and has been and is very active in DebConf organisation. He should be a Debian

Bug#853685: torcs: ftbfs with GCC-7

2017-08-10 Thread Markus Koschany
Control: tags -1 pending patch On Tue, 31 Jan 2017 09:36:22 + Matthias Klose wrote: Package: src:torcs Version: 1.3.3+dfsg-0.4 Severity: normal Tags: sid buster User: debian-...@lists.debian.org Usertags: ftbfs-gcc-7 This issue is fixed in Git and I intend to upload the

Bug#871658: empty directories not removed upon purge

2017-08-10 Thread 積丹尼 Dan Jacobson
Package: php7.0 Version: 7.0.22-2 Severity: minor dpkg: warning: while removing php7.0-mysql, directory '/etc/php/7.0/mods-available' not empty so not removed dpkg: warning: while removing libapache2-mod-php7.0, directory '/etc/php/7.0/apache2/conf.d' not empty so not removed dpkg: warning:

Bug#871660: ITP: fairsim -- ImageJ plugin for SIM reconstruction

2017-08-10 Thread Carnë Draug
Package: wnpp Severity: wishlist Owner: =?utf-8?q?Carn=C3=AB_Draug?= * Package name: fairsim Version : 1.2.0 Upstream Author : Marcel Müller * URL : https://fairsim.github.io/ * License : GPL-2+

Bug#871663: enigmail: 2.1.9.8.1.1 on jessie requires gnupg later than latest available

2017-08-10 Thread D. R. Evans
Package: enigmail Version: 2:1.8.2-4~deb8u1 Severity: important Dear Maintainer, On 64-bit jessie, updating to the current officially supported versions of thunderbird/iceweasel (version 1.52.2.1) and enigmail, the enigmail portion (version 2.1.9.8.1.1) is unusable because it requires gnupg

Bug#871649: lv2-dev: abuse of non portable pointer of uint8_t type

2017-08-10 Thread James Cowgill
Hi, On 10/08/17 08:31, Joël Krähemann wrote: > Package: lv2-dev > Version: 1.14.0~dfsg1-1 > Severity: important > > Dear Maintainer, > > The following header makes use of smallest possible pointer in > LV2_Event_Buffer struct's data field. > > lv2/lv2plug.in/ns/ext/event/event.h > > Please

Bug#871662: scram-gui: typo in the long package description

2017-08-10 Thread Lev Lamberov
Package: scram-gui Version: 0.14.0-1 Severity: minor Dear Maintainer, the long description of the package contains a typo. Currently, the long description is as follows: The complementary SCRAM GUI front-end for visualization and manipulation of risk anlysis models and reports.

Bug#871668: Remote editition of local documents should be opt-in rather than opt-out

2017-08-10 Thread Didier 'OdyX' Raboud
Package: gobby Version: 0.5.0-8.1 Severity: normal On initial start (and upgrade), the "allow remote users to edit local documents" checkbox is ticked. At a conference like DebConf17, it led to have plenty of people 'pollute' the list of documents, and makes the "centralized gobby server"

Bug#871669: maven-debian-helper: building the documentation takes too long, dpkg failed to execute successfully

2017-08-10 Thread Markus Koschany
Package: maven-debian-helper Version: 2.2.2 Severity: normal Hi, I am filing this bug report to keep track of a build issue with maven-debian-helper. Building the documentation takes too long in some cases because mdh tries to find installed documentation with dpkg --search but fails if it can't

Bug#871672: Pending fixes for bugs in the libfile-sharedir-perl package

2017-08-10 Thread pkg-perl-maintainers
tag 871672 + pending thanks Some bugs in the libfile-sharedir-perl package are closed in revision 81d82feab66430a1d1df4a0dd179819c32f76534 in branch 'master' by gregor herrmann The full diff can be seen at

Bug#871676: openssl: Asterisk-11.25.1 failed to compile

2017-08-10 Thread Tech
Package: openssl Version: 1.1.0f-4 Severity: normal Dear Maintainer, Trying to compile stock Asterisk 11.25.1 version on Stretch -even after having upgraded libssl and openssl to unstable 1.1.0f-4 version- it fail with [CC] tcptls.c -> tcptls.o tcptls.c: In function ‘tcptls_stream_close’:

Bug#871677: insighttoolkit4 ftbfs with GCC 7 (castxml out of date)

2017-08-10 Thread Matthias Klose
Package: src:insighttoolkit4 Version: 4.12.0-dfsg1-1 Severity: serious Tags: sid buster Contrary to the claim in #871282, the package was *not* built using gcc-7. The recent binNMU triggered that, and then showed a ftbfs. Not sure how that was tested ... cd /<>/BUILD/Wrapping/Modules/ITKCommon

Bug#871678: Missing pseudomap.js file

2017-08-10 Thread Bart Visscher
Package: node-pseudomap Version: 1.0.2-1 Hello, I noticed that the package is missing the pseudomap.js file. Bart

Bug#871575: lintian: maintainer-address-causes-mail-loops-or-bounces should be fixed to allow @packages.debian.org emails

2017-08-10 Thread Chris Lamb
tags 871575 + pending thanks Fixed in Git: https://anonscm.debian.org/git/lintian/lintian.git/commit/?id=56864ad575f70ad83a41229b06175918a2d81da4 Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#871649: lv2-dev: abuse of non portable pointer of uint8_t type

2017-08-10 Thread Joël Krähemann
Hi James, It is common that you use for storing uint8_t an entire word. The use of a uint8_t pointer confused me as you are pointing to a struct. Bests, Joël On Thu, Aug 10, 2017 at 4:10 PM, James Cowgill wrote: > Hi, > > On 10/08/17 08:31, Joël Krähemann wrote: >>

Bug#871618: gnome-terminal: package should depend on dbus-x11

2017-08-10 Thread Simon McVittie
On Thu, 10 Aug 2017 at 00:31:24 -0700, Mark Hedges wrote: > Changing the recommends to depends for dbus-user-session won't fix the > immediate problem, unless gnome-terminal is changed to use something other > than > `dbus-launch` to do whatever it is that it's trying to do.  dbus-x11 provides >

Bug#869090: gcc-6: Address sanitizer: Shadow memory range interleaves

2017-08-10 Thread Sven Eckelmann
On Montag, 24. Juli 2017 16:34:34 CEST Ben Hutchings wrote: [...] > > Downgrading the kernel from linux-image-4.11.0-2-amd64 (4.11.11-1+b1) to > > linux-image-4.11.0-1-amd64 (4.11.6-1) fixed this. I wonder if the stack > > clash fix has broken ASan. > > The address space change that went into

Bug#869946: installation-reports: When the computer shuts down abruptly in Stratch 9.0.1 with any kind of cryptography, the computer won't boot again.

2017-08-10 Thread marcopellegrini
Hello Steve, Unfortunately I formatted every system that had cryptography, can you check with a fresh installation on a machine of yours or do you need me to format again with encryption and write all the errors? Marco 4. Aug 2017 17:37 by st...@einval.com: > On Thu, Jul 27, 2017 at

Bug#871672: libfile-sharedir-perl: files installed from CPAN not installed by apt

2017-08-10 Thread Ricardo SIGNES
Package: libfile-sharedir-perl Version: 1.102-1 Severity: important Dear Maintainer, libfile-sharedir-perl is a packaging of File-ShareDir from CPAN. File-ShareDir installs two files to the share directory, sample.txt and subdir/sample.txt . These files can be used for test purposes by

Bug#871675: unbound 1.6.4-1 :libunbound2 enable--with-libevent

2017-08-10 Thread Antony Antony
Package: libunbound2 Version: 1.6.4-1 I am testing the fix #859584, libunbound2 1.6.4-1 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=859584 While testing libunbound2 with libevent, using libreswan and noticed that ub_ctx_create_event() return NULL. The libunbound2 should be built with

Bug#871570: git FTBFS on i386: t7006-pager.sh test failure

2017-08-10 Thread Jonathan Nieder
found 871570 git/1:2.13.2-3 tags 871570 + upstream quit Hi, Adrian Bunk wrote: > https://buildd.debian.org/status/fetch.php?pkg=git=i386=1%3A2.14.0-1=1502132890=0 > > ... > expecting success: > ( > sane_unset LESS LV && > PAGER="env >pager-env.out; wc" && >

Bug#865155: patch

2017-08-10 Thread Eric Dorland
Control: tags -1 patch -- Eric Dorland 43CF 1228 F726 FD5B 474C E962 C256 FBD5 0022 1E93 From 6df25f2f3d9102bb7819d5f36bd824ed12a450ee Mon Sep 17 00:00:00 2001 From: Eric Dorland Date: Thu, 10 Aug 2017 11:31:45 -0400 Subject: [PATCH] Switch to automake, not

Bug#871672: libfile-sharedir-perl: files installed from CPAN not installed by apt

2017-08-10 Thread gregor herrmann
On Thu, 10 Aug 2017 11:03:36 -0400, Ricardo SIGNES wrote: > File-ShareDir installs two files to the share directory, sample.txt and > subdir/sample.txt . These files can be used for test purposes by downstream > libraries and, in fact, are used by the tests for Path-Resolver. This means > that

Bug#871764: snappy-java: Make source package bootstrappable

2017-08-10 Thread Daniel Schepler
Source: snappy-java Version: 1.1.4-1 Severity: wishlist Currently, src:snappy-java Build-Depends on maven-debian-helper, which indirectly Depends on libsnappy-java (through libplexus-archiver-java), which Depends on libsnappy-jni. It would be nice if the source package could provide a build

Bug#846314: alot: Migrate from pygpgme to python-gpg

2017-08-10 Thread Jordan Justen
On 2017-07-08 08:43:18, Jonathan Wiltshire wrote: > I will be requesting removal of pygpgme from unstable at the end of > this month (but it's up to ftp masters if they do so immediately and break > things, or wait for dependencies to be resolved). Jonathan, I wanted to give an update for 'alot'

Bug#871631: lilypond-data: Update fails due to problem with symbolic link creation

2017-08-10 Thread Paul Menzel
Package: lilypond-data Version: 2.18.2-8 Severity: serious Dear Debian folks, The update of lilypond-data fails with the message below. ``` lilypond-data (2.18.2-8) wird eingerichtet ... Running mktexlsr /usr/share/texlive/texmf-dist... mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST...

Bug#871632: gitolite3: include % by default as allowed char in refs

2017-08-10 Thread Uwe Kleine-König
Package: gitolite3 Version: 3.6.1-2+deb8u2 Severity: wishlist Hello, Following DEP14[1] to name my tags for debian packaging I use % in tagnames. When I then try to push such a tag to a gitolite instance I get: remote: FATAL: invalid characters in ref or filename:

Bug#871588: libreoffice-calc: Middle button paste does not work

2017-08-10 Thread Rene Engelhard
Hi, On Wed, Aug 09, 2017 at 06:19:42PM +0200, Kamil Jonca wrote: > 1. Open Writer or Calc window So if this affected also Writer, why is this assigned against libreoffice-calc? > 2. Open emacs or xterm window, write some random text. > 3.Select this text (but DON'T use Ctrl-Insert or sth) >

Bug#870779: pev: Please migrate to openssl1.1 in Buster

2017-08-10 Thread Petter Reinholdtsen
Control: forwarded -1 https://github.com/merces/pev/issues/108 [Sebastian Andrzej Siewior] > Please migrate to libssl-dev in the Buster cycle. I have already asked upstream to port it to OpenSSL 1.1 in https://github.com/merces/pev/issues/108 >, and hope for a new upstream release to fix this.

Bug#871254: pcp missing autopkgtests and debian/watch

2017-08-10 Thread Ken McDonell
Dariusz, There is an extensive PCP QA infrastructure included in the PCP source distribution (it is below the top-level qa directory). Rather than writing more unit tests in Python, I would recommend using a subset of the existing QA tests ... kenj@bozo:~/src/pcp/qa$ cloc . 4233 text

Bug#724711: [Debian-med-packaging] Bug#724711: insighttoolkit4: Drops architecture support

2017-08-10 Thread Gianfranco Costamagna
Hello, >As far as I can see all tests are disabled, failing tests means that >the software has bugs, and I'm not sure whether we want to allow >software with known bugs into the archives. At the least it must be >documented which tests are failing. >Gianfranco, since you did the upload to

Bug#871618: gnome-terminal: package should depend on dbus-x11

2017-08-10 Thread Michael Biebl
Am 10.08.2017 um 01:29 schrieb Mark Hedges: > Package: gnome-terminal > Version: 3.22.2-1 > Severity: important > > Tried to install gnome-terminal by itself on a system without the tasksel > window system tasks run. It wouldn't launch until I manually installed the > dbus-x11 package. Looks

Bug#871543: broken init script

2017-08-10 Thread Jörg Frings-Fürst
tags 871543 - moreinfo tags 871543 + pending thanks Hello Philippe, Am Mittwoch, den 09.08.2017, 09:53 -0400 schrieb Philippe Grégoire: > Hello Jörg, > > Thanks for the prompt response. :) > > Yes it works. I had already edited the script with that argument > so that apt operations would exit

Bug#871630: gcc-defaults should ensure equal versions in both directions

2017-08-10 Thread Adrian Bunk
Source: gcc-defaults Severity: important Tags: patch https://buildd.debian.org/status/fetch.php?pkg=lorene=ppc64el=0.0.0~cvs20161116%2Bdfsg-1%2Bb1=1502276276=0 https://buildd.debian.org/status/fetch.php?pkg=dynare=ppc64el=4.5.1-1%2Bb1=1502287921=0

Bug#811565: [pkg-go] Bug#811565: [uscan] git mode: allow for scanning repositories without tags

2017-08-10 Thread Michael Stapelberg
On Thu, Aug 10, 2017 at 6:50 AM, Osamu Aoki wrote: > Hi, > > > On Wed, Aug 09, 2017 at 07:54:05AM -0700, Michael Stapelberg wrote: > > Thanks for sharing your tool! > > Thank you but I don't use go nor perl regulary :-( I wish uscan was in > Python.) > > But supporting github

Bug#724711: [Debian-med-packaging] Bug#724711: insighttoolkit4: Drops architecture support

2017-08-10 Thread Gert Wollny
> Ubuntu built 4.9.0, 4.10.0 and 4.10.1 on arm64: > > http://ports.ubuntu.com/ubuntu-ports/pool/universe/i/insighttoolkit4/ > > Though it looks like they may have ignored a few test failures to get > there: > > https://launchpad.net/ubuntu/+source/insighttoolkit4/+changelog As far as I can

Bug#871629: thunderbird UI unusable with many widgets not drawn

2017-08-10 Thread Adrian Bunk
On Thu, Aug 10, 2017 at 04:21:10PM +1200, Ben Caradoc-Davies wrote: > Package: thunderbird > Version: 1:52.2.1-4+b1 > Severity: grave > Justification: renders package unusable > > Dear Maintainer, > > the thunderbird UI is unusable with many widgets not drawn. See attached > screenshot. Mouse

Bug#871588: libreoffice-calc: Middle button paste does not work

2017-08-10 Thread Kamil Jońca
Rene Engelhard writes: > Hi, > On Wed, Aug 09, 2017 at 06:19:42PM +0200, Kamil Jonca wrote: >> 1. Open Writer or Calc window > > So if this affected also Writer, why is this assigned against > libreoffice-calc? Because I am not sure against which package assign this. > >> 2.

Bug#871634: [a11y] better/different handling needed for onfocus blur

2017-08-10 Thread Raphaël POITEVIN
Package: firefox Version: 55.0-1 Tags: a11y upstream Owner: b...@hypra.fr User: b...@hypra.fr Usertags: hypra Forwarded: https://bugzilla.mozilla.org/show_bug.cgi?id=422981 DESCRIPTION FROM UPSTREAM: " Steps to reproduce: 1. View the attached test case. 2. Use Tab to move focus from link to

Bug#871635: xpa FTCBFS: fails running tests despite DEB_BUILD_OPTIONS=nocheck

2017-08-10 Thread Helmut Grohne
Source: xpa Version: 2.1.18-2 Tags: patch User: helm...@debian.org Usertags: rebootstrap Hi Ole, thank you for quickly fixing #871509. That made working on the package much more joyful. It currently fails to cross build, because it unconditionally runs the test suite and (expectedly) fails doing

Bug#871638: rustc panics when trying to list the target cpus if the current directory does not exist anymore

2017-08-10 Thread Alex Riesen
Package: rustc Version: 1.14.0+dfsg1-3 Severity: normal Dear Maintainer, just trying to run the commands below (with or without RUST_BACKTRACE) causes rustc to panic. The removal of the directory was originally not intentional, so a crash for such harmless command was a bit of surprise. $ mkdir

Bug#871214: [Pkg-octave-devel] Bug#871214: Bug#871214: Bug#871214: octave-image FTBFS on i386: test hangs

2017-08-10 Thread Rafael Laboissière
* Sébastien Villemot [2017-08-10 11:06]: Le jeudi 10 août 2017 à 09:31 +0200, Rafael Laboissière a écrit : * Adrian Bunk [2017-08-07 01:57]: Source: octave-image Version: 2.6.1-1 Severity: serious Tags: buster sid Some recent change in unstable and

Bug#805609: grilo-plugins: Split grilo-plugins into base and extra

2017-08-10 Thread Gianfranco Costamagna
> From the plugins that you would put in the -extra package only DAAP > and Freebox seem to have additional dependencies, and even those are > quite standard for a GNOME desktop. > > What are the ones that concern you the most to have in the main > package, and why? > usually

Bug#871641: udev: USB serial device wrongly tagged as pci in /dev/serial/by-id/

2017-08-10 Thread Nicolas Schodet
Package: udev Version: 232-25+deb9u1 Severity: normal Dear Maintainer, When I plug a USB device using the ACM driver, it is listed in /dev/serial/by-id as pci-xx-if00 instead of usb-xx-if00. This behaviour changed when tty and serial rules were merged together in upstream commit

Bug#871633: upx-ucl FTCBFS: hard codes the build architecture compiler

2017-08-10 Thread Helmut Grohne
Source: upx-ucl Version: 3.94-2 Tags: patch User: helm...@debian.org Usertags: rebootstrap upx-ucl fails to cross build from source, because debian/rules hard codes the build architecture compiler. Deferring compiler choice to debhelper fixes that. It also confuses build and host, so whenever the

Bug#871618: gnome-terminal: package should depend on dbus-x11

2017-08-10 Thread Michael Biebl
Am 10.08.2017 um 09:31 schrieb Mark Hedges: > Changing the recommends to depends for dbus-user-session won't fix the > immediate problem, unless gnome-terminal is changed to use something other > than `dbus-launch` to do whatever it is that it's trying to do. dbus-x11 > provides the dbus-launch

Bug#871264: ejabberd 16.09 on Stretch can't use ECDSA certificates

2017-08-10 Thread Adrien Dorsaz
Hello, On Mon, 7 Aug 2017 16:02:50 +0200 Philipp Huebner wrote: >  > I think we can fix this for Stretch if the release managers agree to the > proposed patch, but I probably won't have time to work on this before > September. A minimal patch would be welcome! >  > I also

Bug#871637: ITP: silx -- Toolbox for X-Ray data analysis

2017-08-10 Thread Picca Frédéric-Emmanuel
Package: wnpp Severity: wishlist Owner: =?utf-8?q?Picca_Fr=C3=A9d=C3=A9ric-Emmanuel?= * Package name: silx Version : 0.5.0 Upstream Author : European Synchrotron Radiation Facility Data analysis unit (s...@esrf.fr) * URL :

Bug#871640: ITP: python-django-celery-results -- Celery result backends for Django

2017-08-10 Thread Michael Fladischer
Package: wnpp Severity: wishlist Owner: Michael Fladischer -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 * Package name: python-django-celery-results Version : 1.0.1 Upstream Author : Ask Solem * URL :

Bug#169437: xzgv: Fixed in 0.9.2

2017-08-10 Thread Reuben Thomas
Package: xzgv Tags: fixed-upstream Followup-For: Bug #169437 This is fixed in the upcoming 0.9.2, which adds “panoramic zoom”. -- System Information: Debian Release: stretch/sid APT prefers xenial-updates APT policy: (500, 'xenial-updates'), (500, 'xenial-security'), (500, 'xenial'), (100,

Bug#871638: [Pkg-rust-maintainers] Bug#871638: rustc panics when trying to list the target cpus if the current directory does not exist anymore

2017-08-10 Thread Markus Wanner
Control: tags -1 +confirmed Control: found -1 1.18.0+dfsg1 Hello Alex, On 08/10/2017 10:32 AM, Alex Riesen wrote: > just trying to run the commands below (with or without RUST_BACKTRACE) causes > rustc to panic. The removal of the directory was originally not intentional, > so a crash for such

Bug#811565: [pkg-go] Bug#811565: [uscan] git mode: allow for scanning repositories without tags

2017-08-10 Thread Michael Stapelberg
On Thu, Aug 10, 2017 at 9:34 AM, Osamu Aoki wrote: > Hi, > > On Thu, Aug 10, 2017 at 08:19:20AM +0200, Michael Stapelberg wrote: > > On Thu, Aug 10, 2017 at 6:50 AM, Osamu Aoki wrote: > > > > The functionality in the tool is exactly what was already

Bug#871214: [Pkg-octave-devel] Bug#871214: octave-image FTBFS on i386: test hangs

2017-08-10 Thread Rafael Laboissière
* Adrian Bunk [2017-08-07 01:57]: Source: octave-image Version: 2.6.1-1 Severity: serious Tags: buster sid Some recent change in unstable and buster makes octave-image FTBFS on i386: https://tests.reproducible-builds.org/debian/history/octave-image.html

Bug#871636: say use URI

2017-08-10 Thread 積丹尼 Dan Jacobson
Package: liburi-perl Version: 1.72-1 Severity: minor File: /usr/share/man/man3/URI.3pm.gz The page forgot to say "use URI;" at top.

Bug#871639: NULL pointer dereference in reset_common_ring+0xc3/0x170 [i915]

2017-08-10 Thread Bjørn Mork
Package: src:linux Version: 4.9.30-2+deb9u3 Severity: normal File: /boot/vmlinuz-4.9.0-3-amd64 -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 I've been having issues with the i915 driver ever since I got this Skylake laptop. The GPU is hanging every now and then. But the error handling has

Bug#833929: wicd-daemon: takes time to reconnect / autoconnect after connection loss

2017-08-10 Thread Vincent Lefevre
Control: retitle -1 wicd-daemon: no autoconnect when GUI is open I've done some tests in debug mode, and could see that messages like "Autoconnecting..." that normally occur every 3 minutes are absent when the GUI is open. This reminds me bug 582567:

Bug#871629: thunderbird UI unusable with many widgets not drawn

2017-08-10 Thread Ben Caradoc-Davies
Downgrading to thunderbird and lightning 52.2.1-4 restores usability. Reinstallation of libevent-2.0-5 (autoremoved) is also required. Kind regards, -- Ben Caradoc-Davies Director Transient Software Limited New Zealand

Bug#799833: still exists

2017-08-10 Thread Jack.R
On Tue, 01 Aug 2017 18:44:37 +0100 Juha =?ISO-8859-1?Q?J=E4ykk=E4?= wrote: > Still exists in 1.9.1-1+b1. > > This bug is almost two years old with no activity what so ever from > the maintainer. It the package still being maintained? > > I am running buster/sid on kernel

Bug#871618: gnome-terminal: package should depend on dbus-x11

2017-08-10 Thread Mark Hedges
Changing the recommends to depends for dbus-user-session won't fix the immediate problem, unless gnome-terminal is changed to use something other than `dbus-launch` to do whatever it is that it's trying to do. dbus-x11 provides the dbus-launch executable. dbus-user-session does not. Is there a

Bug#724711: [Debian-med-packaging] Bug#724711: insighttoolkit4: Drops architecture support

2017-08-10 Thread Edmund Grimley Evans
> As far as I can see all tests are disabled, failing tests means that > the software has bugs, and I'm not sure whether we want to allow > software with known bugs into the archives. Yes, but if the bug is in the test then disabling the test is one way of fixing the bug. On the other hand, a

Bug#811565: [pkg-go] Bug#811565: [uscan] git mode: allow for scanning repositories without tags

2017-08-10 Thread Osamu Aoki
Hi, On Thu, Aug 10, 2017 at 08:19:20AM +0200, Michael Stapelberg wrote: > On Thu, Aug 10, 2017 at 6:50 AM, Osamu Aoki wrote: > > The functionality in the tool is exactly what was already communicated in the > bug :). > > If you need any help with that bug, just let me know.

Bug#837898: Please remove icu-config as it is no longer used by libicu-dev's reverse dependencies

2017-08-10 Thread Hugh McMaster
Package: libicu-dev Version: 57.1-6 Followup-For: Bug #837898 Dear Maintainer, I have checked all 19 reverse dependencies of libicu-dev. Only one package (fis-gtm-6.3-000a) uses icu-config, and even then, it is only used if detected during configure. If not present, the configure script works

Bug#871214: [Pkg-octave-devel] Bug#871214: Bug#871214: octave-image FTBFS on i386: test hangs

2017-08-10 Thread Sébastien Villemot
Le jeudi 10 août 2017 à 09:31 +0200, Rafael Laboissière a écrit : > > * Adrian Bunk [2017-08-07 01:57]: > > > Source: octave-image > > Version: 2.6.1-1 > > Severity: serious > > Tags: buster sid > > > > Some recent change in unstable and buster makes octave-image FTBFS on i386:

Bug#859867: [buildd-tools-devel] Bug#859867: Bug#859867: Bug#859867: Please add a package which automatically configures sbuild for Debian packaging

2017-08-10 Thread Michael Stapelberg
Sounds good. Are you willing to contribute to this? I have no experience with autopkgtest at all. On Thu, Aug 10, 2017 at 6:41 AM, Raphael Hertzog wrote: > Hello guys, > > On Sat, 05 Aug 2017, Michael Stapelberg wrote: > > Thanks for the thorough review. It took me quite a

Bug#868558: nmu: multiple r-* packages

2017-08-10 Thread Andreas Beckmann
On Sun, 6 Aug 2017 08:15:17 -0500 Dirk Eddelbuettel wrote: > Let's get these 46 packages rebuilt so that r-base 3.4.1 can migrate to > testing. Disclaimer: I don't know anything about R or the R packaging. Isn't it possible to use some virtual r-abi-WHATEVER package(s) to make

Bug#871370: Pending fixes for bugs in the libgettext-commons-java package

2017-08-10 Thread pkg-java-maintainers
tag 871370 + pending thanks Some bugs in the libgettext-commons-java package are closed in revision 1efc5b4490f97cfe659645755eebf9230446bc0b in branch 'master' by Tom Marble The full diff can be seen at https://anonscm.debian.org/cgit/pkg-java/libgettext-commons-java.git/commit/?id=1efc5b4

Bug#871659: www.debian.org: scripts: Debian GNU/Linux FAQ should not be typesetted on webserver but webserver should use faq .deb (was: Re: [...] Debian Documentation BoF @ DebConf17 [...])

2017-08-10 Thread Joost van Baal-Ilić
Package: www.debian.org Severity: normal Hi, Previous, in https://lists.debian.org/msgid-search/20170806213642.ga17...@beskar.mdcc.cx : On Mon, Aug 07, 2017 at 11:06:54PM +0200, Joost van Baal-Ilić wrote: > On Sun, Aug 06, 2017 at 11:36:42PM +0200, Joost van Baal-Ilić wrote: > > On Sat, Aug 05,

Bug#865154: patch

2017-08-10 Thread Eric Dorland
Control: tags -1 patch -- Eric Dorland 43CF 1228 F726 FD5B 474C E962 C256 FBD5 0022 1E93 diff -ruN cloog-ppl-0.16.1.old/debian/control cloog-ppl-0.16.1/debian/control --- cloog-ppl-0.16.1.old/debian/control 2017-08-10 11:21:14.124652961 -0400 +++

Bug#869398: gpg-key2ps: gpg-key2ps crashes ps2pdf

2017-08-10 Thread Guilhem Moulin
Control: tag -1 pending Control: retitle -1 gpg-key2ps: doesn't support EC (sub)keys Hi ben, On Sat, 22 Jul 2017 at 20:06:39 -0600, Ben Hildred wrote: > gpg-key2ps produces output that crashes ps2pdf. here is a session log > and the generated postscript. Fix pending. However you might also

Bug#865158: patch

2017-08-10 Thread Eric Dorland
Control: tags -1 patch -- Eric Dorland 43CF 1228 F726 FD5B 474C E962 C256 FBD5 0022 1E93 diff -ruN fam-2.7.0.old/debian/control fam-2.7.0/debian/control --- fam-2.7.0.old/debian/control 2017-08-10 12:13:37.447504805 -0400 +++ fam-2.7.0/debian/control 2017-08-10

Bug#870073: Bug#869774: Enigmail update broke ppc support

2017-08-10 Thread Daniel Kahn Gillmor
Hi there Stiepan-- On Wed 2017-08-09 01:21:38 +0200, Stiepan Aurélien Kovac wrote: > seems to have broken enigmail support, at least on the ppc (powerpc64) arch. I don't think this is a ppc-specific issue -- nothing in the current version of enigmail is debian-specific. I also think your issue

Bug#871683: release.debian.org: mail_autoremovals.pl should not send any copy to packages.qa.debian.org

2017-08-10 Thread Raphaël Hertzog
Package: release.debian.org Severity: normal I currently get multiple copies of "foo is marked for autoremoval" for each package that I'm subscribed to via the package tracker. The problem is that I get one copy through f...@packages.debian.org which forwards to the tracker and one copy through

Bug#869665: libgit2-dev: please update version in Debian unstable and do a library transition

2017-08-10 Thread Ximin Luo
Russell Sim: > [..] > > Thanks, for doing all that. > > I'm happy to lodge the bugs, I'll wait for the package to clear the new > queue and then send out the emails. > > I have had a look over the package build logs you posted, it appears that > most of them have failed because the package

Bug#871282: libinsighttoolkit4.10: requires rebuild against GCC 7 and symbols/shlibs bump

2017-08-10 Thread Gert Wollny
Control: tags -1 -wontfix Control: block -1 by 871573 Control: block 871677 by 871573 I was getting to that, first I had to check #871573. Well, before that I thought I had it uploaded after gcc-7 became the default (I'm quite positive that I built it with an older version of gcc-7) and

Bug#648292: gnome-control-center: Sticky keys do not work.

2017-08-10 Thread Filip W.
Package: gnome-control-center Version: 1:3.22.2-3 Followup-For: Bug #648292 Dear Maintainer, Yesterday I've upgraded my system and Sticky Keys stopped working despite option in configuration is selected. This is very important feature for me - quadriplegic programmer. Is there a way to quickfix

Bug#871679: libcacard FTCBFS: libtool-bin build dependency unsatisfiable

2017-08-10 Thread Helmut Grohne
Source: libcacard Version: 1:2.5.0-3 Tags: patch User: helm...@debian.org Usertags: rebootstrap libcacard fails to cross build from source, because its Build-Depends: libtool-bin is unsatisfiable. It turns out that libcacard doesn't need libtool-bin and only needs libtool. After demoting the

Bug#868473: dh-acc: Incorrect usage of doit (Dh_Lib)

2017-08-10 Thread Jeremy Bicha
Hi, I just wanted to point out that Ubuntu uses autopkgtests to check uploads before allowing them into the regular development repository. This bug is causing a very large number of autopkgtests to fail, which is disrupting Ubuntu development work. Generally, anything outputted to stderr will

Bug#710814: rubygems-integration: fails to override bin_path

2017-08-10 Thread Kevin Locke
On Wed, 2013-06-05 at 21:35 +0200, Paul van Tilburg wrote: > On Sun, Jun 02, 2013 at 07:18:00PM +0200, Christian Hofstaedtler wrote: >> there is a problem with rubygems-integration in which it fails to >> properly override the binary path for gems. >> >> This is mostly seen when having bin stubs

Bug#871682: RFS: xtensor-python/0.12.2-1

2017-08-10 Thread Ghislain Vaillant
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for the following package: * Package name: xtensor-python Version : 0.12.2-1 Upstream Author : Johan Mabille, Sylvain Corlay and Wolf Vollprecht * URL :

Bug#871688: exim4-base: using su in cronjob invokes a full pam-session. use runuser instead

2017-08-10 Thread Jakobus Schürz
Package: exim4-base Version: 4.89-2+deb9u1 Severity: normal Dear Maintainer, I have some systemd --user services from other packages. The units are located in /etc/systemd/user/ or /usr/lib/systemd/user/ and enabled on installing. When a daemon uses su or sudo on debian, it starts a service

Bug#871687: consul FTBFS: test failures

2017-08-10 Thread Adrian Bunk
Source: consul Version: 0.6.4~dfsg-4 Severity: serious https://buildd.debian.org/status/package.php?p=consul=sid ... === RUN TestExecCommandRun 2017/08/10 13:14:49 [ERR] http: Request GET /v1/catalog/nodes, error: No cluster leader from=127.0.0.1:35066 2017/08/10 13:14:49 [DEBUG] http:

Bug#871696: ggcov: Please add arm64

2017-08-10 Thread Edmund Grimley Evans
Source: ggcov Version: 0.9-15 User: debian-...@lists.debian.org Usertags: arm64 Would it be possible to add arm64? With gcc-7 there's #853417, but with gcc-6 the only test failure on arm64 is test033, where all the asserts are "PC" rather than "CO", and the abort is "UN" rather than "SU". Does

Bug#870073: Bug#869774: Enigmail update broke ppc support

2017-08-10 Thread Stiepan Aurélien Kovac
Hi Daniel, Thank you for your reply. I have checked my Thunderbird version and I have the latest available one on my platform: "apt-cache policy thunderbird thunderbird: Installed: 1:45.8.0-3~deb8u1 Candidate: 1:45.8.0-3~deb8u1" (also according to https://tracker.debian.org/pkg/icedove) I

Bug#871538: Makes apparmor FTBFS on mips64el (generated code thinks that 1 > 1)

2017-08-10 Thread Aurelien Jarno
control: forcemerge 871514 871538 control: affects 871514 apparmor control: affects 871514 clamav On 2017-08-09 10:52, intrigeri wrote: > Hi mips porters, > > can you please have a look at #871538? It includes gdb debugging > information that seems to demonstrate a regression in the toolchain on

Bug#871681: firefox: re-enable omni.ja compression?

2017-08-10 Thread Vincent Lefevre
Package: firefox Version: 55.0-2 Severity: wishlist I've noticed that firefox 55.0-2 takes much more memory on disk than firefox 54.0-2 (155107 KB vs 108884 KB). Looking at the deb files, this partly comes from the fact that the omni.ja files were compressed in FF 54, but this is no longer the

Bug#865159: patch

2017-08-10 Thread Eric Dorland
Control: tags -1 patch -- Eric Dorland 43CF 1228 F726 FD5B 474C E962 C256 FBD5 0022 1E93 diff -ruN freefem3d-1.0pre10.old/debian/control freefem3d-1.0pre10/debian/control --- freefem3d-1.0pre10.old/debian/control 2017-08-10 12:20:09.567154622 -0400 +++

Bug#871690: libglib2.0-0: gtk filechooser places populates with *all* filesystems

2017-08-10 Thread martintxo
Package: libglib2.0-0 Version: 2.53.4-3 Severity: normal Dear Maintainer, * What led up to the situation? Now, when I go to open a file with any gtk (2 & 3) app, now I see the filechooser dialog "places" side panel populated with all the filesystem in the machine. They are the same as the

Bug#871689: mpich FTBFS on armhf: FAIL: test_primitives

2017-08-10 Thread Adrian Bunk
Source: mpich Version: 3.3~a2-2 Severity: serious https://buildd.debian.org/status/fetch.php?pkg=mpich=armhf=3.3~a2-2=1502381558=0 ... FAIL: test_primitives = Testing simple integer load/store functionalityPASSED Testing simple pointer load/store

Bug#871691: nss FTBFS on big endian: cpputil/databuffer.h:96:14: error: 'curve' may be used uninitialized in this function

2017-08-10 Thread Adrian Bunk
Source: nss Version: 2:3.32-1 Severity: serious https://buildd.debian.org/status/package.php?p=nss=sid ... In file included from test_io.h:17:0, from gtest_utils.h:12, from ssl_ecdh_unittest.cc:19: ../../cpputil/databuffer.h: In member function 'virtual

  1   2   3   >