Bug#922063: alot: improper use of 8-bit data from buxtehude.debian.org (BTS)

2019-02-11 Thread Jonas Smedegaard
Package: alot Version: 0.8-1 Severity: important -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Since updating to 0.8-1, my emails to Debian bugreports get rejected: <920...@bugs.debian.org>: host buxtehude.debian.org[209.87.16.39] said: 550 improper use of 8-bit data in message header:

Bug#919395: MySQL-python

2019-02-11 Thread Larry Martell
I am getting this error (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918393) building MySQL-python. Is there a fixed 10.3 I can download for debian buster that resolves this?

Bug#922067: winpdb: upstream is dead. Porting the gui to python3 is under work in winpdb-reborn

2019-02-11 Thread Alberto Fuentes
Package: winpdb Version: 1.4.8-3 Severity: wishlist upstream is dead All hail new upstream: https://github.com/bluebird75/winpdb Its not working 100% but python3 can still be debugged: https://github.com/bluebird75/winpdb/issues/15 -- System Information: Debian Release: buster/sid APT

Bug#918013: O: vlan -- user mode programs to enable VLANs on your ethernet devices

2019-02-11 Thread Willem van den Akker
Hi, Packages is uploaded to unstable by a mentor.Can you give me write access on the git repo?Username: wvdakker-guest ThanksWillemOn Mon, 2019-02-11 at 09:13 +0100, Andrej Shadura wrote: > On Mon, 04 Feb 2019 14:59:12 +0100 Willem van den Akker< > wvdak...@wilsoft.nl> wrote: > > Control: retitle

Bug#922053: libpocl1-common is "arch: all" but embeds arch specific bytecode file

2019-02-11 Thread Raphael Hertzog
On Mon, 11 Feb 2019, Andreas Beckmann wrote: > That was fixed long ago ... do you think this should be fixed via > stable-pu as well? Ah sorry, I misdiagnosed this because I didn't notice that we are using libpocl2 currently. I don't think it's worth fixing in stable. Cheers, -- Raphaël

Bug#920833: apparmor: AppArmor denies access to mime-specifc files for various GUI applications

2019-02-11 Thread Vincas Dargis
Changing this rule [0]: @{user_share_dirs} = @{HOME}/.local/{,share/@{flatpak_exports_root}}/share Into these two: @{user_share_dirs} = @{HOME}/.local/share @{user_share_dirs} += @{HOME}/.local/share/@{flatpak_exports_root}/share Makes logs happy again. Not sure if flatpak-stuff is OK

Bug#913359: xkbcomp.pc requires libxkbfile-dev as dependency

2019-02-11 Thread Julien Cristau
Control: severity -1 minor On Sun, Feb 10, 2019 at 10:12:31PM +0600, Judit Foglszinger wrote: > tags 913359 +patch > user debian-rele...@lists.debian.org > > usertag 913359 + bsp-2019-02-de-berlin > thanks > > Added a patch. > diff -Nru

Bug#922062: ca-certificates package post-installation script subprocess returned error exit status 1

2019-02-11 Thread Michael Shuler
On 2/11/19 12:51 PM, Michel Meyers wrote: > Mystery solved: Somebody (or something) placed a private key in a file > called privkey.pem and stored it in /etc/ssl/certs. This caused openssl > rehash to silently exit with error code 1, thus causing the whole > postinst script to fail. > > After

Bug#909510: [PATCH] New tag: script-uses-unversioned-python-in-shebang

2019-02-11 Thread Chris Lamb
Hi Dmitry, > Yes. Sorry, but I do not understand, how to test tags with severity > 'classification'. It seems to not appear in output, that is > compared with t/tags/checks/*/tags. Look at how, for example: t/tags/checks/scripts/scripts-maintainer-script-classification … works. :)

Bug#867747: rsyslog: /var/log/dmesg world-readable despite kernel.dmesg_restrict = 1

2019-02-11 Thread Dmitry Bogatov
[2019-02-07 17:08] Thorsten Glaser > > part text/plain 869 > On Thu, 7 Feb 2019, Dmitry Bogatov wrote: > > > Hence, I refine my proposal -- create /var/log/dmesg as 640 in > > initscripts, *only* if it does not already exists. Ignore > > kernel.dmesg_restrict. > > +1 Here

Bug#922073: libssh autopkgtest is flaky due to test service startup race

2019-02-11 Thread Steve Langasek
Source: libssh Version: 0.8.6-2 Severity: important User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu disco Dear maintainers, The libssh 'libssh-server' autopkgtest is badly racy; while it doesn't appear to have ever failed on the Debian autopkgtest infrastructure, it fails with high

Bug#922065: Bind9 does not start after upgrade because of AppArmor + workarround

2019-02-11 Thread Bernhard Schmidt
Am 11.02.19 um 18:01 schrieb Paul van der Vlis: Dear Paul, > I upgraded from Debian9 tot Debian10 (testing). After this, bind did not > start. Syslog says it's AppArmor (see syslog below). > > A work-arround is "aa-complain /usr/sbin/named". > You need the package apparmor-utils for that. Are

Bug#922075: npm: segfault during extract on i386

2019-02-11 Thread Teemu Ikonen
Package: npm Version: 5.8.0+ds6-3 Severity: normal I get a repeatable segfault from npm install by doing the following on i386 (deleting the local .npm and node_modules dirs is not needed to reproduce). -*- $ rm -rf .npm/ $ rm -rf node_modules/ $ npm --verbose install

Bug#922076: RFP: python-pydrive -- Python API for Google Drive

2019-02-11 Thread Giovanni Mascellani
Package: wnpp Severity: wishlist X-Debbugs-CC: debian-de...@lists.debian.org Package name: python-pydrive Version: 1.3.1 Upstream Author: Robin Nabel URL: https://pypi.org/project/PyDrive/ License: Apache-2.0 Description: Python API for Google Drive PyDrive is a

Bug#921578: libnfs: autopkgtest failures on Ubuntu

2019-02-11 Thread Sebastien Bacher
Thanks for the update/fix! I'm not on the system where I poked at that the other day now to verify but it looked like only the first test was an issue, "nfs-ls -D nfs://127.0.0.1" didn't return an error so maybe it was not needed to skip that one? Cheers,

Bug#921381: [firefox-esr] Fails to use the correct esr update channel + gmp-components

2019-02-11 Thread Charlemagne Lasse
> The attached patch can be used to switch firefox-esr to the correct > MOZ_UPDATE_CHANNEL "esr" instead of "default" (which provided the > incompatible Gecko Media Plugins widevine and openh264) The same problem was observed on Gentoo. The gentoo reporter basically ported the bugfix from this

Bug#922069: “Suggests: xul-ext-ublock-origin” should instead be “Suggests: webext-ublock-origin”

2019-02-11 Thread Ben Finney
Package: gnome Version: 1:3.22+12 Severity: minor The dependencies declared for ‘gnome’ include a deprecated package, ‘xul-ext-ublock-origin’. This should instead be “Suggests: webext-ublock-origin” which is the current package that provides that functionality. -- \“I washed a sock.

Bug#907907: golang-google-cloud: FTBFS randomly (failing tests)

2019-02-11 Thread Santiago Vila
Friendly ping. I have instances where the failure rate for this package is above 90% so calling this "random" is not really accurate. I've put a bunch of build logs for version 0.9.0-9 here: https://people.debian.org/~sanvila/build-logs/golang-google-cloud/ If you need help to reproduce this,

Bug#821397: sway 1.0-rc2

2019-02-11 Thread Birger Schacht
Hi, sway 1.0-rc2 was released today, i've updated the package and pushed to salsa. Changes: * New upstream version * d/rules: use sed to set upstream version in meson.build cheers, Birger signature.asc Description: OpenPGP digital signature

Bug#922062: ca-certificates package post-installation script subprocess returned error exit status 1

2019-02-11 Thread Michel Meyers
dpkg --debug=65535 shows this: - Setting up ca-certificates (20190110) ... D02: trigproc_activate_packageprocessing pkg=ca-certificates:all D02: fork/exec /var/lib/dpkg/info/ca-certificates.postinst ( configure 20170717 ) Updating certificates in /etc/ssl/certs... dpkg: error

Bug#922065: Bind9 does not start after upgrade because of AppArmor + workarround

2019-02-11 Thread Paul van der Vlis
Package: bind9 Version: 1:9.11.5.P1+dfsg-1 Severity: normal I upgraded from Debian9 tot Debian10 (testing). After this, bind did not start. Syslog says it's AppArmor (see syslog below). A work-arround is "aa-complain /usr/sbin/named". You need the package apparmor-utils for that. With regards,

Bug#921888: apparmor: allow access to ~/.local/share/mime/**

2019-02-11 Thread Vincas Dargis
Don't rush hot-fixing profile, I believe there's bug in AppArmor somewhere: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920833#32

Bug#922074: RM: diveintopython3 -- ROM; abandoned, obsolete, low popcon

2019-02-11 Thread Christian Kastner
Package: ftp.debian.org Severity: normal Please remove diveintopython3 from unstable. Upstream vanished in 2011, and some mirrors and forks have gone cold as well. I looked at updating the package to point to other mirrors, but because of the lack of updates since 2011, I would no longer

Bug#922079: salsa failed to fork project: The #1 argument ($project_id) to fork_project must be a scalar

2019-02-11 Thread Antoine Beaupre
Package: devscripts Version: 2.19.2 Severity: normal File: /usr/bin/salsa I can't use the `salsa fork` command for some reason: anarcat@curie:cron(master)$ git remote -v origin https://salsa.debian.org/webmaster-team/cron/ (fetch) origin https://salsa.debian.org/webmaster-team/cron/ (push)

Bug#922078: RM: commons-jcs -- ROM; Unused, low popcon

2019-02-11 Thread Bas Couwenberg
Package: ftp.debian.org Severity: normal Please remove the common-jcs package from unstable, it should not be included in buster. The package has never been updated, and never got used by another package. Kind Regards, Bas

Bug#922080: borgbackup: fuse mount exposes backup to unauthorized users

2019-02-11 Thread Salvatore Bonaccorso
Source: borgbackup Version: 1.1.8-1 Severity: grave Tags: security upstream Justification: user security hole Forwarded: https://github.com/borgbackup/borg/issues/3903 Control: fixed -1 1.1.9-1 As there is no CVE assigned for this issue, fill a bug for having an unique identifier withing Debian.

Bug#922066: CVE-2019-1000016

2019-02-11 Thread Moritz Muehlenhoff
Package: ffmpeg Version: 7:4.1-1 Severity: important Tags: security Please see https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-116 Cheers, Moritz

Bug#922062: ca-certificates package post-installation script subprocess returned error exit status 1

2019-02-11 Thread Michael Shuler
Control: tag -1 moreinfo On 2/11/19 9:58 AM, Michel Meyers wrote: > > Setting up ca-certificates (20190110) ... > Updating certificates in /etc/ssl/certs... > dpkg: error processing package ca-certificates (--configure): > installed ca-certificates package post-installation script

Bug#922033: [Pkg-xen-devel] Bug#922033: xen: driver domain does not work

2019-02-11 Thread Marek Marczykowski-Górecki
On Mon, Feb 11, 2019 at 04:27:45PM +0100, Hans van Kranenburg wrote: > A number of the things above are currently being done. Thanks for the info. > If you want to help testing, please subscribe to the team mailing list > for progress updates. I can help with testing guest side of the things

Bug#919982: apt-setup: preseeded installation hangs at "Use a network mirror?"

2019-02-11 Thread Wolfgang Schweer
Hi Steve, On Mon, Feb 11, 2019 at 05:32:33PM +, Steve McIntyre wrote: > Done. I've just pushed your simple debian-cd change and uploaded a new > apt-setup package to match. Great! Thank you very much. Wolfgang signature.asc Description: PGP signature

Bug#922071: mosquitto dumps core on startup on armv7l

2019-02-11 Thread Kushal Kumaran
Package: mosquitto Version: 1.4.10-3+deb9u3 Severity: grave Justification: renders package unusable Dear Maintainer, * What led up to the situation? On armv7l box, after updating from 1.4.10-3+deb9u2 to 1.4.10-3+deb9u3, mosquitto dumps core on startup. Used gdb to get a stack trace (after

Bug#384379: Hot Shopping asda 4526UP91

2019-02-11 Thread Tim Sparrow
Hi, Asda Store is Uk's retailer with over 50 physical shops. We are looking for new products to create new partnerships. Could you please send us your catalog through e-mail to learn more about your products and wholesale quote. We hope being able to order with you and start long-term

Bug#922070: gitlab: no diffs visible in merge requests and log

2019-02-11 Thread Maximilian Stein
Source: gitlab Version: 11.2.8+dfsg-2~bpo9+2 Severity: normal Tags: upstream Dear Maintainer, Since I upgraded my Gitlab installation to 11.2.8, I cannot see any diffs anymore (e.g., in merge requests and the log). Instead, it always says "This source diff could not be displayed because it is

Bug#909510: [PATCH] New tag: script-uses-unversioned-python-in-shebang

2019-02-11 Thread Dmitry Bogatov
[2019-02-10 12:46] Chris Lamb > > part text/plain 238 > Hi Dmitry, > > > +Severity: classification > > Replying quickly, excuse terseness; you appear to have removed the > tests? Yes. Sorry, but I do not understand, how to test tags with severity 'classification'. It

Bug#920833: apparmor: AppArmor denies access to mime-specifc files for various GUI applications

2019-02-11 Thread Vincas Dargis
Something strange is going on. Check this output: ``` $ /usr/sbin/apparmor_parser -Q -p /etc/apparmor.d/usr.bin.thunderbird | fgrep user_share @{user_share_dirs} = @{HOME}/.local/{,share/@{flatpak_exports_root}}/share owner @{user_share_dirs}/applications/{**,} r, owner

Bug#922072: linux-image-4.9.0-3-686-pae: A Hauppauge PVR-150 fails obtain any image when a camera is conneted to the composite video input.

2019-02-11 Thread peter
Package: src:linux Version: 4.9.30-2+deb9u5 Severity: normal Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? Video capture card not capturing video. * What exactly did you do (or not do) that was effective

Bug#922050: Debdiff for CVE-2019-5736

2019-02-11 Thread Noah Meyerhans
Control: tags -1 + patch Attached is a debdiff against version 1.0.0~rc6+dfsg1-1 in sid/buster. I'm happy to upload this if it'd be helpful. noah diff -Nru runc-1.0.0~rc6+dfsg1/debian/changelog runc-1.0.0~rc6+dfsg1/debian/changelog --- runc-1.0.0~rc6+dfsg1/debian/changelog 2019-01-24

Bug#922077: python-rjsmin: patch to enable build-time tests

2019-02-11 Thread Steve Langasek
Package: python-rjsmin Version: 1.0.12+dfsg1-4 Severity: normal Tags: patch User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu disco ubuntu-patch Dear maintainers, The python-rjsmin package currently has a commented-out override of dh_auto_test in debian/rules; without any override, the

Bug#920643: mariadb-server-10.3: mariadb won't start when running inside an lxc container when running on debian testing

2019-02-11 Thread Faustin Lammler
Hi Matthew, Thanks for your report! I have no platform setup to test this so I have to install one but I am not a LXC expert. Do you think this could be tested into a libvirt VM? If I understand correctly, you have a Debian testing host and you are running an LXC container with 10.3 mariadb

Bug#922064: [salt-master] Salt master doesn't start anymore after update

2019-02-11 Thread Dirk Heinrichs
Package: salt-master Version: 2018.3.4~git20180207+dfsg1-1 Severity: normal --- Please enter the report below this line. --- After updating to above version, salt-master doesn't start anymore, but prints out the following traceback instead: Feb 11 17:45:41 salt salt-master[17426]: Traceback

Bug#921753: librime-dev: wrong libdir in /usr/lib/x86_64-linux-gnu/pkgconfig/rime.pc

2019-02-11 Thread Shengjing Zhu
Control: reassign -1 librime-dev Control: affects -1 src:fcitx-rime src:ibus-rime Control: retitle: librime-dev: wrong libdir in /usr/lib/x86_64-linux-gnu/pkgconfig/rime.pc Control: found -1 1.4.0+dfsg1-1 Control: merge 921753 921755 /usr/lib/x86_64-linux-gnu/pkgconfig/rime.pc has:

Bug#919982: apt-setup: preseeded installation hangs at "Use a network mirror?"

2019-02-11 Thread Steve McIntyre
On Mon, Feb 11, 2019 at 03:34:24PM +0100, Wolfgang Schweer wrote: >On Mon, Feb 11, 2019 at 02:06:33PM +, Steve McIntyre wrote: >> >Yes. And I guess Debian Edu could get around the scan issuue using this >> >additional preseeding: >> > >> >apt-cdrom-setup apt-setup/cdrom/set-double boolean

Bug#922068: libglib-perl: FTBFS with glib 2.59 (in experimental/after buster)

2019-02-11 Thread gregor herrmann
Source: libglib-perl Version: 3:1.329-1 Severity: important Tags: upstream patch ftbfs experimental Forwarded: https://gitlab.gnome.org/GNOME/perl-glib/merge_requests/1 -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 As reported by @jbicha in

Bug#922062: ca-certificates package post-installation script subprocess returned error exit status 1

2019-02-11 Thread Michel Meyers
Mystery solved: Somebody (or something) placed a private key in a file called privkey.pem and stored it in /etc/ssl/certs. This caused openssl rehash to silently exit with error code 1, thus causing the whole postinst script to fail. After cleaning out the offending file, the package

Bug#913359: xkbcomp.pc requires libxkbfile-dev as dependency

2019-02-11 Thread Judit Foglszinger
tags 913359 -patch thanks > x11-xkb-utils should very much not depend on any -dev package. Ok. Then the patch tag doesn't apply anymore.

Bug#921938: lme4 breaks r-cran-lmertest autopkgtest

2019-02-11 Thread Andreas Tille
Hi Rune, thanks a lot for your quick upgrade. I just uploaded the new version to Debian. Kind regards Andreas. On Mon, Feb 11, 2019 at 05:21:54PM +0100, Rune Christensen wrote: > Dear all, > > This is currently being fixed and a new version of lmerTest is on its way to > CRAN, cf.

Bug#922033: [Pkg-xen-devel] Bug#922033: xen: driver domain does not work

2019-02-11 Thread Hans van Kranenburg
Hi, On 2/11/19 6:35 PM, Marek Marczykowski-Górecki wrote: > On Mon, Feb 11, 2019 at 04:27:45PM +0100, Hans van Kranenburg wrote: >> A number of the things above are currently being done. > > Thanks for the info. > >> If you want to help testing, please subscribe to the team mailing list >> for

Bug#921971: lintian-brush: fixer for out-of-date-standards-version

2019-02-11 Thread Jelmer Vernooij
Hi Dmitry, Thanks for the patch. On Sun, Feb 10, 2019 at 07:08:50PM +, Dmitry Bogatov wrote: > diff --git a/fixers/out-of-date-standards-version.sh > b/fixers/out-of-date-standards-version.sh > new file mode 100755 > index 000..d8cda66 > --- /dev/null > +++

Bug#921870: lintian-brush: generate QA upload string

2019-02-11 Thread Jelmer Vernooij
On Sat, Feb 09, 2019 at 04:36:56PM +, Dmitry Bogatov wrote: > > Package: lintian-brush > Version: 0.11 > Severity: wishlist > > Dear Maintainer, > > please consider making `lintian-brush' to add 'QA upload' entry into > changelog if package is QA maintained. Thanks for the bugreport. I

Bug#922062: ca-certificates package post-installation script subprocess returned error exit status 1

2019-02-11 Thread Michel Meyers
On 2019-02-11 20:43, Michael Shuler wrote: Thanks for the debugging info. I tried to reproduce a non-zero exit from both the old c_rehash and new openssl rehash calls, in order to see if we've found another behavior difference, but each call ended up with a clean 0 exit for me with a key file

Bug#802898: General OpenSCAD limitation

2019-02-11 Thread Kristian Nielsen
I believe this is caused by a general limitation of OpenSCAD. When multiple shapes are combined, the shapes must not share an edge or face exactly. There is some explanation of this in the OpenSCAD manual: https://en.wikibooks.org/wiki/OpenSCAD_User_Manual/STL_Import_and_Export#STL_Export One

Bug#922079: salsa failed to fork project: The #1 argument ($project_id) to fork_project must be a scalar

2019-02-11 Thread Xavier
Le 11/02/2019 à 21:00, Antoine Beaupre a écrit : > Package: devscripts > Version: 2.19.2 > Severity: normal > File: /usr/bin/salsa > > I can't use the `salsa fork` command for some reason: > > anarcat@curie:cron(master)$ git remote -v > originhttps://salsa.debian.org/webmaster-team/cron/

Bug#922079: salsa failed to fork project: The #1 argument ($project_id) to fork_project must be a scalar

2019-02-11 Thread Xavier
Le 11/02/2019 à 22:38, Antoine Beaupré a écrit : > On 2019-02-11 22:20:58, Xavier wrote: >> Le 11/02/2019 à 21:00, Antoine Beaupre a écrit : >>> Package: devscripts >>> Version: 2.19.2 >>> Severity: normal >>> File: /usr/bin/salsa >>> >>> I can't use the `salsa fork` command for some reason: >>>

Bug#921128: Info received (mailman3-web fails to initialize mysql: Specified key was too long)

2019-02-11 Thread Pierre-Elliott Bécue
Le lundi 11 février 2019 à 16:27:21-0500, Antoine Beaupré a écrit : > On 2019-02-11 21:52:32, Pierre-Elliott Bécue wrote: > > Le lundi 11 février 2019 à 09:14:55-0500, Antoine Beaupré a écrit : > >> Right, the only way this could be properly implemented would be if > >> debconf would attempt to

Bug#848660: ruby: might need to strip -fdebug-prefix-map

2019-02-11 Thread Chris Lamb
Hi Christian, > dpkg-buildflags has started injecting -fdebug-prefix-map with a > variable path into C(..)FLAGS. We need to figure out if we need to > strip that. Strip it? As in, the output of CFLAGS ends up in the build...? Regards, -- ,''`. : :' : Chris Lamb `. `'`

Bug#919356: Licensing of include/linux/hash.h

2019-02-11 Thread Jens Axboe
On 2/11/19 3:50 AM, Martin Steigerwald wrote: > Adding in ax...@kernel.dk, as I am not sure whether the oracle.com address > from Jens is actually valid / up to date. > > Domenico Andreoli - 11.02.19, 08:22: >> On Mon, Feb 11, 2019 at 12:08:32AM +0100, Kristian Fiskerstrand wrote: >> > > Mit 

Bug#922048: please allow socket-activation of dkimpy-milter via systemd

2019-02-11 Thread Daniel Kahn Gillmor
On Mon 2019-02-11 10:31:12 -0500, Scott Kitterman wrote: > The one trick I don't think that can be managed this way is that currently > dkimpy-milter reads the private key files as root and then drops privileges > so > that it doesn't have access to the key while running (it's only in memory).

Bug#922083: runescape: missing wget dependency (debian/control)

2019-02-11 Thread Linda Lapinlampi
Package: runescape Version: 0.4-1 Severity: important Dear Maintainer, src/runescape.sh calls into wget on line 27. This dependency is not listed in the debian/control file. wget is installed by default even from the most minimal Debian 9 netinst images, but it is not essential to the base

Bug#922065: Bind9 does not start after upgrade because of AppArmor + workarround

2019-02-11 Thread Paul van der Vlis
Op 11-02-19 om 23:49 schreef Bernhard Schmidt: > Am 11.02.19 um 23:32 schrieb Paul van der Vlis: > > Hi Paul, > > please keep the Bug CCed... Ah, sorry. I upgraded from Debian9 tot Debian10 (testing). After this, bind did not start. Syslog says it's AppArmor (see syslog below).

Bug#810964: [Pkg-xen-devel] Bug#810964: EDAC bug #810964 effects 4.8 too

2019-02-11 Thread Hans van Kranenburg
Hi, On 2/9/19 6:37 AM, Elliott Mitchell wrote: > I'm seeing bug #810964 occur in Xen 4.8 as well. Perhaps #810964 > should be reassigned to xen-hypervisor-common or src:xen ? > > I don't know whether it effects Xen 4.11 yet... Since the issue seems to be a lack of functionality to support

Bug#922095: light-locker: requires manually switching virtual terminals to unlock

2019-02-11 Thread Dan Robinson
Package: light-locker Version: 1.8.0-3 Severity: normal Dear Maintainer, Off a fresh install with no changes to the system, light-locker doesn't respond after locking the screen without manually switching VTs. Mouse or key input just leaves the screen blanked (and backlight off). Manually

Bug#921737: iproute2: `ip route get` problems with 0.0.0.0 and ::

2019-02-11 Thread Luca Boccassi
On Fri, 2019-02-08 at 11:55 -0500, Clément 'wxcafé' Hertling wrote: > Package: iproute2 > Version: 4.20.0-2 > Severity: normal > Tags: ipv6 upstream > > > When using `ip route get` with 0.0.0.0 or ::, iproute2 shows multiple > incorrect behaviors: > > - `ip route get 0.0.0.0/0` answers "need at

Bug#922079: salsa failed to fork project: The #1 argument ($project_id) to fork_project must be a scalar

2019-02-11 Thread Antoine Beaupré
On 2019-02-11 22:20:58, Xavier wrote: > Le 11/02/2019 à 21:00, Antoine Beaupre a écrit : >> Package: devscripts >> Version: 2.19.2 >> Severity: normal >> File: /usr/bin/salsa >> >> I can't use the `salsa fork` command for some reason: >> >> anarcat@curie:cron(master)$ git remote -v >> origin

Bug#922071: mosquitto dumps core on startup on armv7l

2019-02-11 Thread Kushal Kumaran
I attempted starting 1.4.10-3+deb9u3 with a new persistence_location directory, and it started up correctly. In the crashing directory, I have a couple of retained messages and the crash appears to be during loading of those.

Bug#921932: RM: calendar-exchange-provider/3.9.0-4

2019-02-11 Thread Adam D. Barratt
On Sun, 2019-02-10 at 19:49 +0100, Mechtilde Stehmann wrote: > the update has no longer been necessary. There is no such version in > sid or testing/buster. > > Now I know that there is no version working with thunderbird 60. > > Sorry for the confusion but the reason is the major update in

Bug#922090: Missing eol-server info in ubuntu.csv

2019-02-11 Thread Brian Murray
Package: distro-info-data Version: 0.39 Severity: minor Tags: patch User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu disco ubuntu-patch The ubuntu.csv file is missing eol-server dates for multiple releases of Ubuntu (likely because there is not a distinction between EoL dates for

Bug#922065: Bind9 does not start after upgrade because of AppArmor + workarround

2019-02-11 Thread Bernhard Schmidt
Am 12.02.19 um 00:05 schrieb Paul van der Vlis: /var/cache/bind/_default.nzd.lock rwk, >>> >>> With " rwk," at the end? >> >> Yes, that means "read write lock", which according to the log you showed >> was the denied operation. >> >>> When I do "aa-enforce /usr/sbin/named", then I cannot

Bug#919324: CVE-2018-20450 CVE-2018-20452

2019-02-11 Thread Evan Miller
An official release of libxls 1.5.0 is here: https://github.com/libxls/libxls/releases/tag/v1.5.0 It fixes all known vulnerabilities. Thanks for your patience everyone. Evan > On Feb 4, 2019, at 17:15, Dirk Eddelbuettel wrote: > > >

Bug#922072: linux-image-4.9.0-3-686-pae: A Hauppauge PVR-150 fails obtain any image when a camera is conneted to the composite video input.

2019-02-11 Thread Ben Hutchings
Control: tag -1 moreinfo The current kernel version in stable is 4.9.130-2, while you are running a much older version. Please install the available updates and re-test. Note that "apt-get upgrade" does *not* install all available updates; you must use the --with-new-pkgs option. Ben. -- Ben

Bug#922073: libssh autopkgtest is flaky due to test service startup race

2019-02-11 Thread Martin Pitt
Control: tag -1 pending Hello Steve, Steve Langasek [2019-02-11 10:58 -0800]: > The libssh 'libssh-server' autopkgtest is badly racy Whoops, sorry for the blunder. Thanks for the report! > A more correct fix would be to run the server in the foreground, let it > background itself once it's

Bug#893227: libbluray FTBFS with openjdk-9

2019-02-11 Thread Sebastian Ramacher
Hi Petri On 2019-01-22 10:02:40, Petri Hintukainen wrote: > Hello, > > On Wed, Jan 16, 2019 at 7:14 AM Reinhard Tartler wrote: > > Looking at the commit history, it seems that there have been some > > changes wrt java > > compatibility, mostly by you. I wonder whether you'd expect libbluray > >

Bug#922010: Some Debian Med packages need hinting into testing

2019-02-11 Thread Adrian Bunk
On Mon, Feb 11, 2019 at 09:12:21PM +0100, Ivo De Decker wrote: > Hi, Hi Ivo, > On Mon, Feb 11, 2019 at 10:19:08AM +0200, Adrian Bunk wrote: > > Package: release.debian.org > > Severity: normal > > > > The following source packages build binary-all packages that > > are not installable on i386

Bug#922081: pyparted: Please enable build-time tests in pyparted

2019-02-11 Thread Steve Langasek
Package: pyparted Version: 3.11.2-2 Severity: normal Tags: patch User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu disco ubuntu-patch Dear Herbert, In Ubuntu, we have applied the attached patch to pyparted in order to enable build-time tests of the package. It appears you have

Bug#922086: RFP: kanshi -- dynamic display configuration manager

2019-02-11 Thread Fabian Grünbichler
Package: wnpp Severity: wishlist * Package name: kanshi Version : 0.2.1 Upstream Author : emersion * URL : https://github.com/emersion/kanshi * License : MIT Programming Lang: Rust Description : Dynamic display configuration manager Kanshi uses a

Bug#922087: runescape: please remove the unnecessary p7zip-full dependency

2019-02-11 Thread Linda Lapinlampi
Package: runescape Version: 0.4-1 Severity: wishlist Dear Maintainer, currently, src/runescape.sh downloads a .dmg file and extracts it with 7z for the jagexappletviewer.jar file. The 7z executable comes from the p7zip-full package. It would be preferable if the .jar file would be downloaded

Bug#922088: RFP: file-rc -- Alternative SysV init mechanism using a single configuration file

2019-02-11 Thread Andrew Kanaber
Package: wnpp Severity: wishlist * Package name: file-rc Version : 0.8.18 Upstream Author : Winfried Trümper and others * URL : https://packages.debian.org/stretch/file-rc * License : GPL/BSD Programming Lang: sh Description : Alternative SysV init

Bug#921685: 1.8.0~rc2 breaks using Release.gpg instead of InRelease

2019-02-11 Thread Anthony DeRobertis
Sorry it took so long to confirm, but indeed adding -a to the gpg line fixes this problem. And continues to work at least all the way back to Sarge... So, I don't think there is anything to do but a ideally a clearer error message and also some documentation.

Bug#916639: LXC AppArmor confinement breaks systemd v240

2019-02-11 Thread Pierre-Elliott Bécue
Le dimanche 27 janvier 2019 à 19:47:59+0100, intrigeri a écrit : > Hi, > > Pierre-Elliott Bécue: > > We have to decide what solution I will implement. > > Right, thanks for following up. > > > I'm open to suggestions, although I'm considering the "disable > > apparmor profiles for lxc" solution

Bug#922091: RM: srtp -- ROM; obsolete

2019-02-11 Thread Jonas Smedegaard
Package: ftp.debian.org Severity: normal -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi ftpmasters, Source package srtp is obsolete: It is replaced by libsrtp2. Please remove srtp from unstable. - Jonas -BEGIN PGP SIGNATURE-

Bug#922093: node-commander: FTBFS in sid (AssertionError: expected '' to be 'SIGHUPn')

2019-02-11 Thread Santiago Vila
Package: src:node-commander Version: 2.12.2-2 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in sid but it failed: [...] debian/rules build-indep dh build-indep --with nodejs

Bug#922092: core-specs-alpha-clojure: FTBFS in sid (Could not resolve dependencies for project org.clojure:core.specs.alpha:jar:0.2.44)

2019-02-11 Thread Santiago Vila
Package: src:core-specs-alpha-clojure Version: 0.2.44-2 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in sid but it failed: [...] debian/rules build-indep dh build-indep

Bug#922094: spec-alpha-clojure: FTBFS in sid (Could not resolve dependencies for project org.clojure:spec.alpha:jar:0.2.176)

2019-02-11 Thread Santiago Vila
Package: src:spec-alpha-clojure Version: 0.2.176-2 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in sid but it failed: [...] debian/rules build-indep dh build-indep

Bug#913119: linux-image-4.18.0-2-amd64: Hangs on lvm raid1

2019-02-11 Thread Cesare Leonardi
On Tue, 5 Feb 2019 01:36:08 +0100 Dragan Milenkovic wrote: I have tracked the issue to this change: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/diff/block/blk-flush.c?id=344e9ffcbd1898e1dc04085564a6e05c30ea8199 Thank you very much for your deep analisys and thank you

Bug#922044: [emacsen-common] dist-upgrade removes emacs-nox due to emacsen-common version in backports

2019-02-11 Thread Sean Whitton
Hello Martijn, On Mon 11 Feb 2019 at 03:26PM +01, Martijn de Gouw wrote: > Package: emacsen-common > Version: 3.0.4~bpo9+1 > Severity: normal > > --- Please enter the report below this line. --- > Hi, > > After Debian 9.7 was released I started to dist-upgrade our machines, > but it started to

Bug#922010: RFS: libmurmurhash 1.3

2019-02-11 Thread Andreas Tille
Hi Fabian, I had a look on the build logs[1] and at least mips and s390x keep on failing (some archs are not yet build). Sorry for keeping you busy with this Andreas. [1] https://buildd.debian.org/status/package.php?p=libmurmurhash On Mon, Feb 11, 2019 at 05:28:32PM +0100, Andreas

Bug#922010: Some Debian Med packages need hinting into testing

2019-02-11 Thread Ivo De Decker
Control: reopen -1 Hi, On Mon, Feb 11, 2019 at 10:29:19PM +0200, Adrian Bunk wrote: > > On Mon, Feb 11, 2019 at 10:19:08AM +0200, Adrian Bunk wrote: > > > Package: release.debian.org > > > Severity: normal > > > > > > The following source packages build binary-all packages that > > > are not

Bug#921128: [Pkg-mailman-hackers] Bug#921128: Info received (mailman3-web fails to initialize mysql: Specified key was too long)

2019-02-11 Thread Jonas Meurer
Hi PEB, hi anarcat, Pierre-Elliott Bécue: > Le lundi 11 février 2019 à 16:27:21-0500, Antoine Beaupré a écrit : >> On 2019-02-11 21:52:32, Pierre-Elliott Bécue wrote: >>> Le lundi 11 février 2019 à 09:14:55-0500, Antoine Beaupré a écrit : Right, the only way this could be properly

Bug#922082: src:systemd: please package a minimal build of systemd-socket-activate separately

2019-02-11 Thread Daniel Kahn Gillmor
Package: src:systemd Version: 240-5 Severity: wishlist More daemons are beginning to offer systemd-style socket activation, which is a very nice feature for security and isolation. However, those daemons are difficult to run on non-systemd systems, so most upstream daemon authors continue to

Bug#922084: runescape: ratelimits download speed to 200 kB/s

2019-02-11 Thread Linda Lapinlampi
Package: runescape Version: 0.4-1 Severity: normal Dear Maintainer, src/runescape.sh sets `--limit-rate 200k` on line 27. I have a high-speed fiber connection and would like to use it to the full extent, as I have previously done with rsu-client (not available in Debian yet). This arbitrary

Bug#922085: curlftpfs: provide patch to fix file creation on pure-ftp

2019-02-11 Thread Stéphane Chauveau
Package: curlftpfs Version: 0.9.2-9+b1 Severity: important Dear Maintainer, My provider is using Pure-Ftp (I do not know which version) and on that server the chmod command does not work on non-existing files. Unfortunately, curlftpfs is using chmod to create new files which causes a

Bug#921128: Info received (mailman3-web fails to initialize mysql: Specified key was too long)

2019-02-11 Thread Pierre-Elliott Bécue
Le lundi 11 février 2019 à 09:14:55-0500, Antoine Beaupré a écrit : > On 2019-02-11 09:01:22, Pierre-Elliott Bécue wrote: > > Le 11 février 2019 00:10:55 GMT+01:00, "Antoine Beaupré" > > a écrit : > >>On 2019-02-10 01:11:35, Pierre-Elliott Bécue wrote: > >>> Le vendredi 01 février 2019 à

Bug#859122: about 500 DLAs missing from the website

2019-02-11 Thread Antoine Beaupré
On 2019-02-09 03:55:44, Laura Arjona Reina wrote: > Hello all > > Holger Levsen merged the generated DLAs and I've worked to create the > /lts tree to show them separated from the DSA. I have moved to this new > /lts folder the DLAs from years 2014, 2015 and 2016 that we had already, > and remove

Bug#913359: xkbcomp.pc requires libxkbfile-dev as dependency

2019-02-11 Thread Andreas Boll
tags 913359 +patch forwarded 913359 https://gitlab.freedesktop.org/xorg/app/xkbcomp/merge_requests/3 thanks Hi, On Tue, Feb 12, 2019 at 01:53:04AM +0600, Judit Foglszinger wrote: > tags 913359 -patch > thanks > > > x11-xkb-utils should very much not depend on any -dev package. > Ok. Then the

Bug#921128: Info received (mailman3-web fails to initialize mysql: Specified key was too long)

2019-02-11 Thread Antoine Beaupré
On 2019-02-11 21:52:32, Pierre-Elliott Bécue wrote: > Le lundi 11 février 2019 à 09:14:55-0500, Antoine Beaupré a écrit : >> On 2019-02-11 09:01:22, Pierre-Elliott Bécue wrote: >> > Le 11 février 2019 00:10:55 GMT+01:00, "Antoine Beaupré" >> > a écrit : >> >>On 2019-02-10 01:11:35,

Bug#859122: about 500 DLAs missing from the website

2019-02-11 Thread Antoine Beaupré
On 2019-02-09 14:39:50, Holger Levsen wrote: > Hi Laura, > > many many thanks for your work on this, including and especially this > writeup! > > some comments below, where I dont say anything I mean 'yay"! :) > > On Sat, Feb 09, 2019 at 03:55:44AM +0100, Laura Arjona Reina wrote: >> * The

Bug#921176: redis-server service is failing to start in buster lxc container

2019-02-11 Thread Chris Lamb
Hi, > On the other hand, the first thing I would do if this was working > would be to try removing more hardening features as previously > discussed on this bug number until it (likely) worked. Could you > try this please? > > Also, perhaps enable some deeper logging? Or check the actual >

Bug#922089: ITP: golang-github-mtrmac-gpgme -- Go wrapper for the GPGME library

2019-02-11 Thread Reinhard Tartler
Package: wnpp Severity: wishlist Owner: Reinhard Tartler * Package name: golang-github-mtrmac-gpgme Version : 0.0~git20170102.b243242-1 Upstream Author : Miloslav Trmač * URL : https://github.com/mtrmac/gpgme * License : BSD-3-clause Programming Lang: Go

Bug#922075: [Pkg-javascript-devel] Bug#922075: npm: segfault during extract on i386

2019-02-11 Thread Jérémy Lal
Le lun. 11 févr. 2019 à 20:39, Teemu Ikonen a écrit : > Package: npm > Version: 5.8.0+ds6-3 > Severity: normal > > I get a repeatable segfault from npm install by doing the following on > i386 (deleting the local .npm and node_modules dirs is not needed to > reproduce). > > -*- > > $ rm -rf

Bug#921654: Disable updates for workarround

2019-02-11 Thread Paul van der Vlis
Disable Widevine updates for the workarround. If you do not, Widevine will downgrade.

Bug#922065: Bind9 does not start after upgrade because of AppArmor + workarround

2019-02-11 Thread Bernhard Schmidt
Am 11.02.19 um 23:32 schrieb Paul van der Vlis: Hi Paul, please keep the Bug CCed... >>> I upgraded from Debian9 tot Debian10 (testing). After this, bind did not >>> start. Syslog says it's AppArmor (see syslog below). >>> >>> A work-arround is "aa-complain /usr/sbin/named". >>> You need the

  1   2   3   4   >